Hinzufügen einer Datenverbindung zu einer SharePoint-Dokumentbibliothek oder -Liste

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können eine oder mehrere sekundäre datenverbindungen zur Formularvorlage, die entweder Abfragen von Daten aus einer Dokumentbibliothek oder Liste können hinzufügen oder Senden von Daten in einer Dokumentbibliothek auf einer Microsoft Windows SharePoint Services-Server.

Inhalt dieses Artikels

Übersicht

Vorbemerkung

Hinzufügen einer Abfragedatenverbindung

Hinzufügen einer Verbindung zum Absenden von Daten

Übersicht

Bei einer sekundäre Datenverbindung handelt es sich um eine Datenverbindung von einer externen Datenquelle, die Sie einer Formularvorlage hinzufügen. Diese Datenverbindung unterscheidet sich von der Hauptdatenverbindung, die erstellt wird, wenn Sie eine Formularvorlage entwerfen, die auf einer Datenbank, einem Webdienst oder Einstellungen in einer Verbindungsbibliothek basiert. Eine sekundäre Datenverbindung wird nur hinzugefügt, wenn Sie Daten nicht über die Hauptdatenverbindung abfragen oder versenden können.

Wenn Sie eine sekundäre Datenquelle hinzufügen zur Formularvorlage, die Daten für Abfragen, Microsoft Office InfoPath erstellt eine sekundäre Datenquelle mit Datenfelder und Gruppen, die die Art und Weise entspricht, dass die Daten in der Dokumentbibliothek oder Liste gespeichert ist. Beziehung zwischen der externen Datenquelle und die Datenquelle in der Formularvorlage.

Da die Datenstruktur in der sekundären Datenquelle mit der Speicherung der Daten in der Dokumentbibliothek oder Liste übereinstimmen muss, können nicht Sie vorhandene Felder oder Gruppen in der sekundäre Datenquelle ändern.

Eine Datenverbindung, dass Abfragen von Daten aus einer SharePoint-Dokumentbibliothek oder automatisch Liste gibt alle Elemente aus dieser Liste oder Dokumentbibliothek. Wenn Sie eine Verbindung zum Abfragen von Daten verwenden zum Auffüllen von einer Liste Feld, klicken Sie im Dropdown-Listenfeld oder Kombinationsfeld-Steuerelement, und das Steuerelement zu viele Elemente enthält, oder es werden nur Elemente, die einem angegebenen Kriterium entsprechen, angezeigt werden soll, verwenden eines Filters im Steuerelement zum Einschränken der Anzahl der Elemente. Suchen nach Links zu weiteren Informationen zum Filtern von Daten in einem Steuerelement im Abschnitt Siehe auch angezeigt.

Sie können auch jede Abfragedatenverbindung konfigurieren, um deren Ergebnisse zu speichern, sodass Benutzer Zugriff auf die Daten haben, wenn ihr Formular mit keinem Netzwerk verbunden ist. Je nach der Natur der Daten möchten Sie die Daten möglicherweise nur dann abfragen, wenn die Benutzer eine Verbindung zu einem Netzwerk hergestellt haben.

Sicherheitshinweis : Wenn Sie eine sekundäre Datenverbindung verwenden, um vertrauliche Daten aus einer externen Datenquelle abzurufen, sollten Sie diese Funktion eventuell deaktivieren, um die Daten vor unberechtigter Verwendung zu schützen, falls der Computer verloren geht oder gestohlen wird. Wenn Sie diese Funktion deaktivieren, sind die Daten nur verfügbar, falls der Benutzer mit dem Netzwerk verbunden ist.

Wenn Sie einer Formularvorlage eine Abfragedatenverbindung hinzufügen, verwenden die Formulare, die auf dieser Formularvorlage basieren, standardmäßig die Datenverbindung, wenn sie von einem Benutzer geöffnet werden. Sie können die Formularvorlage auch so konfigurieren, dass die Abfragedatenverbindung auf eine der folgenden Weisen verwendet wird:

  • Hinzufügen einer Regel    Sie können eine Regel, um die Verbindung zum Abfragen von Daten verwenden, wenn die Bedingung in der Regel eintritt konfigurieren.

  • Hinzufügen einer Schaltfläche    Sie können die Formularvorlage eine Schaltfläche hinzufügen, die Benutzer klicken können, um Daten zu erhalten, indem Sie die Verbindung zum Abfragen von Daten.

  • Verwenden Sie benutzerdefiniertem code    Wenn Sie eine Regel oder eine Schaltfläche hinzufügen können, können Sie benutzerdefinierten Code zum Abrufen von Daten mithilfe der Verbindungs zum Abfragen von Daten verwenden. Mithilfe von benutzerdefiniertem Code erfordert einen Entwickler zum Erstellen von benutzerdefinierten Codes.

Wenn Sie Ihrer Formularvorlage eine Verbindung zum Absenden von Daten hinzufügen, können Sie die Formularvorlage konfigurieren, um Benutzern das Absenden ihrer Formulardaten zu erlauben. Ferner können Sie die Absendeoptionen für Formulare konfigurieren, die auf Ihrer Formularvorlage basieren.

Seitenanfang

Vorbemerkung

Bevor Sie Ihrer Formularvorlage eine sekundäre Datenverbindung hinzufügen, benötigen Sie von Ihrem Siteadministrator folgende Informationen:

  • Den Standort der SharePoint-Site und die erforderlichen Zugangsberechtigungen

  • Überprüfung, ob die Site konfiguriert ist, sodass Ihre Benutzer Daten aus der Dokumentbibliothek oder -liste abrufen können

  • Überprüfung, ob Sie die Daten aus der Dokumentbibliothek oder -liste zu Offlineverwendung auf dem Computer Ihres Benutzers speichern können

Seitenanfang

Hinzufügen einer Abfragedatenverbindung

Um Benutzern das Abfragen von Daten aus einer Dokumentbibliothek oder -liste zu erlauben, die sich auf einem Server befindet, der mit Microsoft SharePoint Services ausgeführt wird, müssen Sie in der Formularvorlage Folgendes ausführen:

  1. Fügen Sie eine sekundäre Datenverbindung hinzu.

  2. Konfigurieren Sie die Formularvorlage, um die sekundäre Datenverbindung zu verwenden.

Schritt 1: Hinzufügen einer sekundären Datenverbindung

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf SharePoint-Bibliothek oder -Liste und dann auf Weiter.

    Seite im Datenverbindungs-Assistenten auf eine SharePoint-Website als Datenquelle angeben.

  5. Klicken Sie auf der nächsten Seite des Assistenten geben Sie die URL der SharePoint-Website mit der Dokumentbibliothek oder Liste, und klicken Sie dann auf Weiter. Um eine Dokumentenliste auf einer SharePoint-Website mit der URL http://www.adventureworks.com/EmployeeListverwenden möchten, geben Sie beispielsweise http://www.adventureworks.com/EmployeeList.

  6. Klicken Sie auf der nächsten Seite des Assistenten in der Liste Liste oder Bibliothek auswählen auf die zu verwendende Liste oder Bibliothek, und klicken Sie dann auf Weiter.

  7. Aktivieren Sie auf der nächsten Seite des Assistenten die Kontrollkästchen neben den Werten, die Sie empfangen möchten. Wenn die Formularvorlage in der Dokumentbibliothek veröffentlicht wird und Sie auf dieser Formularvorlage basierende Formulare wünschen, um die Metadaten über das Formular zu erhalten, aktivieren Sie das Kontrollkästchen Nur Daten für das aktive Formular einschließen.

  8. Klicken Sie auf Weiter.

  9. Wenn Sie die Abfrageergebnisse zusammen mit der Formularvorlage auf dem Computer speichern möchten, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern. Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse auf dem Computer des Benutzers gespeichert, sodass die Benutzer Zugriff auf diese Daten haben, auch wenn keine Verbindung zwischen dem Computer und dem Netzwerk hergestellt ist.

    Sicherheitshinweis : Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert sind, sind sie in den Formularen verfügbar, die die Benutzer ausfüllen, selbst wenn deren Computer nicht mit einem Netzwerk verbunden sind. Wenn Sie aus dieser Datenverbindung vertrauliche Daten abrufen, sollten Sie dieses Feature deaktivieren, um dazu beizutragen, dass bei Computerverlust oder -diebstahl die Daten geschützt sind.

  10. Klicken Sie auf Weiter.

  11. Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für diese Datenquelle einen beschreibenden Namen für diese sekundäre Datenquelle aus. Dies ist der Name, der in der Liste Datenquelle im Aufgabenbereich Datenquelle angezeigt wird. Wenn Sie möchten diese Abfrage automatisch ausgeführt werden, wenn das Formular von einem Benutzer geöffnet wird, wählen Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen.

Schritt 2: Konfigurieren der Formularvorlage zur Verwendung der sekundären Datenverbindung

Wenn Formularen, die auf diese Datenverbindung verwenden gewünscht, nachdem der Benutzer das Formular öffnet die Formularvorlage basieren, können Sie eine Regel hinzufügen, in der Formularvorlage, die diese Datenverbindung unter einer bestimmten Bedingung verwendet, oder Sie können die Formularvorlage, die Benutzer klicken können, um diese Datenverbindung verwenden eine Schaltfläche hinzufügen.

Hinzufügen einer Regel

Sie können der Formularvorlage eine Regel hinzufügen, um Daten aus der Abfragedatenverbindung abzufragen, wenn die Bedingung für die Regel erfüllt ist. In der folgenden Prozedur wird vorausgesetzt, dass Sie eine Abfragedatenverbindung für Ihre Formularvorlage erstellt haben und dass Sie ein Steuerelement in Ihrer Formularvorlage konfiguriert haben, um die Daten aus dieser Datenverbindung anzuzeigen.

  1. Falls die Formularvorlage über mehrere Ansichten verfügt, klicken Sie auf Name der Ansicht im Menü Ansicht, um zu der Ansicht zu gelangen, wo die Daten aus der sekundären Datenquelle angezeigt werden sollen.

  2. Doppelklicken Sie auf das Steuerelement, das Sie mit den Abfrageergebnissen anzeigen möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Gültigkeitsprüfung und Regeln auf Regeln.

  5. Klicken Sie im Dialogfeld Regeln auf Hinzufügen.

  6. Geben Sie im Feld Name einen Namen für die Regel ein.

  7. Um eine Bedingung festzulegen, wann die Regel ausgeführt werden sollte, klicken Sie auf Bedingung festlegen, und geben Sie dann die Bedingung ein. Die Regel wird bei Eintreten der Bedingung ausgeführt. Wenn Sie keine Bedingung festlegen, wird die Regel immer dann ausgeführt, wenn der Benutzer den Wert im Steuerelement ändert und anschließend den Cursor vom Steuerelement weg bewegt.

  8. Klicken Sie auf Aktion hinzufügen.

  9. Klicken Sie in der Liste Aktion auf Mithilfe einer Datenverbindung abfragen.

  10. Klicken Sie in der Liste Datenverbindung auf die Abfragedatenverbindung, die Sie verwenden möchten, und klicken Sie dann zum Öffnen des Dialogfelds auf OK.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Hinzufügen einer Schaltfläche

Sie können Ihrer Formularvorlage ein Schaltflächensteuerelement hinzufügen, auf das Ihre Benutzer zur Verwendung dieser Abfragedatenverbindung klicken können. In der folgenden Prozedur wird vorausgesetzt, dass Sie eine Abfragedatenverbindung für Ihre Formularvorlage erstellt haben.

  1. Falls die Formularvorlage über mehrere Ansichten verfügt, klicken Sie auf Name der Ansicht im Menü Ansicht, um zu der Ansicht zu gelangen, wo die Daten aus der sekundären Datenquelle angezeigt werden sollen.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Ziehen Sie ein Schaltflächensteuerelement auf Ihre Formularvorlage.

  4. Doppelklicken Sie auf das Schaltflächensteuerelement, das Sie soeben Ihrer Formularvorlage hinzugefügt haben.

  5. Klicken Sie auf die Registerkarte Allgemein.

  6. Klicken Sie in der Liste Aktionen auf Aktualisieren.

  7. Geben Sie im Feld Beschriftung den Namen ein, der auf der Schaltfläche Ihrer Formularvorlage angezeigt werden soll.

  8. Klicken Sie auf Einstellungen.

  9. Klicken Sie im Dialogfeld Aktualisieren auf Eine sekundäre Datenquelle.

  10. Klicken Sie in der Liste Wählen Sie die sekundäre Datenquelle aus auf die sekundäre Datenquelle, die mit der Abfragedatenverbindung verknüpft ist, und klicken Sie dann zum Schließen jedes geöffneten Dialogfelds auf OK.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Seitenanfang

Hinzufügen einer Verbindung zum Absenden von Daten

Sie müssen folgendermaßen vorgehen, um Benutzern das Absenden von Formularen an eine Dokumentbibliothek zu ermöglichen, die auf Ihrer Formularvorlage basieren:

  1. Fügen Sie eine sekundäre Datenverbindung hinzu, die Daten an Ihre Formularvorlage absendet.

  2. Konfigurieren Sie die Formularvorlage, um Benutzern das Absenden ihrer Formulardaten an die Dokumentbibliothek zu ermöglichen.

Schritt 1: Hinzufügen einer sekundären Datenverbindung

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten senden, und klicken Sie dann auf Weiter.

  4. Klicken Sie unter Wie sollen die Daten versendet werden? auf An eine Dokumentbibliothek auf einer SharePoint-Website, und klicken Sie dann auf Weiter.

  5. Geben Sie im Datenverbindungs-Assistenten im Feld Dokumentbibliothek die URL der SharePoint-Dokumentbibliothek ein.

  6. Geben Sie im Feld Dateiname einen Namen ein, der zum Identifizieren des Dokuments in der Dokumentbibliothek verwendet wird.

    Tipp : Sie können auch eine Formel verwenden, um sicherzustellen, dass jeder Formularname eindeutig ist.

    Wie?

    1. Klicken Sie auf Formel einfügen  Formelschaltfläche .

    2. Führen Sie im Dialogfeld Formel einfügen eine der folgenden Aktionen aus:

      • Klicken Sie zum Verwenden eines Felds in der Formel auf Feld oder Gruppe einfügen, klicken Sie auf das Feld, das Sie im Dialogfeld Feld oder Gruppe auswählen verwenden möchten, und klicken Sie dann auf OK.

      • Klicken Sie zum Verwenden einer Funktion in der Formel auf Funktion einfügen. Aktivieren Sie die Funktion, die Sie im Dialogfeld Funktion einfügen verwenden möchten, und klicken Sie dann auf OK.

        Tipp : Wenn die Funktion Parameter erfordert, wählen Sie die Funktion im Dialogfeld Funktion einfügen, klicken Sie auf OK klicken Sie dann im Feld Formel im Dialogfeld Formel einfügen, doppelklicken Sie auf die Funktion, die Sie hinzugefügt, und klicken Sie auf Feld oder Gruppe. Finden Sie Links zu weiteren Informationen zu Funktionen im Abschnitt Siehe auch.

      • Zum Einfügen eines Werts oder mathematischen Operators in die Formel geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein.

    Berechnung

    Symbol

    Addieren

    +

    Subtrahieren

    -

    Multiplizieren

    *

    Dividieren

    /

    • Hinweis : Wenn die Formel den (/) als Divisionsoperator verwendet wird, stellen Sie sicher, dass es ein Leerzeichen vor und nach dem Operator einer Division zurück ist. Wenn der Divisionsoperator hat kein Leerzeichen vor und nach, InfoPath interpretieren möglicherweise "/" als Trennzeichen für XPath-Speicherort Schritte statt als Operator einer Division zurück.

    • Um zu überprüfen, ob die Formel die richtige Syntax aufweist, klicken Sie im Dialogfeld Formel einfügen auf Formel überprüfen.

      Verknüpfungen zu weiteren Informationen über Formeln finden Sie im Abschnitt Siehe auch.

  7. Aktivieren Sie das Kontrollkästchen Vorhandene Dateien überschreiben, um das Überschreiben vorhandener Formulare in der Dokumentbibliothek mit demselben Namen zu ermöglichen.

  8. Klicken Sie auf Weiter.

  9. Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung an einen aussagekräftigen Namen für diese Datenverbindung (Absenden) ein.

Nach Hinzufügen der sekundären Datenverbindung müssen Sie Ihr Formular konfigurieren, um Benutzern das Absenden ihrer Daten mithilfe dieser Absendedatenverbindung zu ermöglichen.

Schritt 2: Aktivieren des Absendens in der Formularvorlage

Wenn Sie die Formularvorlage konfigurieren, um Benutzern das Absenden ihrer Formulardaten zu ermöglichen, fügt InfoPath die Schaltfläche Absenden auf der Symbolleiste Standard und den Befehl Absenden im Menü Datei auf dem Formular hinzu. Sie können die Absendeoptionen für Ihre Formularvorlagen folgendermaßen anpassen:

  • Ändern Sie den Text, der auf der Schaltfläche Absenden angezeigt wird.

  • Ändern Sie die Tastenkombination für die Schaltfläche Absenden.

  • Erstellen Sie benutzerdefinierte Meldungen, die Ihren Benutzern angezeigt werden, wenn diese ihre Formulare absenden.

  • Geben Sie an, ob das Formular geschlossen oder geöffnet werden soll, oder ob ein neues leeres Formular geöffnet werden soll, nachdem das Formular abgesendet wurde.

  • Klicken Sie im Menü Extras auf Absendeoptionen.

  • Klicken Sie im Dialogfeld Optionen zum Absenden aktivieren Sie das Kontrollkästchen Benutzern erlauben, dieses Formular zu senden, klicken Sie auf Senden von Formulardaten an ein einziges Ziel, und klicken Sie dann in der Liste auf SharePoint-Dokumentbibliothek.

  • Klicken Sie in der Liste Datenverbindung für das Senden auswählen auf den Namen der Absendedatenverbindung zur SharePoint-Bibliothek.

    1. Zum Ändern des Namens der Schaltfläche Absenden, die auf der Standard-Symbolleiste angezeigt wird, und des Befehls Absenden, der im Menü Datei angezeigt wird, wenn der Benutzer das Formular ausfüllt, geben Sie den neuen Namen in das Feld Beschriftung im Dialogfeld Absendeoptionen ein.

      Tipp : Wenn Sie dieser Schaltfläche und diesem Befehl eine Tastenkombination zuweisen möchten, geben Sie vor dem Zeichen, das als Tastenkombination dienen soll, das kaufmännische Und-Zeichen (&) ein. Wenn beispielsweise ALT+B als Tastenkombination für die Schaltfläche Absenden und den Befehl dienen soll, geben Sie A&bsenden ein.

  • Wenn beim Ausfüllen des Formulars der Befehl Absenden oder die Schaltfläche Absenden in der Symbolleiste Standard nicht verwendet werden soll, deaktivieren Sie das Kontrollkästchen Menüelement "Absenden" und in der Symbolleiste Schaltfläche "Absenden" anzeigen.

    1. In der Standardeinstellung bleibt das Formular in InfoPath weiterhin geöffnet, nachdem das Formular abgesendet wurde, und es wird eine Meldung angezeigt, dass der Sendevorgang erfolgreich abgeschlossen wurde. Um dieses Standardverhalten zu ändern, klicken Sie auf Erweitert, und führen Sie eine der folgenden Aktionen aus:

      • Um das Formular zu schließen oder ein neues, leeres Formular zu erstellen, nachdem ein ausgefülltes Formular gesendet wurde, klicken Sie in der Liste Nach dem Absenden auf die gewünschte Option.

      • Um eine benutzerdefinierte Meldung zu erstellen, die angibt, ob das Formular erfolgreich übertragen wurde, aktivieren Sie das Kontrollkästchen Benutzerdefinierte Meldung verwenden, und geben Sie anschließend die Meldungen in die Felder Absenden erfolgreich und Absenden fehlgeschlagen ein.

        Tipp : Geben Sie im Feld Absenden fehlgeschlagen eine Meldung mit Lösungsmöglichkeiten ein, wenn beim Absenden eines Formulars Probleme auftreten. Sie können beispielsweise empfehlen, das Formular zu speichern und sich an jemanden zu wenden, der weiterhelfen kann.

      • Wenn nach dem Absenden eines Formulars keine Meldung angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Meldung nach dem Absenden anzeigen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×