Hinzufügen einer Datenverbindung zu einer Microsoft Access-Datenbank

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Wenn für Ihre Benutzer Daten aus einer Microsoft Office Access 2007-Datenbank (ACCDB-Format) oder aus einer in einer früheren Version gespeicherten Access-Datenbank (MDB-Format) erforderlich sind, um ein Formular auf Grundlage Ihrer Microsoft Office InfoPath-Formularvorlage auszufüllen, können Sie eine sekundäre Datenverbindung zur Formularvorlage hinzufügen, die eine Access Datenbank abfragt.

Sie können eine sekundäre Datenverbindung hinzufügen, aber diese Datenverbindung kann nur eine Access-Datenbank abfragen. Sie können keine sekundäre Datenverbindung hinzufügen, die Daten an eine Access-Datenbank sendet.

Wenn Ihre Benutzer ihre Formulardaten an eine Access-Datenbank senden sollen, können Sie eine Formularvorlage entwerfen, die auf einer Access-Datenbank basiert und dann die Verbindung zum Senden von Daten in der primären Datenverbindung aktivieren. Alternativ können Sie eine sekundäre Datenverbindung zu einem Webdienst hinzufügen, der mit Ihrer Access-Datenbank zusammenarbeitet.

Im Abschnitt Siehe auch finden Sie Verknüpfungen zu weiteren Informationen zum Entwerfen von auf Access-Datenbanken basierenden Formularvorlagen und zum Hinzufügen einer sekundären Datenverbindung zu einem Webdienst.

Inhalt dieses Artikels

(Übersicht)

Kompatibilität Aspekte

Vorbemerkung

Schritt 1: Hinzufügen einer sekundäre Datenquelle

Schritt 2: Konfigurieren der Formularvorlage, um die Datenverbindung verwenden

Übersicht

Eine sekundäre Datenverbindung ist eine Datenverbindung, die Sie einer Formularvorlage hinzufügen. Eine sekundäre Datenverbindung unterscheidet sich von der primären Datenverbindung, die Sie beim Entwerfen einer neuen Formularvorlage erstellen, die auf einer Datenbank oder einem Webdienst basiert. Die primäre Datenverbindung einer Formularvorlage kann Daten von externen Datenquellen abrufen und auch Formulardaten an eine externe Datenquelle senden. Eine Formularvorlage kann jedoch nur eine primäre Datenverbindung besitzen.

Sie können beliebig viele sekundäre Datenverbindungen zu einer Formularvorlage hinzufügen. Nehmen Sie beispielsweise an, Sie besitzen eine Access-Datenbank, die eine Tabelle mit Mitarbeiterdaten und eine andere Tabelle mit Kundendaten enthält. Sie können eine sekundäre Datenverbindung hinzufügen, die Daten aus der Mitarbeitertabelle abruft, und Sie können überdies eine weitere sekundäre Datenverbindung hinzufügen, die in derselben Access-Datenbank Daten aus der Kundentabelle abruft.

Obwohl Sie zur Formularvorlage eine sekundäre Datenverbindung hinzufügen können, die Formulardaten an eine externe Datenquelle senden kann, z. B. an einen Webdienst oder eine Windows SharePoint Services-Bibliothek, können Sie sekundäre Datenverbindungen nur zum Abrufen von Daten aus einer Access-Datenbank verwenden. Sie können keine sekundäre Datenverbindung hinzufügen, die Daten an eine Access-Datenbank sendet.

Wenn Sie eine Verbindung zum Abfragen von Daten in einer Datenbank hinzufügen, erstellt InfoPath eine sekundäre Datenquelle, die enthält Datenfelder und Gruppen, die Art und Weise entsprechen, dass die Daten in der Datenbank gespeichert sind. Da die Datenstruktur in der sekundäre Datenquelle mit der Speicherung der Daten in den Tabellen übereinstimmen muss, können nicht Sie die Felder oder Gruppen in der sekundäre Datenquelle ändern.

Sie können die einzelnen Abfragedatenverbindungen konfigurieren, damit ihre Ergebnisse derart gespeichert werden, dass die Benutzer auf die Daten zugreifen können, wenn ihr Formular nicht mit einem Netzwerk verbunden ist. In Abhängigkeit von der Art der Daten möchten Sie die Abfrageergebnisse möglicherweise nur anzeigen, wenn die Benutzer mit einem Netzwerk verbunden sind.

Sicherheitshinweis : Wenn Sie eine sekundäre Datenverbindung verwenden, um vertrauliche Daten aus einer externen Datenquelle abzurufen, sollten Sie diese Funktion eventuell deaktivieren, um die Daten vor unberechtigter Verwendung zu schützen, falls der Computer verloren geht oder gestohlen wird. Wenn Sie diese Funktion deaktivieren, sind die Daten nur verfügbar, falls der Benutzer mit dem Netzwerk verbunden ist.

Wenn Sie einer Formularvorlage eine Abfragedatenverbindung hinzufügen, verwenden die Formulare, die auf dieser Formularvorlage basieren, standardmäßig die Datenverbindung, wenn sie von einem Benutzer geöffnet werden. Sie können die Formularvorlage auch so konfigurieren, dass die Abfragedatenverbindung auf eine der folgenden Weisen verwendet wird:

  • Hinzufügen einer Regel    Sie können eine Regel, um die Verbindung zum Abfragen von Daten verwenden, wenn die Bedingung in der Regel eintritt konfigurieren.

  • Hinzufügen einer Schaltfläche    Sie können die Formularvorlage eine Schaltfläche hinzufügen, die Benutzer klicken können, um Daten zu erhalten, indem Sie die Verbindung zum Abfragen von Daten.

  • Verwenden Sie benutzerdefiniertem code    Wenn Sie eine Regel oder eine Schaltfläche hinzufügen können, können Sie benutzerdefinierten Code zum Abrufen von Daten mithilfe der Verbindungs zum Abfragen von Daten verwenden. Mithilfe von benutzerdefiniertem Code erfordert einen Entwickler zum Erstellen von benutzerdefinierten Codes.

Seitenanfang

Überlegungen zur Kompatibilität

Sie können keine Datenverbindung zu einer Access-Datenbank zu einer Browserkompatible Formularvorlage.

Seitenanfang

Vorbemerkung

Bevor Sie eine sekundäre Datenverbindung zu einer Access-Datenbank zur Formularvorlage hinzufügen, sind folgende Informationen erforderlich:

  • Der Name und der Speicherort der Datenbank.

    Hinweis : Wenn die Access-Datenbank an einem Speicherort im Netzwerk gespeichert wird, stellen Sie sicher, dass die Benutzer auf die Datenbank zugreifen können.

  • Der Name der Tabelle oder Abfrage, die auf dieser Formularvorlage basierenden Formularen die Daten bereitstellt. Sie verwenden diese Tabelle oder Abfrage als Mastertabelle oder -abfrage, wenn Sie die Abfragedatenverbindung konfigurieren.

  • Die Namen der anderen Tabellen oder Abfragen, die weitere Daten zur die primäre Tabelle oder Abfrage angeben. In den meisten Fällen sind die tabellenbeziehungen in der Datenbank bereits eingerichtet. Wenn Sie die Beziehungen zwischen der primären Tabelle oder Abfrage und einer anderen Tabelle oder Abfrage manuell herstellen müssen, benötigen Sie die zugehörigen Feldnamen der beiden Tabellen oder Abfragen.

Seitenanfang

Schritt 1: Hinzufügen einer sekundären Datenverbindung

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank (Microsoft SQL Server oder Microsoft Office Access), und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank auswählen.

  6. Wechseln Sie im Dialogfeld Datenquelle auswählen zum Speicherort Ihrer Datenbank.

    Hinweis : Wenn die Datenbank in einem Speicherort im Netzwerk gespeichert ist, navigieren Sie zu der universal naming Convention (UNC)) Pfad des Speicherorts. Nicht zum Netzwerkspeicherort über eine zugeordnete Netzlaufwerk navigieren. Wenn Sie ein zugeordneten Netzlaufwerk verwenden, werden Benutzer, die Erstellen von Formularen, die auf dieser Formularvorlage basieren für die Datenbank aus einem zugeordneten Netzlaufwerk suchen. Wenn der Benutzer nicht mit ein zugeordneten Netzlaufwerk verfügt, wird das Formular die Datenbank nicht finden.

  7. Klicken Sie auf den Namen der Datenbank und dann auf Öffnen.

  8. Klicken Sie im Dialogfeld Tabelle auswählen auf die zu verwendende Mastertabelle oder -abfrage, und klicken Sie dann auf OK.

  9. Aktivieren Sie auf der nächsten Seite des Assistenten das Kontrollkästchen Tabellenspalten anzeigen.

    Standardmäßig werden alle Felder in der Tabelle oder Abfrage zur primären Datenquelle der Formularvorlage hinzugefügt.

  10. Deaktivieren Sie die Kontrollkästchen für die Felder, die nicht in die sekundäre Datenquelle einbezogen werden sollen.

    Fügen Sie bei Bedarf zusätzliche Tabellen oder Abfragen zur Datenverbindung hinzu.

    So wird's gemacht

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen auf den Namen der untergeordneten Tabelle, und klicken Sie anschließend auf Weiter. InfoPath versucht, die Beziehungen einzurichten, indem es die Feldnamen der beiden Tabellen miteinander abgleicht. Wenn Sie eine vorgeschlagene Beziehung nicht verwenden möchten, wählen Sie die betreffende Beziehung und klicken anschließend auf Beziehung entfernen. Um eine Beziehung hinzuzufügen, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen in der jeweiligen Spalte auf die Namen aller verbundenen Felder und anschließend auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Wiederholen Sie diese Schritte, um zusätzliche untergeordnete Tabellen hinzuzufügen.

  11. Klicken Sie auf Weiter.

  12. Damit die Ergebnisse der Abfragedatenverbindung verfügbar sind, wenn das Formular nicht mit einem Netzwerk verbunden ist, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern.

    Sicherheitshinweis : Durch Aktivieren dieses Kontrollkästchens werden die Daten auf dem Computer des Benutzers gespeichert, wenn das Formular diese Datenverbindung verwendet. Wenn das Formular aus dieser Datenverbindung vertrauliche Daten abruft, sollten Sie dieses Feature möglicherweise deaktivieren, um dazu beizutragen, dass die Daten bei Computerverlust oder -diebstahl geschützt sind.

  13. Klicken Sie auf Weiter.

  14. Geben Sie auf der nächsten Seite des Assistenten einen anschaulichen Namen für diese sekundäre Datenverbindung ein, und überprüfen Sie dann, dass die Daten im Abschnitt Zusammenfassung richtig sind.

  15. Aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen, um das Formular so zu konfigurieren, dass die Daten beim Öffnen automatisch abgerufen werden.

Seitenanfang

Schritt 2: Konfigurieren der Formularvorlage für die Verwendung der Datenverbindung

Wenn die auf dieser Formularvorlage aufbauenden Formulare die Datenverbindung verwenden sollen, nachdem der Benutzer das Formular geöffnet hat, können Sie der Formularvorlage eine Regel hinzufügen, so dass die Datenverbindung unter einer bestimmten Bedingung verwendet wird, oder Sie können der Formularvorlage eine Schaltfläche hinzufügen, die zum Aufbau der Datenverbindung vom Benutzer angeklickt wird.

Hinzufügen einer Regel

Sie können der Formularvorlage eine Regel hinzufügen, die dazu dient, die Daten von der Abfragedatenverbindung abzurufen, sobald die Bedingung der Regel erfüllt ist. Sie können z. B. ein Textfeld zur Formularvorlage hinzufügen, das ein Benutzer ausfüllen kann, um bestimmte Daten von einer externen Datenquelle abzurufen. Sie können dann eine Regel hinzufügen, die die Datenverbindung immer dann verwendet, wenn ein Benutzer Daten in das Textfeld eingibt.

Das folgende Verfahren geht davon aus, dass Sie eine Abfragedatenverbindung für Ihre Formularvorlage erstellt und ein Steuerelement (keine Schaltfläche) auf der Formularvorlage konfiguriert haben, um die Daten der Datenverbindung anzuzeigen.

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Doppelklicken Sie auf das Steuerelement, dem Sie eine Regel hinzufügen möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Gültigkeitsprüfung und Regeln auf Regeln.

  5. Klicken Sie im Dialogfeld Regeln auf Hinzufügen.

  6. Geben Sie im Feld Name einen Namen für die Regel ein.

  7. Um eine Bedingung festzulegen, wann die Regel ausgeführt werden sollte, klicken Sie auf Bedingung festlegen, und geben Sie dann die Bedingung ein. Die Regel wird bei Eintreten der Bedingung ausgeführt. Wenn Sie keine Bedingung festlegen, wird die Regel immer dann ausgeführt, wenn der Benutzer den Wert im Steuerelement ändert und anschließend den Cursor vom Steuerelement weg bewegt.

  8. Klicken Sie auf Aktion hinzufügen.

  9. Klicken Sie in der Liste Aktion auf Mithilfe einer Datenverbindung abfragen.

  10. Klicken Sie in der Liste Datenverbindung auf die Abfragedatenverbindung, die Sie verwenden möchten, und klicken Sie dann zum Öffnen des Dialogfelds auf OK.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Hinzufügen einer Schaltfläche

Sie können Ihrer Formularvorlage ein Schaltflächensteuerelement hinzufügen, auf das Ihre Benutzer zum Abrufen von Daten aus der Abfragedatenverbindung klicken können.

  1. Wenn die Formularvorlage mehrere Ansichten aufweist, klicken Sie auf Ansichtsname im Menü Ansicht zum Wechseln Sie zur Ansicht mit dem Steuerelement, wo Sie die Daten aus der sekundäre Datenquelle anzeigen möchten.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Ziehen Sie ein Schaltflächen-Steuerelement auf die Formularvorlage.

  4. Doppelklicken Sie auf das soeben zur Formularvorlage hinzugefügte Schaltflächen-Steuerelement .

  5. Klicken Sie auf die Registerkarte Allgemein.

  6. Klicken Sie in der Liste Aktionen auf Aktualisieren.

  7. Geben Sie im Feld Beschriftung den Namen ein, der auf der Schaltfläche Ihrer Formularvorlage angezeigt werden soll.

  8. Klicken Sie auf Einstellungen.

  9. Führen Sie im Dialogfeld Aktualisieren eine der folgenden Aktionen aus:

    • Klicken Sie auf Alle sekundären Datenquellen, um die aktuellsten Daten von allen externen Datenquellen abzurufen, die über sekundäre Datenverbindungen zu dieser Formularvorlage verfügen.

    • Um die Schaltfläche so zu konfigurieren, dass die aktuellsten Daten von einer externen Datenquelle über eine sekundäre Datenverbindung zu Ihrer Formularvorlage abgerufen werden, klicken Sie auf Eine sekundäre Datenverbindung, und klicken Sie dann in der Liste Wählen Sie die sekundäre Datenquelle aus auf eine sekundäre Datenverbindung.

  10. Klicken Sie auf OK, um die einzelnen geöffneten Dialogfelder zu schließen.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×