Hinzufügen einer Datenverbindung zu einem Webdienst

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können Ihrer Formularvorlage, die Daten von einem Webdienst abfragen oder an diesen senden kann, eine oder mehrere sekundäre Datenverbindungen hinzufügen.

Inhalt dieses Artikels

Übersicht

Überlegungen zur Kompatibilität

Vorbemerkung

Hinzufügen einer Abfragedatenverbindung

Hinzufügen einer Verbindung zum Absenden von Daten

Übersicht

Bei einer sekundäre Datenverbindung handelt es sich um eine Datenverbindung von einer externen Datenquelle, die Sie einer Formularvorlage hinzufügen. Diese Datenverbindung unterscheidet sich von der Hauptdatenverbindung, die erstellt wird, wenn Sie eine Formularvorlage entwerfen, die auf einer Datenbank, einem Webdienst oder Einstellungen in einer Verbindungsbibliothek basiert. Eine sekundäre Datenverbindung wird nur hinzugefügt, wenn Sie Daten nicht über die Hauptdatenverbindung abfragen oder versenden können.

Wenn Sie eine sekundäre Datenquelle zur Formularvorlage, die Daten für Abfragen, Microsoft Office InfoPath erstellt eine sekundäre Datenquelle mit Datenfelder und Gruppen, die die XML-Schema des Webdiensts entspricht, hinzufügen. Da die Datenstruktur in der sekundären Datenquelle das XML-Schema übereinstimmen muss, können nicht Sie vorhandene Felder oder Gruppen in der sekundäre Datenquelle ändern. Wenn Sie eine Verbindung zum Absenden von Daten zur Formularvorlage hinzufügen, Sie Konfigurieren der Formularvorlage, um Benutzern das Absenden ihrer Formulardaten ermöglichen, und konfigurieren Sie die Absendeoptionen für den Formularen, die auf Ihrer Formularvorlage basieren.

Seitenanfang

Überlegungen zur Kompatibilität

Sie können die Verbindung zum Absenden von Daten in einer Browserkompatible Formularvorlage nicht so konfigurieren, dass die Benutzer Änderungsinformationen zusammen mit den Formulardaten an einen Webdienst absenden können, der ein Microsoft ADO.NET DataSet akzeptiert. Änderungsinformationen bestehen aus den Änderungen, die ein Benutzer an den in einer Datenbank gespeicherten Daten vornimmt. Die Verbindung der Benutzer mit der Datenbank wird mithilfe eines Webdiensts hergestellt. ADO.NET kann anhand der Änderungsinformationen bestimmen, wie die Daten in der Datenbank aktualisiert werden sollen. Wenden Sie sich an den Webdienstadministrator, wenn für den Webdienst Änderungsinformationen zum Aktualisieren einer Datenbank erforderlich sind. Sind diese Informationen erforderlich, sollten Sie eine Formularvorlage entwerfen, deren Formulare nur mit InfoPath ausgefüllt werden können.

Seitenanfang

Vorbemerkung

Bevor Sie Ihrer Formularvorlage eine sekundäre Datenverbindung hinzufügen, benötigen Sie vom Webdienst folgende Informationen:

  • Der Speicherort des Webdienstes.

  • Überprüfung, ob der Webdienst die Codierung "document/literal" verwendet. InfoPath kann nur Webdienste vom Typ "document/literal" konsumieren.

  • Der Name des Webdienstvorgangs, der Daten sendet oder von Formularen enthält, die auf dieser Formularvorlage basieren.

Seitenanfang

Hinzufügen einer Abfragedatenverbindung

Um Benutzern das Abfragen von Daten aus einem Webdienst mithilfe Ihrer Formularvorlage zu ermöglichen, müssen Sie in der Formularvorlage folgende Aktion ausführen:

  1. Fügen Sie eine sekundäre Datenverbindung hinzu.

  2. Konfigurieren Sie die Formularvorlage, um die sekundäre Datenverbindung zu verwenden.

Schritt 1: Hinzufügen einer sekundären Datenverbindung

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie unter Woher möchten Sie Ihre Daten erhalten auf Webdienst, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten an, wo sich der Webdienst befindet, und klicken Sie dann auf Weiter.

    Hinweis : Wenn Sie einem Webdienst mithilfe eines Servers Universal Description Discovery and Integration (UDDI) suchen möchten, klicken Sie auf UDDI durchsuchen, geben Sie die URL des UDDI-Servers ein, die Sie suchen, angeben, ob Sie nach Anbieter oder nach einem Dienst, der bereitgestellt wird, suchen möchten, geben Sie ein Suchschlüsselwort ein, und klicken Sie dann auf Suchen möchten. Webdienste, die das Stichwort entsprechen, werden in der Liste Suchergebnis angezeigt. Wählen Sie den Webdienst, den Sie verwenden möchten, und klicken Sie dann auf OK.

  6. Klicken Sie auf der nächsten Seite des Assistenten in der Liste Wählen Sie einen Vorgang auf den Webdienstvorgang, der die Daten an das Formular zurückgibt, und klicken Sie dann auf Weiter.

  7. Falls der Datenverbindungs-Assistent ein unbekanntes Element im Schema des Webdienstes erkennt, werden Sie auf der nächsten Seite des Assistenten dazu aufgefordert, Beispielwerte für jeden Parameter anzugeben, um zu bestimmen, welche Felder oder Gruppen der primären Datenquelle hinzugefügt werden.

    Wie?

    1. Wählen Sie in der Tabelle Parameter einen Parameter aus, und klicken Sie auf Beispielwert festlegen.

    2. Geben Sie in das Feld Sample value einen Wert ein, den Ihr Benutzer für dieses Feld möglicherweise verwenden kann, und klicken Sie dann auf OK.

    3. Wiederholen Sie diese Schritte für jeden Parameter in der Tabelle Parameter, und klicken Sie dann auf Weiter.

    Technische Einzelheiten

    Wenn Sie im Datenverbindungs-Assistenten eine Datenverbindung zu einem Web-Dienst konfigurieren, stellt Microsoft Office InfoPath eine Verbindung zu diesem Web-Dienst her und fordert die WSDL-Datei (Web Service Description Language) an. Die WSDL-Datei enthält das vom Web-Dienst verwendete Schema. Der Web-Dienst reagiert auf die Anforderung, indem er die betreffende Datei an InfoPath sendet. InfoPath verwendet die Informationen in dieser Datei, um der sekundären Datenquelle in der Formularvorlage die entsprechenden Felder und Gruppen hinzuzufügen. Falls InfoPath einen unbekannten Elementtyp in der WSDL-Datei findet, verwendet InfoPath Beispieldaten, um die Definition des unbekannten Elementtyps zu ermitteln, und fügt der sekundären Datenquelle dann die entsprechenden Felder und Gruppen hinzu.

  8. Wenn die Ergebnisse der Abfrage verfügbar sein sollen, falls das Formular nicht mit einem Netzwerk verbunden ist, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern.

    Sicherheitshinweis : Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert sind, sind sie in den Formularen verfügbar, die die Benutzer ausfüllen, selbst wenn deren Computer nicht mit einem Netzwerk verbunden sind. Wenn Sie aus dieser Datenverbindung vertrauliche Daten abrufen, sollten Sie dieses Feature deaktivieren, um dazu beizutragen, dass bei Computerverlust oder -diebstahl die Daten geschützt sind.

  9. Klicken Sie auf Weiter.

  10. Geben Sie auf der nächsten Seite des Assistenten einen beschreibenden Namen für die Abfragedatenverbindung ein.

  11. Aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abfragen, um Formulare, die auf dieser Formularvorlage basieren, beim Öffnen zum automatischen Empfangen von Daten zu aktivieren.

  12. Vergewissern Sie sich, dass die Informationen im Abschnitt Zusammenfassung korrekt ist, und klicken Sie dann auf Fertig stellen.

  13. Klicken Sie auf Schließen.

Schritt 2: Konfigurieren der Formularvorlage zur Verwendung der sekundären Datenverbindung

Wenn Sie einer Formularvorlage eine Abfragedatenverbindung hinzufügen, verwenden die Formulare, die auf dieser Formularvorlage basieren, standardmäßig die Datenverbindung, wenn sie von einem Benutzer geöffnet werden. Sie können die Formularvorlage auch so konfigurieren, dass die Abfragedatenverbindung auf eine der folgenden Weisen verwendet wird:

  • Hinzufügen einer Regel    Sie können eine Regel, um die Verbindung zum Abfragen von Daten verwenden, wenn die Bedingung in der Regel eintritt konfigurieren.

  • Hinzufügen einer Schaltfläche    Sie können die Formularvorlage eine Schaltfläche hinzufügen, die Benutzer klicken können, um Daten zu erhalten, indem Sie die Verbindung zum Abfragen von Daten.

  • Verwenden Sie benutzerdefiniertem code    Wenn Sie eine Regel oder eine Schaltfläche hinzufügen können, können Sie benutzerdefinierten Code zum Abrufen von Daten mithilfe der Verbindungs zum Abfragen von Daten verwenden. Mithilfe von benutzerdefiniertem Code erfordert einen Entwickler zum Erstellen von benutzerdefinierten Codes.

Hinzufügen einer Regel

Sie können der Formularvorlage eine Regel hinzufügen, um Daten aus der Abfragedatenverbindung abzufragen, wenn die Bedingung für die Regel erfüllt ist. In der folgenden Prozedur wird vorausgesetzt, dass Sie eine Abfragedatenverbindung für Ihre Formularvorlage erstellt haben und dass Sie ein Steuerelement in Ihrer Formularvorlage konfiguriert haben, um die Daten aus dieser Datenverbindung anzuzeigen.

  1. Falls die Formularvorlage über mehrere Ansichten verfügt, klicken Sie auf Name der Ansicht im Menü Ansicht, um zu der Ansicht zu gelangen, wo die Daten aus der sekundären Datenquelle angezeigt werden sollen.

  2. Doppelklicken Sie auf das Steuerelement, dem Sie eine Regel hinzufügen möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Gültigkeitsprüfung und Regeln auf Regeln.

  5. Klicken Sie im Dialogfeld Regeln auf Hinzufügen.

  6. Geben Sie im Feld Name einen Namen für die Regel ein.

  7. Um eine Bedingung festzulegen, wann die Regel ausgeführt werden sollte, klicken Sie auf Bedingung festlegen, und geben Sie dann die Bedingung ein. Die Regel wird bei Eintreten der Bedingung ausgeführt. Wenn Sie keine Bedingung festlegen, wird die Regel immer dann ausgeführt, wenn der Benutzer den Wert im Steuerelement ändert und anschließend den Cursor vom Steuerelement weg bewegt.

  8. Klicken Sie auf Aktion hinzufügen.

  9. Klicken Sie in der Liste Aktion auf Mithilfe einer Datenverbindung abfragen.

  10. Klicken Sie in der Liste Datenverbindung auf die Abfragedatenverbindung, die Sie verwenden möchten, und klicken Sie dann zum Öffnen des Dialogfelds auf OK.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Hinzufügen einer Schaltfläche

Sie können Ihrer Formularvorlage ein Schaltflächensteuerelement hinzufügen, auf das Ihre Benutzer zum Abrufen von Daten aus dieser Abfragedatenverbindung klicken können. In der folgenden Prozedur wird vorausgesetzt, dass Sie eine Abfragedatenverbindung für Ihre Formularvorlage erstellt haben.

  1. Falls die Formularvorlage über mehrere Ansichten verfügt, klicken Sie auf Name der Ansicht im Menü Ansicht, um zu der Ansicht zu gelangen, wo die Daten aus der sekundären Datenquelle angezeigt werden sollen.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Ziehen Sie ein Schaltflächensteuerelement auf Ihre Formularvorlage.

  4. Doppelklicken Sie auf die Schaltfläche, die Sie soeben Ihrer Formularvorlage hinzugefügt haben.

  5. Klicken Sie auf die Registerkarte Allgemein.

  6. Klicken Sie in der Liste Aktionen auf Aktualisieren.

  7. Geben Sie im Feld Beschriftung den Namen ein, der auf der Schaltfläche Ihrer Formularvorlage angezeigt werden soll.

  8. Klicken Sie auf Einstellungen.

  9. Klicken Sie im Dialogfeld Aktualisieren auf Eine sekundäre Datenquelle.

  10. Klicken Sie in der Liste Wählen Sie die sekundäre Datenquelle aus auf die sekundäre Datenquelle, die mit der Abfragedatenverbindung verknüpft ist, und klicken Sie dann zum Schließen jedes geöffneten Dialogfelds auf OK.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Seitenanfang

Hinzufügen einer Verbindung zum Absenden von Daten

Um Benutzern das Absenden von auf Ihrer Formularvorlage basierenden Formularen an einen Webdienst zu ermöglichen, fügen Sie Ihrer Daten sendenden Formularvorlage zunächst eine sekundäre Datenverbindung hinzu, und anschließend konfigurieren Sie die Formularvorlage, um Ihren Benutzern das Absenden ihrer Formulardaten zu ermöglichen.

Schritt 1: Hinzufügen einer sekundären Datenverbindung

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Datenverbindungen auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten senden, und klicken Sie dann auf Weiter.

  4. Klicken Sie unter Wie sollen die Daten versendet werden? auf An einen Webdienst, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten die Speicherposition des Webdienstes ein, in dem Ihre Benutzer ihre Daten absenden werden, und klicken Sie dann auf Weiter.

    Hinweis : Wenn Sie einem Webdienst mithilfe eines Servers Universal Description Discovery and Integration (UDDI) suchen möchten, klicken Sie auf UDDI durchsuchen, geben Sie die URL des UDDI-Servers ein, die Sie suchen, angeben, ob Sie nach Anbieter oder nach einem Dienst, der bereitgestellt wird, suchen möchten, geben Sie ein Suchschlüsselwort ein, und klicken Sie dann auf Suchen möchten. Webdienste, die das Stichwort entsprechen, werden in der Liste Suchergebnis angezeigt. Wählen Sie den Webdienst, den Sie verwenden möchten, und klicken Sie dann auf OK.

  6. Klicken Sie in der Liste Vorgang auswählen auf den Webdienstvorgang, der die Formulardaten erhält, und klicken Sie dann auf Weiter.

  7. Gehen Sie auf der nächsten Seite des Assistenten folgendermaßen vor, um zu bestimmen, welche Daten im Formular für jeden Parameter im Webdienst abgesendet werden sollen:

    Absenden der Daten in einem Feld oder einer Gruppe

    1. Klicken Sie in der Liste Parameter auf den Webdienstparameter, der die Daten aus dem Formular empfängt.

    2. Klicken Sie unter Parameteroptionen auf Feld oder Gruppe.

    3. Klicken Sie auf Ändern Schaltfläche (Symbol) .

    4. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf das Feld oder die Gruppe, deren Daten Sie absenden möchten, und klicken Sie dann auf OK.

    5. Klicken Sie im Feld Einschließen auf Nur Text und untergeordnete Elemente, um nur die Daten in diesem Feld und die untergeordneten Elemente des Felds oder der Gruppe abzusenden, oder klicken Sie auf Untergeordneter XML-Baum, einschließlich ausgewähltem Element, um einen Feldnamen, die Daten im Feld und die untergeordneten Elemente in der ausgewählten Gruppe oder im ausgewählten Feld abzusenden.

    Absenden aller Daten im Formular

    1. Klicken Sie in der Liste Parameter auf den Webdienstparameter, der die Daten aus dem Formular empfängt.

    2. Klicken Sie unter Parameteroptionen auf Gesamtes Formular (XML-Dokument einschließlich Verarbeitungsanweisungen).

    Absenden der Daten als Zeichenfolge

    1. Klicken Sie in der Liste Parameter auf den Webdienstparameter, der die Daten aus dem Formular empfängt.

    2. Klicken Sie unter Parameteroptionen auf Gesamtes Formular (XML-Dokument einschließlich Verarbeitungsanweisungen).

    3. Aktivieren Sie das Kontrollkästchen Daten als Zeichenfolge absenden.

      Hinweis : Normalerweise aktivieren Sie dieses Kontrollkästchen, um digital signierte Daten abzusenden. Deaktivieren Sie in den meisten Fällen dieses Kontrollkästchen.

    Technischer Hinweis zu ADO.NET DataSet-Objekten

    Falls der Webdienst ein ADO.NET DataSet-Objekt erfordert, wählen Sie beim Konfigurieren dieser Datenverbindung einen Datensatzknoten aus. Sollten Sie einen anderen Knotentyp für eine Datenverbindung zu einem Webdienst verwenden, der ein ADO.NET DataSet-Objekt benötigt, schlägt der Absendevorgang fehl.

  8. Klicken Sie auf Weiter.

  9. Geben Sie auf der nächsten Seite des Assistenten einen Namen für die Verbindung zum Absenden von Daten aus.

  10. Vergewissern Sie sich, dass die Informationen im Abschnitt Zusammenfassung korrekt ist, und klicken Sie dann auf Fertig stellen.

  11. Klicken Sie auf Schließen.

Nach Hinzufügen der sekundären Datenverbindung müssen Sie Ihr Formular konfigurieren, um Benutzern das Absenden ihrer Daten mithilfe dieser Absendedatenverbindung zu ermöglichen.

Schritt 2: Aktivieren des Absendens in der Formularvorlage

Wenn Sie die Formularvorlage konfigurieren, um Benutzern das Absenden ihrer Formulardaten zu ermöglichen, fügt InfoPath die Schaltfläche Absenden der Symbolleiste Standard und den Befehl Absenden dem Menü Datei auf dem Formular hinzu. Sie können die Absendeoptionen für Ihre Formularvorlagen folgendermaßen anpassen:

  • Ändern Sie den Text, der auf der Schaltfläche Absenden und den Befehl Absenden angezeigt wird.

  • Ändern Sie die Tastenkombination für die Schaltfläche Absenden und den Befehl Absenden.

  • Erstellen Sie benutzerdefinierte Meldungen, die Ihren Benutzern angezeigt werden, wenn diese ihre Formulare absenden.

  • Geben Sie an, ob das Formular geschlossen oder geöffnet werden soll, oder ob ein neues leeres Formular geöffnet werden soll, nachdem das Formular abgesendet wurde.

  • Klicken Sie im Menü Extras auf Absendeoptionen.

  • Aktivieren Sie im Dialogfeld Absendeoptionen das Kontrollkästchen Übermitteln dieses Formulars durch Benutzer zulassen, klicken Sie auf Formulardaten an ein einziges Ziel senden, und klicken Sie dann in der Liste auf Web Service.

  • Klicken Sie in der Liste Datenverbindung für das Senden auswählen auf den Namen der Absendedatenverbindung zum Webservice, den Sie in den vorherigen Schritten erstellt haben.

    1. Zum Ändern des Namens der Schaltfläche Absenden, die auf der Standard-Symbolleiste angezeigt wird, und des Befehls Absenden, der im Menü Datei angezeigt wird, wenn der Benutzer das Formular ausfüllt, geben Sie den neuen Namen in das Feld Beschriftung im Dialogfeld Absendeoptionen ein.

      Tipp : Wenn Sie dieser Schaltfläche und diesem Befehl eine Tastenkombination zuweisen möchten, geben Sie vor dem Zeichen, das als Tastenkombination dienen soll, das kaufmännische Und-Zeichen (&) ein. Wenn beispielsweise ALT+B als Tastenkombination für die Schaltfläche Absenden und den Befehl dienen soll, geben Sie A&bsenden ein.

  • Wenn beim Ausfüllen des Formulars der Befehl Absenden oder die Schaltfläche Absenden in der Symbolleiste Standard nicht verwendet werden soll, deaktivieren Sie das Kontrollkästchen Menüelement "Absenden" und in der Symbolleiste Schaltfläche "Absenden" anzeigen.

    1. In der Standardeinstellung bleibt das Formular in InfoPath weiterhin geöffnet, nachdem das Formular abgesendet wurde, und es wird eine Meldung angezeigt, dass der Sendevorgang erfolgreich abgeschlossen wurde. Um dieses Standardverhalten zu ändern, klicken Sie auf Erweitert, und führen Sie eine der folgenden Aktionen aus:

      • Um das Formular zu schließen oder ein neues, leeres Formular zu erstellen, nachdem ein ausgefülltes Formular gesendet wurde, klicken Sie in der Liste Nach dem Absenden auf die gewünschte Option.

      • Um eine benutzerdefinierte Meldung zu erstellen, die angibt, ob das Formular erfolgreich übertragen wurde, aktivieren Sie das Kontrollkästchen Benutzerdefinierte Meldung verwenden, und geben Sie anschließend die Meldungen in die Felder Absenden erfolgreich und Absenden fehlgeschlagen ein.

        Tipp : Geben Sie im Feld Absenden fehlgeschlagen eine Meldung mit Lösungsmöglichkeiten ein, wenn beim Absenden eines Formulars Probleme auftreten. Sie können beispielsweise empfehlen, das Formular zu speichern und sich an jemanden zu wenden, der weiterhelfen kann.

      • Wenn nach dem Absenden eines Formulars keine Meldung angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Meldung nach dem Absenden anzeigen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×