Hinzufügen einer Datenverbindung mithilfe der Einstellungen in einer Verbindungsbibliothek

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Inhalt dieses Artikels

Übersicht

Vorbemerkung

Hinzufügen einer Abfragedatenverbindung

Hinzufügen einer Verbindung zum Absenden von Daten

Übersicht

Wenn Sie mehrere Formularvorlagen, die ähnliche datenverbindungen verwenden entwerfen, erwägen Sie mithilfe einer Datenverbindungsdatei statt eine Datenverbindung zu einer externen Datenquelle für jede Formularvorlage zu erstellen. Auf diese Weise müssen Sie nur eine Datenverbindungsdatei aktualisieren, wenn die Verbindungsinformationen für eine Reihe von verknüpften Formularvorlagen geändert wird. Beispielsweise müssen Sie beim Wechsel von Formularvorlagen aus einem Testnetzwerk zu einer laufenden Netzwerk aktualisieren die Daten Verbindungseinstellungen nur einmal in der Verbindungsbibliothek statt in jeder Formularvorlage Datenverbindung aktualisieren. Wenn Sie ein Formular basierend auf einer Formularvorlage, die eine Datenverbindungsdatei verwendet die Datenverbindung verwendet, wird die Verbindung von Daten mit den neuen Einstellungen automatisch aktualisiert.

Eine Datenverbindungsdatei ist eine XML-Datei mit der XML- oder UDCX Erweiterung, die Verbindungsinformationen für eine einzelne externe Datenquelle enthält. Diese Datei wird in einer Datenverbindungsbibliothek auf einem Server unter Microsoft Office SharePoint Server 2007 gespeichert. Eine Datenverbindungsdatei wird von einem Entwickler oder indem Sie eine Verbindung von Daten in einer vorhandenen Formularvorlage in einer Datenverbindungsdatei konvertieren, indem Sie auf die Schaltfläche umwandeln (MenüExtras ) im Dialogfeld Datenverbindungen erstellt.

Die Verwendung von Datenverbindungsdateien hat u. a. folgende Vorteile:

  • Mehrere Formulare können die gleiche Datenverbindungsdatei verwenden, so dass das erneute Erstellen der gleichen Datenverbindung für jede einzelne Formularvorlage entfällt.

  • Ändern sich der Speicherort oder die Verbindungseinstellungen für eine externe Datenquelle, müssen Sie nur die Datenverbindungsdatei aktualisieren, und nicht die einzelnen Formularvorlagen.

  • Die Datenverbindungsdatei kann alternative Authentifizierungsinformationen enthalten, die der Server verwenden kann, wenn ein Benutzer ein Formular unter Verwendung eines Web-Browsers ausfüllt.

  • Formulare, die auf einer Browser-kompatiblen Formularvorlage basieren und in einem Browser ausgefüllt werden, können sich nur mit solchen Servern fremder Domänen verbinden, die Datenverbindungsdateien verwenden.

Hinweis : Microsoft Office InfoPath verwendet Datenverbindungsdateien, die dem Dateiformat Universal Data Connection Version 2.0 entsprechen. Diese Version stellt eine Obermenge des Dateiformats der Version 1.0 dar, die von Microsoft Office FrontPage und Microsoft Office Excel verwendet wird. InfoPath kann keine Datenverbindungsdateien im Dateiformat der Version 1.0 verwenden.

Wenn Sie einer Formularvorlage mithilfe der Einstellungen in einer Datenverbindungsbibliothek eine Datenverbindung hinzufügen, erstellen Sie in dieser Formularvorlage eine sekundäre Datenverbindung. Diese Datenverbindung unterscheidet sich von der primären Datenverbindung, die beim Entwerfen einer Formularvorlage erstellt wird, welche auf einer Datenbank, einem Webdienst oder auf den Einstellungen in einer Datenverbindungsbibliothek basiert. Sie fügen nur dann eine sekundäre Datenverbindung hinzu, wenn Sie über die primäre Datenverbindung keine Daten empfangen oder senden können.

Seitenanfang

Vorbemerkung

Um Ihrer Formularvorlage mithilfe der in einer Datenverbindungsbibliothek gespeicherten Einstellung eine Datenverbindung hinzuzufügen, benötigen Sie vom Siteadministrator folgende Informationen:

  • Der Standort des Servers, auf dem Microsoft Office SharePoint Server 2007 ausgeführt wird, das die Site mit der Datenverbindungsbibliothek enthält.

  • Der Name der Datenverbindungsdatei in der zu verwendenden Datenverbindungsbibliothek

  • Ob die Datenverbindungsdatei Einstellungen für eine Abfragedatenverbindung oder Absendedatenverbindung enthält

  • Ob Sie die Formularvorlage konfigurieren können, um die Abfrageergebnisse zur Offlineverwendung sicher im Formular zu speichern, wenn die Einstellungen für eine Abfragedatenverbindung ausgelegt sind

Seitenanfang

Hinzufügen einer Abfragedatenverbindung

Führen Sie die folgenden Prozeduren aus, um Ihrer Formularvorlage mithilfe von Einstellungen in einer Verbindungsbibliothek eine Datenverbindung hinzuzufügen:

  1. Fügen Sie der Formularvorlage die sekundäre Datenverbindung hinzu.

  2. Binden Sie Steuerelemente an die Abfrage- und Datenfelder in der sekundären Datenquelle.

  3. Konfigurieren Sie die Formularvorlage, um die Datenverbindung mithilfe einer Regel oder Schaltfläche zu verwenden.

Schritt 1: Hinzufügen einer sekundären Datenverbindung

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Nach Verbindungen auf einem Computer mit Microsoft Office SharePoint Server suchen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten in der Liste Site auf den Namen der Site auf einem Server, auf dem Office SharePoint Server 2007 mit der Verbindungsbibliothek ausgeführt wird.

    Meine Site befindet sich nicht auf der Liste

    Gehen Sie folgendermaßen vor, um der Liste Ihre Site hinzuzufügen:

    1. Klicken Sie auf Websites verwalten.

    2. Klicken Sie im Dialogfeld Websites verwalten auf Hinzufügen.

    3. Geben Sie im Feld URL einen Namen für die Datenverbindungsbibliothek ein.

    4. Geben Sie im Feld Anzeigename einen Namen für die Datenverbindungsbibliothek ein. Der Name wird in der Liste Site im Datenverbindungsassistenten angezeigt.

    5. Klicken Sie auf OK.

    6. Klicken Sie auf Schließen.

  5. Klicken Sie auf den Namen der Datenverbindungsbibliothek, um eine Liste von Datenverbindungsdateien anzuzeigen. Klicken Sie auf den Namen der Datenverbindungsdatei, die Sie für diese Datenverbindung verwenden möchten, und klicken Sie dann auf Weiter.

  6. Je nach Verbindungseinstellungen in der Datenverbindungsdatei werden Sie auf der nächsten Seite des Assistenten dazu aufgefordert, Beispielwerte für jeden Parameter anzugeben.

    Wie werden Beispielwerte angegeben?

    1. Wählen Sie in der Tabelle Parameter einen Parameter aus, und klicken Sie auf Beispielwert festlegen.

    2. Geben Sie in das Feld Sample value einen Wert ein, den Ihr Benutzer für dieses Feld möglicherweise verwenden kann, und klicken Sie dann auf OK.

    3. Wiederholen Sie diese Schritte für jeden Parameter in der Tabelle Parameter, und klicken Sie dann auf Weiter.

    Technischer Hinweis

    Wenn Sie im Datenverbindungs-Assistenten eine Datenverbindung zu einem Web-Dienst konfigurieren, stellt Microsoft Office InfoPath eine Verbindung zu diesem Web-Dienst her und fordert die WSDL-Datei (Web Service Description Language) an. Die WSDL-Datei enthält das vom Web-Dienst verwendete Schema. Der Web-Dienst reagiert auf die Anforderung, indem er die betreffende Datei an InfoPath sendet. InfoPath verwendet die Informationen in dieser Datei, um der sekundären Datenquelle in der Formularvorlage die entsprechenden Felder und Gruppen hinzuzufügen. Falls InfoPath einen unbekannten Elementtyp in der WSDL-Datei findet, verwendet InfoPath Beispieldaten, um die Definition des unbekannten Elementtyps zu ermitteln, und fügt der sekundären Datenquelle dann die entsprechenden Felder und Gruppen hinzu.

  7. Wenn die Ergebnisse der Abfrage verfügbar sein sollen, falls das Formular nicht mit einem Netzwerk verbunden ist, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern.

    Sicherheitshinweis : Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert sind, sind sie in den Formularen verfügbar, die die Benutzer ausfüllen, selbst wenn deren Computer nicht mit einem Netzwerk verbunden sind. Wenn Sie aus dieser Datenverbindung vertrauliche Daten abrufen, sollten Sie dieses Feature deaktivieren, um dazu beizutragen, dass bei Computerverlust oder -diebstahl die Daten geschützt sind.

  8. Klicken Sie auf Weiter.

    Auf der nächsten Seite des Assistenten wird eine Zusammenfassung der Einstellungen für diese Datenverbindung angezeigt.

  9. Geben Sie einen beschreibenden Namen für die Datenverbindung ein. Dieser Name wird in der Liste Datenquelle des Aufgabenbereichs Datenquelle angezeigt.

  10. Aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abfragen, um Formulare, die auf dieser Formularvorlage basieren, beim Öffnen zum Verwenden dieser Datenverbindung zu aktivieren.

Seitenanfang

Schritt 2: Hinzufügen eines Steuerelements, um Ihren Benutzern die Daten anzuzeigen

  1. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  2. Ziehen Sie ein Steuerelement auf die Formularvorlage

  3. Wählen Sie im Dialogfeld Steuerelementbindung das Feld aus, das Sie an das Steuerelement binden möchten, und klicken Sie dann auf OK.

Schritt 3: Konfigurieren Sie die Formularvorlage zur Verwendung der Datenverbindung

Wenn Sie möchten, dass Benutzer Daten aus dieser Datenverbindung nach Öffnen des Formulars abrufen, können Sie Ihrer Formularvorlage, die die Datenverbindung unter einer bestimmten Bedingung erfüllt, eine Regel hinzufügen. Sie können Ihrer Formularvorlage aber auch eine Schaltfläche hinzufügen, auf die Ihre Benutzer zur Verwendung der Datenverbindung klicken können.

Hinzufügen einer Regel

Sie können Ihrer Formularvorlage eine Regel hinzufügen, die die Abfragedatenverbindung ausführt, wenn die Bedingung für die Regel erfüllt ist. In der folgenden Prozedur wird vorausgesetzt, dass Sie eine Abfragedatenverbindung für Ihre Formularvorlage erstellt haben und dass Sie ein Steuerelement in Ihrer Formularvorlage konfiguriert haben, um die Daten aus der Datenverbindung anzuzeigen.

  1. Falls die Formularvorlage über mehrere Ansichten verfügt, klicken Sie auf Name der Ansicht im Menü Ansicht, um zu der Ansicht zu gelangen, wo die Daten aus der sekundären Datenquelle angezeigt werden sollen.

  2. Doppelklicken Sie auf das Steuerelement, dem Sie eine Regel hinzufügen möchten.

  3. Klicken Sie auf die Registerkarte Daten.

  4. Klicken Sie unter Gültigkeitsprüfung und Regeln auf Regeln.

  5. Klicken Sie im Dialogfeld Regeln auf Hinzufügen.

  6. Geben Sie im Feld Name einen Namen für die Regel ein.

  7. Um eine Bedingung festzulegen, wann die Regel ausgeführt werden sollte, klicken Sie auf Bedingung festlegen, und geben Sie dann die Bedingung ein. Die Regel wird bei Eintreten der Bedingung ausgeführt. Wenn Sie keine Bedingung festlegen, wird die Regel immer dann ausgeführt, wenn der Benutzer den Wert im Steuerelement ändert und anschließend den Cursor vom Steuerelement weg bewegt.

  8. Klicken Sie auf Aktion hinzufügen.

  9. Klicken Sie in der Liste Aktion auf Mithilfe einer Datenverbindung abfragen.

  10. Klicken Sie in der Liste Datenverbindung auf die Abfragedatenverbindung, die Sie verwenden möchten, und klicken Sie dann zum Schließen jedes Dialogfelds auf OK.

  11. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Hinzufügen einer Schaltfläche zur Verwendung der Abfragedatenverbindung

Sie können Ihrer Formularvorlage ein Schaltflächensteuerelement hinzufügen, auf das Ihre Benutzer beim Ausfüllen eines auf Ihrer Formularvorlage basierenden Formulars klicken können. Nach dem Klicken kann diese Schaltfläche Daten aus der Abfragedatenverbindung abrufen.

  1. Falls die Formularvorlage über mehrere Ansichten verfügt, klicken Sie auf Name der Ansicht im Menü Ansicht, um zu der Ansicht zu gelangen, wo die Daten aus der sekundären Datenquelle angezeigt werden sollen.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Ziehen Sie ein Schaltflächensteuerelement auf Ihre Formularvorlage.

  4. Doppelklicken Sie auf das Schaltflächensteuerelement, das Sie soeben Ihrer Formularvorlage hinzugefügt haben.

  5. Klicken Sie auf die Registerkarte Allgemein.

  6. Klicken Sie in der Liste Aktionen auf Aktualisieren.

  7. Geben Sie im Feld Beschriftung den Namen ein, der auf der Schaltfläche Ihrer Formularvorlage angezeigt werden soll.

  8. Klicken Sie auf Einstellungen.

  9. Klicken Sie im Dialogfeld Aktualisieren auf Eine sekundäre Datenquelle.

  10. Klicken Sie in der Liste Wählen Sie die sekundäre Datenquelle auf die sekundäre Datenquelle, die Ihrer Abfragedatenverbindung zugeordnet ist.

  11. Klicken Sie auf OK, um jedes geöffnete Dialogfeld zu schließen.

  12. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Seitenanfang

Hinzufügen einer Verbindung zum Absenden von Daten

Wenn die Datenverbindungsdatei Einstellungen für eine Absendedatenverbindung enthält, können Sie Ihre Formularvorlage konfigurieren, um Benutzern das Absenden ihrer Formulardaten über diese Datenverbindung zu ermöglichen. Wenn Sie Ihre Formularvorlage konfigurieren, um Benutzern das Absenden ihrer Formulardaten zu ermöglichen, fügt InfoPath die Schaltfläche Absenden auf der Symbolleiste Standard und den Befehl Absenden im Menü Datei hinzu. Sie können die Absendeoptionen für die Formularvorlage im Dialogfeld Absendeoptionen (Menü Extras) konfigurieren. Die Absendeoptionen werden auf dieselbe Weise konfiguriert, wie wenn Sie eine sekundäre Datenverbindung hinzufügen, die eine Absendedatenverbindung ist. Verknüpfungen zu weiteren Informationen über das Hinzufügen einer Absendedatenverbindung zu Ihrer Formularvorlage finden Sie im Abschnitt Siehe auch.

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Nach Verbindungen auf einem Computer mit Microsoft Office SharePoint Server suchen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten in der Liste Site auf den Namen der Site mit der Verbindungsbibliothek.

    Meine Site befindet sich nicht auf der Liste

    Gehen Sie folgendermaßen vor, um der Liste Ihre Site hinzuzufügen:

    1. Klicken Sie auf Websites verwalten.

    2. Klicken Sie im Dialogfeld Websites verwalten auf Hinzufügen.

    3. Geben Sie im Feld URL einen Namen für die Datenverbindungsbibliothek ein.

    4. Geben Sie im Feld Anzeigename einen Namen für die Datenverbindungsbibliothek ein. Der Name wird in der Liste Site im Datenverbindungsassistenten angezeigt.

    5. Klicken Sie auf OK.

    6. Klicken Sie auf Schließen.

  5. Klicken Sie auf den Namen der Datenverbindungsbibliothek, um eine Liste von Datenverbindungsdateien anzuzeigen. Klicken Sie auf den Namen der Datenverbindungsdatei, die Sie für diese Absendedatenverbindung verwenden möchten, und klicken Sie dann auf Weiter.

  6. Wenn die Einstellungen für eine Absendedatenverbindung zu einem Webdienst gelten, kann InfoPath erkennen, welche Parameter im Webdienst die Daten empfangen können. Sie können die Absendedatenverbindung konfigurieren, um sämtliche Daten oder einen Teil davon in der Formularvorlage zu senden.

    Wie?

    1. Klicken Sie in der Liste Parameter auf einen Parameter, der die Daten aus dem Formular empfängt.

    2. Gehen Sie folgendermaßen vor, um sämtliche Daten im Formular für diesen Parameter, einschließlich des Stammelements und der Verarbeitungsanweisungen, zu senden:

      1. Klicken Sie auf Gesamtes Formular (XML-Dokument einschließlich Verarbeitungsanweisungen).

      2. Um die Daten als Zeichenfolge zu senden, aktivieren Sie das Kontrollkästchen Daten als Zeichenfolge senden. Normalerweise aktivieren Sie dieses Kontrollkästchen, um digital signierte Daten abzusenden. Deaktivieren Sie in den meisten Fällen dieses Kontrollkästchen.

    3. Gehen Sie folgendermaßen vor, um ein Feld oder eine Gruppe für diesen Parameter anzugeben:

      1. Klicken Sie unter Parameteroptionen auf Feld oder Gruppe.

      2. Klicken Sie auf Ändern Schaltfläche (Symbol) .

      3. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf das Feld oder die Gruppe, deren Daten Sie absenden möchten, und klicken Sie dann auf OK.

      4. Klicken Sie in der Liste Einschließen auf Nur Text und untergeordnete Elemente, um nur den Inhalt des Felds oder der Gruppe zu senden; klicken Sie auf Untergeordneter XML-Baum, einschließlich ausgewähltem Element, um sowohl den Inhalt als auch die ausgewählte Gruppe oder das Feld zu senden.

    4. Wiederholen Sie diese Schritte für jeden Parameter.

  7. Klicken Sie auf Weiter.

  8. Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung an einen aussagekräftigen Namen für diese Datenverbindung (Absenden) ein.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×