Grundlegende Aufgaben in Access 2010

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Hier sind einige grundlegende Datenbankaufgaben, die Sie ausführen können, wenn Sie Informationen zum Verwenden von Microsoft Access 2010 helfen.

 

Inhalt dieses Artikels

Was ist Access?

Relationale Datenbanken in Access

Wenn Sie Access öffnen

Suchen und Anwenden einer Vorlage

Erstellen einer neuen Datenbank

Öffnen einer vorhandenen Access-Datenbank

Erste Schritte mit der neuen Datenbank

Hinzufügen einer Tabelle

Einfügen von Daten in eine Access-Tabelle aus einer anderen Quelle

Importieren von oder Verknüpfen mit Daten aus einer anderen Quelle

Weitere Schritte

Importieren von Daten aus einer Tabellenkalkulation oder aus einem anderen Programm

Importieren eines Excel-Arbeitsblatts in Access

Importieren eines Excel-Arbeitsblatts in eine neue Datenbank als Tabelle

Verwenden des Tabellenanalyse-Assistenten zum Organisieren der Daten

Arbeiten mit Daten aus anderen Programmen

Verwenden einer früheren Datenbankversion in mehreren Access-Versionen

Verwenden einer Access-Datenbankdatei in verschiedenen Versionen von Access

Schritt 1: Erstellen einer Kopie der vorhandenen Datenbank und Speichern der Kopie in einem neuen Format

Schritt 2: Teilen der kopierten Datenbank und Verwenden der ursprünglichen Datei als Back-End-Datenbank

Schritt 3: Verbinden der neuen Front-End- mit der ursprünglichen Datenbank

Verwenden einer Front-End/Back-End-Anwendung in verschiedenen Access-Versionen

Was ist Access?

Access 2010 ist ein Entwurf und Bereitstellung Datenbanktool von Anwendung , die Sie verwenden können, um wichtige Informationen verfolgen. Strukturieren Sie Ihre Daten auf Ihrem Computer, oder Sie können im Web veröffentlichen, damit andere Ihre Datenbank mit einem Webbrowser verwendet werden können.

Viele Personen beginnen mit der Verwendung von Access, wenn das von ihnen zum Nachverfolgen von Daten verwendete Programm sich für diese Aufgabe zunehmend als unzulänglich erweist. Nehmen wir beispielsweise an, Sie organisieren Veranstaltungen und möchten alle Details, die Sie für die erfolgreiche Abwicklung von Veranstaltungen berücksichtigen müssen, im Auge behalten. Wenn Sie dazu eine Textverarbeitung oder eine Tabellenkalkulation verwenden, können doppelt vorhandene oder inkonsistente Daten Sie leicht in Schwierigkeiten bringen. Sie können ein Terminplanungstool verwenden, aber das Nachverfolgen von Finanzdaten in einem Kalender ist keine überzeugende Lösung.

Relationale Datenbanken in Access

Gelegentlich benötigen Sie eine relationale Datenbank, um solche Informationen zu verwalten. Eine relationale Datenbank ist ein Datenspeicher, der in kleinere Datenzusammenstellungen (als Tabellen bezeichnet) aufgeteilt wurde, damit keine Redundanzen auftreten, und dann über allgemeine Informationseinheiten (als Felder bezeichnet) verknüpft wurde. Beispielsweise könnte eine relationale Datenbank zur Planung von Veranstaltungen eine Tabelle mit Kundeninformationen, eine Tabelle mit Lieferanteninformationen und eine Tabelle mit Veranstaltungsinformationen enthalten. Die Tabelle mit Veranstaltungsinformationen könnte ein Feld haben, über das sie mit der Kundentabelle verknüpft wird, und ein Feld, über das sie mit der Lieferantentabelle verknüpft wird. In diesem Fall kann, wenn sich z. B. die Telefonnummer eines Lieferanten geändert hat, die Information ein Mal in der Lieferantentabelle geändert werden statt für jede Veranstaltung, für die der Lieferant vorgesehen ist.

Access ist ein Werkzeug, mit dem Sie schnell und einfach eine relationale Datenbank entwickeln können, in der Sie Informationen verwalten. Eine Datenbank können Sie für fast alle Arten von Informationen erstellen, z. B. Warenbestände, Berufskontakte oder Geschäftsvorgänge. Zu Access gehören Vorlagen, die Sie sofort dazu verwenden können, unterschiedliche Arten von Informationen zu verwalten, und die das Arbeiten mit Access auch für Anfänger erleichtern.

Wenn Sie Access öffnen

Wenn Sie Access 2010 beginnen, wird die Microsoft Office Backstage-Ansicht, wobei erhalten Sie Informationen über die aktuelle Datenbank, eine neue Datenbank erstellen, öffnen Sie eine vorhandene Datenbank, und Ansicht wichtige Inhalte aus Office.com.

Backstage-Ansicht von Access 2010

Die Backstage-Ansicht enthält außerdem viele weitere Befehle, mit denen Sie Ihre Datenbanken anpassen, warten oder freigeben können. Die Befehle in der Backstage-Ansicht gelten grundsätzlich für eine gesamte Datenbank, nicht nur für Objekte in einer Datenbank.

Hinweis : Sie können die Backstage-Ansicht jederzeit aufrufen, indem Sie auf die Registerkarte Datei klicken.

Seitenanfang

Suchen und Anwenden einer Vorlage

Access stellt eine Vielzahl von Vorlagen bereit, mit denen Sie Datenbanken schneller erstellen können. Eine Vorlage ist eine gebrauchsfertige Datenbank, die bereits alle Tabellen, Abfragen, Formulare und Berichte enthält, die zum Ausführen einer bestimmten Aufgabe erforderlich sind. Es gibt beispielsweise Vorlagen zum Überwachen von Problemen, zum Verwalten von Kontakten oder zum Aufzeichnen von Ausgaben. Bestimmte Vorlagen enthalten Beispieleinträge, um die Art der Verwendung zu verdeutlichen. Vorlagendatenbanken können unverändert verwendet werden oder Ihren Anforderungen entsprechend angepasst werden.

Gehen Sie wie folgt vor, um eine Vorlage auf Ihre Datenbank anzuwenden:

  1. Klicken Sie auf der Registerkarte Datei auf Neu.

  2. Führen Sie unter Verfügbare Vorlagen eine der folgenden Aktionen aus:

    • Klicken Sie zum erneuten Verwenden einer Vorlage, die Sie vor Kurzem verwendet haben, auf Zuletzt verwendete Vorlagen, und wählen Sie dann die gewünschte Vorlage aus.

    • Klicken Sie zum Verwenden einer Vorlage, die Sie bereits installiert haben, auf Meine Vorlagen, und wählen Sie dann die gewünschte Vorlage aus.

    • Klicken Sie auf eine Vorlagenkategorie um eine Vorlage auf Office.com, klicken Sie unter Office.com-Vorlagen finden, wählen Sie die gewünschte Vorlage aus, und klicken Sie dann auf herunterladen, um die Vorlage aus Office .com auf Ihren Computer herunterzuladen.

      Hinweis :  Ferner können Sie direkt aus Access nach Vorlagen auf Office.com suchen. Geben Sie im Feld Vorlagen auf Office.com suchen mindestens ein Stichwort ein, und klicken Sie dann auf die Pfeilschaltfläche zum Starten der Suche.

  3. Klicken Sie optional auf das Ordnersymbol neben dem Feld Dateiname, um zu dem Speicherort zu navigieren, in dem Sie die Datenbank erstellen möchten. Wenn Sie keinen speziellen Speicherort angeben, erstellt Access die Datenbank in dem Standardspeicherort, der unter dem Feld Dateiname angezeigt wird.

  4. Klicken Sie auf Erstellen.

Access erstellt die Datenbank und öffnet sie, sodass sie verwendet werden kann.

Seitenanfang

Erstellen einer neuen Datenbank

Hinweis : Eine ausführlichere Einführung in die Konzepte zum Erstellen einer Datenbank in Access finden Sie in dem Artikel Grundlagen des Datenbankentwurfs.

Wenn keine der Vorlagen Ihren Anforderungen entspricht oder wenn Sie in einem anderen Programm Daten haben, die Sie in Access verwenden möchten, kann es sinnvoll sein, eine neue Datenbank zu erstellen. In Access 2010 haben Sie die Wahl zwischen zwei Datenbanktypen: Standarddesktopdatenbank und Webdatenbank.

Hinweis : Weitere Informationen zu Webdatenbanken finden Sie im Artikel Erstellen einer im Web freizugebenden Datenbank.

Führen Sie folgenden Aktionen aus, um eine neue Datenbank zu erstellen:

  1. Starten Sie Access.

  2. Klicken Sie in der Backstage-Ansicht auf der Registerkarte Neu auf Leere Datenbank oder Leere Webdatenbank.

    Wichtig : Die Wahl, die Sie hier treffen, bestimmt, welche Features in der Datenbank verfügbar sind. Eine Desktopdatenbank kann nicht im Web veröffentlicht werden, und in einer Webdatenbank werden einige Desktopfeatures (z. B. Gesamtsummenabfragen) nicht unterstützt.

  3. Geben Sie auf der rechten Seite einen Namen für die Datenbank im Feld Dateiname ein.

    Wenn Sie den Speicherort ändern möchten, in dem die Datei erstellt werden soll, klicken Sie neben dem Feld Dateiname auf Durchsuchen Schaltflächensymbol, wählen Sie den neuen Speicherort aus, und klicken Sie dann auf OK.

  4. Klicken Sie auf Erstellen.

    Access erstellt die Datenbank und öffnet dann eine leere Tabelle (Tabelle 1) in der Datenblattansicht.

  5. Access setzt den Cursor in die erste leere Zelle in der Zum Hinzufügen klicken-Spalte der neuen Tabelle.

    Beginnen Sie mit der Eingabe, um Daten hinzuzufügen – oder aus einer anderen Datenquelle einzufügen, wie weiter unten in diesem Artikel im Abschnitt Einfügen von Daten in eine Access-Tabelle aus einer anderen Quelle beschrieben wird.

    Hinweise : 

    • Die Dateneingabe in der Datenblattansicht ähnelt dem Eingeben von Daten in ein Excel-Arbeitsblatt. Die wichtigste Beschränkung besteht darin, dass die Daten in zusammenhängende Zeilen und Spalten eingegeben werden müssen, und zwar von der linken oberen Ecke des Datenblatts aus. Daten sollten nicht durch das Einfügen leerer Zeilen oder Spalten formatiert werden, wie dies in einem Excel-Arbeitsblatt möglich ist, da auf diese Weise Platz in der Tabelle verschwendet wird. Die Tabelle enthält lediglich die Daten. Die visuelle Darstellung dieser Daten erfolgt über die Formulare und Berichte, die Sie später erstellen.

    • Die Tabellenstruktur wird während der Eingabe von Daten erstellt. Jedes Mal, wenn Sie das Datenblatt, eine neue Spalte hinzufügen, wird ein neues Feld in der Tabelle definiert. Access stellt die Datentyp für das Feld basierend auf den Typ der Daten, die Sie eingeben. Beispielsweise, wenn Sie eine Spalte haben, in der Sie nur Datumswerte eingegeben haben, wird Access dieses Feld den Datentyp auf Datum/Uhrzeit festgelegt. Wenn Sie später versuchen nicht Datumswert (beispielsweise einen Namen oder eine Telefonnummer) in diesem Feld eingeben, zeigt Access eine Meldung darüber informiert werden, dass der Wert nicht den Datentyp der Spalte entspricht. Wenn möglich, sollten Sie die Tabelle planen, dass jede Spalte den gleichen Typ des Daten enthält, ob es sich um Text, Zahlen, Datumsangaben oder einen anderen Typ ist. Dadurch leichter zu erstellen, Abfragen, Formulare und Berichte, die nur die Daten zu markieren.

Wenn Sie momentan noch keine Daten eingeben möchten, klicken Sie auf Schließen Schaltflächensymbol.

Hinweis : Access schließt die Tabelle Tabelle1, ohne sie zu speichern.

Seitenanfang

Öffnen einer vorhandenen Access-Datenbank

Tipp : Wenn Sie schnell eine der Datenbanken öffnen möchten, die Sie zuletzt geöffnet haben, klicken Sie auf der Registerkarte Datei auf Zuletzt verwendet, und klicken Sie dann auf den Dateinamen.

  1. Klicken Sie auf der Registerkarte Datei auf Öffnen.

  2. Klicken Sie im Dialogfeld Öffnen auf eine Verknüpfung, oder klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner mit der gewünschten Datenbank.

  3. Doppelklicken Sie in der Ordnerliste mehrmals auf Ordner, bis Sie den Ordner geöffnet haben, der die Datenbank enthält.

  4. Gehen Sie folgendermaßen vor, wenn Sie die Datenbank gefunden haben:

    • Doppelklicken Sie auf die Datenbank, um sie im Standardöffnungsmodus zu öffnen.

    • Klicken Sie auf Öffnen, um die Datenbank für gemeinsamen Zugriff in einer Mehrbenutzerumgebung zu öffnen. Auf diese Weise haben Sie gleichzeitig mit anderen Benutzern Lese- und Schreibzugriff auf die Datenbank.

    • Klicken Sie auf den Pfeil neben der Schaltfläche Öffnen und dann auf Schreibgeschützt öffnen, um die Datenbank schreibgeschützt zu öffnen, sodass Sie sie anzeigen, jedoch nicht bearbeiten können.

    • Klicken Sie auf den Pfeil neben der Schaltfläche Öffnen und dann auf Exklusiv öffnen, um die Datenbank exklusiv zu öffnen, sodass sie von keinem anderen Benutzer geöffnet werden kann, während Sie sie geöffnet haben.

    • Um die Datenbank für schreibgeschützten Zugriff zu öffnen, klicken Sie auf den Pfeil neben der Schaltfläche Öffnen, und klicken Sie dann auf Exklusiv schreibgeschützt öffnen. Andere Benutzer können die Datenbank nach wie vor öffnen, aber sie haben nur Lesezugriff.

So suchen Sie die zu öffnende Datenbank   

  1. Klicken Sie im Dialogfeld Öffnen auf die Verknüpfung Arbeitsplatz, oder klicken Sie im Feld Suchen in auf Arbeitsplatz.

  2. Klicken Sie in der Liste der Laufwerke mit der rechten Maustaste auf das Laufwerk, von dem Sie annehmen, dass es die Datenbank enthält, und klicken Sie auf Suchen.

  3. Geben Sie die Suchkriterien ein, und drücken Sie dann die EINGABETASTE, um nach der Datenbank zu suchen.

  4. Wenn die Datenbank gefunden wurde, öffnen Sie sie, indem Sie im Dialogfeld Suchergebnisse auf die Datenbank doppelklicken.

    Hinweis : Da die Suche über das Dialogfeld Öffnen initiiert wurde, müssen Sie in diesem Dialogfeld auf Abbrechen klicken, damit die Datenbank geöffnet wird.

Sie können eine Datendatei direkt in einem externen Dateiformat, z. B. dBASE, Paradox, Microsoft Exchange oder Excel öffnen. Sie können auch eine beliebige ODBC-Datenquelle direkt öffnen, z. B. Microsoft SQL Server oder Microsoft FoxPro. In Access wird automatisch eine neue Access-Datenbank in demselben Ordner erstellt, in dem sich die Datendatei befindet, und jeder Tabelle in der externen Datenbank werden Verknüpfungen hinzugefügt.

Seitenanfang

Erste Schritte mit der neuen Datenbank

Je nachdem, welche Vorlage Sie verwenden, müssen Sie möglicherweise einige der folgenden Schritte ausführen, damit Sie mit der neuen Datenbank starten können:

  • Wenn Access ein Anmeldung-Dialogfeld mit einer leeren Benutzerliste anzeigt, gehen Sie wie folgt vor:

    1. Klicken Sie aufNeuer Benutzer.

    2. Füllen Sie das Formular Benutzerdetails aus.

    3. Klicken Sie auf Speichern und schließen.

    4. Wählen Sie den Benutzernamen aus, den Sie soeben eingegeben haben, und klicken Sie dann auf Anmeldung.

  • Wenn Access ein leeres Datenblatt anzeigt, können Sie direkt Daten in dieses Datenblatt eingeben. Sie können aber auch auf Schaltflächen oder Registerkarten klicken, um sich die Datenbank anzusehen.

  • Wenn Access eine Erste Schritte-Seite anzeigt, können Sie auf Links auf der Seite klicken, um weitere Informationen zu der Datenbank zu erhalten, oder auf Schaltflächen oder Registerkarten klicken, um sich die Datenbank anzusehen.

  • Wenn Access in der Statusleiste eine Sicherheitswarnung-Meldung anzeigt und Sie der Quelle der Vorlage vertrauen, klicken Sie auf Inhalt aktivieren. Wenn für die Datenbank eine Anmeldung erforderlich ist, müssen Sie sich erneut anmelden.

Für Desktop- wie für Webdatenbanken werden Sie ebenfalls mit einem dieser Schritte beginnen wollen:

Seitenanfang

Hinzufügen einer Tabelle

Sie können einer vorhandenen Datenbank eine neue Tabelle hinzufügen, indem Sie die Tools in der Gruppe Tabellen auf der Registerkarte Erstellen verwenden.

Gruppe „Tabellen“ auf der Registerkarte „Erstellen“

Hinweis : In einer Webdatenbank ist in der Gruppe Tabellen nur der Befehl Tabelle verfügbar.

Unabhängig davon, welche Ansicht zuerst angezeigt wird, können Sie jederzeit mithilfe der Ansichtsschaltflächen auf der Statusleiste des Access-Fensters zur anderen Ansicht wechseln.

Erstellen einer leeren Tabelle in der Datenblattansicht    In der Datenblattansicht können Sie sofort Daten eingeben, während Access die Tabellenstruktur im Hintergrund erstellt. Feldnamen werden numerisch zugewiesen (Feld1, Feld2 usw.), und Access legt den Datentyp eines Felds basierend auf den eingegebenen Daten fest.

  1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Tabellen auf Tabelle Schaltflächensymbol.

  2. Access erstellt die Tabelle und platziert dann den Cursor in der ersten leeren Zelle der Spalte Zum Hinzufügen klicken.

  3. Geben Sie Daten in die erste leere Zelle ein. Oder fügen Sie Daten aus einer anderen Quelle ein, wie weiter unten in diesem Artikel beschrieben.

    • Wenn Sie eine Spalte (Feld) umbenennen möchten, doppelklicken Sie auf die Spaltenüberschrift, und geben Sie den neuen Namen ein.

      Tipp : Geben Sie jedem Feld einen aussagekräftigen Namen, damit Sie den Feldinhalt erkennen können, ohne sich die Daten ansehen zu müssen.

    • Wenn Sie eine Spalte verschieben möchten, markieren Sie sie, indem Sie auf die Spaltenüberschrift klicken, und ziehen Sie sie dann an die gewünschte Stelle. Sie können auch mehrere zusammenhängende Spalten markieren und sie zusammen an eine andere Stelle verschieben.

      Wenn Sie der Tabelle weitere Felder hinzufügen möchten, haben Sie zwei Möglichkeiten: Sie können in der Datenblattansicht Eingaben in der Spalte Zum Hinzufügen klicken vornehmen, oder Sie können die Befehle verwenden, die es auf der Registerkarte Felder in der Gruppe Hinzufügen und Löschen gibt.

Erstellen einer Tabelle über die Entwurfsansicht    In der Entwurfsansicht erstellen Sie zunächst die Struktur der neuen Tabelle. Dann wechseln Sie entweder zur Datenblattansicht, um Daten einzugeben, oder Sie geben die Daten auf andere Weise ein, z. B. über ein Formular.

Hinweis : Die Entwurfsansicht ist für Tabellen einer Webdatenbank nicht verfügbar.

  1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Tabellen auf Tabellenentwurf. Schaltflächensymbol

  2. Geben Sie für jedes Feld in der Tabelle einen Namen in die Spalte Feldname ein, und wählen Sie dann einen Datentyp aus der Liste Datentyp aus.

  3. Sie können für jedes Feld zusätzliche Informationen in die Spalte Beschreibung eingeben. Die eingegebene Beschreibung wird in der Statusleiste angezeigt, wenn sich die Einfügemarke im entsprechenden Feld befindet. Sie wird außerdem als Statusleistentext für Steuerelemente verwendet, die Sie erstellen, indem Sie das Feld aus dem Bereich Feldliste auf ein Formular oder in einen Bericht ziehen, sowie für Steuerelemente, die mithilfe des Formular-Assistenten oder des Berichts-Assistenten für dieses Feld erstellt werden.

  4. Nachdem Sie alle Felder hinzugefügt haben, speichern Sie die Tabelle:

    • Klicken Sie auf der Registerkarte Datei auf Speichern.

  5. Sie können jederzeit mit der Dateneingabe beginnen, indem Sie zur Datenblattansicht wechseln, auf die erste leere Zelle klicken und Daten in die Tabelle eingeben. Sie können Daten auch aus einer anderen Quelle einfügen. Dieser Vorgang wird im nächsten Abschnitt beschrieben.

Erstellen einer auf einer SharePoint-Liste basierenden Tabelle    Mit einer SharePoint-Liste können Ihre Daten von Personen verwendet werden, die kein Access haben. Darüber hinaus sind die Listendaten auf einem Server gespeichert, wodurch grundsätzlich ein besserer Schutz vor Datenverlust gegeben ist als für Dateien, die auf einem Desktopcomputer gespeichert sind. Sie können entweder eine neue Liste oder eine Verknüpfung zu einer vorhandenen Liste erstellen. Sie müssen ausreichende Berechtigungen auf der SharePoint-Website haben, auf der Sie die Liste erstellen möchten. Die erforderlichen Berechtigungen können je nach Website unterschiedlich sein. Erfragen Sie die Details zu Ihren Optionen deshalb beim SharePoint-Administrator.

Hinweis : Dieses Feature ist nicht verfügbar in einer Webdatenbank.

  1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Tabellen auf SharePoint-Listen.

  2. Sie können eine der Listenvorlagen dazu verwenden, eine standardmäßige SharePoint-Liste zu erstellen (beispielsweise Kontakte oder Ereignisse).

    Sie können auch eine benutzerdefinierte Liste erstellen, mit einer vorhandenen Liste verknüpfen oder eine vorhandene Liste importieren. Klicken Sie auf die gewünschte Option.

  3. Wenn Sie eine der Listenvorlagen oder die Option zum Erstellen einer benutzerdefinierten Liste ausgewählt haben, werden Sie über das Dialogfeld Neue Liste erstellen durch den Vorgang geführt. Wenn Sie ausgewählt haben, eine vorhandene Liste zu verwenden, wird das Dialogfeld Externe Daten abrufengeöffnet.

Weitere Informationen zu Tabellen finden Sie im Artikel Einführung in Tabellen.

Seitenanfang

Einfügen von Daten in eine Access-Tabelle aus einer anderen Quelle

Falls Ihre Daten zurzeit in einem anderen Programm gespeichert sind, z. B. in Excel, können Sie die Daten kopieren und in eine Access-Tabelle einfügen. Im Allgemeinen funktioniert dies am besten, wenn Ihre Daten bereits in Spalten aufgeteilt sind, wie dies bei einem Excel-Arbeitsblatt der Fall ist. Falls sich Ihre Daten in einem Textverarbeitungsprogramm befinden, sollten Sie die Datenspalten zunächst mit Tabulatoren trennen oder die Daten im Textverarbeitungsprogramm in eine Tabelle konvertieren und die Daten erst dann kopieren. Falls Sie Ihre Daten bearbeiten möchten (z. B. vollständige Namen in Vor- und Nachnamen trennen), sollten Sie dies tun, bevor Sie die Daten kopieren, insbesondere, wenn Sie mit Access nicht vertraut sind.

Wenn Sie Daten in eine leere Tabelle einfügen, wird der Datentyp der einzelnen Felder in Access entsprechend den dort vorgefundenen Daten festgelegt. Wenn ein eingefügtes Feld z. B. nur Datumswerte enthält, wird auf dieses Feld der Datentyp Datum/Uhrzeit angewendet. Falls das eingefügte Feld nur die Wörter "ja" und "nein" enthält, wird auf das Feld der Datentyp Ja/Nein angewendet.

Access benennt die Felder mit den Elementen, die es in der ersten Zeile der eingefügten Daten findet. Wenn die erste Zeile der eingefügten Daten vom Typ her den nachfolgenden Zeilen ähnelt, wird die erste Zeile in Access als Teil der Daten festgelegt, und den Feldern werden generische Namen (Feld1, Feld2 usw.) zugeordnet. Falls die erste Zeile von eingefügten Daten nicht den nachfolgenden Zeilen ähnelt, geht Access so vor, dass es die Einträge der ersten Zeile als Feldnamen verwendet und die erste Zeile nicht in die tatsächlichen Daten aufnimmt.

Falls Access generische Feldnamen zuordnet, sollten Sie die Felder so bald wie möglich umbenennen, um Verwirrungen zu vermeiden. Verwenden Sie die folgende Prozedur:

  1. Klicken Sie auf der Registerkarte Datei auf Speichern, um die Tabelle zu speichern.

  2. Doppelklicken Sie in der Datenblattansicht auf jede Spaltenüberschrift, und geben Sie dann für die jeweilige Spalte einen Feldnamen ein.

  3. Speichern Sie die Tabelle erneut.

Seitenanfang

Importieren von oder Verknüpfen mit Daten aus einer anderen Quelle

Möglicherweise haben Sie in einem anderen Programm Daten gesammelt, die Sie in Access verwenden möchten. Es kann aber auch sein, dass Sie mit Personen zusammenarbeiten, die ihre Daten mit anderen Programmen speichern, und Sie möchten in Access mit diesen Daten arbeiten. Oder Sie haben mehrere getrennte Datenquellen und benötigen eine "Sammelstelle", in der Sie die Daten für umfassendere Analysen zusammenfassen können.

In Access ist es sehr einfach, Daten aus anderen Programmen zu importieren oder über Verknüpfen einzubinden. Sie können Daten aus einem Excel-Arbeitsblatt, aus einer Tabelle in einer anderen Access-Datenbank, aus einer SharePoint-Liste oder aus einer Reihe anderer Quellen importieren. Die Vorgehensweise ist je nach Datenquelle etwas unterschiedlich, doch mit den folgenden Anweisungen können Sie den Vorgang beginnen:

  1. Klicken Sie auf der Registerkarte Externe Daten in der Gruppe Importieren und Verknüpfen auf den Befehl für den Typ der Datei, aus der Sie importieren möchten.

    Wenn Sie beispielsweise Daten aus einem Excel-Arbeitsblatt importieren, klicken Sie auf Excel. Wenn der korrekte Programmtyp nicht angezeigt wird, klicken Sie auf Weiter.

    Hinweis : Wenn Sie den richtigen Formattyp in der Gruppe Importieren und verknüpfen finden können, müssen Sie starten Sie das Programm, in dem Sie die Daten ursprünglich erstellt, und verwenden Sie das Programm dann zum Speichern der Daten in einem Dateiformat, das Access (beispielsweise einer Textdatei mit Trennzeichen ) unterstützt, und klicken Sie dann auf Importieren oder Verknüpfen mit den Daten.

  2. Klicken Sie im Dialogfeld Externe Daten entweder auf Durchsuchen, um zur Quelldatendatei zu wechseln, oder geben Sie in das Feld Dateiname den vollständigen Pfad der Quelldatendatei ein.

  3. Klicken Sie unter Geben Sie an, wie und wo Sie die Daten in der aktuellen Datenbank speichern möchten auf die gewünschte Option. Sie können mithilfe der importierten Daten eine neue Tabelle oder eine verknüpfte Tabelle erstellen, die eine Verknüpfung zur Datenquelle enthält.

  4. Klicken Sie auf OK.

    Je nachdem, welche Option Sie ausgewählt haben, wird das Dialogfeld zum Verknüpfen von Objekten oder zum Importieren von Objekten geöffnet.

  5. Schließen Sie den Vorgang im Dialogfeld ab. Die genaue Vorgehensweise hängt von der gewählten Import- oder Verknüpfungsoption ab.

  6. Klicken Sie auf der letzten Seite des Assistenten auf Fertig stellen.

    Wenn Sie die Option zum Importieren ausgewählt haben, werden Sie von Access gefragt, ob die Details des gerade abgeschlossenen Importvorgangs gespeichert werden sollen.

  7. Wenn Sie vermuten, dass Sie denselben Importvorgang in Zukunft erneut ausführen werden, klicken Sie auf Importschritte speichern, und geben Sie die Einzelheiten ein.

    Sie können dann den Importvorgang problemlos reproduzieren, indem Sie auf Importschritte speichern in der Gruppe Importieren auf der Registerkarte Externe Daten klicken. Anschließend klicken Sie auf die Importspezifikation und dann auf Ausführen.

  8. Wenn die Vorgangsdetails nicht gespeichert werden sollen, klicken Sie auf Schließen.

Access importiert die Daten in eine neue Tabelle und zeigt die Tabelle dann im Navigationsbereich unter Tabellen an.

Folgen Sie den Hyperlinks im Abschnitt Siehe auch dieses Artikels, um weitere Informationen zum Importieren von Daten in Access zu erhalten.

Seitenanfang

Weitere Schritte

Welche weiteren Entwurfsschritte Sie ausführen, hängt von Ihren Zielen ab. Möglicherweise möchten Sie Abfragen, Formulare, Berichte und Makros erstellen. Dieser Artikel enthält keine Informationen, wie solche Datenbankobjekte erstellt werden.

Weitere Informationen hierzu finden Sie in folgenden Artikeln:

Seitenanfang

Importieren von Daten aus einer Tabellenkalkulation oder aus einem anderen Programm

Wenn Sie sich mit anderen Datenbank- oder Tabellenkalkulationsprogrammen auskennen, verfügen Sie wahrscheinlich über grundlegende Kenntnisse zur Funktionsweise dieser Anwendungen und zu den Verwendungsmöglichkeiten von Datenbanken. Access unterscheidet sich von vielen anderen Datenbankanwendungen dadurch, dass Sie die Möglichkeit zum Erstellen relationaler Datenbanken erhalten. Ein weiterer Unterschied zu Tabellenkalkulationsprogrammen besteht in den bereitstehenden Tools zum Entwickeln komplexer Abfragen, Formulare und Berichte. Access stellt außerdem zahlreiche Optionen für die Arbeit mit anderen Datenbankprogrammen, wie z. B. SQL Server, zur Verfügung.

Importieren eines Excel-Arbeitsblatts in Access

Viele Benutzer fangen erst an, die Möglichkeiten zu erkunden, die Access bietet, nachdem sie bereits eine Liste in Excel erstellt haben. Excel ist zum Anlegen einer Liste gut geeignet, aber je umfangreicher die Liste wird, desto schwieriger wird es, sie zu organisieren und auf dem aktuellen Stand zu halten. Die Liste nach Access zu verschieben, ist i. A. der nächste logische Schritt.

Eine Datenbanktabelle ist ähnlich wie ein Arbeitsblatt strukturiert, d. h. Daten werden in Zeilen und Spalten gespeichert. Somit ist der Import eines Arbeitsblatts in eine Datenbanktabelle in der Regel problemlos möglich. Der Hauptunterschied zwischen dem Speichern von Daten in einem Arbeitsblatt und dem Speichern von Daten in einer Datenbank besteht in der Art und Weise, wie die Daten organisiert werden. Das gesamte Arbeitsblatt einfach als neue Tabelle in eine Datenbank zu importieren, löst die Probleme in Bezug auf das Organisieren und Aktualisieren der Daten nicht, insbesondere, wenn das Arbeitsblatt nicht erforderliche Daten enthält. Zum Lösen dieser Probleme müssen Sie die Daten der Tabellenkalkulation in separate Tabellen aufteilen, wobei jede Tabelle verknüpfte Daten enthält. Weitere Informationen zum Anordnen von Daten in Ihren Tabellen finden Sie im Artikel Grundlagen des Datenbankentwurfs.

Access enthält den Tabellenanalyse-Assistenten, der Sie bei diesem Vorgang unterstützen kann. Nachdem die Daten in eine Tabelle importiert wurden, hilft der Assistent dabei, die Tabelle in separate Tabellen zu unterteilen, wobei jede Tabelle Daten enthält, die nicht in den anderen Tabellen dupliziert werden. Der Assistent erstellt außerdem die erforderlichen Beziehungen zwischen den Tabellen.

Seitenanfang

Importieren eines Excel-Arbeitsblatts in eine neue Datenbank als Tabelle

  1. Klicken Sie auf der Registerkarte Datei auf Neu, und klicken Sie dann auf Leere Datenbank.

  2. Geben Sie in das Feld Dateiname einen Namen für die neue Datenbank ein, und klicken Sie dann auf Erstellen.

    Die neue Datenbank wird geöffnet, und Access erstellt die neue leere Tabelle Tabelle1.

  3. Schließen Sie Tabelle 1.

    Wenn Sie gefragt werden, ob die Änderungen am Entwurf von Tabelle 1 geändert werden sollen, klicken Sie auf Nein.

  4. Klicken Sie auf der Registerkarte Externe Daten in der Gruppe Importieren und Verknüpfen auf Excel. Schaltflächensymbol

  5. Klicken Sie im Dialogfeld Externe Daten auf Durchsuchen.

  6. Verwenden Sie das Dialogfeld Datei öffnen, um die Datei zu suchen.

  7. Wählen Sie die Datei aus, und klicken Sie auf Öffnen.

  8. Vergewissern Sie sich, dass im Dialogfeld Externe Daten die Option Importieren Sie die Quelldaten in eine neue Tabelle in der aktuellen Datenbank aktiviert ist.

  9. Klicken Sie auf OK.

    Der Import-Assistent für Kalkulationstabellen wird aufgerufen und stellt einige Fragen zu den Daten.

  10. Befolgen Sie die Anweisungen, und klicken Sie jeweils auf Weiter bzw. auf Zurück, um durch die Seiten zu navigieren. Klicken Sie auf der letzten Seite des Assistenten auf Fertig stellen.

    Hinweis : Sie werden gefragt, ob die Details des gerade abgeschlossenen Importvorgangs gespeichert werden sollen. Wenn Sie vermuten, dass Sie denselben Importvorgang in Zukunft erneut ausführen werden, klicken Sie auf Ja, und geben Sie die Einzelheiten ein. Sie können den Vorgang dann in Zukunft problemlos wiederholen, indem Sie auf der Registerkarte Importieren in der Gruppe Externe Daten auf Gespeicherte Importe klicken. Wenn die Vorgangsdetails nicht gespeichert werden sollen, klicken Sie auf Schließen.

Access importiert die Daten in eine neue Tabelle und zeigt sie dann im Navigationsbereich unter Alle Tabellen an.

Seitenanfang

Verwenden des Tabellenanalyse-Assistenten zum Organisieren der Daten

Wenn die Daten in eine Access-Tabelle importiert wurden, können Sie redundante Daten schnell mithilfe des Tabellenanalyse-Assistenten identifizieren. Der Assistent bietet dann eine einfache Möglichkeit, die sich wiederholenden Daten in separaten Tabellen zu organisieren, damit sie auf möglichst effiziente Weise gespeichert werden. Access bewahrt die ursprüngliche Tabelle als Sicherung auf und erstellt dann neue Tabellen, die Sie als Grundlage für die Datenbankanwendung verwenden können.

  1. Öffnen Sie die Access-Datenbank, die die zu analysierende Tabelle enthält.

  2. Klicken Sie auf der Registerkarte Datenbanktools in der Gruppe Analysieren auf Tabelle analysieren.

    Der Tabellenanalyse-Assistent wird gestartet.

    Die beiden ersten Seiten des Assistenten enthalten ein kurzes Lernprogramm samt Schaltflächen, auf die Sie klicken können, um Beispiele anzuzeigen. Wenn anstelle der Einführungsseiten das Kontrollkästchen Einführungsseiten anzeigen? angezeigt wird, aktivieren Sie dieses Kontrollkästchen, und klicken Sie dann zweimal auf Zurück, damit die Einführung angezeigt wird. Wenn die Einführungsseiten in Zukunft nicht mehr angezeigt werden sollen, nachdem Sie die Einführung gelesen haben, können Sie das Kontrollkästchen Einführungsseiten anzeigen? wieder deaktivieren.

  3. Wählen Sie auf der Seite Welche Tabelle enthält Felder mit Werten, die in vielen Datensätzen wiederholt werden? die Tabelle aus, die analysiert werden soll, und klicken Sie dann auf Weiter.

  4. Sie können die Entscheidung, welche Felder in welcher Tabelle gespeichert werden sollen, dem Assistenten überlassen oder selbst treffen. Wenn Sie die Vorschläge des Assistenten akzeptieren, können Sie das Tabellenlayout auf der nächsten Seite des Assistenten immer noch ändern.

    Hinweis : Wenn Sie den Assistenten entscheiden lassen, welche Felder in welcher Tabelle abgelegt werden, kann es sein, dass die Ergebnisse für die speziellen Daten nicht immer angemessen sind, insbesondere, wenn die Datenmenge gering ist. Sie sollten die Ergebnisse des Assistenten immer sorgfältig prüfen. Auf der anderen Seite sind die Vorschläge des Assistenten jedoch möglicherweise effizienter als die von Ihnen geplante Anordnung, daher ist es sinnvoll, den Assistenten zumindest einmal auszuprobieren. Wenn Ihnen die Vorschläge nicht gefallen, können Sie die Felder immer noch manuell neu anordnen, und Sie können jederzeit auf Zurück klicken und alle Felder selbst anordnen.

  5. Klicken Sie auf Weiter. Auf dieser Seite geben Sie an, welche Tabellen welche Felder enthalten. Wenn Sie diese Entscheidung dem Assistenten überlassen, sollten mehrere Tabellen angezeigt werden, die durch Beziehungslinien miteinander verbunden sind. Andernfalls erstellt Access nur eine Tabelle, die alle Felder enthält. In jedem Fall können Sie auf dieser Seite Änderungen vornehmen.

    • Sie können Felder aus einer Tabelle in einen leeren Bereich der Seite ziehen, um eine neue Tabelle zu erstellen, die diese Felder enthält. Sie werden aufgefordert, einen Tabellennamen einzugeben.

    • Sie können Felder von einer Tabelle zu einer anderen ziehen, wenn Sie der Ansicht sind, dass die Felder dort effizienter gespeichert werden.

    • Den meisten Tabellen wird ein ID-Feld oder ein Feld des Typs Generierte eindeutige Kennnummer zugewiesen. Weitere Informationen zu ID-Feldern erhalten Sie, wenn Sie in der rechten oberen Ecke des Assistenten auf Tipps klicken.

    • Klicken Sie auf die Schaltfläche Rückgängig, um eine Änderung rückgängig zu machen.

    • Wenn Sie eine Tabelle umbenennen möchten, doppelklicken Sie auf die Titelleiste der Tabelle, geben Sie den neuen Namen ein, und klicken Sie dann auf OK.

  6. Wenn Sie die Felder wie gewünscht angeordnet haben, klicken Sie auf Weiter.

  7. Wenn der Assistent Datensätze mit sehr ähnlichen Werten findet, werden diese Werte als mögliche Rechtschreibfehler identifiziert, und es wird ein Bildschirm angezeigt, auf dem Sie die weitere Vorgehensweise bestätigen können. Blättern Sie durch die Liste, um alle Einträge mit Daten in der Spalte Korrektur zu finden, und klicken Sie dann auf das entsprechende Element in der Dropdownliste. Aktivieren Sie die Option (Beibehalten), damit der Assistent keine Änderungen am Wert vornimmt. Klicken Sie auf Weiter, wenn Sie fertig sind.

  8. Sie werden gefragt, ob Sie eine Abfrage erstellen möchten, die der ursprünglichen Tabelle ähnelt. Wenn Sie bereits Formulare und Berichte basierend auf der ursprünglichen Tabelle erstellt haben, ist das Erstellen einer solchen Abfrage ein sinnvoller Schritt. Wenn Sie Eine Abfrage erstellen wählen, benennt der Assistent die ursprüngliche Tabelle um, indem dem Tabellennamen die Endung _OLD angefügt wird, und weist der neuen Abfrage dann den Namen der ursprünglichen Tabelle zu. Die auf dieser Tabelle basierenden Formulare und Berichte verwenden nun die Abfrage für ihre Daten und funktionieren wie zuvor.

  9. Klicken Sie auf Fertig stellen.

    Die neuen Tabellen werden wie angegeben im Assistenten erstellt und dann geöffnet. Wenn Sie die Ergebnisse überprüft haben, schließen Sie die Tabellen.

Seitenanfang

Arbeiten mit Daten aus anderen Programmen

Access 2010 enthält Features für die Arbeit mit Daten, die in anderen Programmen gespeichert sind.

Erstellen einer neuen Access-Datenbank mit Verknüpfungen zu Daten in anderen Dateiformaten    Sie können mit Access Dateien öffnen, die andere Dateiformate haben, beispielsweise Text-, dBASE- oder Tabellenkalkulationsdateien. Access erstellt automatisch eine Access-Datenbank und verknüpft die jeweilige Datei.

  1. Starten Sie Access.

  2. Klicken Sie auf der Registerkarte Datei auf Öffnen.

  3. Klicken Sie im Dialogfeld Öffnen auf den Dateityp, der in der Liste geöffnet werden soll. Wenn Sie nicht sicher sind, welcher Dateityp der Richtige ist, klicken Sie auf Alle Dateien (*.*).

  4. Wechseln Sie ggf. zu dem Ordner, der die zu öffnende Datei enthält. Öffnen Sie die Datei, indem Sie darauf doppelklicken.

  5. Folgen Sie den Anweisungen des Assistenten. Klicken Sie auf der letzten Seite des Assistenten auf Fertig stellen.

Importieren oder Verknüpfen von Daten in eine bzw. mit einer vorhandenen Access-Datenbank    Sie können Daten entweder aus anderen Quellen und Programmen in Access-Tabellen importieren, damit die Daten in der Access-Datei enthalten sind, oder Sie können eine Verknüpfung zwischen Access und den Daten erstellen, sodass die Daten in der ursprünglichen Datei bleiben (außerhalb der Access-Datei).

  1. Klicken Sie auf der Registerkarte Externe Daten in der Gruppe Importieren und Verknüpfen auf das Format, in dem die Daten gespeichert sind.

    Daten, die importiert oder mit denen verknüpft werden soll, können aus folgenden Quellen stammen:

    • Excel    Sie können Daten aus einem Arbeitsblatt oder aus einem benannten Bereich einer Excel-Arbeitsmappe einbinden. Jedes Arbeitsblatt bzw. jeder benannte Bereich muss einzeln importiert oder verknüpft werden.

    • Access    Eine solche Quelle ist sehr nützlich für das Trennen von Verarbeitung und Daten, wodurch eine geteilte Datenbank erstellt wird. Das heißt, eine Datenbank enthält alle Formulare, Berichte und Makros, und eine andere Datenbank enthält die Daten. Dadurch haben Sie die Möglichkeit, Verbesserungen zu entwickeln, ohne die Arbeit anderer Personen zu unterbrechen. Außerdem können Sie Daten aus vielen unterschiedlichen Access-Datenbanken zusammenfassen, wodurch das Summieren von Daten quer durch Abteilungen und zwischen Geschäftspartnern vereinfacht wird.

    • ODBC-Datenbank    Viele Programme unterstützen dieses Format (so auch viele Datenbankserverprodukte). Daher ist das Format geeignet, als "Sammelstellen" fungierende Datenbanken zu erstellen, in denen Daten aus verschiedenen Systemen kombiniert werden.

    • Textdatei    Sie können eine Verbindung mit einer einfachen Textdatei herstellen, und Sie können Access sogar dazu verwenden, den Inhalt dieser Datei zu ändern. Auf diese Weise können Access-Daten für eine breite Palette von Programmen bereitgestellt werden.

    • XML-Datei    Auch dieses Format bietet Kompatibilität mit vielen anderen Programmen (dazu gehören auch einige Webserver).

    • SharePoint-Liste    Über eine solche Liste können Ihre Daten mit einem Webbrowser verwendet werden. Dies ist die standardmäßige Art zur Verwendung einer SharePoint-Liste.

    • Datendienste    Sie können Verbindungen mit Webdatendiensten in Ihrem Unternehmen herstellen.

    • HTML-Dokument   

    • Outlook-Ordner    Sie können Verbindungen mit Outlook-Ordnern herstellen und so Ihre Kontaktdaten einfacher in Ihre anderen Daten integrieren.

    • dBase-Datei    dBase ist ein weit verbreitetes alternatives Datenbanksystem, das von Access unterstützt wird.

      Das Dialogfeld Externe Daten wird geöffnet.

  2. Folgen Sie den Anweisungen im Dialogfeld.

    Access importiert die Daten in die Datenbank oder erstellt die Verknüpfung mit der Datenbank. Bei den meisten Formaten müssen Sie den Speicherort der Daten angeben und dann wählen, wie die Daten in der Datenbank gespeichert werden sollen.

Seitenanfang

Verwenden einer früheren Datenbankversion in mehreren Access-Versionen

Wenn die Access-Datenbank oder das Access-Projekt in Access 2000 oder einer aktuelleren Version erstellt wurde, können Sie mit der Datenbank bzw. mit dem Projekt in der zum Erstellen verwendeten Access-Version oder in einer späteren Version arbeiten, und zwar selbst dann, wenn für diese Datei die Sicherheit aktiviert ist. Beispielsweise können Access 2000-Dateien in Access 2000, Access 2002, Access 2003, Access 2007 und Access 2010 verwendet werden.

Möglicherweise möchten Sie in einer bestimmten Situation Ihre Daten in einer früheren Version von Access beibehalten, aber einige Ihrer Benutzer besitzen eine spätere Version von Access, die eine Verbindung zu diesen Daten herstellen möchten und dennoch die Vorteile von Features der späteren Version nutzen. In einem solchen Falle empfiehlt es sich, eine "Front-End"-Datenbank in der späteren Version zu erstellen (die Formulare, Berichte, Abfragen, Makros, aber keine Tabellen enthält), um diese mit den Tabellen in der früheren Dateiversion zu verbinden. Verwenden Sie eine der folgenden Prozeduren, abhängig davon, ob Ihre Datenbank in einer Datei enthalten oder bereits in eine Front-End-/Back-End-Anwendung gespalten ist.

Verwenden einer Access-Datenbankdatei in verschiedenen Versionen von Access

Wenn alle Tabellen, Formulare und anderen Objekte Ihrer Access-Datenbank aus einer früheren Version in einer Datei enthalten sind und Sie die Datenbank in mehreren Access-Versionen verwenden möchten, können Sie eine neue Front-End-Datenbank in einer späteren Version erstellen und diese mit der ursprünglichen Datei verknüpfen. Benutzer, die die frühere Version von Access verwenden, können die ursprüngliche Datenbank weiterhin versenden. Benutzer der späteren Version können die neue Front-End-Datenbank verwenden, um eine Verknüpfung zu denselben Daten zu erstellen. Sie können mehrere Front-End-Versionen erstellen, wenn Sie eine Anpassung an mehrere Versionen von Access benötigen.

Seitenanfang

Schritt 1: Erstellen einer Kopie der vorhandenen Datenbank und Speichern der Kopie in einem anderen Format

Verwenden Sie den folgenden Vorgang, um die Datenbank in eine der drei zuletzt verwendeten Formate zu konvertieren: Access 2000, Access 2002-2003 oder Access 2007. Mit diesem Befehl wird das ursprüngliche Format der ursprünglichen Datenbank beibehalten und eine Kopie im angegebenen Format erstellt.

  1. Schließen Sie die Access-Datei. Falls es sich bei der Datei um eine Mehrbenutzer-Access-Datenbank auf einem Server oder in einem freigegebenen Ordner handelt, stellen Sie sicher, dass kein anderer Benutzer diese Datenbank geöffnet hat.

  2. Starten Sie Access2010.

  3. Klicken Sie auf der Registerkarte Datei auf Öffnen.

  4. Navigieren Sie zum Speicherort der Datei, die Sie konvertieren möchten, und öffnen Sie die Datei, indem Sie darauf doppelklicken.

    Hinweis : Wenn das Dialogfeld Datenbankverbesserung geöffnet wird, in dem Sie gefragt werden, ob Sie die Datenbank verbessern möchten, klicken Sie auf Nein.

  5. Wenn beim Starten der Datenbank ein Formular geöffnet wird, schließen Sie dieses Formular.

  6. Klicken Sie auf der Registerkarte Datei auf Datenbank speichern als.

  7. Geben Sie im Dialogfeld Speichern unter einen Namen für die neue Datenbank ein.

    Hinweis : Sofern Sie die neue Datenbank nicht an einer anderen Stelle speichern, muss sie einen anderen Namen als die ursprüngliche Datenbank haben. Es ist i. A. auf jeden Fall besser, einen anderen Namen zu verwenden, um problemlos zwischen der Front-End- und der Back-End-Datenbank unterscheiden zu können. Wenn Sie jedoch in das Access 2007-Format konvertieren, wird die Dateinamenerweiterung von MDB zu ACCDB geändert, sodass Sie denselben Dateinamen verwenden können.

  8. Klicken Sie auf Speichern.

Seitenanfang

Schritt 2: Teilen der kopierten Datenbank und Verwenden der ursprünglichen Datei als Back-End-Datenbank

Teilen Sie die konvertierte Datenbank, indem Sie folgende Schritte ausführen:

  • Klicken Sie auf der Registerkarte Datenbanktools in der Gruppe Daten verschieben auf Access-Datenbank.Schaltflächensymbol

  • Klicken Sie im Dialogfeld Assistent zur Datenbankaufteilung auf Datenbank aufteilen.

    Hinweis : Sie können eine Sicherung erstellen, Sie können aber auch einfach erneut ein Kopie von der ursprünglichen Datenbank erstellen.

  • Geben Sie einen Namen für die Back-End-Datenbank ein, und klicken Sie auf Teilen.

Seitenanfang

Schritt 3: Verbinden der neuen Front-End- mit der ursprünglichen Datenbank

  1. Löschen Sie die Back-End-Datenbank, die vom Assistenten zur Datenbankaufteilung erstellt wurde. Achten Sie darauf, dass Sie nicht die ursprüngliche Datenbank löschen. 

  2. Verknüpfen Sie die neue Front-End-Datenbank mit den Tabellen der ursprünglichen Datenbank: Klicken Sie auf der Registerkarte Externe Daten in der Gruppe Importieren und Verknüpfen auf Tabellenverknüpfungs-Manager. Schaltflächensymbol

  3. Klicken Sie auf Alle auswählen, und aktivieren Sie dann das Kontrollkästchen Neuen Speicherort immer bestätigen lassen.

  4. Klicken Sie auf OK, navigieren Sie zur Datenbank der früheren Version, und doppelklicken Sie dann darauf.

    Bei erwartungsgemäßem Ablauf wird in Access eine Meldung angezeigt, die angibt, dass alle ausgewählten verknüpften Tabellen erfolgreich aktualisiert wurden.

Sie können nun die neue Front-End-Datenbank so erweitern, dass sie neue Features für die Benutzer unterstützt, die neuere Versionen von Access haben. Benutzer, die mit früheren Versionen arbeiten, können weiterhin die Datenbank der früheren Version verwenden.

Seitenanfang

Verwenden einer Front-End-/Back-End-Anwendung in verschiedenen Versionen von Access

Wenn Ihre Access-Datenbank bereits ein Front-End-/Back-End-Anwendung ist, können Sie die front-End in das neue Dateiformat konvertieren. Keine Änderungen sind für die Back-End-Datenbank erforderlich.

In der folgenden Prozedur wird die Verwendung des Befehls Datenbank in anderem Format speichern veranschaulicht, um die Front-End-Datenbank in eines der drei aktuellen Formate zu konvertieren: Access 2000, Access 2002-2003 oder Access 2007. Mit diesem Befehl wird das ursprüngliche Format der ursprünglichen Datenbank beibehalten und eine Kopie im angegebenen Format erstellt.

  1. Schließen Sie die Front-End-Datenbank. Falls es sich bei der Datei um eine Mehrbenutzer-Access-Datenbank auf einem Server oder in einem freigegebenen Ordner handelt, stellen Sie sicher, dass kein anderer Benutzer diese Datenbank geöffnet hat.

  2. Starten Sie Access2010.

  3. Klicken Sie auf der Registerkarte Datei auf Öffnen.

  4. Navigieren Sie zum Speicherort der Front-End-Datenbank, und öffnen Sie sie, indem Sie darauf doppelklicken.

    Hinweis : Wenn das Dialogfeld Datenbankverbesserung geöffnet wird, in dem Sie gefragt werden, ob Sie die Datenbank verbessern möchten, klicken Sie auf Nein.

  5. Wenn beim Öffnen der Datenbank ein Formular angezeigt wird, schließen Sie dieses Formular.

  6. Klicken Sie auf der Registerkarte Datei auf Datenbank speichern als.

  7. Geben Sie im Dialogfeld Speichern unter einen Namen für die neue Datenbank ein.

  8. Klicken Sie auf Speichern.

Sie können nun die neue Front-End-Datenbank so erweitern, dass sie neue Features unterstützt.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.



War diese Information hilfreich?

Wie können wir es verbessern?

Wie können wir es verbessern?

Um Ihre Privatsphäre zu schützen, geben Sie bitte keine Kontaktinformationen in Ihrem Feedback an. Lesen Sie unsere Datenschutzbestimmung.

Vielen Dank für Ihr Feedback!