Grundlegende Aufgaben in Access 2010

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Im folgenden finden Sie einige grundlegende Datenbankaufgaben, die Ihnen beim Erlernen der Verwendung von Microsoft Access 2010 helfen können.

 

Inhalt dieses Artikels

Was ist Access?

Relationale Datenbanken in Access

Wenn Sie Access öffnen

Suchen und Anwenden einer Vorlage

Erstellen einer neuen Datenbank

Öffnen einer vorhandenen Access-Datenbank

Erste Schritte mit der Verwendung der neuen Datenbank

Hinzufügen einer Tabelle

Einfügen von Daten aus einer anderen Quelle in eine Access-Tabelle

Importieren oder Verknüpfen von Daten aus einer anderen Quelle

Nächste Schritte

Importieren von Daten aus einer Kalkulationstabelle oder einem anderen Programm

Importieren eines Excel-Arbeitsblatts in Access

Importieren eines Excel-Arbeitsblatts als Tabelle in einer neuen Datenbank

Verwenden des Tabellenanalyse-Assistenten zum Organisieren von Daten

Arbeiten mit Daten aus anderen Programmen

Verwenden einer Datenbank einer früheren Version in mehreren Access-Versionen

Verwenden einer Access-Datenbankdatei in mehreren Access-Versionen

Schritt 1: Erstellen einer Kopie der vorhandenen Datenbank und speichern in einem neuen Format

Schritt 2: aufTeilen der Kopier Datenbank und Verwenden der ursprünglichen Datei als Back-End-Datenbank

Schritt 3: Verbinden des neuen Front-End mit der ursprünglichen Datenbank

Verwenden einer Front-End/Back-End-Anwendung in mehreren Access-Versionen

Was ist Access?

Access 2010 ist ein Tool zum Entwerfen und Bereitstellen von Datenbankanwendungen , mit dem Sie wichtige Informationen nachverfolgen können. Sie können Ihre Daten auf Ihrem Computer speichern oder im Web veröffentlichen, damit andere Personen Ihre Datenbank mit einem Webbrowser verwenden können.

Viele Personen beginnen mit der Verwendung von Access, wenn das Programm, das Sie verwenden, um etwas nachverfolgen zu können, für die Aufgabe allmählich schlechter ist. Nehmen Sie beispielsweise an, dass Sie ein Ereignisplaner sind, und Sie alle Details verfolgen möchten, die Sie verwalten müssen, um Ihre Ereignisse erfolgreich zu gestalten. Wenn Sie eine Textverarbeitungs-oder Tabellenkalkulationsanwendung dazu verwenden, können Sie problemlos mit doppelten und inkonsistente Daten auftreten. Sie können die Kalender Software verwenden, aber die Nachverfolgung von Finanzinformationen in einem Kalender ist nicht gut geeignet.

Relationale Datenbanken in Access

Manchmal benötigen Sie eine relationale Datenbank, um solche Informationen zu überwachen – ein Lagerhaus mit Daten, das in kleinere Datensammlungen (so genannte Tabellen) aufgeteilt wurde, um Redundanz zu eliminieren, und dann auf der Grundlage allgemeiner Informationsbits (so genannte Felder) zusammenhängen. . So kann beispielsweise eine relationale Ereignis Planungsdatenbank eine Tabelle mit Kundeninformationen, eine Tabelle mit Lieferanteninformationen und eine Tabelle mit Ereignisinformationen enthalten. Die Tabelle mit den Ereignisinformationen kann über ein Feld verfügen, das Sie mit der Tabelle "Kunden" verknüpft, und ein Feld, das Sie mit der Vendor-Tabelle in Beziehung setzen soll. Wenn beispielsweise die Telefonnummer eines Kreditors geändert wurde, können die Informationen einmal in der Tabelle "Vendor" und nicht in jedem Fall geändert werden, an dem der Kreditor beteiligt war.

Access ist ein Tool, mit dem Sie relationale Datenbankanwendungen schnell und einfach entwickeln können, die Ihnen bei der Verwaltung von Informationen helfen. Sie können eine Datenbank erstellen, um Ihnen dabei zu helfen, fast jede Art von Informationen wie Inventar, professionelle Kontakte oder Geschäftsprozesse nachzuverfolgen. In der Tat bietet Access Vorlagen, die Sie sofort verwenden können, um eine Vielzahl von Informationen zu überwachen, was auch für Anfänger einfach ist.

Wenn Sie Access öffnen

Wenn Sie Access 2010 starten, sehen Sie die Microsoft Office Backstage-Ansicht, in der Sie Informationen zur aktuellen Datenbank abrufen, eine neue Datenbank erstellen, eine vorhandene Datenbank öffnen und die vorgestellten Inhalte von Office.com anzeigen können.

Backstage-Ansicht von Access 2010

Die Backstage-Ansicht enthält auch viele andere Befehle, mit denen Sie Ihre Datenbanken anpassen, verwalten oder freigeben können. Befehle in der Backstage-Ansicht gelten in der Regel für ganze Datenbanken und nicht für Objekte innerhalb einer Datenbank.

Hinweis: Sie können die Backstage-Ansicht jederzeit aufrufen, indem Sie auf die Registerkarte Datei klicken.

Seitenanfang

Suchen und Anwenden einer Vorlage

Access bietet Ihnen eine Vielzahl von Vorlagen, mit denen Sie den Daten Bank Erstellungsprozess beschleunigen können. Eine Vorlage ist eine Ready-to-use-Datenbank, die alle Tabellen, Abfragen, Formulare und Berichte enthält, die für die Ausführung einer bestimmten Aufgabe erforderlich sind. Es gibt beispielsweise Vorlagen, die verwendet werden können, um Probleme nachzuverfolgen, Kontakte zu verwalten oder eine Aufzeichnung der Ausgaben zu führen. Einige Vorlagen enthalten einige Beispieldatensätze, die Ihnen helfen, deren Verwendung zu veranschaulichen. Vorlagendatenbanken können wie bestehend verwendet werden, oder Sie können Sie anpassen, damit Sie Ihren Anforderungen besser entsprechen.

Gehen Sie wie folgt vor, um eine Vorlage zu suchen und auf Ihre Datenbank anzuwenden:

  1. Klicken Sie auf der Registerkarte Datei auf Neu.

  2. Führen Sie unter verfügbare Vorlageneine der folgenden Aktionen aus:

    • Wenn Sie eine Vorlage wieder verwenden möchten, die Sie zuletzt verwendet haben, klicken Sie auf zuletzt verwendete Vorlagen, und wählen Sie dann die gewünschte Vorlage aus.

    • Wenn Sie eine Vorlage verwenden möchten, die Sie bereits installiert haben, klicken Sie auf Meine Vorlagen, und wählen Sie dann die gewünschte Vorlage aus.

    • Wenn Sie eine Vorlage auf Office.com suchen möchten, klicken sie unter Office.com-Vorlagenauf eine Vorlagenkategorie, wählen Sie die gewünschte Vorlage aus, und klicken Sie dann auf herunterladen , um die Vorlage von Office. com auf Ihren Computer herunterzuladen.

      Sie können auch in Access nach Vorlagen auf Office.com suchen. Geben Sie im Feld Office.com für Vorlagen suchen einen oder mehrere Suchbegriffe ein, und klicken Sie dann auf die Pfeilschaltfläche, um zu suchen.

  3. Optional können Sie auf das Ordnersymbol neben dem Feld Dateiname klicken, um zu dem Speicherort zu navigieren, an dem Sie die Datenbank erstellen möchten. Wenn Sie keinen bestimmten Speicherort angeben, erstellt Access die Datenbank am Standardspeicherort, der unterhalb des Felds Dateiname angezeigt wird.

  4. Klicken Sie auf Erstellen.

Access erstellt die Datenbank und öffnet Sie für die Verwendung.

Seitenanfang

Erstellen einer neuen Datenbank

Wenn Sie eine gründlichere Einführung in die Konzepte für die Verwendung von Access zum Erstellen einer Datenbank benötigen, lesen Sie den Artikel Grundlagen des Datenbankentwurfs.

Wenn keine der Vorlagen Ihren Anforderungen entspricht oder wenn Sie über Daten in einem anderen Programm verfügen, das Sie in Access verwenden möchten, können Sie entscheiden, dass es besser ist, eine Datenbank von Grund auf neu zu erstellen. In Access 2010 haben Sie die Wahl: eine Standard-Desktopdatenbank oder eine Webdatenbank.

Weitere Informationen zu Webdatenbanken finden Sie im Artikel Erstellen einer Datenbank, die im Web freigegeben werden soll.

Gehen Sie wie folgt vor, um eine neue Datenbank zu erstellen:

  1. Starten Sie Access.

  2. Klicken Sie in der Backstage-Ansicht auf der Registerkarte neu auf leere Datenbank oder leere Webdatenbank.

    Wichtig: Die hier vorgenommene Auswahl bestimmt, welche Features in der Datenbank zur Verfügung stehen. Desktopdatenbanken können nicht im Web veröffentlicht werden, und Webdatenbanken unterstützen einige Desktop Features wie Summenabfragen nicht.

  3. Geben Sie auf der rechten Seite im Feld Dateiname einen Namen für die Datenbank ein.

    Wenn Sie den Speicherort ändern möchten, an dem Sie die Datei erstellen, klicken Sie neben dem Feld Dateiname auf Schaltflächensymbol Durchsuchen, navigieren Sie zu dem neuen Speicherort, wählen Sie ihn aus, und klicken Sie dann auf OK.

  4. Klicken Sie auf Erstellen.

    Access erstellt die Datenbank und öffnet dann in Datenblattansicht eine leere Tabelle (mit dem Namen Tabelle1).

  5. Access platziert den Cursor in der ersten leeren Zelle in der Spalte zum Hinzufügen von klicken in der neuen Tabelle.

    Wenn Sie Daten hinzufügen möchten, beginnen Sie mit der Eingabe – oder Sie können Daten aus einer anderen Quelle einfügen, wie im Abschnitt Einfügen von Daten aus einer anderen Quelle in eine Access-Tabelleweiter unten in diesem Artikel beschrieben.

    Hinweise: 

    • Das Eingeben von Daten in der Datenblattansicht ist mit der Eingabe von Daten in einem Excel-Arbeitsblatt vergleichbar. Die wichtigste Einschränkung besteht darin, dass Daten in zusammenhängenden Zeilen und Spalten beginnend in der oberen linken Ecke des Datenblatts eingegeben werden müssen. Versuchen Sie nicht, Ihre Daten zu formatieren, indem Sie leere Zeilen oder Spalten wie in einem Excel-Arbeitsblatt einfügen, da dadurch Platz in Ihrer Tabelle verschwendet wird. Die Tabelle enthält lediglich Ihre Daten. Die visuelle Darstellung dieser Daten erfolgt in den Formularen und Berichten, die Sie später entwerfen.

    • Die Tabellenstruktur wird erstellt, während Sie Daten eingeben. Jedes Mal, wenn Sie dem Datenblatt eine neue Spalte hinzufügen, wird ein neues Feld in der Tabelle definiert. Access legt die Datentyp des Felds basierend auf dem Typ der von Ihnen eingegebenen Daten fest. Wenn Sie beispielsweise über eine Spalte verfügen, in der Sie nur Datumswerte eingegeben haben, wird für Access der Datentyp dieses Felds auf "Datum/Uhrzeit" festgesetzt. Wenn Sie später versuchen, einen nicht Datumswert (wie einen Namen oder eine Telefonnummer) in dieses Feld einzugeben, zeigt Access eine Meldung an, in der Sie darüber informiert werden, dass der Wert nicht dem Datentyp der Spalte entspricht. Wenn möglich, sollten Sie Ihre Tabelle so planen, dass jede Spalte den gleichen Datentyp enthält, ob es sich um Text, Datumsangaben, Zahlen oder einen anderen Typ handelt. Dadurch ist es viel einfacher, Abfragen, Formulare und Berichte zu erstellen, die nur die gewünschten Daten auswählen.

Wenn Sie noch keine Daten eingeben möchten, klicken Sie auf Schaltflächensymbol schließen.

Hinweis: Access löscht Tabelle1, wenn Sie Sie schließen, ohne Sie zu speichern.

Seitenanfang

Öffnen einer vorhandenen Access-Datenbank

Tipp: Wenn Sie eine der zuletzt geöffneten Datenbanken schnell öffnen möchten, klicken Sie auf der Registerkarte Datei auf zuletztverwendet, und klicken Sie dann auf den Dateinamen.

  1. Klicken Sie auf der Registerkarte Datei auf Öffnen.

  2. Klicken Sie im Dialogfeld Öffnen auf eine Verknüpfung – oder klicken Sie im Feld Suchen in auf das Laufwerk oder den Ordner, in dem sich die gewünschte Datenbank befindet.

  3. Doppelklicken Sie in der Ordnerliste auf Ordner, bis Sie den Ordner öffnen, in dem sich die Datenbank befindet.

  4. Wenn Sie die Datenbank gefunden haben, führen Sie eine der folgenden Aktionen aus:

    • Wenn Sie die Datenbank im standardmäßigen geöffneten Modus öffnen möchten, doppelklicken Sie darauf.

    • Klicken Sie auf Öffnen, um die Datenbank für den freigegebenen Zugriff in einer Mehrbenutzerumgebung zu öffnen, damit sowohl Sie als auch andere Benutzer gleichzeitig in der Datenbank lesen und schreiben können.

    • Wenn Sie die Datenbank für schreibgeschützten Zugriff öffnen möchten, sodass Sie Sie anzeigen, aber nicht bearbeiten können, klicken Sie auf den Pfeil neben der Schaltfläche Öffnen , und klicken Sie dann auf schreibgeschützt öffnen.

    • Klicken Sie auf den Pfeil neben der Schaltfläche Öffnen , und klicken Sie dann auf exklusiv öffnen, um die Datenbank für exklusiven Zugriff zu öffnen, damit Sie von niemandem geöffnet wird, während Sie geöffnet sind.

    • Wenn Sie die Datenbank für schreibgeschützten Zugriff öffnen möchten, klicken Sie auf den Pfeil neben der Schaltfläche Öffnen , und klicken Sie dann auf exklusives schreibgeschützt öffnen : andere Benutzer können die Datenbank weiterhin öffnen, aber nur schreibgeschützten Zugriff.

Wenn Sie die Datenbank, die Sie öffnen möchten, nicht finden können    

  1. Klicken Sie im Dialogfeld Öffnen auf die Verknüpfung Arbeitsplatz – oder klicken Sie im Feld Suchen in auf Arbeitsplatz.

  2. Klicken Sie in der Liste der Laufwerke mit der rechten Maustaste auf das Laufwerk, das Ihrer Meinung nach die Datenbank enthalten kann, und klicken Sie dann auf Suchen.

  3. Geben Sie Ihre Suchkriterien ein, und drücken Sie dann die EINGABETASTE, um nach der Datenbank zu suchen.

  4. Wenn die Datenbank gefunden wird, öffnen Sie Sie, indem Sie im Dialogfeld Suchergebnisse darauf doppelklicken.

    Da die Suche über das Dialogfeld Öffnen initiiert wurde, müssen Sie in diesem Dialogfeld auf Abbrechen klicken, bevor die Datenbank geöffnet wird.

Sie können eine Datendatei direkt in einem externen Dateiformat (wie dBASE, Paradox, Microsoft Exchange oder Excel) öffnen. Sie können auch beliebige ODBC-Datenquelle wie Microsoft SQL Server oder Microsoft FoxPro direkt öffnen. Access erstellt automatisch eine neue Access-Datenbank im gleichen Ordner wie die Datendatei und fügt Links zu jeder Tabelle in der externen Datenbank hinzu.

Seitenanfang

Erste Schritte mit der Verwendung der neuen Datenbank

Je nach verwendeter Vorlage müssen Sie möglicherweise eine oder mehrere der folgenden Aktionen ausführen, um mit der neuen Datenbank zu beginnen:

  • Wenn Access ein Anmelde Dialogfeld mit einer leeren Benutzerliste anzeigt, führen Sie die folgenden Schritte aus, um zu beginnen:

    1. Klicken Sie auf neuer Benutzer.

    2. Füllen Sie das Formular Benutzer Details aus.

    3. Klicken Sie auf Speichern und schließen.

    4. Wählen Sie den soeben eingegebenen Benutzernamen aus, und klicken Sie dann auf Anmelden.

  • Wenn Access ein leeres Datenblatt anzeigt, können Sie mit der Eingabe von Daten direkt in dieses Datenblatt beginnen oder auf andere Schaltflächen und Registerkarten klicken, um die Datenbank zu durchsuchen.

  • Wenn Access die Seite " Erste Schritte " anzeigt, können Sie auf dieser Seite auf Links klicken, um mehr über die Datenbank zu erfahren, oder auf andere Schaltflächen und Registerkarten klicken, um die Datenbank zu durchsuchen.

  • Wenn in Access in der Statusleiste eine Sicherheitswarnung angezeigt wird und Sie der Quelle der Vorlage Vertrauen, klicken Sie auf Inhalt aktivieren. Wenn für die Datenbank eine Anmeldung erforderlich ist, müssen Sie sich erneut anmelden.

Für Desktop-und Webdatenbanken möchten Sie auch mit einem der folgenden Schritte beginnen:

Seitenanfang

Hinzufügen einer Tabelle

Sie können eine neue Tabelle zu einer vorhandenen Datenbank hinzufügen, indem Sie die Tools in der Gruppe " Tabellen " auf der Registerkarte " Erstellen " verwenden.

Gruppe „Tabellen“ auf der Registerkarte „Erstellen“

Hinweis: In einer Webdatenbank steht nur der Befehl Tabelle in der Gruppe Tabellen zur Verfügung.

Unabhängig davon, in welcher Ansicht Sie beginnen, können Sie mit den Schaltflächen Ansicht auf der Statusleiste des Access-Fensters jederzeit zur anderen Ansicht wechseln.

Erstellen einer leeren Tabelle in der Datenblattansicht    In der Datenblattansicht können Sie Daten sofort eingeben und den Zugriff auf die Tabellenstruktur Behind the Scenes erstellen lassen. Feldnamen werden numerisch zugewiesen (Feld1, Feld2 usw.), und Access legt den Datentyp des Felds basierend auf dem Typ der eingegebenen Daten fest.

  1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Tabellen auf Tabellen Schaltflächensymbol .

  2. Access erstellt die Tabelle und platziert dann den Cursor in der ersten leeren Zelle in der Spalte zum Hinzufügen klicken .

  3. Wenn Sie Daten hinzufügen möchten, beginnen Sie mit der Eingabe in der ersten leeren Zelle, oder Sie können Daten aus einer anderen Quelle einfügen, wie weiter unten in diesem Artikel beschrieben.

    • Wenn Sie eine Spalte (Feld) umbenennen möchten, doppelklicken Sie auf die Spaltenüberschrift, und geben Sie dann den neuen Namen ein.

      Tipp: Geben Sie jedem Feld einen aussagekräftigen Namen, damit Sie wissen, was es enthält, ohne die Daten sehen zu müssen.

    • Um eine Spalte zu verschieben, wählen Sie Sie aus, indem Sie auf die Spaltenüberschrift klicken, und ziehen Sie Sie dann an die gewünschte Position. Sie können auch mehrere zusammenhängende Spalten auswählen und alle an eine neue Position ziehen.

      Wenn Sie Ihrer Tabelle weitere Felder hinzufügen möchten, können Sie entweder mit der Eingabe in der Spalte Klicken Sie in der Datenblattansicht beginnen, oder Sie können neue Felder mithilfe der Befehle in der Gruppe & löschen auf der Registerkarte Felder hinzufügen.

Erstellen einer Tabelle, die in der Entwurfsansicht beginnt    In der Entwurfsansicht erstellen Sie zunächst die Struktur der neuen Tabelle. Anschließend wechseln Sie entweder zur Datenblattansicht, um Daten einzugeben, oder Sie geben Ihre Daten mithilfe einer anderen Methode ein, beispielsweise mit einem Formular.

Die Entwurfsansicht steht für Tabellen in einer Webdatenbank nicht zur Verfügung.

  1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Tabellen auf Tabellenentwurf. Schaltflächensymbol

  2. Geben Sie für jedes Feld in der Tabelle einen Namen in die Spalte Feldname ein, und wählen Sie dann in der Liste Datentyp den gewünschten Datentyp aus.

  3. Sie können für jedes Feld in der Spalte Beschreibung zusätzliche Informationen eingeben. Die von Ihnen eingegebene Beschreibung wird in der Statusleiste angezeigt, wenn sich die Einfügemarke in diesem Feld befindet, und wird als Statusleistentext für alle Steuerelemente verwendet, die Sie erstellen, indem Sie das Feld aus dem Bereich Feldliste in ein Formular oder einen Bericht ziehen. und für alle Steuerelemente, die vom Formular-Assistenten oder Berichts-Assistenten für dieses Feld erstellt werden.

  4. Nachdem Sie alle Felder hinzugefügt haben, speichern Sie die Tabelle:

    • Klicken Sie auf der Registerkarte Datei auf Speichern.

  5. Sie können jederzeit mit der Eingabe von Daten in die Tabelle beginnen, indem Sie zur Datenblattansicht wechseln, in die erste leere Zelle klicken und dann eingeben. Sie können auch Daten aus einer anderen Quelle einfügen, wie im nächsten Abschnitt beschrieben.

Erstellen einer Tabelle auf der Grundlage einer SharePoint-Liste    Bei einer SharePoint-Liste können Ihre Daten von Personen verwendet werden, die keinen Zugriff haben. Darüber hinaus werden Listendaten auf einem Server gespeichert, der in der Regel einen besseren Schutz vor Datenverlust bietet als Dateien, die auf einem Desktopcomputer gespeichert sind. Sie können entweder mit einer neuen Liste beginnen, oder Sie können eine Verknüpfung mit einer vorhandenen Liste erstellen. Sie müssen über ausreichende Berechtigungen auf der SharePoint-Website verfügen, auf der Sie die Liste erstellen möchten. Dies kann je nach Website variieren, damit Sie sich an Ihren SharePoint-Administrator wenden, um Details zu Ihren Optionen anzuzeigen.

Dieses Feature steht in einer Webdatenbank nicht zur Verfügung.

  1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Tabellen auf SharePoint-Listen.

  2. Sie können eine der Listenvorlagen verwenden, um eine standardmäßige SharePoint-Liste zu erstellen, beispielsweise Kontakte oder Ereignisse.

    Sie können auch auswählen, ob Sie eine benutzerdefinierte Liste erstellen oder eine vorhandene Liste verknüpfen oder importieren möchten. Klicken Sie auf die gewünschte Option.

  3. Wenn Sie eine der Listenvorlagen auswählen oder eine benutzerdefinierte Liste erstellen, wird das Dialogfeld neue Liste erstellen geöffnet, in dem Sie durch den Prozess geleitet werden. Wenn Sie sich entscheiden, eine vorhandene Liste zu verwenden, wird das Dialogfeld externe Daten abrufen geöffnet, damit Sie Ihnen helfen können.

Weitere Informationen zu Tabellen finden Sie im Artikel Einführung in Tabellen.

Seitenanfang

Einfügen von Daten aus einer anderen Quelle in eine Access-Tabelle

Wenn Ihre Daten aktuell in einem anderen Programm wie Excel gespeichert sind, können Sie Ihre Daten in eine Access-Tabelle kopieren und einfügen. Im Allgemeinen funktioniert dies am besten, wenn Ihre Daten bereits in Spalten wie in einem Excel-Arbeitsblatt getrennt sind. Wenn sich Ihre Daten in einem Textverarbeitungsprogramm befinden, sollten Sie zuerst die Datenspalten mithilfe von Tabstopps trennen oder die Daten in eine Tabelle im Textverarbeitungsprogramm konvertieren und dann die Daten kopieren. Wenn Ihre Daten bearbeitet oder manipuliert werden müssen (beispielsweise das Trennen von vollständigen Namen in vor-und Nachnamen), sollten Sie dies tun, bevor Sie die Daten kopieren, insbesondere dann, wenn Sie mit Access nicht vertraut sind.

Wenn Sie Daten in eine leere Tabelle einfügen, legt Access den Datentyp jedes Felds entsprechend dem Typ der Daten fest, die dort gefunden werden. Wenn beispielsweise ein eingefügtes Feld nur Datumswerte enthält, wendet Access den Datentyp "Datum/Uhrzeit" auf dieses Feld an. Wenn das eingefügte Feld nur die Wörter "Ja" und "Nein" enthält, wendet Access den Datentyp "Ja/Nein" auf das Feld an.

Access benennt die Felder in Abhängigkeit davon, was in der ersten Zeile der eingefügten Daten gefunden wird. Wenn die erste Zeile mit eingefügten Daten dem Typ der Zeilen ähnelt, die Folgen, bestimmt Access, dass die erste Zeile Teil der Daten ist, und weist die Felder generische Namen (Feld1, Feld2 usw.) zu. Wenn die erste Zeile mit eingefügten Daten nicht mit den nachfolgenden Zeilen vergleichbar ist, verwendet Access die erste Zeile als Feldnamen und schließt die erste Zeile in den eigentlichen Daten aus.

Wenn Access generische Feldnamen zuweist, sollten Sie die Felder so schnell wie möglich umbenennen, um Verwechslungen zu vermeiden. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie auf der Registerkarte Datei auf Speichern , um die Tabelle zu speichern.

  2. Doppelklicken Sie in der Datenblattansicht auf jede Spaltenüberschrift, und geben Sie dann einen Namen für die Spalte ein.

  3. Speichern Sie die Tabelle erneut.

Seitenanfang

Importieren oder Verknüpfen von Daten aus einer anderen Quelle

Möglicherweise verfügen Sie über Daten, die Sie in einem anderen Programm gesammelt haben, das Sie in Access verwenden möchten. Vielleicht arbeiten Sie mit Personen zusammen, die Ihre Daten in anderen Programmen speichern, und Sie möchten mit Ihren Daten in Access arbeiten. Oder Vielleichthaben Sie mehrere unterschiedliche Datenquellen und benötigen ein "Landing Pad", in dem Sie alle zur vertieften Analyse zusammenführen können.

Access macht es einfach, Daten aus anderen Programmen zu importieren oder zu verknüpfen. Sie können Daten aus einem Excel-Arbeitsblatt, aus einer Tabelle in einer anderen Access-Datenbank, aus einer SharePoint-Liste oder aus einer Vielzahl anderer Quellen einbringen. Der Prozess unterscheidet sich abhängig von der Datenquelle geringfügig, doch mit diesen Anweisungen erhalten Sie einen ersten Schritt:

  1. Klicken Sie auf der Registerkarte externe Daten in der Gruppe Import &-Link auf den Befehl für den Dateityp, aus dem Sie importieren möchten.

    Wenn Sie beispielsweise Daten aus einem Excel-Arbeitsblatt importieren, klicken Sie auf Excel. Wenn der richtige Programmtyp nicht angezeigt wird, klicken Sie auf mehr.

    Hinweis: Wenn Sie den richtigen Formattyp in der Gruppe " Import _AMP_ Link " nicht finden können, müssen Sie möglicherweise das Programm starten, in dem Sie die Daten ursprünglich erstellt haben, und dann dieses Programm verwenden, um die Daten in einem Dateiformat zu speichern, das Access unterstützt (wie etwa ein Textdatei mit Trennzeichen ). , und klicken Sie dann auf die Daten importieren oder verknüpfen.

  2. Klicken Sie im Dialogfeld externe Daten abrufen entweder auf Durchsuchen , um die Quelldatendatei zu durchsuchen, oder geben Sie im Feld Dateiname den vollständigen Pfad der Quelldatendatei ein.

  3. Klicken Sie auf die gewünschte Option unter Geben Sie an, wie und wo die Daten in der aktuellen Datenbank gespeichert werdensollen. Sie können eine neue Tabelle erstellen, indem Sie die importierten Daten verwenden oder eine verknüpfte Tabelle erstellen, die einen Link zur Datenquelle verwaltet.

  4. Klicken Sie auf OK.

    Je nach Ihrer Auswahl wird das Dialogfeld Objekte verknüpfen oder das Dialogfeld Objekte importieren geöffnet.

  5. Verwenden Sie das Dialogfeld, um den Vorgang abzuschließen. Die genaue Vorgehensweise hängt von der ausgewählten Option Importieren oder verknüpfen ab.

  6. Klicken Sie auf der letzten Seite des Assistenten auf Fertig stellen.

    Wenn Sie den Importvorgang ausgewählt haben, fragt Access, ob Sie die Details des soeben abgeschlossenen Importvorgangs speichern möchten.

  7. Wenn Sie der Meinung sind, dass Sie denselben Importvorgang erneut ausführen möchten, klicken Sie auf Importschritte speichern, und geben Sie dann die Details ein.

    Anschließend können Sie den Importvorgang einfach reproduzieren, indem Sie auf der Registerkarte externe Daten in der Gruppe importieren auf gespeicherte Importe klicken, auf die Importspezifikation klicken und dann auf Ausführenklicken.

  8. Wenn Sie die Details des Vorgangs nicht speichern möchten, klicken Sie auf Schließen.

Access importiert die Daten in eine neue Tabelle und zeigt dann die Tabelle unter Tabellen im Navigationsbereich an.

Wenn Sie mehr über das Importieren von Daten in Access erfahren möchten, folgen Sie den Links im Abschnitt Siehe auch dieses Artikels.

Seitenanfang

Nächste Schritte

Der restliche Entwurfsprozess unterscheidet sich je nach Ihren Zielen, doch möchten Sie möglicherweise Abfragen, Formulare, Berichte und Makros erstellen. In diesem Artikel werden keine Informationen zum Erstellen zusätzlicher Datenbankobjekte bereitgestellt.

Weitere Informationen finden Sie in den folgenden Artikeln:

Seitenanfang

Importieren von Daten aus einer Kalkulationstabelle oder einem anderen Programm

Wenn Sie mit anderen Datenbank-oder Tabellen Kalkulationsprogrammen vertraut sind, kennen Sie wahrscheinlich die Grundlagen, wie diese Anwendungen funktionieren und welche Datenbanken verwendet werden. Access unterscheidet sich von vielen anderen Datenbankanwendungen, indem es Ihnen ermöglicht, relationale Datenbanken zu erstellen, und es unterscheidet sich von den meisten Tabellenprogrammen, indem Sie Tools für die Entwicklung anspruchsvoller Abfragen, Formulare und Berichte anbieten. Access bietet auch viele Optionen für das Arbeiten mit anderen Datenbankprogrammen wie SQL Server.

Importieren eines Excel-Arbeitsblatts in Access

Viele Personen beginnen, Access zu erforschen, nachdem Sie das erste Mal eine Liste in Excel erstellt haben. Excel eignet sich hervorragend, um eine Liste zu erstellen, während die Liste wächst, wird es schwieriger, die Organisation zu organisieren und zu aktualisieren. Das Verschieben der Liste in Access ist in der Regel der nächste logische Schritt.

Eine Datenbanktabelle ist in der Struktur mit einem Arbeitsblatt vergleichbar, da Daten in Zeilen und Spalten gespeichert werden. Daher ist es in der Regel einfach, ein Arbeitsblatt in eine Datenbanktabelle zu importieren. Der Hauptunterschied zwischen dem Speichern von Daten in einem Arbeitsblatt und dem Speichern der Daten in einer Datenbank liegt darin, wie die Daten strukturiert sind. Wenn Sie das gesamte Arbeitsblatt einfach als neue Tabelle in einer Datenbank importieren, können Sie die Probleme beim organisieren und Aktualisieren Ihrer Daten nicht lösen, insbesondere dann, wenn das Arbeitsblatt redundante Daten enthält. Um diese Probleme zu lösen, müssen Sie die Kalkulationstabellendaten in separate Tabellen aufteilen, die jeweils verknüpfte Daten enthalten. Weitere Informationen zum Anordnen der Daten in Ihren Tabellen finden Sie im Artikel Grundlagen des Datenbankentwurfs.

Access verfügt über den Tabellenanalyse-Assistenten, der Ihnen bei der Durchführung dieses Vorgangs behilflich sein kann. Nachdem Sie Ihre Daten in eine Tabelle importiert haben, hilft Ihnen der Assistent beim Aufteilen der Tabelle in separate Tabellen, die jeweils Daten enthalten, die in keiner der anderen Tabellen dupliziert werden. Der Assistent erstellt auch die erforderlichen Beziehungen zwischen den Tabellen.

Seitenanfang

Importieren eines Excel-Arbeitsblatts als Tabelle in einer neuen Datenbank

  1. Klicken Sie auf der Registerkarte Datei auf neu, und klicken Sie dann auf leere Datenbank.

  2. Geben Sie im Feld Dateiname einen Namen für die neue Datenbank ein, und klicken Sie dann auf Erstellen.

    Die neue Datenbank wird geöffnet, und Access erstellt eine neue leere Tabelle, Tabelle1.

  3. Schließen Sie Tabelle1.

    Wenn Sie gefragt werden, ob Sie Änderungen am Design von Tabelle1 speichern möchten, klicken Sie auf Nein.

  4. Klicken Sie auf der Registerkarte externe Daten in der Gruppe _AMP_ importieren auf Excel. Schaltflächensymbol

  5. Klicken Sie im Dialogfeld externe Daten abrufen auf Durchsuchen.

  6. Verwenden Sie das Dialogfeld " Datei öffnen ", um die Datei zu suchen.

  7. Wählen Sie die Datei aus, und klicken Sie dann auf Öffnen.

  8. Stellen Sie im Dialogfeld externe Daten abrufen sicher, dass die Option Quelldaten in eine neue Tabelle in der aktuellen Datenbank importieren aktiviert ist.

  9. Klicken Sie auf OK.

    Der Import-Assistent für KalkulationsTabellen wird gestartet und stellt Ihnen einige Fragen zu Ihren Daten.

  10. Folgen Sie den Anweisungen, klicken Sie auf weiter oder zurück , um durch die Seiten zu navigieren. Klicken Sie auf der letzten Seite des Assistenten auf Fertig stellen.

    Hinweis: Access fragt, ob Sie die Details des soeben abgeschlossenen Importvorgangs speichern möchten. Wenn Sie der Meinung sind, dass Sie denselben Importvorgang erneut durchführen werden, klicken Sie auf Ja, und geben Sie dann die Details ein. Anschließend können Sie den Vorgang in Zukunft problemlos reproduzieren, indem Sie auf der Registerkarte externe Daten in der Gruppe importieren auf gespeicherte Importe klicken. Wenn Sie die Details des Vorgangs nicht speichern möchten, klicken Sie auf Schließen.

Access importiert die Daten in eine neue Tabelle und zeigt Sie dann unter alle Tabellen im Navigationsbereich an.

Seitenanfang

Verwenden des Tabellenanalyse-Assistenten zum Organisieren von Daten

Nachdem Ihre Daten in eine Access-Tabelle importiert wurden, können Sie den Tabellenanalyse-Assistenten verwenden, um redundante Daten schnell zu identifizieren. Der Assistent bietet dann eine einfache Möglichkeit, die Daten in separaten Tabellen zu organisieren, sodass Sie auf die effizienteste Weise gespeichert werden. Access behält die ursprüngliche Tabelle als Sicherung bei und erstellt dann neue Tabellen, die Sie als Grundlage für Ihre Datenbankanwendung verwenden können.

  1. Öffnen Sie die Access-Datenbank, die die Tabelle enthält, die Sie analysieren möchten.

  2. Klicken Sie auf der Registerkarte Daten Bank Tools in der Gruppe analysieren auf Tabelle analysieren.

    Der Tabellenanalyse-Assistent wird gestartet.

    Die ersten beiden Seiten des Assistenten enthalten ein kurzes Lernprogramm – komplett mit Schaltflächen, auf die Sie klicken können, um Beispiele anzuzeigen. Wenn die Einführungsseiten nicht angezeigt werden, aber stattdessen ein Kontrollkästchen mit der Bezeichnung einführende Seiten anzeigenangezeigt wird, aktivieren Sie das Kontrollkästchen, und klicken Sie dann zweimal auf zurück , um die Einführung anzuzeigen. Wenn Sie die einführenden Seiten nach dem Lesen der Einleitung nicht mehr anzeigen möchten, können Sie das Kontrollkästchen Einführungsseiten einblenden deaktivieren.

  3. Wählen Sie in der Tabelle welche Felder mit Werten, die in vielen Datensätzen wiederholt werden? die Tabelle aus, die Sie analysieren möchten, und klicken Sie dann auf weiter.

  4. Sie können den Assistenten entscheiden lassen, welche Felder in welche Tabellen gehen, oder Sie können diese Entscheidung selbst treffen. Wenn Sie den Vorschlägen des Assistenten folgen, können Sie auf der nächsten Seite des Assistenten weiterhin Änderungen am Tabellenlayout vornehmen.

    Hinweis: Wenn Sie den Assistenten entscheiden lassen, welche Felder in welche Tabellen eingefügt werden sollen, sind Ihre Entscheidungen möglicherweise nicht immer für Ihre Daten geeignet, insbesondere, wenn nicht viele Daten zur Verfügung stehen. Überprüfen Sie die Ergebnisse des Assistenten sorgfältig. Auf der anderen Seite schlägt der Assistent möglicherweise eine effizientere Organisation vor, die Sie sich vorstellen, daher empfiehlt es sich, mindestens einmal die Entscheidungen des Assistenten auszuprobieren. Wenn Ihnen die Vorschläge nicht gefallen, können Sie die Felder dennoch manuell neu anordnen, und Sie können jederzeit auf zurück klicken und alle Felder selbst anordnen.

  5. Klicken Sie auf Weiter. Auf dieser Seite geben Sie an, welche Tabellen welche Felder enthalten. Wenn Sie den Assistenten entscheiden lassen möchten, sollten Sie mehrere Tabellen sehen, die durch Beziehungslinien verbunden sind. Andernfalls erstellt Access nur eine Tabelle, die alle Felder enthält. In beiden Fällen können Sie Änderungen auf dieser Seite vornehmen.

    • Sie können Felder aus einer Tabelle in einen leeren Bereich der Seite ziehen, um eine neue Tabelle zu erstellen, die diese Felder enthält. Access fordert Sie auf, einen Tabellennamen zu erhalten.

    • Sie können Felder aus einer Tabelle in eine andere Tabelle ziehen, wenn Sie der Meinung sind, dass Sie dort effizienter gespeichert werden.

    • Die meisten Tabellen erhalten eine ID oder ein generiertES eindeutiges ID- Feld. Wenn Sie mehr über die ID-Felder erfahren möchten, klicken Sie in der oberen rechten Ecke des Assistenten auf Tipps .

    • Wenn Sie eine Änderung rückgängig machen möchten, klicken Sie auf die Schaltfläche Rückgängig .

    • Wenn Sie eine Tabelle umbenennen möchten, doppelklicken Sie auf die Titelleiste, geben Sie den neuen Namen ein, und klicken Sie dann auf OK.

  6. Nachdem Sie die Felder in der gewünschten Weise angeordnet haben, klicken Sie auf weiter.

  7. Wenn der Assistent Datensätze findet, die sehr ähnliche Werte aufweisen, werden diese Werte als mögliche typografische Fehler erkannt und ein Bildschirm angezeigt, in dem Sie bestätigen können, was zu tun ist. Scrollen Sie durch die Liste, um alle Werte in der Spalte Korrektur zu finden, und klicken Sie dann auf das entsprechende Element in der Dropdownliste. Wählen Sie (beibehalten) aus, damit der Assistent keine Änderungen am Wert vornimmt. Wenn Sie den Vorgang beenden, klicken Sie auf weiter.

  8. Der Assistent fragt, ob Sie eine Abfrage erstellen möchten, die der ursprünglichen Tabelle ähnelt. Wenn Sie bereits Formulare und Berichte erstellt haben, die auf der ursprünglichen Tabelle basieren, ist das Erstellen einer solchen Abfrage eine gute Idee. Wenn Sie Ja auswählen, die Abfrage erstellen, benennt der Assistent die ursprüngliche Tabelle um, indem Sie "_old" an den Tabellennamen anfügt und dann die neue Abfrage mit dem Namen der ursprünglichen Tabelle benennt. Die Formulare und Berichte, die auf der Tabelle basieren, verwenden nun die Abfrage für Ihre Daten, und Sie funktionieren weiterhin wie zuvor.

  9. Klicken Sie auf Fertig stellen.

    Der Assistent erstellt die neuen Tabellen wie angegeben und öffnet Sie dann. Schließen Sie Sie, wenn Sie die Ergebnisse überprüft haben.

Seitenanfang

Arbeiten mit Daten aus anderen Programmen

Access 2010 bietet Funktionen zum Arbeiten mit Daten, die in anderen Programmen gespeichert sind.

Erstellen einer neuen Access-Datenbank, die mit Daten in einem anderen Dateiformat verknüpft ist    Sie können Access verwenden, um eine Datei in einem anderen Dateiformat wie Text, dBASE oder einem Arbeitsblatt zu öffnen. Access erstellt automatisch eine Access-Datenbank und verknüpft die Datei für Sie.

  1. Starten Sie Access.

  2. Klicken Sie auf der Registerkarte Datei auf Öffnen.

  3. Klicken Sie im Dialogfeld Öffnen auf den Typ der Datei, die Sie in der Liste öffnen möchten. Wenn Sie sich nicht sicher sind, welchen Dateityp Sie haben, klicken Sie auf alle Dateien (*. *).

  4. Navigieren Sie bei Bedarf zu dem Ordner, der die Datei enthält, die Sie öffnen möchten. Wenn Sie die Datei gefunden haben, doppelklicken Sie darauf, um Sie zu öffnen.

  5. Folgen Sie den Anweisungen im Assistenten. Klicken Sie auf der letzten Seite des Assistenten auf Fertig stellen.

Importieren oder Verknüpfen von Daten in einer vorhandenen Access-Datenbank    Sie können Daten aus anderen Quellen und Programmen in Access-Tabellen importieren, damit die Daten in der Access-Datei enthalten sind, oder Sie können eine Verknüpfung zu den Daten von Access herstellen, damit die Daten in der ursprünglichen Datei (außerhalb der Access-Datei) verbleiben.

  1. Klicken Sie auf der Registerkarte externe Daten in der Gruppe Import &-Link auf das Format, in dem die Daten gespeichert werden.

    Sie können Daten aus den folgenden Quellen importieren oder verknüpfen:

    • Excel    Sie können Daten aus einem Arbeitsblatt oder einem benannten Bereich in einer Excel-Arbeitsmappe einbringen. Jedes Arbeitsblatt oder jeder benannte Bereich muss separat importiert oder verknüpft werden.

    • Access    Dies ist sehr praktisch, wenn Sie Ihren Prozess von Ihren Daten trennen und eine geteilte Datenbank erstellen. Das bedeutet, dass Sie eine Datenbank verwenden können, um alle Formulare, Berichte und Makros zu enthalten und Ihre Daten in einer anderen Datenbank zu speichern. Sie können dann Verbesserungen entwickeln, ohne die Arbeit anderer Personen zu unterbrechen. Sie können auch Daten aus vielen verschiedenen Access-Datenbanken in einem kombinieren, wodurch es einfacher ist, Daten über Abteilungen oder zwischen Geschäftspartnern zusammenzufassen.

    • ODBC-Datenbank    Viele Programme unterstützen dieses Format, einschließlich vieler Datenbankserver Produkte. Auf diese Weise können Sie "Landing Pad"-Datenbankenerstellen, in denen Daten aus unterschiedlichen Systemen kombiniert werden.

    • Textdatei    Sie können eine Verbindung mit einer einfachen Textdatei herstellen und sogar Access verwenden, um den Inhalt dieser Datei zu ändern. Dies kann dazu beitragen, dass Access-Daten von zahlreichen Programmen einfach zu nutzen sind.

    • XML-Datei    Dieses Format bietet auch Kompatibilität mit einer Vielzahl anderer Programme, einschließlich einiger Webserver.

    • SharePoint-Liste    Dadurch können Ihre Daten mit einem Webbrowser, der Standardmethode zur Verwendung einer SharePoint-Liste, verwendet werden.

    • Datendienste    Sie können eine Verbindung mit Webdaten Diensten in Ihrem Unternehmen herstellen.

    • HTML-Dokument    

    • Outlook-Ordner    Sie können eine Verbindung mit Outlook-Ordnern herstellen, damit Sie Ihre Kontaktinformationen leichter in die restlichen Daten integrieren können.

    • dBase-Datei    dBase ist ein beliebtes alternatives Datenbanksystem, das von Access unterstützt wird.

      Das Dialogfeld externe Daten abrufen wird angezeigt.

  2. BeFolgen Sie die Anweisungen im Dialogfeld.

    Access importiert oder verknüpft die Daten mit der Datenbank. Bei den meisten Formaten müssen Sie den Speicherort der Daten angeben und dann auswählen, wie die Daten in der Datenbank gespeichert werden sollen.

Seitenanfang

Verwenden einer Datenbank einer früheren Version in mehreren Access-Versionen

Wenn die Access-Datenbank oder das Access-Projekt in Access 2000 oder höher erstellt wurde, können Sie die Datenbank oder das Projekt in der Version von Access, in der Sie erstellt wurde, oder in einer späteren Version verwenden, selbst wenn die Dateisicherheit aktiviert ist. Access 2000-Dateien können beispielsweise in Access 2000, Access 2002, Access 2003, Access 2007 und Access 2010 verwendet werden.

Möglicherweise haben Sie eine Situation, in der Sie Ihre Daten in einer früheren Version von Access behalten möchten, Sie aber über Benutzer mit einer höheren Version von Access verfügen, die eine Verknüpfung zu diesen Daten herstellen möchten, aber dennoch einige der Features der neueren Version nutzen möchten. Die Lösung besteht darin, eine neue "Front-End"-Datenbank in der neueren Version zu erstellen (die Formulare, Berichte, Abfragen, Makros, aber keine Tabellen enthält), und Sie mit den Tabellen in der früheren Versionsdatei zu verknüpfen. Verwenden Sie eines der folgenden Verfahren, je nachdem, ob Ihre Datenbank in einer Datei enthalten ist oder bereits in eine Front-End-/Back-End-Anwendung aufgeteilt ist.

Verwenden einer Access-Datenbankdatei in mehreren Access-Versionen

Wenn alle Tabellen, Formulare und anderen Objekte Ihrer früheren Access-Datenbank in einer Datei enthalten sind und Sie die Datenbank in verschiedenen Versionen von Access verwenden möchten, können Sie eine neue Front-End-Datenbank in einer späteren Version erstellen und Sie mit der ursprünglichen Datei verknüpfen. Benutzer, die über die frühere Version von Access verfügen, können die ursprüngliche Datenbank weiterhin verwenden. Benutzer, die über die neuere Version verfügen, können die neue Front-End-Datenbank verwenden, um eine Verknüpfung mit denselben Daten zu erstellen. Sie können mehrere Front-End-Versionen erstellen, wenn Sie mehrere Versionen von Access berücksichtigen müssen.

Seitenanfang

Schritt 1: Erstellen einer Kopie der vorhandenen Datenbank und speichern in einem neuen Format

Gehen Sie wie folgt vor, um die Datenbank in eines der drei zuletzt verwendeten Formate zu konvertieren: Access 2000, Access 2002-2003 oder Access 2007. Mit diesem Befehl wird die ursprüngliche Datenbank im ursprünglichen Format beibehalten und eine Kopie in dem von Ihnen angegebenen Format erstellt.

  1. Schließen Sie die Access-Datei. Wenn es sich bei der Datei um eine mehr Benutzer-Access-Datenbank auf einem Server oder in einem freigegebenen Ordner handelt, stellen Sie sicher, dass Sie nicht von einer anderen Person geöffnet wurde.

  2. Starten Sie Access 2010.

  3. Klicken Sie auf der Registerkarte Datei auf Öffnen.

  4. Navigieren Sie zum Speicherort der Datei, die Sie konvertieren möchten, und doppelklicken Sie dann darauf, um Sie zu öffnen.

    Wenn das Dialogfeld Daten Bank Erweiterung angezeigt wird, in dem Sie gefragt werden, ob Sie die Datenbank verbessern möchten, klicken Sie auf Nein.

  5. Wenn beim Starten der Datenbank ein Formular geöffnet wird, schließen Sie das Formular.

  6. Klicken Sie auf der Registerkarte Datei auf Datenbank speichernunter.

  7. Geben Sie im Dialogfeld Speichern unter einen Namen für die neue Datenbank ein.

    Hinweis: Sofern Sie die neue Datenbank nicht an einem anderen Speicherort speichern, muss sich der Name von dem der ursprünglichen Datenbank unterscheiden. In beiden Fällen empfiehlt es sich in der Regel, einen anderen Namen zu verwenden, damit Sie problemlos zwischen der Front-End-Datenbank und der Back-End-Datenbank unterscheiden können. Wenn Sie jedoch in das Access 2007-Format konvertieren, ändert sich die Dateinamenerweiterung von MDB in ACCDB, sodass Sie denselben Dateinamen verwenden können.

  8. Klicken Sie auf Speichern.

Seitenanfang

Schritt 2: aufTeilen der Kopier Datenbank und Verwenden der ursprünglichen Datei als Back-End-Datenbank

Teilen Sie die konvertierte Datenbank mithilfe des folgenden Verfahrens auf:

  • Klicken Sie auf der Registerkarte Daten Bank Tools in der Gruppe Daten verschieben auf Access-Datenbank. Schaltflächensymbol

  • Klicken Sie im Dialogfeld Daten Bank Verteiler auf Datenbank teilen.

    Wenn Sie möchten, können Sie eine Sicherung erstellen, aber Sie können die Kopie auch einfach mithilfe der ursprünglichen Datenbank erstellen.

  • Geben Sie einen Namen für die Back-End-Datenbank ein, und klicken Sie dann auf Teilen.

Seitenanfang

Schritt 3: Verbinden des neuen Front-End mit der ursprünglichen Datenbank

  1. Löschen Sie die Back-End-Datenbank, die vom Daten Bank Splitter-Tool erstellt wurde, und achten Sie darauf, ihre ursprüngliche Datenbank nicht zu löschen.

  2. Verknüpfen Sie die neue Front-End-Datenbank mit den Tabellen in der ursprünglichen Datenbank: Klicken Sie auf der Registerkarte externe Daten in der Gruppe & importieren auf Tabellenverknüpfungs- Manager. Schaltflächensymbol

  3. Klicken Sie auf Alles markieren, und aktivieren Sie dann das Kontrollkästchen immer für neuen Speicherort auffordern .

  4. Klicken Sie auf OK, navigieren Sie zur Datenbank der früheren Version, und doppelklicken Sie darauf.

    Wenn alles gut läuft, zeigt Access eine Meldung an, die besagt, dass alle ausgewählten verknüpften Tabellen erfolgreich aktualisiert wurden.

Sie können jetzt die neue Front-End-Datenbank erweitern, um neue Features für Benutzer zu unterstützen, die über neuere Versionen von Access verfügen. Benutzer, die über frühere Versionen verfügen, können die frühere Versionsdatenbank weiterhin verwenden.

Seitenanfang

Verwenden einer Front-End/Back-End-Anwendung in mehreren Access-Versionen

Wenn es sich bei Ihrer Access-Datenbank bereits um eine Front-End-/Back-End-Anwendung handelt, können Sie das Front-End in das neue Dateiformat konvertieren. Für die Back-End-Datenbank sind keine Änderungen erforderlich.

Das folgende Verfahren zeigt, wie Sie den Befehl Datenbank speichern unter verwenden, um die Front-End-Datenbank in eines der drei letzten Formate zu konvertieren: Access 2000, Access 2002-2003 oder Access 2007. Mit diesem Befehl wird die ursprüngliche Datenbank im ursprünglichen Format beibehalten und eine Kopie in dem von Ihnen angegebenen Format erstellt.

  1. Schließen Sie die Front-End-Datenbank. Wenn es sich bei der Datei um eine mehr Benutzer-Access-Datenbank auf einem Server oder in einem freigegebenen Ordner handelt, stellen Sie sicher, dass Sie nicht von einer anderen Person geöffnet wurde.

  2. Starten Sie Access 2010.

  3. Klicken Sie auf der Registerkarte Datei auf Öffnen.

  4. Navigieren Sie zum Speicherort der Front-End-Datenbank, und doppelklicken Sie dann darauf, um Sie zu öffnen.

    Wenn das Dialogfeld Daten Bank Erweiterung angezeigt wird, in dem Sie gefragt werden, ob Sie die Datenbank verbessern möchten, klicken Sie auf Nein.

  5. Wenn beim Öffnen der Datenbank ein Formular angezeigt wird, schließen Sie das Formular.

  6. Klicken Sie auf der Registerkarte Datei auf Datenbank speichernunter.

  7. Geben Sie im Dialogfeld Speichern unter einen Namen für die neue Datenbank ein.

  8. Klicken Sie auf Speichern.

Sie können jetzt die neue Front-End-Datenbank erweitern, um neue Funktionen zu unterstützen.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×