FELDWERT (Funktion)

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Sie können die Funktion FELDWERT zum Abrufen von Felddaten aus verknüpften Datentypen wie den Datentypen "Aktien" oder "Geographie" verwenden. Es gibt einfachere Methoden zum Schreiben von Formeln, die auf Datentypen verweisen, daher sollte die Funktion FELDWERT in erster Linie zum Erstellen von bedingten Berechnungen basierend auf verknüpften Datentypen verwendet werden.

Hinweis: 28. März 2019: Datentypen wurden für alle Windows Office 365-Abonnentenfreigegeben. Wenn Sie ein Office 365-Abonnent sind, vergewissern Sie sich, dass Sie über die neueste Office-Version verfügen.

Technische Details

Syntax

=FELDWERT(Wert; Feldname)

Die Syntax der Funktion FELDWERT weist die folgenden Argumente auf:

Argument

Beschreibung

Wert

Die Funktion gibt alle übereinstimmenden Felder aus dem im Argument "Wert" angegebenen verknüpften Datentyp zurück.

Feldname

Die Namen der Felder, die Sie aus dem verknüpften Datentyp extrahieren möchten.

Beschreibung

Beispiele

Im folgenden einfachen Beispiel extrahiert die Formel =FELDWERT(A2;"Preis") das Feld "Preis" aus dem Datentyp "Aktien" für JM Smucker Co.

Den Aktienkurs eines Unternehmens mit =FELDWERT(A2;"Preis") abrufen

Im nächste Beispiel sehen Sie ein typischeres Beispiel für die Funktion FELDWERT. Hier verwenden wir die WENNFEHLER-Funktion zur Überprüfung auf Fehler. Wenn in Zelle A2 kein Firmennamen enthalten ist, gibt die Formel FELDWERT einen Fehler zurück, und in diesem Fall soll nichts ("") angezeigt werden. Enthält die Zelle jedoch einen Firmennamen, möchten wir den Preis aus dem Datentyp in Zelle A2 mit =WENNFEHLER(FELDWERT($A2;B$1);"") abrufen.

Den Aktienkurs eines Unternehmens abrufen und Fehler mit =WENNFEHLER(FELDWERT($A2;B$1);"") ignorieren

Beachten Sie, dass die Funktion FELDWERT Ihnen ermöglicht, auf Arbeitsblattzellen für das Argument "Feldname" zu verweisen, daher verweist die oben stehende Formel für den "Preis" auf Zelle B1, anstatt "Preis" manuell in die Formel eingeben zu müssen.  

Anmerkungen

Wenn Sie versuchen, Daten aus einem nicht vorhandenen Datentyp Feld abzurufen, gibt die Feldwert -funktion den #FIELD!-Fehler zurück.. So können Sie beispielsweise "Preise" eingegeben haben, wenn das Feld "ist-Datentyp" den Namen "Price" trägt. Überprüfen Sie Ihre Formel, um sicherzustellen, dass Sie einen gültigen Feldnamen verwenden. Wenn Sie eine Liste mit Feldnamen für einen Datensatz anzeigen möchten, wählen Sie die Zelle für den Datensatz aus, und drücken Sie ALT + UMSCHALT + F10.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Siehe auch

Aktien und geografische Datentypen

Schreiben von Formeln, die auf Datentypen verweisen

Fehlertyp #FELD!

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×