FEHLER.TYP (Funktion)

In diesem Artikel werden die Formelsyntax und die Verwendung der Funktion FEHLER.TYP in Microsoft Excel beschrieben.

Beschreibung

Gibt eine Zahl zurück, die einem der Fehlerwerte in Microsoft Excel entspricht, oder den Fehlerwert #NV, wenn kein Fehler vorhanden ist. Sie können FEHLER.TYP in einer WENN-Funktion verwenden, um einen Fehlerwert zu ermitteln und eine Zeichenfolge, beispielsweise eine Meldung, anstelle des Fehlerwerts zurückzugeben.

Syntax

FEHLER.TYP(Fehlerwert)

Die Syntax der Funktion FEHLER.TYP weist die folgenden Argumente auf:

  • Fehlerwert     Erforderlich. Der Fehlerwert, dessen Kennnummer Sie finden möchten. Üblicherweise besteht das Argument Fehlerwert, an dessen Stelle auch die definierten Fehlerwerte angegeben werden können, aus einem Bezug auf eine Zelle mit einer Formel, die Sie prüfen sollten.

Fehlerwert

Rückgabe von FEHLER.TYP

#NULL!

1

#DIV/0!

2

#WERT!

3

#BEZUG!

4

#NAME?

5

#ZAHL!

6

#NV

7

#DATEN_ABRUFEN

8

Sonstiges

#NV

Beispiel

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Daten

#NULL!

#DIV/0!

Formel

Beschreibung

Ergebnis

=FEHLER.TYP(A2)

Zahl des Fehlerwerts #NULL! (1)

1

=WENN(FEHLER.TYP(A3)<3;WAHL(FEHLER.TYP(A3);"Bereiche überschneiden sich nicht";"Der Divisor ist 0"))

Prüft, ob Zelle A3 entweder den Fehlerwert #NULL! oder den Fehlerwert #DIV/0! enthält. Wenn dies der Fall ist, wird die Zahl des Fehlerwerts in der Arbeitsblattfunktion WAHL verwendet, um eine von zwei Meldungen anzuzeigen. Andernfalls wird der Fehlerwert #NV zurückgegeben.

Der Divisor ist 0

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×