Erstellen von bedingten Formeln zum Suchen von Daten oder zum Zuweisen von Formatierungen

Wenn die in Excel integrierten Regeln für bedingte Formatierung nicht für Ihre Erfordernisse ausreichen, können Sie mithilfe einer Formel die gewünschten Ergebnisse erzielen. So können Sie beispielsweise mit einer bedingten Formel nach leeren Zellen suchen und diesen ein Format (etwa die Füllfarbe Rot) zuweisen, damit sie leicht erkennbar sind.

  1. Markieren Sie die Zellen, die Sie formatieren möchten.

  2. Klicken Sie auf Start > Bedingte Formatierung > Neue Regel.

  3. Klicken Sie auf Formel zur Ermittlung der zu formatierenden Zellen verwenden.

  4. Geben Sie unter Werte formatieren, für die diese Formel wahr ist Ihre Formel ein.

  5. Klicken Sie auf Formatieren.

  6. Ändern Sie mithilfe der Steuerelemente auf den Registerkarten Zahlen, Schrift, Rahmen und Ausfüllen Ihre Daten oder die Zellen, in der sich die Daten befinden.

Sie können beispielsweise negative Werte fett formatieren und die Schriftfarbe in Rot ändern, eine hellgelbe Füllfarbe für den Hintergrund der Zellen verwenden oder einen gestrichelten Rahmen hinzufügen.

Klicken Sie auf OK, um alle geöffneten Dialogfelder zu schließen.

Nachfolgend ein Beispiel:

  1. Markieren Sie alle Zellen in einem Arbeitsblatt. Klicken Sie dazu auf die Blattauswahl, die sich über der Zeile 1 und links neben der Spalte A befindet.

  2. Führen Sie die oben beschriebenen Schritte 1 bis 3 aus.

  3. Geben Sie bei Schritt 4 =REST(ZEILE();2)=1 ein.Bei Bedarf können Sie die Formel auch kopieren und einfügen.

  4. Klicken Sie auf Formatieren. Klicken Sie dann auf die Registerkarte Ausfüllen, und wählen Sie eine Blauschattierung aus der Farbpalette aus.

  5. Klicken Sie auf OK,um die Regel zu erstellen. Jede zweite Zeile in Ihrem Arbeitsblatt wird in der ausgewählten Farbe schattiert.

Das ist nur ein Beispiel für die Möglichkeiten, die Sie mit bedingten Formeln in einer Formatierungsregel haben.

Beispiele für bedingte Formeln

  • Wenn Sie leere Zellen suchen möchten, wählen Sie zuerst den Zellbereich (eine Zeile oder Spalte) aus, der die Ergebnisse enthalten soll. Führen Sie dann die im ersten Abschnitt beschriebenen Schritte aus, um eine Formatierungsregel mit folgender Formel zu erstellen:

    =B2=""

    In Ihrer Formel müssen Sie "B2" durch den Namen der ersten Zelle ersetzen, die Sie verwenden möchten.

  • Wenn Sie doppelte Werte in einem Zellbereich suchen möchten, können Sie es mit folgender Formel versuchen, mit der alle nicht eindeutigen Werte formatiert werden:

    =ZÄHLENWENN($A$1:$D$11;D2)>1

  • Geben Sie folgende Formel ein, wenn Sie Durchschnittswerte berechnen möchten:

    =A1>MITTELWERT(A1:A14)

Sobald Sie sich ein bisschen besser mit bedingten Formeln auskennen, können Sie die folgenden Formeln ausprobieren, in denen die logischen Operatoren WENN, UND und ODERverwendet werden. Diese Formeln werden auf der Excel-Bearbeitungsleiste eingegeben (und nicht in einer Regel verwendet). Sie vereinfachen jedoch die Arbeit und sparen Zeit.

  • Suchen von Werten, die zwei Bedingungen erfüllen: Excel zeigt WAHR an, wenn der Wert in Zelle A2 größer ist als der Wert in Zelle A3 und gleichzeitig kleiner als der Wert in Zelle A4. Wenn der Wert in Zelle A2 diese beiden Bedingungen nicht erfüllt, zeigt Excel stattdessen FALSCH an.

    =UND(A2>A3;A2<A4)

  • Suchen von Werten, die eine Bedingung erfüllen: Bei dieser Formel zeigt Excel nur WAHR an, wenn der Wert in Zelle A2 eine der Bedingungen erfüllt – er ist größer als der Wert in Zelle A3 oder kleiner als der Wert in Zelle A4.

    =ODER(A2>A3;A2<A4)

  • Verwenden von Formeln mit einem anderen Ergebnis als WAHR oder FALSCH: In diesem Beispiel wird "OK" angezeigt, wenn der Wert in Zelle A2 nicht mit den Werten in den Zellen A3 und A4 übereinstimmt. Andernfalls wird "NICHT OK" angezeigt.

    =WENN(UND(A2<>A3;A2<>A4);"OK";"NICHT OK") wird angezeigt.

  • Hinzufügen von Einstufungen auf der Grundlage eines Zahlenwerts: Mit dieser Formel werden auf Grundlage eines beliebigen Werts (z. B. Testergebnisse oder Produktbewertungen) Einstufungen hinzugefügt.

    =WENN(D2>=80;"A"; WENN(D2>=75;"B+"; WENN(D2>=70;"B"; WENN(D2>=70;"B"; WENN(D2>=65;"C+"; WENN(D2>=60;"C";"D"))))))

  • E rsetzen der Einstufungen durch "Bestanden" und "Nicht bestanden" :

    =WENN(D2>59;"Bestanden";"Nicht bestanden")

Weitere Informationen zur bedingten Formatierung

In diesen Artikeln finden Sie weitere Informationen zur bedingten Formatierung.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×