Erstellen von PSP-Codes

Kurz gesagt sind PSP-Codes Gliederungnummern, die Sie Vorgängen zuweisen und unter Berücksichtigung Ihrer speziellen Geschäftsanforderungen bearbeiten können. Project stellt automatisch für jeden Vorgang allgemeine Gliederungsnummern bereit. Sie können jedoch auch jederzeit ein eigenes angepasstes Gliederungsschema auf das Projekt anwenden.

Der folgende Abschnitt gilt nur für Microsoft Project 2016, 2013 und 2010.

Worüber möchten Sie mehr wissen?

Erstellen benutzerdefinierter PSP-Codes

Neuberechnen von PSP-Codes

Verwenden allgemeiner Gliederungsnummern

Erstellen benutzerdefinierter PSP-Codes

  1. Klicken Sie auf Ansicht, und wählen Sie dann eine Tabellenansicht (z. B. die Ansicht "Vorgang: Tabelle" oder "Ressource: Tabelle") aus.

  2. Klicken Sie auf Projekt. Klicken Sie in der Gruppe Eigenschaften auf PSP und dann auf Code definieren.

    Bild der Option 'Code definieren', aufgerufen über die Schaltfläche 'PSP'.

  3. Im Feld Projektcodepräfix können Sie einen projektspezifischen Code erstellen. Sie können Zahlen, Groß- und Kleinbuchstaben sowie Symbole verwenden.

Bild des Dialogfelds 'PSP-Codedefinition'

  1. Um den Code für die Vorgänge oberster Ebene festzulegen, wählen Sie in der ersten Zeile der Spalte Reihenfolge einen Zeichentyp aus der Dropdownliste aus. Zur Auswahl stehen Zahlen, Groß- und Kleinbuchstaben oder eine Kombination aus Zahlen, Buchstaben und anderen Symbolen.

  2. Legen Sie in der Spalte Länge die Anzahl der Zeichen für die einzelnen Ebenen der Codezeichenfolge fest. Klicken Sie auf Alle, um für die jeweilige Ebene eine beliebige Zeichenanzahl zu erlauben.

  3. Wählen Sie in der Spalte Trennzeichen ein Zeichen aus, durch das der Code der jeweiligen Ebene vom Code der nächsten Ebene getrennt wird.

    Standardtrennzeichen ist ein Punkt. Sie können andere Trennzeichen auswählen oder ganz auf Trennzeichen verzichten.

    Hinweis :  Das Trennzeichen kann nicht als Teil eines Codes verwendet werden.

  4. Legen Sie in Ihrer Gliederung für jede Ebene der geplanten Vorgänge eine Codezeichenfolge fest.

    Wenn Sie für jede Ebene individuelle Codes angeben möchten, klicken Sie in die nächste Zeile, und nehmen Sie in den Spalten Reihenfolge, Länge und Trennzeichen Ihre Eingaben vor.

  5. Wenn Project beim Eingeben eines neuen Vorgangs nicht automatisch einen PSP-Code zuordnen soll, deaktivieren Sie das Kontrollkästchen PSP-Code für neuen Vorgang erstellen.

  6. Wenn derselbe PSP-Code für mehrere Vorgänge zulässig sein soll, deaktivieren Sie das Kontrollkästchen Eindeutigkeit des neuen PSP-Codes überprüfen.

Neuberechnen von PSP-Codes

Wenn Sie Vorgänge verschieben oder löschen und PSP-Codes in Dokumenten oder anderen Systemen verwenden, die nicht mit der Project-Datei verknüpft sind, berechnet Project die PSP-Codes nicht automatisch neu. Das bedeutet, dass die Codes für die verbleibenden Vorgänge wahrscheinlich fehlerhaft sind. Gehen Sie wie folgt vor, um die PSP-Codes von allen oder ausgewählten Vorgängen neu zu berechnen:

  1. Klicken Sie auf Ansicht, und wählen Sie dann eine Tabellenansicht (z. B. die Ansicht "Vorgang: Tabelle") aus, die die neu zu berechnenden Vorgänge enthält.

  2. Wählen Sie die Vorgänge aus, die Sie neu berechnen möchten. Der erste ausgewählte Vorgang wird nicht neu berechnet.

    Sollen die PSP-Codes für alle Vorgänge neu berechnet werden, wählen Sie keinen Vorgang aus.

  3. Klicken Sie auf Projekt. Klicken Sie in der Gruppe Eigenschaften auf PSP und dann auf Neu berechnen.

    Bild der Registerkarte 'Projekt', Schaltfläche 'PSP', Befehl 'Neu berechnen' im Dropdown-Menü.

  4. Klicken Sie auf Ausgewählte Vorgänge, um die Codes für die ausgewählten Vorgänge neu zu berechnen.

    Klicken Sie auf Gesamtes Projekt, um die Codes für alle Vorgänge im Projekt neu zu berechnen.

    Bild des Dialogfelds 'PSP-Code neu berechnen'

Verwenden allgemeiner Gliederungsnummern

Wenn Sie nicht die detaillierte Struktur benötigen, die mit PSP-Codes ermöglicht wird, können Sie eine allgemeine Gliederung verwenden.

Project erstellt automatisch Gliederungsnummern für jeden Vorgang, und zwar abhängig von der Platzierung des Vorgangs innerhalb der Struktur der Vorgangsliste. Der erste Vorgang in der Vorgangsliste erhält beispielsweise die Nummer 1. Wenn dieser Vorgang drei Teilvorgänge enthält, werden diese mit 1.1, 1.2 und 1.3. nummeriert.

Gliederungsnummern bestehen ausschließlich aus Zahlen und können nicht bearbeitet werden. Sie ändern sich automatisch, wenn Sie einen Vorgang in der Vorgangsliste nach oben oder unten verschieben und Vorgänge herunter- oder heraufstufen.

Zum Anzeigen der Gliederungsnummern fügen Sie das Feld Gliederungsnummer zu einer Tabelle oder Blatthinzu. Gliederungsnummern können auch direkt zu den Namen von Vorgängen hinzugefügt werden:

  1. Rufen Sie die Ansicht Gantt-Diagramm oder Vorgang: Tabelle auf.

  2. Klicken Sie auf Format, und aktivieren Sie dann in der Gruppe Einblenden/Ausblenden das Kontrollkästchen Gliederungsnummer.

Seitenanfang

Dieser Abschnitt gilt nur für Microsoft Project 2007.

Worüber möchten Sie mehr wissen?

Informationen zu PSP-Codes

Definieren benutzerdefinierter PSP-Codes

Neuberechnen von PSP-Codes

Informationen zu PSP-Codes

Es gibt zwei Arten von PSP-Codes in Microsoft Office Project: Gliederungsnummern und benutzerdefinierte PSP-Codes. In den folgenden Abschnitten erfahren Sie mehr darüber.

Gliederungsnummern

Gliederungsnummern stellen den einfachsten Typ der PSP-Codierung dar. Microsoft Office Project berechnet automatisch eine Gliederungsnummer für jeden Vorgang basierend auf der Nummerierung der Gliederungsstruktur der Vorgangsliste. Der erste Vorgang in der Vorgangsliste erhält beispielsweise die Nummer 1. Wenn dieser Vorgang drei Teilvorgänge enthält, werden diese mit 1.1, 1.2 und 1.3. nummeriert.

Gliederungsnummern bestehen nur aus Zahlen (keine Buchstaben) und können nicht bearbeitet werden. Sie werden allerdings automatisch geändert, wenn Sie einen Vorgang in der Vorgangsliste nach oben oder unten verschieben und wenn Sie Vorgänge herunter- oder heraufstufen. Wenn beispielsweise ein Teilvorgang, der aktuell die Gliederungsnummer 3.5.4 aufweist, in der Liste um eine Zeile nach oben verschoben wird, wird die Gliederungsnummer automatisch auf 3.5.3 aktualisiert. Wenn Sie dann den gleichen Teilvorgang heraufstufen, wird die Gliederungsnummer automatisch auf 3.6 aktualisiert.

Tipp : Um Gliederungsnummern anzuzeigen, können Sie das Feld Gliederungsnummer zu einer Tabellenansicht hinzufügen, oder Sie können die Gliederungsnummern neben den Vorgangsnamen anzeigen. Zum Anzeigen der Gliederungsnummern neben den Vorgangsnamen klicken Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Ansicht. Aktivieren Sie unter Gliederungsoptionen das Kontrollkästchen Gliederungsnummer anzeigen.

Benutzerdefinierte PSP-Codes

Wenn Ihr Projekt von detaillierten PSP-Codes mit bestimmten Längen, Reihenfolgen oder Gruppen von Zahlen und Buchstaben profitieren würde, können Sie ein einzelnes benutzerdefiniertes PSP-Codeformat für das Projekt festlegen. (Jedes Projekt kann nur ein einzelnes benutzerdefiniertes Codeformat aufweisen.) Der benutzerdefinierte PSP-Code wird im Feld PSP erfasst.

Wie bei den Gliederungsnummern stellt jede Ebene eines benutzerdefinierten PSP-Codes eine Gliederungsebene in der Vorgangsliste dar. Sie können ein eindeutiges Format für jede Ebene des Codes verwenden, und jede Ebene wird im Code entsprechend der Hierarchie der Vorgänge, Sammelvorgänge und Teilvorgänge aufgeführt.

Wenn Sie beispielsweise in Phasen angeordnete Projekte planen, die sich an organisatorischen Richtlinien für das anstehende Geschäftsjahr orientieren, können Sie ein benutzerdefiniertes PSP-Codeformat erstellen, das jeden Vorgang anhand der entsprechenden Angaben für Richtlinie, Quartal und Projekt darstellt. Bei Verwendung dieses Codes kann es einen Vorgang mit dem benutzerdefinierten PSP-Code "Kdzufr.Q3.KSTools.11" geben, der besagt, dass es sich um Vorgang 11 im Projekt für das Upgrade der Kundensupport-Tools handelt, das während des dritten Quartals gestartet wird und die Geschäftsrichtlinie für Kundenzufriedenheit für das geplante Geschäftsjahr unterstützt.

Seitenanfang

Definieren benutzerdefinierter PSP-Codes

  1. Klicken Sie im Menü Ansicht auf eine Tabellenansicht, z. B. die Ansicht " Vorgang: Tabelle".

    Wenn Sie eine Ansicht verwenden möchten, die nicht im Menü Ansicht enthalten ist, klicken Sie auf Weitere Ansichten. Klicken Sie dann in der Liste Ansichten auf die gewünschte Ansicht, und klicken Sie anschließend auf Übernehmen.

  2. Zeigen Sie im Menü Projekt auf PSP, und klicken Sie dann auf Code definieren.

  3. Um Vorgänge in diesem Projekt von Vorgängen in anderen Projekten zu unterscheiden, geben Sie ein projektspezifisches Codepräfix in das Feld Projektcodepräfix ein.

    Dieses Präfix hilft bei der Identifizierung des Projekts auf der höchsten Ebene des PSP-Codes. Das Präfix kann bei der Identifizierung der Teilprojekte innerhalb eines Hauptprojekts oder beim Erstellen von projektübergreifenden Vorgangsbeziehungen hilfreich sein.

    Sie können eine beliebige Kombination von Zahlen, Groß- und Kleinbuchstaben sowie Symbolen für das Projektcodepräfix eingeben.

  4. Zum Angeben der Codezeichenfolge für Vorgänge der obersten Ebene klicken Sie in der ersten Zeile in der Spalte Reihenfolge auf den Zeichentyp, den Sie für diese Ebene verwenden möchten:

    • Klicken Sie auf Zahlen (geordnet), um einen numerischen PSP-Code für diese Ebene anzuzeigen (z. B. 1, 2 und 3 für die ersten drei Sammelvorgänge im Projekt).

    • Klicken Sie auf Großbuchstaben (geordnet), um alphabetische PSP-Codes in Großbuchstaben anzuzeigen (z. B. A, B und C für die ersten drei Sammelvorgänge im Projekt).

    • Klicken Sie auf Kleinbuchstaben (geordnet), um alphabetische PSP-Codes in Kleinbuchstaben anzuzeigen (z. B. a, b und c für die ersten drei Sammelvorgänge im Projekt).

    • Klicken Sie auf Zeichen (ungeordnete), um eine beliebige Kombination aus Zahlen sowie Groß- und Kleinbuchstaben anzuzeigen (z. B. Arch1, Konst1 und Insp1 für die ersten drei Sammelvorgänge im Projekt).

      Die Auswahl dieser Option bietet die größte Flexibilität bei der Eingabe benutzerdefinierter PSP-Codes. Project zeigt ein Sternchen (*) im PSP-Feld an, bis Sie eine Zeichenfolge für diese Ebene des PSP-Codes eingeben.

  5. Geben Sie in der Spalte Länge die Anzahl der Zeichen für jede Ebene der Codezeichenfolge ein, oder wählen Sie einen Wert aus. Sie können entweder die genaue Anzahl von Zeichen eingeben oder Alle auswählen, um eine beliebige Anzahl von Zeichen für diese Codeebene zuzulassen.

    Sie können z. B. 3 eingeben, damit drei Zeichen die obligatorische Anzahl von Zeichen ist, die für eine Ebene des PSP-Codes einzugeben sind. Ein PSP-Code kann eine Gesamtlänge von 1 bis 255 haben.

  6. Geben Sie in der Spalte Trennzeichen ein Zeichen ein, oder wählen Sie ein Zeichen aus, durch das die Codezeichenfolge der jeweiligen Ebene von der Codezeichenfolge der nächsten Ebene getrennt wird.

    Das Standardtrennzeichen ist ein Punkt. Sie können auf jeder Codeebene ein anderes Trennzeichen verwenden.

    Sie können auch auswählen, dass kein Trennzeichen zwischen den Codeebenen verwendet wird. Löschen Sie im Feld Trennzeichen das vorhandene Trennzeichen.

  7. Geben Sie in Ihrer Gliederung für jede Ebene der geplanten Vorgänge eine Codezeichenfolge an.

    Wenn Sie für jede Ebene individuelle Codezeichenfolgen angeben möchten, klicken Sie in die nächste Zeile, und nehmen Sie in den Spalten Reihenfolge, Länge und Trennzeichen Ihre Eingaben vor.

  8. Wenn Project beim Eingeben eines neuen Vorgangs nicht automatisch einen PSP-Code zuordnen soll, deaktivieren Sie das Kontrollkästchen PSP-Code für neuen Vorgang erstellen.

  9. Wenn derselbe PSP-Code für mehrere Vorgänge zulässig sein soll, deaktivieren Sie das Kontrollkästchen Eindeutigkeit des neuen PSP-Codes überprüfen.

Hinweis : 

  • Das Zeichen, das Sie als Trennzeichen verwenden, kann nicht gleichzeitig Teil des Codes sein. Wenn Sie z. B. einen Bindestrich als Trennzeichen verwenden, können Sie in dem Code, den Sie zur Darstellung eines Vorgangs verwenden, keinen Bindestrich verwenden.

  • Es kann jeweils nur ein Satz von PSP-Codes pro Projekt definiert werden. Wenn Sie eine zusätzliche Organisationsstruktur für Vorgänge anzeigen müssen, können Sie benutzerdefinierte Felder verwenden, um einen separaten Satz von Codes zu erstellen oder anzuwenden.

  • Zum Anzeigen von PSP-Codes müssen Sie das Feld PSP zur Ansicht hinzufügen.

  • Um den PSP-Code für einen Sammelvorgang und alle zugehörigen Teilvorgänge zu ändern, müssen Sie den vorhandenen Code oder die Sternchen im PSP-Code des Sammelvorgangs in einen anderen Satz von Zeichen ändern.

    Hier ein Beispiel: Der PSP-Code für einen bestimmten Teilvorgang ist "Ph3.Prj5.Arch.Vorgang3". "Vorgang3" steht für den Teilvorgang "Pläne entwickeln" und "Arch" steht für den Sammelvorgang "Architekturlösung". Der Name des Sammelvorgangs wird in "Entwurfslösung" geändert, und Sie müssen den Code für den Sammelvorgang und alle zugehörigen Teilvorgänge aktualisieren. Sie ändern den PSP-Code so, dass der Sammelvorgang durch "Entw" dargestellt wird, und der PSP-Code für den Teilvorgang "Pläne entwickeln" wird automatisch auf "Ph3.Prj5.Entw.Vorgang3" aktualisiert.

Neuberechnen von PSP-Codes

Nach dem Verschieben oder Löschen von Vorgängen weisen deren benutzerdefinierte PSP-Codes möglicherweise nicht mehr die richtige Reihenfolge auf. Project berechnet die PSP-Codes nicht automatisch neu, da diese PSP-Codes möglicherweise in Dokumenten oder anderen Systemen verwendet werden, die nicht mit der Project-Datei verknüpft sind. Sie können die PSP-Codes aller oder ausgewählter Vorgänge neu berechnen:

  1. Klicken Sie im Menü Ansicht auf eine Tabellenansicht, die die neu zu berechnenden Vorgänge enthält, z. B. die Ansicht "Vorgang: Tabelle".

    Wenn Sie eine Ansicht verwenden möchten, die nicht im Menü Ansicht enthalten ist, klicken Sie auf Weitere Ansichten. Klicken Sie dann in der Liste Ansichten auf die gewünschte Ansicht, und klicken Sie anschließend auf Übernehmen.

  2. Wählen Sie die neu zu berechnenden Vorgänge aus. (Der erste Vorgang in einer Auswahl von Vorgängen wird nicht neu berechnet. Er wird als der Bezugspunkt für die Neuberechnung der anderen Vorgänge verwendet.)

    Sollen die PSP-Codes für alle Vorgänge neu berechnet werden, wählen Sie keinen Vorgang aus.

  3. Zeigen Sie im Menü Projekt auf PSP, und klicken Sie dann auf Neu berechnen.

  4. Wenn Sie nur die PSP-Codereihenfolge für ausgewählte angrenzende Vorgänge korrigieren möchten, klicken Sie auf Ausgewählte Vorgänge.

    Um die PSP-Codereihenfolge für alle Vorgänge im Projekt zu korrigieren, klicken Sie auf Gesamtes Projekt.

Hinweis : 

  • Wenn Ihr Projekt Teilprojekte enthält, können Sie einige oder alle Vorgänge in den einzelnen Teilprojekten neu berechnen, indem Sie alle Teilvorgänge anzeigen. Klicken Sie auf Anzeigen Anzeigen und dann auf Alle Teilvorgänge. (Project kann keine Neuberechnung für Vorgänge in Teilprojekten durchführen, die nicht angezeigt werden.)

  • Durch die Neuberechnung von Teilprojekten, die in ein Hauptprojekt eingefügt werden, ändert sich auch der Code, der die einzelnen Unterprojekt auf Projektebene darstellt.

  • Zum Anzeigen von PSP-Codes können Sie eine Spalte PSP zu einer Tabellenansicht hinzufügen.

  • Wenn Sie PSP-Codes nach deren Berechnung in Project ändern möchten, zeigen Sie im Menü Projekt auf PSP, und klicken Sie dann auf Code definieren. Ändern Sie in der Spalte Reihenfolgen den Zeichentyp einer beliebigen Ebene des Codeformats. Wenn Sie einen Code auf Sammelvorgangsebene aktualisieren, werden alle Teilvorgänge für diesen Sammelvorgang automatisch aktualisiert.

    Wenn Schwierigkeiten beim Ändern der PSP-Codes auftreten, kann dies eine der folgenden Ursachen haben:

    • Sie versuchen, einen PSP-Code mit einem Codeformat zu ändern, nachdem der Code berechnet wurde    Wenn Sie ein PSP-Codeformat erstellt haben und bereits PSP-Codes für Vorgänge berechnet wurden, können Sie den PSP-Code nur ändern, indem Sie die Ebenen des Codeformats neu festlegen. Nachdem Sie Ebenen des Codeformats neu festgelegt haben, können Sie jede Ebene des Codeformats von geordneten Zahlen, geordneten Großbuchstaben, geordneten Kleinbuchstaben oder ungeordneten Zeichen in einen anderen Typ ändern.

    • Sie versuchen, PSP-Codes auf einer niedrigeren Ebene in der Vorgangsliste zu ändern    Sie können die Zeichen im PSP-Code für einen Teilvorgang nicht ändern, sondern nur für den Sammelvorgang, in dem diese Ebene des PSP-Codes definiert ist.

Seitenanfang

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×