Erstellen und Verwenden von Unterberichten

Bei der Arbeit mit relationalen Daten (und wenn die zusammengehörigen Daten in separaten Tabellen gespeichert sind) müssen Sie häufig Daten aus mehr als einer Tabelle anzeigen oder für den gleichen Bereich abfragen. So kann es vorkommen, dass Sie beispielsweise Kundendaten und gleichzeitig Informationen zu den Aufträgen des Kunden anzeigen möchten. In diesem Fall stellt ein Unterbericht ein hilfreiches Tool hierfür dar, da Sie hiermit die Auftragsinformationen gemeinsam mit Kundendaten in einer logischen und übersichtlichen Weise in einem Bericht darstellen können. Microsoft Office Access 2007 bietet zahlreiche Möglichkeiten für die schnelle Erstellung von Unterberichten.

Was möchten Sie tun?

Grundlegendes zu Unterberichte

Erstellen eines Unterberichts

Nehmen Sie Änderungen am Entwurf an einen Unterbericht

Verstehen der Grundlagen von Unterberichten

Ein Unterbericht ist ein Bericht, der in einem anderen Bericht eingefügt wird. Wenn Sie mehrere Berichte zusammenführen, muss eine von ihnen als Hauptbericht dienen, die den anderen Bericht enthält. Ein Hauptbericht ist gebunden oder ungebundenen. Ein gebundener Bericht ist eine können Daten anzeigen und verfügt über eine Tabelle, ein Abfrage oder SQL-Anweisung angegebenen seine Eigenschaft Datensatzquelle angezeigt. Ungebundener Bericht ist eine, die nicht auf eine Tabelle, Abfrage oder SQL-Anweisung basiert (d. h., die Eigenschaft Datensatzquelle des Berichts ist leer).

Tipp : Haben in Access 2010 Berichte, Steuerelementlayouts, die Dinge aufgestellt schützen und gute suchen!

Beispiel für ein ungebundener Hauptbericht mit zwei nicht verknüpften Unterberichten   

In einem ungebundenen Hauptbericht können keine eigenen Daten angezeigt werden, er kann jedoch als Hauptbericht für nicht verknüpfte Unterberichte dienen, die Sie zusammenführen möchten.

Ungebundener Hauptbericht mit zwei Unterberichten, in den nicht miteinander verknüpfte Daten angezeigt werden

1. Der ungebundene Hauptbericht enthält zwei Unterberichte.

2. In einem Unterbericht werden die Umsätze nach Mitarbeiter zusammengefasst.

3. Im anderen Unterbericht werden die Umsätze nach Kategorie zusammengefasst.

Beispiel für einen Hauptbericht und Unterbericht, die an die gleiche Datensatzquelle gebunden sind   

Der Hauptbericht kann zur Anzeige von Detaildatensätzen wie jedem Umsatz in einem Jahr verwendet werden, und im Unterbericht können nun zusammenfassende Informationen wie die Gesamtumsätze pro Quartal angezeigt werden.

Hauptbericht und Unterbericht, die an die gleiche Datensatzquelle gebunden sind

1. Im Unterbericht werden die jährlichen Umsätze pro Quartal zusammengefasst.

2. Im Hauptbericht werden die täglichen Umsätze aufgeführt.

Beispiel für einen Hauptbericht und Unterbericht, die an gebunden sind verknüpfte Datenquellen   

Ein Hauptbericht kann gemeinsame Daten enthalten, die ein oder mehrere Unterberichte gelten. In diesem Fall enthält der Unterbericht Daten, die mit den Daten des Hauptberichts verknüpft sind.

Hauptbericht mit zwei Unterberichten, die miteinander verknüpfte Daten anzeigen

1. Im Hauptbericht werden der Name und die Stadt jeder Messe aufgelistet.

2. Im Unterbericht werden die Unternehmensvertreter aufgeführt, die an der jeweiligen Messe teilnehmen.

Unterformulare in einem Bericht

Ein Hauptbericht kann Unterformulare, Unterberichte, zusätzlich zu enthalten, und können sie beliebig viele Unterformulare enthalten, und Unterberichte, wie Sie möchten. Darüber hinaus kann ein Hauptbericht bis zu sieben Ebenen von Unterformularen und Unterberichten enthalten. Angenommen, ein Bericht kann einen Unterbericht enthalten, und diese Unterberichts kann ein Unterformular oder einen Unterbericht usw., bis zu sieben Ebenen enthalten.

Wenn Sie einem Bericht ein Unterformular hinzufügen und den Bericht dann in der Berichtsansicht öffnen, können Sie die Datensätze mithilfe des Unterformulars filtern und hierin navigieren. Dem Formular und dessen Steuerelementen zugeordneter VBA-Code (Visual Basic für Applikationen) sowie eingebettete Makros werden weiterhin ausgeführt, obwohl in diesem Kontext einige Ereignisse deaktiviert sind. So können Sie mithilfe eines Unterformulars in einem Berichte keine Datensätze hinzufügen, bearbeiten oder löschen.

Verknüpfen eines Berichts mit einem Unterformular oder Unterbericht

Beim Einfügen eines Unterformulars oder Unterberichts, das oder der Daten enthält, die mit den Daten im Hauptbericht verknüpft sind, muss das Steuerelement "Unterbericht" mit dem Hauptbericht verknüpft werden. Diese Verknüpfung stellt sicher, dass die im Unterformular oder Unterbericht angezeigten Datensätze auch wirklich den Datensätzen entsprechen, die im Hauptbericht gedruckt werden.

Wenn Sie ein Unterformular oder einen Unterbericht mithilfe eines Assistenten erstellen oder wenn Sie ein Objekt aus dem Navigationsbereich in den Bericht ziehen, verknüpft Access das Unterformular oder den Unterbericht automatisch mit dem Hauptbericht, wenn eine der folgenden Bedingungen zutrifft:

  • Definieren von Beziehungen für die Tabellen, die Sie auswählen, oder Sie definieren die Beziehungen für die Tabellen, die zugrunde liegenden der Abfragen, die Sie auswählen.

    Weitere Informationen zum Erstellen von Beziehungen finden Sie unter den Verknüpfungen im Abschnitt Siehe auch.

  • Der Hauptbericht basiert auf einer Tabelle mit einem Primärschlüssel, und das Unterformular oder der Unterbericht basieren auf einer Tabelle, die ein Feld mit dem gleichen Namen wie das Primärschlüsselfeld enthält und das den gleichen oder einen kompatiblen Datentyp aufweist. Ist der Primärschlüssel der Tabelle, die dem Hauptbericht zugrunde liegt, beispielsweise ein Feld vom Typ "AutoWert" und ist dessen Eigenschaft Feldgröße auf Long Integer festgelegt, muss das entsprechende Feld in der Tabelle, auf der das Unterformular oder der Unterbericht basiert, ein Zahlenfeld sein, dessen Eigenschaft Feldgröße auf Long Integer festgelegt ist. Wenn Sie eine oder mehrere Abfragen als Datensatzquelle eines Unterformulars oder Unterberichts auswählen, müssen die der oder den Abfragen zugrunde liegenden Tabellen die gleichen Bedingungen erfüllen.

Seitenanfang

Erstellen eines Unterberichts

Wenn ein Unterbericht mit einem Hauptbericht verknüpft wird, stellen Sie sicher, dass die zugrunde liegenden Datensatzquellen verwandt sind, bevor Sie das folgende Verfahren verwenden. Weitere Informationen zum Erstellen von Beziehungen finden Sie unter den Links im Abschnitt Siehe auch.

Verwenden des Unterberichts-Assistenten zum Erstellen eines Unterberichts

  1. Öffnen Sie den Bericht, den Sie als Hauptbericht verwenden möchten, in der Entwurfsansicht.

  2. Stellen Sie sicher, dass Steuerelement-Assistenten verwenden Schaltflächensymbol ausgewählt ist, klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente. Schaltflächensymbol

  3. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente auf Unterformular /-Bericht Schaltflächensymbol .

  4. Klicken Sie im Bericht auf die Stelle, an der der Unterbericht erscheinen soll.

  5. Wenn Sie ein neues Unterformular oder einen neuen Unterbericht erstellen möchten und dieses oder dieser auf einer Tabelle oder einer Abfrage basieren soll, klicken Sie auf der ersten Seite des Unterberichts-Assistenten auf Bereits vorhandene Tabellen und Abfragen verwenden. Wenn bereits ein Bericht oder ein Formular vorhanden ist, der oder das als Unterbericht/-formular verwendet werden soll, klicken Sie auf Bestehenden Bericht oder bestehendes Formular benutzen, wählen Sie den Bericht oder das Formular aus der Liste aus, und klicken Sie dann auf Weiter.

    Auswählen der Datenquelle im Unterberichts-Assistenten

  6. Wenn Sie auf der vorherigen Seite des Assistenten Bestehenden Bericht oder bestehendes Formular benutzen ausgewählt haben, überspringen Sie diesen Schritt, und fahren Sie direkt mit Schritt 7 fort. Andernfalls wählen Sie aus der Liste Tabellen/Abfragen die Tabelle oder die Abfrage aus, die die Felder enthält, die in den Unterbericht aufgenommen werden sollen. Doppelklicken Sie anschließend in der Liste Verfügbare Felder auf die gewünschten Felder, um sie dem Unterbericht hinzuzufügen.

    Erstellen von Feldern im Unterberichts-Assistenten

    Wenn Sie den Unterbericht mit dem Hauptbericht verknüpfen möchten, fügen Sie unbedingt das oder die Felder hinzu, die für die Erstellung der Verknüpfung verwendet werden sollen, und zwar auch dann, wenn diese nicht angezeigt werden sollen. Normalerweise handelt es sich bei dem Verknüpfungsfeld um ein ID-Feld. In der vorstehenden Abbildung ist die Auftragstabelle die Datensatzquelle des Unterberichts und die Kundentabelle die Datensatzquelle des Hauptberichts. Da die Auftragstabelle über das Feld "Kunden-ID" mit der Kundentabelle verknüpft ist, wird dieses Feld der Liste Ausgewählte Felder hinzugefügt.

    Hinweis : Sie können in den Unterbericht Felder aus mehreren Tabellen und Abfragen einschließen. Wenn Sie alle gewünschten Felder aus der einen Tabelle hinzugefügt haben, wählen Sie die nächste Tabelle oder Abfrage aus der Liste Tabellen/Abfragen aus, und fügen Sie hieraus die gewünschten Felder hinzu.

    Klicken Sie auf Weiter, um fortzufahren.

  7. Auf dieser Seite des Assistenten legen Sie fest, wie der Unterbericht mit dem Hauptbericht verknüpft werden soll. Wenn Access Felder findet, die für die Verknüpfung des Unterberichts mit dem Hauptbericht geeignet erscheinen, zeigt der Assistent eine Liste mit Verknüpfungsvorschlägen an.

    Access schlägt Felder für die Verknüpfung im Unterberichts-Assistenten vor

    Sie können nun den Verknüpfungsvorschlag auswählen, der für Ihr Szenario am besten geeignet ist, oder Sie können Keine auswählen, wenn der Unterbericht nicht mit dem Hauptbericht verknüpft werden soll. Wenn Sie den Unterbericht mit dem Hauptbericht verknüpfen möchten, Ihnen jedoch keiner Verknüpfungsvorschläge als geeignet erscheint, klicken Sie auf Eigene definieren.

    Hinweis : Wenn der Assistent keine geeigneten Felder für die Verknüpfung finden kann, wird auch keine Liste mit Verknüpfungsvorschlägen angezeigt, und die Option Eigene definieren wird automatisch ausgewählt.

    Definieren von eigenen Verknüpfungen im Unterberichts-Assistenten

    Bei Auswahl der Option Eigene definieren zeigt der Assistent zwei Listensätze an.

    • Wählen Sie unter Formular-/Berichtsfelder das oder die Felder aus dem Hauptbericht aus, die zum Verknüpfen des Hauptberichts mit dem Unterbericht oder Unterformular verwendet werden sollen. Es können bis zu drei Felder ausgewählt werden, und jedes ausgewählte Feld muss einem zugehörigen in der Datenquelle des Unterformulars oder des Unterberichts entsprechen.

    • Wählen Sie unter Unterformular-/Unterberichtsfelder das oder die entsprechenden Felder aus dem Unterformular oder dem Unterbericht aus, mit dem oder denen eine Verknüpfung zu den ausgewählten Feldern im Hauptbericht hergestellt wird.

    • Wenn zwischen Unterformular oder Unterbericht und Hauptbericht keine Verknüpfung hergestellt werden soll, vergewissern Sie sich, dass alle Listen leer sind.

      Klicken Sie auf Weiter, um fortzufahren.

  8. Geben Sie auf der letzten Seite des Assistenten einen Namen für das Unterformular oder den Unterbericht ein, und klicken Sie einfach auf Fertig stellen, um den Standardnamen zu übernehmen.

    Hinzufügen eines Namens im Unterberichts-Assistenten

Access fügt ein Unterbericht-Steuerelement des Berichts hinzu und bindet das Steuerelement (d. h., es legt die Eigenschaft des Steuerelements Quellobjekt ) wie folgt:

  • Wenn Sie auf der ersten Seite des Assistenten Bestehenden Bericht oder bestehendes Formular benutzen ausgewählt haben, bindet Access das Unterberichts-Steuerelement an den angegebenen Bericht oder an das angegebenen Formular.

  • Wenn Sie auf der ersten Seite des Assistenten Bereits vorhandene Tabellen und Abfragen verwenden ausgewählt haben, erstellt Access im Navigationsbereich ein neues Berichtsobjekt und bindet dann das Unterberichts-Steuerelement an diese neue Berichtsobjekt. Der Name des neuen Berichtsobjekts entspricht dem Namen, den Sie auf der letzten Seite des Assistenten eingegeben haben.

Hinzufügen einer Tabelle, einer Abfrage, eines Formulars oder eines Berichts als Unterbericht

Eine schnelle Möglichkeit zum Hinzufügen eines Unterberichts zu einem Bericht ist, öffnen den Hauptbericht in der Entwurfsansicht, und ziehen ein Objekt aus dem Navigationsbereich darauf. Wenn Sie das Unterformular oder den Unterbericht mit einem Hauptbericht verknüpft werden soll, stellen Sie sicher, dass die zugrunde liegenden Datensatzquellen verwandt sind und die Datenquellen, die Felder, die verwendet wird enthalten, um das Unterformular oder den Unterbericht mit einem Hauptbericht verknüpfen. Weitere Informationen zum Erstellen von Beziehungen finden Sie unter den Links im Abschnitt Siehe auch.

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht, der als Hauptbericht verwendet werden soll, und klicken Sie dann im Kontextmenü auf Entwurfsansicht.

  2. Ziehen Sie die Tabelle, die Abfrage, das Formular oder einen anderen Bericht aus dem Navigationsbereich in den Bereich des Hauptberichts, in dem der Unterbericht erscheinen soll.

Access führt nun einen der folgenden Schritte aus:

  • Wenn Access feststellen kann, wie die beiden Objekte verknüpft werden müssen, fügt die Anwendung dem Bericht ein Unterberichts-Steuerelement hinzu. Wenn Sie ein Formular oder einen Bericht hinzufügen, bindet Access das Unterberichts-Steuerelement an dieses Objekt. Wenn Sie eine Tabelle oder eine Abfrage hinzufügen, erstellt Access zunächst ein Berichtsobjekt und bindet das Unterberichts-Steuerelement dann an dieses neue Objekt.

  • Wenn Access zum Verknüpfen von zwei Objekten wie ermitteln kann, wird im Unterberichts-Assistenten. Gehen Sie im Abschnitt Erstellen eines Unterberichts, beginnen mit Schritt 7 vor, um den Vorgang fortzusetzen.

    Nach Abschluss des Assistenten fügt Access den Unterbericht dem Bericht hinzu.

Mit dem folgenden Verfahren können Sie prüfen, ob das Unterformular oder der Unterbericht ordnungsgemäß mit dem Hauptbericht verknüpft wurde.

  1. Klicken Sie auf das Unterberichts-Steuerelement, um es auszuwählen.

  2. Wenn das Eigenschaftenblatt nicht bereits angezeigt wird, drücken Sie F4, um es anzuzeigen.

  3. Prüfen Sie auf der Registerkarte Daten des Eigenschaftenblatts die Eigenschaften Verknüpfen nach und Verknüpfen von.

    • Bei einem nicht verknüpften Unterformular oder Unterbericht sollten beide Eigenschaften leer sein.

    • Bei einem verknüpften Unterformular oder Unterbericht sollten in den Eigenschaften Verknüpfen nach und Verknüpfen von das oder die Felder angezeigt werden, mit denen die beiden Objekte verknüpft werden. Werden im Hauptbericht beispielsweise Daten aus der Mitarbeitertabelle und im Unterformular oder Unterbericht Daten aus der Auftragstabelle angezeigt, sollte in der Eigenschaft Verknüpfen nach das ID-Feld aus der Mitarbeitertabelle und in der Eigenschaft Verknüpfen von das Feld "Mitarbeiter-ID" aus der Auftragstabelle angezeigt werden.

Möglicherweise stellen Sie fest, dass diese Eigenschaften bearbeitet werden müssen, damit das Unterformular oder der Unterbericht ordnungsgemäß eingebunden wird. Verwenden Sie dazu folgendes Verfahren.

  1. Klicken Sie auf der Registerkarte Daten des Eigenschaftenfensters klicken Sie auf das Eigenschaftenfeld Verknüpfen nach, und klicken Sie dann auf Schaltfläche "Generator" .

    Das Dialogfeld Feldverknüpfungs-Assistent für Unterberichte wird angezeigt.

    Dialogfeld "Feldverknüpfungs-Assistent für Unterberichte"

  2. Wählen Sie in den Listen Felder in übergeordneter Tabelle und Felder in untergeordneter Tabelle die Felder aus, über die die Berichte verknüpft werden sollen. Wenn Sie nicht sicher sind, welche Felder verwendet werden sollten, klicken Sie auf Vorschlagen, damit Access versucht, die geeigneten Verknüpfungsfelder zu ermitteln. Wenn Sie fertig sind, klicken Sie auf OK.

    Wird das Feld zum Verknüpfen des Berichts nicht angezeigt, müssen Sie die Datensatzquelle des Hauptberichts oder des Unterformulars oder Unterberichts bearbeiten, um sicherzustellen, dass das Verknüpfungsfeld hierin enthalten ist. Basiert der Bericht beispielsweise auf einer Abfrage, müssen Sie sicherstellen, dass das Verknüpfungsfeld in den Abfrageergebnissen vorhanden ist.

  3. Speichern Sie den Hauptbericht, und schalten Sie in die Berichtsansicht um. Prüfen Sie nun, dass der Bericht wie gewünscht funktioniert.

Hinzufügen einer Tabelle oder einer Abfrage als Datenblatt

Ein Datenblatt ist eine einfache Datendarstellung, die mit einem Tabellenblatt verglichen werden kann. Jede Spalte im Datenblatt steht für ein Feld in der Herkunftstabelle oder -abfrage, und jede Zeile steht für einen Datensatz. Mithilfe des Unterformular- oder Unterberichts-Steuerelements kann ein Datenblatt in einem Bericht angezeigt werden. Dies ist eine gute Technik für Situationen, in denen eine kompakte Datenansicht gewünscht wird, die Formatierungsmöglichkeiten eines Formular- oder Berichtsobjekts jedoch nicht benötigt werden. So fügen Sie einem Bericht ein Datenblatt hinzu:

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht, der als Hauptbericht verwendet werden soll, und klicken Sie dann im Kontextmenü auf Entwurfsansicht.

  2. Stellen Sie sicher, dass Steuerelement-Assistenten verwenden nicht ausgewählt ist, klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente. Schaltflächensymbol

  3. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente auf das Unterformular /-Bericht Tool Schaltflächensymbol .

  4. Klicken Sie im Bericht auf die Stelle, an der der Unterbericht erscheinen soll.

  5. Wenn der Unterberichts-Assistent gestartet wird, klicken Sie auf Abbrechen, um ihn zu schließen.

  6. Wenn das Eigenschaftenblatt nicht bereits angezeigt wird, drücken Sie F4, um es anzuzeigen.

  7. Klicken Sie im Bericht auf das neue Unterberichts-Steuerelement, um es auszuwählen.

  8. Klicken Sie auf der Registerkarte Daten des Eigenschaftenblatts auf den Pfeil im Eigenschaftenfeld Herkunftsobjekt, und klicken Sie dann auf die Tabelle oder Abfrage, die im Unterberichts-Steuerelement angezeigt werden soll. Wenn beispielsweise die Auftragstabelle angezeigt werden soll, klicken Sie auf Tabelle.Aufträge.

    Access versucht nun, das Datenblatt basierend auf den in der Datenbank definierten Beziehungen mit dem Hauptbericht zu verknüpfen.

  9. Prüfen Sie auf der Registerkarte Daten des Eigenschaftenblatts die Eigenschaften Verknüpfen nach und Verknüpfen von.

    • Vergewissern Sie bei einem unverknüpften Datenblatt, dass beide Eigenschaften leer sind.

    • Bei einem verknüpften Datenblatt werden in den Eigenschaften Verknüpfen nach und Verknüpfen von das oder die Felder angezeigt werden, mit denen der Hauptbericht mit dem Datenblatt verknüpft wird. Werden im Hauptbericht beispielsweise Daten aus der Mitarbeitertabelle und im Datenblatt Daten aus der Auftragstabelle angezeigt, sollte in der Eigenschaft Verknüpfen nach das ID-Feld aus der Mitarbeitertabelle und in der Eigenschaft Verknüpfen von das Feld "Mitarbeiter-ID" aus der Auftragstabelle angezeigt werden.

In einigen Fällen müssen Sie die Verknüpfungsfeldeigenschaften ggf. bearbeiten. Gehen Sie hierfür wie im Folgenden beschrieben vor.

  1. Klicken Sie auf der Registerkarte Daten des Eigenschaftenfensters klicken Sie auf das Eigenschaftenfeld Verknüpfen nach, und klicken Sie dann auf Schaltfläche "Generator" .

    Das Dialogfeld Feldverknüpfungs-Assistent für Unterberichte wird angezeigt.

    Dialogfeld "Feldverknüpfungs-Assistent für Unterberichte"

  2. Wählen Sie in den Listen Felder in übergeordneter Tabelle und Felder in untergeordneter Tabelle die Felder aus, über die der Hauptbericht und das Datenblatt verknüpft werden sollen. Wenn Sie nicht sicher sind, welche Felder verwendet werden sollten, klicken Sie auf Vorschlagen, damit Access versucht, die geeigneten Verknüpfungsfelder zu ermitteln. Wenn Sie fertig sind, klicken Sie auf OK.

    Wird kein Feld zum Verknüpfen angezeigt, müssen Sie die Datensatzquelle des Hauptberichts oder des Datenblatts bearbeiten, um sicherzustellen, dass das Verknüpfungsfeld hierin enthalten ist. Basiert das Datenblatt beispielsweise auf einer Abfrage, müssen Sie sicherstellen, dass das Verknüpfungsfeld in den Abfrageergebnissen vorhanden ist.

  3. Speichern Sie den Hauptbericht, und schalten Sie in die Berichtsansicht um. Prüfen Sie nun, dass der Bericht wie gewünscht funktioniert.

Seitenanfang

Vornehmen von Entwurfsänderungen an einem Unterbericht

Nachdem Sie einem Bericht einen Unterbericht hinzugefügt haben, möchten Sie möglicherweise Entwurfsänderungen am Unterbericht vornehmen, oder Sie möchten im Hauptbericht auf Daten aus dem Unterbericht verweisen. In den folgenden Abschnitten finden Sie Tipps zum Durchführen dieser Aufgaben.

Öffnen eines Unterformulars oder Unterberichts in einem neuen Fenster in der Entwurfsansicht

Wenn Entwurfsänderungen an einem Unterformular oder einen Unterbericht vorgenommen werden sollen, während Sie den Hauptbericht in der Entwurfsansicht bearbeiten, können Sie das Unterformular oder den Unterbericht in einem eigenen Fenster öffnen.

  1. Klicken Sie auf das Unterformular oder den Unterbericht, um es oder ihn auszuwählen.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Tools auf Unterbericht in neuem Fenster Schaltflächensymbol .

Hinweis : Dieser Befehl steht nicht zur Verfügung, wenn das Unterformular-/Unterberichts-Steuerelement an eine Tabelle oder eine Abfrage gebunden ist.

Anzeigen einer Summe aus einem Unterbericht im Hauptbericht

Einmal angenommen, Sie verwenden einen Unterbericht mit Namen "Aufträge", der ein Textfeld mit Namen "Versandgebühren gesamt" enthält. Mit diesem Textfeld wird die Summe der Spalte "Versandgebühren" berechnet. Soll nun die Summe aus dem Unterbericht im Hauptbericht angezeigt werden, müssen Sie dem Hauptbericht ein Textfeld hinzufügen und mithilfe eines Ausdrucks auf das Textfeld "Versandgebühren gesamt" im Unterbericht verweisen. Gehen Sie hierfür wie im Folgenden beschrieben vor.

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Hauptbericht, und klicken Sie dann im Kontextmenü auf Entwurfsansicht.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente auf Textfeld. Schaltflächensymbol

  3. Klicken Sie im Hauptbericht auf die Stelle, an der das neue Textfeld platziert werden soll.

  4. Wenn das Eigenschaftenblatt nicht bereits angezeigt wird, drücken Sie F4, um es anzuzeigen.

  5. Geben Sie auf der Registerkarte Daten des Eigenschaftenblatts im Eigenschaftenfeld Steuerelementinhalt den folgenden Ausdruck ein:

    = IIf (ISTFEHLER ([Bestellungen Unterbericht]. [ Bericht]! [Liefer-Gebühr Total]), 0, [Bestellungen Unterbericht]. [Bericht]! [Versand Gebühren insgesamt])

    Hinweise : 

    • In diesem Beispiel könnten Sie verwenden Sie den weitere einfachen Ausdruck = [Bestellungen Unterberichts]. [ Bericht]! [Liefer-Gebühren insgesamt] aber dann der Unterbericht keine Daten enthält, zeigt das Steuerelement auf der Hauptbericht #Error. Die IsError -Funktion in der Wenn -Funktion, wie in der ersten Ausdruck dargestellt wird sichergestellt, dass das Textfeld im Hauptbericht eine Null (0), zeigt Wenn der Unterbericht keine Daten zurückgibt.

    • Sie können den Ausdrucks-Generator zum Erstellen des Ausdrucks, indem Sie auf Schaltfläche "Generator" im Eigenschaftenfeld Steuerelementinhalt verwenden.

  6. Legen Sie auf der Registerkarte Format des Eigenschaftenblatts die Eigenschaft Format auf den geeigneten Wert fest (in diesem Fall auf Währung).

  7. Speichern Sie den Bericht, schalten Sie dann in die Berichtsansicht um, und prüfen Sie nun, dass die Berechnung wie gewünscht vorgenommen wird.

Seitenanfang

Hinweise : 

  • Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

  • Die englische Version des Artikels ist als Referenz hier verfügbar: hier. Sie und andere Mitglieder der Microsoft-Community können diesen Artikel über das Collaborative Translation Framework (CTF) verbessern. Zeigen Sie einfach mit der Maus auf einen Satz in diesem Artikel, und klicken Sie dann im CTF-Widget auf "ÜBERSETZUNG VERBESSERN". Klicken Sie hier, um weitere Informationen zum CTF zu erhalten. Durch die Verwendung von CTF stimmen Sie unseren Nutzungsbedingungen zu.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×