Erstellen oder Löschen eines Makros

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Wenn Sie eine sich wiederholende Aufgabe automatisieren möchten, können Sie schnell eine Makro in Microsoft Excel aufzeichnen. Sie können auch ein Makro erstellen, mit der Visual Basic-Editor in Microsoft Visual Basic für Applikationen (VBA) eigene Makrocode schreiben oder alle oder einen Teil eines Makros in ein neues Makro zu kopieren. Nachdem Sie ein Makro erstellen, können Sie es so, dass Sie ausgeführt werden können, indem Sie auf das Objekt zu einem Objekt (wie ein Symbolleisten-Schaltfläche, eine Grafik oder ein Steuerelement) zuweisen. Wenn Sie ein Makro nicht länger verwenden, können Sie es löschen.

Im folgenden werden die Schritte zum Erstellen oder Löschen von Makros in Excel 2013 und Excel 2016.

Aufzeichnen eines Makros

Wenn Sie ein Makro aufzeichnen, werden alle erforderlichen Schritte für die Aktionen, die vom Makro ausgeführt werden sollen, mit der Makroaufzeichnungsfunktion erfasst. Diese Schritte können das Eingeben von Text oder Zahlen, das Klicken auf Zellen oder Befehle im Menüband oder in Menüs, das Formatieren, das Markieren von Zellen, Zeilen oder Spalten sowie das Ziehen der Maus zum Markieren von Zellen auf dem Tabellenblatt umfassen. Die Befehle für das Aufzeichnen, Erstellen und Löschen von Makros stehen im Menüband auf der Registerkarte Entwicklertools bereit.

  1. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Registerkarte Datei.

    2. Klicken Sie auf Optionen und dann auf Menüband anpassen.

    3. Aktivieren Sie in der Kategorie Menüband anpassen in der Liste Hauptregisterkarten das Kontrollkästchen Entwicklertools, und klicken Sie dann auf OK.

  2. Möglicherweise müssen Sie zuerst in den Sicherheitseinstellungen alle Makros aktivieren. Dazu gehen Sie wie folgt vor:

    1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makrosicherheit.

      Gruppe "Code" auf der Registerkarte "Entwicklertools" in Excel

    2. Klicken Sie unter Einstellungen für Makros auf Alle Makros aktivieren (nicht empfohlen, potenziell gefährlicher Code kann ausgeführt werden), und klicken Sie dann auf OK.

      Achtung : Es wird empfohlen, nach dem Beenden der Arbeit mit den Makros eine der Einstellungen zum Deaktivieren aller Makros zu verwenden, um die Ausführung von potenziell gefährlichem Code zu verhindern.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makro aufzeichnen.

  4. Geben Sie im Feld Makroname einen Namen für das Makro ein.

    Hinweis : Das erste Zeichen des Makronamens muss ein Buchstabe sein. Für die folgenden Zeichen können Buchstaben, Zahlen oder Unterstriche verwendet werden. Leerzeichen können in Makronamen nicht verwendet werden, zur Worttrennung eignen sich Unterstriche. Wenn Sie einen Makronamen verwenden, der auch ein Zellbezug ist, wird möglicherweise eine Fehlermeldung ausgeben, dass der Makroname ungültig ist.

  5. Wenn Sie zum Ausführen des Makros eine Tastenkombination mit der STEUERUNGSTASTE (STRG) verwenden möchten, geben Sie im Feld Tastenkombination einen beliebigen zu verwendenden Klein- oder Großbuchstaben ein.

    Die Tastenkombination setzt die entsprechenden, standardmäßig in Excel vorhandenen Tastenkombinationen außer Kraft, solange die Arbeitsmappe mit dem Makro geöffnet ist.

  6. Wählen Sie in der Liste Makro speichern in die Arbeitsmappe aus, in der Sie das Makro speichern möchten.

    Wenn ein Makro bei jeder Verwendung von Excel verfügbar sein soll, wählen Sie Persönliche Makroarbeitsmappe aus. Wenn Sie Persönliche Makroarbeitsmappe auswählen, wird von Excel eine ausgeblendete persönliche Makroarbeitsmappe ("Personal.xlsb") erstellt, sofern eine solche noch nicht vorhanden ist, und das Makro in dieser Arbeitsmappe gespeichert. Unter Windows 7 und Windows Vista wird diese Arbeitsmappe im Ordner "C:\Benutzer\Benutzername\AppData\Local\Microsoft\Excel\XLStart" gespeichert. Unter Microsoft Windows XP wird diese Arbeitsmappe im Ordner "C:\Dokumente und Einstellungen\Benutzername\Anwendungsdaten\Microsoft\Excel\XLStart" gespeichert. Arbeitsmappen im Ordner "XLStart" werden bei jedem Start von Excel automatisch geöffnet. Wenn ein Makro in der persönlichen Makroarbeitsmappe automatisch in einer anderen Arbeitsmappe ausgeführt werden soll, müssen Sie die betreffende Arbeitsmappe ebenfalls im Ordner "XLStart" speichern, damit beim Starten von Excel beide Arbeitsmappen geöffnet werden.

  7. Geben Sie im Feld Beschreibung eine Beschreibung des Makros ein.

  8. Klicken Sie auf OK, um die Aufzeichnung zu starten.

  9. Führen Sie die Aktionen aus, die Sie aufzeichnen möchten.

  10. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Aufzeichnung beenden Schaltflächensymbol .

Seitenanfang

Erstellen eines Makros mit VBA

  1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Visual Basic.

  2. Klicken Sie bei Bedarf im Visual Basic Editor im Menü Einfügen auf Modul.

    Hinweis : Module werden automatisch für alle Blätter der Arbeitsmappe erstellt.

  3. Geben Sie im Codefenster des Moduls den Makrocode ein, den Sie verwenden möchten, oder kopieren Sie diesen.

  4. Drücken Sie die Taste F5, um das Makro im Modulfenster auszuführen.

  5. Wenn Sie das Schreiben des Makros abgeschlossen haben, klicken Sie im Visual Basic Editor im Menü Datei auf Schließen und zurück zu Microsoft Excel.

Seitenanfang

Kopieren von Teilen eines Makros zum Erstellen anderer Makros

  1. Öffnen Sie die Arbeitsmappe mit dem Makro, das Sie kopieren möchten.

  2. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makros.

  3. Klicken Sie im Feld Makroname auf den Namen des zu kopierenden Makros.

  4. Klicken Sie auf Bearbeiten.

  5. Wählen Sie im Codefenster des Visual Basic-Editors die Zeilen des Makros aus, das Sie kopieren möchten.

    Tipp : Wenn Sie das gesamte Makro kopieren möchten, müssen Sie die Zeilen Sub und End Sub in die Markierung einbeziehen.

  6. Klicken Sie im Menü Bearbeiten auf Kopieren.

  7. Klicken Sie im Feld Prozedur des Codefensters auf das Modul, in dem Sie den Code platzieren möchten.

  8. Klicken Sie im Menü Bearbeiten auf Einfügen.

Da es sich bei der persönlichen Makroarbeitsmappendatei ("Personal.xlsb") um eine ausgeblendete Arbeitsmappe handelt, die immer geöffnet ist, können Sie diese möglicherweise nicht bearbeiten. Sie müssen sie zuerst über den Befehl Einblenden sichtbar machen. Sie können die Datei "Personal.xlsb" auch im Visual Basic-Editor öffnen, indem Sie ALT+F11 drücken.

Seitenanfang

Zuweisen eines Makros zu einem Objekt, einer Grafik oder einem Steuerelement

  1. Klicken Sie mit der rechten Maustaste auf einem Arbeitsblatt auf das Objekt, die Grafik oder das Steuerelement, dem bzw. der Sie ein vorhandenes Makros zuweisen möchten, und klicken Sie dann auf Makro zuweisen.

  2. Klicken Sie im Feld Makroname auf das gewünschte Makro.

Seitenanfang

Löschen eines Makros

  1. Führen Sie eine der folgenden Aktionen aus:

    • Öffnen Sie die Arbeitsmappe mit dem Makro, das Sie löschen möchten.

    • Wenn das Makro, das Sie löschen möchten, in einer persönlichen Makroarbeitsmappe (Personal.xlsb) gespeichert ist, und diese Arbeitsmappe ausgeblendet ist, gehen Sie wie folgt vor, um die Arbeitsmappe einzublenden:

      1. Klicken Sie auf der Registerkarte Ansicht in der Gruppe Fenster auf Einblenden.

      2. Klicken Sie unter Arbeitsmappe einblenden klicken Sie auf Persönliche, und klicken Sie dann auf OK.

  2. Wählen Sie in der Liste Makros in die Arbeitsmappe aus, die das zu löschende Makro enthält. Klicken Sie beispielsweise auf Diese Arbeitsmappe.

  3. Klicken Sie im Feld Makroname auf den Namen des Makros, das Sie löschen möchten.

  4. Klicken Sie auf Löschen.

Seitenanfang

Im folgenden werden die Schritte zum Erstellen oder Löschen von Makros, die in Excel 2010.

Aufzeichnen eines Makros

Wenn Sie ein Makro aufzeichnen, werden alle erforderlichen Schritte für die Aktionen, die Sie aufzeichnen möchten, mit der Makroaufzeichnungsfunktion erfasst. Die Navigation auf der Multifunktionsleiste wird in die aufgezeichneten Schritte nicht einbezogen.

  1. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Registerkarte Datei.

    2. Klicken Sie auf Optionen und dann auf Menüband anpassen.

    3. Aktivieren Sie in der Kategorie Menüband anpassen in der Liste Hauptregisterkarten das Kontrollkästchen Entwicklertools, und klicken Sie dann auf OK.

  2. Gehen Sie wie folgt vor, um in den Sicherheitseinstellungen vorübergehend alle Makros zu aktivieren:

    1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makrosicherheit.

      Die Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

    2. Klicken Sie unter Einstellungen für Makros auf Alle Makros aktivieren (nicht empfohlen, potenziell gefährlicher Code kann ausgeführt werden), und klicken Sie dann auf OK.

      Hinweis    Es wird empfohlen, nach dem Beenden der Arbeit mit den Makros eine der Einstellungen zum Deaktivieren aller Makros zu verwenden, um die Ausführung von potenziell gefährlichem Code zu verhindern.

      Weitere Informationen zum Ändern der Einstellungen finden Sie unter Ändern der Sicherheitseinstellungen von Makros in Excel.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makro aufzeichnen.

  4. Geben Sie im Feld Makroname einen Namen für das Makro ein.

    Notiz    Das erste Zeichen des Makroname muss ein Buchstabe sein. Nachfolgende Zeichen können sich aus Buchstaben, Zahlen oder Unterstriche. Leerzeichen können nicht in einem Makro verwendet werden. ein Unterstrich eignet sich gut als Trennzeichen für Wörter. Wenn Sie einen Makronamen, der auch ein Zellbezug ist verwenden, können Sie eine Fehlermeldung angezeigt, dass der Makroname ungültig ist.

  5. Wenn Sie zum Ausführen des Makros eine Tastenkombination mit STRG verwenden möchten, geben Sie im Feld Tastenkombination einen beliebigen zu verwendenden Klein- oder Großbuchstaben ein.

    Hinweis    Die Tastenkombination setzt die entsprechenden, standardmäßig in Excel vorhandenen Tastenkombinationen außer Kraft, solange die Arbeitsmappe mit dem Makro geöffnet ist.

    Eine Liste der in Excel bereits zugewiesenen Tastenkombinationen mit STRG finden Sie unter Tastenkombinationen und Funktionstasten in Excel.

  6. Wählen Sie in der Liste Makro speichern in die Arbeitsmappe aus, in der Sie das Makro speichern möchten.

    Tipp    Wenn ein Makro bei jeder Verwendung von Excel verfügbar sein soll, wählen Sie Persönliche Makroarbeitsmappe aus. Wenn Sie Persönliche Makroarbeitsmappe auswählen, erstellt Excel eine ausgeblendete persönliche Makroarbeitsmappe (Personal.xlsb) aus, sofern dies noch nicht vorhanden ist, und das Makro in dieser Arbeitsmappe gespeichert. Klicken Sie in Windows Vista wird diese Arbeitsmappe im Ordner Name\AppData\Local\Microsoft\Excel\XLStart C:\Users\user gespeichert. Klicken Sie in Microsoft Windows XP wird diese Arbeitsmappe im Ordner C:\Documents und Name\Application c:\Windows\Anwendungsdaten\Microsoft\Excel\Xlstart gespeichert. Arbeitsmappen im Ordner XLStart werden automatisch geöffnet, wenn Excel gestartet wird. Wenn Sie einen Makro in der persönlichen Makroarbeitsmappe automatisch in einer anderen Arbeitsmappe ausgeführt werden soll, müssen Sie diese Arbeitsmappe auch im Ordner XLStart speichern, damit beide Arbeitsmappen beim Start von Excel geöffnet werden.

  7. Geben Sie im Feld Beschreibung eine Beschreibung des Makros ein.

  8. Klicken Sie auf OK, um die Aufzeichnung zu starten.

  9. Führen Sie die Aktionen aus, die Sie aufzeichnen möchten.

  10. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Aufzeichnung beenden Schaltflächensymbol .

    Tipp    Sie können auch auf der linken Seite der Statusleiste auf Aufzeichnung beenden Schaltflächensymbol klicken.

Seitenanfang

Erstellen eines Makros mit VBA

  1. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Registerkarte Datei.

    2. Klicken Sie auf Optionen und dann auf Menüband anpassen.

    3. Aktivieren Sie in der Kategorie Menüband anpassen in der Liste Hauptregisterkarten das Kontrollkästchen Entwicklertools, und klicken Sie dann auf OK.

  2. Gehen Sie wie folgt vor, um in den Sicherheitseinstellungen vorübergehend alle Makros zu aktivieren:

    1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makrosicherheit.

      Die Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

    2. Klicken Sie unter Einstellungen für Makros auf Alle Makros aktivieren (nicht empfohlen, potenziell gefährlicher Code kann ausgeführt werden), und klicken Sie dann auf OK.

      Hinweis    Es wird empfohlen, nach dem Beenden der Arbeit mit den Makros eine der Einstellungen zum Deaktivieren aller Makros zu verwenden, um die Ausführung von potenziell gefährlichem Code zu verhindern.

      Weitere Informationen zum Ändern der Einstellungen finden Sie unter Ändern der Sicherheitseinstellungen von Makros in Excel.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Visual Basic.

  4. Klicken Sie bei Bedarf im Visual Basic Editor im Menü Einfügen auf Modul.

    Notiz    Module werden automatisch für alle Blätter in der Arbeitsmappe erstellt.

  5. Geben Sie im Codefenster des Moduls den Makrocode ein, den Sie verwenden möchten, oder kopieren Sie diesen.

  6. Drücken Sie die Taste F5, um das Makro im Modulfenster auszuführen.

  7. Wenn Sie das Schreiben des Makros abgeschlossen haben, klicken Sie im Visual Basic Editor im Menü Datei auf Schließen und zurück zu Microsoft Excel.

Seitenanfang

Kopieren von Teilen eines Makros zum Erstellen anderer Makros

  1. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Registerkarte Datei.

    2. Klicken Sie auf Optionen und dann auf Menüband anpassen.

    3. Aktivieren Sie in der Kategorie Menüband anpassen in der Liste Hauptregisterkarten das Kontrollkästchen Entwicklertools, und klicken Sie dann auf OK.

  2. Gehen Sie wie folgt vor, um in den Sicherheitseinstellungen vorübergehend alle Makros zu aktivieren:

    1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makrosicherheit.

      Die Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

    2. Klicken Sie unter Einstellungen für Makros auf Alle Makros aktivieren (nicht empfohlen, potenziell gefährlicher Code kann ausgeführt werden), und klicken Sie dann auf OK.

      Hinweis    Es wird empfohlen, nach dem Beenden der Arbeit mit den Makros eine der Einstellungen zum Deaktivieren aller Makros zu verwenden, um die Ausführung von potenziell gefährlichem Code zu verhindern.

      Weitere Informationen zum Ändern der Einstellungen finden Sie unter Ändern der Sicherheitseinstellungen von Makros in Excel.

  3. Öffnen Sie die Arbeitsmappe mit dem Makro, das Sie kopieren möchten.

  4. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makros.

  5. Klicken Sie im Feld Makroname auf den Namen des zu kopierenden Makros.

  6. Klicken Sie auf Bearbeiten.

  7. Wählen Sie im Codefenster des Visual Basic-Editors die Zeilen des Makros aus, das Sie kopieren möchten.

    Tipp    Um das gesamte Makro kopieren möchten, müssen einbeziehen Sie die Zeilen Sub und End Sub in die Markierung.

  8. Klicken Sie im Menü Bearbeiten auf Kopieren.

    Tipp    Sie können auch mit der rechten Maustaste, und klicken Sie dann auf Kopieren, oder Sie können auch STRG + C drücken.

  9. Klicken Sie im Feld Prozedur des Codefensters auf das Modul, in dem Sie den Code platzieren möchten.

  10. Klicken Sie im Menü Bearbeiten auf Einfügen.

    Tipp    Sie können auch mit der rechten Maustaste, und klicken Sie dann auf Einfügen, oder Sie können auch STRG + V drücken.

Tipp    Nicht möglich, die persönliche Makroarbeitsmappe Datei (Personal.xlsb) zu bearbeiten, da es sich um eine ausgeblendete Arbeitsmappe handelt, die immer geöffnet ist. Sie müssen sie zuerst einblenden, mithilfe des Befehls Einblenden. Sie können auch sie im Visual Basic-Editor öffnen, indem Sie ALT + F11 drücken.

Seitenanfang

Zuweisen eines Makros zu einem Objekt, einer Grafik oder einem Steuerelement

  1. Klicken Sie mit der rechten Maustaste auf einem Arbeitsblatt auf das Objekt, die Grafik oder das Steuerelement, dem bzw. der Sie ein vorhandenes Makros zuweisen möchten, und klicken Sie dann auf Makro zuweisen.

  2. Klicken Sie im Feld Makroname auf das gewünschte Makro.

Seitenanfang

Löschen eines Makros

  1. Führen Sie eine der folgenden Aktionen aus:

    • Öffnen Sie die Arbeitsmappe mit dem Makro, das Sie löschen möchten.

    • Wenn das Makro, das Sie löschen möchten, in einer persönlichen Makroarbeitsmappe (Personal.xlsb) gespeichert ist, und diese Arbeitsmappe ausgeblendet ist, gehen Sie wie folgt vor, um die Arbeitsmappe einzublenden:

      1. Klicken Sie auf der Registerkarte Ansicht in der Gruppe Fenster auf Einblenden.

      2. Klicken Sie unter Arbeitsmappe einblenden auf PERSONAL, und klicken Sie anschließend auf OK.

  2. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Registerkarte Datei.

    2. Klicken Sie auf Optionen und dann auf Menüband anpassen.

    3. Aktivieren Sie in der Kategorie Menüband anpassen in der Liste Hauptregisterkarten das Kontrollkästchen Entwicklertools, und klicken Sie dann auf OK.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makros.

    Die Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

  4. Wählen Sie in der Liste Makros in die Arbeitsmappe aus, die das zu löschende Makro enthält. Klicken Sie beispielsweise auf Diese Arbeitsmappe.

  5. Klicken Sie im Feld Makroname auf den Namen des Makros, das Sie löschen möchten.

  6. Klicken Sie auf Löschen.

Seitenanfang

Im folgenden werden die Schritte zum Erstellen oder Löschen von Makros, die in Excel 2007.

Aufzeichnen eines Makros

Wenn Sie ein Makro aufzeichnen, werden alle erforderlichen Schritte für die Aktionen, die Sie aufzeichnen möchten, mit der Makroaufzeichnungsfunktion erfasst. Die Navigation auf der Multifunktionsleiste wird in die aufgezeichneten Schritte nicht einbezogen.

Hinweis : Die Multifunktionsleiste ist eine Komponente der Microsoft Office Fluent-Benutzeroberfläche.

  1. Gehen Sie zum Anzeigen der Registerkarte Entwicklertools wie folgt vor, wenn diese nicht verfügbar ist:

    1. Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , und klicken Sie dann auf Excel-Optionen.

    2. Aktivieren Sie in der Kategorie Häufig verwendet unter Die am häufigsten verwendeten Optionen bei der Arbeit mit Excel das Kontrollkästchen Entwicklerregisterkarte in der Multifunktionsleiste anzeigen, und klicken Sie dann auf OK.

  2. Gehen Sie wie folgt vor, um in den Sicherheitseinstellungen vorübergehend alle Makros zu aktivieren:

    1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makrosicherheit.

      Die Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

    2. Klicken Sie unter Einstellungen für Makros auf Alle Makros aktivieren (nicht empfohlen, potenziell gefährlicher Code kann ausgeführt werden), und klicken Sie dann auf OK.

      Hinweis : Es wird empfohlen, nach dem Arbeiten mit Makros eine der Einstellungen zum Deaktivieren aller Makros zu verwenden, um die Ausführung von potenziell gefährlichem Code zu verhindern. Weitere Informationen zum Ändern der Einstellungen finden Sie unter Ändern der Makrosicherheitseinstellungen in Excel.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makro aufzeichnen.

  4. Geben Sie im Feld Makroname einen Namen für das Makro ein.

Hinweis : Das erste Zeichen des Makronamens muss ein Buchstabe sein. Für die folgenden Zeichen können Buchstaben, Zahlen oder Unterstriche verwendet werden. Leerzeichen können in Makronamen nicht verwendet werden, zur Worttrennung eignen sich Unterstriche. Wenn Sie einen Makronamen verwenden, der auch ein Zellbezug ist, wird möglicherweise eine Fehlermeldung ausgeben, dass der Makroname ungültig ist.

  1. Wenn Sie zum Ausführen des Makros eine Tastenkombination mit STRG verwenden möchten, geben Sie im Feld Tastenkombination einen beliebigen zu verwendenden Klein- oder Großbuchstaben ein.

    Hinweis : Die Tastenkombination setzt die entsprechenden, standardmäßig in Excel vorhandenen Tastenkombinationen außer Kraft, solange die Arbeitsmappe mit dem Makro geöffnet ist. Eine Liste der in Excel bereits zugewiesenen STRG-Tastenkombinationen finden Sie unter Tastenkombinationen und Funktionstasten in Excel.

  2. Wählen Sie in der Liste Makro speichern in die Arbeitsmappe aus, in der Sie das Makro speichern möchten.

    Tipp : Wenn ein Makro bei jeder Verwendung von Excel verfügbar sein soll, wählen Sie Persönliche Makroarbeitsmappe aus. Wenn Sie Persönliche Makroarbeitsmappe auswählen, wird von Excel eine ausgeblendete persönliche Makroarbeitsmappe (Personal.xlsb) erstellt, sofern eine solche nicht bereits vorhanden ist, und das Makro in dieser Arbeitsmappe gespeichert. Unter Windows Vista wird diese Arbeitsmappe im Ordner "C:\Benutzer\Benutzername\AppData\Local\Microsoft\Excel\XLStart" gespeichert. Unter Windows XP wird diese Arbeitsmappe im Ordner"C:\Dokumente und Einstellungen\Benutzername\Anwendungsdaten\Microsoft\Excel\XLStart" gespeichert. Arbeitsmappen im Ordner "XLStart" werden bei jedem Start von Excel automatisch gestartet. Wenn ein Makro in der persönlichen Makroarbeitsmappe automatisch in einer anderen Arbeitsmappe ausgeführt werden soll, müssen Sie die betreffende Arbeitsmappe ebenfalls im Ordner "XLStart" speichern, damit beim Starten von Excel beide Arbeitsmappen geöffnet werden.

  3. Geben Sie im Feld Beschreibung eine Beschreibung des Makros ein.

  4. Klicken Sie auf OK, um die Aufzeichnung zu starten.

  5. Führen Sie die Aktionen aus, die Sie aufzeichnen möchten.

  6. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Aufzeichnung beenden Schaltflächensymbol .

    Sie können auch auf der linken Seite der Statusleiste auf Aufzeichnung beenden Schaltflächensymbol klicken.

Seitenanfang

Erstellen Sie ein Makro mit Microsoft Visual Basic for Applications

  1. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , und klicken Sie dann auf Excel-Optionen.

    2. Aktivieren Sie in der Kategorie Häufig verwendet unter Die am häufigsten verwendeten Optionen bei der Arbeit mit Excel das Kontrollkästchen Entwicklerregisterkarte in der Multifunktionsleiste anzeigen, und klicken Sie dann auf OK.

  2. Gehen Sie wie folgt vor, um in den Sicherheitseinstellungen vorübergehend alle Makros zu aktivieren:

    1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makrosicherheit.

      Die Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

    2. Klicken Sie unter Einstellungen für Makros auf Alle Makros aktivieren (nicht empfohlen, potenziell gefährlicher Code kann ausgeführt werden), und klicken Sie dann auf OK.

      Hinweis : Es wird empfohlen, nach dem Beenden der Arbeit mit den Makros eine der Einstellungen zum Deaktivieren aller Makros zu verwenden, um die Ausführung von potenziell gefährlichem Code zu verhindern.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Visual Basic.

  4. Klicken Sie bei Bedarf im Visual Basic Editor im Menü Einfügen auf Modul.

    Hinweis : Module werden automatisch für alle Blätter der Arbeitsmappe erstellt.

  5. Geben Sie im Codefenster des Moduls den Makrocode ein, den Sie verwenden möchten, oder kopieren Sie diesen.

  6. Drücken Sie die Taste F5, um das Makro im Modulfenster auszuführen.

  7. Wenn Sie das Schreiben des Makros abgeschlossen haben, klicken Sie im Visual Basic Editor im Menü Datei auf Schließen und zurück zu Microsoft Excel.

Seitenanfang

Kopieren von Teilen eines Makros zum Erstellen anderer Makros

  1. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , und klicken Sie dann auf Excel-Optionen.

    2. Aktivieren Sie in der Kategorie Häufig verwendet unter Die am häufigsten verwendeten Optionen bei der Arbeit mit Excel das Kontrollkästchen Entwicklerregisterkarte in der Multifunktionsleiste anzeigen, und klicken Sie dann auf OK.

  2. Gehen Sie wie folgt vor, um in den Sicherheitseinstellungen vorübergehend alle Makros zu aktivieren:

    1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makrosicherheit.

      Die Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

    2. Klicken Sie unter Einstellungen für Makros auf Alle Makros aktivieren (nicht empfohlen, potenziell gefährlicher Code kann ausgeführt werden), und klicken Sie dann auf OK.

      Hinweis : Es wird empfohlen, nach dem Beenden der Arbeit mit den Makros eine der Einstellungen zum Deaktivieren aller Makros zu verwenden, um die Ausführung von potenziell gefährlichem Code zu verhindern.

  3. Öffnen Sie die Arbeitsmappe mit dem Makro, das Sie kopieren möchten.

  4. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makros.

  5. Klicken Sie im Feld Makroname auf den Namen des zu kopierenden Makros.

  6. Klicken Sie auf Bearbeiten.

  7. Wählen Sie im Codefenster des Visual Basic-Editors die Zeilen des Makros aus, das Sie kopieren möchten.

Tipp : Wenn Sie das gesamte Makro kopieren möchten, müssen Sie die Zeilen Sub und End Sub in die Markierung einbeziehen.

  1. Klicken Sie im Menü Bearbeiten auf Kopieren.

    Sie können auch mit der rechten Maustaste klicken und anschließend auf Kopieren klicken, oder drücken Sie STRG+C.

  2. Klicken Sie im Feld Prozedur des Codefensters auf das Modul, in dem Sie den Code platzieren möchten.

  3. Klicken Sie im Menü Bearbeiten auf Einfügen.

    Sie können auch mit der rechten Maustaste klicken und anschließend auf Einfügen klicken, oder drücken Sie STRG+V.

Tipp : Da es sich bei der persönlichen Makroarbeitsmappendatei (Personal.xlsb) um eine ausgeblendete Arbeitsmappe handelt, die immer geöffnet ist, können Sie diese nicht bearbeiten. Sie müssen sie zuerst über den Befehl Einblenden einblenden. Sie können sie auch im Visual Basic-Editor öffnen, indem Sie ALT+F11 drücken.

Seitenanfang

Zuweisen eines Makros zu einem Objekt, einer Grafik oder einem Steuerelement

  1. Klicken Sie mit der rechten Maustaste auf einem Arbeitsblatt auf das Objekt, die Grafik oder das Steuerelement, dem bzw. der Sie ein vorhandenes Makros zuweisen möchten, und klicken Sie dann auf Makro zuweisen.

  2. Klicken Sie im Feld Makroname auf das gewünschte Makro.

Löschen eines Makros

  1. Führen Sie eine der folgenden Aktionen aus:

    • Öffnen Sie die Arbeitsmappe mit dem Makro, das Sie löschen möchten.

    • Wenn das Makro, das Sie löschen möchten, in einer persönlichen Makroarbeitsmappe (Personal.xlsb) gespeichert ist, und diese Arbeitsmappe ausgeblendet ist, gehen Sie wie folgt vor, um die Arbeitsmappe einzublenden:

      1. Klicken Sie auf der Registerkarte Ansicht in der Gruppe Fenster auf Einblenden.

      2. Klicken Sie unter Arbeitsmappe einblenden auf PERSONAL, und klicken Sie anschließend auf OK.

  2. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , und klicken Sie dann auf Excel-Optionen.

    2. Aktivieren Sie in der Kategorie Häufig verwendet unter Die am häufigsten verwendeten Optionen bei der Arbeit mit Excel das Kontrollkästchen Entwicklerregisterkarte in der Multifunktionsleiste anzeigen, und klicken Sie dann auf OK.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makros.

    Die Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

  4. Wählen Sie in der Liste Makros in die Arbeitsmappe aus, die das zu löschende Makro enthält. Klicken Sie beispielsweise auf Diese Arbeitsmappe.

  5. Klicken Sie im Feld Makroname auf den Namen des Makros, das Sie löschen möchten.

  6. Klicken Sie auf Löschen.

Seitenanfang

Haben Sie eine Frage zu einer bestimmten Funktion?

Eine Frage im Excel-Communityforum stellen

Helfen Sie uns bei der Verbesserung von Excel

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Schnellstart: Erstellen eines Makros

Bearbeiten eines Makros

Ausführen eines Makros

Kopieren eines Makromoduls in eine andere Arbeitsmappe

Übersicht über Formeln in Excel

So vermeiden defekter Formeln

Suchen und Beheben von Fehlern in Formeln

Tastenkombinationen in Excel für Windows

Tastenkombinationen in Excel für Mac

Excel-Funktionen (alphabetisch)

Excel-Funktionen (nach Kategorie)

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×