Erstellen oder Bearbeiten von Ansichten in Datenbankmodelldiagrammen

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können eine Ansicht als gespeicherte Abfrage vorstellen. Ansichten sind besonders hilfreich, wenn Sie Zugriff auf die gleichen Informationen aus mehreren Tabellen oder Benutzer Daten offen legen, ohne dass diese die eigentlichen Tabellen ändern möchten.

Was möchten Sie tun?

Hinzufügen einer Sicht zu einem Modell Datenbankdiagramm

Zuordnen von Spalten aus Tabellen zu einer Ansicht

Bearbeiten der Eigenschaften einer Spalte in einer Ansicht

Bearbeiten der Eigenschaften einer Ansicht

Entfernen einer Ansicht

Neuanordnen der Sichten im Codefenster

Definieren Sie einen Wert für Name Leerzeichen für eine Entität oder Ansicht

Erstellen von Code für Ansichten

Werden Modellierung Features für die Datenbank kann nicht gefunden?

Sehr wahrscheinlich enthält Ihre Edition von Microsoft Office Visio die Features, die Sie suchen, nicht. Klicken Sie in dem Menü Hilfe auf Info, um zu ermitteln, welche Edition von Visio Sie verwenden. Der Name der Edition wird im Dialogfeld in der ersten Textzeile angezeigt.

Microsoft Office Visio Standard enthält die Vorlage Datenbankmodelldiagramm nicht.

Microsoft Office Visio Professional unterstützt die Reverse Engineering-Funktionen für die Vorlage Datenbankmodelldiagramm (d. h. das Erstellen eines Modells in Visio mithilfe einer vorhandenen Datenbank), das Forward Engineering (d. h. das Generieren von SQL-Code mithilfe eines Visio-Datenbankmodells) jedoch nicht.

Hinweis : Sie finden die gesamte Palette an Funktionen für die Datenbankmodellierung, einschließlich der Reverse Engineering- und der Forward Engineering-Funktionen, in Visio für Enterprise Architects. Visio für Enterprise Architects ist in der MSDN Premium Subscription inbegriffen, die mit Visual Studio Professional und rollenabhängigen Editionen von Visual Studio Team System erhältlich ist.

Hinzufügen einer Ansicht zu einem Datenbankmodelldiagramm

  • Ziehen Sie aus der Schablone Entitätsbeziehung oder aus der Schablone Objekt - relational ein Ansicht-Shape auf das Zeichenblatt.

Seitenanfang

Zuweisen von Spalten aus Tabellen zu einer Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm mit der Ansicht, der Spalten hinzugefügt werden sollen.

  2. Doppelklicken Sie auf die Ansicht, und klicken Sie dann im Fenster Datenbankeigenschaften in der Liste Kategorien auf Spalten.

  3. Führen Sie eine der folgenden Aktionen aus: 

    • Klicken Sie in einer leeren Zeile auf das Feld Physischer Name, und geben Sie den Namen der Spalte ein. Wiederholen Sie den Vorgang für jede Spalte, die zur Ansicht hinzugefügt werden soll.

    • Klicken Sie auf Hinzufügen. Der Standardname der neuen Spalte entspricht den im Dialogfeld Voreinstellungen für Datenbankmodellierung festgelegten Namenskonventionen. Zum Ändern des Spaltennamens klicken Sie auf den Standardspaltennamen und geben einen neuen Namen ein. Wiederholen Sie den Vorgang für jede Spalte, die zur Ansicht hinzugefügt werden soll.

  4. Klicken Sie auf den Namen der Spalte, deren Eigenschaften Sie definieren möchten, und klicken Sie auf Bearbeiten.

  5. Klicken Sie im Dialogfeld Spalteneigenschaften anzeigen auf der Registerkarte Quelle auf Bekannte Spalte in einer anderen Tabelle oder Ansicht und dann auf Ändern.

  6. Wählen Sie im Dialogfeld Spalte auswählen eine Spalte aus der Liste der Tabellen und Ansichten im Datenbankmodelldiagramm aus, und klicken Sie auf OK.

  7. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf OK.

  8. Wiederholen Sie die Schritte 4 bis 7 für jede Spalte, die Sie in Schritt 3 hinzugefügt.

Seitenanfang

Bearbeiten der Eigenschaften einer Spalte in einer Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Doppelklicken Sie auf die Ansicht, die die zu ändernden Spalten enthält, und klicken Sie dann im Fenster Datenbankeigenschaften in der Liste Kategorien auf Spalten.

  3. Klicken Sie auf den Namen der Spalte, die Sie ändern möchten, und klicken Sie auf Bearbeiten.

  4. Klicken Sie im Dialogfeld Spalteneigenschaften anzeigen auf die Registerkarte, die die zu bearbeitenden Informationen enthält, und führen Sie die Änderungen durch.

  5. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf OK.

Seitenanfang

Bearbeiten der Eigenschaften einer Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Zum Öffnen des Fensters Datenbankeigenschaften doppelklicken Sie auf die Ansicht, deren Eigenschaften Sie bearbeiten möchten.

  3. Klicken Sie im Fenster Datenbankeigenschaften auf die Kategorie, die die zu bearbeitenden Informationen enthält, und führen Sie die gewünschten Änderungen durch.

Das Datenbankmodelldiagramm wird automatisch aktualisiert.

Seitenanfang

Entfernen einer Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Klicken Sie auf dem Zeichenblatt auf die Ansicht, die Sie löschen möchten, und drücken Sie ENTF.

  3. Führen Sie im Dialogfeld Objekt löschen einen der folgenden Schritte aus:

    • Klicken Sie auf Ja, wenn Sie die Ansicht sowohl vom Zeichenblatt als auch aus dem Modell und aus dem Fenster Tabellen und Ansichten entfernen möchten.

    • Klicken Sie auf Nein, wenn Sie die Ansicht vom Zeichenblatt, aber nicht aus dem Modell oder dem Fenster Tabellen und Ansichten entfernen möchten.

Hinweis : Wenn Sie im Dialogfeld Objekt löschen nicht angezeigt werden, wenn Sie ein Objekt aus dem Diagramm, klicken Sie auf das Menü Datenbank löschen zeigen Sie auf Optionen, klicken Sie auf Modellierung und klicken Sie dann auf der Registerkarte Logisches Diagramm im Dialogfeld Datenbank Modeling Einstellungen unter beim Entfernen eines Objekts aus dem Diagramm, Bitten Sie Benutzer was zu tun. Alternativ, wenn Sie die Ansicht aus dem Modell entfernen möchten, klicken Sie auf der Ansicht im Fenster Tabellen und Ansichten, und drücken Sie dann die ENTF-Taste.

Seitenanfang

Neuanordnen der Sichten im Codefenster

  1. Wenn das Fenster Code nicht bereits geöffnet ist, zeigen Sie im Menü Datenbank auf Ansicht und klicken dann auf Code, um das Fenster zu öffnen.

    Hinweis : Dieser Befehl steht nur auf der Vorlage Datenbankmodeldiagramm zur Verfügung.

  2. Ziehen Sie die neu zu sortierende Ansicht auf eine neue Position im Fenster.

Seitenanfang

Definieren Sie einen Wert für Name Leerzeichen für eine Entität oder Ansicht

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Doppelklicken Sie auf die Entität oder Ansicht, deren Namensbereich festgelegt werden soll, um das Fenster Datenbankeigenschaften zu öffnen.

  3. Klicken Sie in der Liste Kategorien auf Definition, und geben Sie den unterscheidenden Text im Feld Namensbereich ein.

Das Datenbankmodell wird automatisch aktualisiert.

Seitenanfang

Erstellen von Code für Ansichten

  1. Ziehen Sie ein Ansicht-Shape aus der Entität Beziehung oder Relationalen Schablone aus.

  2. Doppelklicken Sie auf das Shape, um das Fenster Datenbankeigenschaften zu öffnen.

  3. Klicken Sie unter Kategorien auf SQL.

  4. Geben Sie Ihren Code in das Fenster SQL ein.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×