Erstellen oder Ausführen eines Makros

In Word können Sie häufig ausgeführte Aufgaben automatisieren, indem Sie Makros erstellen und ausführen. Ein Makro ist eine Abfolge von Befehlen und Anweisungen, die Sie als einzelnen Befehl zusammenfassen, um eine Aufgabe automatisch auszuführen.

Wenn Sie bei häufig ausgeführten Aufgaben Zeit sparen möchten, fassen Sie die einzelnen Schritte in einem Makro zusammen. Dazu zeichnen Sie das Makro zuerst auf. Anschließend führen Sie es aus, indem Sie auf eine Schaltfläche auf der Symbolleiste für den Schnellzugriff klicken oder eine Tastenkombination drücken. Das hängt ganz davon ab, wie Sie das Makro eingerichtet haben.

  1. Klicken Sie auf Ansicht > Makros > Makro aufzeichnen.

    Befehl 'Makro aufzeichnen'

  2. Geben Sie einen Namen für das Makro ein.

    Feld 'Makroname'

  3. Wenn Sie dieses Makro in neu erstellten Dokumenten verwenden möchten, vergewissern Sie sich, dass im Feld Makro speichern in der Wert Alle Dokumente (Normal.dotm) angezeigt wird.

    Feld zum Auswählen des Speicherorts für ein Makro

  4. Damit Ihr Makro beim Klicken auf eine Schaltfläche ausgeführt wird, klicken Sie auf Schaltfläche.

    Klicken Sie, um das Makro einer Schaltfläche zuzuweisen.

  5. Klicken Sie auf das neue Makro (das ähnlich wie "Normal.NeueMakros.<Name_des_Makros> heißt). Klicken Sie dann auf Hinzufügen.

    Das Makro und die Schaltfläche 'Hinzufügen'

  6. Klicken Sie auf Ändern.

    Schaltfläche 'Ändern' im Feld 'Symbolleiste für den Schnellzugriff anpassen'

  7. Wählen Sie ein Schaltflächensymbol aus, geben Sie den gewünschten Namen ein, und klicken Sie zweimal auf OK.

    Schaltfläche 'Optionen' im Feld 'Schaltfläche ändern'

  8. Jetzt ist es an der Zeit, die Schritte aufzuzeichnen. Klicken Sie auf die Befehle, oder drücken Sie die Tasten für jeden Schritt der Aufgabe. Word zeichnet Ihre Mausklicks und Tastenanschläge auf.

    Hinweis : Während der Aufzeichnung des Makros müssen Sie Text mit den Tasten der Tastatur markieren. Markierungen mit der Maus werden in Makros nämlich nicht aufgezeichnet. 

  9. Um die Aufzeichnung zu beenden, klicken Sie auf Ansicht > Makros > Aufzeichnung beenden.

    Befehl 'Aufzeichnung beenden'

Auf der Symbolleiste für den Schnellzugriff wird die Schaltfläche für Ihr Makro eingeblendet.

Schaltfläche 'Makro' auf der Symbolleiste für den Schnellzugriff

Klicken Sie auf die Schaltfläche, um das Makro auszuführen.

  1. Klicken Sie auf Ansicht > Makros > Makro aufzeichnen.

    Befehl 'Makro aufzeichnen'

  2. Geben Sie einen Namen für das Makro ein.

    Feld 'Makroname'

  3. Wenn Sie dieses Makro in neu erstellten Dokumenten verwenden möchten, vergewissern Sie sich, dass im Feld Makro speichern in der Wert Alle Dokumente (Normal.dotm) angezeigt wird.

    Feld zum Auswählen des Speicherorts für ein Makro

  4. Damit Ihr Makro beim Drücken einer Tastenkombination ausgeführt wird, klicken Sie auf Tastatur.

    Klicken Sie, um das Makro einer Tastenkombination zuzuweisen.

  5. Geben Sie im Feld Neue Tastenkombination eine Kombination von Tasten ein.

  6. Überprüfen Sie, ob diese Kombination bereits etwas anderem zugewiesen wurde. Falls dies zutrifft, versuchen Sie es mit einer anderen Kombination.

  7. Wenn Sie diese Tastenkombination in neu erstellten Dokumenten verwenden möchten, vergewissern Sie sich, dass im Feld Änderungen speichern in der Wert Normal.dotm angezeigt wird.

  8. Klicken Sie auf Zuweisen.

  9. Jetzt ist es an der Zeit, die Schritte aufzuzeichnen. Klicken Sie auf die Befehle, oder drücken Sie die Tasten für jeden Schritt der Aufgabe. Word zeichnet Ihre Mausklicks und Tastenanschläge auf.

    Hinweis : Während der Aufzeichnung des Makros müssen Sie Text mit den Tasten der Tastatur markieren. Markierungen mit der Maus werden in Makros nämlich nicht aufgezeichnet. 

  10. Um die Aufzeichnung zu beenden, klicken Sie auf Ansicht > Makros > Aufzeichnung beenden.

    Befehl 'Aufzeichnung beenden'

Drücken Sie die festgelegte Tastenkombination, um das Makro auszuführen.

Zum Ausführen eines Makros klicken Sie auf der Symbolleiste für den Schnellzugriff auf die entsprechende Schaltfläche, drücken Sie die festgelegte Tastenkombination, oder führen Sie das Makro aus der Liste Makros aus.

  1. Klicken Sie auf Ansicht > Makros > Makros anzeigen.

    Befehl 'Makros anzeigen'

  2. Klicken Sie in der Liste unter Makroname auf das Makro, das Sie ausführen möchten.

  3. Klicken Sie auf Ausführen.

Wenn Sie ein Makro aus einem Dokument in allen neuen Dokumenten zur Verfügung stellen möchten, fügen Sie es zur Vorlage "Normal.dotm" hinzu.

  1. Öffnen Sie das Dokument, in dem das Makro enthalten ist.

  2. Klicken Sie auf Ansicht > Makros > Makros anzeigen.

    Befehl 'Makros anzeigen'

  3. Klicken Sie auf Organisieren.

    Schaltfläche 'Organisieren' im Feld 'Makros anzeigen'

  4. Klicken Sie auf das Makro, das Sie der Vorlage "Normal.dotm" hinzufügen möchten, und klicken Sie auf Kopieren.

  1. Klicken Sie auf Datei > Optionen > Menüband anpassen.

  2. Klicken Sie unter Befehle auswählen auf Makros.

  3. Klicken Sie auf das gewünschte Makro.

  4. Klicken Sie unter Menüband anpassen auf die Registerkarte und die benutzerdefinierte Gruppe, der Sie das Makro hinzufügen möchten.

Wenn es keine benutzerdefinierte Gruppe gibt, klicken Sie auf Neue Gruppe. Klicken Sie dann auf Umbenennen, und geben Sie einen Namen für die benutzerdefinierte Gruppe ein.

  1. Klicken Sie auf Hinzufügen.

  2. Klicken Sie auf Umbenennen, um ein Bild für das Makro auszuwählen, und geben Sie den gewünschten Namen ein.

  3. Klicken Sie zweimal auf OK.

  1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makros.

  2. Geben Sie im Feld Makroname einen Namen für das Makro ein.

    Hinweis : Wenn Sie einem neuen Makro den gleichen Namen wie einem in Word integrierten Makro geben, ersetzen die Aktionen des neuen Makros das integrierte Makro. Um eine Liste der integrierten Makros anzuzeigen, klicken Sie in der Liste Makros in auf Word-Befehle.

  3. Klicken Sie in der Liste Makros in auf die Vorlage oder das Dokument, in der bzw. dem Sie das Makro speichern möchten.

    Um Ihr Makro in allen Dokumenten verfügbar zu machen, achten Sie darauf, auf Normal.dotm zu klicken.

  4. Klicken Sie auf Erstellen, um den Visual Basic-Editor zu öffnen.

Nachdem Sie den Visual Basic-Editor geöffnet haben, benötigen Sie möglicherweise weitere Informationen über das Arbeiten mit Visual Basic für Applikationen. Um weitere Informationen anzuzeigen, klicken Sie im Menü Hilfe auf Microsoft Visual Basic-Hilfe, oder drücken Sie F1.

Sie können eine Abfolge von Aktionen aufzeichnen oder ein Makro von Grund auf erstellen, indem Sie Visual Basic für Applikationen-Code im Visual Basic-Editor eingeben.

Hinweis : Um in Office Word 2007 mit Makros zu arbeiten, müssen Sie die Registerkarte Entwicklertools einblenden.

  1. Klicken Sie auf die Microsoft Office-Schaltfläche  Abbildung der Office-Schaltfläche , und klicken Sie dann auf Word-Optionen.

  2. Klicken Sie auf Häufig verwendet.

  3. Aktivieren Sie unter Wichtigste Optionen für das Arbeiten mit Word das Kontrollkästchen Registerkarte "Entwicklertools" im Menüband anzeigen.

    Hinweis : Das Menüband ist Bestandteil der Microsoft Office Fluent-Benutzeroberfläche.

  1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makro aufzeichnen.

    Gruppe 'Code' auf der Registerkarte 'Entwicklertools'
  2. Geben Sie im Feld Makroname einen Namen für das Makro ein.

    Hinweis : Wenn Sie einem neuen Makro den gleichen Namen wie einem in Office Word 2007 integrierten Makro geben, ersetzen die Aktionen des neuen Makros das integrierte Makro. Um eine Liste der integrierten Makros anzuzeigen, klicken Sie auf der Registerkarte Entwickler in der Gruppe Code auf Makros. Klicken Sie in der Liste Makros in auf Word-Befehle.

  3. Geben Sie im Feld Makro speichern die Vorlage oder das Dokument ein, in der bzw. dem Sie das Makro speichern möchten.

    Wichtig : Um Ihr Makro in allen Dokumenten verfügbar zu machen, achten Sie darauf, auf Normal.dotm zu klicken.

  4. Geben Sie im Feld Beschreibung eine Beschreibung des Makros ein.

  5. Führen Sie eine der folgenden Aktionen aus:

    • Aufzeichnung starten    Um die Aufzeichnung des Makros zu starten, ohne es einer Schaltfläche auf der Symbolleiste für den Schnellzugriff oder einer Tastenkombination zuzuweisen, klicken Sie auf OK.

    • Erstellen einer Schaltfläche    Um das Makro einer Schaltfläche auf der Symbolleiste für den Schnellzugriff zuzuweisen, gehen Sie wie folgt vor:

      1. Klicken Sie auf Schaltfläche.

      2. Wählen Sie unter Symbolleiste für den Schnellzugriff anpassen das Dokument (oder alle Dokumente) aus, für das Sie das Makro der Symbolleiste für den Schnellzugriff hinzufügen möchten.

        Wichtig : Um Ihr Makro in allen Dokumenten verfügbar zu machen, achten Sie darauf, auf Normal.dotm zu klicken.

      3. Klicken Sie im Dialogfeld Befehle auswählen auf das Makro, das Sie aufzeichnen, und klicken Sie anschließend auf Hinzufügen.

      4. Wenn Sie die Schaltfläche anpassen möchten, klicken Sie auf Ändern.

      5. Klicken Sie unter Symbol auf das Symbol, das Sie für Ihre Schaltfläche verwenden möchten.

      6. Geben Sie im Feld Anzeigename den Makronamen ein, der angezeigt werden soll.

      7. Klicken Sie zwei Mal auf OK, um die Aufzeichnung des Makros zu starten.

        Das ausgewählte Symbol wird auf der Symbolleiste für den Schnellzugriff angezeigt. Der eingegebene Name wird angezeigt, wenn Sie auf das Symbol zeigen.

    • Zuweisen einer Tastenkombination    Um ein Makro einer Tastenkombination zuzuweisen, gehen Sie wie folgt vor:

      1. Klicken Sie auf Tastatur.

      2. Klicken Sie im Feld Befehle auf das Makro, das Sie aufzeichnen.

      3. Geben Sie im Feld Neue Tastenkombination die gewünschte Tastenfolge ein, und klicken Sie dann auf Zuordnen.

      4. Klicken Sie auf Schließen, um mit der Aufzeichnung des Makros zu beginnen.

  6. Führen Sie die Aktionen durch, die das Makro umfassen soll.

    Hinweis : Wenn Sie ein Makro aufzeichnen, können Sie mit der Maus auf Befehle und Optionen klicken, jedoch keinen Text markieren. Sie müssen die Tastatur verwenden, um Text zu markieren. Weitere Informationen zum Markieren von Text mithilfe der Tastatur finden Sie unter Markieren von Text.

  7. Klicken Sie in der Gruppe Code auf Aufzeichnung beenden, um das Aufzeichnen Ihrer Aktionen zu beenden.

Ändern der Tastenkombination für ein Makro

  1. Klicken Sie auf die Microsoft Office-Schaltfläche  Abbildung der Office-Schaltfläche , und klicken Sie dann auf Word-Optionen.

  2. Klicken Sie auf Customize (Anpassen).

  3. Klicken Sie neben Tastenkombinationen auf Anpassen.

  4. Klicken Sie in der Liste Kategorien auf Makros.

  5. Klicken Sie in der Liste Makros auf das Makro, das Sie ändern möchten.

  6. Geben Sie im Feld Neue Tastenkombination die Tastenkombination ein, die Sie festlegen möchten.

  7. Aktivieren Sie das Feld Aktuelle Tasten, um sicherzustellen, dass Sie keine Tastenkombination zuweisen, die Sie bereits für eine andere Aufgabe verwenden.

  8. Klicken Sie in der Liste Änderungen speichern in auf die Option, die dem geplanten Ausführungsort Ihres Makros entspricht.

    Wichtig : Um Ihr Makro in allen Dokumenten verfügbar zu machen, achten Sie darauf, auf Normal.dotm zu klicken.

  9. Klicken Sie auf Schließen.

  1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makros.

    Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

  2. Klicken Sie in der Liste unter Makroname auf das Makro, das Sie ausführen möchten.

  3. Klicken Sie auf Ausführen

  1. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe Code auf Makros.

    Gruppe 'Code' auf der Registerkarte 'Entwicklertools'

  2. Geben Sie im Feld Makroname einen Namen für das Makro ein.

    Hinweis : Wenn Sie einem neuen Makro den gleichen Namen wie einem in Office Word 2007 integrierten Makro geben, ersetzen die Aktionen des neuen Makros das integrierte Makro. Um eine Liste der integrierten Makros anzuzeigen, klicken Sie in der Liste Makros in auf Word-Befehle.

  3. Klicken Sie in der Liste Makros in auf die Vorlage bzw. das Dokument, in dem Sie das Makro speichern möchten.

    Um Ihr Makro in allen Dokumenten verfügbar zu machen, achten Sie darauf, auf Normal.dotm zu klicken.

  4. Klicken Sie auf Erstellen, um den Visual Basic-Editor zu öffnen.

Nachdem Sie den Visual Basic-Editor geöffnet haben, benötigen Sie möglicherweise weitere Informationen über das Arbeiten mit Visual Basic für Applikationen. Um weitere Informationen anzuzeigen, klicken Sie im Menü Hilfe auf Microsoft Visual Basic-Hilfe, oder drücken Sie F1.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×