Erstellen eines einfachen Berichts

Sie können in Access eine Vielzahl einfacher und komplexer Berichte erstellen. Beginnen Sie mit dem Ermitteln der Datensatzquelle für den Bericht. Unabhängig davon, ob der Bericht aus einer einfachen Auflistung von Datensätzen oder aus einer gruppierten Zusammenfassung von Umsätzen nach Region besteht, müssen Sie immer zuerst ermitteln, welche Felder die im Bericht anzuzeigenden Daten enthalten und in welchen Tabellen oder Abfragen sie sich befinden.

Nachdem Sie die Datensatzquelle ausgewählt haben, erstellen Sie den Bericht in der Regel am einfachsten mit dem Berichts-Assistenten. Der Berichts-Assistent ist ein Feature in Access, mit dem Ihnen eine Reihe von Fragen gestellt wird. Dann wird anhand Ihrer Antworten ein Bericht generiert.

Inhalt dieses Artikels

Auswählen einer Datensatzquelle

Erstellen eines Berichts mit dem Berichtstool

Erstellen eines Berichts mit dem Berichts-Assistenten

Erstellen von Etiketten mit dem Etiketten-Assistenten

Erstellen eines Berichts mit dem Tool "Leerer Bericht"

Grundlegendes zu den Berichtsbereichen

Grundlegendes zu Steuerelementen

Optimieren des Berichts in der Layoutansicht

Optimieren des Berichts in der Entwurfsansicht

Hinzufügen von Steuerelementen zum Bericht

Speichern Ihrer Arbeit

Anzeigen, Drucken oder Senden des Berichts als E-Mail-Nachricht

Anzeigen des Berichts

Drucken des Berichts

Senden des Berichts als E-Mail-Nachricht

Auswählen einer Datensatzquelle

Ein Bericht besteht aus Informationen, die aus Tabellen oder Abfragen abgerufen werden, sowie aus Informationen, die mit dem Berichtsentwurf gespeichert werden, wie Beschriftungen, Überschriften und Grafiken. Die Tabellen oder Abfragen, die die zugrunde liegenden Daten bereitstellen, werden auch als Datensatzquelle des Berichts bezeichnet. Sind alle Felder, die Sie einbeziehen möchten, in einer einzigen Tabelle vorhanden, verwenden Sie diese Tabelle als Datensatzquelle. Sind die Felder in mehreren Tabellen enthalten, müssen Sie eine oder mehrere Abfragen als Datensatzquelle verwenden. Diese Abfragen sind möglicherweise bereits in der Datenbank vorhanden, oder Sie müssen neue Abfragen erstellen, die den speziellen Anforderungen Ihres Berichts entsprechen.

Erstellen eines Berichts mit dem Berichtstool

Am schnellsten kann ein Bericht mit dem Berichtstool erstellt werden, da sofort ein Bericht generiert wird, ohne dass Sie zum Eingeben von Informationen aufgefordert werden. Im Bericht werden alle Felder aus der zugrunde liegenden Tabelle oder Abfrage angezeigt. Mit dem Berichtstool wird zwar vielleicht nicht der endgültige, verfeinerte Bericht erstellt, den Sie sich letztendlich vorstellen, es ist jedoch praktisch, um einen schnellen Blick auf die zugrunde liegenden Daten zu werfen. Sie können dann den Bericht speichern und in der Layout- oder Entwurfsansicht so ändern, dass er Ihren Anforderungen besser entspricht.

  1. Klicken Sie im Navigationsbereich auf die Tabelle oder Abfrage, auf der der Bericht basieren soll.

  2. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Berichte auf Bericht  Schaltflächensymbol .

    Der Bericht wird in Access erstellt und in der Layoutansicht angezeigt.

  3. Weitere Informationen zum Anzeigen und Drucken des Berichts finden Sie im Abschnitt Anzeigen, Drucken oder Senden des Berichts als E-Mail-Nachricht.

Sie können den Bericht nach dem Anzeigen speichern und dann den Bericht sowie die zugrunde liegende Tabelle oder Abfrage schließen, die Sie als Datensatzquelle verwendet haben. Beim nächsten Öffnen des Berichts zeigt Access die aktuellsten Daten aus der Datensatzquelle an.

Erstellen eines Berichts mit dem Berichts-Assistenten

Mit dem Berichts-Assistenten können Sie die im Bericht angezeigten Felder präziser auswählen. Außerdem können Sie angeben, wie die Daten gruppiert und sortiert werden sollen, und Sie können Felder aus mehreren Tabellen oder Abfragen verwenden, sofern Sie die Beziehungen zwischen den Tabellen und Abfragen zuvor angegeben haben.

  • Klicken Sie auf der Registerkarte Erstellen in der Gruppe Berichte auf Berichts-Assistent.

  • Folgen Sie den Anweisungen auf den Seiten des Berichts-Assistenten. Klicken Sie auf der letzten Seite auf Fertig stellen.

    Wenn Sie eine Vorschau des Berichts anzeigen, sehen Sie, wie der Bericht gedruckt aussieht. Sie können den Bericht auch vergrößern, um Details genauer anzuzeigen. Weitere Informationen zum Anzeigen und Drucken des Berichts finden Sie im Abschnitt Anzeigen, Drucken oder Senden des Berichts als E-Mail-Nachricht.

Hinweis : Falls der Bericht Felder aus mehreren Tabellen und Abfragen enthalten soll, klicken Sie weder auf Weiter noch auf Fertig stellen, nachdem Sie die Felder aus der ersten Tabelle oder Abfrage auf der ersten Seite des Berichts-Assistenten ausgewählt haben. Wiederholen Sie stattdessen die Schritte zum Auswählen einer Tabelle oder Abfrage, und klicken Sie auf weitere Felder, die Sie in den Bericht einfügen möchten. Klicken Sie dann auf Weiter oder Fertig stellen, um den Vorgang fortzusetzen.

Erstellen von Etiketten mit dem Etiketten-Assistenten

Verwenden Sie den Etiketten-Assistenten, um problemlos Etiketten für eine Vielzahl von Etikettenstandardgrößen zu erstellen.

  1. Öffnen Sie im Navigationsbereich die Tabelle oder Abfrage, die als Datensatzquelle für die Etiketten dienen soll, indem Sie darauf doppelklicken.

  2. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Berichte auf Etiketten.

  3. Folgen Sie den Anweisungen auf den Seiten des Etiketten-Assistenten. Klicken Sie auf der letzten Seite auf Fertig stellen.

Access zeigt die Etiketten in der Seitenansicht an, sodass Sie sehen können, wie sie gedruckt aussehen. Mithilfe des Schiebereglers auf der Statusleiste von Access können Sie Details vergrößern. Weitere Informationen zum Anzeigen und Drucken des Berichts finden Sie im Abschnitt Anzeigen, Drucken oder Senden des Berichts als E-Mail-Nachricht.

Hinweis : Die Seitenansicht ist die einzige Ansicht, in der Sie mehrere Spalten anzeigen können. In den anderen Ansichten werden die Daten in einer einzelnen Spalte dargestellt.

Erstellen eines Berichts mit dem Tool "Leerer Bericht"

Wenn Sie das Berichtstool oder den Berichts-Assistenten nicht verwenden möchten, können Sie einen Bericht mit dem Tool "Leerer Bericht" völlig neu erstellen. Dies kann eine schnelle Methode zum Erstellen eines Berichts sein, besonders, wenn Sie nur einige Felder im Bericht anzeigen möchten. Im Folgenden wird beschrieben, wie Sie das Tool "Leerer Bericht" verwenden:

  • Klicken Sie auf der Registerkarte Erstellen in der Gruppe Berichte auf Leerer Bericht  Schaltflächensymbol .

    Ein leerer Bericht wird in der Layoutansicht angezeigt, und der Bereich "Feldliste" wird auf der rechten Seite des Access-Fensters eingeblendet.

  • Klicken Sie im Bereich Feldliste auf das Pluszeichen neben der Tabelle oder den Tabellen, die die Felder enthalten, die im Bericht angezeigt werden sollen.

  • Ziehen Sie jedes Feld einzeln in den Bericht, oder halten Sie die STRG-TASTE gedrückt, und wählen Sie dann mehrere Felder aus, die Sie dann gleichzeitig in den Bericht ziehen.

  • Verwenden Sie die Tools in der Gruppe Kopfzeile/Fußzeile auf der Registerkarte Entwurf, um dem Bericht ein Logo, einen Titel, Seitenzahlen oder Datum und Uhrzeit hinzuzufügen. Wenn Sie Access 2007 verwenden, befinden sich diese Tools in der Gruppe Steuerelemente auf der Registerkarte Format.

Grundlegendes zu den Berichtsbereichen

In Access ist der Entwurf eines Berichts in Bereiche unterteilt. Sie können den Bericht in der Entwurfsansicht anzeigen, wenn Sie die Bereiche sehen möchten. Damit Sie nützliche Berichte erstellen können, sollten Sie wissen, welche Funktion jeder Bereich hat. Beispielsweise bestimmt der Bereich, in dem Sie ein berechnetes Steuerelement platzieren, wie die Ergebnisse in Access berechnet werden. Die folgende Liste enthält eine Zusammenfassung der Bereichstypen und ihrer Verwendung:

  • Berichtskopf    Dieser Bereich wird nur einmal am Anfang des Berichts gedruckt. Verwenden Sie den Berichtskopf für Informationen, die normalerweise auf einem Deckblatt stehen, z. B. ein Logo, Titel oder Datum. Wenn Sie ein berechnetes Steuerelement, das die Aggregatfunktion Summe verwendet, in den Gruppenkopf aufnehmen, wird die Summe für den gesamten Bericht berechnet. Der Berichtskopf wird vor dem Seitenkopf gedruckt.

  • Seitenkopf    Dieser Bereich wird am Anfang jeder Seite gedruckt. Verwenden Sie einen Seitenkopf beispielsweise, um den Berichtstitel auf jeder Seite zu wiederholen.

  • Gruppenkopf    Dieser Bereich wird am Anfang jeder neuen Datensatzgruppe gedruckt. Verwenden Sie den Gruppenkopf, um den Gruppennamen zu drucken. Verwenden Sie den Gruppenkopf z. B. in einem Bericht, der nach Artikeln gruppiert ist, um den Artikelnamen zu drucken. Wenn Sie im Gruppenkopf ein berechnetes Steuerelement platzieren, das die Aggregatfunktion Summe verwendet, wird die Summe für die aktuelle Gruppe berechnet.

  • Detailbereich    Dieser Bereich wird einmal für jede Zeile in der Datensatzquelle gedruckt. Hier platzieren Sie die Steuerelemente, die den Hauptteil des Berichts bilden.

  • Gruppenfuß    Dieser Bereich wird am Ende jeder Gruppe von Datensätzen gedruckt. Verwenden Sie einen Gruppenfuß, um zusammenfassende Informationen für eine Gruppe zu drucken.

  • Seitenfuß    Dieser Bereich wird am Ende jeder Seite gedruckt. Verwenden Sie den Seitenfuß, um Seitenzahlen oder Informationen auf Seitenbasis zu drucken.

  • Berichtsfuß    Dieser Bereich wird nur einmal am Ende des Berichts gedruckt. Verwenden Sie den Berichtsfuß, um Berichtssummen oder andere zusammenfassende Informationen für den gesamten Bericht zu drucken.

    Hinweis : In der Entwurfsansicht wird der Berichtsfuß unter dem Seitenfuß angezeigt. Beim Drucken oder bei der Vorschau des Berichts wird der Berichtsfuß jedoch über dem Seitenfuß angezeigt, direkt nach dem letzten Gruppenfuß oder der Detailzeile auf der letzten Seite.

Seitenanfang

Grundlegendes zu Steuerelementen

Steuerelemente sind Objekte, die Daten anzeigen, Aktionen ausführen und Ihnen das Anzeigen und Bearbeiten von Informationen ermöglichen, mit denen die Benutzeroberfläche verbessert wird (beispielsweise Bezeichnungsfelder und Bilder). In Access werden drei Arten von Steuerelementen unterstützt: gebundene, ungebundene und berechnete Steuerelemente.

  • Gebundenes Steuerelement    Ein Steuerelement, dessen Datenquelle ein Feld in einer Tabelle oder Abfrage ist, ist ein gebundenes Steuerelement. Sie verwenden gebundene Steuerelemente, um Werte aus Feldern Ihrer Datenbank anzuzeigen. Die Werte können Text, Datumsangaben, Zahlen, Ja/Nein-Werte, Bilder oder Diagramme sein. Ein Textfeld ist der häufigste Typ eines gebundenen Steuerelements. Beispielsweise könnte ein Textfeld auf einem Formular, in dem der Nachname eines Mitarbeiters angezeigt wird, diese Information aus dem Feld "Nachname" der Tabelle "Personal" abrufen.

  • Ungebundenes Steuerelement    Ein Steuerelement, das nicht über eine Datenquelle (ein Feld oder einen Ausdruck) verfügt, ist ein ungebundenes Steuerelement. Mit ungebundenen Steuerelementen zeigen Sie Informationen, Linien, Rechtecke und Bilder an. Beispielsweise ist ein Bezeichnungsfeld, das den Titel eines Berichts anzeigt, ein ungebundenes Steuerelement.

  • Berechnetes Steuerelement    Ein Steuerelement, dessen Datenquelle kein Feld, sondern ein Ausdruck ist, ist ein berechnetes Steuerelement. Sie geben den im Steuerelement gewünschten Wert an, indem Sie einen Ausdruck als Datenquelle für das Steuerelement definieren. Ein Ausdruck ist eine Kombination aus Operatoren (z. B. = oder +), Steuerelementnamen, Feldnamen, Funktionen, die einen einzelnen Wert zurückgeben, und konstanten Werten. Der folgende Ausdruck berechnet z. B. den Preis eines Artikels mit einem Rabatt von 25 %, indem der Wert im Feld "Einzelpreis" mit einem konstanten Wert (0,75) multipliziert wird.

    = [Einzelpreis] * 0,75

    Ein Ausdruck kann Daten aus einem Feld der Tabelle oder Abfrage, die dem Bericht zugrunde liegt, oder aus einem Steuerelement im Bericht verwenden.

Wenn Sie einen Bericht erstellen, ist die vermutlich effizienteste Vorgehensweise, zuerst alle gebundenen Steuerelemente hinzuzufügen und anzuordnen, insbesondere, wenn diese die Mehrheit der Steuerelemente im Bericht ausmachen. Anschließend können Sie die ungebundenen und berechneten Steuerelemente hinzufügen, die den Entwurf vervollständigen. Verwenden Sie dazu die Tools in der Gruppe Steuerelemente auf der Registerkarte Entwurf.

Sie binden ein Steuerelement an ein Feld, indem Sie das Feld angeben, aus dem das Steuerelement seine Daten erhält. Sie können ein Steuerelement erstellen, das an das ausgewählte Feld gebunden ist, indem Sie das Feld aus dem Bereich Feldliste in den Bericht ziehen. Im Bereich Feldliste werden die Felder der Tabelle oder Abfrage angezeigt, die dem Bericht zugrunde liegt. Zum Anzeigen des Bereichs Feldliste klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente auf Vorhandene Felder hinzufügen.

Sie können ein Feld auch an ein Steuerelement binden, indem Sie den Feldnamen direkt in das Steuerelement oder in das Feld für den Wert Steuerelementinhalt im Eigenschaftenblatt des Steuerelements eingeben. Im Eigenschaftenblatt sind die Merkmale des Steuerelements, etwa dessen Name, die Quelle seiner Daten und dessen Format definiert.

Die Verwendung des Bereichs Feldliste ist aus zwei Gründen die beste Vorgehensweise, ein Steuerelement zu erstellen:

  • Ein gebundenes Steuerelement hat ein angefügtes Bezeichnungsfeld, und für dieses Bezeichnungsfeld wird standardmäßig der Name des Felds (oder die für dieses Feld in der zugrunde liegenden Tabelle oder Abfrage definierte Beschriftung) als Beschriftung übernommen, sodass Sie selbst keine Beschriftung eingeben müssen.

  • Ein gebundenes Steuerelement erbt viele der Einstellungen, die das Feld in der zugrunde liegenden Tabelle oder der Abfrage hat (z. B. für die Eigenschaften Format, Dezimalstellenanzeige und Eingabeformat). Sie können deshalb sicher sein, dass die Eigenschaften für das Feld dieselben bleiben, wenn Sie ein Steuerelement erstellen, das an das Feld gebunden ist.

Wenn Sie bereits ein ungebundenes Steuerelement erstellt haben und es an ein Feld binden möchten, legen Sie die Eigenschaft Steuerelementinhalt des Steuerelements auf den Namen des Felds fest. Informationen zur Eigenschaft Steuerelementinhalt erhalten Sie, indem Sie in der Hilfe nach "Steuerelementinhalt" suchen.

Seitenanfang

Optimieren des Berichts in der Layoutansicht

Nachdem Sie einen Bericht erstellt haben, können Sie seinen Entwurf problemlos in der Layoutansicht optimieren. Anhand der eigentlichen Berichtsdaten als Richtschnur können Sie die Spaltenbreiten anpassen, die Spalten neu anordnen sowie Gruppierungsebenen und Summen hinzufügen. Außerdem können Sie neue Felder im Berichtsentwurf platzieren und die Eigenschaften für den Bericht und seine Steuerelemente festlegen.

Zum Wechseln in die Layoutansicht klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Berichtsnamen, und klicken Sie dann auf Layoutansicht  Schaltflächensymbol .

Access zeigt den Bericht in der Layoutansicht an.

Verwenden Sie das Eigenschaftenblatt, um die Eigenschaften des Berichts und der zugehörigen Steuerelemente und Bereiche zu ändern. Um das Eigenschaftenblatt anzuzeigen, drücken Sie F4.

Sie können den Bereich Feldliste verwenden, um dem Berichtsentwurf Felder aus der zugrunde liegenden Tabelle oder Abfrage hinzuzufügen. Damit der Bereich Feldliste angezeigt wird, führen Sie eine der folgenden Aktionen aus:

  • Klicken Sie auf der Registerkarte Entwurf in der Gruppe Extras auf Vorhandene Felder hinzufügen Schaltflächensymbol . Wenn Sie Access 2007 verwenden, befinden sich der Befehl Vorhandene Felder hinzufügen in der Gruppe Steuerelemente auf der Registerkarte Format.

  • Drücken Sie ALT+F8.

Anschließend können Sie Felder hinzufügen, indem Sie sie aus dem Bereich Feldliste in den Bericht ziehen.

Seitenanfang

Optimieren des Berichts in der Entwurfsansicht

Sie können den Berichtsentwurf auch in der Entwurfsansicht optimieren. Sie können dem Bericht neue Steuerelemente und Felder hinzufügen, indem Sie diese in den Entwurfsbereich einfügen. Über das Eigenschaftenblatt erhalten Sie Zugriff auf eine große Anzahl von Eigenschaften, die Sie zum Anpassen des Berichts festlegen können.

Zum Wechseln in die Entwurfsansicht klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Berichtsnamen, und klicken Sie dann auf Entwurfsansicht  Schaltflächensymbol .

Access zeigt den Bericht in der Entwurfsansicht an.

Verwenden Sie das Eigenschaftenblatt, um die Eigenschaften des Berichts und der darin enthaltenen Steuerelemente und Bereiche zu ändern. Um das Eigenschaftenblatt anzuzeigen, drücken Sie F4.

Sie können den Bereich Feldliste verwenden, um dem Berichtsentwurf Felder aus der zugrunde liegenden Tabelle oder Abfrage hinzuzufügen. Damit der Bereich Feldliste angezeigt wird, führen Sie eine der folgenden Aktionen aus:

  • Klicken Sie auf der Registerkarte Format in der Gruppe Steuerelemente auf Vorhandene Felder hinzufügen  Schaltflächensymbol . Wenn Sie Access 2007 verwenden, befinden sich der Befehl Vorhandene Felder hinzufügen in der Gruppe Steuerelemente auf der Registerkarte Format.

  • Drücken Sie ALT+F8.

Anschließend können Sie Felder hinzufügen, indem Sie sie aus dem Bereich Feldliste in den Bericht ziehen.

Seitenanfang

Hinzufügen von Feldern aus dem Bereich "Feldliste"

  • Um ein einzelnes Feld hinzuzufügen, ziehen Sie das Feld aus dem Bereich Feldliste in den Bereich, in dem das Feld im Bericht angezeigt werden soll.

  • Wenn Sie mehrere Felder gleichzeitig hinzufügen möchten, halten Sie STRG gedrückt, und klicken Sie auf die gewünschten Felder. Ziehen Sie dann die ausgewählten Felder in den Bericht.

Wenn Sie die Felder in einem Berichtsbereich ablegen, wird von Access für jedes Feld ein gebundenes Textfeld-Steuerelement erstellt und neben jedem Feld automatisch ein Bezeichnungsfeld-Steuerelement platziert.

Seitenanfang

Hinzufügen von Steuerelementen zum Bericht

Einige Steuerelemente werden automatisch erstellt, wie das gebundene Textfeld-Steuerelement, das erstellt wird, wenn Sie dem Bericht ein Feld aus dem Bereich Feldliste hinzufügen. Viele andere Steuerelemente können in der Entwurfsansicht auch mithilfe der Tools in der Gruppe Steuerelemente auf der Registerkarte Entwurf erstellt werden.

Ermitteln des Namens eines Tools

  • Platzieren Sie den Mauszeiger über dem Tool.

    Access zeigt den Namen des Tools an.

Erstellen eines Steuerelements mit den Tools der Gruppe "Steuerelemente"

  1. Klicken Sie auf das Tool für den Steuerelementtyp, den Sie hinzufügen möchten. Um beispielsweise ein Kontrollkästchen zu erstellen, klicken Sie auf das Tool Kontrollkästchen  Schaltflächensymbol .

  2. Klicken Sie im Entwurfsbereich des Berichts auf die Stelle, an der die obere linken Ecke des Steuerelements platziert werden soll. Klicken Sie einmal, um ein Steuerelement in Standardgröße zu erstellen, oder klicken Sie auf das Tool, und ziehen Sie es dann in den Entwurfsbereich des Berichts, um ein Steuerelement in der gewünschten Größe zu erstellen.

  3. Wenn Sie das Steuerelement beim ersten Versuch nicht perfekt positioniert haben, gehen Sie wie folgt vor, um es zu verschieben:

    1. Klicken Sie auf das Steuerelement, um es auszuwählen.

    2. Positionieren Sie den Mauszeiger so auf dem Rand des Steuerelements, dass sich der Zeiger in einen Pfeil mit vier Spitzen  Verschiebemauszeiger verwandelt.

    3. Ziehen Sie das Steuerelement an die gewünschte Position.

Mit diesem Verfahren wird ein "ungebundenes" Steuerelement erstellt. Wenn der Steuerelementtyp Daten anzeigen kann (etwa ein Textfeld oder ein Kontrollkästchen), müssen Sie einen Feldnamen oder Ausdruck in die Eigenschaft Steuerelementinhalt für das Steuerelement eingeben, damit Daten angezeigt werden. Weitere Informationen finden Sie im Abschnitt Grundlegendes zu Steuerelementen in diesem Thema.

Anzeigen des Eigenschaftenblatts

Führen Sie eine der folgenden Aktionen aus, um das Eigenschaftenblatt in der Entwurfsansicht anzuzeigen:

  • Klicken Sie auf der Registerkarte Entwurf in der Gruppe Tools auf Eigenschaftenblatt. Wenn Sie Access 2007 verwenden, befindet sich der Befehl Eigenschaftenblatt in der Gruppe Einblenden/Ausblenden auf der Registerkarte Entwurf.

  • Drücken Sie F4.

Seitenanfang

Speichern Ihrer Arbeit

Nachdem Sie den Berichtsentwurf gespeichert haben, können Sie den Bericht bei Bedarf immer wieder ausführen. Der Entwurf des Berichts bleibt gleich, bei jedem Drucken oder Anzeigen werden jedoch aktuelle Daten eingefügt. Wenn sich Ihre Anforderungen an den Bericht ändern, können Sie den Berichtsentwurf ändern oder einen neuen, ähnlichen Bericht erstellen, der auf dem ursprünglichen Bericht basiert.

Speichern des Berichtsentwurfs

  • Klicken Sie auf Datei > und dann auf Speichern, oder drücken Sie STRG+S. Wenn Sie Access 2007 verwenden, klicken Sie auf die Microsoft Office-Schaltfläche, und klicken Sie dann auf Speichern, oder drücken Sie STRG+S.

    Alternativ klicken Sie auf der Symbolleiste für den Schnellzugriff auf Speichern  Schaltflächensymbol .

  • Wenn der Bericht noch keinen Titel hat, geben Sie einen Namen in das Feld Berichtsname ein, und klicken Sie dann auf OK.

Speichern des Berichtsentwurfs unter einem neuen Namen

  • Wenn Sie Access 2013 oder höher verwenden, klicken Sie auf Datei > Speichern unter > Objekt speichern als.

    Wenn Sie Access 2010 verwenden, klicken Sie auf Datei > Objekt speichern als.

    Wenn Sie Access 2007 verwenden, klicken Sie auf dieMicrosoft Office-Schaltfläche, und klicken Sie dann auf Speichern unter > Objekt speichern als.

  • Geben Sie im Dialogfeld Speichern unter das Feld Bericht speichern unter einen Namen für den neuen Bericht ein, und klicken Sie dann auf OK.

Seitenanfang

Anzeigen, Drucken oder Senden des Berichts als E-Mail-Nachricht

Nachdem Sie den Berichtsentwurf gespeichert haben, können Sie ihn immer wieder verwenden. Der Entwurf des Berichts bleibt gleich, bei jedem Anzeigen oder Drucken werden jedoch aktuelle Daten eingefügt. Wenn sich Ihre Anforderungen an den Bericht ändern, können Sie den Berichtsentwurf ändern oder einen neuen, ähnlichen Bericht erstellen, der auf dem ursprünglichen Bericht basiert.

Anzeigen des Berichts

Es gibt verschiedene Möglichkeiten, den Bericht anzuzeigen. Für welche Methode Sie sich entscheiden, hängt davon ab, wie Sie den Bericht und dessen Daten verwenden möchten.

  • Wenn Sie vor dem Drucken vorübergehend ändern möchten, welche Daten im Bericht angezeigt werden, oder wenn Sie Daten aus dem Bericht in die Zwischenablage kopieren möchten, verwenden Sie die Berichtsansicht.

  • Wenn Sie den Entwurf des Berichts ändern möchten, während Sie die Daten anzeigen, verwenden Sie die Layoutansicht.

  • Wenn Sie einfach nur sehen möchten, wie der Bericht gedruckt aussieht, verwenden Sie die Seitenansicht.

Hinweis : Wenn der Bericht mit mehreren Spalten formatiert ist, können Sie das Spaltenlayout nur in der Seitenansicht anzeigen. In der Layout- und der Berichtsansicht wird der Bericht als einzelne Spalte dargestellt.

Anzeigen des Berichts in der Berichtsansicht

Die Berichtsansicht ist die Standardansicht, die verwendet wird, wenn Sie im Navigationsbereich auf einen Bericht doppelklicken. Wenn der Bericht noch nicht geöffnet ist, doppelklicken Sie im Navigationsbereich darauf, um ihn in der Berichtsansicht anzuzeigen.

Wenn der Bericht bereits geöffnet ist, klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Berichtsnamen, und klicken Sie dann auf Berichtsansicht.

Arbeiten mit Daten in der Berichtsansicht

In der Berichtsansicht können Sie Text auswählen und in die Zwischenablage kopieren. Wenn Sie ganze Zeilen auswählen möchten, klicken Sie im Rand, und ziehen Sie den Zeiger neben den auszuwählenden Zeilen. Kopieren Sie diese Zeilen dann in die Zwischenablage, indem Sie eine der folgenden Aktionen ausführen:

  1. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf Kopieren  Schaltflächensymbol .

  2. Klicken Sie mit der rechten Maustaste auf die ausgewählten Zeilen, und klicken Sie dann auf Kopieren.

  3. Verwenden Sie die Tastenkombination – Drücken Sie STRG+C.

Anzeigen nur der gewünschten Zeilen durch Verwendung von Filtern

Sie können Filter direkt auf den Bericht anwenden, ohne die Berichtsansicht zu verlassen. Wenn Sie z. B. bei einer Spalte "Land/Region" nur die Zeilen mit dem Land/der Region "Kanada" anzeigen möchten, gehen Sie folgendermaßen vor:

  1. Suchen Sie das Wort "Kanada" im Bericht, und klicken Sie darauf.

  2. Klicken Sie auf Ist gleich "Kanada".

Access erstellt den Filter, und wendet ihn an.

Ein- und Ausschalten eines Filters

Sie können zwischen der gefilterten und der ungefilterten Anzeige umschalten, indem Sie auf der Registerkarte Start in der Gruppe Sortieren und Filtern auf Filter ein/aus klicken. Dadurch wird der Filter nicht entfernt, sondern lediglich ein- oder ausgeschaltet.

Löschen eines Filters

  1. Klicken Sie mit der rechten Maustaste auf das Feld, aus dem Sie den Filter entfernen möchten.

  2. Klicken Sie auf Filter von <Feldname> löschen. (Für Feldname wird das aktuelle Feld aufgelistet.)

Ein einmal entfernter Filter lässt sich nicht mehr mithilfe des Befehls Filter ein/aus einschalten. Sie müssen den Filter zuerst neu erstellen.

Hinweis : Wenn Sie einen Filter auf einen Bericht anwenden und dann den Bericht speichern und schließen, wird der Filter gespeichert. Beim nächsten Öffnen des Berichts wendet Access den Filter jedoch nicht an. Klicken Sie auf der Registerkarte Start in der Gruppe Sortieren und Filtern auf Filter ein/aus, um den Filter erneut anzuwenden.

Vorschau des Berichts in der Seitenansicht

Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht, und klicken Sie dann im Kontextmenü auf Seitenansicht.

Mit den Navigationsschaltflächen können Sie die Seiten in einem Bericht nacheinander anzeigen oder direkt zu einer beliebigen Seite im Bericht springen.

Navigationsschaltflächen

1. Klicken Sie hier, um die erste Seite anzuzeigen.

2. Klicken Sie hier, um die vorherige Seite anzuzeigen.

3. Klicken Sie hier, um die nächste Seite anzuzeigen.

4. Klicken Sie hier, um die letzte Seite anzuzeigen.

5. Geben Sie in diesem Feld eine Seitenzahl ein, und drücken Sie dann die EINGABETASTE, um zu einer bestimmten Seite zu springen.

In der Seitenansicht können Sie den angezeigten Bereich vergrößern, um Details anzuzeigen, oder verkleinern, um zu sehen, wie die Daten auf der Seite angeordnet sind. Positionieren Sie den Cursor auf dem Bericht, und klicken Sie einmal. Klicken Sie erneut, um die Ansicht wieder zu vergrößern bzw. zu verkleinern. Sie können zum Vergrößern oder Verkleinern auch das Zoom-Steuerelement in der Statusleiste von Access verwenden.

Führen Sie eine der folgenden Aktionen aus, um die Seitenansicht zu schließen:

  • Klicken Sie auf der Registerkarte Seitenansicht auf Seitenansicht schließen.

  • Klicken Sie mit der rechten Maustaste auf den Bericht im Navigationsbereich, und klicken Sie dann im Kontextmenü auf Layoutansicht  Schaltflächensymbol oder Entwurfsansicht  Schaltflächensymbol .

Tipp : Nachdem Sie eine Vorschau des Berichts angezeigt haben, können Sie die Ergebnisse nach Microsoft Word, Microsoft Excel oder in verschiedene andere Office-Programme exportieren. Klicken Sie auf der Registerkarte Externe Daten in der Gruppe Exportieren auf die Schaltfläche für das gewünschte Format, und folgen Sie den Anweisungen.

Seitenanfang

Drucken des Berichts

Sie können einen Bericht aus einer beliebigen Ansicht drucken, auch wenn er geschlossen ist. Vor dem Drucken sollten Sie nochmals die Seiteneinstellungen überprüfen, z. B. Seitenränder und Seitenausrichtung. Access speichert die Seiteneinstellungen mit dem Bericht, sodass Sie diese nur einmal festlegen müssen. Wenn sich Ihre Druckanforderungen ändern, können Sie sie später erneut festlegen.

Ändern der Seiteneinstellungen

  1. Öffnen Sie den Bericht in der Seitenansicht. Sie können die Seiteneinstellungen in jeder Ansicht ändern, die Seitenansicht ist jedoch optimal, da Sie die Auswirkungen von Änderungen sofort sehen können.

  2. Klicken Sie auf der Registerkarte Seitenansicht in den Gruppen Seitenlayout und Papierformat auf Hochformat  Schaltflächensymbol oder Querformat  Schaltflächensymbol , um die Seitenausrichtung, die Größe  Schaltflächensymbol , das Papierformat und die Seitenränder  Schaltflächensymbol anzupassen, usw.

  3. Nachdem Sie eine Änderung vorgenommen haben, zeigen Sie mithilfe der Navigationsschaltflächen verschiedene Seiten an, um sicherzustellen, dass auf den Folgeseiten keine Formatierungsprobleme auftreten.

Senden des Berichts an einen Drucker

  1. Öffnen Sie den Bericht in einer beliebigen Ansicht, oder wählen Sie ihn im Navigationsbereich aus.

  2. Klicken Sie auf Datei > Drucken > Drucken. Wenn Sie Access 2007 verwenden, klicken Sie auf die Microsoft Office-Schaltfläche, und klicken Sie dann auf Drucken > Drucken.

    Access zeigt das Dialogfeld Drucken an.

  3. Geben Sie die gewünschten Optionen ein, beispielsweise den Drucker, den Druckbereich und die Anzahl der Exemplare.

  4. Klicken Sie auf OK.

Seitenanfang

Senden des Berichts als E-Mail-Nachricht

Sie können den Bericht als E-Mail-Nachricht an die Empfänger senden, statt eine Papierkopie zu drucken.

  1. Klicken Sie im Navigationsbereich auf den Bericht, um ihn auszwählen. Klicken Sie auf der Registerkarte Externe Daten in der Gruppe Exportieren auf E-Mail. Wenn Sie Access 2007 verwenden, klicken Sie im Navigationsbereich auf den Bericht, um ihn auszuwählen, klicken Sie auf die Microsoft Office-Schaltfläche , und klicken Sie dann auf E-Mail.

  2. Klicken Sie im Dialogfeld Objekt senden als in der Liste Ausgabeformat auswählen auf das zu verwendende Dateiformat.

  3. Beenden Sie alle verbleibenden Dialogfelder.

  4. Geben Sie in Ihrer E-Mail-Anwendung die Nachrichtendetails ein, und senden Sie die Nachricht.

Seitenanfang

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×