Erstellen eines UML-Komponentendiagramms

Sie können ein UML-Komponentendiagramm erstellen, um die Komponenten, Ports und Schnittstellen sowie die Beziehungen zwischen diesen darzustellen. Öffnen Sie zunächst die Vorlage UML-Komponente, und wählen Sie eine der vier Vorlagenoptionen aus. Dann wird die Schablone UML-Komponente zusammen mit Shapes angezeigt, die dem UML 2.5-Standard entsprechen.

Schablone "UML-Komponente" und Beispiel-Shapes auf der Seite

Hinweis : Die Schablone UML-Komponente ist nur für Abonnenten von Visio Pro für Office 365 verfügbar. Wenn Sie über ein Abonnement verfügen, vergewissern Sie sich, dass Sie die neueste Version von Visio verwenden.

  1. Starten Sie Visio. Oder, wenn Sie bereits eine Datei geöffnet haben, klicken Sie auf Datei > Neu.

  2. Wechseln Sie zu Kategorien > Software und Datenbank > UML-Komponente.

  3. Wählen Sie die leere Vorlage oder eines der drei Startdiagramme aus. Klicken Sie nach dem Auswählen der gewünschten Vorlage auf Erstellen.

  4. Daraufhin sollte neben dem Diagramm das Fenster Shapes angezeigt werden. Wenn es nicht angezeigt wird, wechseln Sie zu Ansicht > Aufgabenbereiche, und stellen Sie sicher, dass Shapes ausgewählt ist. Wenn es trotzdem nicht angezeigt wird, klicken Sie auf der linken Seite auf die Schaltfläche Das Shapes-Fenster erweitern Schaltfläche "Das Shapes-Fenster erweitern" .

  5. Stellen Sie auf der Registerkarte Ansicht sicher, dass das Kontrollkästchen neben Verbindungspunkte aktiviert ist. Dadurch werden Verbindungspunkte angezeigt, wenn Sie mit dem Verbinden von Shapes beginnen.

  6. Ziehen Sie jetzt die Shapes, die Sie in Ihr Diagramm einbeziehen möchten, aus dem Fenster Shapes auf das Zeichenblatt. Wenn Sie die Textbezeichnungen umbenennen möchten, doppelklicken Sie auf die Bezeichnungen.

Verwendung

Verwenden Sie Komponenten-Shapes für jede Funktionseinheit in Ihrem System oder Ihrer Anwendung.

Komponente-Shape "Store"

Stereotyp ein- oder ausblenden

Klicken Sie mit der rechten Maustaste auf das Shape, um die Stereotypbezeichnung ein- oder auszublenden.

Kontextmenü, Befehl "Stereotyp anzeigen", <<Komponente>> Bezeichnung

Teilsysteme

Sie können das Komponenten-Shape als Teilsystem-Shape verwenden, das andere Komponenten enthält. Vergrößern Sie einfach das Shape, und legen Sie die anderen Komponenten (per Drag & Drop) darauf ab. Lassen Sie die Maustaste los, wenn die grüne Hervorhebung angezeigt wird. Fortan fungiert das größere Shape als Container, und das kleinere Shape wird mit ihm verschoben.

Tipp : Wenn eine Komponente nicht mehr angezeigt wird, nachdem sie auf eine andere Komponente gezogen wurde, drücken Sie STRG+UMSCHALT+F, um sie in den Vordergrund zu stellen.

Teilsystem-Shape für "Store" mit Komponente "Order", die auf das Teilsystem gezogen ist

Verwendung

  1. Verwenden Sie das Shape Bereitgestellte Schnittstelle, wenn Sie die Realisierung einer Klasse/Schnittstelle angeben möchten.

  2. Verwenden Sie das Shape Erforderliche Schnittstelle, wenn Sie die Abhängigkeit von einer Klasse/Schnittstelle angeben möchten.

Zwei verbundene Schnittstellen, 1: Bereitgestellte Schnittstelle-Shape, das mit Kreis endet, 2: Erforderliche Schnittstelle-Shape, das mit Fassung endet

Schritt 1

Ziehen Sie ein Shape vom Typ Bereitgestellte Schnittstelle auf das Zeichenblatt, und richten Sie das Port-Quadrat mit einem Verbindungspunkt aus. Es ist verbunden, wenn der Verbindungspunkt von der grünen Hervorhebung umgeben ist.

Bereitgestellte Schnittstelle-Shape, das mit dem Komponente-Shape verklebt ist

Schritt 2

Ziehen Sie ein Shape vom Typ Erforderliche Schnittstelle auf das Zeichenblatt, und richten Sie auch das Port-Quadrat mit einem Verbindungspunkt aus. Es ist verbunden, wenn der Verbindungspunkt von der grünen Hervorhebung umgeben ist.

Erforderliche Schnittstelle-Shape, das mit dem Komponente-Shape verklebt ist

Schritt 3

Wenn Sie eine bereitgestellte Schnittstelle und eine erforderliche Schnittstelle verbinden möchten, wählen Sie zuerst das Shape "Erforderliche Schnittstelle" aus. Suchen Sie dann nach dem gelben Ziehpunkt.

Gelber Ziehpunkt auf dem Erforderliche Schnittstelle-Shape

Schritt 4

Ziehen Sie den gelben Ziehpunkt, um die Verbindung mit der bereitgestellten Schnittstelle herzustellen.

Erforderliche Schnittstelle-Shape, verbunden mit Bereitgestellte Schnittstelle-Shape

Begradigen von Verbindern

Wenn ein Verbinder zu viele Wendungen aufweist, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Gerader Verbinder.

Anzeigen der Multiplizität

Klicken Sie ggf. mit der rechten Maustaste auf den Verbinder, und wählen Sie Multiplizität anzeigen aus. Wenn Sie fertig sind, werden vier Textfelder angezeigt, in denen Sie Details hinzufügen können. Wenn Sie nicht alle Textfelder benötigen, löschen Sie die nicht benötigten Textfelder.

Ändern des Verbindertyps

Sie können einen Verbindertyp ändern. Sie können beispielsweise die Assoziation in eine gerichtete Assoziation ändern. Klicken Sie mit der rechten Maustaste auf den Verbinder, und klicken Sie dann auf Verbindertyp festlegen.

Erstellen von dynamischen Verbindungen anstelle von Punkt-zu-Punkt-Verbindungen

Wenn Sie Shapes voraussichtlich oft verschieben, sollten Sie anstelle einer Punkt-zu-Punkt-Verbindung eine dynamische Verbindung erstellen.

Verschieben oder Drehen von Text auf Verbindern

Wahrscheinlich müssen Sie den Text auf Ihren Verbindungslinien drehen oder verschieben. Hier wird beschrieben, wie das geht:

  1. Klicken Sie auf dem Zeichenblatt auf einen leeren Bereich, um eine ggf. bestehende Auswahl aufzuheben.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Tools auf Textblock drehen Schaltfläche "Textblock" .

  3. Klicken Sie auf den Verbinder, der den Text enthält, den Sie drehen oder verschieben möchten.

  4. Ziehen Sie den Textblock, um ihn zu verschieben, oder drehen Sie ihn mithilfe des Drehpunkts Drehpunkt, an dem gezogen wird .

  5. Wenn Sie fertig sind, klicken Sie auf die Schaltfläche Zeigertool Schaltfläche "Zeiger" .

    Nachdem Sie zur Schaltfläche Zeigertool Schaltfläche "Zeiger" zurückgekehrt sind, wird dieselbe relative Position des Texts zum Shape beibehalten. Wenn Sie den Text mit dem Zeigertool Schaltfläche "Zeiger" ziehen, wird auch das Shape verschoben. Wenn Sie den Text unabhängig vom Shape verschieben möchten, müssen Sie wieder zu Textblock drehen Schaltfläche "Textblock" zurückwechseln.

Siehe auch

UML-Diagramme in Visio

Erstellen eines UML-Kommunikationsdiagramms

Erstellen eines UML-Verteilungsdiagramms

Erstellen eines UML-Sequenzdiagramms

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×