Erstellen eines UML-Kommunikationsdiagramms

Sie können ein UML-Kommunikationsdiagramm erstellen, um die Interaktionen zwischen Lebenslinien darzustellen, die sequenzierte Nachrichten in einer Freihandanordnung verwenden. Öffnen Sie zunächst die Vorlage UML-Kommunikation, und wählen Sie eine der vier Vorlagenoptionen aus. Dann wird die Schablone UML-Kommunikation zusammen mit Shapes angezeigt, die dem UML 2.5-Standard entsprechen.

Schablone "UML-Kommunikation", Beispiel-Shapes auf der Seite

Hinweis : Die Schablone UML-Kommunikation ist nur für Abonnenten von Visio Pro für Office 365 verfügbar. Wenn Sie über ein Abonnement verfügen, vergewissern Sie sich, dass Sie die neueste Version von Visio verwenden.

  1. Starten Sie Visio. Oder, wenn Sie bereits eine Datei geöffnet haben, klicken Sie auf Datei > Neu.

  2. Wechseln Sie zu Kategorien > Software und Datenbank > UML-Kommunikation.

  3. Wählen Sie die leere Vorlage oder eines der drei Startdiagramme aus. Wenn Sie die Kollaboration von Lebenslinien durch Aufzeigen der Interaktionen zwischen den Lebenslinien darstellen möchten, stellen Sie sicher, dass Sie in der unteren linken Ecke das Startdiagramm auswählen.

  4. Klicken Sie auf Erstellen.

  5. Daraufhin sollte neben dem Diagramm das Fenster Shapes angezeigt werden. Wenn es nicht angezeigt wird, wechseln Sie zu Ansicht > Aufgabenbereiche, und stellen Sie sicher, dass Shapes ausgewählt ist. Wenn es trotzdem nicht angezeigt wird, klicken Sie auf der linken Seite auf die Schaltfläche Das Shapes-Fenster erweitern Schaltfläche "Das Shapes-Fenster erweitern" .

  6. Stellen Sie auf der Registerkarte Ansicht sicher, dass das Kontrollkästchen neben Verbindungspunkte aktiviert ist. Dadurch werden Verbindungspunkte angezeigt, wenn Sie mit dem Verbinden von Shapes beginnen.

  7. Ziehen Sie jetzt die Shapes, die Sie in Ihr Diagramm einbeziehen möchten, aus dem Fenster Shapes auf das Zeichenblatt. Wenn Sie die Textbezeichnungen umbenennen möchten, doppelklicken Sie auf die Bezeichnungen.

Verwendung

  1. Ziehen Sie das Shape Akteur auf das Zeichenblatt, um die Rolle eines Benutzers oder ein externes System darzustellen.

  2. Ziehen Sie das Shape Lebenslinie für jedes benannte Element, das einen einzelnen Teilnehmer darstellt, auf das Zeichenblatt.

1: Akteur-Shape mit Test "Somebody", 2: Lebenslinie-Shape mit Text ":Coupon"

Schritt 1

Ziehen Sie ein Nachrichten-Shape auf das Zeichenblatt, und kleben Sie ein Ende an einen Verbindungspunkt eines anderen Shapes. Es ist angeklebt, wenn der Verbindungspunkt von einem grünen Quadrat umgeben ist.

Nachricht-Shape, dessen eines Ende grün hervorgehoben und mit einem Lebenslinie-Shape verbunden ist

Schritt 2

Führen Sie denselben Schritt für das andere Ende der Nachricht aus, damit auch dieses Ende an einen Verbindungspunkt angeklebt wird. Es ist angeklebt, wenn der Verbindungspunkt von einer grünen Hervorhebung umgeben ist.

Nachricht-Shape, dessen Ende grün hervorgehoben und mit einem anderen Lebenslinie-Shape verbunden ist

Schritt 3

Wenn die Nachricht asynchron sein soll, klicken Sie mit der rechten Maustaste, und wählen Sie Asynchron aus. Durch diese Aktion ändert sich die geschlossene Pfeilspitze in eine offene Pfeilspitze.

Nachricht-Shape, Kontextmenü, Befehl "Asynchron" ausgewählt

Übersicht

  1. Verbinden Sie zuerst die Lebenslinien mithilfe von Automatischer Verbinder.

  2. Verwenden Sie dann die Shapes Nachricht und Antwortnachricht, um die Interaktionen zwischen den Lebenslinien darzustellen.

1 zeigt auf graue Verbinderlinie, 2 zeigt auf Nachrichtenlinie mit Text "4: Execute()"

Schritt 1

Klicken Sie auf der Registerkarte Start auf Verbinder (1). Zeigen Sie mit der Maus auf einen der Verbindungspunkte eines Lebenslinien-Shapes, bis eine grüne Hervorhebung (2) angezeigt wird.

1 zeigt auf Tool "Verbinder", 2 zeigt auf den Cursor, der sich über dem grün hervorgehobenen Verbindungspunkt auf dem Lebenslinie-Shape befindet

Schritt 2

Klicken und ziehen Sie von der grünen Hervorhebung zu einem Verbindungspunkt eines anderen Lebenslinien-Shape, bis Sie so eine Hervorhebung sehen.

Ende der Verbinderlinie, die zu einem anderen Lebenslinie-Shape gezogen wurde, mit grüner Hervorhebung um Verbindungspunkt

Schritt 3

Klicken Sie nach dem Verbinden der Lebenslinien-Shapes auf das Zeigertool.

"Click here when you're done", zeigt auf Befehl "Zeigertool"

Schritt 4

Ziehen Sie ein anderes Nachrichten-Shape so, dass es parallel zu der anderen Linie verläuft.

Cursor, mit dem das Nachricht-Shape direkt an der Verbinderlinie positioniert wird

Begradigen von Verbindern

Wenn ein Verbinder zu viele Wendungen aufweist, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Gerader Verbinder.

Ändern des Verbindertyps

Sie können einen Verbindertyp ändern. Sie können beispielsweise die Assoziation in eine gerichtete Assoziation ändern. Klicken Sie mit der rechten Maustaste auf den Verbinder, und klicken Sie dann auf Verbindertyp festlegen.

Erstellen von dynamischen Verbindungen anstelle von Punkt-zu-Punkt-Verbindungen

Wenn Sie Shapes voraussichtlich oft verschieben, sollten Sie anstelle einer Punkt-zu-Punkt-Verbindung eine dynamische Verbindung erstellen.

Verschieben oder Drehen von Text auf Verbindern

Wahrscheinlich müssen Sie den Text auf Ihren Verbindungslinien drehen oder verschieben. Hier wird beschrieben, wie das geht:

  1. Klicken Sie auf dem Zeichenblatt auf einen leeren Bereich, um eine ggf. bestehende Auswahl aufzuheben.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Tools auf Textblock drehen Schaltfläche "Textblock" .

  3. Klicken Sie auf den Verbinder, der den Text enthält, den Sie drehen oder verschieben möchten.

  4. Ziehen Sie den Textblock, um ihn zu verschieben, oder drehen Sie ihn mithilfe des Drehpunkts Drehpunkt, an dem gezogen wird .

  5. Wenn Sie fertig sind, klicken Sie auf die Schaltfläche Zeigertool Schaltfläche "Zeiger" .

    Nachdem Sie zur Schaltfläche Zeigertool Schaltfläche "Zeiger" zurückgekehrt sind, wird dieselbe relative Position des Texts zum Shape beibehalten. Wenn Sie den Text mit dem Zeigertool Schaltfläche "Zeiger" ziehen, wird auch das Shape verschoben. Wenn Sie den Text unabhängig vom Shape verschieben möchten, müssen Sie wieder zu Textblock drehen Schaltfläche "Textblock" zurückwechseln.

Siehe auch

UML-Diagramme in Visio

Erstellen eines UML-Komponentendiagramms

Erstellen eines UML-Verteilungsdiagramms

Erstellen eines UML-Sequenzdiagramms

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×