Erstellen eines ORM-Diagramms

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Die Vorlage ORM-Diagramm in Microsoft Office Visio enthält alle Shapes, die Sie benötigen, um die ORM-Methode (Object Role Modeling) für die Erfassung von Business Rules und den Entwurf von Datenbanken zu verwenden. ORM ist ein auf Semantikmodellen beruhender Ansatz, bei dem die Welt mittels Objekten und den Rollen, die diese Objekte spielen, beschrieben wird.

Beispiel für ein ORM-Diagramm

  1. Zeigen Sie im Menü Datei auf Neu, dann auf Software und Datenbank, und klicken Sie auf ORM-Diagramm.

    Tipp : Vor dem Erstellen eines ORM-Diagramms sollten Sie sich die Informationen notieren, die die Datenbank enthalten soll. Beschreiben Sie kurz die vorhandenen Objekte, wie sie erkannt werden und welche Rolle sie spielen.

  2. Fügen Sie einen Objekttyp (Entität) hinzu, und benennen Sie diesen:

    1. Ziehen Sie ein Entität-Shape (zum Darstellen eines Objekttyps) aus dem ORM-Diagramm auf das Zeichenblatt.

    2. Markieren Sie das Shape, und geben Sie den Namen des Entitätstyps ein.

    3. Drücken Sie die EINGABETASTE, und geben Sie dann den Referenzmodus der Entität in Klammern ein.

  3. Fügen Sie einen Werttyp hinzu, und benennen Sie diesen:

    1. Ziehen Sie ein Wert-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

    2. Markieren Sie das Shape, und geben Sie den Namen des Werttyps ein.

  4. Geben Sie einen Untertyp an:

    1. Ziehen Sie ein Untertypverbinder-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

    2. Kleben Sie den Endpunkt Endpunktsymbol – Plus-Zeichen in einem grünen Quadrat , um eine Verbindung Punkt Verbindungspunkt (blaues X) des Untertyp Entität-Shapes.

      Der Endpunkt wird rot angezeigt, was darauf hinweist, dass der Verbinder am Shape klebt. Sie können die geklebten Shapes verschieben, ohne die Verbindung zu lösen.

    3. Kleben Sie die beginnen Sie mit der Punkt Anfangspunkt – grünes Quadrat mit einem X (Ende der Pfeilspitze) zu einer Verbindung Punkt Verbindungspunkt (blaues X) der anderen Entität vom Typ.

  5. Führen Sie einen der folgenden Schritte aus:

    1. Geben Sie eine Beziehung, eine Rolle oder ein Faktum zwischen den Objekttypen an:

      1. Ziehen Sie ein Prädikat-Shape (Unär, Binär, Vertikal binär, Ternär oder Quaternär) aus dem ORM-Diagramm auf das Zeichenblatt.

        Verwenden Sie ein Prädikat-Shape mit ausreichend Rollenfeldern für alle Objekttypen (Entitäten-Shapes), die an der Beziehung beteiligt sind. Verwenden Sie beispielsweise das Ternär-Shape, um Beziehungen zwischen drei Entitäten zu kennzeichnen.

      2. Ziehen Sie ein Rollenverbinder-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      3. Kleben Sie beginnen Sie mit der Punkt Anfangspunkt – grünes Quadrat mit einem X des Shapes Rolle zu einer Verbindung Punkt Verbindungspunkt (blaues X) auf einen Objekttyp (Entität-Shape), für den Sie eine Beziehung definieren möchten.

        Der Anfangspunkt wird rot angezeigt, was darauf hinweist, dass der Verbinder am Shape klebt. Sie können die geklebten Shapes verschieben, ohne die Verbindung zu lösen.

      4. Kleben Sie den Endpunkt Endpunktsymbol – Plus-Zeichen in einem grünen Quadrat des Rolle-Shapes auf das geeignete Rolle aus, auf das Prädikat-Shape (aus Schritt 1).

      5. Doppelklicken Sie auf das Prädikat-Shape. Setzen Sie die Einfügemarke zwischen Ellipsen (oder Platzhaltern), und geben Sie dann einen Namen für die Rolle ein, die ein Entitätstyp spielt.

      6. Wiederholen Sie die Schritte 2 bis 5 für jede Entität, für die Sie eine Beziehung definieren möchten.

    2. Geben Sie eine Beziehung, Rolle oder Referenz zwischen einer Entität und einem Wert an:

      1. Ziehen Sie das Rollenverbinder-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      2. Kleben Sie beginnen Sie mit der Punkt Anfangspunkt – grünes Quadrat mit einem X des Shapes Rolle zu einer Verbindung Punkt Verbindungspunkt (blaues X) eine Entität vom Typ (Entität Shape) für die Sie eine Beziehung definieren möchten.

        Der Anfangspunkt wird rot angezeigt, was darauf hinweist, dass der Verbinder am Shape klebt. Sie können die geklebten Shapes verschieben, ohne die Verbindung zu lösen.

      3. Ziehen Sie ein Binär- oder Vertikal binär-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      4. Kleben Sie den Endpunkt Endpunktsymbol – Plus-Zeichen in einem grünen Quadrat des Shapes Rolle bis zum Ende des binäre oder Vertikale binäre-Shapes.

      5. Doppelklicken Sie auf das Binär-Shape, um den Text zu bearbeiten. Platzieren Sie die Einfügemarke zwischen Ellipsen oder Platzhalter, und geben Sie dann einen Namen für die Rolle ein, die eine Entität spielt.

        Tipp : Zum Verschieben der Ellipsen und Namen eines Vertikal binär-Shapes auf die andere Seite des Shapes klicken Sie mit der rechten Maustaste auf das Shape, zeigen Sie im Kontextmenü auf Shape, und klicken Sie dann auf Horizontal kippen.

  6. Zeigen Sie ein geschachteltes Objekt an, indem Sie ein objektifiziertes Prädikat erstellen:

    1. Klicken Sie auf die Zeichentools Schaltfläche Schaltflächensymbol um die Symbolleiste Zeichentools anzuzeigen, und klicken Sie dann auf das Rechteck / Quadrat Schaltflächensymbol

    2. Zeichnen Sie ein Rechteck um das Prädikat-Shape (Unär, Binär, Vertikal binär, Ternär und Quaternär), das Sie als objektifiziertes Prädikat kennzeichnen möchten.

    3. Klicken Sie mit der rechten Maustaste auf das Rechteck, zeigen Sie im Kontextmenü auf Shape, und klicken Sie dann auf In den Hintergrund.

    4. Klicken Sie, während das Rechteck markiert ist, im Menü Format auf Eckabrundung, klicken Sie auf die dritte Option in der obersten Zeile, und klicken Sie dann auf OK.

  7. Führen Sie einen der folgenden Schritte aus:

    1. Geben Sie eine erforderliche Rolleneinschränkung an:

      1. Ziehen Sie das Erf. Rollenverbinder-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      2. Kleben Sie den Anfangspunkt mit dem schwarzen Kreis Anfangspunkt – grünes Quadrat mit einem X um eine Verbindung Punkt Verbindungspunkt (blaues X) eines Objekts (Entität Shape).

        Der Anfangspunkt wird rot angezeigt, was darauf hinweist, dass der Verbinder am Shape klebt. Sie können die geklebten Shapes verschieben, ohne die Verbindung zu lösen.

      3. Kleben Sie den Endpunkt Endpunktsymbol – Plus-Zeichen in einem grünen Quadrat von der Erf. Rollenverbinder Shapes an ein Prädikat-Shape (unärer, binäre, Vertikale binäre, Ternär oder Quaternär ).

    2. Geben Sie eine Eindeutigkeitseinschränkung an:

      1. Ziehen Sie das Eindeutigkeitseinschränkung-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      2. Platzieren Sie das Shape direkt über oder unter das Prädikat-Shape (Unär, Binär, Vertikal binär, Ternär und Quaternär), das eingeschränkt werden soll.

      3. Ziehen Sie einen Ihrer Endpunkte ( Anfangspunkt – grünes Quadrat mit einem X oder Endpunktsymbol – Plus-Zeichen in einem grünen Quadrat ) aus, damit der Pfeil über das Feld geeignete Rolle des Prädikat-Shapes erstreckt.

    3. Geben Sie eine Frequenzeinschränkung an:

      1. Ziehen Sie das Frequenzeinschränkung-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      2. Platzieren Sie das Shape neben dem Prädikat-Shape (Unär, Binär, Vertikal binär, Ternär und Quaternär), das eingeschränkt werden soll.

      3. Markieren Sie das Shape, und geben Sie die gewünschte Frequenz ein.

    4. Geben Sie eine Subset- oder Gleichheitseinschränkung an:

      1. Ziehen Sie das Subseteinschränkung- oder Gleichheitseinschränkung-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      2. Platzieren Sie das Shape zwischen den Prädikat-Shapes (Unär, Binär, Vertikal binär, Ternär und Quaternär), die einzuschränkende Rollen enthalten.

      3. Kleben Sie beginnen Sie mit der Punkt Anfangspunkt – grünes Quadrat mit einem X des Teilmenge Einschränkung oder Equality Einschränkung-Shapes an eine Verbindung Punkt Verbindungspunkt (blaues X) geeignete Rolle im Dialogfeld auf das Prädikat-Shape.

        Der Anfangspunkt wird rot angezeigt, was darauf hinweist, dass der Verbinder am Shape klebt. Sie können die geklebten Shapes verschieben, ohne die Verbindung zu lösen.

      4. Kleben Sie den Endpunkt Endpunktsymbol – Plus-Zeichen in einem grünen Quadrat des Teilmenge Einschränkung oder Equality Einschränkung-Shapes auf das geeignete Rolle der anderen Prädikat-Shape.

    5. Geben Sie eine Ringeinschränkung an:

      1. Ziehen Sie das Ringeinschränkung-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      2. Platzieren Sie das Shape neben dem Prädikat-Shape (Unär, Binär, Vertikal binär, Ternär und Quaternär), das die beiden Rollen enthält, die eingeschränkt werden sollen.

      3. Führen Sie einen der folgenden Schritte aus:

        • Wenn Sie die beiden Rollen ein mehr Prädikat gehören, kleben Sie jeder Endpunkt ( Anfangspunkt – grünes Quadrat mit einem X und Endpunktsymbol – Plus-Zeichen in einem grünen Quadrat ) von Anrufen Einschränkung-Shapes an eine der Rollen auf das Prädikat-Shape.

        • Wenn es sich bei den beiden Rollen um ein binäres Prädikat handelt, markieren Sie das Ringeinschränkung-Shape, und klicken Sie dann im Menü Format auf Linie. Klicken Sie in der Liste Muster auf Ohne, und klicken Sie dann auf OK.

      4. Klicken Sie mit der rechten Maustaste auf das Ringeinschränkung-Shape, und klicken Sie im Kontextmenü auf den gewünschten Ringeinschränkungstyp.

    6. Geben Sie eine externe Einschränkung an:

      1. Ziehen Sie ein Shape mit einer externen Einschränkung (Ext. Frequ.- Einschränkung, Ext. P- Einschränkung, Ext. erford.- Einschränkung oder Ext. Eindeut.- Einschränkung) aus dem ORM-Diagramm auf das Zeichenblatt.

      2. Platzieren Sie das Shape neben den Prädikat-Shapes, die die einzuschränkenden Rollen darstellen.

      3. Ziehen Sie das Einschränkungsverbinder-Shape aus dem ORM-Diagramm auf das Zeichenblatt.

      4. Kleben Sie beginnen Sie mit der Punkt Anfangspunkt – grünes Quadrat mit einem X der Einschränkung Verbinder-Shapes an eine Verbindung Punkt Verbindungspunkt (blaues X) des externen Einschränkung-Shapes.

        Der Anfangspunkt wird rot angezeigt, was darauf hinweist, dass der Verbinder am Shape klebt. Sie können die geklebten Shapes verschieben, ohne die Verbindung zu lösen.

      5. Kleben Sie den Endpunkt Endpunktsymbol – Plus-Zeichen in einem grünen Quadrat des Einschränkung-Shapes auf das geeignete Rolle aus, auf das Prädikat-Shape (unärer, binäre, Vertikale binäre, Ternär oder Quaternär ).

      6. Zum Ändern der Frequenz des Shapes mit der externen Einschränkung (Ext. Frequ.- Einschränkung, Ext. P- Einschränkung, Ext. erford.- Einschränkung oder Ext. Eindeut.- Einschränkung) markieren Sie das Shape und geben dann die gewünschte Frequenz ein.

  8. Speichern Sie das Diagramm.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×