Erstellen eines Modells anhand einer vorhandenen Datenbank mittels Reverse Engineering

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Mit dem in Visio Pro für Office 365, Microsoft Visio Professional und Microsoft Visio Premium-Editionen verfügbaren Assistenten für Reverse Engineering können Sie ein Datenbankmodell anhand einer vorhandenen Datenbank oder Microsoft Excel-Arbeitsmappe erstellen. In Datenbankmodellen wird die Struktur einer Datenbank grafisch dargestellt, sodass Sie die Beziehungen zwischen Datenbankelementen wie Tabellen und Ansichten erkennen können, ohne dass die eigentlichen Daten angezeigt werden. Dadurch kann eine neue Datenbank einfacher erstellt bzw. die Struktur einer vorhandenen Datenbank besser nachvollzogen werden.

Inhalt dieses Artikels

Wo finde ich die Datenbankmodellierungsfeatures für Visio Pro für Office 365?

Überprüfen der vom Assistenten für Reverse Engineering extrahierten Elemente

Auszuführende Schritte vor dem Starten des Assistenten

Durchführen von Reverse Engineering für eine vorhandene Datenbank

Wo finde ich die Datenbankmodellierungsfeatures für Visio Pro für Office 365?

Mit dem Visio-Add-In für Datenbankmodelle können Sie ein Datenbankmodell anhand einer vorhandenen Datenbank erstellen. Dieses Add-In funktioniert nur in Visio Pro für Office 365. Wenn Sie nicht genau wissen, welche Visio-Version Sie verwenden, klicken Sie auf Datei > Konto > Info. Weitere Informationen zur Abonnementversion von Visio finden Sie unter Visio Pro für Office 365.

Herunterladen des Visio-Add-Ins für Datenbankmodelle

  1. Sie können das Add-In hier herunterladen.

  2. Wählen Sie auf der Downloadseite die gewünschte Sprache aus, und klicken Sie dann auf Herunterladen.

  3. Wählen Sie die 64-Bit-Version (x64) bzw. die 32-Bit-Version (x86) aus, die Ihrer Visio Pro für Office 365-Version entspricht. Sie können auch eine PDF-Datei herunterladen, die Anweisungen zur Installation enthält. Klicken Sie auf Weiter, um die Dateien auf Ihren Computer oder auf das Gerät herunterzuladen.

  4. Schließen Sie Visio, bevor Sie den nächsten Schritt ausführen, falls das Programm geöffnet ist.

  5. Suchen Sie nach der MSI-Installationsdatei, die Sie heruntergeladen haben, und doppelklicken Sie dann darauf, um die Installation zu starten. Klicken Sie bei der entsprechenden Aufforderung auf Installieren, und klicken Sie sich dann durch die Installationsbildschirme, um den Installationsvorgang vollständig auszuführen.

  6. Das Datenbankmodelldiagramm ist jetzt in Ihrem Visio Pro für Office 365-Abonnementprogramm verfügbar.

Überprüfen der vom Assistenten für Reverse Engineering extrahierten Elemente

Die Informationen zur Schemadefinition, die der Assistent extrahieren kann, sind von einer Kombination verschiedener Faktoren wie den Funktionen des Datenbank-Managementsystems (DBMS) und dem ODBC-Treiber abhängig. Im Assistenten werden alle Elemente angezeigt, die extrahiert werden können, und Sie können die gewünschten Elemente auswählen. So sind Sie beispielsweise nur an 5 von 10 Tabellen und 2 von 4 Ansichten interessiert.

Beim Ausführen des Assistenten können Sie auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

Sofern die Elemente im Ziel-DBMS verfügbar sind, können Sie die folgenden Elemente extrahieren:

  • Tabellen

  • Ansichten

  • Primärschlüssel

  • Fremdschlüssel

  • Indizes

  • Trigger (einschließlich Code)

  • Feldprüfungsbedingungen/Prüfklauseln (einschließlich Code)

  • Gespeicherte Prozeduren (einschließlich Code)

Auszuführende Schritte vor dem Starten des Assistenten

Wenn Sie ein Reverse Engineering für eine Excel-Arbeitsmappe durchführen, müssen Sie vor dem Starten des Assistenten die Arbeitsmappe öffnen und die Gruppe (oder den Bereich) von Zellen benennen, die die Spaltenüberschriften enthalten. Wenn Sie mehrere Arbeitsblätter verwenden möchten, benennen Sie einfach die Gruppe von Spaltenzellen in jedem Arbeitsblatt. Im Assistenten werden diese Bereiche wie Tabellen behandelt. Weitere Informationen dazu, wie Sie einen Zellbereich benennen, finden Sie in der Microsoft Office Excel-Hilfe.

Legen Sie vor dem Ausführen des Assistenten für Reverse Engineering den Standardtreiber auf die Zieldatenbank fest, für die das Reverse Engineering durchgeführt werden soll, um optimale Ergebnisse zu erzielen. Dadurch wird sichergestellt, dass der Assistent die systemeigenen Datentypen richtig zuordnet und der gesamte vom Assistenten extrahierte Code im Codefenster ordnungsgemäß angezeigt wird.

  1. Klicken Sie auf die Registerkarte Datei, klicken Sie auf Neu, auf Vorlagen und auf Software und Datenbank, und doppelklicken Sie dann auf Datenbankmodelldiagramm.

  2. Klicken Sie auf der Registerkarte Datenbank in der Gruppe Verwalten auf Datenbanktreiber.

  3. Wählen Sie auf der Registerkarte Treiber den von Visio bereitgestellten Treiber für Ihr DBMS aus. Wenn Sie beispielsweise eine Access-Datenbank entwerfen, wählen Sie "Microsoft Access" aus.

    Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

  4. Klicken Sie auf Einrichten.

  5. Aktivieren Sie auf der Registerkarte ODBC-Treiber das Kontrollkästchen für den vom Hersteller bereitgestellten Treiber für Ihr DBMS. Wenn Sie beispielsweise eine Access-Datenbank entwerfen, aktivieren Sie das Kontrollkästchen Microsoft Access-Treiber (*.mdb, *.accdb).

  6. Klicken Sie in jedem Dialogfeld auf OK.

Ein vom Hersteller bereitgestellter 32-Bit-ODBC-Treiber muss aus einem ODBC Data Access Pack einer höheren Version als 2.0 stammen und mit ODBC Level 1 (oder höher) kompatibel sein. Ein vom Hersteller bereitgestellter OLE DB-Anbieter muss mit der OLE DB-Version 1.0 oder einer höheren Spezifikation kompatibel sein.

Seitenanfang

Durchführen von Reverse Engineering für eine vorhandene Datenbank

  1. Klicken Sie in Ihrem Datenbankmodelldiagramm auf der Registerkarte Datenbank auf Reverse Engineering.

  2. Führen Sie auf dem ersten Bildschirm des Assistenten für Reverse Engineering die folgenden Aktionen aus:

    1. Wählen Sie den Microsoft Visio-Datenbanktreiber für Ihr Datenbank-Managementsystem (DBMS) aus. Wenn Sie den Visio-Datenbanktreiber noch keiner bestimmten ODBC-Datenquelle zugeordnet haben, klicken Sie auf Einrichten, um dies nun zu tun.

      Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

    2. Wählen Sie die Datenquelle der Datenbank aus, die Sie aktualisieren möchten. Wenn Sie noch keine Datenquelle für die vorhandene Datenbank erstellt haben, klicken Sie auf Neu, um dies nun zu tun.

      Wenn Sie eine neue Quelle erstellen, wird ihr Name zur Liste Datenquellen hinzugefügt.

    3. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf Weiter.

    4. Folgen Sie den Anweisungen in allen treiberspezifischen Dialogfeldern. Geben Sie beispielsweise im Dialogfeld Datenquelle verbinden einen Benutzernamen und das Kennwort ein, und klicken Sie dann auf OK. Wenn Ihre Datenquelle nicht kennwortgeschützt ist, klicken Sie auf OK.

  3. Aktivieren Sie die Kontrollkästchen für die Informationen, die Sie extrahieren möchten, und klicken Sie dann auf Weiter.

    Einige Elemente sind möglicherweise abgeblendet, weil nicht alle Systeme alle Arten von Elementen unterstützen, die der Assistent extrahieren kann.

  4. Aktivieren Sie die Kontrollkästchen für die Tabellen (und Ansichten, falls vorhanden), die Sie extrahieren möchten, oder klicken Sie auf Alles auswählen um alle Tabellen (und Ansichten) zu extrahieren, und klicken Sie dann auf Weiter.

    Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen und in dieser Liste keine Elemente angezeigt werden, müssen Sie wahrscheinlich den Bereich der Zellen benennen, die die Spaltenüberschriften in Ihrer Tabelle enthalten.

  5. Wenn Sie in Schritt 5 das Kontrollkästchen Gespeicherte Prozeduren aktiviert haben, wählen Sie die zu extrahierenden Prozeduren aus, oder klicken Sie auf Alles auswählen, um alle Prozeduren zu extrahieren, und klicken Sie dann auf Weiter.

  6. Wählen Sie aus, ob die Elemente, für die ein Reverse Engineering durchgeführt wurde, automatisch zur aktuellen Seite hinzugefügt werden sollen.

    Sie können im Assistenten auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

  7. Überprüfen Sie die ausgewählten Optionen, um sicherzustellen, dass die gewünschten Informationen extrahiert werden, und klicken Sie dann auf Fertig stellen.

Wenn Sie den Standardtreiber "ODBC-Treiber Universal" verwenden, wird möglicherweise eine Fehlermeldung angezeigt, die darauf hinweist, dass die Informationen, für die ein Reverse Engineering durchgeführt wurde, unvollständig sein können. In den meisten Fällen ist das kein Problem. Klicken Sie einfach auf OK, und setzen Sie die Ausführung des Assistenten fort.

Der Assistent extrahiert die ausgewählten Informationen und zeigt im Ausgabefenster Hinweise zum Extrahierungsprozess an.

Seitenanfang

Visio 2016 unterstützt keine Reverse Engineering-Assistenten

Der Assistent für Reverse Engineering ist nicht verfügbar in Visio Professional 2016 oder Visio Standard 2016. Um die Datenbankfunktionen verwenden zu können, in Erwägung Visio Pro für Office 365.

Testen der neuen Version von Outlook

In Visio 2013 wird der Assistent für Reverse Engineering nicht unterstützt

Der Assistent für Reverse Engineering ist nicht verfügbar in Visio Professional 2013 oder Visio Standard 2013. Um die Datenbankfunktionen verwenden zu können, in Erwägung Visio Pro für Office 365.

Testen der neuen Version von Outlook

Inhalt dieses Artikels

Überprüfen der vom Assistenten für Reverse Engineering extrahierten Elemente

Auszuführende Schritte vor dem Starten des Assistenten

Durchführen von Reverse Engineering für eine vorhandene Datenbank

Überprüfen der vom Assistenten für Reverse Engineering extrahierten Elemente

Die Informationen zur Schemadefinition, die der Assistent extrahieren kann, sind von einer Kombination verschiedener Faktoren wie den Funktionen des Datenbank-Managementsystems (DBMS) und dem ODBC-Treiber abhängig. Im Assistenten werden alle Elemente angezeigt, die extrahiert werden können, und Sie können die gewünschten Elemente auswählen. So sind Sie beispielsweise nur an 5 von 10 Tabellen und 2 von 4 Ansichten interessiert.

Beim Ausführen des Assistenten können Sie auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

Sofern die Elemente im Ziel-DBMS verfügbar sind, können Sie die folgenden Elemente extrahieren:

  • Tabellen

  • Ansichten

  • Primärschlüssel

  • Fremdschlüssel

  • Indizes

  • Trigger (einschließlich Code)

  • Feldprüfungsbedingungen/Prüfklauseln (einschließlich Code)

  • Gespeicherte Prozeduren (einschließlich Code)

Seitenanfang

Auszuführende Schritte vor dem Starten des Assistenten

Wenn Sie ein Reverse Engineering für eine Excel-Arbeitsmappe durchführen, müssen Sie vor dem Starten des Assistenten die Arbeitsmappe öffnen und die Gruppe (oder den Bereich) von Zellen benennen, die die Spaltenüberschriften enthalten. Wenn Sie mehrere Arbeitsblätter verwenden möchten, benennen Sie einfach die Gruppe von Spaltenzellen in jedem Arbeitsblatt. Im Assistenten werden diese Bereiche wie Tabellen behandelt. Weitere Informationen dazu, wie Sie einen Zellbereich benennen, finden Sie in der Microsoft Office Excel-Hilfe.

Legen Sie vor dem Ausführen des Assistenten für Reverse Engineering den Standardtreiber auf die Zieldatenbank fest, für die das Reverse Engineering durchgeführt werden soll, um optimale Ergebnisse zu erzielen. Dadurch wird sichergestellt, dass der Assistent die systemeigenen Datentypen richtig zuordnet und der gesamte vom Assistenten extrahierte Code im Codefenster ordnungsgemäß angezeigt wird.

  1. Klicken Sie auf die Registerkarte Datei, klicken Sie auf Neu und auf Software und Datenbank, und doppelklicken Sie dann auf Datenbankmodelldiagramm.

  2. Klicken Sie auf der Registerkarte Datenbank in der Gruppe Verwalten auf Datenbanktreiber.

  3. Wählen Sie auf der Registerkarte Treiber den von Visio bereitgestellten Treiber für Ihr DBMS aus. Wenn Sie beispielsweise eine Access-Datenbank entwerfen, wählen Sie "Microsoft Access" aus.

    Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

  4. Klicken Sie auf Einrichten.

  5. Aktivieren Sie auf der Registerkarte ODBC-Treiber das Kontrollkästchen für den vom Hersteller bereitgestellten Treiber für Ihr DBMS. Wenn Sie beispielsweise eine Access-Datenbank entwerfen, aktivieren Sie das Kontrollkästchen Microsoft Access-Treiber (*.mdb).

  6. Klicken Sie in jedem Dialogfeld auf OK.

Ein vom Hersteller bereitgestellter 32-Bit-ODBC-Treiber muss aus einem ODBC Data Access Pack einer höheren Version als 2.0 stammen und mit ODBC Level 1 (oder höher) kompatibel sein. Ein vom Hersteller bereitgestellter OLE DB-Anbieter muss mit der OLE DB-Version 1.0 oder einer höheren Spezifikation kompatibel sein.

Seitenanfang

Durchführen von Reverse Engineering für eine vorhandene Datenbank

  1. Klicken Sie in Ihrem Datenbankmodelldiagramm auf der Registerkarte Datenbank auf Reverse Engineering.

  2. Führen Sie auf dem ersten Bildschirm des Assistenten für Reverse Engineering die folgenden Aktionen aus:

    1. Wählen Sie den Microsoft Visio-Datenbanktreiber für Ihr Datenbank-Managementsystem (DBMS) aus. Wenn Sie den Visio-Datenbanktreiber noch keiner bestimmten ODBC-Datenquelle zugeordnet haben, klicken Sie auf Einrichten, um dies nun zu tun.

      Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

    2. Wählen Sie die Datenquelle der Datenbank aus, die Sie aktualisieren möchten. Wenn Sie noch keine Datenquelle für die vorhandene Datenbank erstellt haben, klicken Sie auf Neu, um dies nun zu tun.

      Wenn Sie eine neue Quelle erstellen, wird ihr Name zur Liste Datenquellen hinzugefügt.

    3. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf Weiter.

    4. Folgen Sie den Anweisungen in allen treiberspezifischen Dialogfeldern. Geben Sie beispielsweise im Dialogfeld Datenquelle verbinden einen Benutzernamen und das Kennwort ein, und klicken Sie dann auf OK. Wenn Ihre Datenquelle nicht kennwortgeschützt ist, klicken Sie auf OK.

  3. Aktivieren Sie die Kontrollkästchen für die Informationen, die Sie extrahieren möchten, und klicken Sie dann auf Weiter.

    Einige Elemente sind möglicherweise abgeblendet, weil nicht alle Systeme alle Arten von Elementen unterstützen, die der Assistent extrahieren kann.

  4. Aktivieren Sie die Kontrollkästchen für die Tabellen (und Ansichten, falls vorhanden), die Sie extrahieren möchten, oder klicken Sie auf Alles auswählen um alle Tabellen (und Ansichten) zu extrahieren, und klicken Sie dann auf Weiter.

    Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen und in dieser Liste keine Elemente angezeigt werden, müssen Sie wahrscheinlich den Bereich der Zellen benennen, die die Spaltenüberschriften in Ihrer Tabelle enthalten.

  5. Wenn Sie in Schritt 5 das Kontrollkästchen Gespeicherte Prozeduren aktiviert haben, wählen Sie die zu extrahierenden Prozeduren aus, oder klicken Sie auf Alles auswählen, um alle Prozeduren zu extrahieren, und klicken Sie dann auf Weiter.

  6. Wählen Sie aus, ob die Elemente, für die ein Reverse Engineering durchgeführt wurde, automatisch zur aktuellen Seite hinzugefügt werden sollen.

    Sie können im Assistenten auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

  7. Überprüfen Sie die ausgewählten Optionen, um sicherzustellen, dass die gewünschten Informationen extrahiert werden, und klicken Sie dann auf Fertig stellen.

Wenn Sie den Standardtreiber "ODBC-Treiber Universal" verwenden, wird möglicherweise eine Fehlermeldung angezeigt, die darauf hinweist, dass die Informationen, für die ein Reverse Engineering durchgeführt wurde, unvollständig sein können. In den meisten Fällen ist das kein Problem. Klicken Sie einfach auf OK, und setzen Sie die Ausführung des Assistenten fort.

Der Assistent extrahiert die ausgewählten Informationen und zeigt im Ausgabefenster Hinweise zum Extrahierungsprozess an.

Seitenanfang

Inhalt dieses Artikels

Überprüfen der vom Assistenten für Reverse Engineering extrahierten Elemente

Auszuführende Schritte vor dem Starten des Assistenten

Durchführen von Reverse Engineering für eine vorhandene Datenbank

Sie können die Datenbankmodellierungsfeatures nicht finden?

Wahrscheinlich sind die Features, die Sie suchen, in Ihrer Version von Visio nicht enthalten. Wenn Sie herausfinden möchten, über welche Visio-Version Sie verfügen, klicken Sie im Menü Hilfe auf Info. Der Name der Version wird im Dialogfeld in der obersten Textzeile angezeigt.

  • In Microsoft Office Visio Standard ist die Vorlage "Datenbankmodelldiagramm" nicht enthalten.

  • Microsoft Office Visio Professional unterstützt die Reverse Engineering-Funktionen für die Vorlage "Datenbankmodelldiagramm" (also das Verwenden einer vorhandenen Datenbank zum Erstellen eines Modells in Visio). Das Forward Engineering (also das Verwenden eines Visio-Datenbankmodells zum Generieren von SQL-Code) wird jedoch nicht unterstützt.

  • Visio für Enterprise Architects umfasst die gesamte Sammlung von Datenbankmodellierungsfeatures, einschließlich Reverse Engineering und Forward Engineering. Visio für Enterprise Architects ist im MSDN Premium-Abonnement enthalten, das für Visual Studio Professional und für rollenbasierte Editionen von Visual Studio Team System verfügbar ist.

Überprüfen der vom Assistenten für Reverse Engineering extrahierten Elemente

Die Informationen zur Schemadefinition, die der Assistent extrahieren kann, sind von einer Kombination verschiedener Faktoren wie den Funktionen des Datenbank-Managementsystems (DBMS) und dem ODBC-Treiber abhängig. Im Assistenten werden alle Elemente angezeigt, die extrahiert werden können, und Sie können die gewünschten Elemente auswählen. So sind Sie beispielsweise nur an 5 von 10 Tabellen und 2 von 4 Ansichten interessiert.

Beim Ausführen des Assistenten können Sie auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

Sofern die Elemente im Ziel-DBMS verfügbar sind, können Sie die folgenden Elemente extrahieren:

  • Tabellen

  • Ansichten

  • Primärschlüssel

  • Fremdschlüssel

  • Indizes

  • Trigger (einschließlich Code)

  • Feldprüfungsbedingungen/Prüfklauseln (einschließlich Code)

  • Gespeicherte Prozeduren (einschließlich Code)

Seitenanfang

Auszuführende Schritte vor dem Starten des Assistenten

Wenn Sie ein Reverse Engineering für eine Excel-Arbeitsmappe durchführen, müssen Sie vor dem Starten des Assistenten die Arbeitsmappe öffnen und die Gruppe (oder den Bereich) von Zellen benennen, die die Spaltenüberschriften enthalten. Wenn Sie mehrere Arbeitsblätter verwenden möchten, benennen Sie einfach die Gruppe von Spaltenzellen in jedem Arbeitsblatt. Im Assistenten werden diese Bereiche wie Tabellen behandelt. Weitere Informationen dazu, wie Sie einen Zellbereich benennen, finden Sie in der Microsoft Office Excel-Hilfe unter dem Thema zum Definieren von benannten Zellbezügen oder Bereichen.

Legen Sie vor dem Ausführen des Assistenten für Reverse Engineering den Standardtreiber auf die Zieldatenbank fest, für die das Reverse Engineering durchgeführt werden soll, um optimale Ergebnisse zu erzielen. Dadurch wird sichergestellt, dass der Assistent die systemeigenen Datentypen richtig zuordnet und der gesamte vom Assistenten extrahierte Code im Codefenster ordnungsgemäß angezeigt wird.

  1. Zeigen Sie im Menü Datenbank auf Optionen, und klicken Sie dann auf Treiber.

  2. Wählen Sie auf der Registerkarte Treiber den von Visio bereitgestellten Treiber für Ihr DBMS aus. Wenn Sie beispielsweise eine Access-Datenbank entwerfen, wählen Sie "Microsoft Access" aus.

    Hinweis : Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

  3. Klicken Sie auf Einrichten.

  4. Aktivieren Sie auf der Registerkarte ODBC-Treiber das Kontrollkästchen für den vom Hersteller bereitgestellten Treiber für Ihr DBMS. Wenn Sie beispielsweise eine Access-Datenbank entwerfen, aktivieren Sie das Kontrollkästchen Microsoft Access-Treiber (*.mdb).

  5. Klicken Sie in jedem Dialogfeld auf OK.

Hinweis : Ein vom Hersteller bereitgestellter 32-Bit-ODBC-Treiber muss aus einem ODBC Data Access Pack einer höheren Version als 2.0 stammen und mit ODBC Level 1 (oder höher) kompatibel sein. Ein vom Hersteller bereitgestellter OLE DB-Anbieter muss mit der OLE DB-Version 1.0 oder einer höheren Spezifikation kompatibel sein.

Seitenanfang

Durchführen von Reverse Engineering für eine vorhandene Datenbank

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Software und Datenbank, und klicken Sie dann auf Datenbankmodelldiagramm.

  2. Klicken Sie im Menü Datenbank auf Reverse Engineering.

  3. Führen Sie auf dem ersten Bildschirm des Assistenten für Reverse Engineering die folgenden Aktionen aus:

    • Wählen Sie den Microsoft Office Visio-Datenbanktreiber für Ihr Datenbank-Managementsystem (DBMS) aus. Wenn Sie den Visio-Datenbanktreiber noch keiner bestimmten ODBC-Datenquelle zugeordnet haben, klicken Sie auf Einrichten, um dies nun zu tun.

      Hinweis : Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

    • Wählen Sie die Datenquelle der Datenbank aus, die Sie aktualisieren möchten. Wenn Sie noch keine Datenquelle für die vorhandene Datenbank erstellt haben, klicken Sie auf Neu, um dies nun zu tun.

      Wenn Sie eine neue Quelle erstellen, wird ihr Name zur Liste Datenquellen hinzugefügt.

    • Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf Weiter.

    • Folgen Sie den Anweisungen in allen treiberspezifischen Dialogfeldern. Geben Sie beispielsweise im Dialogfeld Datenquelle verbinden einen Benutzernamen und das Kennwort ein, und klicken Sie dann auf OK. Wenn Ihre Datenquelle nicht kennwortgeschützt ist, klicken Sie auf OK.

  4. Aktivieren Sie die Kontrollkästchen für die Informationen, die Sie extrahieren möchten, und klicken Sie dann auf Weiter.

    Hinweis : Einige Elemente sind möglicherweise abgeblendet, weil nicht alle Datenbank-Managementsysteme alle Arten von Elementen unterstützen, die der Assistent extrahieren kann.

  5. Aktivieren Sie die Kontrollkästchen für die Tabellen (und Ansichten, falls vorhanden), die Sie extrahieren möchten, oder klicken Sie auf Alles auswählen um alle Tabellen (und Ansichten) zu extrahieren, und klicken Sie dann auf Weiter.

    Hinweis : Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen und in dieser Liste keine Elemente angezeigt werden, müssen Sie wahrscheinlich den Bereich der Zellen benennen, die die Spaltenüberschriften in Ihrer Tabelle enthalten.

  6. Wenn Sie in Schritt 5 das Kontrollkästchen Gespeicherte Prozeduren aktiviert haben, wählen Sie die zu extrahierenden Prozeduren aus, oder klicken Sie auf Alles auswählen, um alle Prozeduren zu extrahieren, und klicken Sie dann auf Weiter.

  7. Wählen Sie aus, ob die Elemente, für die ein Reverse Engineering durchgeführt wurde, automatisch zur aktuellen Seite hinzugefügt werden sollen.

    Hinweis : Sie können im Assistenten auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

  8. Überprüfen Sie die ausgewählten Optionen, um sicherzustellen, dass die gewünschten Informationen extrahiert werden, und klicken Sie dann auf Fertig stellen.

Hinweis : Wenn Sie den Standardtreiber "ODBC-Treiber Universal" verwenden, wird möglicherweise eine Fehlermeldung angezeigt, die darauf hinweist, dass die Informationen, für die ein Reverse Engineering durchgeführt wurde, unvollständig sein können. In den meisten Fällen ist das kein Problem. Klicken Sie einfach auf OK, und setzen Sie die Ausführung des Assistenten fort.

Der Assistent extrahiert die ausgewählten Informationen und zeigt im Ausgabefenster Hinweise zum Extrahierungsprozess an.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×