Erstellen eines Datenbankmodells (auch als Entitätsbeziehungsdiagramm bezeichnet)

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Mit der Vorlage Datenbankmodelldiagramm können Sie ein neues Modell erstellen oder ein Modell anhand einer vorhandenen Datenbank mittels Reverse Engineering unter Verwendung des relationalen oder des objektrelationalen Modellierungskonzepts erstellen. Verwenden Sie die Schablone Entitätsbeziehung, um Datenbanken zu modellieren, die auf dem SQL92-Standard und früheren Standards basieren. Verwenden Sie die Schablone Objekt - relational, die zusätzliche Shapes für die Verwendung mit Typen enthält, um Datenbanken zu modellieren, die auf dem SQL99-Standard und späteren Standards basieren.

Mit der Vorlage Datenbankmodelldiagramm können Sie ein neues Modell erstellen oder ein Modell anhand einer vorhandenen Datenbank mittels Reverse Engineering unter Verwendung des relationalen oder des objektrelationalen Modellierungskonzepts erstellen. Verwenden Sie die Schablone Entitätsbeziehung, um Datenbanken zu modellieren, die auf dem SQL92-Standard und früheren Standards basieren. Verwenden Sie die Schablone Objekt - relational, die zusätzliche Shapes für die Verwendung mit Typen enthält, um Datenbanken zu modellieren, die auf dem SQL99-Standard und späteren Standards basieren.

Beispiel anzeigen

In diesem Artikel wird beschrieben, wie ein Datenbankmodell erstellt wird und was Sie nach dem Erstellen mit dem Modell tun können.

Werden Modell Features für die Datenbank kann nicht gefunden?

Das Datenbankmodellfeature steht nicht in allen Editionen von Microsoft Visio zur Verfügung. Wenn Sie die in den Verfahren in diesem Artikel beschriebenen Features nicht finden können, verwenden Sie wahrscheinlich eine Edition von Visio, die diese nicht enthält.

  • Microsoft Visio Standard enthält die Vorlage Datenbankmodelldiagramm nicht.

  • Die Editionen Microsoft Visio Professional und Microsoft Visio Premium unterstützen die Reverse Eingineering-Funktionen für die Vorlage Datenbankmodelldiagramm (d. h. das Erstellen eines Modells in Visio mithilfe einer vorhandenen Datenbank), das Forward Engineering (d. h. das Generieren von SQL-Code mithilfe eines Visio-Datenbankmodells) jedoch nicht.

  1. Zum Erstellen des Datenbankmodelldiagramms führen Sie einen der folgenden Schritte aus:

    Erstellen eines neuen Modelldiagramms Seitenvorlage

    Wenn Sie keine vorhandene Datenbank haben, die Sie als Ausgangspunkt verwenden möchten, können Sie mit einem leeren Datenbankmodell beginnen und eigene Tabellen und Beziehungen hinzufügen.

    1. Klicken Sie auf die Registerkarte Datei.

    2. Klicken Sie auf Neu, klicken Sie auf Software und Datenbank, und doppelklicken Sie auf Datenbankmodelldiagramm.

    3. Klicken Sie auf der Registerkarte Datenbank in der Gruppe Verwalten auf Anzeigeoptionen.

    4. Wählen Sie im Dialogfeld Datenbank-Dokumentoptionen den Zeichensatz aus, der verwendet werden soll, sowie weitere Tabellen- und Beziehungsoptionen, und klicken Sie auf OK.

    Verwenden einer vorhandenen Datenbank als Ausgangspunkt

    Wenn Sie eine Datenbank haben, die Sie modellieren möchten, sodass Sie sie besser verstehen, oder die Sie als Ausgangspunkt für ein neues Modell verwenden möchten, können Sie mithilfe des Assistenten für Reverse Engineering das Schema oder die Struktur der Datenbank extrahieren und ein neues Modell erstellen.

    Bevor Sie den Assistenten aufrufen:

    1. Wenn Sie bei einer Microsoft Excel-Arbeitsmappe ein Reverse Engineering durchführen, müssen Sie vor dem Aufrufen des Assistenten die Arbeitsmappe öffnen und die Gruppe (oder den Bereich) mit Zellen angeben, die die Spaltenüberschriften enthält. Wenn Sie mehrere Arbeitsblätter verwenden möchten, geben Sie einfach die Gruppe mit Spaltenzellen in den einzelnen Arbeitsblättern an. Diese Bereiche werden im Assistenten wie Tabellen behandelt. Weitere Informationen zum Angeben eines Zellbereichs finden Sie in der Excel-Hilfe im Thema zum Definieren von benannten Zellbezügen oder Zellbereichen.

    2. Um optimale Ergebnisse zu erzielen, sollten Sie den Standardtreiber auf die Zieldatenbank festlegen, für die ein Reverse Engineering durchgeführt werden soll, bevor Sie den Assistenten für Reverse Engineering ausführen. Durch diesen Schritt wird sichergestellt, dass der Assistent die systemeigenen Datentypen einwandfrei zuordnet und dass der gesamte, durch den Assistenten extrahierte Code im Fenster Code ordnungsgemäß angezeigt wird.

    3. Klicken Sie auf die Registerkarte Datei.

    4. Klicken Sie auf Neu, klicken Sie auf Software und Datenbank, und doppelklicken Sie auf Datenbankmodelldiagramm.

    5. Klicken Sie auf der Registerkarte Datenbank in der Gruppe Modell auf Reverse Engineering.

    6. Führen Sie auf der ersten Seite von Assistent für Reverse Engineering folgende Schritte aus:

      1. Wählen Sie den Datenbanktreiber für Ihr Datenbank-Managementsystem (DBMS) aus. Wenn der Visio-Datenbanktreiber noch nicht mit einer bestimmten ODBC-Datenquelle verknüpft wurde, klicken Sie auf Einrichten.

        Hinweis : Wenn Sie ein Reverse Engineering für ein Excel-Tabellenblatt ausführen, wählen Sie ODBC-Treiber Universal aus.

      2. Wählen Sie die Datenquelle der Datenbank aus, die aktualisiert werden soll. Wenn für die vorhandene Datenbank noch keine Datenquelle erstellt wurde, holen Sie dies jetzt nach, indem Sie auf Neu klicken.

        Wenn Sie eine neue Quelle erstellen, wird ihr Name zur Liste Datenquellen hinzugefügt.

      3. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf Weiter.

    7. Folgen Sie den Anweisungen in allen treiberspezifischen Dialogfeldern.

      Geben Sie beispielsweise im Dialogfeld Datenquelle verbinden den Benutzernamen und das Kennwort ein, und klicken Sie auf OK.

      Hinweis : Wenn Sie den ODBC-Treiber Universal verwenden, wird möglicherweise eine Fehlermeldung angezeigt, die angibt, dass die Informationen zum Reverse Engineering nicht vollständig sind. Dies stellt in der Regel kein Problem dar; klicken Sie einfach auf OK, um mit dem Assistenten fortzufahren.

    8. Aktivieren Sie die Kontrollkästchen für die Art von Informationen, die Sie extrahieren möchten, und klicken Sie auf Weiter.

      Hinweis : Einige Elemente sind möglicherweise nicht verfügbar (werden grau angezeigt), da nicht alle Datenbankverwaltungssysteme alle Arten von Elementen unterstützen, die der Assistent extrahieren kann.

    9. Aktivieren Sie die Kontrollkästchen für die Tabellen (und Ansichten, falls vorhanden), die extrahiert werden sollen, oder klicken Sie auf Alles auswählen, um alle zu extrahieren. Klicken Sie dann auf Weiter.

      Hinweis : Wenn Sie für ein Excel-Tabellenblatt ein Reverse Engineering durchführen und in dieser Liste nichts angezeigt wird, müssen Sie wahrscheinlich den Zellbereich angeben, der die Spaltenüberschriften im Tabellenblatt enthält.

    10. Wenn Sie das Kontrollkästchen Gespeicherte Prozeduren aktiviert haben, wählen Sie die Prozeduren aus, die extrahiert werden sollen, oder klicken Sie auf Alles auswählen, um alle zu extrahieren. Klicken Sie dann auf Weiter.

    11. Legen Sie fest, ob die Elemente, für die das Reverse Engineering durchgeführt wurde, automatisch zum aktuellen Zeichenblatt hinzugefügt werden sollen.

      Hinweis : Sie können festlegen, dass der Assistent die Zeichnung automatisch erstellt und die Elemente, für die ein Reverse Engineering ausgeführt wurde, im Fenster Tabellen und Ansichten anzeigt. Wenn Sie nicht möchten, dass die Zeichnung automatisch erstellt wird, können Sie die Elemente aus dem Fenster Tabellen und Ansichten auf das Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

    12. Überprüfen Sie Ihre Auswahl, um sicherzustellen, dass die gewünschten Informationen extrahiert werden, und klicken Sie auf Fertig stellen.

      Der Assistent extrahiert die ausgewählten Informationen und zeigt im Ausgabefenster Hinweise zur Extraktion an.

    Importieren Sie und verfeinern Sie ein vorhandenes Modell

    Wenn Sie über ein vorhandenes VisioModeler- oder PLATINUM ERwin-Modell verfügen, können Sie dieses möglicherweise importieren, um ein Visio-Datenbankmodelldiagramm zu erstellen. Dies ist jedoch nur bei Wörterbuchmodelldateien (IMD) möglich, die mit VisioModeler 2.0 oder höher erstellt wurden, sowie mit ERX-Dateien, die mit PLATINUM ERwin 2.6, 3.0 und 3.52 erstellt wurden.

    1. Klicken Sie auf die Registerkarte Datei.

    2. Klicken Sie auf Neu, klicken Sie auf Software und Datenbank, und doppelklicken Sie auf Datenbankmodelldiagramm.

    3. Klicken Sie auf der Registerkarte Datenbank in der Gruppe Modell auf Importieren, und klicken Sie dann auf den Modelltyp.

    4. Geben Sie den Pfad- und Dateinamen für das zu importierende Modell ein, oder klicken Sie auf die Schaltfläche Durchsuchen, um die Modelldatei zu suchen, und klicken Sie dann auf Öffnen.

    5. Klicken Sie im Dialogfeld Importieren auf OK.

      Visio importiert die Datei und zeigt dabei den Fortschritt im Fenster Ausgabe an. Die importierten Tabellen werden im Fenster Tabellen und Ansichten angezeigt.

    6. Wählen Sie im Fenster Tabellen und Ansichten die zu modellierenden Tabellen aus, und ziehen Sie sie auf das Zeichenblatt.

  2. Nach dem Erstellen eines Datenbankmodelldiagramms müssen Sie das Diagramm verfeinern. Sie können Tabellen und Ansichten hinzufügen und anpassen, Beziehungen erstellen und Spalten und Datentypen anpassen.

    Tabellen

    Verwenden Sie das Entität-Shape, um im Diagramm eine Tabelle zu erstellen.

    1. Ziehen Sie entweder aus der Schablone Entitätsbeziehung oder aus der Schablone Objekt - relational ein Entität-Shape auf die Zeichnung.

    2. Doppelklicken Sie auf das Shape, um das Fenster Datenbankeigenschaften zu öffnen.

    3. Klicken Sie unter Kategorien auf Definition, und geben Sie einen Namen für die Tabelle ein.

    4. Klicken Sie unter Kategorien auf Spalten, geben Sie einen Namen ein, und wählen Sie einen Datentyp aus.

    5. Aktivieren Sie das Kontrollkästchen Erforderlich für Spalten, die keine Nullwerte enthalten dürfen.

    6. Aktivieren Sie das Kontrollkästchen PK (Primärschlüssel) für Spalten, die die einzelnen Zeilen in der Datenbanktabelle eindeutig identifizieren.

    7. Klicken Sie unter Kategorien auf Indizes, Trigger, Prüfvorgang oder Erweitert, um diese optionalen Elemente zu erstellen.

    Spalten

    Verwenden Sie das Fenster Datenbankeigenschaften, um Eigenschaften für Spalten, wie etwa Datentypen und Primärschlüssel, hinzuzufügen oder zu ändern.

    1. Doppelklicken Sie auf die Tabelle im Diagramm.

    2. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Spalten.

    3. Klicken Sie in die erste leere Physischer Name-Zelle, und geben Sie einen Namen ein.

    4. Um den Datentyp für eine Spalte zu ändern, klicken Sie auf das Feld Datentyp der Spalte, und wählen Sie einen Datentyp aus der Liste aus, oder geben Sie ihn in die Liste ein. Sie können beispielsweise decimal(8;2) oder char(30) eingeben.

    5. Aktivieren Sie das Kontrollkästchen Erforderlich, um zu verhindern, dass Nullwerte eingegeben werden.

    6. Um die Spalte als Primärschlüssel zu definieren, aktivieren Sie das Kontrollkästchen PK.

    7. Um außer den Spalteneigenschaften, die angezeigt werden, wenn Sie auf die Kategorie Spalten klicken, weitere Spalteneigenschaften anzuzeigen, markieren Sie die Spalte, und klicken Sie dann auf Bearbeiten.

    Beziehungen

    Beziehungen verwenden Primär- und Fremdschlüssel, damit Datenbanken eine Zeile in einer Tabelle an eine Zeile in einer verwandten Tabelle anpassen können. Diese Beziehungen können im Diagramm angezeigt werden. Darüber hinaus können Sie die Kardinalität (z. B. 1:n) festlegen und mithilfe der Krähenfüße-Notation, der relationalen Notation oder der IDEF1X-Notation anzeigen. n:n-Beziehungen können in der Vorlage Datenbankmodelldiagramm nicht mit diesen Notationen angezeigt werden.

    1. Erstellen einer Beziehung zwischen Tabellen:

      1. Stellen Sie sicher, dass beide Tabellen im Diagramm angezeigt werden. Wenn Sie das Modell aus einer vorhandenen Datenbank mittels Reverse Engineering erstellt haben, müssen Sie möglicherweise eine oder beide Tabellen aus dem Fenster Tabellen und Ansichten auf das Zeichenblatt ziehen.

      2. Doppelklicken Sie auf die Tabelle, die Sie als Primärschlüssel in der Beziehung festlegen möchten.

      3. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Spalten.

      4. Klicken Sie im Gitter auf die Spalte, die Sie zur eindeutigen Identifizierung der einzelnen Zeilen in der Tabelle verwenden möchten, und aktivieren Sie das Kontrollkästchen PK, um diese Spalte als Primärschlüssel festzulegen.

      5. Ziehen Sie aus der Schablone Objekt - relational oder Entitätsbeziehung ein Beziehung-Shape, und legen Sie es an einer freien Stelle auf dem Blatt ab.

      6. Verbinden Sie das obere Ende mit der Tabelle mit der übergeordneten Tabelle.

      7. Verbinden Sie das andere Ende mit der untergeordneten Tabelle.

        Wenn die zweite Tabelle nicht bereits eine Spalte mit demselben Namen wie der Primärschlüssel enthält, fügt der Modellierer der zweiten Tabelle eine als Fremdschlüssel hinzu.

        Hinweis : Wenn die Beziehungslinien nicht mehr angezeigt werden, klicken Sie auf der Registerkarte Datenbank in der Gruppe Verwalten auf Anzeigeoptionen. Aktivieren Sie auf der Registerkarte Beziehung unter Anzeigen das Kontrollkästchen Beziehungen.

    2. Festlegen der Kardinalität der Beziehung:

      1. Doppelklicken Sie auf die Beziehung.

      2. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Sonstiges.

      3. Wählen Sie unter Kardinalität die für die Beziehung am besten geeignete Kardinalität. Bei 1:n-Beziehungen eignet sich entweder Null oder mehr oder Eins oder mehr am besten. Bei 1:1-Beziehungen eignet sich Null oder eins oder Genau eins am besten.

  3. Um das Diagramm weiter zu verfeinern (z. B. Indizes, Feldprüfungsbedingungen und Trigger erstellen) können Sie folgende Aktionen ausführen:

    Erstellen von Indizes

    Mit Indizes wird die Leistung oder Geschwindigkeit der Datenbank beim Ausführen einer Abfrage verbessert.

    1. Öffnen Sie das Datenbankmodelldiagramm.

    2. Doppelklicken Sie auf die Tabelle, der ein Index hinzugefügt werden soll. Klicken Sie im Fenster Datenbankeigenschaften in der Liste Kategorien auf Indizes.

    3. Klicken Sie auf Neu.

    4. Geben Sie im Dialogfeld Index erstellen einen Namen für den Index ein, und klicken Sie auf OK.

    5. Wählen Sie in der Liste Indextyp eine Option aus, um einen eindeutigen oder nicht eindeutigen Index zu erstellen.

    6. Wählen Sie in der Liste Verfügbare Spalten die Namen derjenigen Spalten aus, die in diesem Index enthalten sein sollen, und klicken Sie dann auf Hinzufügen >.

    7. Aktivieren Sie in der Liste Indizierte Spalten das Kontrollkästchen Auf, um einen Index in aufsteigender Sortierreihenfolge zu erstellen, oder deaktivieren Sie das Kontrollkästchen, um einen Index in absteigender Sortierreihenfolge zu erstellen.

      Das Datenbankmodelldiagramm wird damit aktualisiert.

    Erstellen von Ansichten

    Sie können sich eine Ansicht als gespeicherte Abfrage vorstellen. Ansichten sind besonders praktisch, wenn Sie wiederholt auf dieselben Informationen aus mehreren Tabellen zugreifen müssen, oder wenn Sie die Daten für Benutzer anzeigen möchten, ohne dass diese die eigentlichen Tabellen ändern können.

    Ziehen Sie aus der Schablone Entitätsbeziehung oder aus der Schablone Objekt - relational ein Ansicht-Shape auf das Zeichenblatt.

    Legen Sie erweiterte Eigenschaften für Tabellen und Ansichten

    Je nach Datenbank-Managementsystem (DBMS) können Sie möglicherweise erweiterte Eigenschaften für Tabellen oder Ansichten festlegen, um deren Speicherort zu bestimmen.

    Doppelklicken Sie auf die Tabelle oder Ansicht, deren erweiterte Eigenschaften festgelegt werden sollen, und klicken Sie im Fenster Datenbankeigenschaften in der Liste Kategorien auf Erweitert.

    Kontrollkästchen Klauseln erstellen

    Verwenden Sie Feldprüfungsbedingungen, um sicherzustellen, dass sich die Daten, die in eine Spalte eingegeben werden, in einem bestimmten Wertebereich befinden. Sie können beispielsweise eine Feldprüfungsbedingung erstellen, für die die Daten in einer Spalte mit der Bezeichnung "Alter" über 65 liegen müssen.

    1. Doppelklicken Sie auf die Tabelle, um das Fenster Datenbankeigenschaften zu öffnen.

    2. Klicken Sie unter Kategorien auf Spalten, und klicken Sie dann auf die Spalte, die einer Feldprüfungsbedingung hinzugefügt werden soll.

    3. Klicken Sie auf Bearbeiten.

    4. Geben Sie auf der Registerkarte Prüfvorgang im Dialogfeld Spalteneigenschaften die gewünschten Einschränkungen ein.

      Die Feldprüfungsbedingung wird dem Fenster Code unter Lokaler Code hinzugefügt.

    Erstellen von gespeicherten Prozeduren und benutzerdefinierten Funktionen

    Erstellen Sie mithilfe von gespeicherten Prozeduren und benutzerdefinierten Funktionen Codepakete, die zum wiederholten Ausführen derselben Aktionen wiederverwendet werden können. Der Hauptunterschied zwischen gespeicherten Prozeduren und benutzerdefinierten Funktionen besteht darin, dass benutzerdefinierte Funktionen einen Wert zurückgeben, während gespeicherte Prozeduren Code ausführen, ohne einen Wert zurückzugeben.

    1. Aktivieren Sie auf der Registerkarte Datenbank in der Gruppe Einblenden/Ausblenden das Kontrollkästchen Code, um das Fenster Code zu öffnen.

    2. Klicken Sie auf Globaler Code, und klicken Sie dann auf Neu.

    3. Klicken Sie auf der Registerkarte Eigenschaften im Dialogfeld Code-Editor auf den Code, der erstellt werden soll, und geben Sie einen Namen für den Code ein.

    4. Geben Sie auf der Registerkarte Rumpf den Code ein, und klicken Sie dann auf OK.

    Erstellen von Triggern

    Trigger lösen die Ausführung von im Trigger angegebenem SQL-Code aus, wenn ein bestimmtes Ereignis in der Datenbank auftritt.

    1. Doppelklicken Sie auf die Tabelle, um das Fenster Datenbankeigenschaften zu öffnen.

    2. Klicken Sie unter Kategorien auf Trigger, und klicken Sie dann auf Hinzufügen.

    3. Geben Sie auf der Registerkarte Eigenschaften einen Namen für den Trigger ein.

    4. Geben Sie auf der Registerkarte Rumpf den Code ein, und klicken Sie dann auf OK.

      Der Trigger wird dem Fenster Code unter Lokaler Code hinzugefügt.

Beispiel anzeigen

In diesem Artikel wird beschrieben, wie ein Datenbankmodell erstellt wird, und was Sie nach dem Erstellen mit dem Modell tun können. Um rasch zu beginnen, zeigen Sie im Menü Datei auf Neu, dann auf Software und Datenbank, und klicken Sie dann auf Datenbankmodelldiagramm.

Werden Modell Features für die Datenbank kann nicht gefunden?

Sehr wahrscheinlich enthält Ihre Edition von Microsoft Office Visio die Features, die Sie suchen, nicht. Klicken Sie in dem Menü Hilfe auf Info, um zu ermitteln, welche Edition von Visio Sie verwenden. Der Name der Edition wird im Dialogfeld in der ersten Textzeile angezeigt.

  • Microsoft Office Visio Standard enthält die Vorlage Datenbankmodelldiagramm nicht.

  • Microsoft Office Visio Professional unterstützt die Reverse Eingineering-Funktionen für die Vorlage Datenbankmodelldiagramm (d. h. das Erstellen eines Modells in Visio mithilfe einer vorhandenen Datenbank), das Forward Engineering (d. h. das Generieren von SQL-Code mithilfe eines Visio-Datenbankmodells) jedoch nicht.

  • Sie finden die gesamte Palette an Funktionen für die Datenbankmodellierung, einschließlich der Reverse Engineering- und der Forward Engineering-Funktionen, in Visio für Enterprise Architects. Visio für Enterprise Architects ist in der MSDN Premium Subscription inbegriffen, die mit Visual Studio Professional und rollenabhängigen Editionen von Visual Studio Team System erhältlich ist.

  1. Zum Erstellen des Datenbankmodelldiagramms führen Sie einen der folgenden Schritte aus:

    Erstellen eines neuen Modelldiagramms Seitenvorlage

    Wenn Sie keine vorhandene Datenbank haben, die Sie als Ausgangspunkt verwenden möchten, können Sie mit einem leeren Datenbankmodell beginnen und eigene Tabellen und Beziehungen hinzufügen.

    1. Zeigen Sie im Menü Datei auf Neu, dann auf Software und Datenbank, und klicken Sie auf Datenbankmodelldiagramm.

    2. Zeigen Sie im Menü Datenbank auf Optionen, und klicken Sie auf Dokument.

    3. Wählen Sie im Dialogfeld Datenbank-Dokumentoptionen den Zeichensatz aus, der verwendet werden soll, sowie weitere Tabellen- und Beziehungsoptionen, und klicken Sie auf OK.

    Eine vorhandene Datenbank als Ausgangspunkt verwenden

    Wenn Sie eine Datenbank haben, die Sie modellieren möchten, sodass Sie sie besser verstehen, oder die Sie als Ausgangspunkt für ein neues Modell verwenden möchten, können Sie mithilfe des Assistenten für Reverse Engineering das Schema oder die Struktur der Datenbank extrahieren und ein neues Modell erstellen.

    Hinweis : Bevor Sie den Assistenten aufrufen:

    1. Wenn Sie bei einer Microsoft Office Excel-Arbeitsmappe ein Reverse Engineering durchführen, müssen Sie vor dem Aufrufen des Assistenten die Arbeitsmappe öffnen und die Gruppe (oder den Bereich) mit Zellen angeben, die die Spaltenüberschriften enthält. Wenn Sie mehrere Tabellenblätter verwenden möchten, geben Sie einfach die Gruppe mit Spaltenzellen in den einzelnen Tabellenblättern an. Diese Bereiche werden im Assistenten wie Tabellen behandelt. Weitere Informationen zum Angeben eines Zellbereichs finden Sie in der Microsoft Office Excel-Hilfe im Thema zum Definieren von benannten Zellverweisen oder Zellbereichen.

    2. Um optimale Ergebnisse zu erzielen, sollten Sie den Standardtreiber auf die Zieldatenbank festlegen, für die ein Reverse Engineering durchgeführt werden soll, bevor Sie den Assistenten für Reverse Engineering ausführen. Durch diesen Schritt wird sichergestellt, dass der Assistent die systemeigenen Datentypen einwandfrei zuordnet und dass der gesamte, durch den Assistenten extrahierte Code im Fenster Code ordnungsgemäß angezeigt wird.

    3. Zeigen Sie im Menü Datei auf Neu, dann auf Software und Datenbank, und klicken Sie auf Datenbankmodelldiagramm.

    4. Klicken Sie im Menü Datenbank auf Reverse Engineering.

    5. Führen Sie auf der ersten Seite von Assistent für Reverse Engineering folgende Schritte aus:

      1. Wählen Sie den Microsoft Office Visio-Datenbanktreiber für Ihr Datenbank-Managementsystem (DBMS) aus. Wenn der Visio-Datenbanktreiber noch nicht mit einer bestimmten ODBC-Datenquelle verknüpft wurde, klicken Sie auf Einrichten.

        Hinweis : Wenn Sie ein Reverse Engineering für ein Excel-Tabellenblatt ausführen, wählen Sie ODBC-Treiber Universal aus.

      2. Wählen Sie die Datenquelle der Datenbank aus, die aktualisiert werden soll. Wenn für die vorhandene Datenbank noch keine Datenquelle erstellt wurde, holen Sie dies jetzt nach, indem Sie auf Neu klicken.

        Wenn Sie eine neue Quelle erstellen, wird ihr Name zur Liste Datenquellen hinzugefügt.

      3. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf Weiter.

    6. Folgen Sie den Anweisungen in allen treiberspezifischen Dialogfeldern.

      Geben Sie beispielsweise im Dialogfeld Datenquelle verbinden einen Benutzernamen und ein Kennwort ein, und klicken Sie auf OK. Wenn die Datenquelle nicht kennwortgeschützt ist, klicken Sie einfach auf OK.

      Hinweis : Wenn Sie den ODBC-Treiber Universal verwenden, wird möglicherweise eine Fehlermeldung angezeigt, die angibt, dass die Informationen zum Reverse Engineering nicht vollständig sind. Dies stellt in der Regel kein Problem dar; klicken Sie einfach auf OK, um mit dem Assistenten fortzufahren.

    7. Aktivieren Sie die Kontrollkästchen für die Art von Informationen, die Sie extrahieren möchten, und klicken Sie auf Weiter.

      Hinweis : Einige Elemente sind möglicherweise nicht verfügbar (werden grau angezeigt), da nicht alle Datenbankverwaltungssysteme alle Arten von Elementen unterstützen, die der Assistent extrahieren kann.

    8. Aktivieren Sie die Kontrollkästchen für die Tabellen (und Ansichten, falls vorhanden), die extrahiert werden sollen, oder klicken Sie auf Alles auswählen, um alle zu extrahieren. Klicken Sie dann auf Weiter.

      Hinweis : Wenn Sie für ein Excel-Tabellenblatt ein Reverse Engineering durchführen und in dieser Liste nichts angezeigt wird, müssen Sie wahrscheinlich den Zellbereich angeben, der die Spaltenüberschriften im Tabellenblatt enthält.

    9. Wenn Sie das Kontrollkästchen Gespeicherte Prozeduren in Schritt 5 aktiviert haben, wählen Sie die Prozeduren aus, die extrahiert werden sollen, oder klicken Sie auf Alles auswählen, um alle zu extrahieren. Klicken Sie dann auf Weiter.

    10. Legen Sie fest, ob die Elemente, für die das Reverse Engineering durchgeführt wurde, automatisch zum aktuellen Zeichenblatt hinzugefügt werden sollen.

      Hinweis : Sie können festlegen, dass der Assistent die Zeichnung automatisch erstellt und die Elemente, für die ein Reverse Engineering ausgeführt wurde, im Fenster Tabellen und Ansichten anzeigt. Wenn Sie nicht möchten, dass die Zeichnung automatisch erstellt wird, können Sie die Elemente aus dem Fenster Tabellen und Ansichten auf das Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

    11. Überprüfen Sie Ihre Auswahl, um sicherzustellen, dass die gewünschten Informationen extrahiert werden, und klicken Sie auf Fertig stellen.

      Der Assistent extrahiert die ausgewählten Informationen und zeigt im Ausgabefenster Hinweise zur Extraktion an.

    Importieren Sie und verfeinern Sie ein vorhandenes Modell

    Wenn Sie über ein vorhandenes VisioModeler- oder PLATINUM ERwin-Modell verfügen, können Sie dieses möglicherweise importieren, um ein Visio-Datenbankmodelldiagramm zu erstellen. Dies ist jedoch nur bei Wörterbuchmodelldateien (IMD) möglich, die mit VisioModeler 2.0 oder höher erstellt wurden, sowie mit ERX-Dateien, die mit PLATINUM ERwin 2.6, 3.0 und 3.52 erstellt wurden.

    1. Zeigen Sie im Menü Datei auf Neu, dann auf Software und Datenbank, und klicken Sie auf Datenbankmodelldiagramm.

    2. Zeigen Sie im Menü Datenbank auf Importieren, und klicken Sie dann auf <Modelltyp> importieren.

    3. Geben Sie den Pfad- und Dateinamen für das zu importierende Modell ein, oder klicken Sie auf die Schaltfläche Durchsuchen, um die Modelldatei zu suchen, und klicken Sie dann auf Öffnen.

    4. Klicken Sie im Dialogfeld Importieren auf OK.

      Visio importiert die Datei und zeigt dabei den Fortschritt im Fenster Ausgabe an. Die importierten Tabellen werden im Fenster Tabellen und Ansichten angezeigt.

    5. Wählen Sie im Fenster Tabellen und Ansichten die zu modellierenden Tabellen aus, und ziehen Sie sie auf das Zeichenblatt.

  2. Nach dem Erstellen eines Datenbankmodelldiagramms müssen Sie das Diagramm verfeinern. Sie können Tabellen und Ansichten hinzufügen und anpassen, Beziehungen erstellen und Spalten und Datentypen anpassen.

    Tabellen

    Verwenden Sie das Entität-Shape, um im Diagramm eine Tabelle zu erstellen.

    1. Ziehen Sie entweder aus der Schablone Entitätsbeziehung oder aus der Schablone Objekt - relational ein Entität-Shape auf die Zeichnung.

    2. Doppelklicken Sie auf das Shape, um das Fenster Datenbankeigenschaften zu öffnen.

    3. Klicken Sie unter Kategorien auf Definition, und geben Sie einen Namen für die Tabelle ein.

    4. Klicken Sie unter Kategorien auf Spalten, geben Sie einen Namen ein, und wählen Sie einen Datentyp aus.

    5. Aktivieren Sie das Kontrollkästchen Erforderlich für Spalten, die keine Nullwerte enthalten dürfen.

    6. Aktivieren Sie das Kontrollkästchen PK (Primärschlüssel) für Spalten, die die einzelnen Zeilen in der Datenbanktabelle eindeutig identifizieren.

    7. Klicken Sie unter Kategorien auf Indizes, Trigger, Prüfvorgang oder Erweitert, um diese optionalen Elemente zu erstellen.

    Spalten

    Verwenden Sie das Fenster Datenbankeigenschaften, um Eigenschaften für Spalten, wie etwa Datentypen und Primärschlüssel, hinzuzufügen oder zu ändern.

    1. Doppelklicken Sie auf die Tabelle im Diagramm.

    2. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Spalten.

    3. Klicken Sie in die erste leere Physischer Name-Zelle, und geben Sie einen Namen ein.

    4. Um den Datentyp für eine Spalte zu ändern, klicken Sie auf das Feld Datentyp der Spalte, und wählen Sie einen Datentyp aus der Liste aus, oder geben Sie ihn in die Liste ein. Sie können beispielsweise decimal(8;2) oder char(30) eingeben.

    5. Aktivieren Sie das Kontrollkästchen Erforderlich, um zu verhindern, dass Nullwerte eingegeben werden.

    6. Um die Spalte als Primärschlüssel zu definieren, aktivieren Sie das Kontrollkästchen PK.

    7. Um außer den Spalteneigenschaften, die angezeigt werden, wenn Sie auf die Kategorie Spalten klicken, weitere Spalteneigenschaften anzuzeigen, markieren Sie die Spalte, und klicken Sie dann auf Bearbeiten.

    Beziehungen

    Beziehungen verwenden Primär- und Fremdschlüssel, damit Datenbanken eine Zeile in einer Tabelle an eine Zeile in einer verwandten Tabelle anpassen können. Diese Beziehungen können im Diagramm angezeigt werden. Darüber hinaus können Sie die Kardinalität (z. B. 1:n) festlegen und mithilfe der Krähenfüße-Notation, der relationalen Notation oder der IDEF1X-Notation anzeigen. n:n-Beziehungen können in der Vorlage Datenbankmodelldiagramm nicht mit diesen Notationen angezeigt werden.

    1. Erstellen einer Beziehung zwischen Tabellen:

      1. Stellen Sie sicher, dass beide Tabellen im Diagramm angezeigt werden. Wenn Sie das Modell aus einer vorhandenen Datenbank mittels Reverse Engineering erstellt haben, müssen Sie möglicherweise eine oder beide Tabellen aus dem Fenster Tabellen und Ansichten auf das Zeichenblatt ziehen.

      2. Doppelklicken Sie auf die Tabelle, die Sie als Primärschlüssel in der Beziehung festlegen möchten.

      3. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Spalten.

      4. Klicken Sie im Gitter auf die Spalte, die Sie zur eindeutigen Identifizierung der einzelnen Zeilen in der Tabelle verwenden möchten, und aktivieren Sie das Kontrollkästchen PK, um diese Spalte als Primärschlüssel festzulegen.

      5. Ziehen Sie aus der Schablone Objekt - relational oder Entitätsbeziehung ein Beziehung-Shape, und legen Sie es an einer freien Stelle auf dem Blatt ab.

      6. Verbinden Sie das obere Ende mit der Tabelle mit der übergeordneten Tabelle.

      7. Verbinden Sie das andere Ende mit der untergeordneten Tabelle.

        Wenn die zweite Tabelle nicht bereits eine Spalte mit demselben Namen wie der Primärschlüssel enthält, fügt der Modellierer der zweiten Tabelle eine als Fremdschlüssel hinzu.

        Hinweis : Wenn die Beziehungslinien nicht mehr angezeigt werden, zeigen Sie im Menü Datenbank auf Optionen, und klicken Sie dann auf Dokument. Aktivieren Sie auf der Registerkarte Beziehung unter Anzeigen das Kontrollkästchen Beziehungen.

    2. Festlegen der Kardinalität der Beziehung:

      1. Doppelklicken Sie auf die Beziehung.

      2. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Sonstiges.

      3. Wählen Sie unter Kardinalität die für die Beziehung am besten geeignete Kardinalität. Bei 1:n-Beziehungen eignet sich entweder Null oder mehr oder Eins oder mehr am besten. Bei 1:1-Beziehungen eignet sich Null oder eins oder Genau eins am besten.

  3. Um das Diagramm weiter zu verfeinern (z. B. Indizes, Feldprüfungsbedingungen und Trigger erstellen) können Sie folgende Aktionen ausführen:

    Erstellen von Indizes

    Mit Indizes wird die Leistung oder Geschwindigkeit der Datenbank beim Ausführen einer Abfrage verbessert.

    1. Öffnen Sie das Datenbankmodelldiagramm.

    2. Doppelklicken Sie auf die Tabelle, der ein Index hinzugefügt werden soll. Klicken Sie im Fenster Datenbankeigenschaften in der Liste Kategorien auf Indizes.

    3. Klicken Sie auf Neu.

    4. Geben Sie im Dialogfeld Index erstellen einen Namen für den Index ein, und klicken Sie auf OK.

    5. Wählen Sie in der Liste Indextyp eine Option aus, um einen eindeutigen oder nicht eindeutigen Index zu erstellen.

    6. Wählen Sie in der Liste Verfügbare Spalten die Namen derjenigen Spalten aus, die in diesem Index enthalten sein sollen, und klicken Sie dann auf Hinzufügen >.

    7. Aktivieren Sie in der Liste Indizierte Spalten das Kontrollkästchen Auf, um einen Index in aufsteigender Sortierreihenfolge zu erstellen, oder deaktivieren Sie das Kontrollkästchen, um einen Index in absteigender Sortierreihenfolge zu erstellen.

      Das Datenbankmodelldiagramm wird damit aktualisiert.

    Erstellen von Ansichten

    Sie können sich eine Ansicht als gespeicherte Abfrage vorstellen. Ansichten sind besonders praktisch, wenn Sie wiederholt auf dieselben Informationen aus mehreren Tabellen zugreifen müssen, oder wenn Sie die Daten für Benutzer anzeigen möchten, ohne dass diese die eigentlichen Tabellen ändern können.

    Ziehen Sie aus der Schablone Entitätsbeziehung oder aus der Schablone Objekt - relational ein Ansicht-Shape auf das Zeichenblatt.

    Legen Sie erweiterte Eigenschaften für Tabellen und Ansichten

    Je nach Datenbank-Managementsystem (DBMS) können Sie möglicherweise erweiterte Eigenschaften für Tabellen oder Ansichten festlegen, um deren Speicherort zu bestimmen.

    Doppelklicken Sie auf die Tabelle oder Ansicht, deren erweiterte Eigenschaften festgelegt werden sollen, und klicken Sie im Fenster Datenbankeigenschaften in der Liste Kategorien auf Erweitert.

    Kontrollkästchen Klauseln erstellen

    Verwenden Sie Feldprüfungsbedingungen, um sicherzustellen, dass sich die Daten, die in eine Spalte eingegeben werden, in einem bestimmten Wertebereich befinden. Sie können beispielsweise eine Feldprüfungsbedingung erstellen, für die die Daten in einer Spalte mit der Bezeichnung "Alter" über 65 liegen müssen.

    1. Doppelklicken Sie auf die Tabelle, um das Fenster Datenbankeigenschaften zu öffnen.

    2. Klicken Sie unter Kategorien auf Spalten, und klicken Sie dann auf die Spalte, die einer Feldprüfungsbedingung hinzugefügt werden soll.

    3. Klicken Sie auf Bearbeiten.

    4. Geben Sie auf der Registerkarte Überprüfen Sie im Dialogfeld Eigenschaften der Spalte die Einschränkungen, die gewünschte. Weitere Informationen zu den Optionen finden Sie unter Dialogfeld "Spalte" und "Feldeigenschaften" (Registerkarte "Überprüfen").

      Die Feldprüfungsbedingungen werden dem Fenster Code unter Lokaler Code hinzugefügt.

    Erstellen von gespeicherten Prozeduren und benutzerdefinierten Funktionen

    Erstellen Sie mithilfe von gespeicherten Prozeduren und benutzerdefinierten Funktionen Codepakete, die zum wiederholten Ausführen derselben Aktionen wiederverwendet werden können. Der Hauptunterschied zwischen gespeicherten Prozeduren und benutzerdefinierten Funktionen besteht darin, dass benutzerdefinierte Funktionen einen Wert zurückgeben, während gespeicherte Prozeduren Code ausführen, ohne einen Wert zurückzugeben.

    1. Zeigen Sie im Menü Datenbank auf Ansicht, und klicken Sie auf Code, um das Fenster Code zu öffnen.

    2. Klicken Sie auf Globaler Code, und klicken Sie dann auf Neu.

    3. Klicken Sie auf der Registerkarte Eigenschaften im Dialogfeld Code-Editor auf den Code, der erstellt werden soll, und geben Sie einen Namen für den Code ein.

    4. Geben Sie auf der Registerkarte Rumpf den Code ein, und klicken Sie dann auf OK.

    Erstellen von Triggern

    Trigger lösen die Ausführung von im Trigger angegebenem SQL-Code aus, wenn ein bestimmtes Ereignis in der Datenbank auftritt.

    1. Doppelklicken Sie auf die Tabelle, um das Fenster Datenbankeigenschaften zu öffnen.

    2. Klicken Sie unter Kategorien auf Trigger, und klicken Sie dann auf Hinzufügen.

    3. Geben Sie auf der Registerkarte Eigenschaften einen Namen für den Trigger ein.

    4. Geben Sie auf der Registerkarte Rumpf den Code ein, und klicken Sie dann auf OK.

      Der Trigger wird dem Fenster Code unter Lokaler Code hinzugefügt.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×