Erstellen eines Boxplotdiagramms

Wenn Sie eine statistische Analyse machen, möchten Sie möglicherweise ein standardmäßiges Boxplotdiagramm erstellen, um die Verteilung eines Datensets anzuzeigen. In einem Boxplot werden numerische Daten in Quartile unterteilt, und zwischen den ersten und dritten Quartilen wird ein Feld gezeichnet, wobei eine zusätzliche Linie entlang des zweiten Quartils gezeichnet wird, um den Median zu kennzeichnen. Bei einigen Boxplotdiagrammen werden die Minimal- und Maximalwerte außerhalb der ersten und dritten Quartile durch Linien gekennzeichnet, die häufig als Whiskers bezeichnet werden.

Die verschiedenen Teile eines Boxplots

In Excel 2013 gibt es zwar keine Diagrammvorlage für Boxplots, Sie können Boxplots jedoch mit den folgenden Schritten erstellen:

  1. Berechnen Sie die Quartilwerte aus dem Quelldatenset.

  2. Berechnen Sie die Unterschiede zwischen den Quartilen.

  3. Erstellen Sie aus dem Quartilbereichen ein gestapeltes Säulendiagramm.

  4. Konvertieren Sie das gestapelte Säulendiagramm in ein Diagramm vom Typ Boxplot.

In unserem Beispiel enthält das Quelldatenset drei Spalten. Jede Spalte enthält 30 Einträge aus den folgenden Bereichen:

  • Spalte 1 (2013): 100-200

  • Spalte 2 (2014): 120-200

  • Spalte 3 (2015): 100-180

Tabelle "Quelldaten"

Inhalt dieses Artikels

Schritt 1: Berechnen der Quartilwerte

Im ersten Schritt müssen Sie die Minimal-, Maximal- und Medianwerte sowie die ersten und dritten Quartile aus dem Datenset berechnen.

  1. Erstellen Sie hierzu eine zweite Tabelle, und fügen Sie hierin die folgenden Formeln ein:

    Wert

    Formel

    Minimalwert

    MIN(Zellbereich)

    Erstes Quartil

    QUARTILE.INKL(Zellbereich;1)

    Medianwert

    QUARTILE.INKL(Zellbereich;2)

    Drittes Quartil

    QUARTILE.INKL(Zellbereich;3)

    Maximalwert

    MAX(Zellbereich)

  2. Als Ergebnis sollten Sie eine Tabelle mit den korrekten Werten enthalten. Die folgenden Quartile wurden auf Basis des Beispieldatensets berechnet:

    Die endgültige Tabelle und Werte

Seitenanfang

Schritt 2: Berechnen der Unterschiede zwischen den Quartilen

Im nächsten Schritt berechnen Sie die Unterschiede zwischen jeder Phase. Im Wesentlichen müssen Sie die Unterschiede zwischen Folgendem berechnen:

  • Erstem Quartil und Minimalwert

  • Median und erstem Quartil

  • Drittem Quartil und Median

  • Maximalwert und drittem Quartil

  1. Erstellen Sie zunächst eine dritte Tabelle, und kopieren Sie die Minimalwerte aus der letzten Tabelle direkt hier hinein.

  2. Berechnen Sie die Unterschiede zwischen den Quartilen mit der Excel-Subtraktionsformel ("Zelle 1 - Zelle2"), und füllen Sie die dritte Tabelle mit den Ergebnissen.

Für das Beispieldatenset sieht die dritte Tabelle wie folgt aus:

Die dritte Tabelle sollte so aussehen.

Seitenanfang

Schritt 3: Erstellen eines gestapeltes Säulendiagramms

Die Daten in der dritten Tabelle sind hervorragend für ein Boxplot geeignet, und wir beginnen mit der Erstellung eines gestapelten Säulendiagramms, das anschließend geändert wird.

  1. Markieren Sie alle Daten in der dritten Tabelle, und klicken Sie auf Einfügen > Säulendiagramm einfügen > Gestapeltes Säulendiagramm.

    Beginnen Sie, indem Sie "Gestapelte Säule" auswählen.

    Auf den ersten Blick ähnelt das Diagramm nicht einem Boxplot, da Excel die gestapelten Säulen standardmäßig aus horizontalen und nicht aus vertikalen Datensets erstellt.

    Das Standarddiagramm mit gestapelten Säulen
  2. Zum Vertauschen der Diagrammachsen klicken Sie mit der rechten Maustaste auf das Diagramm, und klicken Sie dann auf Daten auswählen.

  3. Klicken Sie auf Zeile/Spalte wechseln.

    Tipps : Zum Umbenennen der Spalten klicken Sie auf der Seite Horizontale Achsenbeschriftungen (Rubrik) auf Bearbeiten, markieren Sie den Zellbereich in der dritten Tabelle mit den gewünschten Rubrikennamen, und klicken Sie auf OK. Wählen Sie den Zellbereich aus, den Sie umbenennen möchten.

    Um die Legendeneinträge umzubenennen, klicken Sie auf der Seite Legendeneinträge (Reihen) auf Bearbeiten, und geben Sie den gewünschten Eintrag ein.

  4. Klicken Sie auf OK.

Das Diagramm sollte nun wie das nachstehend dargestellte aussehen. In diesem Beispiel wurde auch der Diagrammtitel bearbeitet, und die Legende wurde ausgeblendet.

Ihr Diagramm sollte jetzt so aussehen.

Seitenanfang

Schritt 4: Konvertieren des gestapelten Säulendiagramms in ein Diagramm vom Typ Boxplot

Ausblenden der unteren Datenreihe

Zum Konvertieren eines gestapelten Säulendiagramms in ein Boxplotdiagramm beginnen Sie mit dem Ausblenden der unteren Datenreihe:

  1. Markieren Sie den unteren Teil der Säulen.

    Hinweis : Wenn Sie auf eine einzelne Säule klicken, werden alle Instanzen aus derselben Datenreihe markiert.

  2. Klicken Sie auf Format > Aktuelle Auswahl > Auswahl formatieren. Auf der rechten Seite wird der Bereich Format geöffnet.

    "Auswahl formatieren" befindet sich auf der Registerkarte "Format".
  3. Wählen Sie im Bereich Format auf der Registerkarte Füllung die Option Keine Füllung aus.

    Die untere Datenreihe wird im Diagramm ausgeblendet.

    In diesem Diagramm sind die unteren Daten ausgeblendet.

Erstellen von Whiskers für das Boxplot

Der nächste Schritt besteht darin, die oberste Datenreihe und die zweite Datenreihe von unten (die dunkelblauen und orangefarbigen Bereich in der Abbildung) durch Linien oder Whiskers zu ersetzen.

  1. Markieren Sie die oberste Datenreihe.

  2. Wählen Sie im Bereich Format auf der Registerkarte Füllung die Option Keine Füllung aus.

  3. Klicken Sie im Menüband auf Entwurf > Diagrammelement hinzufügen > Fehlerindikatoren > Standardabweichung.

    Die Menüs "Diagrammelement hinzufügen" und "Fehlerindikatoren"
  4. Klicken Sie auf einen der gezeichneten Fehlerindikatoren.

  5. Öffnen Sie im Bereich Format die Registerkarte Optionen für Fehlerindikatoren, und legen Sie diese wie folgt fest:

    • Legen Sie Richtung auf Minus fest.

    • Legen Sie Linienende auf Ohne Abschluss fest.

    • Legen Sie für Fehlerbetrag die Option Prozentsatz auf 100 fest.

      Unter "Fehlerbetrag" sollte der Wert in "Prozentsatz" gleich "100%" lauten.
  6. Wiederholen Sie die vorstehenden Schritte für die zweite Datenreihe von unten.

    Das gestapelte Säulendiagramm sollte nun einem Boxplot ähneln.

    Das endgültige Diagramm weist jetzt "Whisker" auf.

Einfärben der mittleren Bereiche

Boxplots werden normalerweise mit einer Füllfarbe und einem dünnen Außenrahmen gezeichnet. In den folgenden Schritten wird beschrieben, wie Sie das Layout fertig stellen.

  1. Markieren Sie den oberen Bereich des Boxplots.

  2. klicken Sie im Bereich Format auf der Registerkarte Füllung und Linie auf Einfarbige Füllung.

  3. Wählen Sie eine Füllfarbe aus.

  4. Klicken Sie auf derselben Registerkarte auf Durchgezogene Linie.

  5. Wählen Sie eine Linienfarbe und eine Breite aus.

  6. Legen Sie dieselben Werte für andere Bereiche Ihres Boxplots fest.

    Das Endergebnis sollte wie ein Boxplotdiagramm aussehen.

    Ihre endgültigen Boxplots sollten so aussehen.

Seitenanfang

Siehe auch

Verfügbare Diagrammtypen

Diagramme und anderen Visualisierungen in Power View

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×