Erstellen einer Lösung für die Bestandsnachverfolgung mithilfe von InfoPath und Excel

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

In Microsoft Office InfoPath können Sie Formularvorlagen für die Dateneingabe und -sammlung erstellen. In Microsoft Office Excel 2007 können Benutzer Daten berechnen, in Diagrammen darstellen und analysieren. Mithilfe von diesen beiden Programmen und XML können Sie problemlos eine einfache und trotzdem effektive Geschäftslösung ohne Code für das Nachverfolgen des Bestands in einem Unternehmen erstellen.

Überblick einer Lösung für das Nachverfolgen von Posten

Inhalt dieses Artikels

Einführung in das Erstellen einer Lösung für die Bestandsnachverfolgung

Schritt 1: Anpassen der Formularvorlage für die Bestandsnachverfolgung

Schritt 2: Zuordnen der Schemadatei und Anpassen des Tabellenlayouts in Excel

Schritt 3: Erstellen eines PivotTable- und PivotChart-Zusammenfassungsberichts

Schritt 4: Sammeln von Bestandsinformationen von Benutzern

Schritt 5: Importieren von Formularen in Excel

Abschließende Überlegungen: Verwenden einer SharePoint-Liste oder einer Access-Datenbank

Einführung in das Erstellen einer Lösung für die Bestandsnachverfolgung

Sie können XML-Daten zwischen InfoPath und Excel austauschen. Obwohl der InfoPath-Befehl Exportieren eine einfache Möglichkeit zum Senden von Formulardaten an Excel darstellt, gibt es noch einen anderen Ansatz, der Ihnen viel mehr Flexibilität bietet. Wenn Sie die InfoPath-XML-Schemadatei (XSD) in Excel explizit zuordnen und dann InfoPath-Formulardateien (XML) in Excel importieren, können Sie das Layout der Daten anpassen und die Features in Excel besser nutzen, um Ihre Daten effizienter zu verwalten und zu analysieren.

In diesem Artikel verwenden wir die InfoPath-Beispielformularvorlage für die Bestandsnachverfolgung, um zu veranschaulichen, wie Sie die Zusammenarbeit von InfoPath, XML und Excel ermöglichen. Stellen Sie sich vor, dass Ihre Organisation jedes Jahr den Bestand in den Büroräumen der einzelnen Mitarbeiter inventarisiert. Anschließend wird ein Excel-Bericht ausgeführt, um zu entscheiden, wie das Budget für die Ausstattung für das nächste Jahr zugeteilt werden soll. Das folgende Diagramm bietet einen Überblick darüber, wie Sie die Bestandsdaten in Ihrer Abteilung sammeln, nachverfolgen und in einem Bericht erfassen können.

a

1. Die Formularvorlage für die Bestandsnachverfolgung wird erstellt.

2. Die Schemadatei wird einer Excel-Tabelle zugeordnet, und das Tabellenlayout wird angepasst.

3. Es wird ein leerer PivotTable- und PivotChart-Zusammenfassungsbericht erstellt.

4. Das Formular für die Bestandsnachverfolgung wird verwendet, um Daten von Benutzern zu sammeln.

5. Alle Formulardaten werden in die Excel-Tabelle exportiert, und die PivotTable- und PivotChart-Berichte werden aktualisiert.

Diese Lösung umfasst die folgenden Benutzerrollen und Produkte:

Symbol 'Vollständige Unterstützung' = Erforderlich Symbol 'Keine Unterstützung' = Nicht erforderlich

Softwareanforderungen

Rollen

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Lösungsdesigner

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Entscheidungsträger

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Mitarbeiter

Symbol 'Vollständige Unterstützung'

Symbol 'Vollständige Unterstützung'

Symbol 'Keine Unterstützung'

Seitenanfang

Schritt 1: Anpassen der Formularvorlage für die Bestandsnachverfolgung

Mithilfe der in InfoPath enthaltenen Formularvorlage für die Bestandsnachverfolgung können Sie Informationen zu jeder Anlage im Büroraum eines Mitarbeiters, zur Abteilung, der der Mitarbeiter angehört, zu Bestandskategorien und Details zu den einzelnen Anlagen sammeln. In dieser Lösung sendet ein Formulardesigner (Entwickler) die Formularvorlage mithilfe von Office Outlook 2007 an das E-Mail-Konto des Entscheidungsträgers.

Vorlage für die Bestandsnachverfolgung

Aufgabe 1: Öffnen und Anpassen der Formularvorlage für die Bestandsnachverfolgung

Da Sie eine Formularvorlage, die ein Steuerelement für ein Feld für Rich-Text mit verknüpften Bildern enthält, nicht an eine Liste von E-Mail-Empfängern senden können, müssen Sie eine kleine Änderung an der Beispielformularvorlage für die Bestandsnachverfolgung vornehmen.

  1. Klicken Sie im Menü Datei auf Eine Formularvorlage entwerfen.

  2. Klicken Sie im Dialogfeld Eine Formularvorlage entwerfen unter Formularvorlage öffnen auf Ein Beispiel anpassen.

  3. Klicken Sie im Dialogfeld Erste Schritte auf Beispiel – Nachverfolgen des Bestands, und klicken Sie dann unter Formularbezogene Aufgaben auf Dieses Formular entwerfen.

  4. Klicken Sie mit der rechten Maustaste auf das Steuerelement assetNotes, zeigen Sie auf die Eigenschaften von Feld für Rich-Text, und klicken Sie auf die Registerkarte Anzeige. Deaktivieren Sie dann unter Verfügbare Formatierungen das Kontrollkästchen Verknüpfte Bilder.

Aufgabe 2: Festlegen der Absendeoptionen

Die nächste Aufgabe besteht darin, die Absendeoptionen festzulegen, damit die Mitarbeiter eine eindeutig benannte Formulardatei (XML) als Dateianlage an das E-Mail-Konto des Entscheidungsträgers senden können.

  1. Klicken Sie im Menü Extras auf Absendeoptionen.

  2. Aktivieren Sie im Dialogfeld Absendeoptionen das Kontrollkästchen Übermitteln dieses Formulars durch Benutzer zulassen.

  3. Klicken Sie auf Formulardaten an ein einziges Ziel senden, und klicken Sie anschließend in der Liste auf E-Mail.

  4. Klicken Sie auf Hinzufügen.

    Der Datenverbindungs-Assistent wird geöffnet.

  5. Geben Sie im Feld An den Alias des Entscheidungsträgers ein, der alle übermittelten Formulare erhalten soll.

  6. Gehen Sie zum Angeben einer eindeutigen Betreffzeile im Feld Betreff wie folgt vor:

    • Klicken Sie auf Formel einfügen  Formelschaltfläche .

    • Geben Sie die folgende Formel ein:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Klicken Sie auf Formel überprüfen, und klicken Sie dann zweimal auf OK.

  • Geben Sie im Feld Einleitung entsprechende Informationen ein, oder fügen Sie wichtige Anweisungen für diese Lösung hinzu.

  • Klicken Sie auf Weiter.

  • Klicken Sie auf der nächsten Seite des Assistenten auf Formulardaten als Anlage senden, und aktivieren Sie dann das Kontrollkästchen Formularvorlage anfügen, um sicherzustellen, dass Benutzer das Formular öffnen können.

    Dadurch wird sichergestellt, dass die Mitarbeiter Zugriff auf die Formularvorlagendatei (XSN) haben, falls sie nicht über die Netzwerkadresse darauf zugreifen können.

  • Gehen Sie zum Angeben eines eindeutigen Dateinamens für jede Formulardatei (XML) im Feld Name der Anlage wie folgt vor:

    1. Klicken Sie auf Formel einfügen  Formelschaltfläche .

    2. Geben Sie dieselbe Formel wie in der Betreffzeile ein:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Klicken Sie auf Formel überprüfen, und klicken Sie dann zweimal auf OK.

  • Klicken Sie auf Weiter.

  • Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung an einen aussagekräftigen Namen für diese Datenverbindung (Absenden) ein.

  • Überprüfen Sie, ob die Informationen im Abschnitt Zusammenfassung korrekt sind, und klicken Sie dann auf Fertig stellen.

  • Speichern Sie das Formular in einem öffentlichen Netzwerkordner, auf den der Entscheidungsträger und alle Mitarbeiter zugreifen kann/können.

Seitenanfang

Schritt 2: Zuordnen der Schemadatei und Anpassen des Tabellenlayouts in Excel

Zum Einrichten der Verbindung zwischen InfoPath und Excel müssen die folgenden drei Aufgaben ausgeführt werden: Extrahieren der Schemadatei für die Formularvorlage für die Bestandsnachverfolgung, Zuordnen dieser Schemadatei in Excel und Anpassen des Layouts der Excel-Tabelle, die alle importierten XML-Formulardatendateien enthält.

Aufgabe 1: Extrahieren der Schemadatei aus InfoPath

  1. Öffnen Sie in InfoPath die Formularvorlagendatei für die Bestandsnachverfolgung.

  2. Klicken Sie im Menü Extras auf Dieses Formular entwerfen.

  3. Klicken Sie im Menü Datei auf Als Quelldateien speichern.

  4. Wählen Sie im Dialogfeld Nach Ordner suchen einen Ordner aus, oder erstellen Sie einen neuen Ordner, in dem Sie die Schemadatei speichern möchten.

Notieren Sie sich den Speicherort des Ordners, in dem alle Quelldateien gespeichert sind, und den Namen der Schemadatei (in diesem Fall myschema.xsd), die die Schemadefinition der XML-Formulardaten enthält.

Aufgabe 2: Zuordnen der InfoPath-Schemadatei in Excel

  1. Erstellen Sie eine neue Excel-Datei, und speichern Sie die Datei dann an einem Speicherort, auf den der Entscheidungsträger zugreifen kann.

  2. Wenn in Excel die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie wie folgt vor:

    1. Klicken Sie auf die Microsoft Office-Schaltfläche  Abbildung der Office-Schaltfläche , und klicken Sie dann auf Excel-Optionen.

    2. Aktivieren Sie in der Kategorie Häufig verwendet unter Die am häufigsten verwendeten Optionen bei der Arbeit mit Excel das Kontrollkästchen Entwicklerregisterkarte in der Multifunktionsleiste anzeigen, und klicken Sie dann auf OK.

      Hinweis : Die Multifunktionsleiste ist eine Komponente der Microsoft Office Fluent-Benutzeroberfläche.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe XML auf Quelle.

    Gruppe 'XML' im Menüband

    Der Aufgabenbereich XML-Quelle wird angezeigt.

  4. Klicken Sie auf XML-Zuordnungen, und klicken Sie dann im Dialogfeld XML-Zuordnungen auf Hinzufügen.

  5. Auf einem Computer unter Windows Vista   

    1. Klicken Sie in der Adressleiste auf das Laufwerk oder den Ordner, das/der die Datei myschema.xsd enthält, die Sie in Schritt 2 des Abschnitts in Aufgabe 1: Extrahieren der Schemadatei aus InfoPath erstellt haben.

      Auf einem Computer unter Microsoft Windows XP   

    2. Klicken Sie in der Liste Suchen in auf das Laufwerk oder den Ordner, das/der die Datei myschema.xsd enthält, die Sie in Schritt 2 des Abschnitts in Aufgabe 1: Extrahieren der Schemadatei aus InfoPath erstellt haben.

  6. Klicken Sie auf die Datei und dann auf Öffnen.

  7. Wenn das Dialogfeld Mehrere Wurzeln angezeigt wird, klicken Sie auf den Stammknoten assetTracking, der in der Datei "myschema.xsd" definiert wird, und klicken Sie dann auf OK.

    Im Aufgabenbereich XML-Quelle wird die XML-Zuordnung angezeigt.

  8. Ziehen Sie das Knotenelement ns1:asset, bei dem es sich um ein wiederholtes XML-Element handelt, im Arbeitsblatt an die Stelle, an der die Excel-Tabelle angezeigt werden soll.

    Zuordnen der InfoPath-Schemadatei in Excel

Aufgabe 3: Anpassen des Layouts der Excel-Tabelle

In Excel werden standardmäßig die Namen der XML-Elemente als Spaltenüberschriften für die Tabelle verwendet. Sie können die Spaltenüberschriften jedoch ändern, indem Sie die zugehörigen Zellen bearbeiten.

  1. Wenn Sie die standardmäßigen Spaltenüberschriften ändern möchten, suchen Sie in der ausgewählten Excel-Tabelle das Zeichenfolgenpräfix ns1:asset, und entfernen Sie es. Ändern Sie beispielsweise ns1:assetID in ID.

    Anpassen der Excel-Tabellenüberschriften

  2. Wenn Sie die Spaltenbreite anpassen möchten, klicken Sie auf die Schaltfläche Alles markieren, und doppelklicken Sie dann auf eine Begrenzungslinie einer Spaltenüberschrift.

Seitenanfang

Schritt 3: Erstellen eines PivotTable- und PivotChart-Zusammenfassungsberichts

Entscheidungsträger verwenden PivotTable- und PivotChart-Berichte zum Analysieren, Durchsuchen und Visualisieren von Zusammenfassungsdaten. Wenn Sie die in diesem Szenario zu verwendenden PivotTable- und PivotChart-Berichte vorab einrichten, kann ein Entscheidungsträger den Bericht mit den vollständigen Daten später in einem ganz einfachen Vorgang ausführen.

  1. Markieren Sie in der Excel-Tabelle eine Zelle.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Tabellen auf PivotTable, und klicken Sie dann auf PivotTable.

    Abbildung der Excel-Multifunktionsleiste

    Das Dialogfeld PivotTable erstellen wird angezeigt.

  3. Wenn Sie den PivotTable-Bericht auf einem neuen Arbeitsblatt beginnend bei Zelle A1 platzieren möchten, klicken Sie auf Neues Arbeitsblatt, und klicken Sie dann auf OK.

    Excel fügt an der angegebenen Position einen leeren PivotTable-Bericht hinzu, und die PivotTable-Feldliste wird angezeigt, sodass Sie Felder hinzufügen, ein Layout erstellen und den PivotTable-Bericht anpassen können.

  4. Wenn Sie einen tabellenübergreifenden Bericht der Daten erstellen möchten, ziehen Sie das Feld ID in den Bereich "Werte", das Feld Abteilung in den Bereich "Spaltenbeschriftungen", das Feld Kategorie in den Bereich "Zeilenbeschriftungen" und das Feld Zugewiesen an in den Bereich "Berichtsfilter".

  5. Klicken Sie auf den PivotTable-Bericht.

  6. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Diagramme auf den Diagrammtyp Balken.

    Abbildung des Excel-Menübands

  7. Wählen Sie unter 2D-Balken die Option Gruppierte Balken aus.

  8. Passen Sie die Größe und die Position des PivotChart-Berichts nach Belieben an.

Leere PivotTable- und PivotChart-Berichte

Seitenanfang

Schritt 4: Sammeln von Bestandsinformationen von Benutzern

Die Formularvorlage kann jetzt von allen Mitarbeitern ausgefüllt werden. Dazu müssen Sie das Formular veröffentlichen und an jeden Mitarbeiter senden. Wenn die einzelnen Mitarbeiter das ausgefüllte Formular übermitteln, wird es in einer E-Mail-Nachricht als angefügte XML-Datendatei (XML) an das E-Mail-Konto des Entscheidungsträgers gesendet. Der Entscheidungsträger kann dann alle Nachrichten in Outlook in einen dedizierten InfoPath-Ordner verschieben. In diesem Szenario empfiehlt es sich, einen bestimmten Zeitraum festzulegen, in dem alle Benutzer die Formulare ausfüllen müssen, damit der Entscheidungsträger den Bericht nach Ablauf der Abgabefrist mit allen ausgefüllten Formularen ausführen kann.

Eingeben von Daten in die Bestandsnachverfolgungsformular

  1. Öffnen Sie in InfoPath die Formularvorlage (XSN), die Sie in Schritt 1: Anpassen der Formularvorlage für die Bestandsnachverfolgung gespeichert haben.

  2. Klicken Sie im Menü Extras auf Dieses Formular entwerfen.

  3. Klicken Sie im Menü Datei auf Veröffentlichen.

  4. Klicken Sie im Veröffentlichen-Assistenten auf In einer Liste von E-Mail-Empfängern, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten im Feld Name der Formularvorlage einen Namen für die Formularvorlage ein, und klicken Sie dann auf Weiter. Der Name der Formularvorlage wird in der Betreffzeile der Nachricht angezeigt, die an die E-Mail-Empfänger gesendet wird.

  6. Auf der nächsten Seite des Assistenten können Sie optional Spalten erstellen, die in Ihren Outlook-Ordnern angezeigt werden. So können Sie Ihre E-Mail-Nachrichten besser organisieren.

  7. Klicken Sie auf Weiter.

  8. Klicken Sie auf Veröffentlichen.

  9. Nachdem der Veröffentlichen-Assistent die Formularvorlage veröffentlicht hat, wird das Formular in einer E-Mail-Nachricht geöffnet.

  10. Füllen Sie das Formular in der Nachricht aus, geben Sie die Namen der Mitarbeiter ein, oder verwenden Sie eine Verteilerliste, und senden Sie dann die Nachricht.

In Outlook stehen dem Entscheidungsträger zwei Möglichkeiten zum Organisieren aller übermittelten XML-Formulare zur Verfügung:

  • Wenn das Feld InfoPath-Formularordner beim ersten Öffnen der Nachricht angezeigt wird, klicken Sie auf Formularordner erstellen.

  • Erstellen Sie in Outlook eine Regel, um alle zugehörigen InfoPath-Formulare in einen InfoPath-Ordner zu verschieben.

    Weitere Informationen finden Sie unter Verwalten von Nachrichten mithilfe von Regeln.

Seitenanfang

Schritt 5: Importieren von Formularen in Excel

Weil Sie bereits die Schritte 2 und 3 für die Excel-Arbeitsmappe ausgeführt haben, kann der Entscheidungsträger die Formulardaten ganz einfach exportieren und überprüfen. Der Entscheidungsträger muss einfach nur die XML-Dateien aus Outlook exportieren, alle Formulardateien (XML) in die Excel-Arbeitsmappe importieren und dann die Daten aktualisieren.

Aufgabe 1: Exportieren der Formulare aus Outlook in einen Windows-Ordner

  1. Wählen Sie in Outlook den Ordner aus, der alle Formulare enthält, die Sie von den Mitarbeitern erhalten haben, und drücken Sie dann STRG+A, um alle E-Mail-Nachrichten mit Formularen auszuwählen.

  2. Klicken Sie mit der rechten Maustaste auf die Auswahl, zeigen Sie auf InfoPath-Aktionen, und klicken Sie dann auf Formulare exportieren.

  3. Wählen Sie im Dialogfeld Formulare exportieren einen Ordner aus, und klicken Sie dann auf OK.

Aufgabe 2: Importieren der Formulare in Excel

  1. Wählen Sie in der Excel-Arbeitsmappe, die Sie in Schritt 2: Zuordnen der Schemadatei und Anpassen des Tabellenlayouts in Excel erstellt haben, eine der zugeordneten Zellen in der Excel-Tabelle aus.

  2. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe XML auf Importieren.

    Gruppe 'XML' im Menüband

    Das Dialogfeld XML importieren wird angezeigt.

  3. Auf einem Computer unter Windows Vista   

  4. Führen Sie eine der folgenden Aktionen aus:

    • Halten Sie bei zusammenhängenden Dateien die UMSCHALTTASTE gedrückt, und klicken Sie dann auf die erste und letzte Datei in der Liste.

    • Bei unzusammenhängenden Dateien drücken Sie STRG, und klicken Sie dann in der Liste auf die einzelnen zu importierenden Dateien.

  5. Klicken Sie auf Importieren.

    Excel-Tabelle mit importierten Daten

In Excel werden standardmäßig alle vorhandenen Daten in den zugeordneten Zellen überschrieben. Dies ist das gewünschte Endergebnis für diese Geschäftslösung. Ein Entscheidungsträger könnte aber beispielsweise die Daten mehrmals importieren, um den Fortschritt vor dem geplanten Stichtag zu messen.

Hinweis : In Excel können Sie auch die Daten mithilfe der Option Vorhandene XML-Tabellen um neue Daten erweitern anfügen. (Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe XML auf Eigenschaften zuordnen.) Dies bietet sich möglicherweise bei anderen Lösungen an.

Weitere Informationen finden Sie auf der Excel-Hilfethemen importieren XML-Daten und Anfügen oder überschreiben zugeordnete XML-Daten.

Aufgabe 3: Aktualisieren der PivotTable- und PivotChart-Berichte

  • Klicken Sie im PivotTable-Bericht auf eine Zelle.

  • Klicken Sie auf der Registerkarte Optionen in der Gruppe Daten auf den Pfeil neben Alle aktualisieren, und klicken Sie dann auf Aktualisieren.

    Abbildung des Outlook-Menübands

Endgültiger PivotTable- und PivotChart-Bericht

Die Excel-Arbeitsmappe enthält jetzt alle Daten und Zusammenfassungsberichte, die Sie benötigen, um das Budget für die Ausstattung für das nächste Jahr zuzuteilen. Sie können natürlich ggf. noch weitere Analysen in Ihrer Excel-Arbeitsmappe durchführen und beispielsweise die Daten sortieren, filtern oder bedingt formatieren.

Seitenanfang

Abschließende Überlegungen: Verwenden einer SharePoint-Liste oder einer Access-Datenbank

Als Alternative können Sie anstelle von XML eine SharePoint-Liste oder eine Access-Datenbank verwenden, um Daten zwischen InfoPath und Excel zu übertragen.

Verwenden einer SharePoint-Liste

In InfoPath können Sie problemlos eine SharePoint-Liste als schreibgeschützte Datenquelle verwenden. Sie können eine der beiden folgenden Aktionen ausführen:

  • Exportieren Sie von der SharePoint-Liste die Daten nach Excel. Dadurch wird automatisch eine Datenverbindung in Excel erstellt.

  • Erstellen Sie in Excel explizit eine Datenverbindung mit der SharePoint-Liste.

Nachdem eine Datenverbindung erstellt wurde, können Sie die Daten in Excel aktualisieren, um die aktuellen Daten abzurufen.

Sie können eine SharePoint-Liste verwenden, um Daten hinzuzufügen und zu aktualisieren, in einem InfoPath-Formular ein Element aus der Liste anzeigen (z. B. ein komplexes oder großes Element, das am besten vertikal angezeigt wird) und dann Excel verwenden, um die Daten weiter zu analysieren.

Kombinieren von InfoPath, einer SharePoint-Liste und Excel

1. Ein einzelnes Element zur einfachen Überprüfung in InfoPath anzeigen

2. Daten in einer SharePoint-Liste hinzufügen und aktualisieren

3. In Excel die Daten aktualisieren und einen aktuellen Bericht anzeigen

Weitere Informationen finden Sie unter Hinzufügen einer Datenverbindung zu einer SharePoint-Dokumentbibliothek oder -Liste und Importieren von Daten von einer SharePoint-Liste.

Verwenden einer Access-Datenbank

In InfoPath können Sie eine Verbindung mit Lese-/Schreibzugriff mit einer Access-Datenbank erstellen. In Excel können Sie explizit eine Datenverbindung mit der Access-Datenbank erstellen, die Sie aktualisieren können, um aktuelle Daten abzurufen. Sie können die Verbindung sogar so konfigurieren, dass sie beim Öffnen der Arbeitsmappe automatisch aktualisiert oder regelmäßig (z. B. alle 5 Minuten) aktualisiert wird.

Sie können eine Access-Datenbank als Vermittler zwischen InfoPath und Excel verwenden. Wenn Sie ein InfoPath-Formular an Access senden, aktualisieren Sie die Access-Datenbank. Wenn Sie die Datenverbindung in Excel aktualisieren, rufen Sie aktualisierte Daten von Access ab. Sie senden also praktisch Daten indirekt von InfoPath an eine Excel-Arbeitsmappe.

Kombinieren von InfoPath, Access und Excel

1. Ein Formular anzeigen und an eine Access-Datenbank senden

2. Daten in einer Access-Datenbank speichern

3. In Excel die Daten aktualisieren und einen aktuellen Bericht anzeigen

Weitere Informationen finden Sie unter Entwerfen einer auf einer Microsoft Access-Datenbank basierenden Formularvorlage.

Tipp : Wussten Sie, dass Sie ein InfoPath-Formular direkt in Access 2007 erstellen können? Wenn auf den Computern Ihrer Benutzer Outlook 2007 und InfoPath 2007 installiert ist, können Sie Daten von verschiedenen Benutzern direkt in Access 2007 sammeln. Dazu verwenden Sie den Assistenten zum Sammeln von Daten über E-Mail-Nachrichten. Weitere Informationen finden Sie im Access 2007-Hilfethema Sammeln von Daten mithilfe von E-Mail-Nachrichten.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×