Erstellen bedingter Formeln

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Testen, ob die Bedingungen WAHR oder falsch und ausführenden logische Vergleiche zwischen Ausdrücken allgemeine zu vielen Vorgängen sind. Die UND, ODER, NICHTund WENN -Funktionen können bedingte Formeln erstellt.

Die WENN -Funktion verwendet, beispielsweise die folgenden Argumente.

Formel mit der If (Funktion)

Formel, die die WENN-Funktion verwendet

Schaltflächensymbol Prüfung: die Bedingung, die Sie überprüfen möchten.

Schaltflächensymbol Dann_Wert: den Wert zurück, wenn die Bedingung wahr ist.

Schaltflächensymbol Sonst_Wert: den Wert zurück, wenn die Bedingung False ergibt.

Weitere Informationen zum Erstellen von Formeln finden Sie unter Erstellen oder Löschen einer Formel.

Was möchten Sie tun?

Erstellen einer bedingten Formel, die Ergebnis in ein logischer Wert (WAHR oder FALSCH)

Erstellen einer bedingten Formel, die Werte in einer anderen Berechnung oder anderen Wert als TRUE oder FALSE ergibt

Erstellen einer bedingten Formel mit einem Wahrheitswert als Ergebnis (WAHR oder FALSCH)

Verwenden Sie zum Ausführen dieser Aufgabe UND, ODERund NICHT Funktionen und Operatoren, wie im folgenden Beispiel gezeigt.

Beispiel

Möglicherweise wird das Beispiel verständlicher, wenn Sie es in ein leeres Arbeitsblatt kopieren.

Wie kopiere ich ein Beispiel?

  1. Markieren Sie das Beispiel in diesem Artikel.

    Wichtig : Markieren Sie dabei nicht die Zeilen- oder Spaltenüberschriften.

    Auswählen eines Beispiels aus der Hilfe für Excel 2013 für Windows

    Auswählen eines Beispiels aus der Hilfe

  2. Drücken Sie STRG+C.

  3. Öffnen Sie in Excel eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.

  4. Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.

Wichtig : Damit das Beispiel ordnungsgemäß funktioniert, müssen Sie es in Zelle A1 des Arbeitsblatts einfügen.

  1. Um zwischen der Anzeige der Ergebnisse und der Anzeige der Formeln, die diese Ergebnisse zurückgeben, zu wechseln, drücken Sie STRG+` (Gravis), oder klicken Sie auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf die Schaltfläche Formeln anzeigen.

Nachdem Sie das Beispiel in ein leeres Arbeitsblatt kopiert haben, können Sie es es Ihren Anforderungen anpassen.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Daten

15

2,74

2,44

Zahnräder

Vorrichtungen

Formel

Beschreibung (Ergebnis)

=UND(A2>A3;A2<A4)

Ermittelt, ob der Wert in Zelle A2 größer als der Wert in Zelle A3 ist. Ermittelt außerdem, ob der Wert in A2 kleiner als der Wert in A4 ist. (FALSCH)

=ODER(A2>A3;A2<A4)

Ermittelt, ob der Wert in Zelle A2 größer als der Wert in Zelle A3 ist; oder ermittelt, ob der Wert in A2 kleiner als der Wert in A4 ist. (WAHR)

=NICHT(A2+A3=24)

Ermittelt, ob die Summe der Werte in den Zellen A2 und A3 nicht gleich 24 ist. (FALSCH)

=NICHT(A5="Zahnräder")

Ermittelt, ob der Wert in Zelle A5 nicht gleich "Zahnräder" ist. (FALSCH)

=ODER(A5<>"Zahnräder";A6 = "Vorrichtungen")

Ermittelt, ob der Wert in Zelle A5 nicht gleich "Zahnräder" ist, oder ob der Wert in A6 gleich "Vorrichtungen" ist. (WAHR)

Weitere Informationen zum Verwenden dieser Funktionen finden Sie unter Funktion UNDund oder-FunktionNICHT (Funktion).

Seitenanfang

Erstellen einer bedingten Formel mit einer anderen Berechnung oder anderen Werten als WAHR oder FALSCH als Ergebnis

Verwenden Sie zum Ausführen dieser Aufgabe IF, UNDund ODER -Funktionen und Operatoren, wie im folgenden Beispiel dargestellt.

Beispiel

Möglicherweise wird das Beispiel verständlicher, wenn Sie es in ein leeres Arbeitsblatt kopieren.

Wie kopiere ich ein Beispiel?

  1. Markieren Sie das Beispiel in diesem Artikel.

Wichtig : Markieren Sie dabei nicht die Zeilen- oder Spaltenüberschriften.

Auswählen eines Beispiels aus der Hilfe für Excel 2013 für Windows

Auswählen eines Beispiels aus der Hilfe

  1. Drücken Sie STRG+C.

  2. Öffnen Sie in Excel eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.

  3. Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.

Wichtig : Damit das Beispiel ordnungsgemäß funktioniert, müssen Sie es in Zelle A1 des Arbeitsblatts einfügen.

  1. Um zwischen der Anzeige der Ergebnisse und der Anzeige der Formeln, die diese Ergebnisse zurückgeben, zu wechseln, drücken Sie STRG+` (Gravis), oder klicken Sie auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf die Schaltfläche Formeln anzeigen.

Nachdem Sie das Beispiel in ein leeres Arbeitsblatt kopiert haben, können Sie es es Ihren Anforderungen anpassen.

1

2

3

4

5

6

7


2,44



9



10



11




12



13



14




15



16

A

B

Daten

15

2,74

2,44

Zahnräder

Vorrichtungen

Formel

Beschreibung (Ergebnis)

=WENN(A2=15;"OK";"Nicht OK")

Wenn der Wert in Zelle A2 gleich 15 ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (OK)

=WENN(A2<>15; "OK"; "Nicht OK")

Wenn der Wert in Zelle A2 nicht gleich 15 ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (Nicht OK)

=WENN(NICHT(A2<=15); "OK"; "Nicht OK")

Wenn der Wert in Zelle A2 nicht kleiner oder gleich 15 ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (Nicht OK)

=WENN(A5<>"ZAHNRÄDER"; "OK"; "Nicht OK")

Wenn der Wert in Zelle A5 nicht gleich ZAHNRÄDER ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (Nicht OK)

=WENN(UND(A2>A3;A2<A4);"OK";"Nicht OK")

Wenn der Wert in Zelle A2 größer als der Wert in A3 ist, und wenn gleichzeitig der Wert in A2 kleiner als der Wert in A4 ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (Nicht OK)

=WENN(UND(A2<>A3, A2<>A4), "OK"; "Nicht OK")

Wenn der Wert in Zelle A5 nicht gleich A3 oder der Wert in A2 nicht gleich dem Wert in A4 ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (Nicht OK)

=WENN(ODER(A2>A3;A2<A4);"OK";"Nicht OK")

Wenn der Wert in Zelle A2 größer als der Wert in A3 ist, oder wenn der Wert in A2 kleiner als der Wert in A4 ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (OK)

=WENN(ODER(A5<>"Zahnräder"; A6<>"Vorrichtungen"); "OK"; "Nicht OK")

Wenn der Wert in Zelle A5 nicht gleich Zahnräder oder der Wert in A6 nicht gleich Vorrichtungen ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (Nicht OK)

=WENN(ODER(A2<>A3, A2<>A4), "OK"; "Nicht OK")

Wenn der Wert in Zelle A2 nicht gleich dem Wert in A3 ist oder wenn der Wert in A2 nicht gleich dem Wert in A4 ist, wird OK zurückgegeben. Anderenfalls wird Nicht OK zurückgegeben. (OK)

Weitere Informationen zum Verwenden dieser Funktionen finden Sie unter WENN-Funktion, Funktion UNDund oder-Funktion.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×