Erstellen, Veröffentlichen und Pflegen einer Publisher-Website

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Planen und erstellen Sie eine Webpublikation in Microsoft Office Publisher 2007 können Sie es im Web, einem Netzwerkserver oder einem freigegebenen Ordner auf dem eigenen Computer veröffentlichen. Abhängig vom Ziel erstellt Publisher gefilterte HTML-Dateien aus der Webpublikation. Öffnen und Lesen Sie diese HTML-Dateien in einem beliebigen Webbrowser, z. B. Windows Internet Explorer.

Webpublikation mit Navigationsleiste, Text und Grafiken

Inhalt dieses Artikels

In diesem Artikel werden die Verfahren beschrieben, die Sie zum Erstellen und Veröffentlichen einer Webpublikation als HTML-Dateien im Internet kennen müssen. Außerdem wird erläutert, wie Sie die Website durch Bearbeiten der Webpublikation und erneutes Veröffentlichen aktualisieren.

Erstellen einer Website

Veröffentlichen einer Website

Verwalten einer Website

Erstellen einer Website

Ihre Website ist ein Aushängeschild für Sie, Ihr Unternehmen und Ihre Unternehmensmarkenpolitik. Planen Sie Ihre Website, bevor Sie sie erstellen. Hilfe hierzu finden Sie im Artikel Planen der Website.

Welches Tool ist am besten geeignet?

Beim Planen Ihrer Site und die Informationen, die sie bereitstellen, sollten Sie die-authoring-Tool für Ihre Bedürfnisse geeignet ist. Office Publisher 2007 ist ein ausgezeichnetes Dokumenterstellungstool verwenden, um schnell erstellen, veröffentlichen und Verwalten von einfachen statischen Websites mit den Business-Marke und die Versionen nur Text und Grafiken erfordern. Office Publisher 2007 ist nicht das gewünschte in folgenden Fällen:

  • Wenn Ihre Website Interaktionen oder datenbankgesteuerten Inhalt erfordert, damit Besucher der Website in einem Weblog (Blog) antworten oder Dinge in einem Einkaufswagen einkaufen können

  • Wenn für die Website Datenvalidierung erforderlich ist, z. B. zum Überprüfen von Kreditkartennummern

  • Wenn Sie planen, den unformatierten HTML-Code in einem HTML-Editor nach dem Erstellen Ihrer Website in Office Publisher 2007, HTML-, XML- und VML-Codes zu Websites verbindet später ändern

Grundlegende Web-hosting und online-Website erstellen Microsoft® Office Live das richtige Tool für Sie möglicherweise. Informationen finden Sie auf der Website Microsoft® Office Live .

Für interaktive Websites bietet Microsoft Expression Web Tools für umfassende, auf Standards basierende Websites erstellen. Informationen zu Microsoft Expression Web finden.

Erstellen einer Website

Sie können eine neue Webpublikation in Office Publisher 2007 erstellen. Soll auf einer vorhandenen Website arbeiten für die Ihnen keine Webpublikation kopieren und Einfügen von Inhalt aus der veröffentlichten Webseiten in eine neue, die Website als eine neu erstellt oder ein HTML editing Tool verwenden.

  1. Klicken Sie im Menü Datei auf Neu.

  2. Klicken Sie in der Liste Publikationstypen auf die Option Websites.

  3. Führen Sie einen der folgenden Vorgänge aus:

    • Zum Erstellen einer benutzerdefinierten Website, die auf Ihre Websiteziele ausgerichtet ist, vergewissern Sie sich, dass im Aufgabenbereich Optionen die Option Assistenten zur einfachen Websiteerstellung verwenden ausgewählt ist, und klicken Sie anschließend auf das gewünschte Design.

    • Wenn Sie eine Website von Grund auf neu erstellen möchten, klicken Sie unter Websites auf Leere Formate, und klicken Sie danach auf das gewünschte Format.

  4. Klicken Sie auf Erstellen.

  5. Wenn Sie sich für den Assistenten zur einfachen Websiteerstellung entschieden haben, wählen Sie im Dialogfeld Generator zur einfachen Websiteerstellung die gewünschten Optionen aus, und klicken Sie dann auf OK.

  6. Fügen Sie die Inhalte in die Publikation ein, und nehmen Sie alle gewünschten Änderungen vor.

    Tipp : Vermeiden, dass Objekte auf Masterseiten in Ihrer Webpublikation. Objekte auf Masterseiten Office Publisher 2007 platziert werden, werden bei Anzeige in einigen Web-Browsern korrekt angezeigt.

Überprüfen der Webpublikation

Vor dem Veröffentlichen der Website sollten Sie überprüfen, ob sie wie gewünscht funktioniert und Sie alle möglichen Probleme bedacht haben.

Sie können mithilfe des Designdetektivs nach Problemen suchen und eine Vorschau der Website anzeigen.

Suchen und Beheben von Problemen mit dem Designdetektiv

Der Designdetektiv ist ein leistungsstarkes Tool zum Auffinden möglicher Probleme. Viele der durchgeführten Überprüfungen betreffen grundlegende Formatierungsprobleme, es gibt jedoch auch Überprüfungen, die speziell im Hinblick auf Webpublikationen durchgeführt werden. Gehen Sie wie folgt vor, um den Designdetektiv auszuführen:

  1. Klicken Sie im Menü Extras auf Designdetektiv.

  2. Aktivieren Sie im Aufgabenbereich Designdetektiv die Kontrollkästchen Allgemeine Designprüfungen ausführen und Websiteprüfungen ausführen.

    Hinweis : Stellen Sie sicher, dass das Kontrollkästchen Professionelle Druckprüfungen ausführen nicht aktiviert ist.

  3. Klicken Sie im Aufgabenbereich Designdetektiv unter Zu korrigierendes Element auswählen auf den Pfeil neben dem zu korrigierenden Element, und führen Sie dann eine der folgenden Aktionen aus:

    • Klicken Sie auf AutoKorrektur, um das Problem an dem betreffenden Element automatisch zu beheben.

      Die vorgeschlagene AutoKorrektur ist abhängig von dem vorliegenden Problem. In den meisten Fällen ist keine AutoKorrektur verfügbar.

    • Klicken Sie auf Gehe zu diesem Element, um zu der Seite zu wechseln, auf der das Problem lokalisiert wurde.

      Nehmen Sie alle erforderlichen Änderungen vor, um das Problem zu beheben.

    • Klicken Sie auf Erklären, um ein Hilfethema zu öffnen, in dem das Problem ausführlich beschrieben wird und Lösungsvorschläge aufgeführt werden.

    • Klicken Sie auf Diese Prüfung nie wieder ausführen, um die Prüfung zu deaktivieren.

      Diese Einstellung wird auf alle Instanzen des Problems angewendet.

Anzeigen einer Vorschau der Website

  • Klicken Sie im Menü Datei auf Webseitenvorschau.

Im Standardbrowser wird eine Vorschau der Website angezeigt. Überprüfen Sie in der Vorschau Folgendes:

  • Die Website wird geöffnet, und es kann auf alle Seiten zugegriffen werden.

  • Alle Hyperlinks funktionieren ordnungsgemäß.

  • Steuerelemente für die Navigation funktionieren ordnungsgemäß.

  • Es fehlen keine Elemente.

  • Hintergrundsound wird richtig abgespielt.

Suchen nach einem Webhostingdienst

Bevor Sie Ihre Website im Web veröffentlichen können, müssen Sie abonnieren Webhosting-Dienstanbieter, die von einem Internetdienstanbieter (ISP) bereitgestellt. Dieser Service wird Ihnen mit Speicherplatz auf einem Webserver und einem Uniform Resource Locator (URL), Personen auf Ihre Website zugreifen können. Bevor Sie Ihre Website veröffentlichen, wenden Sie sich an Ihren Internetdienstanbieter oder Systemadministrator um die Informationen abzurufen, die Sie benötigen und die URL der Website oder die Adresse der Website FTP, in dem Sie Dateien speichern können.

In Ihrer Gegend stehen Ihnen wahrscheinlich mehrere ISPs zur Verfügung. Achten Sie beim Abonnieren des ISP darauf, dass er Ihnen auch den gewünschten Support bietet. Wenn Sie wenig Erfahrung mit Veröffentlichungen im Web haben, sollte der ISP Ihnen bei möglichen Problemen helfen können.

Seitenanfang

Veröffentlichen einer Website

Wenn Sie die Webpublikation getestet und überprüft und einen Webhostingdienst abonniert haben, sind alle Vorbereitungen zum Veröffentlichen der Website getroffen.

Sie können eine Website Webserver, einem Netzwerkserver, einem Server (FTP = File Transfer Protocol) oder einem Ordner auf dem eigenen Computer veröffentlichen.

Das Veröffentlichen der eigenen Website an einem Speicherort auf dem eigenen Computer kann mehrere Vorteile bieten:

  • Sie können mit den veröffentlichen Dateien die Website testen, bevor Sie die Dateien im Web verfügbar machen.

  • Sie können mit einem FTP-Programm die Dateien im Web veröffentlichen. Hierfür laden Sie sie von dem Speicherort der Dateien auf Ihrem Computer hoch.

  • Sie behalten eine lokale Kopie der HTML-Dateien sowie der Webpublikation.

Ihr ISP kann Sie beraten und Informationen bereitstellen, die Sie bei der Auswahl der am besten geeigneten Veröffentlichungsmethode unterstützen.

Ob Sie im Web oder auf Ihrem Computer veröffentlichen, baut Office Publisher 2007 die zugehörigen Dateien in einem Ordner erstellt. Die Dateien erstellt, Office Publisher 2007 umfassen die anderen HTML-Seiten, aus denen Ihre Website besteht, GIF- und JPEG-Grafiken, die auf den Seiten sowie Dateien für eingebettete Sounds.

Sie können Office Publisher 2007 diese Dateien im Ordner organisieren, Ihrer Website auf zwei Arten veröffentlichen, einrichten. Standardmäßig erstellt Office Publisher 2007 eine Homepage und einen Unterordner, der alle unterstützenden Dateien enthält, die für die Website erforderlich sind. Oder können Sie die Homepage für Ihre Website in einem Ordner mit den unterstützenden Dateien organisieren.

Wie steuere ich, Office Publisher 2007 der Website organisiert Dateien veröffentlicht?

Klicken Sie im Menü Extras auf Optionen, klicken Sie auf die Registerkarte Web, und führen Sie dann einen der folgenden Schritte aus:

  • Aktivieren Sie das Kontrollkästchen Hilfsdateien in einen Ordner speichern, um die Homepage von den Hilfsdateien zu trennen.

  • Deaktivieren Sie das Kontrollkästchen Hilfsdateien in einen Ordner speichern, wenn die Homepage und alle Hilfsdateien in demselben Ordner gruppiert werden sollen.

Wenn Sie eine Publikation im Web veröffentlichen, erstellt Office Publisher 2007 gefilterte HTML-Dateien, die schneller als ungefilterte HTML-Dateien im Internet verbreiten. Da die gefilterten HTML-Format, Office Publisher 2007 Dateien erstellt keine Microsoft Office-spezifische Tags enthalten, können nicht in Office Publisher 2007 HTML-Dateien öffnen und bearbeiten. Sie müssen zu Ihrer Website in der Webpublikation ändern und die Website im Web veröffentlichen.

Veröffentlichen einer Website unter einer Adresse im Internet oder in einem Netzwerk

Bevor Sie dieses Verfahren anwenden, wenden Sie sich an Ihren ISP oder Systemadministrator, und holen Sie die benötigten Informationen für das Veröffentlichen und den URL der Website ein, auf der Sie die Dateien speichern können.

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Geben Sie im Dialogfeld Veröffentlichen im Web im Feld Dateiname den URL des Web- oder Netzwerkservers ein, auf dem die Website gespeichert werden soll. Geben Sie beispielsweise http://www.northwindtraders.com ein.

  3. Klicken Sie auf Speichern.

  4. Wenn Sie dazu aufgefordert werden, geben Sie Ihren Benutzernamen und das Kennwort ein, und klicken Sie auf OK.

    Im Dialogfeld Veröffentlichen im Web wird das Ihrem URL zugeordnete Verzeichnis angezeigt.

  5. Doppelklicken Sie auf den Ordner, in dem Sie die Website speichern möchten.

  6. Wählen Sie im Feld Dateiname den Namen index als Standardnamen für die Homepage aus, und klicken Sie auf Speichern.

    Hinweis : Index.htm ist die Standardauswahl. Wenn Sie index als Namen für die Homepage auswählen, wird der Zugriff auf die Homepage vereinfacht, und die Benutzer sehen keine Liste der Dateien, aus denen Ihre Website besteht.

  7. Wenn Sie dazu aufgefordert werden, klicken Sie auf OK.

Veröffentlichen einer Website mit FTP

Bevor Sie dieses Verfahren, Systemadministrator ISP oder Informationen erhalten, die Sie auf einer FTP-Site veröffentlichen. Sie müssen auch eine FTP-Site in FTP-Adressen erstellen.

So wird's gemacht

Bevor Sie der Liste in FTP-Adressen eine FTP-Site hinzufügen, müssen Sie über einen Zugang zum Internet oder zu einem Intranet verfügen.

In Windows Vista

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie im Dialogfeld Im Web veröffentlichen auf Extras und dann auf Netzlaufwerk verbinden.

  3. Führen Sie im Dialogfeld Netzlaufwerk verbinden folgende Aktion aus:

    • Klicken Sie in der Liste Laufwerk auf einen Laufwerksbuchstaben. Sie können jeden verfügbaren Buchstaben auswählen.

    • Damit jedes Mal, wenn Sie sich bei Ihrem Computer anmelden, die Verbindung hergestellt wird, aktivieren Sie das Kontrollkästchen Verbindung bei Anmeldung wiederherstellen.

    • Klicken Sie auf Verbindung mit einer Website herstellen, auf der Sie Dokumente und Bilder speichern können.

  4. Klicken Sie im Assistenten zum Hinzufügen von Netzwerkorten auf Weiter, klicken Sie auf Eine benutzerdefinierte Netzwerkressource auswählen, und klicken Sie dann auf Weiter.

  5. Geben Sie im Adressenfeld Internet- oder Netzwerkadresse die Adresse der FTP-Site ein (geben Sie z. B. ftp://ftp.microsoft.com ein), und klicken Sie dann auf Weiter.

    Hinweis : Wenn es Ihnen nicht gelingt, die Verbindung zu einem Netzwerklaufwerk oder Netzwerkordner herzustellen, ist der Computer möglicherweise abgeschaltet, oder Sie besitzen nicht die korrekten Berechtigungen. Wenden Sie sich an Ihren Netzwerkadministrator oder ISP, wenn sich die Verbindung nicht herstellen lässt.

  6. Wenn Sie sich nicht anonym anmelden möchten, deaktivieren Sie das Kontrollkästchen Anonym anmelden, geben den Benutzernamen in das Feld Benutzername ein und klicken dann auf Weiter.

  7. Geben Sie einen Namen für diesen Netzwerkspeicherort ein, und klicken Sie dann auf Weiter.

  8. Klicken Sie auf Fertig stellen.

Unter Microsoft Windows XP

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie in der Liste Speichern in auf den Pfeil, und klicken Sie dann auf FTP-Adressen.

  3. Doppelklicken Sie auf FTP-Adressen hinzufügen/ändern.

  4. Geben Sie im Feld Name der FTP-Site den FTP-Site-Namen ein. Geben Sie z. B. ftp.microsoft.com ein.

  5. Führen Sie einen der folgenden Vorgänge aus:

    • Wenn Sie sich bei einer FTP-Site anmelden möchten, die anonyme Anmeldungen toleriert, klicken Sie unter Anmelden als auf Anonym.

    • Wenn Sie sich bei einer FTP-Site anmelden, für die Sie über Benutzerberechtigungen verfügen, klicken Sie unter Anmelden als auf Benutzer und geben dann in das Feld Kennwort das Kennwort ein.

  6. Klicken Sie auf Hinzufügen.

  7. Klicken Sie auf OK.

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie in der Liste Speichern in auf FTP-Adressen.

  3. Doppelklicken Sie in der Liste der FTP-Sites auf die gewünschte Site, und doppelklicken Sie dann auf den Ordner, in dem Ihre Website veröffentlicht werden soll.

    Hinweis : Internetdienstanbieter ein bestimmtes Programm zum Uploaden der Website erfordert oder wenn Sie Ihre Website in einem Firmenintranet veröffentlichen, müssen Sie eine Version der Website in einem bestimmten HTML-Dateiformat speichern und andere Schritte zum Veröffentlichen Ihrer Website. Bitten Sie Ihren Internetdienstanbieter oder Systemadministrator Informationen speichern und Veröffentlichen Ihrer Website.

Veröffentlichen einer Website in einem Ordner auf dem eigenen Computer

In Windows Vista

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie auf der Adressleiste auf das Laufwerk oder den Ordner, in dem die Website veröffentlicht werden soll z. B. im Ordner Dokumente.

    Hinweis : Wenn Sie die Website einem neuen Ordner hinzufügen möchten, klicken Sie zum Erstellen eines neuen Ordners auf der Symbolleiste auf Neuer Ordner, geben einen Namen für den neuen Ordner ein und drücken dann die EINGABETASTE.

  3. Wählen Sie im Feld Dateiname den Namen index als Standardnamen für die Homepage aus, und klicken Sie auf Speichern.

    Hinweis : Index.htm ist die Standardauswahl. Wenn Sie index als Namen für die Homepage auswählen, wird der Zugriff auf die Homepage vereinfacht, und die Benutzer sehen keine Liste der Dateien, aus denen Ihre Website besteht.

In Windows XP

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie in der Liste Speichern in auf das Laufwerk oder den Ordner, in dem die Website veröffentlicht werden soll, z. B. im Ordner Eigene Dateien.

    Hinweis : Wenn Sie die Website einem neuen Ordner hinzufügen möchten, klicken Sie mit der rechten Maustaste an der Stelle, an der der neue Ordner hinzugefügt werden soll. Wählen Sie Neu aus, klicken Sie zum Erstellen eines neuen Ordners auf Ordner, geben Sie einen Namen für den neuen Ordner in das Feld Name ein, und klicken Sie dann auf Öffnen.

  3. Wählen Sie im Feld Dateiname den Namen index als Standardnamen für die Homepage aus, und klicken Sie auf Speichern.

    Hinweis : Index.htm ist die Standardauswahl. Wenn Sie index als Namen für die Homepage auswählen, wird der Zugriff auf die Homepage vereinfacht, und die Benutzer sehen keine Liste der Dateien, aus denen Ihre Website besteht.

Seitenanfang

Verwalten einer Website

Wenn Sie Ihre Website veröffentlicht haben, können Sie sie nach Bedarf aktualisieren, um sie auf dem neuesten Stand zu halten. Sie können gefilterte HTML-Dateien jedoch nicht in Publisher öffnen. Sie müssen die ursprüngliche Webpublikation öffnen, die gewünschten Änderungen vornehmen und die Website erneut im Web veröffentlichen.

Hinweis : Sie sollten nicht versuchen, die gefilterten HTML-Dateien mit einem Texteditor zu aktualisieren, z. B. in Microsoft Editor oder Microsoft WordPad. Dies ist zwar möglich, die von Publisher erzeugten HTML-Dateien sind jedoch sehr komplex, und das manuelle Bearbeiten wird Ihnen vermutlich schwer fallen. Um optimale Ergebnisse zu erzielen, sollten Sie eine Publisher-Website anhand der Webpublikation aktualisieren und sie dann erneut im Web veröffentlichen.

Veröffentlichen nur der Änderungen

In Office Publisher 2007 können Sie veröffentlichen eine zuvor veröffentlichten Website schnell mit inkrementellen Updates Veröffentlichen im Web, die nur die Seiten veröffentlicht, die Sie aktualisiert haben. Sollten Sie Ihre Website häufig aktualisieren oder ist Ihre Website große und komplexe, inkrementelle Publizieren im Web können Sie die Aufgabe der Aktualisierung Ihrer Website beschleunigen.

Wenn Sie zu Ihrer Website direkt auf eine Webserver außerhalb der Office Publisher 2007, jedoch einschalten inkrementelle im Web veröffentlichen ändern Sie möglicherweise Aktualisierungen der Website mit dem Befehl Veröffentlichen im Web veröffentlichen. Wenn Sie beabsichtigen, die Websitedateien direkt auf dem Webserver verwalten (z. B. über ein separates FTP Programm), Sie sollten deaktivieren inkrementelle Publizieren im Web.

Hinweis : Das inkrementelle Publizieren im Web ist standardmäßig in Publisher aktiviert.

Aktivieren und Deaktivieren des inkrementellen Publizierens im Web

  1. Klicken Sie im Menü Extras auf Optionen, und klicken Sie dann auf die Registerkarte Web.

  2. Führen Sie unter Speichern eine der folgenden Aktionen aus:

    • Zum Deaktivieren des inkrementellen Publizierens im Web deaktivieren Sie das Kontrollkästchen Inkrementelles Publizieren im Web aktivieren.

    • Zum Aktivieren des inkrementellen Publizierens im Web aktivieren Sie das Kontrollkästchen Inkrementelles Publizieren im Web aktivieren.

Veröffentlichen von Änderungen an einer Website

Das Veröffentlichen von Aktualisierungen an einer Website unterscheidet sich von der ersten Veröffentlichung der Website. Wenn Sie eine Website im Web oder in einem Netzwerk veröffentlicht haben, wird unter Netzwerkumgebung eine Verknüpfung zum entsprechenden Webserver bzw. Netzwerkserver angezeigt.

In Windows Vista

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie im Navigationsbereich im Dialogfeld Veröffentlichen im Web auf Computer.

  3. Doppelklicken Sie in der Dateiliste auf die Verknüpfung mit dem Ordner auf dem Webserver oder Netzwerkserver, auf dem Sie die Website veröffentlicht haben.

  4. Doppelklicken Sie auf den Ordner, in dem die Datei gespeichert werden soll.

  5. Geben Sie im Feld Dateiname den Namen der zu aktualisierenden Datei ein, und klicken Sie dann auf Speichern.

In Windows XP

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie im Dialogfeld Veröffentlichen im Web auf Netzwerkumgebung.

  3. Doppelklicken Sie auf die Verknüpfung mit dem Ordner auf dem Webserver oder Netzwerkserver, auf dem Sie die Website veröffentlicht haben.

  4. Doppelklicken Sie auf den Ordner, in dem die Datei gespeichert werden soll.

  5. Geben Sie im Feld Dateiname den Namen der zu aktualisierenden Datei ein, und klicken Sie dann auf Speichern.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×