Erstellen, Ausführen, Bearbeiten und Löschen eines Makros

Wenn Sie bei häufig ausgeführten Aufgaben Zeit sparen möchten, können Sie die Schritte dieser Aufgaben als Makro aufzeichnen. Wenn Sie dann eine dieser aufgezeichneten Aufgaben ausführen möchten, können Sie das Makro zur Ausführung der Schritte aktivieren.

Word

In Word 2016 für Mac können Sie ein Makro erstellen, das eine Tastenkombination aufweist, ein Makro ausführen und nicht mehr benötigte Makros löschen.

  1. Klicken Sie auf Ansicht > Makros > Makro aufzeichnen.

    Klicken Sie auf der Registerkarte "Ansicht" auf "Makro", und klicken Sie dann auf "Makro aufzeichnen", um mit dem Erstellen eines Makros zu beginnen.
  2. Geben Sie einen Namen für das Makro ein, oder übernehmen Sie den in Word angegebenen Standardnamen.

    Geben Sie einen Namen für Ihr Makro in "Makroname" ein, oder übernehmen Sie den generischen Namen, der von Word bereitgestellt wird.
  3. Wenn Sie dieses Makro in von Ihnen neu erstellten Dokumenten verwenden möchten, vergewissern Sie sich, dass in der Liste Makro speichern in der Eintrag Alle Dokumente (Normal) ausgewählt ist.

  4. Klicken Sie auf Tastatur, um dem Makro eine Tastenkombination zuzuweisen.

    In Word wird das Dialogfeld Tastatur anpassen angezeigt.

  5. Geben Sie im Feld Neue Tastenkombination drücken die gewünschte Tastenkombination ein.

    Word zeigt ggf., nachdem Sie eine Tastenkombination gedrückt haben, den Befehl oder das Makro an, der oder das der Tastenkombination bereits zugewiesen ist.

    Wenn Sie eine Tastenkombination drücken, wird in Word ggf. der dieser Tastenkombination aktuell zugewiesene Befehl oder die Aktion angezeigt.

  6. Wenn die von Ihnen ausgewählte Tastenkombination bereits zugewiesen ist, löschen Sie diese im Feld Neue Tastenkombination drücken, und wählen Sie dann eine neue Tastenkombination aus.

    Fahren Sie mit dem nächsten Schritt fort, nachdem Sie eine nicht zugewiesene Tastenkombination gefunden haben.

    Word kennzeichnet, wenn Sie eine Tastenkombination gedrückt haben, die noch keinem Befehl oder Makro zugeordnet ist.
  7. Wenn Sie diese Tastenkombination in allen neuen Dokumenten verwenden möchten, müssen Sie sicherstellen, dass in der Liste Änderungen speichern in die globale Vorlage Normal.dotm ausgewählt ist.

    Wählen Sie "Normal.dotm" aus, damit ein Makro in neuen Dokumenten verfügbar ist, die Sie erstellen.
  8. Klicken Sie auf Zuweisen.

  9. Klicken Sie auf OK, wenn Sie mit der Aufzeichnung des Makros beginnen möchten.

  10. Klicken Sie auf die Befehle, oder drücken Sie die Tasten für jeden Schritt der Aufgabe.

    Word zeichnet Ihre Mausklicks und Tastatureingaben auf. Text, den Sie mit der Maus markieren, wird jedoch nicht aufgezeichnet. Verwenden Sie die Tastatur, wenn Sie Text während der Aufzeichnung eines Makros markieren möchten.

  11. Um die Aufzeichnung zu beenden, klicken Sie auf Ansicht > Makros > Aufzeichnung beenden.

    Klicken Sie im Menü "Makros" auf "Aufzeichnung beenden", um das Aufzeichnen eines Makros zu beenden.

Um ein Makro auszuführen, drücken Sie die ihm zugewiesene Tastenkombination, oder führen Sie das Makro über die Liste Makros aus.

  1. Klicken Sie auf Ansicht > Makros > Makros anzeigen.

    Klicken Sie auf "Makros anzeigen", um Makros anzuzeigen und zu bearbeiten, die mit dem aktuellen Dokument verknüpft sind.
  2. Wählen Sie in der Liste unter Makroname das Makro aus, das Sie ausführen möchten.

  3. Klicken Sie auf Ausführen.

    Nachdem Sie unter "Makroname" ein Makro ausgewählt haben, klicken Sie auf "Ausführen", um es zu starten.

  1. Klicken Sie auf Ansicht > Makros > Makros anzeigen.

    Klicken Sie auf "Makros anzeigen", um Makros anzuzeigen und zu bearbeiten, die mit dem aktuellen Dokument verknüpft sind.
  2. Stellen Sie sicher, dass der von Makros in angegebene Speicherort den Speicherort des zu löschenden Makros enthält.

    Wählen Sie den Speicherort der Makros aus, die in der Liste "Makros in" angezeigt werden sollen.

    Die Liste enthält das im aktuellen Fenster geöffnete Dokument sowie die globale Vorlage und Word-Befehle.

  3. Wählen Sie unter Makroname das zu löschende Makro aus, und klicken Sie dann auf das Minuszeichen unterhalb der Liste.

    Wählen Sie das zu löschende Makro aus, und klicken Sie dann auf das Minuszeichen unterhalb der Liste.
  4. Wenn Sie in Word aufgefordert werden, das Löschen des Makros zu bestätigen, klicken Sie auf Ja.

Excel

In Excel 2016 für Mac können Sie ein Makro erstellen, das eine Tastenkombination aufweist, ein Makro ausführen und nicht mehr benötigte Makros löschen.

Wenn Sie ein Makro aufzeichnen, werden alle erforderlichen Schritte für die Aktionen, die vom Makro ausgeführt werden sollen, mit der Makroaufzeichnungsfunktion erfasst. Diese Schritte können das Eingeben von Text oder Zahlen, das Klicken auf Zellen oder Befehle im Menüband oder in Menüs, das Formatieren, das Markieren von Zellen, Zeilen oder Spalten sowie das Ziehen der Maus zum Markieren von Zellen auf dem Tabellenblatt umfassen.

Hinweis : Die Befehle zum Aufzeichnen, Erstellen und Löschen von Makros sowie weitere erweiterte Funktionen stehen außerdem auf der Registerkarte Entwicklertools im Menüband zur Verfügung. Weitere Informationen zur Verwendung der Registerkarte "Entwicklertools" finden Sie unter Verwenden der Registerkarte "Entwicklertools" zum Erstellen oder Löschen eines Makros in Excel 2016 für Mac.

  1. Wählen Sie Extras > Makro > Aufzeichnen aus.

    Wählen Sie "Extras", dann "Makro", dann "Neues Makro aufzeichnen" aus.

  2. Geben Sie im Feld Makroname einen Namen für das Makro ein.

    Geben Sie einen Makronamen, einen Speicherort und eine Tastenkombination ein.

  3. Geben Sie zum Erstellen einer Tastenkombination für das Makro einen Buchstaben in das Feld Wahltaste+Befehlstaste ein.

  4. Wählen Sie in der Dropdownliste einen Speicherort für das Makro aus.

    So speichern Sie das Makro

    Klicken Sie auf

    In dem Dokument, in dem das Makro erstellt wird

    Diese Arbeitsmappe

    In allen offenen Dokumenten

    Neue Arbeitsmappe

    Damit es bei jeder Verwendung von Excel verfügbar ist

    Persönliche Makroarbeitsmappe

  5. (Optional) Fügen Sie eine Beschreibung Ihres E-Mail-Kontos hinzu.

  6. Klicken Sie auf OK, wenn Sie mit der Aufzeichnung beginnen möchten.

  7. Klicken Sie auf die Befehle, oder drücken Sie die Tasten für jeden Schritt der Aufgabe.

  8. Wählen Sie zum Beenden der Aufzeichnung Extras > Makro > Aufzeichnung beenden aus. (Dieser Schritt wird nicht im Makro aufgezeichnet.)

    Wählen Sie "Aufzeichnung beenden" aus.

Um ein Makro auszuführen, drücken Sie die ihm zugewiesene Tastenkombination, oder führen Sie das Makro über das Dialogfeld Makros aus.

  1. Klicken Sie auf der Registerkarte Ansicht auf Makros anzeigen.

  2. Klicken Sie im Popupmenü auf Makros, und wählen Sie Diese Arbeitsmappe aus.

  3. Wählen Sie Ihr Makro aus der Liste aus, und klicken Sie auf Ausführen.

    Excel für Mac-Dialogfeld "Makro"

  1. Wählen Sie Extras > Makro > Makros aus.

    Wählen Sie "Makro" und anschließend "Makros" aus.

  2. Wählen Sie das zu löschende Makro aus, und drücken Sie dann auf das Minuszeichen.

    Wählen Sie den Makronamen und dann das Minuszeichen aus.

  3. Eine Bestätigungsmeldung wird angezeigt. Klicken Sie auf Ja, um den Löschvorgang zu bestätigen.

    Bestätigen des Löschvorgangs

Sie können ein Makro auch von der Registerkarte Entwicklertools löschen.

  1. Klicken Sie auf der Registerkarte Entwicklertools auf Makros.

  2. Klicken Sie in der Liste auf das zu löschende Makro und dann auf die Schaltfläche zum Löschen.

    Wählen Sie ein Makro aus, und klicken Sie auf das Minuszeichen, um es zu löschen.

Word

Zum Automatisieren einer sich wiederholenden Aufgabe können Sie schnell ein Makro in Word erstellen Sie können auch den Visual Basic-Editor in Microsoft Visual Basic for Applications verwenden, um ein eigenes Makroskript zu schreiben oder um ein ganzes Makro bzw. einen Teil davon in ein neues Makro zu kopieren.

Beim Aufzeichnen eines Makros werden alle Schritte, die zum Ausführen der Aktionen erforderlich sind, die von dem Makro ausgeführt werden sollen, aufgezeichnet. Die Navigation zurück zu der Registerkarte, um die Aufzeichnung zu beenden, wird aber nicht aufgezeichnet.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Aufzeichnen.

    Word-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Geben Sie in das Feld Makroname einen Namen für das Makro ein.

  3. Führen Sie im Popupmenü Makro speichern in eine der folgenden Aktionen aus:

    So speichern Sie das Makro

    Klicken Sie auf

    In dem Dokument, in dem das Makro erstellt wird

    [Dokumentname] (Dokument)

    In allen offenen Dokumenten

    Alle Dokumente (Normal)

  4. Klicken Sie auf OK, und führen Sie dann die Aktionen aus, die aufgezeichnet werden sollen.

  5. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Beenden.

Sie können den integrierten Visual Basic-Editor verwenden, um ein Makro zu erstellen.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Editor.

    Word-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Zum Einfügen eines Moduls klicken Sie im Visual Basic-Editor im Menü Einfügen auf Modul.

  3. Geben Sie im Codefenster des Moduls den zu verwendenden Makrocode ein, bzw. fügen Sie ihn ein.

  4. Klicken Sie, wenn Sie den Vorgang abgeschlossen haben, im Menü Word auf Schließen und zurück zu Microsoft Word.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    Word-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das auszuführende Makro und dann auf Ausführen.

Verwenden Sie zum Bearbeiten eines Makros den Visual Basic-Editor.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    Word-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu bearbeitende Makro und dann auf Bearbeiten.

    Der Visual Basic-Editor wird geöffnet.

  3. Nehmen Sie die gewünschten Änderungen vor.

  4. Klicken Sie, wenn Sie den Vorgang abgeschlossen haben, im Menü Word auf Schließen und zurück zu Microsoft Word.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    Word-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu kopierende Makro und dann auf Bearbeiten.

    Der Visual Basic-Editor wird geöffnet.

  3. Markieren Sie im Codefenster des Visual Basic-Editors die Zeilen des Makros, die Sie kopieren möchten.

    Tipp : Wenn Sie das gesamte Makro kopieren möchten, müssen Sie die Zeilen "Sub" und "End Sub" in die Markierung einbeziehen.

  4. Klicken Sie im Menü Bearbeiten auf Kopieren.

  5. Klicken Sie im Codefenster im Feld Projekt auf das Modul, in dem der Code abgelegt werden soll.

  6. Klicken Sie im Menü Bearbeiten auf Einfügen.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    Word-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu löschende Makro und dann auf Löschen.

PowerPoint

Um eine wiederkehrende Aufgabe zu automatisieren, können Sie Visual Basic for Applications verwenden, um ein Makro in PowerPoint zu erstellen.

Sie können den integrierten Visual Basic-Editor verwenden, um ein Makro zu erstellen.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Editor.

    PowerPoint-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Zum Einfügen eines Moduls klicken Sie im Visual Basic-Editor im Menü Einfügen auf Modul.

  3. Geben Sie im Codefenster des Moduls den zu verwendenden Makrocode ein, bzw. fügen Sie ihn ein.

  4. Klicken Sie, wenn Sie den Vorgang abgeschlossen haben, im Menü PowerPoint auf Schließen und zurück zu Microsoft PowerPoint.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    PowerPoint-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das auszuführende Makro und dann auf Ausführen.

Verwenden Sie zum Bearbeiten eines Makros den Visual Basic-Editor.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    PowerPoint-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu bearbeitende Makro und dann auf Bearbeiten.

    Der Visual Basic-Editor wird geöffnet.

  3. Nehmen Sie die gewünschten Änderungen vor.

  4. Klicken Sie, wenn Sie den Vorgang abgeschlossen haben, im Menü PowerPoint auf Schließen und zurück zu Microsoft PowerPoint.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    PowerPoint-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu kopierende Makro und dann auf Bearbeiten.

    Der Visual Basic-Editor wird geöffnet.

  3. Markieren Sie im Codefenster des Visual Basic-Editors die Zeilen des Makros, die Sie kopieren möchten.

    Tipp : Wenn Sie das gesamte Makro kopieren möchten, müssen Sie die Zeilen "Sub" und "End Sub" in die Markierung einbeziehen.

  4. Klicken Sie im Menü Bearbeiten auf Kopieren.

  5. Klicken Sie im Codefenster im Feld Projekt auf das Modul, in dem der Code abgelegt werden soll.

  6. Klicken Sie im Menü Bearbeiten auf Einfügen.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    PowerPoint-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu löschende Makro und dann auf Löschen.

Excel

Zum Automatisieren einer sich wiederholenden Aufgabe können Sie schnell ein Makro in Excel erstellen Sie können auch den Visual Basic-Editor in Microsoft Visual Basic for Applications verwenden, um ein eigenes Makroskript zu schreiben oder um ein ganzes Makro bzw. einen Teil davon in ein neues Makro zu kopieren.

Alle Schritte, die zum Ausführen der Aktionen erforderlich sind, die von dem Makro ausgeführt werden sollen, werden aufgezeichnet. Die Navigation zurück zu der Registerkarte, um die Aufzeichnung zu beenden, wird aber nicht aufgezeichnet.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Aufzeichnen.

    Excel-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Geben Sie in das Feld Makroname einen Namen für das Makro ein.

    Tipp : Geben Sie zum Erstellen einer Tastenkombination für das Makro einen Buchstaben in das Feld Wahltaste+Befehlstaste+ ein.

  3. Führen Sie im Popupmenü Makro speichern in eine der folgenden Aktionen aus:

    So speichern Sie das Makro

    Klicken Sie auf

    In dem Dokument, in dem das Makro erstellt wird

    Diese Arbeitsmappe

    In allen offenen Dokumenten

    Neue Arbeitsmappe

    Damit es bei jeder Verwendung von Excel verfügbar ist

    Persönliche Makroarbeitsmappe

    Die persönliche Makroarbeitsmappe befindet sich unter "Benutzer/Benutzername/Library/Anwendungsunterstützung/Microsoft/Office/Excel".

  4. Klicken Sie auf OK, und führen Sie dann die Aktionen aus, die aufgezeichnet werden sollen.

  5. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic erneut auf Aufzeichnen.

Sie können den integrierten Visual Basic-Editor verwenden, um ein Makro zu erstellen.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Editor.

    Excel-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Zum Einfügen eines Moduls klicken Sie im Visual Basic-Editor im Menü Einfügen auf Modul.

  3. Geben Sie im Codefenster des Moduls den zu verwendenden Makrocode ein, bzw. fügen Sie ihn ein.

  4. Klicken Sie, wenn Sie den Vorgang abgeschlossen haben, im Menü Excel auf Schließen und zurück zu Microsoft Excel.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    Excel-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das auszuführende Makro und dann auf Ausführen.

    Tipp : Zum Ausführen eines Makros mithilfe einer Tastenkombination drücken Sie WAHLTASTE + BEFEHL + den Buchstaben, den Sie beim Erstellen der Tastenkombination eingegeben haben.

Verwenden Sie zum Bearbeiten eines Makros den Visual Basic-Editor.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    Excel-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu bearbeitende Makro und dann auf Bearbeiten.

    Der Visual Basic-Editor wird geöffnet.

  3. Nehmen Sie die gewünschten Änderungen vor.

  4. Klicken Sie, wenn Sie den Vorgang abgeschlossen haben, im Menü Excel auf Schließen und zurück zu Microsoft Excel.

Nachdem Sie dieses Verfahren abgeschlossen haben, wird das Makro bei jedem Öffnen der Arbeitsmappe, die das Makro enthält, ausgeführt.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Aufzeichnen.

    Excel-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Geben Sie im Feld Makroname den Namen Auto_öffnen ein.

  3. Führen Sie im Popupmenü Makro speichern in eine der folgenden Aktionen aus:

    So speichern Sie das Makro

    Klicken Sie auf

    In dem Dokument, in dem das Makro erstellt wird

    Diese Arbeitsmappe

    In allen offenen Dokumenten

    Neue Arbeitsmappe

    Damit es bei jeder Verwendung von Excel verfügbar ist

    Persönliche Makroarbeitsmappe

  4. Klicken Sie auf OK, und führen Sie dann die Aktionen aus, die aufgezeichnet werden sollen.

  5. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic erneut auf Aufzeichnen.

  6. Klicken Sie im Menü Datei auf Speichern unter.

  7. Klicken Sie im Popupmenü Format auf Excel-Arbeitsmappe mit Makros (.xlsm), und klicken Sie dann auf Speichern.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    Excel-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu kopierende Makro und dann auf Bearbeiten.

    Der Visual Basic-Editor wird geöffnet.

  3. Markieren Sie im Codefenster des Visual Basic-Editors die Zeilen des Makros, die Sie kopieren möchten.

    Tipp : Wenn Sie das gesamte Makro kopieren möchten, müssen Sie die Zeilen "Sub" und "End Sub" in die Markierung einbeziehen.

  4. Klicken Sie im Menü Bearbeiten auf Kopieren.

  5. Klicken Sie im Codefenster im Feld Projekt auf das Modul, in dem der Code abgelegt werden soll.

  6. Klicken Sie im Menü Bearbeiten auf Einfügen.

  1. Klicken Sie auf der Registerkarte Entwicklertools unter Visual Basic auf Makros.

    Excel-Registerkarte "Entwicklertools", Gruppe "Visual Basic"

    Wenn die Registerkarte "Entwicklertools" nicht verfügbar ist

    1. Klicken Sie auf der rechten Seite des Menübands auf  Popupmenü "Aktion" , und klicken Sie dann auf Menübandeinstellungen.

    2. Aktivieren Sie unter Anpassen das Kontrollkästchen Entwicklertools.

  2. Klicken Sie in der Liste auf das zu löschende Makro und dann auf Löschen.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×