Anmelden

Erste Schritte mit SharePoint Designer 2010

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Microsoft SharePoint Designer 2010 ist eine Website und Anwendung Quellprogramm mit dem Entwerfen, erstellen, und Anpassen von Websites, die auf SharePoint Foundation 2010 und Microsoft SharePoint Server 2010 ausgeführt. Mit SharePoint Designer 2010 können Sie Daten umfangreicher Webseiten erstellen, erstellen leistungsfähige Workflow aktiviert Lösungen und das Aussehen und Verhalten Ihrer Website entwerfen.

Verwenden Sie den nachstehenden Links, um weitere Informationen zur SharePoint Designer 2010 bis Artikeln, Videos und andere Lernressourcen. Verwenden Sie die folgenden Verfahren lernen die grundlegenden Aufgaben, die Sie in SharePoint Designer 2010 ausführen.

Logo 'Erste Schritte'

Was Sie WAN- t

Wobei bis g o

Benötigen Sie nur Informationen über Änderungen?   

Die Neuerungen in dieser Version kennenlernen und erfahren, wie sie optimal genutzt werden können.

Neuerungen in SharePoint Designer 2010

Suchen Sie Menüs und Befehle der 2007-er Version?   

Eine Tabelle mit Menü- und Symbolleistenbefehlen in der 2007-er Version anzeigen und ihre neuen Positionen mithilfe dieser Zuordnungstabelle kennenlernen.

Zuordnungshilfen für Microsoft Office-Anwendungen

Sie haben noch nie mit SharePoint Designer gearbeitet?   

Erfahren Sie, welche SharePoint Designer 2010 Akzente ist und wie Sie es in Ihrer Organisation optimal.

Einführung in SharePoint Designer 2010

Sie suchen Schulungsmöglichkeiten für sich und andere Mitglieder Ihres Teams?   

Somit produktiver in dieser Version mit Schulung auf SharePoint Designer 2010.

Microsoft Office-Schulungen

Grundlegende Aufgaben in SharePoint Designer 2010

Öffnen und Erstellen von SharePoint-Websites

Erstellen von Listen, Bibliotheken und Verbindungen zu Datenquellen

Erstellen benutzerdefinierter Ansichten und Formulare

Erstellen benutzerdefinierter Workflows

Entwerfen von Websiteseiten, Gestaltungsvorlagen und Seitenlayouts

Speichern als Vorlage

Öffnen und Erstellen von SharePoint-Websites

In SharePoint Designer 2010 Sie können vorhandene SharePoint-Websites auf dem Server, und starten sie anpassen öffnen, und Sie können erstellen neue Websites basierend auf SharePoint-Websitevorlagen oder neue, leere Websites, die Sie von Grund auf anpassen.

Öffnen von Websites

Klicken Sie zum Öffnen einer vorhandenen Website auf die Registerkarte Datei, wählen Sie Websites aus, und führen Sie einen der folgenden Schritte aus:

  • Klicken Sie auf Website öffnen, um die auf dem Server verfügbaren Websites zu durchsuchen.

  • Klicken Sie auf "Meine Website" anpassen, um Ihre eigene Website zu öffnen und anzupassen.

  • Wählen Sie unter Zuletzt geöffnete Websites eine Website aus, die Sie vor kurzem bearbeitet haben.

Erstellen von Websites

Klicken Sie zum Erstellen einer neuen Website auf die Registerkarte Datei, wählen Sie Websites aus, und führen Sie einen der folgenden Schritte aus:

  • Klicken Sie auf Neue leere Website, um eine leere SharePoint-Website zu erstellen.

  • Klicken Sie auf Unterwebsite zu "Meine Website" hinzufügen, um unter Meine Website eine neue Website zu erstellen.

  • Wählen Sie unter Websitevorlagen einer Vorlage zur Erstellung einer neuen Website basierend auf einer SharePoint-Vorlage aus.

Hinweis : Zusätzlich zu öffnen, und Erstellen von Websites SharePoint Designer 2010, können Sie eine SharePoint-Website mit Ihrem Browser zu öffnen und öffnen Sie die Website in SharePoint Designer 2010 mit den verfügbaren Links im Menü Websiteaktionen, klicken Sie im Menüband und anderen Speicherorten in SharePoint.

Seitenanfang

Erstellen von Listen, Bibliotheken und Verbindungen zu Datenquellen

Sie können Listen und Bibliotheken, die häufig als Datenquelle für SharePoint-Websites dienen, erstellen SharePoint Designer 2010 und Sie können datenquellenverbindungen XML-Dateien, externe Datenbanken und Webdienste erstellen.

SharePoint-Listen und -Bibliotheken

Klicken Sie zum Erstellen einer SharePoint-Liste oder -Bibliothek im Navigationsbereich auf Listen und Bibliotheken, und wählen Sie anschließend auf der Registerkarte Listen und Bibliotheken eine der folgenden Optionen aus:

  • Klicken Sie auf Benutzerdefinierte Liste, um eine leere Liste von Grund auf zu erstellen.

  • Klicken Sie auf SharePoint-Liste, um eine Liste basierend auf einer SharePoint-Listenvorlage zu erstellen.

  • Klicken Sie auf Dokumentbibliothek, um eine Bibliothek basierend auf einer SharePoint-Bibliotheksvorlage zu erstellen.

  • Klicken Sie auf Externe Liste, um eine externe Liste basierend auf einem externen Inhaltstyp zu erstellen. (Externe Inhaltstypen werden weiter unten vorgestellt.)

  • Klicken Sie auf Liste aus Tabellenkalkulation, um eine Liste basierend auf einer importierten Tabelle zu erstellen.

Datenquellenverbindungen

Klicken Sie zum Erstellen einer Datenquellenverbindung im Navigationsbereich auf Datenquellen, und wählen Sie anschließend auf der Registerkarte Datenquellen eine der folgenden Optionen aus:

  • Klicken Sie auf Verknüpfte Datenquelle, um eine Datenverbindung zu mehreren Datenquellen einzurichten.

  • Klicken Sie auf Datenbankverbindung, um eine Verbindung zu einer Datenbank einzurichten, die das OLE DB- oder ODBC-Protokoll unterstützt.

  • Klicken Sie auf SOAP-Dienstverbindung, um über SOAP (Simple Object Access Protocol) eine Verbindung zu einem XML-Webdienst einzurichten.

  • Klicken Sie auf REST-Dienstverbindung, um über REST (Representational State Transfer) eine Verbindung zu einem serverseitigen Skript herzustellen.

  • Klicken Sie auf XML-Dateiverbindung, um eine Verbindung zu einer XML-Quelldatei herzustellen.

Externe Inhaltstypen

Mithilfe externer Inhaltstypen können Sie eine Verbindung mit zahlreichen Datenquellen herstellen und diese Daten dann in die SharePoint-Website und unterstützten Office-Clientprogramme integrieren. Nach Erstellen eines externen Inhaltstyps können Sie externe Listen anlegen, die den Benutzer eine Interaktion mit den Daten ermöglichen, als handele es sich um eine SharePoint-Liste oder -Bibliothek.

Führen Sie zum Erstellen eines externen Inhaltstyp die folgenden Schritte aus.

  1. Klicken Sie im Navigationsbereich auf Externe Inhaltstypen.

  2. Klicken Sie auf der Registerkarte Externe Inhaltstypen auf Externer Inhaltstyp, und entwerfen Sie anschließend die Vorgänge, Felder usw. für den externen Inhaltstyp.

Seitenanfang

Erstellen benutzerdefinierter Ansichten und Formulare

In SharePoint Designer 2010 können Sie benutzerdefinierte Ansichten und Formulare für Ihre Datenquellen erstellen, die Benutzeroberfläche zum Lesen und Schreiben von Daten in diesen Datenquellen wirklich verwendet werden.

Ansichten

Eine Ansicht ist eine anpassbare live Anzeige einer Datenquelle, die auf einer beliebigen SharePoint-Seite hinzugefügt werden können. In SharePoint Designer 2010 können Sie erstellen, Listenansichten (die die XSLT-Listenansicht-Webpart verwenden zu können) und Datenansichten (die das Datenformular-Webpart verwenden zu können). Führen Sie eine der folgenden Schritte zum Erstellen einer Liste oder Daten-Ansicht.

  • Klicken Sie im Navigationsbereich auf Listen und Bibliotheken, wählen Sie die Liste aus, für die Sie eine Ansicht erstellen möchten, und klicken Sie dann auf der Registerkarte Listeneinstellungen auf Listenansicht.

    Hinweis : Dadurch wird eine Ansicht erstellt, die der Liste oder Bibliothek zugeordnet ist. Den Benutzern wird die Ansicht angezeigt, die sie auf dem SharePoint-Menüband über die Gruppe Ansichten verwalten anzeigen und ändern können.

  • Klicken Sie im Navigationsbereich auf Websiteseiten, bearbeiten Sie die Seite, auf der Sie die Ansicht erstellen möchten, klicken Sie auf die Registerkarte Einfügen, wählen Sie Datenansicht aus, und wählen Sie dann die SharePoint-Liste oder -Bibliothek aus, die Sie für die Ansicht verwenden möchten.

Formulare

Ein Formular ist eine anpassbare Anzeige einer Datenquelle, die Sie übermitteln, oder Schreiben Sie in der Datenquelle zurück. In SharePoint Designer 2010 können Sie erstellen, Listenformulare und Datenformularen (beide über das Datenformular-Webpart verwenden). Führen Sie eine der folgenden Schritte zum Erstellen eines Formulars Liste oder Daten.

  • Klicken Sie im Navigationsbereich auf Listen und Bibliotheken, wählen Sie die Liste aus, für die Sie ein Formular erstellen möchten, und klicken Sie dann auf der Registerkarte Listeneinstellungen auf Listenformular.

  • Klicken Sie im Navigationsbereich auf Websiteseiten, bearbeiten Sie die Seite, auf der Sie das Formular erstellen möchten, klicken Sie auf die Registerkarte Einfügen, wählen Sie Formular für neuen Eintrag, Formular zum Ändern eines Eintrags oder Formular zum Anzeigen eines Eintrags aus, und wählen Sie dann die Datenquelle aus, die Sie für das Formular verwenden möchten.

Hinweis : Sie können zusätzlich zu den Entwurfstools Formular in SharePoint Designer 2010 verwenden, erstellen und Anpassen von SharePoint-Formularen mit Microsoft InfoPath 2010.

Seitenanfang

Erstellen benutzerdefinierter Workflows

In SharePoint Designer 2010 können Sie von Geschäftsprozessen mit hochgradig angepasste Workflows verwalten. Workflows können zum Verwalten von Anwendungsprozessen sowie personenbezogenen Prozessen für die Zusammenarbeit verwendet werden. Beim Erstellen von Workflows, stehen Ihnen eine Reihe von Optionen.

Erstellen von Workflows in SharePoint Designer 2010

Beim Erstellen eines Workflows können Sie ihn auf einer SharePoint-Liste oder - Bibliothek basieren lassen. Sie können einen wieder verwendbaren Workflow erstellen, der einer beliebige Liste oder Bibliothek zugeordnet werden kann. Oder Sie können einen Website-Workflow einrichten, der auf Websiteebene funktioniert.

Klicken Sie zum Erstellen dieser Workflows im Navigationsbereich auf Workflows, und führen Sie anschließend auf der Registerkarte Workflows einen der folgenden Schritte aus:

  • Klicken Sie auf Listenworkflow, und wählen Sie die Liste aus, der Sie den Workflow zuordnen möchten.

  • Klicken Sie auf Wieder verwendbarer Workflow, um einen wieder verwendbaren Workflow zu erstellen, der einer beliebigen Liste oder Bibliothek zugeordnet werden kann.

  • Klicken Sie auf Website-Workflow, um einen Workflow zu erstellen, der auf Websiteebene zugeordnet werden kann.

Verwenden Sie nach Erstellen des Workflows den Workflow-Designer, um die Bedingungen, Aktionen und Schritte im Workflow zu strukturieren. Im Aufgaben-Designer können Sie die zu den einzelnen Aufgaben gehörenden Ereignisse verwalten.

Importieren von Workflows aus Microsoft Visio 2010

Zusätzlich zum Erstellen von Workflows in SharePoint Designer 2010, können Sie einen Workflow in Microsoft Visio 2010 unter Verwendung des bereitgestellten Workflow Schablonen und Vorlagen entworfenen importieren.

Klicken Sie zum Importieren eines Workflows im Navigationsbereich auf Workflows, und führen Sie anschließend auf der Registerkarte Workflows die folgenden Schritte aus:

  1. Klicken Sie auf Aus Visio importieren, und suchen Sie dann in Ihrem Dateisystem oder der SharePoint-Dokumentbibliothek die Visio Workflow Interchange-Datei (.vwi).

  2. Verknüpfen Sie den Workflow mit einer Liste, oder richten Sie ihn als wieder verwendbaren Workflow ein, und klicken Sie Fertig stellen

  3. Beginnen Sie mit der Anpassung des Workflows in SharePoint Designer.

Seitenanfang

Entwerfen von Websiteseiten, Gestaltungsvorlagen und Seitenlayouts

Sie können in SharePoint Designer 2010 erstellen und Anpassen von Websiteseiten, Gestaltungsvorlagen und Seitenlayouts. Während Sie jede dieser Seiten mit einen anderen Zweck dient, ähnelt die Seite Erfahrung bearbeiten. Sie können hinzufügen und Entfernen von Text, Bilder, Links, Tabellen, Webparts, Serversteuerelemente und vieles mehr. Anwenden von Definitionen der Formatvorlagen und Cascading Stylesheets auf Ihre Gestaltungsvorlagen und Seitenlayouts ändern das Aussehen und Verhalten Ihrer Website oder kennzeichnen, um Ihre Identität Ihres Unternehmens zu entsprechen.

Websiteseiten

Klicken Sie zum Erstellen einer Websiteseite im Navigationsbereich auf Websiteseiten, und führen Sie anschließend auf der Registerkarte Seiten einen der folgenden Schritte aus:

  • Klicken Sie auf Webpartseite, um eine Seite zu erstellen, die über Kopfzeilen- und Textkörper-Webparts verfügt und darüber hinaus der Gestaltungsvorlage Ihrer Website zugeordnet ist.

  • Klicken Sie auf Seite, und wählen Sie ASPX oder HTML, um eine leere Websiteseite zu erstellen, die nicht der Gestaltungsvorlage Ihrer Website zugeordnet ist.

Gestaltungsvorlagen

  • Klicken Sie auf im Navigationsbereich auf Gestaltungsvorlagen und anschließend auf der Registerkarte Gestaltungsvorlagen auf Leere Gestaltungsvorlage.

Seitenlayouts

  • Klicken Sie im Navigationsbereich auf Seitenlayouts, dann auf der Registerkarte Seitenlayouts auf Neues Seitenlayout, und wählen Sie dann die Inhaltstypgruppe samt Namen aus, auf der das Seitenlayout basieren soll.

Hinweis : Gestaltungsvorlagen und Seitenlayouts sind für alle Benutzer mit Ausnahme der Websitesammlungs-Administratoren standardmäßig deaktiviert. Wenn Sie die Option zum Anzeigen oder Bearbeiten von Gestaltungsvorlagen oder Seitenlayouts in SharePoint Designer 2010 angezeigt werden, wenden Sie sich an den Administrator dieser Website über das Aktivieren dieser Optionen.

Seitenanfang

Speichern als Vorlage

Sobald Sie die Anpassung Ihrer Website abgeschlossen haben, können Sie die Website vollständig oder teilweise als Vorlage speichern, sodass andere Benutzer in Ihrer Organisation die Vorlage zum Erstellen von u. a. Listen, Ansichten, Workflows und Websiteseiten nutzen können.

Mithilfe der Vorlage können Sie die Website in einer anderen Umgebung bearbeiten oder von anderen Benutzern anpassen lassen, z. B. im Webbrowser oder in Microsoft Visual Studio.

Suchen Sie nach die Option als Vorlage speichern in SharePoint Designer 2010 diese Funktionen nutzen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.



War diese Information hilfreich?

Wie können wir es verbessern?

Wie können wir es verbessern?

Um Ihre Privatsphäre zu schützen, geben Sie bitte keine Kontaktinformationen in Ihrem Feedback an. Lesen Sie unsere Datenschutzbestimmung.

Vielen Dank für Ihr Feedback!