Erste Schritte beim Abrufen und Transformieren von Daten in Excel 2016

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Mit Abrufen und transformieren in Excel 2016 können Sie nach Datenquellen suchen, Verbindungen herstellen und diese Daten dann Ihren jeweiligen Anforderungen entsprechend modellieren (z. B. eine Spalte entfernen, einen Datentyp ändern oder Tabellen zusammenführen). Nachdem Sie Ihre Daten modelliert haben, können Sie Ihre Ergebnisse freigeben oder Ihre Abfrage zum Erstellen von Berichten verwenden.

Power Query allgemeinen Schritte

Diese Schritte erfolgen häufig in der folgenden Reihenfolge:

  • Verbinden: Stellen Sie Verbindungen mit Daten her, die sich in der Cloud, in einem Dienst oder in einem lokalen Verzeichnis befinden.

  • Transformieren: Modellieren Sie die Daten gemäß Ihren Anforderungen. Die ursprüngliche Quelle bleibt unverändert.

  • Kombinieren: Erstellen Sie ein Datenmodell aus mehreren Datenquellen, und erhalten Sie einen einzigartigen Einblick in die Daten.

  • Freigeben: Nach Abschluss Ihrer Abfrage können Sie die Abfrage speichern, freigeben oder für Berichte verwenden.

Jedes Mal, wenn Sie eine Verbindung mit Daten herstellen, Daten transformieren oder sie mit anderen Datenquellen kombinieren, wird jeder einzelne Schritt von einem Feature von Abrufen und transformieren namens Abfrage-Editor aufgezeichnet, und Sie können jeden Schritt auf die erforderliche Weise ändern. Der Abfrage-Editor bietet außerdem die Möglichkeit, jeden Schritt rückgängig zu machen, zu wiederholen, zu ändern oder die Reihenfolge der Schritte zu ändern, sodass Sie die gewünschte Ansicht der verbundenen Daten modellieren können.

Mit Abrufen und transformieren können Sie je nach Bedarf einfache oder komplexe Abfragen erstellen. Wenn Sie Schritte zu einer Abfrage hinzufügen, erstellt der Abfrage-Editor im Hintergrund eine Reihe von Einzelanweisungen zum Ausführen Ihrer Befehle. Diese Anweisungen werden in der Sprache M erstellt. Benutzer, die die Leistungsfähigkeit und Flexibilität der Datenskripterstellung nutzen, können mithilfe von Erweiterter Editor die Sprache M zum manuellen Erstellen (oder Optimieren) von Abfragen verwenden. Diese Leistungsfähigkeit und Flexibilität – ob beim automatischen oder manuellen Erstellen von Schritten –ist Bestandteil der Sammlung von Features unter Abrufen und transformieren in Excel 2016. Abfrage-Editor und Erweiterter Editor werden weiter unten in diesem Artikel ausführlicher beschrieben.

Sie können eine neue Abfrage starten, indem Sie in der Gruppe Abrufen und transformieren im Menüband von Excel 2016 auf die Schaltfläche Neue Abfrage klicken.

Neue Abfrage in Excel 2016

Hinweis : Diese Technologie steht auch für frühere Versionen von Excel mit dem Power Query-Add-In, das als Download verfügbar ist, sowie in Power BI bereit. Das Verwenden von Power Query in früheren Versionen von Excel wird unter Erste Schritte mit Power Query gezeigt.

Verbinden

Sie können mithilfe einer Abfrage eine Verbindung mit einer einzelnen Datenquelle (beispielsweise mit einer Access-Datenbank) herstellen, oder Sie können eine Verbindung mit mehreren Dateien, Datenbanken, OData-Feeds oder Websites herstellen, die sich im Internet befinden. Mit Abrufen und transformieren können Sie dann alle diese Quellen zusammenbringen und dabei Ihre eigenen eindeutigen Kombinationen verwenden und Erkenntnisse aufdecken, die Sie ansonsten nicht hätten erzielen können.

Wenn Sie Neue Abfrage im Menübandabschnitt Abrufen und transformieren auf der Registerkarte Daten auswählen, werden die verfügbaren Datenquellen in einem Menü angezeigt. Es steht eine Vielzahl von Datenquellen zur Auswahl. Dazu gehören Dateien, wie z. B. Excel-Arbeitsmappen oder CSV-Dateien, Datenbanken, wie Access, SQL Server, Oracle und MySQL, Azure-Dienste, wie HDInsight oder BLOB-Speicher, sowie alle möglichen anderen Quellen, z. B. das Web, SharePoint-Listen, Hadoop-Dateien, Facebook, Salesforce und viele andere.

Hinweis : Einige Datenquellen stehen nur bei Professional- und Professional Plus-Lizenzen zur Verfügung.

Datenquellen für Abfrage

Beim Herstellen einer Verbindung mit einer Datenquelle zeigt Abrufen und transformieren ein Fenster mit Namen Navigator an, in dem Sie die Daten aus der Quelle bearbeiten können. Wenn Sie im Fenster Navigator die Option Bearbeiten auswählen, startet Abrufen und transformieren den Abfrage-Editor, ein dediziertes Fenster für die vereinfachte Herstellung von Datenverbindungen, in dem Ihre Datenverbindungen und die von Ihnen angewendeten Transformationen angezeigt werden. Im nächsten Abschnitt (Transformieren) finden Sie weitere Informationen zum Abfrage-Editor.

Transformieren

Mit Abrufen und transformieren können Sie die Daten aus Ihren Datenquellen so transformieren, dass Sie die Daten besser analysieren können. Transformieren von Daten bedeutet, dass Sie die Daten gemäß Ihren Anforderungen ändern können. So könnten Sie beispielsweise eine Spalte entfernen, einen Datentyp ändern oder Tabellen zusammenführen. Jede dieser Aktionen stellt eine Datentransformation dar. Beim Transformieren der Daten nehmen diese kollektiv die Form an, die Sie für die weiterführende Analyse benötigen. Das Anwenden von Transformationen auf eine oder mehrere Gruppen von Daten wird häufig Modellieren von Daten genannt.

Excel verwendet ein dediziertes Fenster namens Abfrage-Editor, um Datentransformationen zu vereinfachen und anzuzeigen. Wenn Sie auf der Registerkarte Daten im Menübandabschnitt Abrufen und transformieren die Option Neue Abfrage und dann die Datenquelle auswählen (z. B. eine Arbeitsmappe oder eine Datenbank), wird das Fenster Navigator angezeigt, in dem Sie auswählen können, welche Tabelle (oder Tabellen) in Ihrer Abfrage verwendet werden soll. Wenn Sie eine Tabelle auswählen, wird eine Vorschau der entsprechenden Daten im rechten Bereich des Fensters Navigator angezeigt.

Abfragenavigator

Wenn Sie Laden auswählen, wird die Datenquelle direkt in Excel übernommen. In diesem Fall wird Bearbeiten ausgewählt, um den Abfrage-Editor zu starten.

Abfrage-Editor

Der Abfrage-Editor verfolgt alle Schritte, die Sie mit den Daten ausführen. Vom Abfrage-Editor wird jede Transformation (oder jeder Schritt) aufgezeichnet und beschriftet, die (oder den) Sie auf die Daten anwenden. Ganz gleich, ob es sich bei der Transformation um eine Datenverbindung (Datenquelle), das Entfernen einer Spalte, eine Zusammenführung oder eine Datentypänderung handelt, der Abfrage-Editor verfolgt jeden Vorgang im Abschnitt ANGEWENDETE SCHRITTE (im Bereich Abfrageeinstellungen).

Die Transformationen, die Sie auf Ihre Datenverbindungen anwenden, bilden zusammen die Abfrage.

Es ist wichtig (und hilfreich) zu wissen, dass sich durch die im Abfrage-Editor definierten Aktionen die ursprünglichen Quelldaten nicht ändern. Stattdessen zeichnet Excel jeden Schritt auf, den Sie beim Herstellen einer Verbindung oder beim Transformieren der Daten ausführen. Wenn Sie mit dem Modellieren der Daten fertig sind, wird eine Momentaufnahme der optimierten Daten erstellt und in die Arbeitsmappe eingefügt.

Es gibt sehr viele Transformationen, die Sie auf Daten anwenden können. Sie können auch eigene Transformationen in der Sprache M (wird vom Abfrage-Editor zum Aufzeichnen der Schritte im Hintergrund verwendet) mithilfe von Erweiterter Editor des Abfrage-Editors schreiben. Sie können Erweiterter Editor im Menüband des Abfrage-Editors über Ansicht öffnen. Dort können Sie die mit der vorhandenen Abfrage verbundenen Schritte in der Sprache M ändern. Mit Erweiterter Editor können Sie auch Abfragen ganz neu erstellen.

Erweiterter Editor für Abfrage

Wenn Sie die Abfrage erstellt haben, können Sie Schließen & laden auf der Registerkarte Start im Menüband auswählen. Die Ergebnisse der Abfrage werden dann in Excel geladen und sind auf einem neuen Arbeitsmappenregister verfügbar.

Weitere Informationen zum Transformieren finden Sie hier:

Freigeben

Beim Speichern einer Excel-Arbeitsmappe, die eine Abfrage enthält, wird die Abfrage ebenfalls automatisch gespeichert. Sie können alle Abfragen in einer Excel-Arbeitsmappe anzeigen, indem Sie auf der Registerkarte Daten im Menübandabschnitt Abrufen und transformieren die Option Abfragen anzeigen auswählen.

Abfragen anzeigen

Im Bereich Arbeitsmappenabfragen werden alle in der Arbeitsmappe enthaltenen Abfragen angezeigt.

Arbeitsmappenabfragen in Excel 2016

Aber das ist längst noch nicht alles! Mit dem Power BI-Datenkatalog können Sie Ihre Abfragen für andere Personen in Ihrer Organisation freigeben. Sie können auch eine häufig verwendete Abfrage erstellen und sie dann in mehreren Arbeitsmappen verwenden und sich so viel Arbeit sparen. Statt Excel-Arbeitsmappen zu speichern und per E-Mail zu senden (und sich den Kopf darüber zu zerbrechen, welche Version das Original ist, was geändert wurde oder ob die enthaltenen Daten veraltet sind), können Sie eine Abfrage im Datenkatalog speichern und sich so den Ärger mit unzähligen nicht verfolgten Arbeitsmappenversionen sparen, die den Posteingang überfüllen. Klicken Sie einfach im Bereich Arbeitsmappenabfragen mit der rechten Maustaste auf eine Abfrage, und es wird ein Menü mit vielen verschiedenen Optionen (einschließlich An Datenkatalog senden) angezeigt.

An Datenkatalog senden

Beachten Sie auch die anderen Optionen des Kontextmenüs. Sie können eine Abfrage duplizieren, sodass Sie bestimmte (oder alle) Elemente einer Abfrage ändern können, ohne die ursprüngliche Abfrage zu ändern. Das ist mit dem Erstellen einer Abfragevorlage vergleichbar, die Sie dann ändern können, um benutzerdefinierte DataSets zu erstellen – z. B. ein DataSet für den Einzelhandel, ein weiteres DataSet für den Großhandel und ein DataSet für den Bestand –, die alle auf denselben Datenverbindungen basieren.

Sie können auch Abfragen zusammenführen oder anfügen, sodass Sie Abfragen in wiederverwendbare Bausteine umwandeln können.

Sie können Ihre Arbeitsmappe auch in Power BI veröffentlichen und Onlineberichte erstellen, die für Ihre Gruppe freigegeben, automatisch aktualisiert und optimiert werden können. Zum Veröffentlichen einer Arbeitsmappe in Power BI wählen Sie Datei > Veröffentlichen > In Power BI veröffentlichen aus. In Power BI veröffentlichen

Hinweis : Die Arbeitsmappe muss auf OneDrive for Business gespeichert sein, um in Power BI veröffentlicht werden zu können.

Nach Abschluss Ihrer Abfrage können Sie diese zum Erstellen von Berichten in Excel oder in Power BI verwenden. Beachten Sie den folgenden Abschnitt, um mehr über die Berichterstellungsressourcen zu erfahren, mit denen Sie Ihre gute Arbeit nutzen können, die Sie beim Modellieren der Daten mithilfe der Funktionen von Abrufen und transformieren geleistet haben.

Weitere Informationen zu Freigeben:

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×