Ermitteln von Fehlern in Formeln

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Fehler in Formeln können manchmal nicht nur zu unerwünschten Ergebnissen, sondern auch zu Fehlerwerten führen. Es folgt eine Aufstellung von Tools, mit denen Sie die Ursachen für diese Fehler suchen und analysieren sowie Lösungen ermitteln können.

Hinweis : Dieses Thema enthält Techniken, mit denen Sie Formelfehler korrigieren können. Die Liste ist keine vollständige Aufstellung der Methoden zum Beheben aller möglichen Formelfehler. Um Hilfe zu bestimmten Fehlern zu erhalten, können Sie das Excel-Communityforum nach Fragen wie der Ihren durchsuchen oder eine eigene Frage stellen.

Link zum Excel-Communityforum

Informationen zum Eingeben einer einfachen Formel

Formeln sind Gleichungen, mit denen Werte auf Ihrem Arbeitsblatt berechnet werden. Eine Formel beginnt mit einem Gleichheitszeichen (=). In der folgenden Formel wird beispielsweise 3 und 1 addiert:

=3+1

Eine Formel kann zudem ein oder alle der folgenden Elemente enthalten: Funktionen, Verweise, Operatoren und Konstanten.

Bestandteile einer Formel

Bestandteile einer Formel

  1. Funktionen: Als Bestandteil von Excel sind Funktionen vorgefertigte Formeln, mit denen bestimmte Berechnungen ausgeführt werden. Die PI()-Funktion gibt beispielsweise den Wert zurück: 3,142...

  2. Bezüge: beziehen sich auf einzelne Zellen oder Zellbereiche. A2 gibt den Wert in Zelle A2 zurück.

  3. Konstanten: Zahlen- oder Textwerte, die direkt in eine Formel eingegeben werden, z. B. 2.

  4. Operatoren: Mit dem Operator "^"(Caretzeichen) wird die Potenz einer Zahl berechnet, und der Operator "*" (Stern) multipliziert die Zahl. Verwenden Sie "+" und "-" zum Addieren und Subtrahieren, und "/" zum Dividieren.

    Hinweis : Einige Funktionen setzen so genannte Argumente voraus. Argumente sind die Werte, die von bestimmten Funktionen zum Durchführen ihrer Berechnungen verwendet werden. Wenn erforderlich, werden Argumente zwischen die runden Klammer "()" der Funktion gesetzt. Die Funktion PI benötigt keine Argumente, daher ist die Klammer leer. Einige Funktionen benötigen ein oder mehrere Argumente und können Platz für weitere Argumente bereitstellen. Sie müssen zum Trennen der Argumente je nach Standorteinstellungen ein Komma oder ein Semikolon (;) verwenden.

So erfordert die Funktion SUMME beispielsweise nur ein Argument, kann jedoch insgesamt 255 Argumente aufnehmen.

Funktion SUMME

=SUMME(A1:A10) ist ein Beispiel für ein einzelnes Argument.

=SUMME(A1:A10; C1:C10) ist ein Beispiel für mehrere Argumente.

In der folgenden Tabelle sind einige der häufigsten Fehler zusammengefasst, die ein Benutzer beim Eingeben einer Formel machen kann. Außerdem wird erläutert, wie Sie diese beheben:

Stellen Sie Folgendes sicher:

Weitere Informationen

Beginnen Sie jede Funktion mit einem Gleichheitszeichen (=).

Wenn Sie das Gleichheitszeichen auslassen, wird die eingegebene Zeichenfolge als Text oder als ein Datum angezeigt. Wenn Sie z. B. SUMME(A1:A10) eingeben, wird in Excel die Textzeichenfolge SUMME(A1:A10) angezeigt und keine Berechnung ausgeführt. Wenn Sie 11/2 eingeben, wird in Excel das Datum 2. Nov angezeigt (wenn das Zellformat Standard lautet) und nicht 11 durch 2 dividiert.

Achten Sie beim Einfügen von Klammern darauf, dass diese geschlossen werden.

Stellen Sie sicher, dass alle Klammern paarweise vorhanden sind (öffnende und schließende Klammer). Wenn Sie in einer Formel eine Funktion verwenden, muss sich jede Klammer an der richtigen Position befinden, damit die Funktion korrekt funktioniert. Die Formel =WENN(B5<0);"Nicht gültig";B5*1,05) funktioniert beispielsweise nicht, weil sie zwei schließende Klammern, aber nur eine öffnende Klammer enthält, wo es nur eine öffnende und eine schließende Klammer geben sollte. Die korrekte Formel sollte wie folgt aussehen: =WENN(B5<0;"Nicht gültig";B5*1,05).

Verwenden Sie zum Angeben eines Bereichs einen Doppelpunkt.

Zum Herstellen eines Bezugs auf einen Zellbereich verwenden Sie einen Doppelpunkt (:), um den Bezug auf die erste Zelle des Bereichs und den Bezug auf die letzte Zelle des Bereichs voneinander zu trennen, z. B. =SUMME (A1:A5) und nicht =SUMME(A1 A5). Diese Formel würde den Fehler #Null! zurückgeben.

Geben Sie alle erforderlichen Argumente ein.

Bei einigen Funktionen ist die Angabe von Argumenten zwingend erforderlich. Stellen Sie zudem sicher, dass Sie nicht mehr als die zulässigen Argumente eingegeben haben.

Geben Sie die richtige Art von Argumenten ein.

Für einige Funktionen, z. B. SUMME, sind numerische Argumente erforderlich. Andere Funktionen, z. B. ERSETZEN, erfordern für mindestens eines der Argumente einen Textwert. Wenn Sie den falschen Datentyp als Argument verwenden, gibt Excel möglicherweise unerwartete Ergebnisse zurück oder zeigt einen Fehler an.

Schachteln Sie nicht mehr als 64 Funktionen.

Sie können innerhalb einer Funktion maximal 64 Funktionsebenen einfügen (schachteln).

Setzen Sie die Namen anderer Arbeitsblätter in einfache Anführungszeichen.

Wenn die Formel einen Bezug auf Werte oder Zellen aus anderen Arbeitsblättern oder Arbeitsmappen enthält und der Name der anderen Arbeitsmappe oder des Arbeitsblatts Leerzeichen oder nicht alphabetische Zeichen enthält, müssen Sie den Namen in einfache Anführungszeichen (') einschließen, wie in ='Daten 1. Quartal'!D3 oder ='123'!A1.

Fügen Sie hinter dem Namen eines Arbeitsblatts ein Ausrufezeichen (!) ein, wenn Sie in einer Formel darauf verweisen.

Damit z. B. der Wert aus Zelle D3 in einem Arbeitsblatt namens Quartalsdaten in derselben Arbeitsmappe zurückgegeben wird, verwenden Sie diese Formel: ='Quartalsdaten'!D3.

Geben Sie den Pfad für externe Arbeitsmappen an.

Stellen Sie sicher, dass jeder externe Bezug den Namen einer Arbeitsmappe und den Pfad zur Arbeitsmappe enthält.

Ein Bezug auf eine Arbeitsmappe enthält den Namen der Arbeitsmappe und muss in Klammern ([Arbeitsmappenname.xlsx]) eingeschlossen werden. Der Bezug muss zudem den Namen des Arbeitsblatts in der Arbeitsmappe enthalten.

Wenn die Arbeitsmappe, auf die Sie verweisen möchten, nicht in Excel geöffnet ist, können Sie trotzdem einen Bezug darauf in eine Formel einschließen. Dazu geben Sie den vollständigen Dateipfad an, wie in diesem Beispiel: =ZEILEN('C:\Meine Daten\[Qrt.2 operatives Geschäft.xlsx]Umsätze'!A1:A8). Die Formel gibt die Anzahl von Zeilen in einem Bereich zurück, der die Zellen A1 bis A8 in der anderen Arbeitsmappe umfasst (8).

Hinweis : Wenn der vollständige Pfad Leerzeichen enthält, wie im vorherigen Beispiel, müssen Sie den Pfad in einfache Anführungszeichen einschließen (am Anfang des Pfads und hinter dem Namen des Arbeitsblatts vor dem Ausrufezeichen).

Geben Sie Zahlen nicht formatiert ein.

Geben Sie Zahlen ohne Formatierung in Formeln ein. Wenn der einzugebende Wert beispielsweise "1.000 €" lautet, geben Sie in die Formel 1000 ein. Wenn Sie als Teil einer Zahl einen Punkt eingeben, wird dieser von Excel als Trennzeichen betrachtet. Wenn Zahlen mit Tausender- oder Millionentrennzeichen oder Währungssymbolen angezeigt werden sollen, formatieren Sie die Zellen nach der Eingabe der Zahlen.

Wenn Sie beispielsweise zu dem Wert in Zelle A3 die Zahl  3100 addieren möchten und dazu die Formel =SUMME(3.100;A3) eingeben, addiert Excel die Zahlen 3 und 100 und addiert dann die Summe zum Wert von A3, anstatt 3100 zum Wert von A3 zu addieren, was =SUMME(3100;A3) entspräche. Oder wenn Sie die Formel =ABS(-2;134) eingeben, zeigt Excel einen Formelfehler an, da die ABS-Funktion nur ein Argument akzeptiert: =ABS(-2134).

Sie können bestimmte Regeln implementieren, um Formeln auf Fehler zu überprüfen. Diese Regeln garantieren nicht, dass Ihr Arbeitsblatt fehlerfrei ist, sie können jedoch sehr hilfreich sein, um häufig auftretende Fehler zu finden. Sie können jede dieser Regeln einzeln aktivieren oder deaktivieren.

Fehler können auf zwei Arten markiert und behoben werden: immer jeweils ein Fehler (wie bei einer Rechtschreibprüfung) oder sofort bei ihrem Auftreten im Arbeitsblatt während der Dateneingabe.

Sie können einen Fehler mithilfe der in Excel angezeigten Optionen beheben oder den Fehler ignorieren, indem Sie auf Fehler ignorieren klicken. Wenn Sie einen Fehler in einer bestimmten Zelle ignorieren, wird der Fehler in dieser Zelle in weiteren Fehlerüberprüfungen nicht mehr angezeigt. Sie können jedoch alle zuvor ignorierten Fehler zurücksetzen, damit sie wieder angezeigt werden.

  1. Klicken Sie auf Datei > Optionen > Formeln.

    Klicken Sie in Excel 2007 auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche > Excel-Optionen > Formeln.

  2. Aktivieren Sie unter Fehlerüberprüfung das Kontrollkästchen Fehlerüberprüfung im Hintergrund aktivieren. Jeder gefundene Fehler wird mit einem Dreieck in der oberen linken Ecke der Zelle markiert.

    Zelle mit einem Formelproblem
  3. Zum Ändern der Farbe für das Dreieck, mit dem die Stelle markiert wird, an der ein Fehler auftritt, wählen Sie im Feld Fehler mit der folgenden Farbe kennzeichnen die gewünschte Farbe aus.

  4. Aktivieren oder deaktivieren Sie unter Regeln für die Fehlerüberprüfung die Kontrollkästchen für die folgenden Regeln:

    • Zellen mit Formeln, die zu einem Fehler führen: Eine Formel verwendet nicht die erwartete Syntax, die erwarteten Argumente oder Datentypen. Zu den Fehlerwerten zählen #DIV/0!, #NV, #NAME?, #NULL!, #ZAHL!, #BEZUG! und #WERT!. Für jeden dieser Fehlerwerte liegen verschiedene Ursachen vor, und sie werden auf verschiedene Arten gelöst.

      Hinweis : Wenn Sie einen Fehlerwert direkt in eine Zelle eingeben, wird er als dieser Fehlerwert gespeichert, aber nicht als Fehler markiert. Wenn jedoch in einer Formel in einer anderen Zelle auf diese Zelle Bezug genommen wird, gibt die Formel den Fehlerwert aus dieser Zelle zurück.

    • Inkonsistente berechnete Spaltenformel in Tabellen: Eine berechnete Spalte kann einzelne Formeln enthalten, die sich von der Masterspaltenformel unterscheiden. Dadurch wird eine Ausnahme ausgelöst. Ausnahmen durch berechnete Spalten werden ausgelöst, wenn Sie einen der folgenden Vorgänge ausführen:

      • Geben Sie andere Daten als eine Formel in eine berechnete Spaltenzelle ein.

      • Geben Sie eine Formel in einer Zelle einer berechneten Spalte ein, und drücken Sie dann STRG+Z, oder klicken Sie auf der Symbolleiste für den Schnellzugriff auf Rückgängig  Schaltflächensymbol .

      • Geben Sie eine neue Formel in eine berechnete Spalte ein, die bereits eine oder mehrere Ausnahmen enthält.

      • Kopieren Sie Daten in die berechnete Spalte, die nicht mit der Formel der berechneten Spalte übereinstimmen. Wenn die kopierten Daten eine Formel enthalten, werden die Daten in der berechneten Spalte durch diese Formel überschrieben.

      • Verschieben oder löschen Sie eine Zelle in einem anderen Arbeitsblattbereich, auf den eine der Zeilen in einer berechneten Spalte verweist.

    • Zellen, die zweistellige Jahreszahlen enthalten: Die Zelle enthält einen Textdatumswert, bei dem das Jahrhundert falsch interpretiert werden kann, wenn er in Formeln verwendet wird. Beispielsweise könnte es sich bei dem Datum in der Formel =JAHR("1.1.31") um 1931 oder 2031 handeln. Verwenden Sie diese Regel, um Zellen auf zweideutige Textdatumswerte zu überprüfen.

    • Zahlen, die als Text formatiert sind oder denen ein Apostroph vorangestellt ist: Die Zelle enthält Zahlen, die als Text gespeichert sind. Dies ist normalerweise der Fall, wenn Daten aus anderen Quellen importiert werden. Als Text gespeicherte Zahlen können zu unerwarteten Sortierergebnissen führen, und es empfiehlt sich daher, sie in Zahlen zu konvertieren. '=SUMME(A1:A10) wird als Text betrachtet.

    • Formeln, die mit anderen Formeln im Bereich inkonsistent sind: Die Formel entspricht nicht dem Muster der anderen Formeln in ihrer Nähe. Häufig unterscheiden sich angrenzende Formeln nur in den verwendeten Bezügen. Im folgenden Beispiel mit vier angrenzenden Formeln wird ein Fehler neben der Formel =SUMME(A10:C10) in Zelle D4 angezeigt, da sich die umliegenden Formeln immer um jeweils eine Zeile erhöhen und sich diese Formel um 8 Zeilen erhöht. Excel erwartet die Formel =SUMME(A4:C4).

      Excel zeigt einen Fehler an, wenn eine Formel nicht den Mustern der angrenzenden Formeln entspricht.

      Wenn die in einer Formel verwendeten Bezüge nicht mit denen der angrenzenden Formeln konsistent sind, zeigt Excel einen Fehler an.

    • Formeln, die sich nicht auf alle Zellen im Bereich beziehen: Eine Formel enthält möglicherweise nicht automatisch Bezüge auf die Daten, die Sie zwischen dem ursprünglichen Datenbereich und der Zelle einfügen, die die Formel enthält. Mit dieser Regel wird der Bezug in einer Formel mit dem tatsächlichen Zellbereich verglichen, der an die Zelle grenzt, die die Formel enthält. Wenn die angrenzenden Zellen zusätzliche Werte enthalten und nicht leer sind, zeigt Excel neben der Formel einen Fehler an.

      Bei Anwendung dieser Regel fügt Excel beispielsweise einen Fehler neben der Formel =SUMME(D2:D4) ein, da die Zellen D5, D6 und D7 an die Zellen, auf die in der Formel Bezug genommen wird, und die Zelle, die die Formel enthält (D8), grenzen und diese Zellen Daten enthalten, auf die in der Formel Bezug genommen werden sollte.

      Excel zeigt einen Fehler an, wenn eine Formel Zellen in einem Breich überspringt
    • Nicht gesperrte Zellen, die Formeln enthalten: Die Formel ist nicht zu ihrem Schutz gesperrt. Standardmäßig sind alle Zellen in einem Arbeitsblatt gesperrt, sodass sie nicht geändert werden können, wenn das Arbeitsblatt geschützt wird. Dies kann unbeabsichtigte Fehler wie das versehentliche Löschen oder Ändern von Formeln vermeiden. Dieser Fehler gibt an, dass die Zelle auf entsperrt festgelegt, das Blatt jedoch nicht geschützt wurde. Vergewissern Sie sich, dass Sie die Zelle absichtlich entsperrt haben.

    • Formeln, die sich auf leere Zellen beziehen: Die Formel enthält einen Bezug auf eine leere Zelle. Dies kann zu unbeabsichtigten Ergebnissen führen, wie es im folgenden Beispiel dargestellt ist.

      Angenommen, Sie möchten den Mittelwert der Zahlen in der folgenden Zellenspalte berechnen. Ist die dritte Zelle leer, wird sie nicht in die Berechnung einbezogen, und das Ergebnis ist 22,75. Enthält die dritte Zelle eine 0, ist das Ergebnis 18,2.

      Excel zeigt einen Fehler an, wenn eine Formel auf leere Zellen verweist.
    • In eine Tabelle eingegebene Daten sind ungültig: Es ist ein Fehler bei der Gültigkeitsprüfung in einer Tabelle aufgetreten. Prüfen Sie die Einstellung der Gültigkeitsprüfung für die Zelle, indem Sie zur Registerkarte Daten wechseln und in der Gruppe Datentools auf Datenüberprüfung klicken.

  1. Wählen Sie das Arbeitsblatt aus, das auf Fehler überprüft werden soll.

  2. Wenn das Arbeitsblatt manuell berechnet wird, drücken Sie F9, damit es neu berechnet wird.

    Wenn das Dialogfeld Fehlerüberprüfung nicht angezeigt wird, klicken Sie auf der Registerkarte Formeln auf Formelüberwachung und dann auf die Schaltfläche Fehlerüberprüfung.

  3. Wenn Sie zuvor Fehler ignoriert haben, können Sie diese Fehler erneut überprüfen. Gehen Sie dazu wie folgt vor: Klicken Sie auf Datei > Optionen > Formeln.

    Klicken Sie im Bereich Fehlerüberprüfung auf Ignorierte Fehler zurücksetzen und dann auf OK.

    Fehlerüberprüfung

    Hinweis : Durch das Zurücksetzen ignorierter Fehler werden alle Fehler in allen Blättern der aktiven Arbeitsmappe zurückgesetzt.

    Tipp : Es kann hilfreich sein, das Dialogfeld Fehlerüberprüfung direkt unterhalb der Bearbeitungsleiste zu platzieren.

    Das Dialogfeld "Fehlerüberprüfung" unter die Bearbeitungsleiste ziehen
  4. Klicken Sie auf eine der Aktionsschaltflächen auf der rechten Seite des Dialogfelds. Die verfügbaren Aktionen sind je nach Art des Fehlers verschieden.

  5. Klicken Sie auf Weiter.

Hinweis : Wenn Sie auf Fehler ignorieren klicken, wird der Fehler bei jeder nachfolgenden Überprüfung ignoriert.

  1. Klicken Sie neben der Zelle auf die angezeigte Schaltfläche Fehlerüberprüfung  Symbol "Fehlerüberprüfung" und dann auf die gewünschte Option. Die verfügbaren Befehle sind je nach Art des Fehlers unterschiedlich, und im ersten Eintrag ist der Fehler beschrieben.

    Wenn Sie auf Fehler ignorieren klicken, wird der Fehler bei jeder nachfolgenden Überprüfung ignoriert.

    Das Dialogfeld "Fehlerüberprüfung" unter die Bearbeitungsleiste ziehen

Wenn eine Formel ein Ergebnis nicht richtig auswerten kann, zeigt Excel einen Fehlerwert an, beispielsweise #####, #DIV/0!, #NV, #NAME?, #NULL!, #NUM!, #BEZUG! und #WERT!. Für jeden Fehlertyp gibt es andere Ursachen und Lösungen.

Die folgende Tabelle enthält Links zu Artikeln, in denen diese Fehler detailliert beschrieben werden, sowie eine kurze Beschreibung der ersten Schritte.

Thema

Beschreibung

Korrigieren eines Fehlerwerts vom Typ #####

Dieser Fehler wird in Excel angezeigt, wenn eine Spalte nicht breit genug ist, um den gesamten Inhalt einer Zelle anzuzeigen, oder wenn eine Zelle negative Datums- oder Uhrzeitwerte enthält.

Eine Formel, die ein Datum in der Zukunft von einem Datum in der Vergangenheit subtrahiert, also z. B. =15.6.2008-1.7.2008, führt zu einem negativen Datumswert.

Tipp : Versuchen Sie, die Breite der Zelle automatisch anzupassen, indem Sie zwischen den Spaltenüberschriften doppelklicken. Wenn ##### angezeigt wird, weil Excel nicht alle Zeichen anzeigen kann, wird dieses Problem damit behoben.

#-Fehler

Korrigieren eines Fehlerwerts vom Typ #DIV/0!

Dieser Fehler wird in Excel angezeigt, wenn eine Zahl entweder durch Null (0) oder durch eine Zelle geteilt wird, die keinen Wert enthält.

Tipp : Fügen Sie einen Fehlerhandler wie im folgenden Beispiel hinzu, d. h. =WENN(C2;B2/C2;0)

Fehlerbehandlungsfunktionen wie WENN können zum Abfangen von Fehlern verwendet werden

Korrigieren eines Fehlerwerts vom Typ #NV

Dieser Fehler wird in Excel angezeigt, wenn ein Wert für eine Funktion oder Formel nicht verfügbar ist.

Wenn Sie eine Funktion wie SVERWEIS verwenden, gibt es für den von Ihnen gesuchten Nachschlagewert eine Übereinstimmung im Nachschlagebereich? Dies ist meistens nicht der Fall.

Versuchen Sie es mit WENNFEHLER, um den Fehler #NV zu unterdrücken. Verwenden Sie in diesem Fall folgende Formel:

=WENNFEHLER(SVERWEIS(D2;$D$6:$E$8;2;WAHR);0)

#NV-Fehler

Korrigieren eines Fehlerwerts vom Typ #NAME?

Dieser Fehler wird angezeigt, wenn Text in einer Formel von Excel nicht erkannt wird, beispielsweise wenn ein Bereichsname oder der Name einer Funktion falsch geschrieben wurde.

Hinweis : Wenn Sie eine Funktion verwenden, vergewissern Sie sich, dass der Funktionsname richtig geschrieben ist. In diesem Fall ist SUMME falsch geschrieben. Entfernen Sie das doppelte E, und Excel korrigiert die Formel.

Excel zeigt den Fehler #NAME? an, wenn ein Funktionsname einen Tippfehler enthält.

Korrigieren eines Fehlerwerts vom Typ #NULL!

Dieser Fehler wird in Excel angezeigt, wenn Sie eine Schnittmenge von zwei Bereichen angeben, die sich nicht überschneiden. Der Schnittmengen-Operator ist ein Leerzeichen zwischen Bezügen in einer Formel.

Hinweis : Vergewissern Sie sich, dass die Bereiche korrekt getrennt sind. Die Bereiche C2:C3 und E4:E6 überschneiden sich nicht, also gibt die Formel =SUMME(C2:C3 E4:E6) den Fehler #NULL! zurück. Wenn Sie ein Semikolon zwischen die Bereiche C und E setzen, wird die Formel korrigiert: SUMME(C2:C3;E4:E6)

#NULL!-Fehler

Korrigieren eines Fehlerwerts vom Typ #ZAHL!

Dieser Fehler wird in Excel angezeigt, wenn eine Formel oder Funktion ungültige numerische Werte enthält.

Verwenden Sie eine Formel, die iteriert, wie IKV oder ZINS? Falls ja, wird der Fehler #NUM! wahrscheinlich angezeigt, weil die Funktion kein Ergebnis findet. Schritte zur Lösung des Problems finden Sie im entsprechenden Hilfethema.

Korrigieren eines Fehlerwerts vom Typ #BEZUG!

Dieser Fehler wird in Excel angezeigt, wenn ein Zellbezug ungültig ist, beispielsweise, wenn Sie Zellen gelöscht haben, auf die von anderen Formeln Bezug genommen wird, oder wenn Sie Zellen verschieben und über Zellen einfügen, auf die von anderen Formeln Bezug genommen wird.

Haben Sie versehentlich eine Zeile oder Spalte gelöscht? In dieser Formel =SUMME(A2;B2;C2) haben wir Spalte B gelöscht. Mal sehen, was passiert.

Verwenden Sie entweder Rückgängig (STRG+Z) um die Löschung rückgängig zu machen, erstellen Sie die Formel neu, oder verwenden Sie einen zusammenhängenden Bereichsbezug wie =SUMME(A2:C2), wenn Spalte B gelöscht wurde.

Excel zeigt den Fehler #BEZUG! an, wenn ein Zellbezug ungültig ist.

Korrigieren eines Fehlerwerts vom Typ #WERT!

Excel kann diese Fehlermeldung anzeigen, wenn Ihre Formel Zellen mit unterschiedlichen Datentypen enthält.

Verwenden Sie mathematische Operatoren (+, -, *, /, ^) mit unterschiedlichen Datentypen? Falls ja, versuchen Sie stattdessen mit einer Funktion. In diesen Fall würde =SUMME(F2:F5) das Problem beheben.

#WERT!-Fehler

Wenn Zellen auf einem Tabellenblatt nicht angezeigt werden, können Sie diese Zellen und deren Formeln auf der Symbolleiste "Überwachungsfenster" anzeigen. Mit dem Überwachungsfenster können Sie Berechnungen von Formeln und Ergebnisse in umfangreichen Arbeitsblättern bequem überprüfen. Wenn Sie das Überwachungsfenster verwenden, müssen Sie nicht ständig blättern oder zu unterschiedlichen Teilen des Arbeitsblatts wechseln.

Mit dem Überwachungsfenster können Formeln in einem Arbeitsblatt ganz einfach überwacht werden.

Diese Symbolleiste kann wie jede andere Symbolleiste verschoben oder verankert werden. Beispielsweise können Sie sie am unteren Rand des Dialogfelds verankern. Die Symbolleiste überwacht die folgenden Zelleigenschaften: 1. Arbeitsmappe, 2. Arbeitsblatt, 3. Name (wenn die Zelle einen entsprechenden benannten Bereich enthält), 4. Zelladresse, 5. Wert und 6. Formel.

Hinweis : Pro Zelle kann diese Symbolleiste nur einmal verwendet werden.

Hinzufügen von Zellen zum Überwachungsfenster

  1. Markieren Sie die Zellen, die Sie überwachen möchten.

    Wenn Sie alle Zellen mit Formeln auf einem Arbeitsblatt markieren möchten, klicken Sie auf der Registerkarte Start in der Gruppe Bearbeiten auf Suchen und Auswählen (Sie können auch STRG+G auf dem PC oder CTRL+G auf dem Mac verwenden). Klicken Sie dann auf Gehe zu > Inhalte auswählen > Formeln.

    Dialogfeld "Gehe zu > Inhalte"
  2. Klicken Sie auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf Überwachungsfenster.

  3. Klicken Sie auf Überwachung hinzufügen.

    Auf "Überwachung hinzufügen" klicken, um der Tabelle eine Überwachung hinzuzufügen
  4. Vergewissern Sie sich, dass Sie alle Zellen markiert haben, die überwacht werden sollen, und klicken Sie dann auf Hinzufügen.

    In "Überwachung hinzufügen" den zu überwachenden Zellbereich eingeben
  5. Wenn Sie die Breite eines Überwachungsfensters ändern möchten, ziehen Sie die Begrenzungslinie auf der rechten Seite der Spaltenüberschrift.

  6. Wenn Sie die Zelle anzeigen möchten, auf die sich ein Eintrag im Überwachungsfenster bezieht, doppelklicken Sie auf den Eintrag.

    Hinweis : Zellen mit externen Bezügen zu anderen Arbeitsmappen werden nur dann auf der Symbolleiste "Überwachungsfenster" angezeigt, wenn die anderen Arbeitsmappen geöffnet sind.

Entfernen von Zellen aus dem Überwachungsfenster

  1. Wenn die Symbolleiste "Überwachungsfenster" nicht angezeigt wird, klicken Sie auf der Registerkarte Formeln in der Gruppe Formelüberwachung auf Überwachungsfenster.

  2. Markieren Sie die Zellen, die Sie entfernen möchten.

    Wenn Sie mehrere Zellen markieren möchten, drücken Sie STRG, und klicken Sie dann auf die Zellen.

  3. Klicken Sie auf Überwachung löschen.

    Überwachung löschen

Manchmal lässt es sich nur schwer nachvollziehen, wie eine geschachtelte Formel das Endergebnis berechnet, da mehrere Zwischenberechnungen und Wahrheitsprüfungen durchgeführt werden. Mithilfe des Dialogfelds Formel auswerten können Sie jedoch die verschiedenen Teile einer geschachtelten Formel in der Reihenfolge auswerten, in der die Formel berechnet wird. Die Formel =WENN(MITTELWERT(D2:D5)>50;SUMME(E2:E5);0) ist beispielsweise einfacher zu verstehen, wenn Sie die folgenden Zwischenergebnisse betrachten:

"Formel auswerten" hilft Ihnen zu sehen, wie die unterschiedlichen Teile von geschachtelten Formeln ausgewertet werden.

Im Dialogfeld "Formel auswerten"

Beschreibung

=WENN(MITTELWERT(D2:D5)>50,SUMME(E2:E5);0)

Zunächst wird die geschachtelte Formel angezeigt. Die Funktionen MITTELWERT und SUMME sind in der WENN-Funktion geschachtelt.

Der Zellbereich D2:D5 enthält die Werte 55, 35, 45 und 25. Daher lautet das Ergebnis der Funktion MITTELWERT(D2:D5) 40.

=WENN(40>50;SUMME(E2:E5);0)

Der Zellbereich D2:D5 enthält die Werte 55, 35, 45 und 25. Daher lautet das Ergebnis der Funktion MITTELWERT(D2:D5) 40.

=WENN(Falsch;SUMME(E2:E5);0)

Da 40 nicht größer als 50 ist, lautet der Ausdruck im ersten Argument der WENN-Funktion (das Argument Wahrheitstest) "Falsch".

Die WENN-Funktion gibt den Wert des dritten Arguments zurück (das Argument Sonst_Wert). Die Funktion SUMME wird nicht ausgewertet, da sie das zweite Argument der WENN-Funktion ist (das Argument Dann_Wert) und nur zurückgegeben wird, wenn der Ausdruck "Wahr" lautet.

  1. Markieren Sie die Zelle, die Sie auswerten möchten. Es kann immer nur jeweils eine Zelle ausgewertet werden.

  2. Klicken Sie auf der Registerkarte Formeln auf Formelüberwachung > Formel auswerten.

  3. Klicken Sie auf Auswerten, um den Wert des unterstrichenen Bezugs auszuwerten. Das Ergebnis der Auswertung wird kursiv dargestellt.

    Wenn der unterstrichene Teil der Formel auf eine andere Formel verweist, klicken Sie auf Einzelschritt, um die andere Formel im Feld Auswertung anzuzeigen. Klicken Sie auf Rückschritt, um zur vorherigen Zelle und Formel zurückzukehren.

    Die Schaltfläche Einzelschritt ist nicht für einen Bezug verfügbar, wenn der Bezug zum zweiten Mal in der Formel auftritt oder wenn sich die Formel auf eine Zelle in einer anderen Arbeitsmappe bezieht.

  4. Fahren Sie fort, auf Auswerten zu klicken, bis jeder Teil der Formel ausgewertet wurde.

  5. Wenn Sie die Auswertung erneut anzeigen möchten, klicken Sie auf Neu starten.

  6. Wenn Sie die Auswertung beenden möchten, klicken Sie auf Schließen.

Hinweise : 

  • Einige Teile von Formeln, die die Funktionen WENN und WAHL verwenden, werden nicht ausgewertet. In diesen Fällen wird im Feld "Auswertung" der Fehlerwert #NV angezeigt.

  • Wenn ein Bezug leer ist, wird im Feld Auswertung ein Nullwert (0) angezeigt.

  • Die folgenden Funktionen werden jedes Mal neu berechnet, wenn sich das Arbeitsblatt ändert, und können bewirken, dass im Dialogfeld Formel auswerten andere Ergebnisse als in der Zelle angezeigt werden: ZUFALLSZAHL, BEREICHE, INDEX, BEREICH.VERSCHIEBEN, ZELLE, INDIREKT, ZEILEN, SPALTEN, JETZT, HEUTE, ZUFALLSBEREICH.

Haben Sie eine bestimmte Frage?

Posten Sie eine Frage im Excel-Communityforum.

Helfen Sie uns, Excel zu verbessern

Haben Sie Vorschläge, wie wir die kommende Version von Excel verbessern könnten? Wenn ja, lesen Sie die Themen unter Excel User Voice.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Siehe auch

Anzeigen der Beziehungen zwischen Formeln und Zellen

Video: Korrigieren defekter Formeln (Excel 2010)

Vermeiden defekter Formeln

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×