Entwerfen einer Formularvorlage für die Offlineverwendung

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Inhalt dieses Artikels

Informationen über Offlineformulare

Erstellen einer Datenverbindung zu einer SQL-Datenbank für die Offlineverwendung

Erstellen einer Datenverbindung zu einer Access-Datenbank für die Offlineverwendung

Erstellen einer Datenverbindung zu einer SharePoint-Dokumentbibliothek für die Offlineverwendung

Konfigurieren der Datenverfügbarkeit

Deaktivieren der Offlineverwendung

Informationen über Offlineformulare

Sie müssen möglicherweise eine Microsoft Office InfoPath-Formularvorlage entwerfen, die Benutzer ausfüllen können, während ihre Computer nicht mit dem Netzwerk verbunden sind. Sie können z. B. eine Formularvorlage für einen Schadenssachverständigen entwerfen, die dieser im Außendienst verwenden kann, während er einen Schadensanspruch untersucht. Die Formularvorlage enthält sekundäre Datenverbindungen, die Daten aus einer externen Datenbank für das Formular bereitstellen. Der Sachverständige benötigt diese Daten zum Ausfüllen des Formulars. Während er sich noch im Büro befindet und mit dem Netzwerk verbunden ist, kann der Sachverständige ein auf dieser Formularvorlage basierendes Formular erstellen und dieses dann auf seinem Computer speichern. Im Außendienst kann der Sachverständige das Formular öffnen und speichern, ohne mit dem Netzwerk verbunden sein zu müssen. Nachdem er wieder im Büro ist und die Verbindung zum Netzwerk erneut besteht, kann der Schadenssachverständige das Formular senden.

Ein auf einem Computer gespeichertes Formular kann standardmäßig ohne Netzwerkverbindung arbeiten. Wenn ein Benutzer ein auf einer Formularvorlage basierendes Formular erstellt, lädt InfoPath eine Kopie dieser Formularvorlage auf den Computer des Benutzers herunter und speichert sie. Sobald der Benutzer ein auf dieser Formularvorlage basierendes Formular öffnet, prüft InfoPath zuerst, ob eine Netzwerkverbindung zum Computer besteht. Wenn eine Netzwerkverbindung vorhanden ist, prüft InfoPath den Speicherort, von dem aus die Formularvorlage heruntergeladen wurde, um zu ermitteln, ob eine aktualisierte Version der Formularvorlage vorhanden ist. Wenn eine aktualisierte Version vorhanden ist, aktualisiert InfoPath die Formularvorlage auf dem Computer des Benutzers. Wenn keine Netzwerkverbindung vorhanden ist, verwendet InfoPath die Version der Formularvorlage, die auf dem Computer des Benutzers gespeichert wird.

Um eine Formularvorlage für die Offlineverwendung zu entwerfen, muss die Formularvorlage auf dem Computer des Benutzers gespeichert und sämtliche vom Benutzer zum Ausfüllen des Formulars erforderliche Daten, z. B. ein Listenfeld, müssen dem Benutzer zur Verfügung gestellt werden, auch wenn der Computer nicht mit dem Netzwerk verbunden ist. Die Daten in diesen Steuerelementen werden von einer sekundären Datenverbindung zu einer externen Datenquelle bereitgestellt. Diese Daten können auf dem Computer des Benutzers entweder in der Formularvorlage oder an einem speziellen Speicherort namens Cache gespeichert werden.

Wenn Sie eine sekundäre Datenverbindung zu einer Formularvorlage hinzufügen, die Daten von einer externen Datenquelle abfragt, dann sendet InfoPath eine Abfrage an diese externe Datenquelle. Die Ergebnisse der Abfrage werden in der Formularvorlage gespeichert. Wenn der Benutzer ein neues Formular auf Grundlage dieser Formularvorlage erstellt, stehen die in der Formularvorlage gespeicherten Daten dem Benutzer zur Verfügung.

Wenn das Formular diese sekundäre Datenverbindung verwendet, um die Inhalte eines Listenfeld- oder Kombinationsfeld-Steuerelements mit den aktuellsten Daten aus der externen Datenquelle zu aktualisieren, dann speichert InfoPath die Ergebnisse dieser Abfrage an einem speziellen Speicherort namens Cache, wenn der Computer mit einem Netzwerk verbunden ist. InfoPath verwendet die Daten in diesem Cache, um diesen Steuerelementen Daten bereitzustellen.

Sie können eine oder beide der folgenden Aktionen ausführen, um die Daten einer sekundären Datenverbindung für Benutzer zur Verfügung zu stellen, auch wenn ihre Computer nicht mit einem Netzwerk verbunden sind:

  • Speichern Sie die Daten aus der externen Datenquelle in der Formularvorlage.

  • Verwenden Sie die sekundäre Datenverbindung, wenn das Formular geöffnet wird.

Nachdem Sie die sekundäre Datenverbindung so konfiguriert haben, dass sie auch funktioniert, wenn der Computer des Benutzers offline ist, können Sie auch das Formular so konfigurieren, dass es die aktuellsten Daten aus der externen Datenquellen abruft. Sie können die Formularvorlage für die Abfrage der aktuellsten Daten konfigurieren (indem Sie die Verfügbarkeit vorhandener Daten im Formular auf eine festgelegte Anzahl von Tagen einschränken) und dann eine Schaltfläche hinzufügen, um die aktuellsten Daten abzurufen.

Speichern der Daten in der Formularvorlage

Sie können die Daten einer sekundären Datenverbindung in einer Formularvorlage speichern, indem sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern im Datenverbindungs-Assistenten aktivieren, wenn Sie die sekundäre Datenverbindung erstellen.

Datenverbindungs-Assistent (Dialogfeld)

Wenn Sie dieses Kontrollkästchen aktivieren, verwendet InfoPath die Datenverbindung, um Daten von der externen Datenquellen abzurufen. Dann speichert es diese Daten in der Formularvorlage. Wenn ein Benutzer ein Formular erstellt oder ein auf ihrer Formularvorlage basierendes Formular öffnet, wird eine Kopie der Formularvorlage zusammen mit den gespeicherten Daten auf den Computer des Benutzers heruntergeladen. Wenn der Computer des Benutzers bei der Erstellung des Formulars mit einem Netzwerk verbunden ist, ruft InfoPath Daten von der externen Datenverbindung ab, sobald das Formular diese Datenverbindung verwendet. Wenn der Benutzer bei der Erstellung des Formulars nicht mit einem Netzwerk verbunden ist, verwendet InfoPath die Daten, die in der Formularvorlage auf dem Computer des Benutzers gespeichert sind.

Da die Daten bei der Erstellung der Datenverbindung abgerufen wurden, ist möglicherweise eine Aktualisierung der externen Datenquelle erfolgt, als ein Benutzer ein auf dieser Formularvorlage basierendes Formular erstellt hat. Wenn Ihre Benutzer die aktuellsten Daten aus der externen Datenquelle erhalten sollen, wenn sie ein neues Formular erstellen oder ein vorhandenes Formular öffnen, das auf Ihrer Formularvorlage basiert, dann sollten Sie das Formular so entwerfen, dass beim erstmaligen Öffnen des Formulars eine sekundäre Datenverbindung verwendet wird.

Verwenden der sekundären Datenverbindung beim Öffnen des Formulars

Wenn die Benutzer die aktuellsten Daten aus einer externen Datenquelle erhalten sollen, anstatt die in einer Formularvorlage gespeicherten Daten zu verwenden, dann aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen im Datenverbindungs-Assistenten, wenn Sie die sekundäre Datenverbindung erstellen. Letzte Seite des Datenverbindungs-Assistenten (Dialogfeld)

Wenn ein Benutzer ein neues Formular erstellt, während er mit dem Netzwerk verbunden ist, verwendet InfoPath diese sekundäre Datenverbindung, um die aktuellsten Daten von der externen Datenquelle abzurufen. Diese Daten werden im Cache gespeichert. Wenn der Benutzer ein vorhandenes Formular öffnet, das auf seinem Computer gespeichert ist, überprüft InfoPath, ob der Computer mit einem Netzwerk verbunden ist. Wenn der Computer mit einem Netzwerk verbunden ist, ruft InfoPath die aktuellsten Daten aus der Datenquelle mithilfe dieser Datenverbindung ab. Wenn der Benutzer offline arbeitet, verwendet InfoPath die im Cache oder in der Formularvorlage gespeicherten Daten.

Sicherheitshinweis : Die Daten aus einer sekundären Datenquelle abgerufen werden als nur-Text auf dem Computer gespeichert. Wenn Sie eine sekundäre Datenquelle verwenden, um vertrauliche Daten aus einer externen Datenquelle abzurufen, möchten Sie möglicherweise helfen, die Daten vor unbefugtem Zugriff schützen, falls der Computer verloren gegangen sind oder gestohlen wird diese Funktion deaktivieren. Wenn Sie dieses Feature deaktivieren, werden die Daten nur verfügbar, wenn der Benutzer mit dem Netzwerk verbunden ist.

Abrufen der aktuellsten Daten

Wenn eine externe Datenquelle regelmäßig aktualisiert wird, können Sie eine Formularvorlage konfigurieren, um den Benutzern das Abrufen der aktuellsten Daten über die sekundäre Datenverbindung zu ermöglichen. Dazu können Sie die Verfügbarkeit der Daten, die momentan im Cache gespeichert werden, auf eine bestimmte Anzahl von Tagen einschränken. Anschließend können Sie eine Schaltfläche hinzufügen, um mithilfe aller sekundären Datenverbindungen im Formular Daten aus beliebigen externen Datenquellen abzurufen. Dadurch wird sichergestellt, dass die Benutzer mit den aktuellsten Daten arbeiten.

Alternativ können Sie die Verfügbarkeit von Daten einer externen Datenverbindung einschränken, indem Sie ein Ablaufdatum festlegen, um zu bestimmen, wie lange die Daten auf dem Computer des Benutzers gespeichert werden sollen. Formularoptionen (Dialogfeld)

Wenn Sie diese Option verwenden, stellt InfoPath die Daten von allen sekundären Datenverbindungen nur für die angegebene Anzahl von Tagen für das Formular zur Verfügung. Nachdem die Frist abgelaufen ist, werden die Daten nicht mehr im Formular angezeigt. Sie können dem Formular dann eine Schaltfläche hinzufügen, über die die Benutzer die Daten mithilfe einer bestimmten sekundären oder über alle sekundären Datenverbindungen im Formular abrufen können.

Sicherheitshinweis : Auch wenn die Daten nicht für das Formular verfügbar sind, verbleiben sie nach Ablauf der angegebenen Anzahl von Tagen dennoch auf dem Computer des Benutzers. Die Daten werden nur überschrieben, wenn das Betriebssystem diesen Speicherplatz verwendet, um andere Daten zu speichern.

Seitenanfang

Erstellen einer Datenverbindung zu einer SQL-Datenbank für die Offlineverwendung

Bevor Sie eine sekundäre Datenverbindung zu einer Microsoft SQL Server-Datenbank zur Formularvorlage hinzufügen, sind folgende Informationen vom Datenbankadministrator erforderlich:

  • Der Name des Servers, auf dem die von Ihnen für die Formularvorlage zu verwendende Datenbank gespeichert wird.

  • Der Name der Datenbank, die Sie mit dieser Formularvorlage verwenden werden.

  • Die von der Datenbank erforderliche Authentifizierung. Die Datenbank kann entweder die Microsoft Windows-Authentifizierung oder die SQL Server-Authentifizierung verwenden, um zu ermitteln, wie die Benutzer auf die Datenbank zugreifen können.

  • Der Name der Tabelle, die die an das Formular zu sendenden Daten enthält. Dies ist die Mastertabelle. Wenn Sie in der Datenbank mehrere Tabellen verwenden möchten, sind auch die Namen dieser anderen, untergeordneten Tabellen erforderlich. Außerdem sind die Namen der Felder in den untergeordneten Tabellen erforderlich, die über Beziehungen zu den Feldern in der Mastertabelle verfügen.

  • Die Information, ob Sie die Abfrageergebnisse im Formular für die Offlineverwendung sicher speichern können.

Nachdem Sie diese Informationen erhalten haben, können Sie das folgende Verfahren verwenden, um die Datenverbindung zu einer SQL-Datenbank für die Offlineverwendung zu erstellen.

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank (Microsoft SQL Server oder Microsoft Office Access), und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank auswählen.

  6. Klicken Sie im Dialogfeld Datenquelle auswählen auf Neue Quelle.

  7. Klicken Sie in der Liste Zu welchem Datenquellentyp möchten Sie die Verbindung herstellen auf Microsoft SQL Server, und klicken Sie dann auf Weiter.

  8. Geben Sie im Feld Servername den Namen des Servers ein, auf dem die Datenbank gespeichert wird.

  9. Führen Sie unter Anmeldeinformationen eine der folgenden Aktionen aus:

    • Wenn die Datenbank auf Grundlage der in einem Microsoft Windows-Netzwerk verwendeten Anmeldeinformationen bestimmt, wer Zugriff auf den Server hat, klicken Sie auf Windows-Authentifizierung verwenden.

    • Wenn die Datenbank auf Grundlage eines vom Datenbankadministrator erhaltenen, bestimmten Benutzernamens und eines Kennworts bestimmt, wer Zugriff auf den Server hat, klicken Sie auf Benutzername und Kennwort verwenden, und geben Sie dann diesen Benutzernamen und das zugehörige Kennwort in die Felder Benutzername und Kennwort ein.

  10. Klicken Sie auf Weiter.

  11. Klicken Sie auf der nächsten Seite des Assistenten in der Liste Wählen Sie die Datenbank, die die benötigten Daten enthält auf die zu verwendende Datenbank, aktivieren Sie das Kontrollkästchen Mit einer ausgewählten Tabelle verbinden, und klicken Sie dann auf den Namen der Mastertabelle. Anschließend klicken Sie auf Weiter.

  12. Auf der nächsten Seite des Assistenten geben Sie im Feld Dateiname einen Namen für die Datei ein, die die Datenverbindungsinformationen speichert.

  13. Klicken Sie auf Fertig stellen, um diese Einstellungen zu speichern.

  14. Fügen Sie sonstige Tabellen, die Sie in der Abfragedatenverbindung verwenden wollen, hinzu.

    Wie?

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen auf den Namen der untergeordneten Tabelle, und klicken Sie anschließend auf Weiter. InfoPath versucht, die Beziehungen einzurichten, indem es die Feldnamen der beiden Tabellen miteinander abgleicht. Wenn Sie eine vorgeschlagene Beziehung nicht verwenden möchten, wählen Sie die betreffende Beziehung und klicken anschließend auf Beziehung entfernen. Um eine Beziehung hinzuzufügen, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen in der jeweiligen Spalte auf die Namen aller verbundenen Felder und anschließend auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Wiederholen Sie diese Schritte, um zusätzliche untergeordnete Tabellen hinzuzufügen.

  15. Klicken Sie auf Weiter.

  16. Wenn die Daten dieser sekundären Datenverbindung auch dann verfügbar sein sollen, wenn der Computer eines Benutzers nicht mit einem Netzwerk verbunden ist, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern. Wenn Sie dieses Kontrollkästchen aktivieren, fragt InfoPath die externe Datenquelle ab und speichert die Ergebnisse in der Formularvorlage.

    Sicherheitshinweis : Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert sind, sind sie in den Formularen verfügbar, die die Benutzer ausfüllen, selbst wenn deren Computer nicht mit einem Netzwerk verbunden sind. Wenn Sie aus dieser Datenverbindung vertrauliche Daten abrufen, sollten Sie dieses Feature deaktivieren, um dazu beizutragen, dass bei Computerverlust oder -diebstahl die Daten geschützt sind.

  17. Klicken Sie auf Weiter.

  18. Geben Sie auf der nächsten Seite des Assistenten einen anschaulichen Namen für diese sekundäre Datenverbindung ein. Überprüfen Sie, dass die Daten im Abschnitt Zusammenfassung richtig sind. Aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen, damit die Benutzer diese sekundäre Datenverbindung verwenden dürfen, wenn sie ein auf dieser Formularvorlage basierendes neues Formular erstellen oder ein vorhandenes Formular öffnen.

Seitenanfang

Erstellen einer Datenverbindung zu einer Access-Datenbank für die Offlineverwendung

Bevor Sie eine sekundäre Datenverbindung zu einer Access-Datenbank zur Formularvorlage hinzufügen, sind folgende Informationen vom Datenbankadministrator erforderlich:

  • Der Name und der Speicherort der Datenbank.

    Hinweis : Außerdem müssen Sie wissen, ob sich die Datenbank an einem Speicherort im Netzwerk befindet, auf den die Benutzer zugreifen können. Wenn andere Benutzer im Netzwerk Formulare erstellen, die auf dieser Formularvorlage basieren, dann muss sich Ihre Datenbank an einem Speicherort im Netzwerk befinden, auf den Ihre Benutzer Zugriff haben.

  • Wenn die Formularvorlage nur die Datenbank abfragt, ist der Name der Tabelle erforderlich, die die Ergebnisse der an die Datenbank gesendeten Abfrage bereitstellt. Diese Tabelle wird zur Mastertabelle, wenn Sie die Abfragedatenverbindung konfigurieren.

  • Die Namen von einem beliebigen anderen Tabellen, denen die primäre Tabelle Daten aus erfordern möglicherweise. In den meisten Fällen sind die tabellenbeziehungen in der Datenbank bereits eingerichtet. Wenn Sie die Beziehungen zwischen der primären Tabelle und einer weiteren Tabelle herstellen müssen, benötigen Sie die zugehörigen Feldnamen in beiden Tabellen.

Nachdem Sie diese Informationen erhalten haben, können Sie das folgende Verfahren verwenden, um die Datenverbindung zu einer Access-Datenbank für die Offlineverwendung zu erstellen.

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank (Microsoft SQL Server oder Microsoft Office Access), und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der nächsten Seite des Assistenten auf Datenbank auswählen.

  6. Wechseln Sie im Dialogfeld Datenquelle auswählen zum Speicherort Ihrer Datenbank.

    Hinweis : Wenn die Datenbank in einem Speicherort im Netzwerk gespeichert ist, navigieren Sie zu der UNC Pfad des Speicherorts. Nicht zum Netzwerkspeicherort über eine zugeordnete Netzlaufwerk navigieren. Wenn Sie ein Netzlaufwerk verwenden, werden basierend auf dieser Formularvorlage erstellte Formulare für die Datenbank aus einem zugeordneten Netzlaufwerk suchen. Wenn der Benutzer ein Netzlaufwerk nicht besitzen, wird das Formular die Datenbank nicht finden.

  7. Klicken Sie auf den Namen der Datenbank und dann auf Öffnen.

  8. Klicken Sie im Dialogfeld Tabelle auswählen auf die zu verwendende Mastertabelle, und klicken Sie dann auf OK.

  9. Aktivieren Sie auf der nächsten Seite des Assistenten das Kontrollkästchen Tabellenspalten anzeigen.

    Standardmäßig werden alle Felder in der Tabelle zur primären Datenquelle der Formularvorlage hinzugefügt.

  10. Deaktivieren Sie unter Datenquellenstruktur die Kontrollkästchen für die Felder, die nicht in die primäre Datenquelle einbezogen werden sollen.

    Fügen Sie sonstige Tabellen oder Abfragen hinzu, die Sie in dieser Datenverbindung verwenden möchten.

    Wie?

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen auf den Namen der untergeordneten Tabelle, und klicken Sie anschließend auf Weiter. InfoPath versucht, die Beziehungen einzurichten, indem es die Feldnamen der beiden Tabellen miteinander abgleicht. Wenn Sie eine vorgeschlagene Beziehung nicht verwenden möchten, wählen Sie die betreffende Beziehung und klicken anschließend auf Beziehung entfernen. Um eine Beziehung hinzuzufügen, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen in der jeweiligen Spalte auf die Namen aller verbundenen Felder und anschließend auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Wiederholen Sie diese Schritte, um zusätzliche untergeordnete Tabellen hinzuzufügen.

  11. Klicken Sie auf Weiter.

  12. Damit die Daten dieser sekundären Datenverbindung auch dann verfügbar sind, wenn der Computer eines Benutzers nicht mit einem Netzwerk verbunden ist, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern. Wenn Sie dieses Kontrollkästchen aktivieren, fragt InfoPath die externe Datenquelle ab und speichert die Abfrageergebnisse in der Vorlage.

    Sicherheitshinweis : Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert sind, sind sie in den Formularen verfügbar, die die Benutzer ausfüllen, selbst wenn deren Computer nicht mit einem Netzwerk verbunden sind. Wenn Sie aus dieser Datenverbindung vertrauliche Daten abrufen, sollten Sie dieses Feature deaktivieren, um dazu beizutragen, dass bei Computerverlust oder -diebstahl die Daten geschützt sind.

  13. Klicken Sie auf Weiter.

  14. Geben Sie auf der nächsten Seite des Assistenten einen anschaulichen Namen für diese sekundäre Datenverbindung ein. Überprüfen Sie, dass die Daten im Abschnitt Zusammenfassung richtig sind. Aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen, damit die Benutzer diese sekundäre Datenverbindung verwenden dürfen, wenn sie ein auf dieser Formularvorlage basierendes neues Formular erstellen oder ein vorhandenes Formular öffnen.

Seitenanfang

Erstellen einer Datenverbindung zu einer SharePoint-Dokumentbibliothek für die Offlineverwendung

Bevor Sie eine sekundäre Datenverbindung Formularvorlage hinzufügen, sind folgende Informationen vom Siteadministrator erforderlich:

  • Der Speicherort der Microsoft Windows SharePoint Services-Site und die erforderlichen Berechtigungen für den Zugriff.

  • Die Bestätigung, dass die Site so konfiguriert ist, dass die Benutzer auf Daten der Dokumentbibliothek oder Liste zugreifen können.

  • Die Bestätigung, dass Sie die Daten aus der Dokumentbibliothek oder Liste auf den Computern der Benutzer für die Offlineverwendung speichern können.

Nachdem Sie diese Informationen erhalten haben, können Sie das folgende Verfahren verwenden, um die Datenverbindung zu einer Access-Datenbank für die Offlineverwendung zu erstellen.

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf SharePoint-Bibliothek oder -Liste und dann auf Weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten die URL der SharePoint-Site mit der Dokumentbibliothek oder Liste ein, und klicken Sie dann auf Weiter.

  6. Klicken Sie auf der nächsten Seite des Assistenten in der Liste Wählen Sie eine Liste oder Bibliothek aus auf die zu verwendende Liste oder Bibliothek, und klicken Sie dann auf Weiter.

  7. Aktivieren Sie auf der nächsten Seite des Assistenten die Kontrollkästchen neben den Feldern, die Daten für die Formularvorlage bereitstellen sollen. Wenn die Formularvorlage für die Dokumentbibliothek veröffentlicht wird und Sie wünschen, dass die auf dieser Formularvorlage basierenden Formulare Metadaten zum Formular abrufen sollen, dann aktivieren Sie das Kontrollkästchen Nur Daten für das aktive Formular einschließen.

  8. Klicken Sie auf Weiter.

  9. Damit die Daten dieser sekundären Datenverbindung auch dann verfügbar sind, wenn der Computer eines Benutzers nicht mit einem Netzwerk verbunden ist, aktivieren Sie das Kontrollkästchen Kopie der Daten in der Formularvorlage speichern. Wenn Sie dieses Kontrollkästchen aktivieren, fragt InfoPath die externe Datenquelle ab und speichert die Abfrageergebnisse in der Formularvorlage.

    Sicherheitshinweis : Durch Aktivieren dieses Kontrollkästchens werden die Abfrageergebnisse in der Formularvorlage gespeichert. Da die Daten in der Formularvorlage gespeichert sind, sind sie in den Formularen verfügbar, die die Benutzer ausfüllen, selbst wenn deren Computer nicht mit einem Netzwerk verbunden sind. Wenn Sie aus dieser Datenverbindung vertrauliche Daten abrufen, sollten Sie dieses Feature deaktivieren, um dazu beizutragen, dass bei Computerverlust oder -diebstahl die Daten geschützt sind.

  10. Klicken Sie auf Weiter.

  11. Geben Sie auf der nächsten Seite des Assistenten einen anschaulichen Namen für diese sekundäre Datenverbindung ein, und überprüfen Sie dann, dass die Daten im Abschnitt Zusammenfassung richtig sind.

  12. Aktivieren Sie das Kontrollkästchen Daten beim Öffnen des Formulars automatisch abrufen, damit die Benutzer diese sekundäre Datenverbindung verwenden dürfen, wenn sie ein auf dieser Formularvorlage basierendes neues Formular erstellen oder ein vorhandenes Formular öffnen.

Seitenanfang

Konfigurieren der Datenverfügbarkeit

Wenn Ihre externe Datenquelle regelmäßig mit neuen Daten aktualisiert wird, können Sie die Formularvorlage so konfigurieren, dass alle zwischengespeicherten Daten zur Verfügung stehen. Diese Daten sind für die auf dieser Formularvorlage basierenden Formulare für eine begrenzte Anzahl von Tagen verfügbar, die dem Aktualisierungsplan der externen Datenquelle entspricht. Durch die Begrenzung der Anzahl der Tage, an denen die Daten für Formulare verfügbar sind, die auf dieser Formularvorlage basieren, können Sie durchsetzen, dass die Benutzer die Daten regelmäßig von der externen Datenquelle aktualisieren.

Um die Daten zu aktualisieren, können Sie eine Schaltfläche zur Formularvorlage hinzufügen, mit deren Hilfe die Benutzer die Daten von allen in der Formularvorlage verwendeten sekundären Datenverbindungen aktualisieren können.

Hinweis : Wenn Sie zum Aktualisieren der Datenverbindung eine Schaltfläche verwenden, teilen Sie den Benutzern mit, dass sie nur auf diese Schaltfläche klicken sollen, wenn eine Verbindung zum Netzwerk besteht.

Festlegen der Anzahl der Tage für die Verfügbarkeit zwischengespeicherter Daten

Diese Einstellung gilt für alle sekundären Datenverbindungen in der Formularvorlage.

  1. Klicken Sie im Menü Extras auf Formularoptionen.

  2. Klicken Sie im Dialogfeld Formularoptionen in der Liste Kategorie auf Offline.

  3. Aktivieren Sie unter Offline das Kontrollkästchen Daten, die von Abfragen zurückgegeben werden, speichern, damit sie im Offlinemodus verwendet werden können.

  4. Klicken Sie auf Gespeicherte Abfragen laufen nach folgender Anzahl von Tagen ab.

  5. Wählen Sie in der Liste die Anzahl der Tage für die Verfügbarkeit der zwischengespeicherten Daten im Formular aus.

Hinzufügen einer Schaltfläche zum Aktualisieren der Datenverbindung

  1. Falls die Formularvorlage über mehrere Ansichten verfügt, klicken Sie auf Name der Ansicht im Menü Ansicht, um zu der Ansicht zu gelangen, wo die Daten aus der sekundären Datenquelle angezeigt werden sollen.

  2. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  3. Ziehen Sie ein Schaltflächen-Steuerelement auf die Formularvorlage.

  4. Doppelklicken Sie auf das soeben zur Formularvorlage hinzugefügte Schaltflächen-Steuerelement .

  5. Klicken Sie auf die Registerkarte Allgemein.

  6. Klicken Sie in der Liste Aktionen auf Aktualisieren.

  7. Geben Sie den Namen, der auf der Schaltfläche angezeigt werden soll, im Feld Beschriftung ein.

  8. Klicken Sie auf Einstellungen.

  9. Führen Sie im Dialogfeld Aktualisieren eine der folgenden Aktionen aus:

    • Klicken Sie auf Eine sekundäre Datenquelle, um die Schaltfläche zum Abrufen der aktuellsten Daten über diese Datenverbindung zu konfigurieren.

    • Klicken Sie auf Alle sekundären Datenquellen, um die Schaltfläche zum Abrufen der aktuellsten Daten über alle sekundären Datenverbindungen zu konfigurieren.

  10. Klicken Sie in der Liste Wählen Sie die sekundäre Datenquelle aus auf die sekundäre Datenquelle, die der Abfragedatenverbindung zugeordnet ist.

  11. Klicken Sie auf OK, um alle geöffneten Dialogfelder zu schließen.

  12. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

Seitenanfang

Deaktivieren der Offlineverwendung

In einigen Fällen möchten Sie möglicherweise eine Formularvorlage entwerfen, die den Benutzern das Ausfüllen eines Formulars nur dann ermöglicht, wenn sie mit einem Netzwerk verbunden sind. Wenn Ihre Formularvorlage z. B. über eine Datenverbindung zu einer externen Datenquelle verfügt, die geschützte oder vertrauliche Daten enthält, dann möchten Sie die Formularvorlage möglicherweise so konfigurieren, dass sie das Ausfüllen von Formularen nur dann ermöglicht, wenn die Verbindung zum Netzwerk besteht. Indem Sie die Formularvorlage auf diese Weise konfigurieren, können Sie dazu beitragen, die Daten zu schützen, falls der Computer verloren oder gestohlen wird, da die Daten nicht auf dem Computer des Benutzers gespeichert werden.

Führen Sie die folgenden Schritte durch, um die Formularvorlage so zu konfigurieren, dass die Benutzer das Formular nur dann ausfüllen können, wenn ihr Computer mit einem Netzwerk verbunden ist.

  1. Klicken Sie im Menü Extras auf Formularoptionen.

  2. Klicken Sie im Dialogfeld Formularoptionen in der Liste Kategorie auf Offline.

  3. Deaktivieren Sie unter Offline das Kontrollkästchen Benutzer können dieses Formular ausfüllen, wenn keine Daten verfügbar sind.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×