Entwerfen einer Formularvorlage basierend auf einer Microsoft SQL Server-Datenbank

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können eine Formularvorlage entwerfen, die mit einer Microsoft SQL Server-Datenbank verwendet werden kann, um Daten abzufragen oder um Daten abzufragen und abzusenden.

Inhalt dieses Artikels

(Übersicht)

Kompatibilität Aspekte

Vorbemerkung

Entwerfen der Formularvorlage

Konfigurieren der Absendeoptionen

Übersicht

Ein Formular kann eine primäre Datenverbindung und optional eine oder mehrere sekundäre Datenverbindungen haben. Abhängig vom Zweck des Formulars kann eine Datenverbindung Formulardaten abfragen oder an eine externe Datenquelle senden, z. B. eine Microsoft SQL Server-Datenbank oder einen Webdienst.

Beim Entwerfen einer Formularvorlage, die auf einer Datenbank basiert, erstellt Microsoft Office InfoPath ein Hauptfenster Datenquelle mit Gruppen, die Abfragefelder und Datenfelder und eine Verbindung zum Abfragen von Daten als für die Formularvorlage Datenverbindung Hauptfenster enthalten. Diese Felder und Gruppen entsprechen der Anzeige von Daten in Tabellen in der Datenbank gespeichert ist. Abfragefelder enthalten die Daten, die von einem Benutzer für die Abfrageergebnisse auf Datensätze zu beschränken, die die Daten in den Abfragefeldern entsprechen eingegeben werden. Wenn ein Formular basierend auf dieser Formularvorlage Hauptfenster Datenverbindung verwendet wird, erstellt InfoPath eine Abfrage mit den Daten in den Abfragefeldern ein. InfoPath sendet dann die Abfrage über die Verbindung zum Abfragen von Daten aus. Die Datenbank gibt die Ergebnisse der Abfrage an das Formular durch die Verbindung zum Abfragen von Daten zurück. Die Ergebnisse der Abfrage werden in Datenfelder, setzen Sie die Steuerelemente nacheinander bearbeitet werden kann, die an diese Felder gebunden sind.

Da die Datenstruktur der Abfrage und der Datenfelder mit der Speicherung der Daten in der Datenbank übereinstimmen muss, können Sie diese Felder oder Gruppen in der primären Datenquelle nicht ändern. Sie können Felder oder Gruppen nur der Stammgruppe in der primären Datenquelle hinzufügen. Hyperlinks zu weiteren Informationen zu Datenquellen finden Sie im Abschnitt Siehe auch.

Ein Formular kann Daten an eine Datenbank über die Hauptdatenverbindung des Formulars senden, wenn die dem Formular zugrunde liegende Formularvorlage und die Datenbank folgende Anforderungen erfüllen:

  • Die Formularvorlage ist keine browserkompatible Formularvorlage    InfoPath wird eine Verbindung zum Absenden von Daten nicht in den Hauptfenster Verbindung erstellen, wenn Sie eine browserkompatible Formularvorlage entwerfen. Damit die Benutzer zum Senden von Daten in einem Formular, das auf eine browserkompatible Formularvorlage basiert, verwenden Sie einen Webdienst, der mit der Datenbank arbeitet.

  • In jedem Paar verknüpfter Tabellen in der primären Datenquelle die linke Tabelle enthält einen Primärschlüssel    Mindestens eines der "Beziehungen" für jedes Paar verknüpften Tabellen muss einen Primärschlüssel aus der linken Tabelle enthalten.

  • Keiner der Datenfelder in der primären Datenquelle des Formulars Speichers ein großer binäre Datentyp    InfoPath wird die Verbindung zum Absenden von Daten deaktiviert, wenn die Abfrage Felder enthält, die einen große binäre Datentyp, wie Bilder, Bilder, OLE Objekte, Dateianlagen, die Office Access Memo-Datentyp oder den Text der SQL-Datentyp speichern können.

Wenn von InfoPath die Verbindung zum Absenden von Daten aktiviert wird, können die Benutzer die Daten in den Datenfeldern in der primären Datenquelle an die Datenbank absenden. Wird von InfoPath die Verbindung zum Absenden von Daten aktiviert, können Sie die Absendeoptionen für die Formulare anpassen, die auf dieser Formularvorlage basieren.

Seitenanfang

Überlegungen zur Kompatibilität

Wenn Sie eine Formularvorlage entwerfen, die auf einer Datenbank basiert, können Sie eine Browserkompatible Formularvorlage entwerfen. Von InfoPath wird eine Abfragedatenverbindung als primäre Datenverbindung in einer browserkompatiblen Formularvorlage erstellt. Browserkompatible Formularvorlagen können jedoch nicht so konfiguriert werden, dass Benutzer Daten an eine Datenbank absenden können. Wenn Sie also eine Formularvorlage entwerfen, die auf einer SQL Server-Datenbank basiert, und wenn die Benutzer die Formulardaten über die primäre Datenverbindung an die Datenbank absenden sollen, können Sie keine browserkompatible Formularvorlage verwenden.

Seitenanfang

Vorbemerkung

Um die Formularvorlage basierend auf einer SQL Server-Datenbank zu entwerfen, benötigen Sie die folgenden Informationen vom Datenbankadministrator:

  • Den Namen des Servers, der die Datenbank enthält, mit der Sie die Formularvorlage verbinden.

  • Den Namen der Datenbank, die Sie mit dieser Formularvorlage verwenden.

  • Die für die Datenbank erforderliche Authentifizierung. Für die Datenbank kann die Microsoft Windows-Authentifizierung oder die SQL Server-Authentifizierung verwendet werden, um den Benutzerzugriff auf die Datenbank zu bestimmen.

  • Den Namen der Tabelle, die die Daten enthält, die Sie an das Formular senden möchten, oder die die Daten vom Formular erhält. Dies ist die primäre Tabelle. Wenn Sie mehr als eine Tabelle der Datenbank verwenden möchten, benötigen Sie die Namen dieser anderen, untergeordneten Tabellen. Sie benötigen zudem die Namen der Felder in den untergeordneten Tabellen, die Beziehungen zu den Feldern in der primären Tabelle aufweisen.

Seitenanfang

Entwerfen der Formularvorlage

Zum Entwerfen einer Formularvorlage mit einer Abfragedatenverbindung müssen Sie die folgenden Aktionen ausführen:

  1. Erstellen der Formularvorlage    Wenn Sie eine Formularvorlage erstellen, die auf einer Datenbank basiert, wird von InfoPath eine Abfragedatenverbindung als primäre Datenverbindung zwischen der Formularvorlage und der Datenbank erstellt. Dabei wird automatisch die primäre Datenquelle der Formularvorlage erstellt.

  2. Fügen Sie eine oder mehrere Steuerelemente zum Anzeigen der Abfrageergebnisse    Damit die Benutzer zum Anzeigen und bearbeiten die Daten in den Feldern in der primären Datenquelle aus, wenn sie das Formular öffnen, können Sie Hinzufügen eines Steuerelements in der Formularvorlage und das Steuerelement dann an ein Feld in der primären Datenquelle binden.

Schritt 1: Erstellen der Formularvorlage

  1. Klicken Sie im Menü Datei auf Formularvorlage entwerfen.

  2. Klicken Sie im Dialogfeld Eine Formularvorlage entwerfen unter Neu entwerfen auf Formularvorlage.

  3. Klicken Sie in der Liste Basierend auf auf Datenbank.

  4. Wenn Sie eine browserkompatible Formularvorlage entwerfen, aktivieren Sie das Kontrollkästchen Nur browserkompatible Features aktivieren.

    Hinweis : Die Verbindung zum Absenden von Daten wird in einer browserkompatiblen Formularvorlage vom Datenverbindungs-Assistenten nicht aktiviert. Damit Benutzer Daten aus Formularen, die auf einer browserkompatiblen Formularvorlage basieren, an eine Datenbank senden können, fügen Sie einem Webdienst, der mit der Datenbank arbeitet, eine sekundäre Datenverbindung hinzu. Hyperlinks zu weiteren Informationen zu sekundären Datenverbindungen finden Sie im Abschnitt Siehe auch.

  5. Klicken Sie auf OK.

  6. Klicken Sie im Datenverbindungs-Assistenten auf Datenbank auswählen.

  7. Klicken Sie im Dialogfeld Datenquelle auswählen auf Neue Quelle.

  8. Klicken Sie in der Liste Zu welchem Datenquellentyp möchten Sie die Verbindung herstellen auf Microsoft SQL Server, und klicken Sie dann auf Weiter.

  9. Geben Sie in das Feld Servername den Namen des Servers mit der SQL Server-Datenbank ein.

  10. Führen Sie unter Anmeldeinformationen eine der folgenden Aktionen aus:

    • Wenn von der Datenbank basierend auf den in einem Microsoft Windows-Netzwerk verwendeten Anmeldeinformationen bestimmt wird, wer über Zugriff verfügt, klicken Sie auf Windows-Authentifizierung verwenden.

    • Wenn von der Datenbank basierend auf einem angegebenen vom Datenbankadministrator zugeteilten Benutzernamen und Kennwort bestimmt wird, wer über Zugriff verfügt, klicken Sie auf Benutzername und Kennwort verwenden, und geben Sie dann den Benutzernamen und das Kennwort in den Feldern Benutzername und Kennwort ein.

  11. Klicken Sie auf Weiter.

  12. Klicken Sie in der Liste Wählen Sie die Datenbank, die die benötigten Daten enthält auf den Namen der Datenbank, die Sie verwenden möchten. Aktivieren Sie das Kontrollkästchen Mit einer ausgewählten Tabelle verbinden, klicken Sie auf den Namen der primären Tabellen, und klicken Sie dann auf Weiter.

  13. Geben Sie auf der nächsten Seite des Assistenten in das Feld Dateiname einen Namen für die Datei ein, in der die Datenverbindungsinformationen gespeichert werden. Klicken Sie dann auf Fertig stellen, um diese Einstellungen zu speichern.

    Wenn Sie andere Tabellen in der Abfragedatenverbindung verwenden möchten, können Sie die anderen Tabellen auf dieser Seite des Assistenten hinzufügen.

    So wird's gemacht

    1. Klicken Sie auf Tabelle hinzufügen.

    2. Klicken Sie im Dialogfeld Tabelle oder Abfrage hinzufügen auf den Namen der untergeordneten Tabelle, und klicken Sie anschließend auf Weiter. InfoPath versucht, die Beziehungen einzurichten, indem es die Feldnamen der beiden Tabellen miteinander abgleicht. Wenn Sie eine vorgeschlagene Beziehung nicht verwenden möchten, wählen Sie die betreffende Beziehung und klicken anschließend auf Beziehung entfernen. Um eine Beziehung hinzuzufügen, klicken Sie auf Beziehung hinzufügen. Klicken Sie im Dialogfeld Beziehung hinzufügen in der jeweiligen Spalte auf die Namen aller verbundenen Felder und anschließend auf OK.

    3. Klicken Sie auf Fertig stellen.

    4. Wiederholen Sie diese Schritte, um zusätzliche untergeordnete Tabellen hinzuzufügen.

  14. Klicken Sie auf Weiter.

  15. Geben Sie auf der letzten Seite des Assistenten einen Namen für die Verbindung zum Hauptfenster Daten ein. Dieser Name wird in der Liste Datenquelle im Aufgabenbereich Datenquelle angezeigt.

  16. Wenn Ihre Formularvorlage die im Abschnitt Übersicht erfüllt, wird dieser Seite des Assistenten laut InfoPath die Verbindung zum Absenden von Daten in das Hauptfenster Datenverbindung aktiviert. Um den Namen für die Verbindung zum Übermitteln von Daten zu ändern, geben Sie einen neuen Namen in das entsprechende Feld ein. Wenn Ihre Benutzer übermitteln, dass ihre Formulardaten über einen anderen Datenverbindung Absenden, die Sie der Formularvorlage später hinzufügen werden soll, deaktivieren Sie das Kontrollkästchen Absenden für diese Verbindung aktivieren.

    Hinweis : Wenn Ihre Formularvorlage die Anforderungen im Abschnitt Übersicht nicht erfüllt, InfoPath deaktiviert die Verbindung zum Absenden von Daten und im Feld Geben Sie einen Namen für die Verbindung zum Absenden und das Kontrollkästchen Absenden für diese Verbindung aktivieren, sind nicht verfügbar (abgeblendet). Wenn die Verbindung zum Absenden von Daten mit InfoPath deaktiviert wird, kann die Datenverbindung Hauptfenster für die Formularvorlage nur eine Verbindung zum Abfragen von Daten sind.

Schritt 2: Hinzufügen eines oder mehrere Steuerelemente zum Anzeigen der Abfrageergebnisse

  1. Wenn der Aufgabenbereich Steuerelemente nicht angezeigt wird, klicken Sie im Menü Einfügen auf Weitere Steuerelemente, oder drücken Sie ALT+I, C.

  2. Ziehen Sie ein Steuerelement auf die Formularvorlage.

  3. Wählen Sie im Dialogfeld Steuerelement Bindung die Gruppe oder das Feld, das das Steuerelement gebunden werden soll.

Seitenanfang

Konfigurieren der Absendeoptionen

Wenn die Formularvorlage und die Tabellen, die Sie im Datenverbindungs-Assistenten ausgewählt die Anforderungen im Abschnitt Übersicht entsprechen, konfiguriert InfoPath Ihrer Formularvorlage, um Daten über die Verbindung zum Hauptfenster Daten zu übermitteln. Wenn Sie verwenden diese Datenverbindung übermitteln, InfoPath die Formularvorlage so konfiguriert, dass Benutzer ihre Formulardaten an die Datenbank übermitteln können und die Senden-Schaltfläche auf der Standardsymbolleiste und klicken Sie im Menü Datei den Befehl Absenden addiert, wenn Benutzer das Formular ausfüllen. InfoPath konfiguriert auch die Formularvorlage so, dass, wenn die Benutzer ihre Formulare senden, das Formular geöffnet bleibt und eine Meldung für den Benutzer, der angibt, ob das Formular erfolgreich gesendet wurde. Sie können den Text, klicken Sie auf die Schaltfläche Absenden und das Verhalten ändern, nachdem der Benutzer ein Formular übermittelt.

  1. Klicken Sie im Menü Extras auf Absendeoptionen.

    1. Zum Ändern des Namens der Schaltfläche Absenden, die auf der Standard-Symbolleiste angezeigt wird, und des Befehls Absenden, der im Menü Datei angezeigt wird, wenn der Benutzer das Formular ausfüllt, geben Sie den neuen Namen in das Feld Beschriftung im Dialogfeld Absendeoptionen ein.

      Tipp : Wenn Sie diese Schaltfläche und den Befehl eine Tastenkombination zuweisen möchten, geben Sie ein kaufmännisches und-Zeichen (&) vor dem Zeichen, das als Tastenkombination verwenden möchten. Geben Sie beispielsweise um ALT + B als Tastenkombination für die Senden-Schaltfläche und der Befehl zuweisen, & bsenden.

  2. Wenn beim Ausfüllen des Formulars der Befehl Absenden oder die Schaltfläche Absenden in der Symbolleiste Standard nicht verwendet werden soll, deaktivieren Sie das Kontrollkästchen Menüelement "Absenden" und in der Symbolleiste Schaltfläche "Absenden" anzeigen.

    1. In der Standardeinstellung bleibt das Formular in InfoPath weiterhin geöffnet, nachdem das Formular abgesendet wurde, und es wird eine Meldung angezeigt, dass der Sendevorgang erfolgreich abgeschlossen wurde. Um dieses Standardverhalten zu ändern, klicken Sie auf Erweitert, und führen Sie eine der folgenden Aktionen aus:

      • Um das Formular zu schließen oder ein neues, leeres Formular zu erstellen, nachdem ein ausgefülltes Formular gesendet wurde, klicken Sie in der Liste Nach dem Absenden auf die gewünschte Option.

      • Um eine benutzerdefinierte Meldung zu erstellen, die angibt, ob das Formular erfolgreich übertragen wurde, aktivieren Sie das Kontrollkästchen Benutzerdefinierte Meldung verwenden, und geben Sie anschließend die Meldungen in die Felder Absenden erfolgreich und Absenden fehlgeschlagen ein.

        Tipp : Geben Sie im Feld Absenden fehlgeschlagen eine Meldung mit Lösungsmöglichkeiten ein, wenn beim Absenden eines Formulars Probleme auftreten. Sie können beispielsweise empfehlen, das Formular zu speichern und sich an jemanden zu wenden, der weiterhelfen kann.

      • Wenn nach dem Absenden eines Formulars keine Meldung angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Meldung nach dem Absenden anzeigen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×