Einheitliches Abrufen und Transformieren

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

In Excel 2016 wurde unter der Bezeichnung Abrufen und Transformieren eine leistungsstarke Sammlung von Tools eingeführt. Diese Tools, die auf der Power Query-Technologie aufbauen, erlauben Ihnen auf einfache Weise, Verbindungen mit Daten aus einer Vielzahl von Quellen herzustellen, sie zu kombinieren und zu modellieren. Das folgende Abrufen und Transformieren-Tutorial führt Sie durch die Grundlagen.

Wir freuen uns, das nächste Hauptupdate für die Import- und Modellierungsfunktionen für Daten in Excel anzukündigen – die einheitliche Oberfläche zum Abrufen und Transformieren. Mit dem Update für Office 365 aus März 2017 haben wir die Excel-Funktionen zum Datenimport verbessert und die Schaltflächen auf der Registerkarte "Daten" neu angeordnet, sodass es leichter denn je ist, die Funktionen zum Abrufen und Transformieren in vollem Umfang zu nutzen.

Optionen für Abrufen und transformieren auf der Registerkarte "Daten"

Mit der vereinheitlichten Oberfläche zum Abrufen und Transformieren profitieren Sie von der gut integrierten und modernen Sammlung an Modellierungsfunktionen in Excel. Sie können auf einfache Weise Verbindungen herstellen und Daten aus einer Vielzahl beliebter Datenquellen abrufen, wie etwa Dateien, Datenbanken, Azure- und Onlinediensten und mehr. Und Sie können diese Daten auf sehr leistungsstarke Weise modellieren, indem Sie sie sortieren, Datentypen ändern, Spalten aufteilen, die Daten aggregieren usw. Das ständig wachsende Angebot an neuen Connectors sowie die leicht auszuführenden Transformationen machen Abrufen und Transformieren zu einem unschätzbaren, zeitsparenden Tool für Ihre tägliche Arbeit.

Beachten Sie, dass die neue Oberfläche die älteren Legacy-Assistenten für den Datenimport ersetzt, die unter Daten > Externe Daten abrufen verfügbar waren. Der Zugriff auf diese ist auf Wunsch aber immer noch möglich. Weitere Informationen finden Sie unter: Wie lässt sich die Legacy-Oberfläche "Externe Daten abrufen" wiederherstellen?

Hinweis : Dieses Feature ist in Excel nur verfügbar, wenn Sie über ein Office 365-Abonnement verfügen. Wenn Sie ein Office 365-Abonnent sind, vergewissern Sie sich, dass Sie über die neueste Office-Version verfügen.

Wie rufe ich Daten aus häufig verwendeten Quellen wie CSV-Dateien oder dem Internet ab?

Wir wissen, dass Benutzer, die Daten importieren, die besonders häufig verwendeten Connectors gern im Menüband im direkten Zugriff haben möchten. Mit diesem Update haben wir versucht, diesem Prinzip zu folgen, und haben die Oberfläche mit der Ihnen vertrauten konsistent gehalten. Sie finden die folgenden drei wichtigen Connectors im Abschnitt "Abrufen und Transformieren" auf der Registerkarte "Daten": Aus Text/CSV, Aus dem Web und Aus Tabelle/Bereich.

Aus Text/CSV

Mit diesem Connector können Sie auf einfache Weise Daten aus Ihren Textdateien (TXT), Dateien mit durch Trennzeichen getrennten Werten (CSV) oder formatierten Textdateien (PRN) importieren. Dieser moderne Connector basiert auf Power Query-Technologie und ersetzt den Legacy-Assistenten zum Importieren aus Text.

Um mit dem Importieren von Daten mit dem neuen Connector zu beginnen, klicken Sie auf Daten > Aus Text/CSV, wählen Sie die Quelldatei aus, und klicken Sie dann auf OK. Der neue und verbesserte Aus Text/CSV-Connector analysiert darauf hin Ihre Eingabedatei und wendet automatisch die relevanten Importeinstellungen an. Er kann die Spalten anhand von Trennzeichen aufteilen, die erste Zeile für die Verwendung als Spaltenüberschrift heraufstufen und mehr.

Optionen von Abrufen und transformieren aus Text

Wenn die Vorschau nicht das gewünschte Ergebnis zeigt, können Sie die grundlegenden Importeinstellungen, wie Dateiursprung, Trennzeichen oder Erkennungslogik für den Datentyp direkt dort konfigurieren. Auf der Grundlage der von Ihnen gewählten Optionen wird die Vorschau der Daten automatisch aktualisiert.

Anschließend können Sie auf Laden klicken, um die Daten direkt in Ihr Arbeitsblatt zu laden, oder auf den Pfeil neben Laden klicken, um die Daten in Ihr Datenmodell zu laden. Wenn Sie im Abfrage-Editor zusätzliche Datentransformationen anwenden möchten, klicken Sie auf Bearbeiten.

Aus dem Web

Mit diesem Connector können Sie Daten von HTML-Seiten "abziehen". Dies ist ein weiterer moderner Connector, der ebenfalls auf Power Query-Technologie basiert und den Legacy-Assistenten "Aus dem Web" ersetzt.

Um ihn zu verwenden, klicken Sie auf Daten > Aus dem Web, geben Sie die URL der Zielseite an, und klicken Sie dann auf OK. Im Navigator-Dialogfeld wird eine Liste aller Tabellen auf der Seite angezeigt. Sie haben die Möglichkeit, Aktionen für die Webseite entweder in der Tabellenansicht oder der Webansicht auszuführen. Klicken Sie in der Tabellenansicht zuerst links auf einen Tabellennamen, dann werden rechts Daten aus der betreffenden Tabelle angezeigt. In der Webansicht können Sie auf eine Tabelle entweder in der Navigatorliste oder im Vorschaubereich der Webansicht klicken. In beiden Ansichten können mehrere Tabellen ausgewählt werden.

Optionen von Abrufen und transformieren aus dem Web

Aus Tabelle/Bereich

Mit diesem Connector können Sie eine neue Abfrage erstellen, die mit einer Tabelle oder einem benannten Bereich in Ihrem Excel-Arbeitsblatt verknüpft ist. Anschließend können Sie Ihre Daten im Fenster des Abfrage-Editors weiter einschränken und weitere Transformationen auf sie anwenden.

Optionen von Abrufen und transformieren aus einer Tabelle

Wie rufe ich Daten aus zusätzlichen Quellen, wie XML-Dateien oder Microsoft SQL Server ab?

Sie können eine neue Abfrage erstellen, um Daten aus einer einzelnen Datenquelle zu importieren, wie z. B. einer Microsoft Access-Datenbank oder einem OData-Feed, oder Sie können Daten aus mehreren Textdateien in einem Ordner auf einmal importieren.

Wenn Sie auf Daten > Daten abrufen klicken, werden Ihnen die verfügbaren Datenquellen in einem Dropdownmenü angezeigt. Die Quelloptionen sind in Kategorien geordnet, die Dateien wie Excel-Arbeitsmappen, XML-Dateien oder den gesamten Ordner, Datenbanken wie SQL Server oder Oracle, Azure-Dienste wie HDInsight oder Blob Storage, Onlinedienste wie SharePoint-Online-Liste oder Salesforce und eine Vielzahl anderer Quellen, wie OData oder ODBC, beinhalten.

Die Liste der verfügbaren Connectors wächst ständig.

Optionen von Abrufen und transformieren aus einer Datenbank

Mit diesem Update haben wir außerdem die folgenden Legacy-Assistenten entfernt, die zuvor unter dem Abschnitt "Externe Daten abrufen" der Registerkarte "Daten" verfügbar waren: Aus Access, Aus dem Web, Aus Text, Aus SQL Server, Aus OData-Datenfeed, Aus XML-Datenimport und Aus dem Datenverbindungs-Assistenten. Informationen zum Vorgehen, wenn Sie aus irgendeinem Grund einen dieser entfernten Legacy-Assistenten verwenden müssen, finden Sie unter: Wie lässt sich die Legacy-Oberfläche "Externe Daten abrufen" wiederherstellen?

Es gibt jedoch zwei beliebte und ziemlich einzigartige Assistenten, die zur alten Funktionssammlung Externe Daten abrufen gehören und in der neuen Oberfläche erhalten bleiben: Aus Analysis Services und Aus Microsoft Query. Sie befinden sich in der neuen Oberfläche unter Daten > Aus Datenbank bzw. Daten > Aus anderen Quellen.

Wie nutze ich die Funktionen zum Abrufen und Transformieren, um meine Daten zu bereinigen und zu modellieren?

Mithilfe von Abrufen und Transformieren können Sie Ihre Daten als grundlegenden Schritt für eine stabile Datenanalyse bereinigen und modellieren. Sie können Spalten entfernen, Zeilen filtern, Spaltendatentypen ändern, Werte ersetzen und mehr. Dies erfolgt im dedizierten Fenster des Abfrage-Editors, das Ihre Datentransformationen erleichtert und sie anzeigt.

Wechseln Sie im Menüband zur Registerkarte Daten, klicken Sie auf Daten abrufen, stellen Sie mithilfe eines der verfügbaren Connectors eine Verbindung mit der gewünschten Datenquelle her (etwa einer Datei oder Datenbank), und führen Sie eine Vorschau Ihrer Daten im Navigator-Fenster aus.

Navigator von Abrufen und transformieren

Wählen Sie als nächstes die Tabellen aus, die Sie gerne importieren möchten, und klicken Sie auf Bearbeiten, um das Fenster des Abfrage-Editors zu starten.

Abfrage-Editor für Abrufen und transformieren

Verwenden Sie die umfangreiche Sammlung an Befehlen, die im Menüband im Fenster des Abfrage-Editors zur Verfügung stehen. Durch das Sortieren und Filtern von Daten, das Konvertieren von Datentypen, das Aufteilen oder Verbinden von Spalten, das Aggregieren ihrer Daten und mehr können Sie leistungsstarke Transformationen anwenden.

Alle Transformationsschritte, die Sie auf Ihre Daten anwenden, werden aufgezeichnet und als Teil Ihrer Abfrage gespeichert. Die aufgezeichneten Transformationen können im Bereich ANGEWENDETE SCHRITTE im Fenster des Abfrage-Editors verfolgt und verwaltet werden und werden bei jeder Aktualisierung Ihrer Abfrage erneut auf Ihre Daten angewendet.

Wie rufe ich Daten aus zuletzt verwendeten Quellen, ODC-Dateien (Office Database Connection), anderen Arbeitsmappenverbindungen oder Tabellen ab?

Eins der häufigsten Szenarien im Bereich des Datenimports ist das Herstellen von Verbindungen mit und das Abrufen von Daten aus den zuletzt verwendeten Quellen. Benutzer entwickeln oftmals im Lauf der Zeit einen Satz häufig verwendeter Quellen, mit denen sie Verbindungen herstellen, um Daten abzurufen.

Um eine Verbindung mit einer Ihrer zuletzt verwendeten Datenquellen herzustellen und daraus eine Abfrage zu erstellen, klicken Sie auf Daten > Zuletzt verwendete Quellen. Anschließend können Sie Ihre zuletzt verwendeten Quellen durchsuchen, eine auswählen, und dann auf Verbinden klicken, um den Importvorgang fortzusetzen.

Bereich "Zuletzt verwendete Quellen" von Abrufen und transformieren

Ein weiteres häufiges Szenario besteht im Importieren von Daten aus vorhandenen Verbindungen oder Tabellen in Ihrer Arbeitsmappe. Beispielsweise kann es sein, dass Sie auf der Grundlage einer zuvor erstellten Arbeitsmappenverbindung eine neue PivotTable erstellen möchten. Oder Sie möchten eine Verbindung mit einer Datenquelle mithilfe einer ODC-Datei (Office Database Connection) herstellen, die von jemand innerhalb Ihrer Organisation definiert wurde, und Daten daraus importieren.

Dieses Update gibt Ihnen die Möglichkeit, jede Ihrer Abfragedefinitionen in eine ODC-Datei zu exportieren, die Sie dann über Ihre Arbeitsmappen oder für Ihre Arbeitskollegen freigeben können. Um eine Abfragedefinition in eine ODC-Datei zu exportieren, klicken Sie im Seitenbereich Abfragen und Verbindungen mit der rechten Maustaste auf eine Abfrage, und wählen Sie Verbindungsdatei exportieren aus. Die erstellte ODC-Datei enthält die Definition Ihrer Abfrage mit allen Abhängigkeiten, einschließlich der Verbindungsanweisungen für die Datenquelle und den auf Ihre Daten angewendeten Transformationsschritten. Eine weitere Möglichkeit zum Exportieren einer Abfragedefinition besteht über das Dialogfeld Abfrageeigenschaften, das Sie durch Auswählen von Eigenschaften im Kontextmenü der Abfrage öffnen können.

Sobald Sie eine ODC-Datei erhalten, können Sie sie nutzen und die Abfragedefinition in Ihre Arbeitsmappe importieren. Um Daten über den ODC-Mechanismus zu importieren, klicken Sie auf Daten > Vorhandene Verbindungen. Das Dialogfeld Vorhandene Verbindungen wird angezeigt, und Sie können aus den verfügbaren ODC-Dateien, vorhandenen Arbeitsmappenverbindungen oder Tabellen importieren.

Auswählen unter vorhandenen Verbindungen oder Abfragen

Wenn Sie eine ODC-Datei erstellen müssen, die von einer anderen Anwendung, wie Visio oder Excel 2013 und früher, genutzt werden soll, können Sie das mithilfe der folgenden Connectors erreichen: Aus SQL Server-Datenbank, Aus Microsoft Access-Datenbank, Aus OData-Datenfeed, Aus Analysis Services, Aus Microsoft Query oder des Legacy-Connectors Aus Datenverbindungs-Assistent. Es ist wichtig, zu wissen, dass beim Nutzen der ODC-Dateien aus einer anderen Anwendung die Anwendung nur die Verbindungsanweisungen aus der ODC-Datei wiederverwendet und keine Transformationsschritte ausführt, die möglicherweise in Ihrer ursprünglichen Abfrage enthalten waren. Informationen zum Wiederherstellen der Legacy-Connectors Aus Access, Aus SQL Server, Aus OData-Datenfeed finden Sie unter: Wie lässt sich die Legacy-Oberfläche "Externe Daten abrufen" wiederherstellen?

Wie lassen sich vorhandene Arbeitsmappenabfragen und -verbindungen verwalten?

Bei der Einführung von Abrufen und Transformieren in Excel 2016 haben wir zwei Methoden für den Import von Daten vorgestellt: Die erste war die neue Oberfläche Abrufen und Transformieren, die Abfragen verwendet (und hinter den Kulissen darüber hinaus Arbeitsmappenverbindungen für die Aktualisierung und das Laden in Arbeitsmappenelemente nutzt). Die zweite war eine ältere Legacy-Oberfläche, die Arbeitsmappenverbindungen verwendet. Das Verwalten von Arbeitsmappenabfragen und -verbindungen erfolgte ebenfalls separat. Arbeitsmappenabfragen wurden im dedizierten Bereich "Abfragen" verwaltet, während Verbindungen im Dialogfeld "Arbeitsmappenverbindungen" verwaltet wurden. Dies hat bei unseren Benutzern zu Verwirrung geführt.

Mit diesem Update haben wir uns dieses Problems angenommen. Sie können jetzt im dedizierten Seitenbereich Abfragen und Verbindungen auf Ihre Arbeitsmappenabfragen und -verbindungen zugreifen und sie verwalten. Um diesen Seitenbereich zu öffnen, klicken Sie auf die Schaltfläche Daten > Abfragen und Verbindungen.

Bereich "Abfragen und Verbindungen" von Abrufen und transformieren

Wenn Sie auf die Registerkarte Abfragen oben im Bereich klicken, können Sie die in Ihrer Arbeitsmappe verfügbaren Abfragen durchsuchen und verwalten. Klicken Sie mit der rechten Maustaste auf eine Abfrage, um auf das Kontextmenü der Abfrage zuzugreifen, das Ihnen weitere Aktionen ermöglicht. Beispielsweise können Sie die Abfragedaten aus der zugrundeliegenden Quelle aktualisieren, die Abfrage kopieren/einfügen, Abfragetransformationen im Abfrage-Editor bearbeiten und mehr.

Außerdem haben wir die Verwaltung der Abfrage und ihrer zugrundeliegenden Verbindung durch das neue Dialogfeld Abfrageeigenschaften vereinfacht. Wenn Sie heute eine neue Abfrage in der Arbeitsmappe erstellen, wird hinter den Kulissen immer automatisch eine neue zugrundeliegende Verbindungsentität erstellt und der Abfrage zugeordnet. Während die Rolle der Abfrage darin besteht, die Verbindung mit der Datenquelle herzustellen und darüber hinaus die erforderlichen Datentransformationen auszuführen, steuert die zugrundeliegende Verbindung, wohin die Daten geladen werden (z. B. Arbeitsmappe oder Datenmodell) sowie die Aktualisierungseinstellungen für die Abfragedaten, wie etwa die Aktualisierungshäufigkeit. Mit dem neuen Dialogfeld Abfrageeigenschaften können Sie bequem zentral alle Abfrageeigenschaften steuern, wie etwa ihren Namen oder die Transformationsanweisungen und die zugrundeliegenden Verbindungseigenschaften, wie die Aktualisierungseinstellungen. Um das neue Dialogfeld Abfrageeigenschaften zu öffnen, klicken Sie auf den Befehl Eigenschaften im Kontextmenü der Abfrage im Seitenbereich Abfragen und Verbindungen.

Wenn Sie oben im Seitenbereich auf Verbindungen klicken, können Sie die verfügbaren Legacy-Verbindungen in Ihrer Arbeitsmappe durchsuchen und verwalten, die einem der Legacy-Assistenten zugeordnet sind, wie etwa Aus Text, Aus Analysis Services oder Aus Microsoft Query. Klicken Sie mit der rechten Maustaste auf eine Verbindung, um auf das Kontextmenü zuzugreifen. Dort können Sie zusätzliche Aktionen ausführen, etwa Verbindungsdaten aus der Quelle aktualisieren, Verbindungen löschen oder Verbindungseigenschaften mithilfe des vertrauten Dialogfelds Verbindungseigenschaften verwalten.

Wie lässt sich die Legacy-Oberfläche "Externe Daten abrufen" wiederherstellen?

Die neue Oberfläche ist den Legacy-Assistenten bei den angebotenen Connectors und Transformationsfunktionen überlegen. Es kann aber Fälle geben, in denen es sinnvoll sein kann, für den Import von Daten einen der alten Assistenten zu verwenden. Beispielsweise, wenn Sie die Anmeldeinformationen für die Datenquelle als Teil Ihrer Arbeitsmappe speichern möchten. (Bitte beachten Sie, dass dieses Verfahren nicht den heutigen Sicherheitsstandards entspricht und daher in der neuen Oberfläche Abrufen und Transformieren nicht unterstützt wird).

Sie können auf die Legacy-Connectors zugreifen, indem Sie das Menüband anpassen, oder Sie können mithilfe der neuen und einfachen Konfigurationseinstellungen im Excel-Dialogfeld "Optionen" die Legacy-Assistenten für den Datenimport direkt in das Dropdownmenü Daten > Daten abrufen zurückbringen und sie dort anzeigen.

Wechseln Sie zu Datei > Optionen > Daten > Legacy-Assistenten für den Datenimport anzeigen, und wählen Sie die Legacy-Assistenten aus, die Sie verwenden möchten:

Optionen zum Wiederherstellen von Legacydaten von Abrufen und transformieren

Öffnen Sie das Dropdownmenü Daten > Daten abrufen, und starten Sie einen der zuvor ausgewählten Legacy-Assistenten für den Datenimport aus der dedizierten Kategorie "Legacy-Assistenten":

Traditionelles Menü von Abrufen und transformieren

Weitere Informationen zu Abrufen und Transformieren

Wenn Sie mehr über die Funktionen von Abrufen und Transformieren erfahren möchten, stellt die Microsoft Power Query für Excel-Hilfe einen guten Ausgangspunkt dar.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×