Einführung in Abfragen

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Die Verwendung von Abfragen macht es einfacher, Daten in einer Access-Datenbank anzeigen, hinzufügen, zu löschen oder zu ändern. Weitere Gründe für die Verwendung von Abfragen:

  • Schnelles Auffinden bestimmter Datensätze durch Filtern nach speziellen Kriterien (Bedingungen)

  • Berechnen oder Zusammenfassen von Daten

  • Automatisieren von Datenverwaltungsaufgaben, wie z. B. die regelmäßige Überprüfung der aktuellen Daten

Sie erhalten eine weitere umfangreiche Sammlung von Abfrageoptionen, wenn Sie eine Access-Desktopdatenbank arbeiten, aber Access Web apps einige der bieten nachfolgend aufgeführten Abfrageoptionen. Weitere Informationen zu Access Web apps die neue Art der Datenbank, die Sie mit Access entwerfen und veröffentlichen online finden Sie unter Erstellen einer Access-app.

Hinweis :  Wenn Sie die Abfragen in den Beispielen verwenden möchten, müssen Sie eine Access-Desktopdatenbank verwenden.

Abfragen helfen Ihnen, Ihre Daten zu finden und mit ihnen zu arbeiten

Erstellen einer Auswahlabfrage

Erstellen einer Parameterabfrage

Erstellen einer Summenabfrage

Erstellen einer Kreuztabellenabfrage

Erstellen einer Tabellenerstellungsabfrage

Erstellen einer Anfügeabfrage

Erstellen einer Aktualisierungsabfrage

Erstellen einer Löschabfrage

Abfragen helfen Ihnen, Ihre Daten zu finden und mit ihnen zu arbeiten

In einer gut gestalteten Datenbank befinden sich die Daten, die Sie in einem Formular oder Bericht präsentieren möchten, häufig in mehreren Tabellen. Eine Abfrage kann die Informationen aus verschiedenen Tabellen abrufen und zusammensetzen, damit sie im Formular oder Bericht angezeigt werden können. Bei einer Abfrage kann es sich um eine Anforderung handeln, Datenergebnisse aus der Datenbank abzurufen und/oder Aktionen für Daten durchzuführen. Eine Abfrage kann Antworten auf einfache Fragen geben, Berechnungen ausführen, Daten aus verschiedenen Tabellen zusammenfassen, sowie Daten hinzufügen, ändern oder aus einer Datenbank löschen. Da Abfragen so vielseitig sind, gibt es viele verschiedenartige Abfragen, die von der jeweiligen Aufgabenstellung abhängig sind.

Wichtige Abfragetypen

Verwendung

Auswahl

Abrufen von Daten aus einer Tabelle oder Durchführen von Berechnungen

Aktion

Hinzufügen, Ändern oder Löschen von Daten. Für jede Aufgabe gibt es eine spezielle Aktionsabfrage. Aktionsabfragen sind in Access-Apps nicht verfügbar.

Seitenanfang

Erstellen einer Auswahlabfrage

Verwenden Sie eine Auswahlabfrage, wenn Sie nur Daten aus bestimmten Feldern in einer Tabelle überprüfen, Daten aus mehreren Tabellen gleichzeitig überprüfen oder Daten lediglich abhängig von bestimmten Kriterien anzeigen möchten. Weitere Informationen finden Sie unter Erstellen einer Auswahlabfrage.

Überprüfen von Daten ausgewählter Felder

Wenn die Datenbank beispielsweise eine Tabelle mit einer Vielzahl von Informationen zu Artikeln enthält, und Sie eine Liste der Artikel sowie deren Preise überprüfen möchten, können Sie eine Auswahlabfrage erstellen, die lediglich die Namen und die zugehörigen Preise von Artikeln zurückgibt. Gehen Sie dazu folgendermaßen vor:

  1. Öffnen Sie die Datenbank, und klicken Sie auf der Registerkarte Erstellen auf Abfrageentwurf.

  2. Doppelklicken Sie im Feld Tabelle anzeigen auf der Registerkarte Tabellen auf die Tabelle Artikel, und schließen Sie das Dialogfeld.

  3. Die Artikeltabelle enthält beispielsweise die Felder Artikelname und Listenpreis. Doppelklicken Sie auf Artikelname und Listenpreis, um diese Felder im Entwurfsbereich der Abfrage hinzuzufügen.

  4. Klicken Sie auf der Registerkarte Entwurf auf Ausführen. Die Abfrage wird ausgeführt, und zeigt eine Liste der Produkte und deren Preise.

Seitenanfang

Gleichzeitiges Überprüfen von Daten aus mehreren verknüpften Tabellen

Sie verfügen beispielsweise über eine Datenbank für ein Geschäft, das Lebensmittel verkauft, und möchten die Bestellungen von Kunden überprüfen, die in einer bestimmten Stadt wohnen. Die Daten zu Bestellungen bzw. Kunden sind in zwei Tabellen mit dem Namen Kunden und Bestellungen gespeichert. Jede Tabelle enthält das Feld Kunden-ID, das die Grundlage einer 1:n-Beziehung zwischen den beiden Tabellen bildet. Führen Sie die folgenden Schritte durch, um eine Abfrage zu erstellen, die Bestellungen für Kunden aus einer bestimmten Stadt (zum Beispiel Las Vegas) zurückgibt:

  1. Öffnen Sie die Datenbank, und klicken Sie auf der Registerkarte Erstellen in der Gruppe Abfrage auf Abfrageentwurf.

  2. Doppelklicken Sie im Dialogfeld Tabelle anzeigen auf der Registerkarte Tabellen auf Kunden und Bestellungen.

  3. Schließen Sie das Dialogfeld Tabelle anzeigen. Beachten Sie die als Verknüpfung bezeichnete Linie, die das ID-Feld in der Kundentabelle mit dem Feld Kunden-ID in der Tabelle Bestellungen verknüpft. Diese Linie zeigt die Beziehung zwischen den beiden Tabellen an.

  4. Doppelklicken Sie in der Kundentabelle auf Firma und Ort, um diese Felder im Abfrageentwurfsbereich hinzuzufügen.

  5. Deaktivieren Sie im Abfrageentwurfsbereich in der Spalte Ort das Kontrollkästchen in der Zeile Anzeigen.

  6. Geben Sie in der Zeile Kriterien der Spalte Ort das Kriterium Las Vegas ein.

    Durch Deaktivieren des Kontrollkästchens Anzeigen wird verhindert, dass der Ort in den Abfrageergebnissen angezeigt wird. Wenn Sie den Text Las Vegas in der Zeile Kriterien angeben, bedeutet dies, dass nur diejenigen Datensätze angezeigt werden sollen, bei denen der Wert des Felds Ort die Stadt Las Vegas ist. In diesem Fall gibt die Abfrage als Ergebnisse nur diejenigen Kunden zurück, die in Las Vegas ansässig sind. Sie müssen ein Feld nicht anzeigen, damit es in einem Kriterium verwendet werden kann

  7. Doppelklicken Sie in der Tabelle Bestellungen auf Bestell-Nr. und Bestelldatum, um diese Felder in den nächsten beiden Spalten des Abfrageentwurfsbereichs hinzuzufügen.

  8. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen. Die Abfrage wird ausgeführt, und es wird eine Liste der Artikel mit den jeweiligen Preisen angezeigt.

  9. Drücken Sie STRG+S, um die Abfrage zu speichern.

Seitenanfang

Erstellen einer Parameterabfrage

Wenn Sie häufig Varianten einer bestimmten Abfrage ausführen, können Sie eine Parameterabfrage verwenden. Wenn Sie eine Parameterabfrage ausführen, werden Sie zur Eingabe von Feldwerten aufgefordert. Die angegebenen Werte werden zum Erstellen der Kriterien für die Abfrage verwendet.

Hinweis :  Sie können in Access-Apps keine Parameterabfragen erstellen.

Ausgehend vom vorherigen Beispiel, in dem das Erstellen einer Auswahlabfrage erklärt wurde, die Bestellungen für Kunden in Las Vegas zurückgibt, können Sie die Auswahlabfrage so ändern, dass Sie beim Ausführen der Abfrage aufgefordert werden, den Ort anzugeben. Öffnen Sie die Datenbank, die Sie im vorherigen Beispiel erstellt haben, um den Ausführungen folgen zu können:

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf die Abfrage namens Bestellungen nach Ort (die Sie im vorherigen Abschnitt erstellt haben), und klicken Sie dann im Kontextmenü auf Entwurfsansicht.

  2. Klicken Sie im Abfrageentwurfsbereich in der Zeile Kriterien der Spalte Ort löschen Sie Las Vegas, und geben Sie dann [für welchen city?].

    Bei der Zeichenfolge [Für welchen Ort?] handelt es sich um die Aufforderung zur Eingabe des Parameters. Die eckigen Klammern geben an, dass die Abfrage zur Eingabe auffordern soll. Der Text (in diesem Fall Für welchen Ort?) ist die Frage, die in der Eingabeaufforderung für den Parameter angezeigt wird.

Hinweis : In einer Aufforderung zur Eingabe von Parametern darf als Text weder ein Punkt (.) noch ein Ausrufezeichen (!) verwendet werden.

  1. Aktivieren Sie das Kontrollkästchen in der Zeile Anzeigen der Spalte Ort, sodass der Ort in den Abfrageergebnissen angezeigt wird.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen. Die Abfrage fordert Sie zum Eingeben eines Werts für den Ort auf.

  3. Geben Sie New York ein, und drücken Sie die EINGABETASTE, um die Bestellungen für Kunden in New York anzuzeigen.

    Wie gehen Sie jedoch vor, wenn Sie nicht wissen, welche Werte Sie angeben können? Sie können in der Eingabeaufforderung Platzhalterzeichen verwenden:

  4. Klicken Sie auf der Registerkarte Start in der Gruppe Ansichten auf Ansicht und dann auf Entwurfsansicht.

  5. Geben Sie im Abfrageentwurfsbereich in der Zeile Kriterien der Spalte Ort den Text Wie [Für welchen Ort?]&"*" ein.

    In dieser Aufforderung zur Eingabe von Parametern bieten das Schlüsselwort Wie, das kaufmännische Und-Zeichen (&) und das in Anführungszeichen eingeschlossene Sternchen (*) dem Benutzer die Möglichkeit, eine Kombination aus Zeichen, einschließlich Platzhalterzeichen, einzugeben, mit denen eine Vielzahl von Ergebnissen zurückgegeben werden kann. Wenn Benutzer beispielsweise * eingeben, gibt die Abfrage sämtliche Orte zurück. Bei Eingabe von L gibt die Abfrage alle Orte zurück, deren Name mit dem Buchstaben "L" beginnt, und bei Eingabe von *s* werden alle Orte zurückgegeben, deren Name den Buchstaben "s" enthält.

  6. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen. Geben Sie in der Eingabeaufforderung der Abfrage New ein, und drücken Sie die EINGABETASTE.

    Die Abfrage wird ausgeführt, und es werden die Bestellungen für Kunden in New York angezeigt.

Angeben von Parameterdatentypen

Sie können auch angeben, welche Art von Daten ein Parameter übernehmen soll. Sie können den Datentyp für jeden beliebigen Parameter festlegen, es ist jedoch insbesondere wichtig, den Datentyp für nummerische Daten, Währungsdaten oder Datums-/Uhrzeitdaten festzulegen. Wenn Sie den Datentyp angeben, den ein Parameter übernehmen soll, wird den Benutzern eine hilfreiche Fehlermeldung angezeigt, falls sie einen falschen Datentyp eingeben (beispielsweise Eingabe von Text an einer Stelle, an der eine Währung erwartet wird).

Wenn der Parameter so eingerichtet ist, dass er Textdaten akzeptiert, wird jede Eingabe als Text interpretiert, ohne dass eine Fehlermeldung angezeigt wird.

Führen Sie die folgenden Schritte durch, um den Datentyp für Parameter in einer Abfrage anzugeben:

  1. Klicken Sie bei geöffneter Abfrage in der Entwurfsansicht auf der Registerkarte Entwurf in der Gruppe Einblenden/Ausblenden auf Parameter.

  2. Geben Sie im Dialogfeld Abfrageparameter in der Spalte Parameter die Eingabeaufforderung für die einzelnen Parameter ein, für die der Datentyp angegeben werden soll. Achten Sie darauf, dass jeder Parameter der in der Zeile Kriterien des Abfrageentwurfsbereichs verwendeten Eingabeaufforderung entspricht.

  3. Wählen Sie in der Spalte Datentyp den Datentyp für jeden Parameter aus.

Weitere Informationen hierzu finden Sie unter Eingabeparameter beim Ausführen einer Abfrage.

Seitenanfang

Erstellen einer Summenabfrage

Die Ergebniszeile in einem Datenblatt ist sehr nützlich. Für komplexere Fragen sollten Sie jedoch eine Summenabfrage einsetzen. Bei einer Summenabfrage handelt es sich um eine Auswahlabfrage, mit der Sie Daten gruppieren und zusammenzufassen können, um beispielsweise den Gesamtumsatz je Artikel anzuzeigen. In einer Summenabfrage können Sie die Aggregatfunktion Summe verwenden, um den Gesamtumsatz je Artikel anzuzeigen.

Hinweis : Sie können in einer Access-App keine Aggregatfunktionen verwenden.

Führen Sie die folgenden Schritte aus, um die Abfrage Artikelzwischensummen, die Sie im vorherigen Beispiel erstellt haben, so zu ändern, dass sie die Artikelzwischensummen nach Artikel zusammenfasst.

  1. Klicken Sie auf der Registerkarte Start auf Ansicht > Entwurfsansicht.

    Die Abfrage Artikelzwischensummen wird in der Entwurfsansicht geöffnet.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Einblenden/Ausblenden auf Summen.

    Die Zeile Funktion wird im Abfrageentwurfsbereich angezeigt.

Hinweis : Die Zeile Funktion im Entwurfsbereich und die Zeile Summe in einem Datenblatt sind zwar vergleichbar, aber nicht identisch:

  • Mithilfe der Zeile Funktion im Entwurfsbereich können Sie Daten nach Feldwerten gruppieren.

  • Sie können die Zeile Summe eines Datenblatts zu den Ergebnissen einer Summenabfrage hinzufügen.

  • Wenn Sie die Zeile Funktion im Entwurfsbereich verwenden, müssen Sie für jedes Feld eine Aggregatfunktion auswählen. Falls Sie keine Berechnung für ein Feld durchführen möchten, können Sie nach dem Feld gruppieren.

  • Wählen Sie in der zweiten Spalte des Entwurfsbereichs in der Zeile Funktion in der Dropdownliste Summe aus.

  • Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen. Die Abfrage wird ausgeführt, und eine Liste der Artikel mit Zwischensummen wird angezeigt.

  • Drücken Sie STRG+S, um die Abfrage zu speichern. Lassen Sie die Abfrage geöffnet.

Weitere Informationen finden Sie unter Summieren von Werten in einem Datenblatt mit einer Ergebniszeile

Seitenanfang

Durchführen von Berechnungen basierend auf den Daten

Normalerweise werden in Tabellen keine berechneten Werte wie Zwischensummen gespeichert (auch dann nicht, wenn sie auf den Daten in der jeweiligen Datenbank basieren), da berechnete Werte veralten können, wenn die zugrundeliegenden Werte geändert werden. Beispielsweise empfiehlt es sich nicht, das Alter einer Person in einer Tabelle zu speichern, da dieser Wert jedes Jahr aktualisiert werden muss. Speichern Sie stattdessen das Geburtsdatum der Person, und verwenden Sie dann eine Abfrage, um das Alter der Person zu berechnen.

Sie verfügen beispielsweise über eine Datenbank für Artikel, die Sie verkaufen möchten. Diese Datenbank umfasst eine Tabelle namens Bestelldetails, die in Feldern Informationen zu den Artikeln enthält, wie z. B. Preis der einzelnen Artikel und Mengen. Sie können die Zwischensumme mithilfe einer Abfrage berechnen. Dabei wird die Anzahl jedes Artikels mit dem Einzelpreis für diesen Artikel multipliziert. Dann wird die Anzahl jedes Artikels mit dem Einzelpreis und dem Rabatt für diesen Artikel multipliziert. Anschließend wird der Gesamtrabatt von dem Gesamteinzelpreis abgezogen. Falls Sie die Beispieldatenbank im vorherigen Beispiel erstellt haben, öffnen Sie die, und folgenden Sie den Anweisungen:

  1. Registerkarte ' Erstellen ', klicken Sie auf Abfrageentwurf.

  2. In der im Dialogfeld Tabelle anzeigen im Feld Aktivieren der Registerkarte " Tabellen ", doppelklicken Sie auf Bestelldetails.

  3. Schließen der im Dialogfeld Tabelle anzeigen.

  4. Doppelklicken Sie in der Tabelle Bestelldetails auf Produkt-ID, um dieses Feld in der ersten Spalte des Abfrageentwurfsbereichs hinzuzufügen.

  5. In der zweiten Spalte des Entwurfsbereichs mit der Maustaste die Zeile Feld, und klicken Sie dann auf im Kontextmenü auf Zoom.

  6. In der im Feld Zoom geben oder fügen Sie die folgenden: Teilergebnis: ([Menge] * [Einzelpreis])-([Menge] * [Unit Price]*[Discount])

  7. Klicken Sie auf OK.

  8. Klicken Sie auf der Entwurf, klicken Sie auf Ausführen. Die Abfrage wird ausgeführt, und klicken Sie dann zeigt eine Liste der Produkte und Zwischensummen, pro Reihenfolge.

  9. Drücken Sie STRG+S, um die Abfrage zu speichern, und geben Sie als Bezeichnung der Abfrage Artikelzwischensummen an.

Weitere Informationen finden Sie außerdem unter Summieren von Werten in einem Datenblatt mit einer Ergebniszeile

Seitenanfang

Anzeigen zusammengefasster oder aggregierter Daten

Wenn Sie zum Erfassen von Transaktionen oder Speichern regelmäßig vorkommender nummerischer Daten Tabellen verwenden, ist es nützlich, wenn diese Daten als Aggregatdaten (zum Beispiel Summen oder Mittelwerte) angezeigt werden können. In Access können Sie eine Ergebniszeile zu einem Datenblatt hinzufügen. Die Ergebniszeile ist eine Zeile am Ende des Datenblatts, in der eine laufende Summe oder ein anderer Aggregatwert angezeigt werden kann.

  1. Führen Sie die Abfrage Artikelzwischensummen aus, und lassen Sie die Ergebnisse in der Datenblattansicht geöffnet.

  2. Klicken Sie auf der Registerkarte Start, klicken Sie auf Summen. Wird eine neue Zeile am Ende der Datenblatt, mit dem Word Total in die erste Spalte.

  3. Klicken Sie auf die Zelle in der letzten Zeile des Datenblatts Total.

  4. Klicken Sie auf den Pfeil, um die verfügbaren Aggregatfunktionen anzeigen. Da die Spalte Textdaten enthält, sind nur zwei Optionen: keine und Anzahl.

  5. Wählen Sie Anzahl. Der Inhalt der Zelle ändert sich von Summe in Anzahl der Werte in den Spalten.

  6. Klicken Sie auf die angrenzende Zelle (die zweite Spalte). Beachten Sie, dass in der Zelle ein Pfeil angezeigt wird.

  7. Klicken Sie auf den Pfeil, und klicken Sie dann auf Summe. Das Feld zeigt die Summe der Werte in den Spalten an.

  8. Lassen Sie die Abfrage in der Datenblattansicht geöffnet.

Seitenanfang

Erstellen einer Kreuztabellenabfrage

Angenommen, Sie möchten Artikelzwischensummen anzeigen, diese jedoch auch monatlich summieren, sodass in jeder Zeile die Zwischensummen für einen Artikel und in jeder Spalte die Artikelzwischensummen für einen Monat angezeigt werden. Zum Anzeigen der Zwischensummen für einen Artikel und der Artikelzwischensummen für einen Monat verwenden Sie eine Kreuztabellenabfrage.

Hinweis : Eine Kreuztabellenabfrage kann nicht in einer Access-App angezeigt werden.

Sie können die Abfrage Artikelzwischensummen erneut ändern, sodass die Abfrage nun Zeilen mit Artikelzwischensummen und Spalten mit monatlichen Zwischensummen zurückgibt.

  1. Klicken Sie auf der Registerkarte Start in der Gruppe Ansichten auf Ansicht und dann auf Entwurfsansicht.

  2. Klicken Sie in der Gruppe Abfragesetup auf Tabelle anzeigen.

  3. Doppelklicken Sie im Dialogfeld Tabelle anzeigen auf Bestellungen und dann auf Schließen.

  4. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Abfragetyp auf Kreuztabelle. Im Entwurfsbereich ist die Zeile Anzeigen ausgeblendet, und die Zeile Kreuztabelle wird angezeigt.

  5. Klicken Sie in der dritten Spalte des Entwurfsbereichs mit der rechten Maustaste auf die Zeile Feld, und klicken Sie dann im Kontextmenü auf Zoom. Das Feld Zoom wird geöffnet.

  6. Geben oder fügen Sie im Feld Zoom den folgenden Text ein: Monat: "Monat " & DatTeil("m", [Bestelldatum])

  7. Klicken Sie auf OK.

  8. Wählen Sie in der Zeile Kreuztabelle in der Dropdownliste die folgenden Werte aus: Zeilenüberschrift für die erste Spalte, Wert für die zweite Spalte und Spaltenüberschrift für die dritte Spalte.

  9. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen. Die Abfrage wird ausgeführt, und die nach Monat summierten Artikelzwischensummen werden angezeigt.

  10. Drücken Sie STRG+S, um die Abfrage zu speichern.

    Weitere Informationen finden Sie unter

Seitenanfang

Erstellen einer Tabellenerstellungsabfrage

Mit einer Tabellenerstellungsabfrage können Sie eine neue Tabelle aus Daten erstellen, die in anderen Tabellen gespeichert sind.

Hinweis :  Tabellenerstellungsabfragen sind in Access-Apps nicht verfügbar.

Angenommen, Sie möchten Daten für Bestellungen aus Chicago an einen Geschäftspartner in Chicago senden, der seine Berichte mithilfe von Access vorbereitet. Statt sämtliche Bestelldaten zu senden, möchten Sie nur diejenigen Daten senden, die sich auf Bestellungen aus Chicago beziehen.

Sie können eine Auswahlabfrage erstellen, die Bestelldaten aus Chicago enthält, und mithilfe dieser Auswahlabfrage dann die neue Tabelle erstellen. Führen Sie dazu die folgenden Schritte durch:

  1. Öffnen Sie die Beispieldatenbank aus dem vorherigen Beispiel.

    Zum Ausführen einer Tabellenerstellungsabfrage müssen Sie möglicherweise den Datenbankinhalt aktivieren.

    Hinweis : Wenn Sie eine Nachricht unterhalb der Multifunktionsleiste zum Aktivieren der Datenbank angezeigt wird, klicken Sie auf Inhalt aktivieren., Wenn Ihre Datenbank bereits an einem vertrauenswürdigen Speicherort ist, werden Sie nicht die Statusleiste angezeigt.

  2. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Abfrage auf Abfrageentwurf.

  3. Doppelklicken Sie im Dialogfeld Tabelle anzeigen auf Bestelldetails und Bestellungen, und schließen Sie das Dialogfeld Tabelle anzeigen.

  4. Doppelklicken Sie in der Tabelle Bestellungen auf Kunden-ID und Lieferort, um diese Felder im Entwurfsbereich hinzuzufügen.

  5. Doppelklicken Sie in der Tabelle Bestelldetails auf Bestell-Nr., Artikel-Nr., Anzahl, Einzelpreis und Rabatt, um diese Felder im Entwurfsbereich hinzuzufügen.

  6. Deaktivieren Sie in der Spalte Lieferort des Entwurfsbereichs das Kontrollkästchen in der Zeile Anzeigen. Geben Sie in der Zeile Kriterien die Stadt 'Chicago' (einschließlich der einfachen Anführungszeichen) ein. Überprüfen Sie die Abfrageergebnisse, bevor Sie sie zum Erstellen der Tabelle verwenden.

  7. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen.

  8. Drücken Sie STRG+S, um die Abfrage zu speichern.

  9. Geben Sie im Feld Abfragename den Text Abfrage Bestellungen aus Chicago ein, und klicken Sie auf OK.

  10. Klicken Sie auf der Registerkarte Start in der Gruppe Ansichten auf Ansicht und dann auf Entwurfsansicht.

  11. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Abfragetyp auf Tabelle erstellen.

  12. Geben Sie im Dialogfeld Tabelle erstellen im Feld Tabellenname den Text Bestellungen Chicago ein, und klicken Sie dann auf OK.

  13. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen.

  14. Klicken Sie im Bestätigungsdialogfeld auf Ja. Die neue Tabelle wird im Navigationsbereich angezeigt.

    Hinweis : Wenn bereits eine Tabelle mit demselben Namen vorhanden ist wie dem, den Sie angegebene haben, löscht Access diese Tabelle, bevor die Abfrage ausgeführt wird.

Seitenanfang

Erstellen einer Anfügeabfrage

Mit einer Anfügeabfrage können Sie Daten aus einer oder mehreren Tabellen abrufen und diese in einer anderen Tabelle hinzufügen.

Hinweis : Anfügeabfragen sind in Access-Apps nicht verfügbar.

Angenommen, Sie haben beispielsweise eine Tabelle erstellt, die Sie einem Geschäftspartner in Chicago zur Verfügung stellen möchten. Sie haben aber festgestellt, dass Ihr Partner auch mit Kunden in das Gebiet Milwaukee arbeitet. Daher möchten Sie Zeilen mit Daten für das Gebiet Milwaukee zur Tabelle hinzufügen, bevor Sie die Tabelle Ihrem Partner zur Verfügung stellen. Führen Sie die folgenden Schritte aus, um Daten für das Gebiet Milwaukee zur Tabelle Bestellungen Chicago hinzuzufügen:

  1. Öffnen Sie die Abfrage Abfrage Bestellungen aus Chicago in der Entwurfsansicht.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Abfragetyp auf Anfügen. Das Dialogfeld Anfügen wird geöffnet.

  3. Klicken Sie im Dialogfeld Anfügen auf den Pfeil im Feld Tabellenname. Wählen Sie dann in der Dropdownliste Bestellungen Chicago aus, und klicken Sie auf OK.

  4. Löschen Sie im Entwurfsbereich in der Zeile Kriterien der Spalte Lieferort den Text 'Chicago', und geben Sie dann 'Milwaukee' ein.

  5. Wählen Sie in der Zeile Anfügen an das entsprechende Feld für jede Spalte aus.

    In diesem Beispiel sollten die Werte der Zeile Anfügen an den Werten in der Zeile Feld entsprechen. Dies ist jedoch nicht erforderlich, damit Anfügeabfragen funktionieren.

  6. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen.

Hinweis :  Bei der Ausführung einer Abfrage, die sehr viele Daten zurückgibt, kann u. U. eine Fehlermeldung mit dem Hinweis angezeigt werden, dass die Abfrage nicht rückgängig gemacht werden kann. Versuchen Sie, den Grenzwert für das Speichersegment auf 3 MB zu erhöhen, damit die Abfrage ausgeführt werden kann.

Seitenanfang

Erstellen einer Aktualisierungsabfrage

Mit einer Aktualisierungsabfrage können Sie Daten in den Tabellen ändern oder Kriterien eingeben, mit denen angegeben wird, welche Zeilen aktualisiert werden sollen. Eine Aktualisierungsabfrage bietet Ihnen die Möglichkeit, die aktualisierten Daten zu überprüfen, bevor Sie die Aktualisierung durchführen.

Wichtig : Eine Aktionsabfrage kann nicht rückgängig gemacht werden. Sie sollten ggf. eine Sicherungskopie der Tabellen erstellen, die mit einer Aktualisierungsabfrage aktualisiert werden sollen.

Hinweis : Aktualisierungsabfragen sind in Access-Apps nicht verfügbar.

Im vorherigen Beispiel haben Sie Zeilen an die Tabelle Bestellungen Chicago angefügt. In der Tabelle Bestellungen Chicago enthält das Feld Artikel-Nr die numerische Artikel-Nr. Damit die Daten in Berichten verständlicher sind, können Sie die Artikel-Nr durch den Produktnamen ersetzen. Gehen Sie dazu folgendermaßen vor:

  1. Öffnen Sie die Tabelle Bestellungen Chicago in der Entwurfsansicht.

  2. Ändern Sie in der Zeile Artikel-Nr. den Datentyp von Zahl in Text.

  3. Speichern und schließen Sie die Tabelle Bestellungen Chicago.

  4. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Abfrage auf Abfrageentwurf.

  5. Doppelklicken Sie im Dialogfeld Tabelle anzeigen auf Bestellungen Chicago und Artikel, und schließen Sie das Dialogfeld Tabelle anzeigen.

  6. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Abfragetyp auf Aktualisieren.

  7. Im Entwurfsbereich werden die Zeilen Sortieren und Anzeigen nicht mehr angezeigt. Die Zeile Jetzt aktualisieren wird nun angezeigt.

  8. Doppelklicken Sie in der Tabelle Bestellungen Chicago auf Artikel-Nr., um dieses Feld im Entwurfsbereich hinzuzufügen.

  9. Geben oder fügen Sie im Entwurfsbereich in der Zeile Aktualisieren der Spalte Artikel-Nr. den folgenden Text ein:[Artikel].[Artikelname]

    Tipp : Mit einer Aktualisierungsabfrage können Sie Feldwerte löschen, indem Sie in der Zeile Aktualisieren eine leere Zeichenfolge ("") oder NULL verwenden.

  10. Geben oder fügen Sie in der Zeile Kriterien den folgenden Text ein: [Artikel-Nr] Wie ([Artikel].[ID])

  11. Welche Werte durch eine Aktualisierungsabfrage geändert werden, können Sie überprüfen, indem Sie die Abfrage in der Datenblattansicht anzeigen.

  12. Klicken Sie auf der Registerkarte Entwurf auf Ansicht > Datenblattansicht. Die Abfrage gibt eine Liste der Produkt-IDs, die aktualisiert werden sollen.

  13. Klicken Sie auf der Registerkarte Entwurf auf Ausführen.

    Wenn Sie die Tabelle Bestellungen Chicago öffnen, stellen Sie fest, dass die numerischen Werte im Feld Artikel-Nr. durch die Artikelnamen aus der Artikeltabelle ersetzt wurden. Siehe Erstellen einer Aktualisierungsabfrage.

Seitenanfang

Erstellen einer Löschabfrage

Mit einer Löschabfrage können Sie Daten aus den Tabellen löschen. Weiterhin können Sie eine Löschabfrage verwenden, um Kriterien einzugeben, mit denen angegeben wird, welche Zeilen gelöscht werden sollen. Eine Löschabfrage bietet Ihnen die Möglichkeit, vor Durchführung des Löschvorgangs die Zeilen zu überprüfen, die gelöscht werden.

Hinweis : Löschabfragen sind in Access-Apps nicht verfügbar.

Angenommen, Sie wollten die Tabelle Bestellungen Chicago aus dem vorherigen Beispiel an Ihren Geschäftspartner in Chicago senden, haben dabei aber festgestellt, dass einige Zeilen mehrere leere Felder enthalten. Sie entschließen sich, die betreffenden Zeilen zu löschen, bevor Sie die Tabelle senden. Sie können die Tabelle einfach öffnen und die Zeilen manuell löschen. Wenn jedoch viele Zeilen gelöscht werden müssen und klare Kriterien für die Zeilen, die gelöscht werden sollen, vorhanden sind, kann eine Löschabfrage von Nutzen sein.

Führen Sie die folgenden Schritte durch, um eine Abfrage zum Löschen der Zeilen in der Tabelle Bestellungen Chicago zu verwenden, in denen kein Wert für die Artikelnummer vorhanden ist:

  1. Klicken Sie auf der Registerkarte Erstellen auf Abfrageentwurf.

  2. Doppelklicken Sie im Feld Tabelle anzeigen auf Bestellungen Chicago, und schließen Sie das Feld Tabelle anzeigen.

  3. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Abfragetyp auf Löschen. Klicken Sie im Entwurfsbereich die Sortieren und Anzeigen von Zeilen ausgeblendet, und die Zeile Löschen wird angezeigt.

  4. Doppelklicken Sie in der Tabelle Bestellungen Chicago auf Bestell-Nr, um sie im Entwurfsbereich hinzuzufügen.

  5. Geben Sie im Entwurfsbereich in der Zeile Kriterien der Spalte Bestell-Nr. den Text Ist Null ein.

  6. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Ergebnisse auf Ausführen.

Lesen Sie auch Erstellen einer Löschabfrage.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

War diese Information hilfreich?

Wie können wir es verbessern?

Wie können wir es verbessern?

Um Ihre Privatsphäre zu schützen, geben Sie bitte keine Kontaktinformationen in Ihrem Feedback an. Lesen Sie unsere Datenschutzbestimmung.

Vielen Dank für Ihr Feedback!