Einfügen eines Datenblatts in ein Formular

Ein Datenblatt ist eine einfache Ansicht von Daten, die in Zeilen und Spalten angeordnet sind. Wenn Sie im Navigationsbereich auf eine Tabelle doppelklicken, wird die Tabelle von Microsoft Office Access 2007 als Datenblatt angezeigt. Aufgrund der kompakten Darstellung der Daten sind Datenblätter besonders geeignet, wenn die als Unterformulare zum Anzeigen der n-Seite einer 1:n-Beziehung verwendet werden. In diesem Artikel wird beschrieben, wie Sie Ihren Formularen in Office Access 2007 Datenblätter hinzufügen können.

Was möchten Sie tun?

Anzeigen eines Beispiels für ein Datenblatt in einem Formular

Herstellen von Beziehungen zwischen Tabellen

Erstellen eines Formulars mit einem Datenblatt unter Verwendung des Tools für Formulare

Erstellen eines Formulars mit einem Datenblatt unter Verwendung der Layoutansicht

Einfügen eines Datenblatts in ein vorhandenes Formular unter Verwendung der Layoutansicht

Einfügen eines Datenblatts in ein vorhandenes Formular mithilfe der Entwurfsansicht

Grundlegende Unterschiede zwischen einem geteilten Formular und einem Formular mit einem Datenblatt

Anzeigen eines Beispiels für ein Datenblatt in einem Formular

Angenommen, Sie möchten ein Formular erstellen, in dem Daten zu Produktkategorien sowie alle Artikel innerhalb dieser Kategorien angezeigt werden. Die Daten in der Tabelle Kategorien repräsentieren die 1-Seite der Beziehung, und die Daten in der Tabelle Artikel repräsentieren die n-Seite der Beziehung. Für jede Kategorie können mehrere Artikel vorhanden sein.

Formular mit einem Unterformular

1. Im Hauptformular werden Daten der 1-Seite der Beziehung angezeigt.

2. Im Datenblatt werden Daten der n-Seite der Beziehung angezeigt.

Seitenanfang

Herstellen von Beziehungen zwischen Tabellen

Bevor Sie ein Formular mit einem Datenblatt entwerfen, müssen Sie die Beziehungen zwischen den Tabellen überprüfen und ggf. fehlende Beziehungen hinzufügen. Dadurch können von Access automatisch die Verknüpfungen zwischen Datenblättern und Hauptformularen hergestellt werden. Klicken Sie auf der Registerkarte Erweiterte Tools in der Gruppe Analyse auf Beziehungen, um Beziehungen zwischen den Tabellen in der Datenbank anzuzeigen, hinzuzufügen oder zu ändern. Weitere Informationen zum Erstellen von Beziehungen finden Sie im Abschnitt Siehe auch.

Seitenanfang

Erstellen eines Formulars mit einem Datenblatt unter Verwendung des Tools für Formulare

Wenn Sie mit dem Tool für Formulare ein Formular erstellen, das auf einer Tabelle auf der 1-Seite einer 1:n-Beziehung basiert, wird von Access automatisch ein Datenblatt eingefügt.

Wenn beispielsweise die folgenden Bedingungen zutreffen, wird von Access ein Datenblatt eingefügt, in dem alle Bestellungen für alle Kunden angezeigt werden:

  • Sie erstellen ein einfaches Formular, das auf der Tabelle Kunden basiert.

  • Sie haben eine 1:n-Beziehung mit der Tabelle Bestellungen definiert, in der ein Datensatz in der Tabelle Kunden angegeben ist, der mit mehreren Datensätzen in der Tabelle Bestellungen verknüpft sein kann.

  • Die Tabelle Kunden befindet sich nicht auf der 1-Seite einer anderen 1:n-Beziehung.

  • Klicken Sie im Navigationsbereich auf die Tabelle auf der 1-Seite der 1:n-Beziehung.

  • Klicken Sie auf der Registerkarte Erstellen in der Gruppe Formulare auf Formular.Schaltflächensymbol

Access erstellt ein Formular mit dem Datenblatt im unteren Bereich des Formulars. Wenn von Access kein Datenblatt erstellt wird, bedeutet dies, dass die Tabelle, die Sie für das Formular verwendet haben, kein Bestandteil einer 1:n-Beziehung oder ein Bestandteil einer 1:n-Beziehung ist.

Hinweise   

  • Durch diesen Prozess werden außer dem Hauptformular keine weiteren Formularobjekte erstellt. Das Datenblatt ist eine Direktansicht der Tabelle.

  • So blenden Sie eine Spalte in einem Datenblatt aus    Klicken Sie mit der rechten Maustaste auf die Spalte, und klicken Sie dann auf Spalte ausblenden. Diese Einstellung wird gespeichert. Wenn Sie das Formular speichern, schließen und anschließend erneut öffnen, bleibt die Spalte ausgeblendet.

  • So stellen Sie eine ausgeblendete Spalte in einem Datenblatt wieder her    Klicken Sie im Datenblatt auf eine Spaltenüberschrift, und klicken Sie dann auf Spalten einblenden. Aktivieren Sie das Kontrollkästchen neben jeder Spalte, die Sie wieder herstellen möchten, und klicken Sie dann auf Schließen.

Seitenanfang

Erstellen eines Formulars mit einem Datenblatt unter Verwendung der Layoutansicht

Wenn die Beziehungen zwischen den Tabellen in der Datenbank bereits definiert sind, können Sie mit der Layoutansicht schnell ein Formular mit einem Datenblatt erstellen. Wenn Sie einem Formular, das auf der 1-Seite einer Beziehung basiert, ein Feld von der n-Seite der Beziehung hinzufügen, erstellt Access automatisch ein Datenblatt in der Datenblattansicht, in der die verknüpften Datensätze angezeigt werden.

  1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Formulare auf Leeres Formular.Schaltflächensymbol

    Access öffnet ein leeres Formular in der Layoutansicht und zeigt den Bereich Feldliste an.

    Hinweis   Wenn Sie den Bereich Feldliste versehentlich schließen, können Sie ihn erneut öffnen, indem Sie eine der folgenden Aktionen ausführen:

    • Drücken Sie ALT+F8.

      – Oder –

      Klicken Sie auf der Registerkarte Format in der Gruppe Steuerelemente auf Vorhandene Felder hinzufügen.Schaltflächensymbol

  2. Klicken Sie auf das Pluszeichen neben der Tabelle, die sich auf der 1-Seite der 1:n-Beziehung befindet, und ziehen Sie dann das erste gewünschte Feld in das Formular.

    Der Bereich Feldliste teilt die Tabellen in Bereiche: Für diese Ansicht verfügbare Felder und darunter In verknüpften Tabellen verfügbare Felder. Unten im Bereich Feldliste sind unter In anderen Tabellen verfügbare Felder andere Tabellen aufgeführt, die nicht direkt mit der Haupttabelle verknüpft sind.

  3. Ziehen Sie ggf. weitere Felder aus dem Bereich Für diese Ansicht verfügbare Felder, die im Hauptformular enthalten sein sollen.

  4. Ziehen Sie das erste Feld, das im Datenblatt enthalten sein soll, aus dem Bereich In verknüpften Tabellen verfügbare Felder auf das Formular. Access erstellt ein Datenblatt und fügt diesem das Feld hinzu.

  5. Um dem neuen Datenblatt weitere Felder hinzuzufügen, müssen Sie zuerst auf das Datenblatt klicken, um es zu markieren. Beachten Sie, dass Access den Bereich Feldliste neu anordnet, sodass die für das Datenblatt verfügbaren Felder oben in der Liste angezeigt werden. Ziehen Sie ggf. weitere Felder, die im Datenblatt enthalten sein sollen, aus dem Bereich Für diese Ansicht verfügbare Felder. Wenn Sie die einzelnen Felder in das Datenblatt ziehen, zeichnet Access eine Einfügeleiste, damit Sie sehen können, an welcher Stelle das Feld eingefügt wird, wenn Sie die Maustaste loslassen.

  6. Fügen Sie alle gewünschten Felder in das Hauptformular oder in das Datenblatt ein, indem Sie zunächst auf das Hauptformular oder auf das Datenblatt klicken, um es zu markieren, und ziehen Sie dann das Feld aus dem Bereich Feldliste.

Im Bereich In anderen Tabellen verfügbare Felder des Bereichs Feldliste sind Tabellen enthalten, die nicht direkt mit der Tabelle oder Abfrage verknüpft sind, auf der das ausgewählte Formular oder Datenblatt basiert. Wenn Sie alle gültigen Tabellenbeziehungen im Fenster Beziehungen definiert haben, stellen die Felder im Bereich In anderen Tabellen verfügbare Felder wahrscheinlich keine zulässige Auswahl für das zu erstellende Formular dar. Wenn Sie ein Feld aus diesem Bereich in das Formular ziehen, zeigt Access das Dialogfeld Beziehung angeben an. Bevor Sie den Vorgang fortsetzen, müssen Sie das Feld oder die Felder angeben, mit dem bzw. denen die beiden Tabellen miteinander verknüpft werden. Daraufhin wird der Bereich Feldliste nicht mehr in Bereiche nach den vordefinierten Beziehungen unterteilt sein. Am besten klicken Sie in diesem Dialogfeld auf Abbrechen, und überprüfen Sie stattdessen die Tabellenbeziehungen erneut. Weitere Informationen zu Beziehungen finden Sie im Artikel Erstellen, Bearbeiten oder Löschen einer Beziehung.

Seitenanfang

Einfügen eines Datenblatts in ein vorhandenes Formular unter Verwendung der Layoutansicht

Wenn Sie die Beziehungen zwischen den Tabellen in der Datenbank bereits definiert haben, können Sie mithilfe der Layoutansicht einem vorhandenen Formular rasch ein Datenblatt hinzufügen. Wenn Sie einem Formular, das auf der 1-Seite einer Beziehung basiert, ein Feld aus der n-Seite der Beziehung hinzufügen, erstellt Access automatisch ein Datenblatt, um die verknüpften Datensätze anzuzeigen.

  1. Öffnen Sie das vorhandene Formular in der Layoutansicht, indem Sie im Navigationsbereich mit der rechten Maustaste auf das Formular klicken. Klicken Sie anschließend im Kontextmenü auf Layoutansicht.

    Wenn der Bereich Feldliste nicht angezeigt wird, gehen Sie folgendermaßen vor:

    • Drücken Sie ALT+F8.

      – Oder –

      Klicken Sie auf der Registerkarte Format in der Gruppe Steuerelemente auf Vorhandene Felder hinzufügen.Schaltflächensymbol

      Der Bereich Feldliste teilt die Tabellen in Bereiche: Für diese Ansicht verfügbare Felder und darunter In verknüpften Tabellen verfügbare Felder. Unten im Bereich Feldliste sind unter In anderen Tabellen verfügbare Felder andere Tabellen aufgeführt, die nicht direkt mit der Haupttabelle verknüpft sind.

  2. Erweitern Sie im Bereich In verknüpften Tabellen verfügbare Felder die Tabelle mit dem ersten Feld, das Sie in das Datenblatt einfügen möchten, und ziehen Sie das Feld in das Formular. Access erstellt ein Datenblatt und fügt diesem das Feld hinzu.

  3. Um dem neuen Datenblatt weitere Felder hinzuzufügen, müssen Sie zuerst auf das Datenblatt klicken, um es zu markieren. Beachten Sie, dass Access den Bereich Feldliste neu anordnet, sodass die für das Datenblatt verfügbaren Felder oben in der Liste angezeigt werden. Ziehen Sie ggf. weitere Felder, die im Datenblatt enthalten sein sollen, aus dem Bereich Für diese Ansicht verfügbare Felder. Wenn Sie die einzelnen Felder in das Datenblatt ziehen, zeichnet Access eine Einfügeleiste, damit Sie sehen können, an welcher Stelle das Feld eingefügt wird, wenn Sie die Maustaste loslassen.

  4. Fügen Sie alle gewünschten Felder in das Hauptformular oder in das Datenblatt ein, indem Sie zunächst auf das Hauptformular oder auf das Datenblatt klicken, um es zu markieren, und ziehen Sie dann das Feld aus dem Bereich Feldliste.

Im Bereich In anderen Tabellen verfügbare Felder des Bereichs Feldliste sind Tabellen enthalten, die nicht direkt mit der Tabelle oder Abfrage verknüpft sind, auf der das ausgewählte Formular basiert. Wenn Sie alle gültigen Tabellenbeziehungen im Fenster Beziehungen definiert haben, stellen die Felder im Bereich In anderen Tabellen verfügbare Felder wahrscheinlich keine zulässige Auswahl für das zu erstellende Formular dar. Wenn Sie ein Feld aus diesem Bereich in das Formular ziehen, zeigt Access das Dialogfeld Beziehung angeben an. Bevor Sie den Vorgang fortsetzen, müssen Sie das Feld oder die Felder angeben, mit dem bzw. denen die beiden Tabellen miteinander verknüpft werden. Daraufhin wird der Bereich Feldliste nicht mehr in Bereiche nach den vordefinierten Beziehungen unterteilt sein. Am besten klicken Sie in diesem Dialogfeld auf Abbrechen, und überprüfen Sie stattdessen die Tabellenbeziehungen erneut. Weitere Informationen zu Beziehungen finden Sie im Artikel Erstellen, Bearbeiten oder Löschen einer Beziehung.

Seitenanfang

Einfügen eines Datenblatts in ein vorhandenes Formular mithilfe der Entwurfsansicht

Gehen Sie folgendermaßen vor, um in der Entwurfsansicht einem vorhandenen Formular ein Datenblatt hinzuzufügen, das direkt auf einer Tabelle oder Abfrage basiert.

  1. Öffnen Sie das Formular in der Entwurfsansicht, indem Sie im Navigationsbereich mit der rechten Maustaste auf das Formular und dann auf Entwurfsansicht klicken.

  2. Wenn das Tool Steuerelement-Assistenten verwenden auf der Registerkarte Entwurf in der Gruppe Steuerelemente aktiviert ist, klicken Sie darauf, um es zu deaktivieren.

    Schaltflächensymbol

    Warum?

    Wenn der Steuerelement-Assistent verwendet wird, erstellt er ein eigenes Formularobjekt und erstellt das Unterformularsteuerelement auf der Grundlage dieses Formularobjekts. Im Gegensatz dazu wird bei diesem Vorgang ein Datenblatt erstellt, das nicht auf einem Formular, sondern direkt auf einer Tabelle oder Abfrage basiert.

  3. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Steuerelemente auf die Schaltfläche Unterformular/-bericht Schaltflächensymbol.Schaltflächensymbol

  4. Klicken Sie im Entwurfsbereich des Formulars auf die Stelle, an der das Datenblatt eingefügt werden soll.

  5. Ändern Sie die Position und Größe des Unterformulars, indem Sie die Ziehpunkte an den Kanten und Ecken des Formulars ziehen.

  6. Bearbeiten Sie das angefügte Bezeichnungsfeld für das Unterformular-Steuerelement. Klicken Sie hierzu zunächst auf das Bezeichnungsfeld, doppelklicken Sie darauf, um den zugehörigen Text zu markieren, und geben Sie dann eine neue Bezeichnung ein. Wenn Sie das Bezeichnungsfeld löschen möchten, klicken Sie auf das Bezeichnungsfeld, und drücken Sie dann ENTF.

  7. Wenn das Eigenschaftenblatt nicht bereits angezeigt wird, drücken Sie F4, um es anzuzeigen.

  8. Wenn das Unterformular zurzeit deaktiviert ist, klicken Sie einmal darauf, um es zu aktivieren.

  9. Klicken Sie auf der Registerkarte Daten des Eigenschaftenblatts auf die Dropdownliste Quellobjekt, und klicken Sie dann auf die Tabelle oder Abfrage, die im Datenblatt angezeigt werden soll. Wenn Sie z. B. Daten aus der Tabelle Bestellungen anzeigen möchten, klicken Sie auf Tabelle.Bestellungen.

  10. Wenn Sie die Beziehungen vor Beginn dieses Verfahrens richtig festgelegt haben, legt Access für die Eigenschaften Verknüpfen von und Verknüpfen nach automatisch die richtigen Werte fest, mit denen das Hauptformular mit dem Datenblatt verknüpft wird.

    Die Eigenschaften Verknüpfen von und Verknüpfen nach sind leer

    Wenn Access nicht bestimmen kann, wie das Unterformular-Steuerelement mit dem Hauptformular verknüpft werden soll, bleiben die Eigenschaften Verknüpfen von und Verknüpfen nach des Unterformular-Steuerelements leer. Sie müssen diese Eigenschaften folgendermaßen manuell einstellen:

    1. Öffnen Sie das Hauptformular in der Entwurfsansicht.

    2. Klicken Sie einmal auf das Unterformular, um es auszuwählen.

    3. Wenn das Eigenschaftenblatt zurzeit nicht angezeigt wird, drücken Sie F4.

    4. Klicken Sie auf der Registerkarte Daten des Eigenschaftenblatts neben dem Eigenschaftenfeld Verknüpfen von auf (...).

      Das Dialogfeld Feldverknüpfungs-Assistent für Unterformulare wird angezeigt.

    5. Wählen Sie in den Dropdownlisten Felder in übergeordneter Tabelle und Felder in untergeordneter Tabelle die Felder aus, mit denen die Formulare verknüpft werden sollen. Wenn Sie nicht sicher sind, welche Felder verwendet werden sollen, klicken Sie auf Vorschlagen, damit Access die Verknüpfungsfelder bestimmt. Wenn Sie den Vorgang abgeschlossen haben, klicken Sie auf OK.

      Wenn das Feld, das Sie zum Verknüpfen der Formulare verwenden möchten, nicht angezeigt wird, müssen Sie möglicherweise die Datensatzquelle des über- oder untergeordneten Formulars bearbeiten, um sicherzustellen, dass das Feld darin enthalten ist. Wenn das Formular z. B. auf einer Abfrage basiert, stellen Sie sicher, dass das Verknüpfungsfeld in den Abfrageergebnissen enthalten ist.

    6. Speichern Sie das Hauptformular, und wechseln Sie zur Formularansicht, um sicherzustellen, dass das Formular erwartungsgemäß funktioniert.

  11. Speichern Sie das Formular, indem Sie auf der Symbolleiste für den Schnellzugriff auf Speichern Schaltflächensymbol klicken oder indem Sie STRG+S drücken.

  12. Wechseln Sie zur Formularansicht, und prüfen Sie, ob das Datenblatt wie erwartet funktioniert.

Seitenanfang

Grundlegende Unterschiede zwischen einem geteilten Formular und einem Formular mit einem Datenblatt

In einem Formular mit einem Datenblatt werden Daten aus unterschiedlichen (aber in der Regel miteinander verknüpften) Datenquellen angezeigt. So werden in einem Formular z. B. Mitarbeiter angezeigt, und im Datenblatt werden alle Aufgaben angezeigt, die den einzelnen Mitarbeitern zugewiesen sind. Das Datenblatt hat eine andere Datenquelle als das Formular, in dem es enthalten ist. Ein geteiltes Formular hingegen besteht aus zwei Bereichen (einem Formular und einem Datenblatt), aber in beiden Bereichen werden dieselben Daten angezeigt. Beide Bereiche werden miteinander verfolgt und zeigen gleichzeitig verschiedene Ansichten der Daten an.

Weitere Informationen zum Erstellen von und Arbeiten mit einem geteilten Formular finden Sie im Artikel Erstellen eines geteilten Formulars.

Seitenanfang

Gilt für: Access 2007



War diese Information hilfreich?

Ja Nein

Wie können wir es verbessern?

255 Zeichen verfügbar

Um Ihre Privatsphäre zu schützen, geben Sie bitte keine Kontaktinformationen in Ihrem Feedback an. Lesen Sie unsere Datenschutzbestimmung.

Vielen Dank für Ihr Feedback!

Supportressourcen

Sprache ändern