Einführung in Berichte in Access

Einführung in Berichte in Access

Berichte bieten die Möglichkeit, die Informationen in Ihrer Microsoft Access-Datenbank anzuzeigen, zu formatieren und zusammenzufassen. Sie können beispielsweise einen einfachen Bericht mit den Telefonnummern aller Kontakte oder einen zusammenfassenden Bericht mit dem Gesamtumsatz in verschiedenen Regionen und Zeiträumen erstellen.

Dieser Bericht bietet eine Übersicht über Berichte in Access. Darüber hinaus werden die Grundlagen der Berichterstellung und die Verwendung von Optionen, wie z. B. Sortieren, Gruppieren und Zusammenfassen der Daten, sowie Voranzeigen und Drucken des Berichts behandelt.

Hinweis : Die Informationen in diesem Artikel wird nur in Verbindung mit Access-Desktopdatenbanken gelten. Access Web apps unterstützt nicht Berichte.

Inhalt dieses Artikels

Übersicht über Berichte in Access

Erstellen eines Berichts in Access

Hinzufügen von Gruppierung, Sortierung oder Gesamtergebnissen

Hervorheben von Daten mit bedingter Formatierung

Anpassen von Farben und Schriftarten

Hinzufügen eines Logos oder Hintergrundbilds

Anzeigen einer Vorschau und Drucken von Berichten

Übersicht über Berichte in Access

Was kann man mit einem Bericht anfangen?

Ein Bericht ist ein praktisches Datenbankobjekt, wenn Sie die Informationen in Ihrer Datenbank für folgende Zwecke verwenden möchten:

  • Anzeigen oder Verteilen einer Zusammenfassung der Daten

  • Archivieren von Momentaufnahmen der Daten

  • Bereitstellen von Details zu einzelnen Datensätzen

  • Erstellen von Etiketten

Bestandteile eines Berichts

Obwohl die Möglichkeit besteht, “ungebundene” Berichte zu erstellen, die keine Daten anzeigen, wird im Rahmen dieses Artikels jedoch davon ausgegangen, dass ein Bericht an eine Datenquelle, z. B. eine Tabelle oder Abfrage, gebunden ist. Der Entwurf eines Berichts ist in Bereiche unterteilt, die Sie in der Entwurfsansicht anzeigen können. Die Kenntnis der Funktionsweise der einzelnen Bereiche erleichtert das Erstellen optimaler Berichte. Beispielsweise bestimmt der Bereich, in dem Sie ein berechnetes Steuerelement platzieren, wie die Ergebnisse in Access berechnet werden. Im Folgenden finden Sie eine Zusammenfassung der Bereichstypen und ihrer Verwendung:

Abschnitt

Anzeige des Bereichs beim Drucken

Verwendungsmöglichkeiten des Bereichs

Berichtskopf

Am Anfang des Berichts

Verwenden Sie den Berichtskopf für Informationen, die normalerweise auf einem Deckblatt stehen, z. B. ein Logo, Titel oder Datum. Wenn Sie ein Steuerelement, das die Aggregatfunktion "Summe" verwendet, in den Gruppenkopf aufnehmen, wird die Summe für den gesamten Bericht berechnet. Der Berichtskopf wird vor dem Seitenkopf gedruckt.

Seitenkopf

Dieser Abschnitt wird am Anfang jeder Seite gedruckt.

Verwenden Sie einen Seitenkopf, um den Berichtstitel auf jeder Seite zu wiederholen.

Gruppenkopf

Am Anfang jeder neuen Datensatzgruppe

Verwenden Sie den Gruppenkopf zum Drucken des Gruppennamens. Verwenden Sie den Gruppenkopf z. B. in einem Bericht, der nach Artikel gruppiert ist, um den Artikelnamen zu drucken. Wenn Sie ein Steuerelement, das die Aggregatfunktion "Summe" verwendet, in den Gruppenkopf aufnehmen, wird die Summe für die aktuelle Gruppe berechnet. Es können mehrere Gruppenkopfbereiche in einem Bericht verwendet werden, abhängig von der Anzahl der hinzugefügten Gruppierungsebenen. Weitere Informationen zum Erstellen von Gruppenköpfen und Gruppenfüßen finden Sie im Abschnitt "Hinzufügen von Gruppierung, Sortierung oder Gesamtergebnissen".

Detailbereich

Dieser Abschnitt wird einmal für jede Zeile in der Datensatzquelle gedruckt.

Hier fügen Sie die Steuerelemente ein, die den Hauptteil des Berichts bilden.

Gruppenfuß

Am Ende jeder Datensatzgruppe

Verwenden Sie den Gruppenfuß, um zusammenfassende Informationen für eine Gruppe zu drucken. Es können mehrere Gruppenfußbereiche in einem Bericht verwendet werden, abhängig von der Anzahl der hinzugefügten Gruppierungsebenen.

Seitenfuß

Dieser Abschnitt wird am Ende jeder Seite gedruckt.

Verwenden Sie den Seitenfuß, um Seitenzahlen oder Informationen auf Seitenbasis zu drucken.

Berichtsfuß

Am Ende des Berichts

Hinweis : In der Entwurfsansicht wird der Berichtsfuß unter dem Seitenfuß angezeigt. In allen anderen Ansichten (z. B der Layoutansicht oder beim Drucken oder bei der Vorschau des Berichts) wird der Berichtsfuß jedoch über dem Seitenfuß angezeigt, direkt nach dem letzten Gruppenfuß oder der Detailzeile auf der letzten Seite.

Verwenden Sie den Berichtsfuß, um Berichtssummen oder andere zusammenfassende Informationen für den gesamten Bericht zu drucken.

Elementname, es viel einfacher ist, aussagekräftige Berichte erstellen, wenn die Datenbank eine durchdachter Tabellenstruktur und Beziehungen enthält. Eine Einführung in das Planen und Entwerfen einer Datenbank finden Sie im Artikel Grundlagen des Datenbankentwurfs.

Seitenanfang

Erstellen eines Berichts in Access

Führen Sie die folgenden Schritte aus, um Berichte für eine Access-Desktopdatenbank zu erstellen:

Schritt 1: Auswählen einer Datensatzquelle

Die Datensatzquelle eines Berichts kann eine Tabelle, eine benannte Abfrage oder eine eingebettete Abfrage sein. Die Datensatzquelle muss alle Zeilen und Spalten der Daten enthalten, die im Bericht angezeigt werden sollen.

  • Wenn die Daten aus einer vorhandenen Tabelle oder Abfrage stammen, wählen Sie im Navigationsbereich die Tabelle oder Abfrage aus, und fahren Sie mit Schritt2 fort.

  • Wenn die Datensatzquelle noch nicht vorhanden ist, führen Sie eine der folgenden Aktionen aus:

    • Fahren Sie mit Schritt2 fort, und verwenden Sie das Berichtstool Leerer Bericht,

      Oder

    • Erstellen Sie die Tabellen oder eine Abfrage, die die benötigten Daten enthält. Wählen Sie die Abfrage oder die Tabelle im Navigationsbereich, und fahren Sie mit Schritt2.

Schritt 2: Auswählen eines Berichtstools

Die Berichtstools befinden sich auf der Registerkarte Erstellen des Menübands in der Gruppe Berichte. In der folgenden Tabelle sind die Optionen beschrieben:

Tool

Beschreibung

Bericht

Erstellt einen einfachen Bericht in Tabellenform, der alle Felder in der Datensatzquelle enthält, die Sie im Navigationsbereich ausgewählt haben.

Berichtsentwurf

Öffnet einen leeren Bericht in der Entwurfsansicht, dem die erforderlichen Felder und Steuerelemente hinzugefügt werden können.

Leerer Bericht

Öffnet einen leeren Bericht in der Layoutansicht und zeigt die Feldliste an, aus der Sie Felder zum Bericht hinzufügen können.

Berichts-Assistent

Zeigt einen Assistenten mit mehreren Schritten an, in dem Sie Felder, Gruppierungs-/Sortierungsebenen und Layoutoptionen angeben können.

Etiketten

Zeigt einen Assistenten an, in dem standardmäßige oder benutzerdefinierte Etikettengrößen sowie die anzuzeigenden Felder und die Art ihrer Sortierung ausgewählt werden können.

Schritt 3: Erstellen des Berichts

  1. Klicken Sie auf die Schaltfläche für das gewünschte Tool. Wenn ein Assistent angezeigt wird, folgen Sie den Schritten des Assistenten, und klicken Sie dann auf der letzten Seite auf Fertig stellen.
    Access zeigt den Bericht in der Entwurfsansicht an.

  2. Formatieren Sie den Bericht, bis sein Aussehen Ihren Vorstellungen entspricht:

    • Ändern Sie die Größe von Feldern und Beschriftungen, indem Sie sie auswählen und dann die Kanten bis zur gewünschten Größe ziehen.

    • Verschieben Sie ein Feld, indem Sie es auswählen (und dessen Beschriftung, sofern vorhanden) und es dann an die neue Position ziehen.

    • Klicken Sie mit der rechten Maustaste auf ein Feld, und verwenden Sie die Befehle im Kontextmenü zum Zusammenführen oder Teilen von Zellen, zum Löschen oder Auswählen von Feldern und zum Ausführen weiterer Formatierungsaufgaben.

      Darüber hinaus können Sie die in den folgenden Abschnitten beschriebenen Features verwenden, um den Bericht attraktiver und besser lesbar zu gestalten.

Seitenanfang

Hinzufügen von Gruppierung, Sortierung oder Gesamtergebnissen

Das schnellste Verfahren zum Hinzufügen von Gruppierung, Sortierung oder Gesamtergebnissen zu einem Desktopdatenbankbericht besteht darin, mit der rechten Maustaste auf das Feld zu klicken, auf das die Gruppierung, Sortierung oder das Gesamtergebnis angewendet werden soll, und klicken Sie dann im Kontextmenü auf den gewünschten Befehl.

Sie können Gruppierung, Sortierung oder Summen auch hinzufügen, mithilfe den Bereich Gruppieren, Sortieren und Summe, während der Bericht in der Layoutansicht oder Entwurfsansicht geöffnet ist:

  1. Wenn der Bereich Gruppieren, Sortieren und Summe noch nicht geöffnet ist, klicken Sie auf der Registerkarte Entwerfen in der Gruppe Gruppierung und Summen auf Gruppieren und Sortieren.

  2. Klicken Sie auf Gruppe hinzufügen oder auf Sortierung hinzufügen, und wählen Sie dann das Feld aus, nach dem Sie gruppieren oder sortieren möchten.

  3. Klicken Sie in einer zu gruppierenden oder sortierenden Zeile auf Mehr, um weitere Optionen festzulegen und Gesamtergebnisse hinzuzufügen.

Ausführlichere Informationen zu Gruppierung, Sortierung und Gesamtergebnissen finden Sie im Artikel Erstellen eines gruppierten oder zusammenfassenden Berichts.

Seitenanfang

Hervorheben von Daten mit bedingter Formatierung

Access stellt Tools zum Hervorheben von Daten in einem Bericht. Sie können die Regeln zur bedingte Formatierung für jedes Steuerelement oder eine Steuerelementgruppe hinzufügen und im Clientberichte können Sie auch Hinzufügen von Datenbalken, um die Daten zu vergleichen.

Bedingte Formatierung hinzufügen für Steuerelemente:

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht und dann auf Layoutansicht.

  2. Wählen Sie die erforderlichen Steuerelemente aus und klicken Sie auf der Format tab, in der Gruppe Steuerelementformatierung, klicken Sie auf Bedingte Formatierung.

    Tipp : Wenn Sie mehrere Steuerelemente markieren möchten, klicken Sie bei gedrückter STRG-Taste auf die Steuerelemente.

  3. Klicken Sie im Dialogfeld Manager für Regeln zur bedingten Formatierung auf Neue Regel.

  4. Wählen Sie im Dialogfeld Neue Formatierungsregel unter Regeltyp auswählen einen Wert aus:

    • Aktivieren Sie zum Erstellen einer Regel, die für jeden Datensatz einzeln ausgewertet wird, die Option Werte im aktuellen Datensatz prüfen oder einen Ausdruck verwenden.

    • Klicken Sie zum Erstellen einer Regel, die Datensätze mithilfe von Datenbalken miteinander vergleicht, auf Mit anderen Datensätzen vergleichen.

  1. Geben Sie unter Regelbeschreibung bearbeiten die Regel, die festlegt, wann die Formatierung angewendet werden soll, sowie die Formatierung an, die angewendet werden soll, wenn Sie auf OK klicken. .

  2. Wiederholen Sie diese Schritte ausgehend von Schritt 4, um eine weitere Regel für dieses Steuerelement oder diese Sammlung von Steuerelementen zu erstellen.

Seitenanfang

Anpassen von Farben und Schriftarten

Mithilfe der Optionen für App-Designs können Sie Farben und Schriftarten anpassen.

  1. Öffnen Sie einen Bericht in der Layoutansicht, indem Sie mit der rechten Maustaste im Navigationsbereich und dann auf Layout VAnzeigen.

  2. Klicken Sie auf der Registerkarte Entwurf in den Optionen unter Berichtslayouttools auf Designs. Wenn Sie den Cursor über die verschiedenen Designs im Katalog bewegen, wird eine Vorschau der jeweiligen Auswirkungen angezeigt. Klicken Sie auf ein Design, um es auszuwählen, und speichern Sie anschließend den Bericht.

  3. Verwenden Sie die Kataloge Farben oder Schriftarten, um Farben oder Schriftarten unabhängig festzulegen.


Seitenanfang

Hinzufügen eines Logos oder Hintergrundbilds

Sie können ein Logo oder ein Hintergrundbild zu einem Bericht hinzufügen. Wenn Sie das Bild aktualisieren, erfolgt die Aktualisierung automatisch überall dort, wo das Bild in der Datenbank verwendet wird.

So fügen Sie ein Bild hinzu, oder entfernen Sie ein Bild:

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht, und klicken Sie auf Layoutansicht.

  2. Klicken Sie im Bericht auf die Stelle, in der Sie das Bild hinzufügen möchten, und klicken Sie auf der Registerkarte Entwurf in der Gruppe Kopfzeile/Fußzeile auf Logo.

  3. Navigieren Sie zum Bild, und klicken Sie auf Öffnen. Access fügt dem Bericht das Bild hinzu.

  4. Um das Bild zu entfernen, mit der rechten Maustaste in des Bilds, und klicken Sie im Kontextmenü auf Löschen.

So fügen Sie in Hintergrundbild hinzu:

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht, und klicken Sie auf Layoutansicht.

  2. Klicken Sie auf der Registerkarte Format in der Gruppe Hintergrund auf Hintergrundbild.

  3. Wählen Sie in der Liste Bildergalerie ein Bild aus, oder klicken Sie auf Durchsuchen, wählen Sie ein Bild aus, und klicken Sie anschließend auf OK.

Seitenanfang

Anzeigen von Berichten in der Vorschau und Drucken

Berichte in der Vorschau anzeigen und drucken

  1. Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht und dann auf Seitenansicht. Sie können die Befehle auf der Registerkarte Seitenansicht verwenden, um beliebige der folgenden Vorgänge auszuführen:

    • Drucken des Berichts

    • Anpassen von Seitengröße oder Layout

    • Hinein- und Herauszoomen oder Anzeigen mehrerer Seiten zugleich

    • Aktualisieren der Daten im Bericht

    • Exportieren des Berichts in ein anderes Dateiformat

  2. Klicken Sie auf Seitenansicht schließen.

Drucken eines Berichts

So drucken Sie einen Bericht ohne Vorschau:

  • Klicken Sie im Navigationsbereich mit der rechten Maustaste auf den Bericht und dann auf Drucken. Der Bericht wird an den Standarddrucker gesendet.

    Hinweis :  Wenn Sie den Bericht im Navigationsbereich und dann auf der Registerkarte Datei die Option Drucken auswählen, können Sie weitere Druckoptionen auswählen, z. B. Seitenzahlen und Anzahl der Exemplare, und einen Drucker angeben.

    • Zum Öffnen eines Dialogfelds, in dem ein Drucker ausgewählt, die Anzahl der Exemplare festgelegt werden kann usw. klicken Sie auf Drucken.

Seitenanfang

Hinweise : 

  • Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

  • Die englische Version des Artikels ist als Referenz hier verfügbar: hier. Sie und andere Mitglieder der Microsoft-Community können diesen Artikel über das Collaborative Translation Framework (CTF) verbessern. Zeigen Sie einfach mit der Maus auf einen Satz in diesem Artikel, und klicken Sie dann im CTF-Widget auf "ÜBERSETZUNG VERBESSERN". Klicken Sie hier, um weitere Informationen zum CTF zu erhalten. Durch die Verwendung von CTF stimmen Sie unseren Nutzungsbedingungen zu.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×