Einfügen eines Objekts in einer Excel-Kalkulationstabelle

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Object Linking and Embedding (OLE) können Sie die Inhalte von anderen Programmen wie Word oder Excel enthalten.

OLE wird von vielen verschiedenen Programmen unterstützt und verwendet, um Inhalte, die in einem Programm erstellt wurden, in einem anderen Programm verfügbar zu machen. So können Sie beispielsweise ein Office Word-Dokument in eine Excel-Arbeitsmappe einfügen. Zur Anzeige, welche Arten von Inhalten Sie einfügen können, klicken Sie in der Gruppe Text auf der Registerkarte Einfügen auf Objekt. Nur Programme, die auf Ihrem Computer installiert sind und OLE-Objekte unterstützen, werden im Feld Objekttyp angezeigt.

Wenn Sie Informationen zwischen Excel oder einem beliebigen anderen Programm, das OLE unterstützt, wie z. B. Word, kopieren, können Sie die Informationen entweder als Verknüpftes Objekt oder als Eingebettetes Objekt kopieren. Die Hauptunterschiede zwischen verknüpften und eingebetteten Objekten bestehen darin, wo die Daten gespeichert sind und wie das Objekt aktualisiert wird, nachdem Sie es in der Zieldatei platziert haben. Eingebettete Objekte werden in die Arbeitsmappe gespeichert, die in sie eingefügt wurden, und werden nicht aktualisiert. Verknüpfte Objekte sind weiterhin als separate Dateien vorhanden und können aktualisiert werden.

Verknüpfte und eingebettete Objekte in einem Dokument

Verknüpfte und eingebettete Objekte in einem Office für Windows-Dokument

1. Ein eingebettetes Objekt verfügt über keine Verbindung zur Quelldatei.

2. Ein verknüpftes Objekt ist mit der Quelldatei verknüpft.

3. Die Quelldatei aktualisiert das verknüpfte Objekt.

Verwendungsmöglichkeiten für verknüpfte Objekte

Wenn die Informationen in einer Zieldatei nach einer Änderung der Daten in der Quelldatei aktualisiert werden sollen, verwenden Sie verknüpfte Objekte.

Bei einem verknüpften Objekt bleiben die ursprüngliche Informationen in der Quelldatei gespeichert. In der Zieldatei wird zwar eine Darstellung der verknüpften Informationen angezeigt, jedoch erfolgt die Speicherung nur am Speicherort der ursprünglichen Daten (und in der ursprünglichen Größe, wenn das Objekt ein Excel-Diagrammobjekt ist). Die Quelldatei muss auf Ihrem Computer oder in Ihrem Netzwerk verfügbar sein, damit die Verknüpfung zu den ursprünglichen Daten beibehalten wird.

Die verknüpften Informationen werden automatisch aktualisiert, wenn Sie die ursprünglichen Daten in der Quelldatei ändern. Wenn Sie beispielsweise einen Absatz in einem Word-Dokument auswählen und diesen Absatz dann als verknüpftes Objekt in eine Excel-Arbeitsmappe einfügen, können die Informationen in Excel aktualisiert werden, wenn Sie sie in Ihrem Word-Dokument ändern.

Verwendungsmöglichkeiten für eingebettete Objekte

Wenn Sie nicht möchten, dass die kopierten Daten bei einer Änderung in der Quelldatei aktualisiert werden, verwenden Sie ein eingebettetes Objekt. Die Version der Quelle wird vollständig in die Arbeitsmappe eingebettet. Wenn Sie Daten als eingebettetes Objekt kopieren, wird für die Zieldatei mehr Speicherplatz benötigt als beim Verknüpfen von Informationen.

Wenn ein Benutzer die Datei auf einem anderen Computer öffnet, kann er das eingebettete Objekt ohne Zugriff auf die ursprünglichen Daten anzeigen. Da ein eingebettetes Objekt keine Verknüpfung zur Quelldatei aufweist, wird das Objekt nicht aktualisiert, wenn Sie die ursprünglichen Daten ändern. Zum Ändern eines eingebetteten Objekts doppelklicken Sie auf das Objekt, um es zu öffnen, und bearbeiten es dann im Quellprogramm. Das Quellprogramm (oder ein anderes Programm, mit dem das Objekt bearbeitet werden kann) muss auf Ihrem Computer installiert sein.

Ändern die Möglichkeit, dass ein OLE-Objekt angezeigt wird

Sie können ein Verknüpftes Objekt oder ein Eingebettetes Objekt in einer Arbeitsmappe genau so anzeigen, wie es im Quellprogrammangezeigt wird, oder Sie können es als Symbol anzeigen. Wenn die Arbeitsmappe online angezeigt wird und Sie die Arbeitsmappe nicht drucken möchten, können Sie das Objekt als Symbol anzeigen. Auf diese Weise verringern Sie den Speicherplatz, der zum Anzeigen des Objekts benötigt wird. Betrachter, die die Daten anzeigen möchten, können auf das Symbol doppelklicken.

Einbetten eines Objekts in ein Arbeitsblatt

  1. Klicken Sie innerhalb der Zelle des Arbeitsblatts, in der Sie das Objekt einfügen möchten.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Text auf Objekt Objektsymbol auf der Multifunktionsleiste .
    Objekt einfügen

  3. Klicken Sie auf die Registerkarte aus Datei erstellen, klicken Sie im Dialogfeld Objekt .

  4. Klicken Sie auf Durchsuchen, und wählen Sie die Datei aus, die Sie einfügen möchten.

  5. Wenn Sie ein Symbol in der Kalkulationstabelle einfügen möchten anstelle von zeigen Sie des Inhalts der Datei an, aktivieren Sie das Kontrollkästchen als Symbol anzeigen . Wenn Sie keine Kontrollkästchen aktivieren, zeigt Excel die erste Seite der Datei an. In beiden Fällen die vollständige Datei, die mit einem Doppelklick wird geöffnet. Klicken Sie auf OK.

    Hinweis : Nachdem Sie das Symbol oder die Datei hinzufügen möchten, können Sie ziehen und legen Sie sie an einer beliebigen Stelle auf dem Arbeitsblatt. Sie können auch das Symbol oder den Dateinamen der Größe mit den Ziehpunkten. Informationen zum Aufrufen um der Ziehpunkte zu finden, die Datei oder das Symbol klicken Sie einmal auf.

Einfügen eines Links in eine Datei

Möglicherweise möchten das Objekt anstatt Sie vollständig einzubetten nur einen Link hinzufügen. Sie können dies tun, wenn die Arbeitsmappe und das Objekt, die Sie beide auf einer SharePoint-Website, einem freigegebenen Netzlaufwerk oder einem ähnlichen Speicherort gespeichert sind hinzufügen möchten, und der Speicherort der Dateien bleibt unverändert. Dies ist hilfreich, wenn das verknüpfte Objekt Änderungen durchläuft, da der Link immer das aktuellste Dokument wird geöffnet.

Hinweis : Wenn Sie die verknüpfte Datei an eine andere Position verschieben, funktioniert der Link nicht mehr.

  1. Klicken Sie innerhalb der Zelle des Arbeitsblatts, in der Sie das Objekt einfügen möchten.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Text auf Objekt Objektsymbol auf der Multifunktionsleiste .
    Objekt einfügen

  3. Klicken Sie auf die Registerkarte aus Datei erstellen .

  4. Klicken Sie auf Durchsuchen, und wählen Sie dann auf die Datei, die Sie verknüpfen möchten.

  5. Aktivieren Sie das Kontrollkästchen Mit Datei verknüpfen, und klicken Sie auf OK.

Erstellen eines neuen Objekts in Excel

Sie können ein vollständig neues Objekt ausgehend von einem anderen Programm ohne Verlassen der Arbeitsmappe zu erstellen. Wenn Sie weitere Einzelheiten zu Ihrem Diagramm oder einer Tabelle hinzufügen möchten, können Sie beispielsweise ein eingebettetes Dokument, beispielsweise eine Datei Word oder PowerPoint in Excel erstellen. Sie können entweder festlegen Ihrer Objekttyp für die Anzeige in einem Arbeitsblatt nach rechts, oder fügen Sie ein Symbol, das die Datei wird geöffnet.

Dieses eingebettete Objekt ist ein Word-Dokument.
  1. Klicken Sie innerhalb der Zelle des Arbeitsblatts, in der Sie das Objekt einfügen möchten.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Text auf Objekt Objektsymbol auf der Multifunktionsleiste .
    Objekt einfügen

  3. Wählen Sie auf der Registerkarte Neu erstellen den Typ des einzufügenden Objekts aus der angezeigten Liste aus. Wenn Sie anstelle des Objekts ein Symbol in die Tabelle einfügen möchten, aktivieren Sie das Kontrollkästchen Als Symbol anzeigen.

  4. Klicken Sie auf OK. Je nach Typ der Datei, die Sie einfügen möchten, wird ein neues Programmfenster geöffnet oder ein Bearbeitungsfenster in Excel angezeigt.

  5. Erstellen Sie das neue Objekt, das Sie einfügen möchten.

    Wenn Sie fertig sind und Excel in einem neuem Programmfenster geöffnet haben, können Sie direkt darin arbeiten.

    Sie können das eingebettete Word-Dokument direkt in Excel bearbeiten.

    Wenn Sie mit der Arbeit im Fenster fertig sind, können Sie weitere Aufgaben ausführen, ohne das eingebettete Objekt speichern. Wenn Sie die Arbeitsmappe geschlossen werden der neue Objekte automatisch gespeichert.

    Hinweis : Nachdem Sie das Objekt hinzugefügt haben, können Sie es an eine beliebige Stelle auf dem Excel-Arbeitsblatt ziehen und ablegen. Sie können auch die Größe des Objekts mithilfe der Ziehpunkte ändern. Klicken Sie einmal auf das Objekt, um die Ziehpunkte anzuzeigen.

Einbetten eines Objekts in ein Arbeitsblatt

  1. Klicken Sie innerhalb der Zelle des Arbeitsblatts, in der Sie das Objekt einfügen möchten.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Text auf Objekt.

    Die Option "Objekt" befindet sich auf der Registerkarte "Einfügen".
  3. Klicken Sie auf die Registerkarte Aus Datei erstellen.

    Registerkarte "Aus Datei erstellen" im Dialogfeld "Objekt"
  4. Klicken Sie auf Durchsuchen, und wählen Sie die Datei aus, die Sie einfügen möchten.

  5. Wenn Sie ein Symbol in der Kalkulationstabelle einfügen möchten anstelle von zeigen Sie des Inhalts der Datei an, aktivieren Sie das Kontrollkästchen als Symbol anzeigen . Wenn Sie keine Kontrollkästchen aktivieren, zeigt Excel die erste Seite der Datei an. In beiden Fällen die vollständige Datei, die mit einem Doppelklick wird geöffnet. Klicken Sie auf OK.

    Hinweis : Nachdem Sie das Symbol oder die Datei hinzufügen möchten, können Sie ziehen und legen Sie sie an einer beliebigen Stelle auf dem Arbeitsblatt. Sie können auch das Symbol oder den Dateinamen der Größe mit den Ziehpunkten. Informationen zum Aufrufen um der Ziehpunkte zu finden, die Datei oder das Symbol klicken Sie einmal auf.

Einfügen eines Links in eine Datei

Möglicherweise möchten das Objekt anstatt Sie vollständig einzubetten nur einen Link hinzufügen. Sie können dies tun, wenn die Arbeitsmappe und das Objekt, die Sie beide auf einer SharePoint-Website, einem freigegebenen Netzlaufwerk oder einem ähnlichen Speicherort gespeichert sind hinzufügen möchten, und der Speicherort der Dateien bleibt unverändert. Dies ist hilfreich, wenn das verknüpfte Objekt Änderungen durchläuft, da der Link immer das aktuellste Dokument wird geöffnet.

Hinweis : Wenn Sie die verknüpfte Datei an eine andere Position verschieben, funktioniert der Link nicht mehr.

  1. Klicken Sie innerhalb der Zelle des Arbeitsblatts, in der Sie das Objekt einfügen möchten.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Text auf Objekt.

    Die Option "Objekt" befindet sich auf der Registerkarte "Einfügen".
  3. Klicken Sie auf die Registerkarte aus Datei erstellen .

  4. Klicken Sie auf Durchsuchen, und wählen Sie dann auf die Datei, die Sie verknüpfen möchten.

  5. Aktivieren Sie das Kontrollkästchen Mit Datei verknüpfen, und klicken Sie auf OK.

    Aktivieren Sie auf der Registerkarte "Aus Datei erstellen" das Kontrollkästchen "Mit Datei verknüpfen".

Erstellen eines neuen Objekts in Excel

Sie können ein vollständig neues Objekt ausgehend von einem anderen Programm ohne Verlassen der Arbeitsmappe zu erstellen. Wenn Sie weitere Einzelheiten zu Ihrem Diagramm oder einer Tabelle hinzufügen möchten, können Sie beispielsweise ein eingebettetes Dokument, beispielsweise eine Datei Word oder PowerPoint in Excel erstellen. Sie können entweder festlegen Ihrer Objekttyp für die Anzeige in einem Arbeitsblatt nach rechts, oder fügen Sie ein Symbol, das die Datei wird geöffnet.

Dieses eingebettete Objekt ist ein Word-Dokument.
  1. Klicken Sie innerhalb der Zelle des Arbeitsblatts, in der Sie das Objekt einfügen möchten.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Text auf Objekt.

    Die Option "Objekt" befindet sich auf der Registerkarte "Einfügen".
  3. Wählen Sie auf der Registerkarte Neu erstellen den Typ des einzufügenden Objekts aus der angezeigten Liste aus. Wenn Sie anstelle des Objekts ein Symbol in die Tabelle einfügen möchten, aktivieren Sie das Kontrollkästchen Als Symbol anzeigen.

    Die Registerkarte "Neu erstellen" im Dialogfeld "Objekt"
  4. Klicken Sie auf OK. Je nach Typ der Datei, die Sie einfügen möchten, wird ein neues Programmfenster geöffnet oder ein Bearbeitungsfenster in Excel angezeigt.

  5. Erstellen Sie das neue Objekt, das Sie einfügen möchten.

    Wenn Sie fertig sind und Excel in einem neuem Programmfenster geöffnet haben, können Sie direkt darin arbeiten.

    Sie können das eingebettete Word-Dokument direkt in Excel bearbeiten.

    Wenn Sie mit der Arbeit im Fenster fertig sind, können Sie weitere Aufgaben ausführen, ohne das eingebettete Objekt speichern. Wenn Sie die Arbeitsmappe geschlossen werden der neue Objekte automatisch gespeichert.

    Hinweis : Nachdem Sie das Objekt hinzugefügt haben, können Sie es an eine beliebige Stelle auf dem Excel-Arbeitsblatt ziehen und ablegen. Sie können auch die Größe des Objekts mithilfe der Ziehpunkte ändern. Klicken Sie einmal auf das Objekt, um die Ziehpunkte anzuzeigen.

Verknüpfen oder Einbetten von Inhalt aus einem anderen Programm mithilfe von OLE

Sie können den Inhalt aus einem anderen Programm ganz oder teilweise verknüpfen oder einbetten.

Erstellen eines Links auf den Inhalt aus einem anderen Programm

  1. Klicken Sie im Arbeitsblatt an die Stelle, an der das Verknüpftes Objekt platziert werden soll.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Text auf Objekt.

    Abbildung der Excel-Multifunktionsleiste

  3. Klicken Sie auf die Registerkarte Aus Datei erstellen.

  4. Geben Sie im Feld Dateiname den Namen der Datei ein, oder klicken Sie auf Durchsuchen, um die Datei aus einer Liste auszuwählen.

  5. Aktivieren Sie das Kontrollkästchen Verknüpfen.

  6. Führen Sie eine der folgenden Aktionen aus:

    • Wenn der Inhalt angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Als Symbol anzeigen.

    • Um ein Symbol anzuzeigen, wählen Sie das Kontrollkästchen als Symbol anzeigen. Optional zum Ändern der standardmäßigen Symbolbild oder Bezeichnung klicken Sie auf Symbol ändern, und klicken Sie dann klicken Sie auf das Symbol, das in der Liste Symbol aus, oder geben Sie eine Beschriftung in das Feld Beschriftung ein.

    Hinweis : Sie können den Befehl Objekt nicht zum Einfügen von Grafiken und bestimmte Dateitypen verwenden. Zum Einfügen einer Grafik oder einer Datei klicken Sie auf der Registerkarte Einfügen in der Gruppe Illustrationen auf Bild.

Einbetten von Inhalten aus einem anderen Programm

  1. Klicken Sie im Arbeitsblatt an die Stelle, an der das Eingebettetes Objekt platziert werden soll.

  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Text auf Objekt.

    Abbildung der Excel-Multifunktionsleiste

  3. Wenn das Dokument noch nicht vorhanden ist, klicken Sie auf die Registerkarte Neu erstellen. Klicken Sie im Feld Objekttyp auf den zu erstellenden Objekttyp.

    Ist das Dokument bereits vorhanden, klicken Sie auf die Registerkarte Aus Datei erstellen. Geben Sie im Feld Dateiname den Namen der Datei ein, oder klicken Sie auf Durchsuchen, um die Datei in einer Liste auszuwählen.

  4. Deaktivieren Sie das Kontrollkästchen Mit Datei verknüpfen.

  5. Führen Sie eine der folgenden Aktionen aus:

    • Wenn der Inhalt angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Als Symbol anzeigen.

    • Um ein Symbol anzuzeigen, wählen Sie das Kontrollkästchen als Symbol anzeigen. Zum Ändern der standardmäßigen Symbolbild oder Bezeichnung klicken Sie auf Symbol ändern, und klicken Sie dann klicken Sie auf das Symbol, das in der Liste Symbol aus, oder geben Sie eine Beschriftung in das Feld Beschriftung ein.

Verknüpfen Sie oder betten Sie teilweisen Inhalt aus einem anderen Programm ein

  1. Wählen Sie aus einem anderen Programm als Excel die Informationen, die Sie als ein verknüpftes kopieren oder Eingebettetes Objekt möchten.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf Kopieren.

    Abbildung des Excel-Menübands

  3. Wechseln zu dem Arbeitsblatt, in dem die Informationen platziert werden sollen, und klicken Sie dann an die Position, an der die Informationen angezeigt werden sollen.

  4. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf den Pfeil unter Einfügen, und klicken Sie dann auf Inhalte einfügen.

  5. Führen Sie eine der folgenden Aktionen aus:

    • Klicken Sie auf Verknüpfung einfügen, um die Informationen als verknüpftes Objekt einzufügen.

    • Um die Informationen als eingebettetes Objekt einzufügen, klicken Sie auf Einfügen. Klicken Sie im Feld Als auf den Eintrag mit dem Wort "Objekt" im Namen. Wenn Sie beispielsweise die Daten aus einem Word-Dokument kopiert haben, klicken Sie auf das Objekt Microsoft Word-Dokument.

Ändern der Art und Weise, wie ein OLE-Objekt angezeigt wird

  1. Klicken Sie mit der rechten Maustaste auf das Symbol oder Objekt, zeigen Sie auf den ObjekttypObjekt (z. B. auf das Objekt Dokument), und klicken Sie dann auf Konvertieren.

  2. Führen Sie eine der folgenden Aktionen aus:

    • Wenn der Inhalt angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Als Symbol anzeigen.

    • Um ein Symbol anzuzeigen, wählen Sie das Kontrollkästchen als Symbol anzeigen. Optional können Sie die standardmäßigen Symbolbild oder Beschriftung von ändern. Klicken Sie dazu klicken Sie auf Symbol ändern, und klicken Sie dann klicken Sie auf das Symbol, das in der Liste Symbol aus, oder geben Sie eine Beschriftung in das Feld Beschriftung ein.

Steuern der Aktualisierung von verknüpften Objekten

Sie können Verknüpfungen zu anderen Programmen so festlegen, dass sie auf eine der folgenden Weisen aktualisiert werden: automatisch, wenn Sie die Zieldatei öffnen, manuell, wenn Sie die vorherigen Daten anzeigen möchten, bevor Sie das Objekt mit den neuen Daten aus der Quelldatei aktualisieren, oder wenn Sie die Aktualisierung speziell anfordern, ungeachtet, ob die automatische oder manuelle Aktualisierung aktiviert ist.

Festlegen einer Verknüpfung zu einem anderen Programm, die manuell aktualisiert wird

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Verknüpfungen bearbeiten.

    Abbildung der Excel-Multifunktionsleiste

    Hinweis : Der Befehl Verknüpfungen bearbeiten steht nicht zur Verfügung, wenn Ihre Datei keine Verknüpfungen zu anderen Dateien enthält.

  2. Klicken Sie in der Liste Quelle auf das verknüpfte Objekt, das Sie aktualisieren möchten. Ein A in der Spalte Aktualisieren bedeutet, dass es sich bei der Verknüpfung um eine automatische Verknüpfung handelt, und ein M in der Spalte Aktualisieren bedeutet, dass die Aktualisierungsverknüpfung auf Manuell festgelegt ist.

    Tipp : Um mehrere verknüpfte Objekte auszuwählen, halten Sie STRG gedrückt, und klicken Sie auf jedes verknüpfte Objekt. Um alle verknüpften Objekte zu markieren, drücken Sie STRG+A.

  3. Klicken Sie auf Manuell, um ein verknüpftes Objekt nur dann zu aktualisieren, wenn Sie auf Werte aktualisieren klicken.

Festlegen einer Verknüpfung zu einem anderen Programm, die automatisch aktualisiert wird

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Verknüpfungen bearbeiten.

    Abbildung der Excel-Multifunktionsleiste

    Hinweis : Der Befehl Verknüpfungen bearbeiten steht nicht zur Verfügung, wenn Ihre Datei keine Verknüpfungen zu anderen Dateien enthält.

  2. Klicken Sie in der Liste Quelle auf das verknüpfte Objekt, das Sie aktualisieren möchten. Ein A in der Spalte Aktualisieren bedeutet, dass es sich bei der Verknüpfung um eine automatische Verknüpfung handelt, und ein M in der Spalte Aktualisieren bedeutet, dass die Verknüpfung manuell aktualisiert werden muss.

    Tipp : Um mehrere verknüpfte Objekte auszuwählen, halten Sie STRG gedrückt, und klicken Sie auf jedes verknüpfte Objekt. Um alle verknüpften Objekte zu markieren, drücken Sie STRG+A.

  3. Klicken Sie auf OK.

Problem: Ich kann nicht die automatische Links in Ihrem Arbeitsblatt aktualisiert.

Die Option Automatischkann durch die Excel-Option Verknüpfungen mit anderen Dokumenten aktualisieren überschrieben werden.

So stellen Sie sicher, dass automatische Verknüpfung zu OLE-Objekte automatisch aktualisiert werden können

  1. Klicken Sie auf der Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , klicken Sie auf Excel-Optionen, und klicken Sie dann auf die Kategorie Erweitert.

  2. Vergewissern Sie sich, dass unter Beim Berechnen dieser Arbeitsmappe das Kontrollkästchen Verknüpfungen mit anderen Dokumenten aktualisieren aktiviert ist.

Sofortiges Aktualisieren einer Verknüpfung zu einem anderen Programm

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Verknüpfungen bearbeiten.

    Abbildung der Excel-Multifunktionsleiste

    Hinweis : Der Befehl Verknüpfungen bearbeiten steht nicht zur Verfügung, wenn die Datei keine verknüpften Informationen enthält.

  2. Klicken Sie in der Liste Quelle auf das verknüpfte Objekt, das Sie aktualisieren möchten.

    Tipp : Um mehrere verknüpfte Objekte auszuwählen, halten Sie STRG gedrückt, und klicken Sie auf jedes verknüpfte Objekt. Um alle verknüpften Objekte zu markieren, drücken Sie STRG+A.

  3. Klicken Sie auf Werte aktualisieren.

Bearbeiten der Inhalte aus einem OLE-Programm

Während Sie in Excel arbeiten, können Sie die Inhalte ändern, die aus einem anderen Programm verknüpft oder eingebettet wurden.

Bearbeiten eines verknüpften Objekts im Quellprogramm

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Verknüpfungen bearbeiten.

    Abbildung der Excel-Multifunktionsleiste

    Hinweis : Der Befehl Verknüpfungen bearbeiten steht nicht zur Verfügung, wenn die Datei keine verknüpften Informationen enthält.

  2. Klicken Sie in der Liste Quelldatei auf die Quelle des Verknüpftes Objekt, und klicken Sie dann auf Quelle öffnen.

  3. Nehmen Sie die gewünschten Änderungen an dem verknüpften Objekt vor.

  4. Beenden Sie das Quellprogramm, um zur Zieldatei zurückzukehren.

Bearbeiten eines eingebetteten Objekts im Quellprogramm

  1. Doppelklicken Sie auf das Eingebettetes Objekt, um es zu öffnen.

  2. Nehmen Sie die gewünschten Änderungen am Objekt vor.

  3. Wenn Sie das Objekt direkt im geöffneten Programm bearbeitet haben, klicken Sie auf eine beliebige Stelle außerhalb des Objekts, um zur Zieldatei zurückzukehren.

    Wenn Sie das eingebettete Objekt im Quellprogramm in einem separaten Fenster bearbeiten, beenden Sie das Quellprogramm, um zur Zieldatei zurückzukehren.

Hinweis : Bei einem Doppelklick auf bestimmte eingebettete Objekte wie Video- und Soundclips wird das Objekt abgespielt und nicht das Programm geöffnet. Zum Bearbeiten eines dieser eingebetteten Objekte klicken Sie mit der rechten Maustaste auf das Symbol oder Objekt, zeigen auf ObjekttypObjekt (z. B. Medienclip-Objekt) und klicken dann auf Bearbeiten.

Bearbeiten eines eingebetteten Objekts in einem anderen Programm als dem Quellprogramm

  1. Wählen Sie das Eingebettetes Objekt aus, das Sie bearbeiten möchten.

  2. Klicken Sie mit der rechten Maustaste auf das Symbol oder Objekt, zeigen Sie auf Objekttyp-Objekt (z. B. Dokument-Objekt), und klicken Sie auf Konvertieren.

  3. Führen Sie eine der folgenden Aktionen aus:

    • Zum Konvertieren des eingebetteten Objekts in den Typ, den Sie in der Liste ausgewählt haben, klicken Sie auf Umwandeln in.

    • Zum Öffnen des eingebetteten Objekts als den Typ, den Sie in der Liste ausgewählt haben, ohne den Typ des eingebetteten Objekts zu ändern, klicken Sie auf Aktivieren.

Auswählen eines OLE-Objekts mit der Tastatur

  1. Drücken Sie STRG+G, um das Dialogfeld Gehe zu anzuzeigen.

  2. Klicken Sie auf Sonderformat, wählen Sie Objekte aus, und klicken Sie dann auf OK.

  3. Drücken Sie die TABULATORTASTE, bis das Objekt, das Sie auswählen möchten, markiert ist.

  4. Drücken Sie UMSCHALT+F10.

  5. Zeigen Sie auf Objekt oder Diagrammobjekt, und klicken Sie dann auf Bearbeiten.

Problem: Beim Doppelklick auf ein verknüpftes oder eingebettetes Objekt wird die Meldung "Kann nicht bearbeitet werden" angezeigt

Diese Meldung wird angezeigt, wenn die Quelldatei oder das Quellprogramm nicht geöffnet werden kann.

Vergewissern Sie sich, dass das Quellprogramm verfügbar ist.     Wenn das Quellprogramm auf Ihrem Computer nicht installiert ist, konvertieren Sie das Objekt in das Dateiformat eines installierten Programms.

Sorgen Sie dafür, dass der Arbeitsspeicher ausreicht.     Stellen Sie sicher, dass genügend Speicherplatz für das Ausführen des Quellprogramms zur Verfügung steht. Schließen Sie ggf. andere Programme, um Speicherplatz freizumachen.

Schließen Sie alle Dialogfelder.     Stellen Sie beim Ausführen des Quellprogramms sicher, dass darin keine Dialogfelder geöffnet sind. Wechseln Sie zum Quellprogramm, und schließen Sie alle offenen Dialogfelder.

Schließen Sie die Quelldatei.     Wenn es sich bei der Quelldatei um ein verknüpftes Objekt handelt, stellen Sie sicher, dass dieses von keinem anderen Benutzer geöffnet wurde.

Vergewissern Sie sich, dass der Name der Quelldatei nicht geändert wurde.     Wenn es sich bei der Quelldatei, die Sie bearbeiten möchten, um ein verknüpftes Objekt handelt, stellen Sie sicher, dass die Datei noch den gleichen Namen aufweist wie zu dem Zeitpunkt, als Sie die Verknüpfung erstellt haben, und dass die Datei nicht verschoben wurde. Markieren das verknüpfte Objekt, und klicken Sie dann auf der Registerkarte Daten in der Gruppe Verbindungen auf Verknüpfungen bearbeiten, um den Namen der Quelldatei anzuzeigen. Wenn die Quelldatei umbenannt oder verschoben wurde, klicken Sie im Dialogfeld Verknüpfungen bearbeiten auf die Schaltfläche Quelle ändern, um die Quelldatei zu suchen und die Verknüpfung wiederherzustellen.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×