Bereitstellen von externen Tabellendaten in Excel Services mithilfe von PivotTable-Berichten

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Wenn Sie mit Tabellendaten arbeiten möchten, die auf einer externen Datenverbindung in Excel Services basieren, können Sie keinen externen Datenbereich (auch als Abfragetabelle bezeichnet) verwenden. Sie müssen einen PivotTable-Bericht erstellen, der die multidimensionalen, hierarchischen Daten in eine Tabelle umwandelt oder auf zwei Dimensionen „abflacht“. Hier wird die Vorgehensweise erläutert:

Vergleichen multidimensionaler und zweidimensionaler Daten

1. Konvertieren Sie einen multidimensionalen PivotTable-Bericht…

2. …in einen zweidimensionalen PivotTable-Bericht…

3. …sodass Sie die umgewandelten Tabellendaten in Excel Services sehen können.

Was möchten Sie tun?

Hier erfahren Sie, wie Excel Services die Verbindungen zu externen Datenquellen unterstützt

Unterschiede zwischen PivotTable-Berichten, die mit externen Daten verbunden sind, und externen Datenbereichen

Erstellen eines zweidimensionalen, tabellarischen PivotTable-Berichts

Erstellen des PivotTable-Berichts und Herstellen der Verbindung zu der externen Datenquelle

Hinzufügen, Gestalten und Anordnen der Felder im Bereich der Zeilenbeschriftungen

Ändern von PivotTable-Optionen und Feldeinstellungen

Gestalten des PivotTable-Berichts als zweidimensionale Tabelle

Anpassen des Entwurfs des PivotTable-Berichts

Veröffentlichen der Arbeitsmappe in Excel Services

Hier erfahren Sie, wie Excel Services die Verbindungen zu externen Datenquellen unterstützt

PivotTable-Berichte sind zum Aggregieren großer Mengen numerischer Daten in Summen und Gesamtwerten und zum Arbeiten mit multidimensionalen Daten, die in einer Hierarchie angeordnet sind, konzipiert. Externe Datenbereiche sind wiederum zweidimensionale Tabellen, die in Zeilen und Spalten strukturiert sind, die die nichtaggregierten Datensätze der Quelldaten wiedergeben.

Wenn Sie die Verbindung zu externen Daten im Datenverbindungs-Assistenten oder in Microsoft Query verwenden, erstellen Sie in der Regel einen externen Datenbereich aus. Die einzige Ausnahme ist, wenn Sie einen PivotTable-Bericht erstellen, der mit externen Daten verbunden ist. Ein PivotTable-Bericht erstellt keine externen Datenbereich. Dieser Unterschied in der Anzeige von Verbindungen erstellt werden ist wichtig, zu verstehen, wenn Sie eine Arbeitsmappe in Excel Services veröffentlichen, da Excel Services nur Verbindungen mit externen Daten auf der Grundlage PivotTable-Berichte unterstützt und externe Datenbereiche nicht unterstützt.

Seitenanfang

Unterschiede zwischen PivotTable-Berichten, die mit externen Daten verbunden sind, und externen Datenbereichen

Wenn Sie mit einem PivotTable-Bericht arbeiten, die mit verbunden ist Externe Daten bestehen die Unterschiede zwischen dem Verhalten eines PivotTable-Berichts und eines externen Datenbereichs, dass Ihnen bekannt, einschließlich der Folgendes sein sollte:

PivotTable-Berichte ordnen die Daten in Gruppen und Untergruppen von links nach rechts an

Im Allgemeinen sind Daten basierend auf einer Datensortierung nach einer oder mehreren Spalten gruppiert. Wenn Sie beispielsweise alle Mitarbeiter nach Abteilungen gruppiert anzeigen möchten, können Sie in einer ersten Sortierung nach Abteilungen und in einer zweiten Sortierung nach Mitarbeitern sortieren. Sie können Gruppen auch verschachteln, z. B. Produktlinie, Kategorie und Produkt oder Geografie, Land/Region, Bundesland/Kanton und Stadt. Standardmäßig werden PivotTable-Berichte automatisch in Gruppen und Untergruppen von links nach rechts sortiert, um das Anzeigen verwandter Daten, der Überschrift und der Zusammenfassung sowie das Erweitern oder Reduzieren verwandter Elemente zu erleichtern.

Daten gruppiert nach Produktlinieund subgrouped innerhalb jeder Zeile Produkt nach Kategorie

Produktlinie

Kategorie

Produkt

Antriebssysteme

Flugzeug

Tragflächenbefestigung

Heckbefestigung

Hilfstriebwerk

Auto

269 PS

454 PS

Auspuffsysteme

Kraftfahrzeug

Überhitzungsschutz

Rückgängig

Geländewagen

Klein

Indem Sie eine Spalte mit eindeutigen Werten in den Bereich der Zeilenbeschriftungen links stellen, können Sie die Daten automatisch abflachen.

Die gleichen Produkt Zeile Daten reduziert sind, indem Sie die Num-ID -Spalte hinzufügen

ID-Nummer

Produktlinie

Kategorie

Produkt

WM-345

Antriebssysteme

Flugzeug

Tragflächenbefestigung

TM-231

Antriebssysteme

Flugzeug

Heckbefestigung

BSTR-567

Antriebssysteme

Flugzeug

Hilfstriebwerk

6C-734

Antriebssysteme

Auto

269 PS

8C-121

Antriebssysteme

Auto

454 PS

MF-202

Auspuffsysteme

Kraftfahrzeug

Überhitzungsschutz

MF-321

Auspuffsysteme

Kraftfahrzeug

Rückgängig

MF-211

Auspuffsysteme

Geländewagen

Klein

Wenn die Spalte nicht angezeigt werden soll, können Sie die Spalte nach dem Hinzufügen zum PivotTable-Bericht ausblenden. (Markieren Sie die Spalte, und klicken Sie anschließend auf der Registerkarte Start in der Gruppe Zellen auf den Pfeil neben Format, zeigen Sie auf Aus-/Einblenden, und klicken Sie dann auf Spalten ausblenden.)

Wichtig : Wenn ein PivotTable-Bericht zwei oder mehrere doppelt vorhandene Datenzeilen in der Datenquelle entdeckt, zeigt der PivotTable-Bericht nur jeweils eine Zeile an. Wenn alle Zeilen, auch die doppelten Zeilen, im PivotTable-Bericht angezeigt werden sollen, müssen Sie der Tabelle, Abfrage oder Ansicht, die Sie aus der Datenquelle importieren, eine Spalte, die eindeutige Werte enthält, hinzufügen. Wenn die Datenquelle über keine eindeutige Spalte verfügt, könnten Sie der Datenquelle eine hinzufügen. Sie könnten beispielsweise einer Microsoft Office Access-Tabelle eine Spalte hinzufügen, die über den Datentyp AutoNr verfügt, oder einer Microsoft SQL Server-Tabelle eine Spalte mit dem Datentyp Identität oder einer Datenbankabfrage oder -ansicht eine berechnete Spalte, die für jeden Datensatz eine eindeutige Zahl anzeigt.

Bearbeiten von Zelldaten und Hinzufügen berechneter Spalten

Vor dem Veröffentlichen der Arbeitsmappe auf Excel Services können Sie die Daten in einem externen Datenbereich bearbeiten, aber PivotTable-Daten sind immer schreibgeschützt.

Wenn Sie auf eine Zelle in einem externen Datenbereich doppelklicken, gelangen Sie in den Bearbeitungsmodus, und Sie können den Wert ändern oder sogar eine Formel eingeben. Beachten Sie jedoch, dass Sie nicht den ursprünglichen Wert an der Datenquelle ändern und somit bei der nächsten Datenaktualisierung der neue Wert möglicherweise überschrieben wird, je nach Festlegung der Eigenschaft für den externen Datenbereich Wenn sich bei Datenaktualisierung die Anzahl der Zeilen ändert.

Wenn Sie auf eine Zeilenbeschriftungszelle in einem PivotTable-Bericht doppelklicken, erweitert oder reduziert die Zelle die Elemente in der Zeilenbeschriftungszelle. Beim Abflachen eines PivotTable-Berichts in eine zweidimensionale Tabelle hat das Abflachen den Effekt, dass alle Zeilenwerte in einer Gruppe links von der Zelle nicht mehr angezeigt oder wieder angezeigt werden.

Berechnete Spalten können an beliebiger Stelle in Microsoft Office Excel-Tabellen, die auf einem externen Datenbereich basieren, eingefügt werden. Sie können auch Spalten und Formeln zum Abwärtsausfüllen in einem externen Datenbereich einfügen. In einen PivotTable-Bericht können keine berechneten Spalten eingefügt werden (wohl aber berechnete Felder). Sie können jedoch eine Spalte, die Daten oder Formeln abwärts einliest, unmittelbar links oder rechts vom PivotTable-Bericht hinzufügen, und innerhalb einer abwärts ausgefüllten Formel können Sie Zellbezüge im PivotTable-Bericht verwenden.

Erstellen von Diagrammen

Wenn Sie ein Diagramm auf der Grundlage der Daten in der PivotTable-Bericht erstellen möchten, Sie können einen PivotChart-Bericht auf ähnliche Weise standard Diagramme verhält, erstellen, aber es gibt einige Unterschiede, darunter die folgenden:

Interaktion     Mit Standarddiagrammen kann für jede gewünschte Datenansicht ein Diagramm erstellt werden, aber die Ansichten sind nicht interaktiv. Mit PivotChart-Berichten können Sie ein einziges Diagramm erstellen und die Daten interaktiv auf unterschiedliche Weise anzeigen, indem Sie das Berichtslayout oder das angezeigte Detail ändern. In Excel Services können sowohl ein Standarddiagramm als auch ein PivotChart-Bericht aufgrund der Benutzerinteraktion mit der Arbeitsmappe aktualisiert werden, aber beide Diagramme werden als statische Bilder angezeigt.

Diagrammtypen     Der Standarddiagrammtyp für ein Standarddiagramm ist ein gruppiertes Säulendiagramm, bei dem die Werte kategorienübergreifend verglichen werden. Der Standarddiagrammtyp für einen PivotChart-Bericht ist ein gestapeltes Säulendiagramm, bei dem der Anteil der Einzelwerte mit dem Gesamtwert aller Kategorien verglichen wird. Ein PivotChart-Bericht kann in jeden Diagrammtyp außer Punkt (XY)-Diagramm, Kursdiagramm oder Blasendiagramm geändert werden.

Diagrammelementen     PivotChart-Berichte enthalten die gleichen Elemente wie standard Diagramme, aber sie enthalten auch Felder und Elemente, die hinzugefügt, gedreht oder entfernt werden, um verschiedene Ansichten der Daten angezeigt werden können. Rubriken, Datenreihen und Daten in Diagrammen standard sind Kategorienfelder, von Reihenfeldern und Wertfelder in PivotChart-Berichten. PivotChart-Berichte können auch Berichtsfilter enthalten. Jedes dieser Felder enthält Elemente, die in standard-Diagramme als Etiketts oder Reihe Kategorienamen in Legenden angezeigt werden.

Formatierung     Die meisten formatieren, einschließlich der Elemente, Layout und Format, wird beibehalten, wenn Sie Aktualisieren einem PivotChart-Bericht. Trendlinien, datenbeschriftungen, Fehlerindikatoren und andere Änderungen an den Datenreihen werden jedoch nicht beibehalten. Standard-Diagramme verlieren sich nicht auf diese Formatierung auf einmal angewendet.

Verschieben von Elementen oder Ändern ihrer Größe     In einem PivotChart-Bericht können die Zeichnungsfläche, die Legende, Diagrammtitel oder Achsentitel nicht verschoben oder in der Größe geändert werden, obwohl Sie eine von mehreren im Voraus festgelegten Positionen für die Legende auswählen können, und Sie können den Schriftgrad von Titeln ändern. In einem Standarddiagramm können alle diese Elemente verschoben und in der Größe geändert werden.

Nachdem Sie einen PivotChart-Bericht erstellen, wenn Sie es vorziehen, können Sie es zu einem standard-Diagramm konvertieren. Weitere Informationen finden Sie im Artikel Erstellen oder Löschen einer PivotTable- oder PivotChart-Berichtaus.

Vergleich zwischen den Eigenschaften von externen Datenbereichen und den PivotTable-Optionen

Externe Datenbereiche und PivotTable-Berichte weisen Eigenschaften auf, mit denen Sie die Datenformatierung und das Datenlayout steuern und das Datenverhalten aktualisieren können.

Bei externen Datenbereichen und PivotTable-Berichten können Sie im Falle einer Aktualisierung der externen Daten die Spaltenbreite anpassen und die Spaltensortierung, das Filtern, die Zellformatierung und das Layout der Daten beibehalten.

In externen Datenbereichen verfügen Sie auch über die Option, Zeilennummern als erste Datenspalte aufzunehmen. Bei PivotTable-Berichten gibt es keine ähnliche Option. Eine Diskussion zum Hinzufügen einer eindeutigen Spalte an der Datenquelle finden Sie im Abschnitt PivotTable-Berichte ordnen die Daten in Gruppen und Untergruppen von links nach rechts an.

Beim Aktualisieren eines externen Datenbereichs können Sie steuern, was mit den vorhandenen Daten geschehen soll, wenn sich die Zeilenanzahl in Datenbereichen aufgrund einer der folgenden Optionen ändert:

  • Zellen für neue Daten einfügen, nicht verwendete Zellen löschen (Standard)

  • Ganze Zeilen für neue Daten einfügen, nicht verwendete Zellen löschen

  • Bestehende Zellinhalte überschreiben, nicht verwendete Zellen löschen

Wenn Sie einen PivotTable-Bericht aktualisieren, bringt einfach neuen Daten. Jedoch möglicherweise aufgefordert und aufgefordert, zu entscheiden, ob Sie die vorhandene Zellen unter dem aktuellen Bericht zu überschreiben.

Filtern von Daten

Das Filtern von Daten in einem externen Datenbereich und in einem PivotTable-Bericht ist sehr ähnlich, aber es sind einige Unterschiede vorhanden, u. a. folgende:

  • Für externe Datenbereiche werden die Befehle Textfilter, Zahlenfilter und Datumsfilter verwenden, während in PivotTable-Berichten die Befehle Beschriftungsfilter, Wertefilter und Datumsfilter verwendet werden.

  • Das Filtermenü eines externen Datenbereichs entfernt immer alle nicht mehr gültigen Elemente, und das Filtermenü nimmt mit einem angewendeten Filter nach einer Aktualisierung niemals neue Elemente auf. Bei PivotTable-Berichten sind dagegen Optionen vorhanden, um dieses Verhalten zu steuern. Weitere Informationen finden Sie im Abschnitt Ändern von PivotTable-Optionen und Feldeinstellungen.

  • PivotTable-Berichte verfügen über eine Berichtsfilterfunktion (nicht verfügbar bei einem externen Datenbereich), mit deren Hilfe die Benutzer im PivotTable-Bericht mit einer Teilmenge von Daten arbeiten können.

Sortieren von Daten

In externen Datenbereichen kann eine Mehrspaltensortierung nach bis zu 64 Spalten erfolgen. Jede beliebige Spalte kann als primäre Sortierspalte fungieren, und alle anderen Spalten können als sekundäre Sortierspalten ausgewählt werden. Jedoch unterscheidet sich der Ablauf der Datensortierung in einem PivotTable-Bericht von der Sortierung in einem externen Datenbereich. Im Unterschied zum externen Datenbereich können Sie in einem PivotTable-Bericht eine primäre Sortierung nur über der Spalte durchführen, die sich am weitesten links befindet. Alle anderen Spalten durchlaufen sekundäre Sortierungen, die auf der jeweils links davon befindlichen Spalte basieren. Kurz gesagt, Sie können eine primäre und sekundäre Sortierung nur von links nach rechts durchführen.

Wenn Sie eine Spalte mit eindeutigen Werten als erste Spalte ganz links anordnen, können Sie außerdem nur nach dieser Spalte sortieren, weil Sie folglich eine primäre Gruppe für jede Zeile erstellen. Je nach den Anforderungen der Benutzer möchten Sie evtl. die Daten in Excel vorsortieren und nach der Veröffentlichung der Arbeitsmappe auf Excel Services das Sortieren deaktivieren, indem Sie das Kontrollkästchen Sortieren im Microsoft Office Excel Web Access-Webpart-Toolbereich deaktivieren.

Verwendung von Hyperlinks

Anders als in externen Datenbereichen werden aktive Hyperlinks in PivotTable-Zellen nicht unterstützt. Der Hyperlink wird als Text behandelt, und daher können Sie dem Hyperlink nicht in eine Webseite oder in ein Webdokument in Excel oder Excel Services folgen.

Seitenanfang

Erstellen eines zweidimensionalen, tabellarischen PivotTable-Berichts

Es sind mehrere Schritte zum Abflachen von mehrdimensionalen Daten in einen zweidimensionalen, tabellarischen PivotTable-Bericht erforderlich. Das beste Ergebnis erzielen Sie, wenn Sie die folgenden Aktionen nacheinander ausführen.

Seitenanfang

Erstellen des PivotTable-Berichts und Herstellen der Verbindung zu der externen Datenquelle

  1. Markieren Sie eine leere Zelle.

  2. Klicken Sie auf der Registerkarte Einfügenin der Gruppe Tabellen auf PivotTable, und klicken Sie dann auf PivotTable.

    Abbildung der Excel-Multifunktionsleiste

    Das Dialogfeld PivotTable erstellen wird angezeigt.

  3. Klicken Sie auf Externe Datenquelle verwenden.

  4. Klicken Sie auf Verbindung auswählen.

    Die Klicken Sie im Dialogfeld Vorhandene Verbindungen wird angezeigt.

  5. Wählen Sie in der Liste Anzeigen oben im Dialogfeld die Kategorie von Verbindungen aus, für die Sie eine Verbindung auswählen möchten, oder wählen Sie Alle vorhandenen Verbindungen (Standardfall) aus.

  6. Wählen Sie in der Liste Verbindung auswählen eine Verbindung aus, und klicken Sie dann auf Öffnen.

  7. Geben Sie einen Speicherort an. Führen Sie einen der folgenden Schritte aus:

    • Um den PivotTable-Bericht in einer neuen Arbeitsmappe beginnend bei Zelle A1 zu platzieren, klicken Sie auf Neues Arbeitsblatt.

    • Zum Anordnen des PivotTable-Berichts in einem vorhandenen Arbeitsblatt wählen Sie Vorhandenes Arbeitsblatt aus und geben dann die erste Zelle in dem Zellenbereich ein, in dem der PivotTable-Bericht platziert werden soll.

      Alternativ klicken Sie auf Dialogfeld reduzieren Schaltflächensymbol , um das Dialogfeld vorübergehend auszublenden, markieren Sie die Anfangszelle des Arbeitsblatts, und klicken Sie dann auf Dialogfeld erweitern Schaltflächensymbol .

  8. Klicken Sie auf OK.

An der von Ihnen angegebenen Position wird der leere PivotTable-Bericht mit der PivotTable-Feldliste angezeigt.

Seitenanfang

Hinzufügen, Gestalten und Anordnen der Felder im Bereich der Zeilenbeschriftungen

Verwenden Sie die PivotTable-Feldliste, um die Felder hinzuzufügen, zu gestalten und anzuordnen, und stellen Sie sicher, dass alle Felder dem Zeilenbeschriftungsbereich hinzugefügt werden.

  1. Klicken Sie auf den PivotTable-Bericht.

  2. Führen Sie eine oder mehrere der folgenden Aktionen aus:

    • Führen Sie zum Hinzufügen von Feldern zum Bericht eine oder mehrere der folgenden Aktionen aus:

      • Aktivieren Sie das Kontrollkästchen neben jedem Feldnamen in dem Feldabschnitt in der Feldliste. Jedes Feld wird in einem Standardbereich des Gestaltungsabschnitts platziert, Sie können jedoch die Felder umordnen.

        Standardmäßig werden die nichtnumerischen Felder dem Bereich der Zeilenbeschriftungen hinzugefügt, die numerischen Felder dem Bereich der Werte und die Uhrzeit/Datumsfelder dem Bereich der Spaltenbeschriftungen.

      • Wenn Sie ein Feld in den Bereich der Zeilenbeschriftungen verschieben möchten, klicken Sie mit der rechten Maustaste auf den Feldnamen und wählen dann im Kontextmenü die Option Zu Zeilenbeschriftungen hinzufügen aus.

        Tipp : Sie können auch auf einen Feldnamen klicken, die Maustaste gedrückt halten und das Feld anschließend vom Feldbereich in einen Bereich im Layoutabschnitt ziehen.

    • Zum Umordnen der Felder klicken Sie auf den Feldnamen in einem der Bereiche, und wählen Sie dann einen der folgenden Befehle aus:

Nach oben   

Verschiebt das Feld im Bereich um eine Position nach oben.

Nach unten   

Das Feld wird innerhalb des Bereichs um eine Position nach unten verschoben.

An den Anfang verschieben   

Verschiebt das Feld an den Anfang des Bereichs.

An das Ende verschieben   

Das Feld wird an das Ende des Bereichs verschoben.

In Zeilenbeschriftungen verschieben   

Verschiebt das Feld in den Zeilenbeschriftungsbereich.

  • So entfernen Sie eine Markieren Sie das Feld mit dem Namen in einem der Layoutbereiche, und dann klicken Sie auf Feld entfernen oder deaktivieren Sie das Kontrollkästchen neben jedem Feldnamen ein, die Sie im Feldabschnitt entfernen möchten.

    Tipp : Sie können auch auf einen Feldnamen im Layoutabschnitt klicken, die Maustaste gedrückt halten und anschließend den Feldnamen aus der PivotTable-Feldliste ziehen.

    Hinweis : Durch das Deaktivieren eines Kontrollkästchens im Feldabschnitt werden alle Instanzen des Felds aus dem Bericht entfernt.

Seitenanfang

Ändern von PivotTable-Optionen und Feldeinstellungen

Gehen Sie folgendermaßen vor, um sicherzustellen, dass sich ein PivotTable-Bericht genauso verhält wie ein externer Datenbereich:

Ändern der PivotTable-Optionen   

  1. Klicken Sie auf den PivotTable-Bericht.

  2. Klicken Sie auf der Registerkarte Optionen in der Gruppe PivotTable auf Optionen.

    Das Dialogfeld PivotTable-Optionen wird angezeigt.

  3. Wenn nach einer Aktualisierung die Spaltenbreite automatisch angepasst werden soll, klicken Sie auf die Registerkarte Layout & Format, und anschließend aktivieren Sie unter dem Abschnitt Anzeige das Kontrollkästchen Spaltenbreiten bei Aktualisierung automatisch anpassen.

  4. Wenn nach einer Aktualisierung die Formatierung beibehalten werden soll, klicken Sie auf die Registerkarte Layout & Format, und anschließend aktivieren Sie unter dem Abschnitt Anzeige das Kontrollkästchen Zellformatierung bei Aktualisierung beibehalten.

  5. Um sicherzustellen, dass das Filtermenü nach einer Aktualisierung die nicht mehr gültigen Elemente entfernt, klicken Sie auf die Registerkarte Daten, und wählen Sie in dem Feld Anzahl der pro Feld beizubehaltenden Elemente die Option Keine aus.

Ändern der Feldeinstellungen   

  1. Klicken Sie auf den PivotTable-Bericht.

  2. Um in einen PivotTable-Bericht mit einem angewendeten Filter neue Elemente aufzunehmen, klicken Sie bei jedem Feld mit der rechten Maustaste auf eine Zelle, klicken Sie im Kontextmenü auf Feldeinstellungen, klicken Sie auf die Registerkarte Teilergebnisse & Filter, und aktivieren Sie dann unter dem Abschnitt Filter das Kontrollkästchen Neue Elemente in manuellen Filter einschließen.

Seitenanfang

Gestalten des PivotTable-Berichts als zweidimensionale Tabelle

Wenn Sie den PivotTable-Bericht als zweidimensionale Tabelle gestalten möchten, gehen Sie wie folgt vor:

  1. Klicken Sie auf den PivotTable-Bericht.

  2. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Layout auf Teilergebnisse und dann auf Teilergebnisse nicht anzeigen.

  3. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Layout auf Gesamtsummen, und klicken Sie dann auf Für Zeilen und Spalten deaktiviert.

  4. Klicken Sie auf der Registerkarte Entwurf in der Gruppe Layout auf Berichtslayout und dann auf In Tabellenformat anzeigen.

  5. Klicken Sie auf der Registerkarte Optionen in der Gruppe Einblenden/Ausblenden auf Feldkopfzeilen.

Seitenanfang

Anpassen des Entwurfs des PivotTable-Berichts

Die integrierten PivotTable-Formate und Optionen für Tabellenformat dienen zur mehrdimensionaler Daten, keiner zweidimensionalen Tabelle. Wenn Sie den Bericht in einer Tabelle zweidimensionale diese Formatvorlagen reduzieren Zellrahmen werden nicht angezeigt, und die Verbundene Zeilen und Spalten verbundene Kontrollkästchen in der Gruppe PivotTable Formatoptionen der Registerkarte ' Entwurf ' wirken sich nicht das Format der Zellen. Sie können jedoch ein PivotTable-Format anpassen, dass jede Zelle von Zellrahmen hat und PivotTable-Bericht bedingte Formatierung, verwendet verbundene Zeilen oder Spalten angezeigt werden.

Anpassen der PivotTable-Formatierung   

  1. Klicken Sie auf den PivotTable-Bericht.

  2. Wählen Sie auf der Registerkarte Entwurf in der Gruppe PivotTable-Formate das gewünschte Format aus, und führen Sie dann folgende Aktionen aus:

    1. Klicken Sie mit der rechten Maustaste auf ein sichtbares Format, blättern Sie durch den Katalog, oder klicken Sie unten auf der Bildlaufleiste auf Weitere, um alle verfügbaren Formate anzuzeigen.

    2. Klicken Sie auf Duplizieren.

      Das Dialogfeld Schnellformatvorlage für PivotTable ändern wird angezeigt.

    3. Geben Sie optional einen neuen Namen in das Feld Name ein.

    4. Wählen Sie im Feld Tabellenelement die Option Ganze Tabelle aus, und klicken Sie dann auf Format.

      Das Dialogfeld Zellen formatieren wird angezeigt.

    5. Klicken Sie auf die Registerkarte Rahmen, und erstellen Sie dann einen Zellenrahmen.

    6. Klicken Sie optional auf die Registerkarten Füllbereich und Schriftart, und nehmen Sie weitere Änderungen vor.

    7. Klicken Sie zweimal auf OK.

    8. Klicken Sie unten auf der Bildlaufleiste auf Weitere, und klicken Sie dann unter der Kategorie Benutzerdefiniert auf das gerade von Ihnen erstellte PivotTable-Format.

Anzeigen verbundener Zeilen oder Spalten mithilfe der bedingten Formatierung   

  1. Markieren Sie alle Spalten im PivotTable-Bericht.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Formatvorlagen auf den Pfeil neben Bedingte Formatierung, und klicken Sie dann auf Regeln verwalten.

    Excel-Menübandsymbol

    Das Dialogfeld Manager für Regeln zur bedingten Formatierung wird angezeigt.

  3. Klicken Sie zum Hinzufügen eines bedingten Formats auf Neue Regel.

    Das Dialogfeld Neue Formatierungsregel wird angezeigt.

  4. Klicken Sie unter Regeltyp auswählen auf Formel zur Ermittlung der zu formatierenden Zellen verwenden.

    1. Geben Sie unter Regelbeschreibung bearbeiten im Feld Werte formatieren, für die diese Formel wahr ist eine Formel ein.

    2. Führen Sie eine der folgenden Aktionen aus:

      • Um Zeilen abwechselnd unterschiedlich zu formatieren, geben Sie die folgende Formel ein:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A))

  • Um Spalten abwechselnd unterschiedlich zu formatieren, geben Sie die folgende Formel ein:

=AND(MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  • Um Zeilen und Spalten abwechselnd unterschiedlich zu formatieren, geben Sie die folgende Formel ein:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A),MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  1. Klicken Sie auf Format, um das Dialogfeld Zellen formatieren anzuzeigen.

  2. Wählen Sie die Zahl, die Schriftart, den Rahmen oder das Füllformat aus, das Sie anwenden möchten, wenn der Zellwert die Bedingung erfüllt, und klicken Sie dann auf OK.

    Sie können mehr als ein Format auswählen. Die ausgewählten Formate werden im Feld Vorschau angezeigt.

Seitenanfang

Veröffentlichen der Arbeitsmappe in Excel Services

  1. Klicken Sie auf die Microsoft Office-Schaltfläche Abbildung der Office-Schaltfläche , klicken Sie auf den Pfeil neben Veröffentlichen, und klicken Sie anschließend unter Das Dokument an andere Benutzer verteilen auf Excel Services.

  2. Geben Sie in das Feld Dateiname den Pfad zum Server ein, und übernehmen Sie den vorgeschlagenen Namen für die Arbeitsmappe, oder geben Sie ggf. einen neuen Namen ein.

    Auf einem Computer mit Windows Vista   

    • Wählen Sie in der Adressleiste das Netzwerkverzeichnis aus, auf das die vorgesehenen Benutzer zugreifen können, und klicken Sie auf Speichern.

      Auf einem Computer mit Microsoft Windows XP   

    • Wählen Sie im Feld Speichern in einen Netzwerkpfad aus, auf den die vorgesehenen Benutzer zugreifen können, und klicken Sie dann auf Speichern.

      Geben Sie beispielsweise http://Server/Website/Dateiname

      Hinweis : In Excel kann eine Arbeitsmappe auf dem Server nur im Microsoft Office Excel 2007 XML-basierten Dateiformat (XLSX) oder im Office Excel 2007 binären Dateiformat (XSLB) veröffentlicht werden.

  3. Klicken Sie auf OK.

  4. Wenn Sie überprüfen möchten, dass die sichtbaren Bereiche der Arbeitsmappe im Browser korrekt angezeigt werden, aktivieren Sie das Kontrollkästchen Diese Arbeitsmappe nach dem Speichern in meinem Browser öffnen.

  5. Klicken Sie auf Speichern.

Weitere Informationen finden Sie im Artikel Veröffentlichen einer Arbeitsmappe in Excel Services.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×