Beispiele für häufig verwendete Formeln in SharePoint-Listen

Beispiele für häufig verwendete Formeln in SharePoint-Listen

Die Verwendung von Formeln in berechneten Spalten einer SharePoint-Liste oder SharePoint-Bibliothek kann dabei helfen, Werte zu vorhandenen Spalten zu addieren, etwa beim Berechnen der Mehrwertsteuer auf einen Preis. Diese Verfahren können kombiniert werden, um die Gültigkeit von Daten programmgesteuert zu überprüfen.

Formeln werden ohne Leerzeichen zwischen Schlüsselwörtern und Operatoren eingegeben, sofern nicht anders angegeben. Die folgende Liste ist nicht erschöpfend. Informationen zum Anzeigen aller Formeln in SharePoint finden Sie in der alphabetischen Liste am Ende dieses Artikels.

Hinweis : Berechnete Felder können nur in ihrer eigenen Zeile funktionieren, daher können Sie nicht auf einen Wert in einer anderen Zeile oder in einer Spalte einer anderen Liste oder Bibliothek verweisen. Nachschlagefelder werden in Formeln nicht unterstützt, und die ID einer neu eingefügten Zeile kann nicht verwendet werden, da die ID beim Verarbeiten der Formel nicht vorhanden ist.

Sie können die folgenden Formeln verwenden, um die Bedingung einer Anweisung zu testen und den Wert "Ja" oder "Nein" zurückzugeben, um einen alternativen Wert wie "OK" oder "Nicht OK" zu testen oder ein Leerzeichen oder Gedankenstrich zurückzugeben, um einen Nullwert darzustellen.

Überprüfen, ob eine Zahl größer als oder kleiner als eine andere Zahl ist

Verwenden Sie zum Durchführen dieses Vergleichs die WENN-Funktion.

Spalte1

Spalte2

Formel

Beschreibung (mögliches Ergebnis)

15000

9000

=[Spalte1]>[Spalte2]

Ist Spalte1 größer als Spalte2? (Ja)

15000

9000

=WENN([Spalte1]<=[Spalte2]; "OK"; "Nicht OK")

Ist Spalte1 kleiner als oder gleich Spalte2? (Nicht OK)

Zurückgeben eines logischen Werts nach dem Vergleich von Spalteninhalten

Verwenden Sie für ein Ergebnis, das einen logischen Wert darstellt (Ja oder Nein) die Funktionen UND, ODER und NICHT.

Spalte1

Spalte2

Spalte3

Formel

Beschreibung (mögliches Ergebnis)

15

9

8

=UND([Spalte1]>[Spalte2]; [Spalte1]<[Spalte3])

Ist 15 größer als 9 und kleiner als 8? (Nein)

15

9

8

=ODER([Spalte1]>[Spalte2]; [Spalte1]<[Spalte3])

Ist 15 größer als 9 oder kleiner als 8? (Ja)

15

9

8

=NICHT([Spalte1]+[Spalte2]=24)

Ist 15 plus 9 ungleich 24? (Nein)

Verwenden Sie für ein Ergebnis, das eine andere Berechnung oder einen beliebigen anderen Wert als "Ja" oder "Nein" darstellt, die Funktionen WENN, UND und ODER.

Spalte1

Spalte2

Spalte3

Formel

Beschreibung (mögliches Ergebnis)

15

9

8

=WENN([Spalte1]=15; "OK"; "Nicht OK")

Wenn der Wert in Spalte1 gleich 15 ist, wird "OK" zurückgegeben. (OK)

15

9

8

=WENN(UND([Spalte1]>[Spalte2]; [Spalte1]<[Spalte3]); "OK"; "Nicht OK")

Wenn 15 größer als 9 und kleiner als 8 ist, wird "OK" zurückgegeben. (Nicht OK)

15

9

8

=WENN(ODER([Spalte1]>[Spalte2]; [Spalte1]<[Spalte3]); "OK"; "Nicht OK")

Wenn 15 größer als 9 oder kleiner als 8 ist, wird "OK" zurückgegeben. (OK)

Anzeigen von Nullwerten als Leerzeichen oder Striche

Führen Sie zum Anzeigen einer Null eine einfache Berechnung aus. Führen Sie zum Anzeigen eines Leerzeichens oder eines Striches die WENN-Funktion aus.

Spalte1

Spalte2

Formel

Beschreibung (mögliches Ergebnis)

10

10

=[Spalte1]-[Spalte2]

Zweite Zahl von der ersten (0) subtrahiert

15

9

=WENN([Spalte1]-[Spalte2];"-";[Spalte1]-[Spalte2])

Gibt einen Strich (-) zurück, wenn der Wert Null ist.

Ausblenden von Fehlerwerten in Spalten

Verwenden Sie die ISTFEHLER-Funktion, um einen Strich, #N/V oder NV anstelle eines Fehlerwerts anzuzeigen.

Spalte1

Spalte2

Formel

Beschreibung (mögliches Ergebnis)

10

0

=[Spalte1]/[Spalte2]

Ergibt einen Fehler (#DIV/0)

10

0

=WENN(ISTFEHLER([Spalte1]/[Spalte2]);"NV";[Spalte1]/[Spalte2])

Gibt "NV" zurück, wenn der Wert ein Fehler ist

10

0

=WENN(ISTFEHLER([Spalte1]/[Spalte2]);"-";[Spalte1]/[Spalte2])

Gibt einen Bindestrich zurück, wenn der Wert ein Fehler ist

Suchen nach leeren Feldern

Sie können die Formel ISTLEER verwenden, um leere Felder zu finden.

Spalte1

Formel

Beschreibung (mögliches Ergebnis)

"Geleebohnen"

=ISTLEER([Spalte1]

Gibt "Ja" oder "Nein" bei leerem bzw. nicht leerem Feld zurück

"Stahl"

=WENN(ISTLEER([Spalte1]), "Nicht OK"; "OK")

Setzen Sie Werte eigener Wahl ein – der erste steht für ein leeres Feld, der zweite für ein nicht leeres Feld.

Informationen zu weiteren WENN-Funktionen finden Sie unter WENN-Funktionen.

Mithilfe der folgenden Formeln können Sie Berechnungen durchführen, die auf Datumsangaben und Uhrzeiten basieren, z. B. das Addieren einer Anzahl von Tagen, Monaten oder Jahren zu einem Datum, die Berechnung des Unterschieds zwischen zwei Datumsangaben sowie die Konvertierung einer Uhrzeit in einen Dezimalwert.

Addieren von Datumswerten

Verwenden Sie zum Addieren einer Anzahl von Tagen zu einem Datum den Additionsoperator (+).

Hinweis : Beim Bearbeiten von Datumsangaben muss der Rückgabetyp der berechneten Spalte auf Datum und Uhrzeit festgelegt werden.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

09.06.2007

3

=[Spalte1]+[Spalte2]

Addiert 3 Tage zum 09.06.2007 (12.06.2007)

10.12.2008

54

=[Spalte1]+[Spalte2]

Addiert 54 Tage zum 10.12.2008 (02.02.2009)

Um eine Anzahl von Monaten zu einem Datum hinzuzufügen, verwenden Sie die Funktionen DATUM, JAHR, MONAT und TAG.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

09.06.2007

3

=DATUM(JAHR([Spalte1]);MONAT([Spalte1])+[Spalte2];TAG([Spalte1]))

Addiert 3 Monate zum 09.06.2007 (09.09.2007)

10.12.2008

25

=DATUM(JAHR([Spalte1]);MONAT([Spalte1])+[Spalte2];TAG([Spalte1]))

Addiert 25 Monate zum 10.12.2008 (10.01.2011)

Um eine Anzahl von Jahren zu einem Datum hinzuzufügen, verwenden Sie die Funktionen DATUM, JAHR, MONAT und TAG.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

09.06.2007

3

=DATUM(JAHR([Spalte1])+[Spalte2];MONAT([Spalte1]);TAG([Spalte1]))

Addiert 3 Jahre zum 09.06.2007 (09.06.2010)

10.12.2008

25

=DATUM(JAHR([Spalte1])+[Spalte2];MONAT([Spalte1]);TAG([Spalte1]))

Addiert 25 Jahre zum 10.12.2008 (10.12.2033)

Um eine Kombination von Tagen, Monaten und Jahren zu einem Datum hinzuzufügen, verwenden Sie die Funktionen DATUM, JAHR, MONAT und TAG.

Spalte1

Formel

Beschreibung (Ergebnis)

09.06.2007

=DATUM(JAHR([Spalte1])+3;MONAT([Spalte1])+1;TAG([Spalte1])+5)

Addiert 3 Jahre, 1 Monat und 5 Tage zum 09.06.2007 (14.07.2010)

10.12.2008

=DATUM(JAHR([Spalte1])+1;MONAT([Spalte1])+7;TAG([Spalte1])+5)

Addiert 1 Jahr, 7 Monate und 5 Tage zum 10.12.2008 (15.07.2010)

Berechnen des Unterschieds zwischen zwei Datumsangaben

Verwenden Sie zum Durchführen dieser Berechnung die DATEDIF-Funktion.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

01-Jan-1995

15-Jun-1999

=DATEDIF([Spalte1]; [Spalte2];"d")

Gibt die Anzahl von Tagen zwischen zwei Datumsangaben zurück (1626)

01-Jan-1995

15-Jun-1999

=DATEDIF([Spalte1]; [Spalte2];"ym")

Gibt die Anzahl der Monate zwischen den Datumsangaben zurück, wobei die Jahresangabe ignoriert wird (5)

01-Jan-1995

15-Jun-1999

=DATEDIF([Spalte1]; [Spalte2];"yd")

Gibt die Anzahl der Tage zwischen den Datumsangaben zurück, wobei die Jahresangabe ignoriert wird (165)

Berechnen des Unterschieds zwischen zwei Uhrzeiten

Verwenden Sie den Subtraktionsoperator (-) und die TEXT-Funktion, um das Ergebnis im Standardzeitformat (Stunden:Minuten:Sekunden) darzustellen. Damit diese Methode funktioniert, dürfen die Stunden den Wert 24 sowie die Minuten und Sekunden den Wert 60 nicht überschreiten.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

09.06.2007 10:35 Uhr

09.06.2007 15:30 Uhr

=TEXT([Spalte2]-[Spalte1];"h")

Stunden zwischen zwei Zeitangaben (4)

09.06.2007 10:35 Uhr

09.06.2007 15:30 Uhr

=TEXT([Spalte2]-[Spalte1];"h:mm")

Stunden und Minuten zwischen zwei Zeitangaben (4:55)

09.06.2007 10:35 Uhr

09.06.2007 15:30 Uhr

=TEXT([Spalte2]-[Spalte1];"h:mm:ss")

Stunden, Minuten und Sekunden zwischen zwei Zeitangaben (4:55:00)

Um das Ergebnis in einem Gesamtwert darzustellen, der auf einer Zeiteinheit basiert, verwenden Sie die GANZZAHL-Funktion oder die Funktionen STUNDE, MINUTE oder SEKUNDE.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

09.06.2007 10:35 Uhr

10.06.2007 15:30 Uhr

=GANZZAHL(([Spalte2]-[Spalte1])*24)

Gesamtzahl von Stunden zwischen zwei Zeitangaben (28)

09.06.2007 10:35 Uhr

10.06.2007 15:30 Uhr

=GANZZAHL(([Spalte2]-[Spalte1])*1440)

Gesamtzahl von Minuten zwischen zwei Zeitangaben (1735)

09.06.2007 10:35 Uhr

10.06.2007 15:30 Uhr

=GANZZAHL(([Spalte2]-[Spalte1])*86400)

Gesamtzahl von Sekunden zwischen zwei Zeitangaben (104100)

09.06.2007 10:35 Uhr

10.06.2007 15:30 Uhr

=STUNDE([Spalte2]-[Spalte1])

Stunden zwischen zwei Zeitangaben, wenn der Unterschied 24 nicht überschreitet (4)

09.06.2007 10:35 Uhr

10.06.2007 15:30 Uhr

=MINUTE([Spalte2]-[Spalte1])

Minuten zwischen zwei Zeitangaben, wenn der Unterschied 60 nicht überschreitet (55)

09.06.2007 10:35 Uhr

10.06.2007 15:30 Uhr

=SEKUNDE([Spalte2]-[Spalte1])

Sekunden zwischen zwei Zeitangaben, wenn der Unterschied 60 nicht überschreitet (0)

Konvertieren von Zeitangaben

Verwenden Sie die GANZZAHL-Funktion, um Stunden aus dem Standardzeitformat in eine Dezimalzahl zu konvertieren.

Spalte1

Formel

Beschreibung (Ergebnis)

10:35 Uhr

=([Spalte1]-GANZZAHL([Spalte1]))*24

Anzahl der Stunden seit 12:00 Uhr (10,583333)

12:15 Uhr

=([Spalte1]-GANZZAHL([Spalte1]))*24

Anzahl der Stunden seit 00:00 Uhr (12,25)

Verwenden Sie den Divisionsoperator und die TEXT-Funktion, um Stunden aus einer Dezimalzahl in das Standardzeitformat (Stunden:Minuten:Sekunden) zu konvertieren.

Spalte1

Formel

Beschreibung (Ergebnis)

23:58

=TEXT(Spalte1/24; "hh:mm:ss")

Stunden, Minuten und Sekunden seit 00:00 Uhr (00:59:55)

2:06

=TEXT(Spalte1/24; "h:mm")

Stunden und Minuten seit 00:00 Uhr (0:05)

Einfügen von julianischen Datumsangaben

Ein julianisches Datum bezieht sich auf ein Datumsformat, das eine Kombination aus dem aktuellen Jahr und der Anzahl der Tage seit Jahresbeginn darstellt. Der 1. Januar 2007 wird z. B. als 2007001 und der 31. Dezember 2007 als 2007365 dargestellt. Dieses Format basiert nicht auf dem julianischen Kalender.

Verwenden Sie die Funktionen TEXT und DATWERT, um ein Datum in ein julianisches Datum zu konvertieren.

Spalte1

Formel

Beschreibung (Ergebnis)

23.06.2007

=TEXT([Spalte1];"yy")&TEXT(([Spalte1]-DATWERT("1/1/"& TEXT([Spalte1];"yy"))+1);"000")

Datum im julianischen Format mit einer zweistelligen Jahresangabe (07174)

23.06.2007

=TEXT([Spalte1];"yyyy")&TEXT(([Spalte1]-DATWERT("1/1/"&TEXT([Spalte1];"yy"))+1);"000")

Datum im julianischen Format mit einer vierstelligen Jahresangabe (2007174)

Verwenden Sie die Konstante 2415018,50, um ein Datum in ein julianisches Datum zu konvertieren, das in der Astronomie verwendet wird. Diese Formel funktioniert nur bei Datumsangaben nach dem 01.03.1901 und bei Verwendung des 1900-Datumssystems.

Spalte1

Formel

Beschreibung (Ergebnis)

23.06.2007

=[Spalte1]+2415018,50

Datum im julianischen Format, das in der Astronomie verwendet wird (2454274,50)

Anzeigen von Datumsangaben als Wochentage

Verwenden Sie die Funktionen TEXT und WOCHENTAG, um Datumsangaben in Text für den Wochentag zu konvertieren.

Spalte1

Formel

Beschreibung (mögliches Ergebnis)

19-Feb-2007

=TEXT(WOCHENTAG([Spalte1]); "dddd")

Berechnet den Wochentag für das Datum und gibt den vollständigen Namen des Tages zurück (Montag)

3-Jan-2008

=TEXT(WOCHENTAG([Spalte1]); "ddd")

Berechnet den Wochentag für das Datum und gibt den abgekürzten Namen des Tages zurück (Don)

Mithilfe der folgenden Formeln können Sie eine Vielzahl von mathematischen Berechnungen durchführen, z. B. Additionen, Subtraktionen und Divisionen, Berechnung von Mittel- oder Medianwerten, Runden von Zahlen und Zählen von Werten.

Addieren von Zahlen

Verwenden Sie den Additionsoperator (+) oder die SUMME-Funktion, um Zahlen in zwei oder mehr Spalten in einer Zeile zu addieren.

Spalte1

Spalte2

Spalte3

Formel

Beschreibung (Ergebnis)

6

5

4

=[Spalte1]+[Spalte2]+[Spalte3]

Addiert die Werte in den ersten drei Spalten (15)

6

5

4

=SUMME([Spalte1];[Spalte2];[Spalte3])

Addiert die Werte in den ersten drei Spalten (15)

6

5

4

=SUMME(WENN([Spalte1]>[Spalte2]; [Spalte1]-[Spalte2]; 10); [Spalte3])

Wenn Spalte1 größer als Spalte2 ist, werden die Differenz und Spalte3 addiert. Andernfalls werden 10 und Spalte3 addiert (5)

Subtrahieren von Zahlen

Verwenden Sie den Subtraktionsoperator (-) oder die SUMME-Funktion mit negativen Zahlen, um Zahlen in zwei oder mehr Spalten in einer Zeile zu subtrahieren.

Spalte1

Spalte2

Spalte3

Formel

Beschreibung (Ergebnis)

15000

9000

-8000

=[Spalte1]-[Spalte2]

Subtrahiert 9000 von 15000 (6000)

15000

9000

-8000

=SUMME([Spalte1]; [Spalte2]; [Spalte3])

Addiert Zahlen in den ersten drei Spalten, einschließlich negativer Werte (16000)

Berechnen der Differenz zwischen zwei Zahlen und Anzeigen als Prozentsatz

Verwenden Sie die Subtraktions- (-) und Divisionsoperatoren (/) sowie die ABS-Funktion.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

2342

2.500

=([Spalte2]-[Spalte1])/ABS([Spalte1])

Änderung des Prozentsatzes (6,75 % oder 0,06746)

Multiplizieren von Zahlen

Verwenden Sie den Multiplikationsoperator (*) oder die PRODUKT-Funktion, um Zahlen in zwei oder mehr Spalten in einer Zeile zu multiplizieren.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

5

2

=[Spalte1]*[Spalte2]

Multipliziert die Zahlen in den ersten beiden Spalten (10)

5

2

=PRODUKT([Spalte1]; [Spalte2])

Multipliziert die Zahlen in den ersten beiden Spalten (10)

5

2

=PRODUKT([Spalte1];[Spalte2];2)

Multipliziert die Zahlen in den ersten beiden Spalten und die Zahl 2 (20)

Dividieren von Zahlen

Verwenden Sie den Divisionsoperator (/), um Zahlen in zwei oder mehr Spalten in einer Zeile zu dividieren.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

15000

12

=[Spalte1]/[Spalte2]

Dividiert 15000 durch 12 (1250)

15000

12

=([Spalte1]+10000)/[Spalte2]

Addiert 15000 und 10000 und dividiert dann die Summe durch 12 (2083)

Berechnen des Mittelwerts von Zahlen

Der Mittelwert wird auch als Durchschnitt bezeichnet. Verwenden Sie die MITTELWERT-Funktion, um den Mittelwert von Zahlen in zwei oder mehr Spalten in einer Zeile zu berechnen.

Spalte1

Spalte2

Spalte3

Formel

Beschreibung (Ergebnis)

6

5

4

=MITTELWERT([Spalte1]; [Spalte2];[Spalte3])

Mittelwert der Zahlen in den ersten drei Spalten (5)

6

5

4

=MITTELWERT(WENN([Spalte1]>[Spalte2]; [Spalte1]-[Spalte2]; 10); [Spalte3])

Wenn Spalte1 größer als Spalte2 ist, wird der Mittelwert aus der Differenz und Spalte3 berechnet. Andernfalls wird der Mittelwert des Werts 10 und Spalte3 berechnet (2,5).

Berechnen des Medians von Zahlen

Der Median ist der Wert in der Mitte eines sortierten Bereichs von Zahlen. Verwenden Sie die MEDIAN-Funktion, um den Median einer Gruppe von Zahlen zu berechnen.

A

B

C

D

B

F

Formel

Beschreibung (Ergebnis)

10

7

9

27

0

4

=MEDIAN(A; B; C; D; E; F)

Median der Zahlen in den ersten sechs Spalten (8)

Berechnen der kleinsten oder größten Zahl in einem Bereich

Verwenden Sie die Funktionen MIN und MAX, um die kleinste oder größte Zahl in zwei oder mehr Spalten in einer Zeile zu berechnen.

Spalte1

Spalte2

Spalte3

Formel

Beschreibung (Ergebnis)

10

7

9

=MIN([Spalte1]; [Spalte2]; [Spalte3])

Kleinste Zahl (7)

10

7

9

=MAX([Spalte1]; [Spalte2]; [Spalte3])

Größte Zahl (10)

Zählen von Werten

Verwenden Sie die ANZAHL-Funktion, um numerische Werte zu zählen.

Spalte1

Spalte2

Spalte3

Formel

Beschreibung (Ergebnis)

Apfel

12.12.2007

=ANZAHL([Spalte1]; [Spalte2]; [Spalte3])

Zählt die Anzahl der Spalten, die numerische Werte enthalten. Ausgeschlossen werden Datum und Uhrzeit, Text und Nullwerte (0)

$12

#DIV/0!

1,01

=ANZAHL([Spalte1]; [Spalte2]; [Spalte3])

Zählt die Anzahl der Spalten, die numerische Werte enthalten, schließt jedoch Fehler- und logische Werte aus (2)

Erhöhen oder Verringern einer Zahl um einen Prozentsatz

Verwenden Sie den Prozentoperator (%), um diese Berechnung auszuführen.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

23

3 %

=[Spalte1]*(1+5 %)

Erhöht die Zahl in Spalte1 um 5 % (24,15)

23

3 %

=[Spalte1]*(1+[Spalte2])

Erhöht die Zahl in Spalte1 um den Prozentwert in Spalte2: 3 % (23,69)

23

3 %

=[Spalte1]*(1-[Spalte2])

Verringert die Zahl in Spalte1 um den Prozentwert in Spalte2: 3 % (22,31)

Potenzieren einer Zahl

Verwenden Sie den Potenzierungsoperator (^) oder die POTENZ-Funktion, um diese Berechnung auszuführen.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

5

2

=[Spalte1]^[Spalte2]

Berechnet die Potenz von 5 (25)

5

3

=POTENZ([Spalte1]; [Spalte2])

Berechnet die dritte Potenz von 5 (125)

Runden einer Zahl

Verwenden Sie die Funktionen AUFRUNDEN, GERADE oder UNGERADE, um eine Zahl zu runden.

Spalte1

Formel

Beschreibung (Ergebnis)

20,3

=AUFRUNDEN([Spalte1];0)

Rundet 20,3 auf die nächste ganze Zahl auf (21)

-5,9

=AUFRUNDEN([Spalte1];0)

Rundet -5,9 auf die nächste ganze Zahl auf (-5)

12,5493

=AUFRUNDEN([Spalte1];2)

Rundet 12,5493 auf das nächste Hundertstel und zwei Dezimalstellen auf (12,55)

20,3

=GERADE([Spalte1])

Rundet 20,3 auf die nächste gerade Zahl auf (22)

20,3

=UNGERADE([Spalte1])

Rundet 20,3 auf die nächste ungerade ganze Zahl auf (21)

Verwenden Sie die ABRUNDEN-Funktion, um eine Zahl abzurunden.

Spalte1

Formel

Beschreibung (Ergebnis)

20,3

=ABRUNDEN([Spalte1];0)

Rundet 20,3 auf die nächste ganze Zahl ab (20)

-5,9

=ABRUNDEN([Spalte1];0)

Rundet -5,9 auf die nächste ganze Zahl ab (-6)

12,5493

=ABRUNDEN([Spalte1];2)

Rundet 12,5493 auf das nächste Hundertstel und zwei Dezimalstellen ab (12,54)

Verwenden Sie die RUNDEN-Funktion, um eine Zahl auf die nächste Zahl oder Kommastelle zu runden.

Spalte1

Formel

Beschreibung (Ergebnis)

20,3

=RUNDEN([Spalte1];0)

Rundet 20,3 ab, da die Kommastelle kleiner als 0,5 ist (20)

5,9

=RUNDEN([Spalte1];0)

Rundet 5,9 auf, da die Kommastelle größer als 0,5 ist (6)

-5,9

=RUNDEN([Spalte1];0)

Rundet -5,9 ab, da die Kommastelle kleiner als -0,5 ist (-6)

1,25

=RUNDEN([Spalte1]; 1)

Rundet die Zahl auf das nächste Zehntel (eine Dezimalstelle). Da der zu rundende Teil 0,05 oder mehr beträgt, wird die Zahl aufgerundet (Ergebnis: 1,3)

30,452

=RUNDEN([Spalte1]; 2)

Rundet die Zahl auf das nächste Hundertstel (zwei Dezimalstellen). Da der zu rundende Teil 0,002 kleiner als 0,005 ist, wird die Zahl abgerundet (Ergebnis: 30,45)

Verwenden Sie die Funktionen RUNDEN, AUFRUNDEN, ABRUNDEN, GANZZAHL und LÄNGE, um eine Zahl auf die signifikante Stelle über 0 zu runden.

Spalte1

Formel

Beschreibung (Ergebnis)

5492820

=RUNDEN([Spalte1];3-LÄNGE(GANZZAHL([Spalte1])))

Rundet die Zahl auf drei signifikante Stellen (5490000)

22230

=ABRUNDEN([Spalte1];3-LÄNGE(GANZZAHL([Spalte1])))

Rundet die untere Zahl auf drei signifikante Stellen ab (22200)

5492820

=AUFRUNDEN([Spalte1]; 5-LÄNGE(GANZZAHL([Spalte1])))

Rundet die obere Zahl auf fünf signifikante Stellen auf (5492900)

Mithilfe der folgenden Formeln können Sie Text bearbeiten, z. B. die Werte aus mehreren Spalten kombinieren oder verketten, die Inhalte von Spalten vergleichen, Zeichen oder Leerzeichen entfernen sowie Zeichen wiederholen.

Ändern der Schreibung von Text

Verwenden Sie die Funktionen GROSS, KLEIN und GROSS2, um die Großschreibung von Text zu ändern.

Spalte1

Formel

Beschreibung (Ergebnis)

nina Vietzen

=GROSS([Spalte1])

Ändert den Text in Großbuchstaben (NINA VIETZEN)

nina Vietzen

=KLEIN([Spalte1])

Ändert den Text in Kleinbuchstaben (nina vietzen)

nina Vietzen

=GROSS2([Spalte1])

Ändert den Text in große Anfangsbuchstaben (Nina Vietzen)

Kombinieren von Vornamen und Nachnamen

Verwenden Sie das kaufmännische Und-Zeichen (&) oder die VERKETTEN-Funktion, um Vornamen und Nachnamen zu kombinieren.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

Conrad

Kutzsche

=[Spalte1]&[Spalte2]

Kombiniert zwei Zeichenfolgen (ConradKutzsche)

Conrad

Kutzsche

=[Spalten1]&" "&[Spalte2]

Kombiniert zwei Zeichenfolgen, die durch ein Leerzeichen getrennt werden (Conrad Kutzsche)

Conrad

Kutzsche

=[Spalte2]&"; "&[Spalte1]

Kombiniert zwei Zeichenfolgen, die durch ein Komma und ein Leerzeichen getrennt werden (Kutzsche, Conrad)

Conrad

Kutzsche

=VERKETTEN([Spalte2]; ","; [Spalte1])

Kombiniert zwei Zeichenfolgen, die durch ein Komma getrennt werden (Kutzsche,Conrad)

Kombinieren von Text und Zahlen aus verschiedenen Spalten

Verwenden Sie die VERKETTEN-Funktion, das kaufmännische Und-Zeichen (&) oder die TEXT-Funktion und das kaufmännische Und-Zeichen, um Text und Zahlen zu kombinieren.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

Lorenz

28

=[Spalte1]&" hat "&[Spalte2]&" Einheiten verkauft."

Kombiniert die obigen Inhalte zu einem Satz (Lorenz hat 28 Einheiten verkauft.)

Wilske

40%

=[Spalte1]&" hat "&TEXT([Spalte2];"0 %")&" des Gesamtumsatzes erzielt."

Kombiniert die obigen Inhalte zu einem Satz (Wilske hat 40 % des Gesamtumsatzes erzielt.)

Hinweis : Die TEXT-Funktion fügt den formatierten Wert von Spalte2 anstelle des zugrunde liegenden Werts an, der 0,4 ist.

Lorenz

28

=VERKETTEN([Spalte1];" hat ";[Spalte2];" Einheiten verkauft.")

Kombiniert die obigen Inhalte zu einem Satz (Lorenz hat 28 Einheiten verkauft.)

Kombinieren von Text mit einem Datum oder einer Uhrzeit

Verwenden Sie die TEXT-Funktion und das kaufmännische Und-Zeichen (&), um Text mit einem Datum oder einer Uhrzeit zu kombinieren.

Spalte1

Spalte2

Formel

Beschreibung (Ergebnis)

Rechnungsdatum

5-Jun-2007

="Aufstellungsdatum: "&TEXT([Spalte2]; "d-mmm-yyyy")

Kombiniert Text mit einem Datum (Aufstellungsdatum: 5-Jun-2007)

Rechnungsdatum

5-Jun-2007

=[Spalte1]&" "&TEXT([Spalte2]; "mmm-dd-yyyy")

Kombiniert Text und eine Datumsangabe aus verschiedenen Spalten zu einer einzigen Spalte (Rechnungsdatum Jun-05-2007)

Vergleichen von Spalteninhalt

Verwenden Sie die Funktionen IDENTISCH und ODER, um eine Spalte mit einer anderen Spalte oder einer Liste von Werten zu vergleichen.

Spalte1

Spalte2

Formel

Beschreibung (mögliches Ergebnis)

BD122

BD123

=IDENTISCH([Spalte1];[Spalte2])

Vergleicht die Inhalte der ersten beiden Spalten (Nein)

BD122

BD123

=IDENTISCH([Spalte1]; "BD122")

Vergleicht den Inhalt von Spalte1 mit der Zeichenfolge "BD122" (Ja)

Überprüfen, ob ein Spaltenwert oder ein Teil davon einem bestimmten Text entspricht

Verwenden Sie die Funktionen WENN, FINDEN, SUCHEN und ISTZAHL, um zu überprüfen, ob ein Spaltenwert oder ein Teil davon einem bestimmten Text entspricht.

Spalte1

Formel

Beschreibung (mögliches Ergebnis)

Vietzen

=WENN([Spalte1]="Vietzen"; "OK"; "Nicht OK")

Überprüft, ob Spalte1 Vietzen entspricht (OK)

Vietzen

=WENN(ISTZAHL(FINDEN("v";[Spalte1])); "OK"; "Nicht OK")

Überprüft, ob Spalte1 den Buchstaben v enthält (OK)

BD123

=ISTZAHL(FINDEN("BD";[Spalte 1]))

Überprüft, ob Spalte1 BD enthält (Ja)

Zählen nicht leerer Spalten

Verwenden Sie die ANZAHL2-Funktion, um nicht leere Spalten zu zählen.

Spalte1

Spalte2

Spalte3

Formel

Beschreibung (Ergebnis)

Vertrieb

19

=ANZAHL2([Spalte1]; [Spalte2])

Zählt die Anzahl nicht leerer Spalten (2)

Vertrieb

19

=ANZAHL2([Spalte1]; [Spalte2]; [Spalte3])

Zählt die Anzahl nicht leerer Spalten (2)

Entfernen von Zeichen aus Text

Verwenden Sie die Funktionen LÄNGE, LINKS und RECHTS, um Zeichen aus Text zu entfernen.

Spalte1

Formel

Beschreibung (Ergebnis)

Vitamin A

=LINKS([Spalte1];LÄNGE([Spalte1])-2)

Gibt 7 (9-2) Zeichen von links zurück (Vitamin)

Vitamin B1

=RECHTS([Spalte1]; LÄNGE([Spalte1])-8)

Gibt 2 (10-8) Zeichen von rechts zurück (B1)

Entfernen von Leerzeichen am Anfang und Ende einer Spalte

Verwenden Sie die GLÄTTEN-Funktion, um Leerzeichen aus einer Spalte zu entfernen.

Spalte1

Formel

Beschreibung (Ergebnis)

 Hallo zusammen!

=GLÄTTEN([Spalte1])

Entfernt die Leerzeichen am Anfang und am Ende (Hallo zusammen!)

Wiederholen eines Zeichens in einer Spalte

Verwenden Sie die WIEDERHOLEN-Funktion, um ein Zeichen in einer Spalte zu wiederholen.

Formel

Beschreibung (Ergebnis)

=WIEDERHOLEN("."; 3)

Wiederholt einen Punkt drei Mal (...)

=WIEDERHOLEN("-"; 10)

Wiederholt einen Gedankenstrich 10 Mal (----------)

Alphabetische Liste der Funktionen

Die folgende Liste verzeichnet die Links zu den für SharePoint-Benutzer zugänglichen Funktionen. Sie enthält trigonometrische, statistische und finanzmathematische Funktionen sowie Formeln zu Bedingungen, Datum, Mathematik und Text.

ABS

ARCCOS

ARCCOSHYP

ARCCOSHYP

UND

ARCSIN

ARCSINHYP

ARCTAN

ARCTAN2

MITTELWERT

MITTELWERTA

BETAVERT

BETAINV

BINOMVERT

OBERGRENZE

ZEICHEN

CHIVERT

WAHL

CODE

VERKETTEN

KONFIDENZ

COS

ANZAHL

ANZAHL2

KRITBINOM

DATUM

DATEDIF-Funktion

DATWERT

TAG

TAGE360

GDA

GRAD

DM

GERADE

IDENTISCH

EXPONVERT

FAKULTÄT

FVERT

FINDEN

FINV

FISHER

FEST

GAMMAVERT

GAMMAINV

GAMMALN

GEOMITTEL

HARMITTEL

STUNDE

HYPGEOMVERT

WENN

GANZZAHL

ZINSZ

IST

LINKS

LÄNGE

LN

LOG

LOG10

LOGINV

LOGNORMVERT

KLEIN

MAX

ICH

MEDIAN

TEIL

MIN

MINA

MINUTE

REST

MONAT

NEGBINOMVERT

NORMVERT

STANDNORMVERT

STANDNORMINV

NICHT

ZZR

NBW

NBW

UNGERADE

ODER

RMZ

POTENZ

KAPZ

PRODUKT

GROSS2

BW

BOGENMASS

ERSETZEN

WIEDERHOLEN

RECHTS

RUNDEN

ABRUNDEN

AUFRUNDEN

SUCHEN

SEKUNDE

VORZEICHEN

SIN

SINHYP

WURZEL

STANDARDISIERUNG

STABWA

STABWN

STABWNA

SUMME

QUADRATESUMME

DIA

TANHYP

TVERT

TEXT

ZEIT

TINV

HEUTE

GLÄTTEN

WAHR

WAHR

GROSS

USDOLLAR

WERT

VARIANZ

VARIANZA

VARIANZEN

VARIANZENA

WOCHENTAG

WEIBULL

JAHR

Weitere Ressourcen

Wenn Sie hier nicht finden, was Sie vorhaben, probieren Sie aus, ob es in Excel funktioniert, oder schauen Sie sich die Webpart-Filter an. Hier einige weitere Quellen. Einige davon befassen sich möglicherweise mit älteren Versionen, sodass die dargestellte Benutzeroberfläche möglicherweise Unterschiede aufweist. Beispielsweise befinden sich die Elemente im Menü Websiteaktionen in SharePoint 2010 mittlerweile im Menü Einstellungen Die Schaltfläche für die Office 365 Einstellungen - sieht wie ein Zahnrad neben Ihrem Namen aus .

Es gibt eine Vielzahl weiterer Ressourcen im Web, nach denen Sie suchen können, wie beispielsweise Farbliches Codieren von berechneten Feldern.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×