Beispiele für häufig verwendete Formeln

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Die folgenden Beispiele können in berechneten Spalten einer Liste oder Bibliothek verwendet werden. Mithilfe von Beispielen, in denen keine Verweise auf Spalten einbezogen sind, kann der Standardwert einer Spalte angegeben werden.

Inhalt dieses Artikels

Bedingte Formeln

Datums- und Uhrzeitfunktionen

Mathematische Formeln

Textformeln

Bedingte Formeln

Verwenden Sie die folgenden Formeln, um die Bedingung einer Anweisung zu testen und den Wert Wahr oder Falsch zurückzugeben, um einen alternativen Wert OK oder Nicht OK zu testen oder eine Leerzeile oder einen Strich zurückzugeben, um einen Nullwert darzustellen.

Überprüfen, ob eine Zahl größer als oder kleiner als eine andere Zahl ist

Führen Sie den Vergleich mithilfe der WENN-Funktion aus.

Spalte 1

Spalte 2

Formel

Beschreibung (mögliches Ergebnis)

15000

9000

=[Spalte 1]>[Spalte 2]

Ist die Zahl in Spalte 1 größer als die Zahl in Spalte 2? (WAHR)

15000

9000

=WENN([Spalte 1]<=[Spalte 2];"OK";"Nicht OK")

Ist die Zahl in Spalte 1 kleiner oder gleich der Zahl in Spalte 2? (Nicht OK)

Zurückgeben eines logischen Werts nach dem Vergleich von Spalteninhalten

Verwenden Sie für ein Ergebnis, bei dem es sich um einen logischen Wert (WAHR oder FALSCH) handelt, die Funktionen UND, ODER und NICHT.

Spalte 1

Spalte 2

Spalte 3

Formel

Beschreibung (mögliches Ergebnis)

15

2,74

2,44

=UND([Spalte 1]>[Spalte 2];[Spalte 1]<[Spalte 3])

Ist 15 größer als 9 und kleiner als 8? (FALSCH)

15

2,74

2,44

=ODER([Spalte 1]>[Spalte 2];[Spalte 1]<[Spalte 3])

Ist 15 größer als 9 oder kleiner als 8? (WAHR)

15

2,74

2,44

=NICHT([Spalte 1]+[Spalte 2]=24)

Ist 15 plus 9 nicht gleich 24? (FALSCH)

Bei einem Ergebnis, das sich in einer anderen Berechnung befindet, oder einem anderen Wert, bei dem es sich nicht um WAHR oder FALSCH handelt, verwenden Sie die Funktionen WENN, UND und ODER.

Spalte 1

Spalte 2

Spalte 3

Formel

Beschreibung (mögliches Ergebnis)

15

2,74

2,44

=WENN([Spalte 1]=15;"OK";"Nicht OK")

Wenn der Wert in Spalte 1 der Zahl 15 entspricht, wird "OK" zurückgegeben. (OK)

15

2,74

2,44

=WENN(UND([Spalte 1]>[Spalte 2];[Spalte 1]<[Spalte 3]);"OK";"Nicht OK")

Wenn 15 größer als 9 und kleiner als 8 ist, wird "OK" zurückgegeben. (Nicht OK)

15

2,74

2,44

=WENN(ODER([Spalte 1]>[Spalte 2];[Spalte 1]<[Spalte 3]);"OK";"Nicht OK")

Wenn 15 größer als 9 oder kleiner als 8 ist, wird "OK" zurückgegeben. (OK)

Anzeigen von Nullwerten als Leerzeichen oder Striche

Um einen Nullwert anzuzeigen, führen Sie eine einfache Berechnung aus. Um eine Leerzeile oder einen Strich anzuzeigen, verwenden Sie die WENN-Funktion.

S palte1

Spalte 2

Formel

Beschreibung (mögliches Ergebnis)

10

10

=[Spalte 1]-[Spalte 2]

Die zweite Zahl wird von der ersten Zahl subtrahiert (0).

15

2,74

=WENN([Spalte 1]-[Spalte 2];"-";[Spalte 1]-[Spalte 2])

Gibt einen Strich zurück, wenn der Wert Null ist (-)

Ausblenden von Fehlerwerten in Spalten

Verwenden Sie die ISTFEHLER-Funktion, um anstelle eines Fehlerwerts einen Strich, #N/V oder NV anzuzeigen.

Spalte 1

Spalte 2

Formel

Beschreibung (mögliches Ergebnis)

10

3500

=[Spalte 1]/[Spalte 2]

Ergibt einen Fehler (#DIV/0)

10

3500

=WENN(ISTFEHLER([Spalte 1]/[Spalte 2]);"NV";[Spalte 1]/[Spalte 2])

Gibt "NV" zurück, wenn der Wert ein Fehler ist

10

3500

=WENN(ISTFEHLER([Spalte 1]/[Spalte 2]);"-";[Spalte 1]/[Spalte 2])

Gibt einen Bindestrich zurück, wenn der Wert ein Fehler ist

Seitenanfang

Datums- und Zeitformeln

Verwenden Sie die folgenden Formeln, um Berechnungen auf der Grundlage von Datums- und Zeitangaben auszuführen, z. B. zum Hinzufügen einer Anzahl von Tagen, Monaten oder Jahren zu einem Datum, zum Berechnen des Unterschieds zwischen zwei Datumsangaben und zum Konvertieren einer Zeitangabe in einen Dezimalwert.

Addieren von Datumswerten

Verwenden Sie den Additionsoperator (+), um einem Datum eine Anzahl von Tagen hinzuzufügen.

Hinweis : Beim Bearbeiten von Datumsangaben muss der Rückgabetyp der berechneten Spalte auf Datum und Uhrzeit festgelegt werden.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

09.06.07

4

=[Spalte 1]+[Spalte 2]

Fügt dem 09.06.07 3 Tage hinzu (12.06.07)

10.12.08

54

=[Spalte 1]+[Spalte 2]

Fügt dem 10.12.08 54 Tage hinzu (02.02.09)

Verwenden Sie die Funktionen DATUM, JAHR, MONAT und TAG, um einem Datum eine Anzahl von Monaten hinzuzufügen.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

09.06.07

4

=DATUM(JAHR([Spalte 1]);MONAT([Spalte 1])+[Spalte 2];TAG([Spalte 1]))

Fügt 3 Monate zu 09.06.07 hinzu (09.09.07)

10.12.08

25

=DATUM(JAHR([Spalte 1]);MONAT([Spalte 1])+[Spalte 2];TAG([Spalte 1]))

Fügt 25 Monate zu 10.12.08 hinzu (10.01.2011).

Verwenden Sie die Funktionen DATUM, JAHR, MONAT und TAG, um einem Datum eine Anzahl von Jahren hinzuzufügen.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

09.06.07

4

=DATUM(JAHR([Spalte 1])+[Spalte 2];MONAT([Spalte 1]);TAG([Spalte 1]))

Fügt 3 Jahre zu 09.06.07 hinzu (09.06.10)

10.12.08

25

=DATUM(JAHR([Spalte 1])+[Spalte 2];MONAT([Spalte 1]);TAG([Spalte 1]))

Fügt 25 Jahre zu 10.12.08 hinzu (10.12.33)

Verwenden Sie die Funktionen DATUM, JAHR, MONAT und TAG, um eine Kombination von Tagen, Monaten und Jahren zu einem Datum hinzuzufügen.

Spalte 1

Formel

Beschreibung (Ergebnis)

09.06.07

=DATUM(JAHR([Spalte 1])+3;MONAT([Spalte 1])+1;TAG([Spalte 1])+5)

Fügt 3 Jahre, 1 Monat und 5 Tage zu 09.06.2007 hinzu (14.07.2010)

10.12.08

=DATUM(JAHR([Spalte 1])+1;MONAT([Spalte 1])+7;TAG([Spalte 1])+5)

Fügt 1 Jahr, 7 Monate und 5 Tage zu 10.12.08 hinzu (15.07.10)

Berechnen des Unterschieds zwischen zwei Datumsangaben

Verwenden Sie die DATEDIF-Funktion, um diese Berechnung auszuführen.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

01.01.95

15.06.99

=DATEDIF([Spalte 1];[Spalte 2];"d")

Gibt die Anzahl von Tagen zwischen den beiden Datumsangaben zurück (1626)

01.01.95

15.06.99

=DATEDIF([Spalte 1];[Spalte 2];"ym")

Gibt die Anzahl von Monaten zwischen den beiden Datumsangaben zurück, wobei die Jahresangaben ignoriert werden (5)

01.01.95

15.06.99

=DATEDIF([Spalte 1];[Spalte 2];"yd")

Gibt die Anzahl von Tagen zwischen den beiden Datumsangaben zurück, wobei die Jahresangaben ignoriert werden (165)

Berechnen des Unterschieds zwischen zwei Uhrzeiten

Verwenden Sie den Subtraktionsoperator (-) und die TEXT-Funktion, um das Ergebnis im Standardzeitformat (Stunden:Minuten:Sekunden) darzustellen. Stunden dürfen nie die Anzahl 24, Minuten nie die Anzahl 60 und Sekunden nie die Anzahl 60 überschreiten.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

09.06.07 10:35

09.06.07 15:30

=TEXT([Spalte 2]-[Spalte 1];"h")

Stunden zwischen zwei Zeitangaben (4)

09.06.2007 10:35

09.06.07 15:30

=TEXT([Spalte 2]-[Spalte 1];"h:mm")

Stunden und Minuten zwischen zwei Zeitangaben (4:55)

09.06.2007 10:35

09.06.07 15:30

=TEXT([Spalte 2]-[Spalte 1];"h:mm:ss")

Stunden, Minuten und Sekunden zwischen zwei Zeitangaben (4:55:00)

Verwenden Sie die GANZZAHL-Funktion oder die Funktionen STUNDE, MINUTE und SEKUNDE, um das Ergebnis in einer Gesamtsumme darzustellen, die auf einer Zeiteinheit basiert.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

09.06.07 10:35

10.06.2007 15:30

=GANZZAHL(([Spalte 2]-[Spalte 1])*24)

Gesamtanzahl der Stunden zwischen zwei Zeitangaben (28)

09.06.2007 10:35

10.06.2007 15:30

=GANZZAHL(([Spalte 2]-[Spalte 1])*1440)

Gesamtanzahl der Minuten zwischen zwei Zeitangaben (1735)

09.06.2007 10:35

10.06.2007 15:30

=GANZZAHL(([Spalte 2]-[Spalte 1])*86400)

Gesamtanzahl der Sekunden zwischen zwei Zeitangaben (104100)

09.06.2007 10:35

10.06.2007 15:30

=STUNDE([Spalte 2]-[Spalte 1])

Stunden zwischen zwei Zeitangaben, wenn der Unterschied 24 nicht überschreitet (4)

09.06.2007 10:35

10.06.2007 15:30

=MINUTE([Spalte 2]-[Spalte 1])

Minuten zwischen zwei Zeitangaben, wenn der Unterschied 60 nicht überschreitet (55)

09.06.2007 10:35

10.06.2007 15:30

=SEKUNDE([Spalte 2]-[Spalte 1])

Sekunden zwischen zwei Zeitangaben, wenn der Unterschied 60 nicht überschreitet (0)

Konvertieren von Zeitangaben

Verwenden Sie die GANZZAHL-Funktion, um Stunden aus dem Standardzeitformat (Stunden:Minuten:Sekunden) in das Dezimalformat zu konvertieren.

Spalte 1

Formel

Beschreibung (Ergebnis)

10:35

=([Spalte 1]-GANZZAHL([Spalte 1]))*24

Anzahl von Stunden seit 0:00 (10,583333)

12:15

=([Spalte 1]-GANZZAHL([Spalte 1]))*24

Anzahl von Stunden seit 0:00 (12,25)

Verwenden Sie den Divisionsoperator (/) und die TEXT-Funktion, um Stunden aus dem Dezimalformat in das Standarzeitformat (Stunden:Minuten:Sekunden) zu konvertieren.

Spalte 1

Formel

Beschreibung (Ergebnis)

23:58

=TEXT(Spalte 1/24;"hh:mm:ss")

Stunden, Minuten und Sekunden seit 12:00 (00:59:55)

2:06

=TEXT(Spalte 1/24;"h:mm")

Stunden und Minuten seit 12:00 (0:05)

Einfügen von julianischen Datumsangaben

Ein julianisches Datum bezieht sich auf ein Datumsformat, das aus der Kombination des aktuellen Jahres und der Anzahl von Tagen seit Jahresbeginn besteht. Der 1. Januar 2007 wird beispielsweise als 2007001 dargestellt, der 31. Dezember 2007 wird als 2007356 dargestellt. Beachten Sie, dass dieses Format nicht auf dem julianischen Kalender basiert.

Verwenden Sie die Funktionen TEXT und DATWERT, um ein Datum in ein julianisches Datum zu konvertieren.

Spalte 1

Formel

Beschreibung (Ergebnis)

23.06.07

=TEXT([Spalte 1];"jj")&TEXT(([Spalte 1]-DATWERT("1/1/"&TEXT([Spalte 1];"jj"))+1);"000")

Datum in julianischem Format mit zweistelliger Jahresangabe (07174)

23.06.07

=TEXT([Spalte 1];"jjjj")&TEXT(([Spalte 1]-DATWERT("1/1/"&TEXT([Spalte 1];"jj"))+1);"000")

Datum in julianischem Format mit vierstelliger Jahresangabe (2007174)

Verwenden Sie die Konstante 2415018,50, um ein Datum in ein in der Astronomie verwendetes julianisches Datum zu konvertieren. Diese Formel ist nur für Datumsangaben nach dem 1.3.1901 und nur in Arbeitsmappen mit dem 1900-Datumssystem funktionsfähig.

Spalte 1

Formel

Beschreibung (Ergebnis)

23.06.07

=[Spalte 1]+2415018,50

Datum in in der Astronomie verwendetem julianischem Format (2454274,50)

Anzeigen von Datumsangaben als Wochentage

Verwenden Sie die Funktionen TEXT und WOCHENTAG, um Datumsangaben in den Text des Wochentags zu konvertieren.

Spalte 1

Formel

Beschreibung (mögliches Ergebnis)

19.02.07

=TEXT(WOCHENTAG([Spalte 1]);"tttt")

Berechnet den Wochentag für das Datum und gibt den vollständigen Namen des Tags zurück (Montag)

3-Jan-2008

=TEXT(WOCHENTAG([Spalte 1]);"ttt")

Berechnet den Wochentag für das Datum und gibt den abgekürzten Namen des Tags zurück (Mo)

Seitenanfang

Mathematische Formeln

Mithilfe der folgenden Formeln können Sie verschiedene mathematische Berechnungen ausführen, z. B. Addieren, Subtrahieren, Multiplizieren und Dividieren von Zahlen, Berechnen des Durchschnitts oder Medians von Zahlen, Auf- oder Abrunden einer Zahl und Zählen von Werten.

Addieren von Zahlen

Verwenden Sie den Additionsoperator (+) oder die SUMME-Funktion, um Zahlen in mindestens zwei Spalten in einer Zeile zu addieren.

Spalte 1

Spalte 2

Spalte 3

Formel

Beschreibung (Ergebnis)

19

18

3500

=[Spalte 1]+[Spalte 2]+[Spalte 3]

Addiert die Werte in den ersten drei Spalten (15)

19

18

3500

=SUMME([Spalte 1];[Spalte 2];[Spalte 3])

Addiert die Werte in den ersten drei Spalten (15)

19

18

3500

=SUMME(WENN([Spalte 1]>[Spalte 2];[Spalte 1]-[Spalte 2];10);[Spalte 3])

Wenn Spalte 1 größer als Spalte 2 ist, wird die Differenz und Spalte 3 addiert. Andernfalls wird 10 und Spalte 3 addiert (5)

Subtrahieren von Zahlen

Verwenden Sie den Minusoperator (-) oder die SUMME-Funktion mit negativen Zahlen, um Zahlen in mindestens zwei Spalten in einer Zeile zu subtrahieren.

Spalte 1

Spalte 2

Spalte 3

Formel

Beschreibung (Ergebnis)

15000

9000

-8000

=[Spalte 1]-[Spalte 2]

Subtrahiert 9000 von 15000 (6000)

15000

9000

-8000

=SUMME([Spalte 1];[Spalte 2];[Spalte 3])

Addiert die Zahlen in den ersten drei Spalten einschließlich negativer Werte (16000)

Berechnen der Differenz zwischen zwei Zahlen und Anzeigen als Prozentsatz

Verwenden Sie den Minusoperator (-) und den Divisionsoperator (/) sowie die ABS-Funktion.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

2342

2500

=([Spalte 2]-[Spalte 1])/ABS([Spalte 1])

Änderung des Prozentsatzes (6,75% oder 0,06746)

Multiplizieren von Zahlen

Verwenden Sie den Multiplikationsoperator (*) oder die PRODUKT-Funktion, um die Zahlen in mindestens zwei Spalten in einer Zeile zu multiplizieren.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

18

3500

=[Spalte 1]*[Spalte 2]

Multipliziert die Zahlen in den beiden ersten Spalten (10)

18

3500

=PRODUKT([Spalte 1];[Spalte 2])

Multipliziert die Zahlen in den beiden ersten Spalten (10)

18

3500

=PRODUKT([Spalte 1];[Spalte 2];2)

Multipliziert die Zahlen in den beiden ersten Spalten mit der Zahl 2 (20)

Dividieren von Zahlen

Verwenden Sie den Divisionsoperator (/), um Zahlen in mindestens zwei Spalten zu dividieren.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

15000

3,66

=[Spalte 1]/[Spalte 2]

Dividiert 15000 durch 12 (1250)

15000

3,66

=([Spalte 1]+10000)/[Spalte 2]

Addiert 15000 und 10000 und dividiert die Summe dann durch 12 (2083)

Berechnen des Mittelwerts von Zahlen

Der Mittelwert wird auch Durchschnitt genannt. Verwenden Sie die MITTELWERT-Funktion, um den Mittelwert von Zahlen in zwei oder mehr Spalten zu berechnen.

Spalte 1

Spalte 2

Spalte 3

Formel

Beschreibung (Ergebnis)

19

18

3500

=MITTELWERT([Spalte 1];[Spalte 2];[Spalte 3])

Durchschnitt der Zahlen in den ersten drei Spalten (5)

19

18

3500

=MITTELWERT(WENN([Spalte 1]>[Spalte 2];[Spalte 1]-[Spalte 2];10);[Spalte 3])

Wenn Spalte 1 größer als Spalte 2 ist, wird der Durschnitt der Differenz und Spalte 3 berechnet. Andernfalls wird der Durchschnitt des Werts 10 und Spalte 3 berechnet (2,5)

Berechnen des Medians von Zahlen

Der Median ist der Wert, der in der Mitte einer sortierten Zahlenreihe liegt. Verwenden Sie die MEDIAN-Funktion, um den Median einer Gruppe von Zahlen zu berechnen.

A

B

C

D

E

F

Formel

Beschreibung (Ergebnis)

10

7

2,74

27

3500

3500

=MEDIAN(A;B;C;D;E;F)

Median der Zahlen in den ersten 6 Spalten (8)

Berechnen der kleinsten oder größten Zahl in einem Bereich

Verwenden Sie die Funktionen MIN und MAX, um die kleinste oder größte Zahl in mindestens zwei Spalten in einer Zeile zu berechnen.

Spalte 1

Spalte 2

Spalte 3

Formel

Beschreibung (Ergebnis)

10

7

2,74

=MIN([Spalte 1];[Spalte 2];[Spalte 3])

Kleinste Zahl (7)

10

7

2,74

=MAX([Spalte 1];[Spalte 2];[Spalte 3])

Größte Zahl (10)

Zählen von Werten

Verwenden Sie die ANZAHL-Funktion, um numerische Werte zu zählen.

Spalte 1

Spalte 2

Spalte 3

Formel

Beschreibung (Ergebnis)

Apfel

12.12.07

=ANZAHL([Spalte 1];[Spalte 2];[Spalte 3])

Berechnet die Anzahl von Spalten, die numerische Werte enthalten. Ausgeschlossen werden Datum und Uhrzeit, Text und Nullwerte (0)

$12

#DIV/0!

1,01

=ANZAHL([Spalte 1];[Spalte 2];[Spalte 3])

Berechnet die Anzahl von Spalten, die numerische Werte enthalten, schließt jedoch Fehler- und logische Werte aus (2)

Erhöhen oder Verringern einer Zahl um einen Prozentsatz

Verwenden Sie den %-Operator, um diese Berechnung auszuführen.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

23

3%

=[Spalte 1]*(1+5%)

Erhöht die Zahl in Spalte 1 um 5 % (24,15)

23

3%

=[Spalte 1]*(1+[Spalte 2])

Erhöht die Zahl in Spalte 1 um den Prozenzsatz in Spalte 2: 3 % (23,69)

23

3%

=[Spalte 1]*(1-[Spalte 2])

Verringert die Zahl in Spalte 1 um den Prozentsatz in Spalte 2: 3 % (22,31)

Potenzieren einer Zahl

Verwenden Sie den Potenzierungsoperator (^) oder die POTENZ-Funktion, um diese Berechnung auszuführen.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

18

3500

=[Spalte 1]^[Spalte 2]

Berechnet 5 im Quadrat (25)

18

4

=POTENZ([Spalte 1];[Spalte 2])

Berechnet Fünf hoch drei (125)

Runden einer Zahl

Verwenden Sie die Funktion AUFRUNDEN, UNGERADE oder GERADE, um eine Zahl aufzurunden.

Spalte 1

Formel

Beschreibung (Ergebnis)

20,3

=AUFRUNDEN([Spalte 1];0)

Rundet 20,3 auf die nächste ganze Zahl auf (21)

-5,9

=AUFRUNDEN([Spalte 1];0)

Rundet -5,9 auf die nächste ganze Zahl auf (-5)

12,5493

=AUFRUNDEN([Spalte 1];2)

Rundet 12,5493 auf das nächste Hundertstel und zwei Dezimalstellen auf (12,55)

20,3

=GERADE([Spalte 1])

Rundet 20,3 auf die nächste gerade Zahl auf (22)

20,3

=UNGERADE([Spalte 1])

Rundet 20,3 auf die nächste ungerade Zahl auf (21)

Verwenden Sie die ABRUNDEN-Funktion, um eine Zahl abzurunden.

Spalte 1

Formel

Beschreibung (Ergebnis)

20,3

=ABRUNDEN([Spalte 1];0)

Rundet 20,3 auf die nächste ganze Zahl ab (20)

-5,9

=ABRUNDEN([Spalte 1];0)

Rundet -5,9 auf die nächste ganze Zahl ab (-6)

12,5493

=ABRUNDEN([Spalte 1];2)

Rundet die Zahl auf das nächste Hundertstel und zwei Dezimalstellen ab (12.54)

Verwenden Sie die RUNDEN-Funktion, um eine Zahl auf die nächste Zahl oder Kommastelle zu runden.

Spalte 1

Formel

Beschreibung (Ergebnis)

20,3

=RUNDEN([Spalte 1];0)

Rundet 20,3 ab, da der zu rundende Teil weniger als 0,5 beträgt (20)

5,9

=RUNDEN([Spalte 1];0)

Rundet 5,9 auf, weil der zu rundende Teil größer als 0,5 ist (6)

-5,9

=RUNDEN([Spalte 1];0)

Rundet -5,9 ab, weil der zu rundende Teil weniger als -0,5 beträgt (-6)

1,25

=RUNDEN([Spalte 1];1)

Rundet die Zahl auf das nächste Zehntel (eine Dezimalstelle) auf. Da die zu rundende Teilzahl über 0,05 liegt, wird die Zahl aufgerundet. (Ergebnis: 1,3)

30,452

=RUNDEN([Spalte 1];2)

Rundet die Zahl auf das nächste Hundertstel (zwei Dezimalstellen) auf. Da die zu rundende Teilzahl, 0,002, unter 0,005 liegt, wird die Zahl abgerundet. (Ergebnis: 30,45)

Verwenden Sie die Funktionen RUNDEN, ABRUNDEN, AUFRUNDEN, GANZZAHL und LÄNGE, um eine Zahl auf einen Zahlenwert größer Null zu runden.

Spalte 1

Formel

Beschreibung (Ergebnis)

5492820

=RUNDEN([Spalte 1];3-LÄNGE(GANZZAHL([Spalte 1])))

Rundet die Zahl auf drei Stellen (5490000)

22230

=ABRUNDEN([Spalte 1];3-LÄNGE(GANZZAHL([Spalte 1])))

Rundet die untere Zahl ab auf drei Stellen (22200)

5492820

=AUFRUNDEN([Spalte 1];5-LÄNGE(GANZZAHL([Spalte 1])))

Rundet die obere Zahl auf fünf Stellen auf (5492900)

Seitenanfang

Textformeln

Mithilfe der folgenden Formeln können Sie Text bearbeiten, z. B. Werte aus mehreren Spalten kombinieren oder verketten, den Inhalt von Spalten vergleichen, Zeichen oder Leerzeichen entfernen und Zeichen wiederholen.

Ändern der Schreibung von Text

Verwenden Sie die Funktion GROSS, KLEIN oder GROSS2, um die Schreibweise von Text zu ändern.

Spalte 1

Formel

Beschreibung (Ergebnis)

eva Valverde

=GROSS([Spalte 1])

Ändert die Schreibweise des Texts in Großbuchstaben (EVA VALVERDE)

eva Valverde

=KLEIN([Spalte 1])

Ändert die Schreibweise des Texts in Kleinbuchstaben (eva valverde)

eva Valverde

=GROSS2([Spalte 1])

Ändert die Schreibweise des Texts in große Anfangsbuchstaben (Eva Valverde)

Kombinieren von Vornamen und Nachnamen

Verwenden Sie den Operator kaufmännisches Und (&) oder die VERKETTEN-Funktion, um Vor- und Nachnamen zu kombinieren.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

Carlos

Carvallo

=[Spalte 1]&[Spalte 2]

Fasst die beiden Zeichenfolgen zusammen (CarlosCarvallo)

Carlos

Carvallo

=[Spalte 1]&" "&[Spalte 2]

Fasst die beiden Zeichenfolgen getrennt durch ein Leerzeichen zusammen (Carlos Carvallo)

Carlos

Carvallo

=[Spalte 2]&", "&[Spalte 1]

Fasst die beiden Zeichenfolgen getrennt durch ein Komma und ein Leerzeichen zusammen (Carvallo, Carlos)

Carlos

Carvallo

=VERKETTEN([Spalte 2];",";[Spalte 1])

Fasst die beiden Zeichenfolgen getrennt durch ein Komma zusammen (Carvallo,Carlos)

Kombinieren von Text und Zahlen aus verschiedenen Spalten

Verwenden Sie die VERKETTEN-Funktion, den Operator kaufmännisches Und (&) oder die TEXT-Funktion und den Operator kaufmännisches Und, um Text und Zahlen zu kombinieren.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

Yang

28

=[Spalte 1]&" verkaufte "&[Spalte 2]&" Einheiten."

Kombiniert die oben angegebenen Informationen zu einem Satz (Yang verkaufte 28 Einheiten.)

Dubois

40%

=[Spalte 1]&" machte "&TEXT([Spalte 2];"0%")&" des Gesamtumsatzes."

Kombiniert die oben angegebenen Informationen zu einem Satz (Dubois machte 40% des Gesamtumsatzes.)

Hinweis : Mithilfe der TEXT-Funktion wird statt des enthaltenen Werts der formatierte Wert aus Spalte 2 angehängt (0,4).

Yang

28

=VERKETTEN([Spalte 1];" verkaufte ";[Spalte 2];" Einheiten.")

Kombiniert die oben angegebenen Informationen zu einem Satz (Yang verkaufte 28 Einheiten.)

Kombinieren von Text mit einem Datum oder einer Uhrzeit

Verwenden Sie die TEXT-Funktion und den Operator kaufmännisches Und (&), um Text mit einer Datums- oder Zeitangabe zu kombinieren.

Spalte 1

Spalte 2

Formel

Beschreibung (Ergebnis)

Rechnungsdatum

05.06.2007

="Abrechnungsdatum: "&TEXT([Spalte 2];"t.mm.jjjj")

Kombiniert Text mit einem Datum (Rechnungsdatum: 5.06.2007)

Rechnungsdatum

05.06.2007

=[Spalte 1]&" "&TEXT([Spalte 2];"tt.mm.jjjj")

Kombiniert Text und eine Datumsangabe aus verschiedenen Spalten in einer Spalte (Rechnungsdatum 05.06.2007)

Vergleichen von Spalteninhalt

Verwenden Sie die Funktionen IDENTISCH und ODER, um eine Spalte mit einer anderen oder einer Liste von Werten zu vergleichen.

Spalte 1

Spalte 2

Formel

Beschreibung (mögliches Ergebnis)

BD122

BD123

=IDENTISCH([Spalte 1];[Spalte 2])

Vergleicht den Inhalt der beiden ersten Spalten (FALSCH)

BD122

BD123

=IDENTISCH([Spalte 1];"BD122")

Vergleicht den Inhalt von Spalte 1 mit der Zeichenfolge "BD122" (WAHR)

Überprüfen, ob ein Spaltenwert oder ein Teil davon einem bestimmten Text entspricht

Verwenden Sie die Funktionen WENN, FINDEN, SUCHEN und ISTZAHL, um zu überprüfen, ob ein Spaltenwert oder ein Teil davon mit angegebenem Text übereinstimmt.

Spalte 1

Formel

Beschreibung (mögliches Ergebnis)

Valverde

=WENN([Spalte 1]="Valverde";"OK";"Nicht OK")

Überprüft, ob Spalte 1 den Text Valverde enthält (OK)

Valverde

=WENN(ISTZAHL(FINDEN("V";[Spalte 1]));"OK";"Nicht OK")

Überprüft, ob Spalte 1 den Buchstaben V enthält (OK)

BD123

=ISTZAHL(FINDEN("BD";[Spalte 1]))

Überprüft, ob Spalte 1 BD enthält (WAHR)

Zählen nicht leerer Spalten

Verwenden Sie die ANZAHL2-Funktion, um nicht leere Spalten zu zählen.

Spalte 1

Spalte 2

Spalte 3

Formel

Beschreibung (Ergebnis)

Vertrieb

19

=ANZAHL2([Spalte 1];[Spalte 2])

Zählt die Anzahl der nicht leeren Spalten (2)

Vertrieb

19

=ANZAHL2([Spalte 1];[Spalte 2];[Spalte 3])

Zählt die Anzahl der nicht leeren Spalten (2)

Entfernen von Zeichen aus Text

Verwenden Sie die Funktionen LÄNGE, LINKS und RECHTS, um Zeichen aus Text zu entfernen.

Spalte 1

Formel

Beschreibung (Ergebnis)

Vitamin A

=LINKS([Spalte 1];LÄNGE([Spalte 1])-2)

Entfernt die beiden letzten Zeichen von links und gibt 7 (9-2) Zeichen zurück (Vitamin)

Vitamin B1

=RECHTS([Spalte 1];LÄNGE([Spalte 1])-8)

Entfernt die ersten 8 Zeichen von rechts und gibt 2 (10-8) Zeichen zurück (B1)

Entfernen von Leerzeichen am Anfang und Ende einer Spalte

Verwenden Sie die GLÄTTEN-Funktion, um Leerzeichen aus einer Spalte zu entfernen.

Spalte 1

Formel

Beschreibung (Ergebnis)

 Aufgepasst!

=GLÄTTEN([Spalte 1])

Entfernt am Anfang und am Ende die Leerzeichen aus der Zeichenfolge (Aufgepasst!)

Wiederholen eines Zeichens in einer Spalte

Verwenden Sie die WIEDERHOLEN-Funktion, um ein Zeichen in einer Spalte zu wiederholen.

Formel

Beschreibung (Ergebnis)

=WIEDERHOLEN(".";3)

Wiederholt einen Punkt (.) drei Mal (...)

=WIEDERHOLEN("-";10)

Wiederholt einen Gedankenstrich (-) zehn Mal (----------)

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×