Beispiel für eine Berechnung in Solver

Solver ist Bestandteil einer Reihe von Befehlen, die auch als Was-wäre-wenn-Analyse -Tools bezeichnet werden. Mit Solver kann ein optimaler (Maximal- oder Minimal-) Wert für eine Formel in einer Zelle – die als Zielzelle bezeichnet wird – unter Berücksichtigung der Bedingungen oder Einschränkungen für die Werte anderer Formelzellen auf einem Blatt gefunden werden. Solver arbeitet mit einer Gruppe von Zellen, die als Entscheidungsvariablen oder einfach Variablenzellen bezeichnet werden und an der Berechnung der Formeln in den Ziel- und Einschränkungszellen beteiligt sind. Solver passt die Werte in den Entscheidungsvariablenzellen so an, dass sie den Grenzwerten in Einschränkungszellen entsprechen und das gewünschte Ergebnis für die Zielzelle ergeben.

Solver kann verwendet werden, um den Maximal- oder Minimalwert einer Zelle durch Ändern der anderen Zellen zu bestimmen. Beispielsweise können Sie den Betrag des prognostizierten Werbeetats ändern und die Auswirkungen auf den prognostizierten Gewinn ablesen.

Im folgenden Beispiel wirkt sich der Werbeaufwand pro Quartal auf die Anzahl der verkauften Einheiten aus und bestimmt so indirekt den Betrag des Verkaufserlöses, der zugeordneten Ausgaben und des Gewinns. Solver kann die vierteljährlichen Werbebudgets (Entscheidungsvariablenzellen B5:C5) bis zu einem Gesamtbudgetgrenzwert von $20.000 (Zelle D5) ändern, bis der Gesamtgewinn (Zielzelle D7) den maximal möglichen Betrag erreicht. Die Werte in den Variablenzellen werden verwendet, um den Gewinn für jedes Quartal zu berechnen, daher hängen sie mit der Zielzelle der Formel D7, =SUMME(Q1 Gewinn:Q2 Gewinn) zusammen.

Solver-Beispielauswertung

Legende 1 Variablenzellen

Schaltflächensymbol Eingeschränkte Zelle

Legende 3  Zielzelle

Nach Solver Ausführungen ergeben sich die folgenden neuen Werte.

Solver-Beispielauswertung mit neuen Werte

Führen Sie eine der folgenden Aktionen aus:

Definieren und Lösen eines Problems

  1. Klicken Sie auf der Registerkarte Daten unter Analyse auf Solver.

    Registerkarte "Daten", Gruppe "Analyse", Solver-Add-In

    Vorgehen, falls Solver auf der Registerkarte "Daten" nicht unter "Analyse" angezeigt wird

    1. Klicken Sie im Menü Extras auf Add-Ins.

    2. Aktivieren Sie in der Liste Verfügbare Add-Ins das Kontrollkästchen Solver.xlam, und klicken Sie auf OK.

  2. Geben Sie in Ziel festlegen einen Zellbezug oder den Namen der Zielzelle ein.

    Hinweis : Sie Zielzelle muss eine Formel enthalten.

  3. Führen Sie einen der folgenden Schritte aus:

Zweck

Verfahren

Festlegen des größtmöglichen Werts für die Zielzelle

Klicken Sie auf Max.

Festlegen des kleinstmöglichen Werts für die Zielzelle

Klicken Sie auf Min.

Festlegen der Zielzelle auf einen bestimmten Wert

Klicken Sie auf Wert von, und geben Sie dann den Wert in das Feld ein.

  1. Geben Sie im Feld Durch Ändern von Variablenzellen einen Namen oder Bezug für jeden Bereich von Entscheidungsvariablenzellen ein. Trennen Sie nicht aneinander angrenzende Bezüge durch Kommas.

    Die Variablenzellen müssen direkt oder indirekt auf die Zielzelle bezogen sein. Sie können bis zu 200 Variablenzellen angeben.

  2. Fügen Sie im Feld Unterliegt den Nebenbedingungen alle Einschränkungen hinzu, die gelten sollen.

    Hinzufügen einer Beschränkung

    1. Klicken Sie im Dialogfeld Solver-Parameter auf Hinzufügen.

    2. Geben Sie im Feld Zellbezug den Zellbezug oder den Namen des Zellbereichs ein, für den Sie den Wert einschränken möchten.

    3. Wählen Sie im <=-Beziehungspopupmenü die gewünschte Beziehung zwischen der Zelle, auf die verwiesen wird, und der Einschränkung aus.Wenn Sie <=, = oder >= auswählen, geben Sie im Feld Nebenbedingung eine Zahl, einen Zellbezug oder -namen oder eine Formel ein.

      Hinweis : In Einschränkungen für Entscheidungsvariablenzellen können nur die Beziehungen "int", "bin" und "dif" angewendet werden.

    4. Führen Sie einen der folgenden Schritte aus:

    Zweck

    Verfahren

    Akzeptieren der Einschränkung und Hinzufügen einer weiteren Einschränkung

    Klicken Sie auf Hinzufügen.

    Akzeptieren der Einschränkung und Rückkehr zum Dialogfeld Solver-Parameter

    Klicken Sie auf OK.

  3. Klicken Sie auf Lösen, und führen Sie dann eine der folgenden Aktionen aus:

Zweck

Verfahren

Beibehalten der Lösungswerte auf dem Blatt

Klicken Sie im Dialogfeld Solver-Ergebnisse auf Solver-Lösung akzeptieren.

Wiederherstellen der ursprünglichen Daten

Klicken Sie auf Ursprüngliche Werte wiederherstellen.

Hinweise : 

  1. Drücken Sie die ESC-TASTE , um den Lösungsprozess zu unterbrechen. Excel führt eine Neuberechnung des Blatts mit den letzten Werten, die für die anpassbaren Zellen gefunden werden, durch.

  2. Zum Erstellen eines Berichts, der auf Ihrer Lösung basiert, können Sie auf einen Berichtstyp im Feld Berichte und anschließend auf OK klicken, nachdem Solver eine Lösung gefunden hat. Der Bericht wird auf einem neuen Blatt in der Arbeitsmappe erstellt. Wenn Solver keine Lösung findet, steht die Option zum Erstellen eines Berichts nicht zur Verfügung.

  3. Zum Speichern der angepassten Zellwerten als Szenario, das zu einem späteren Zeitpunkt angezeigt werden kann, klicken Sie im Dialogfeld Solver-Ergebnisse auf Szenario speichern, und geben Sie dann im Feld Szenarionameeinen Namen für das Szenario ein.

Schrittweises Durchlaufen von Solver-Zwischenergebnissen

  1. Klicken Sie auf der Registerkarte Daten unter Analyse auf Solver.

    Registerkarte "Daten", Gruppe "Analyse", Solver-Add-In

    Vorgehen, falls Solver auf der Registerkarte "Daten" nicht unter "Analyse" angezeigt wird

    1. Klicken Sie im Menü Extras auf Add-Ins.

    2. Aktivieren Sie in der Liste Verfügbare Add-Ins das Kontrollkästchen Solver.xlam, und klicken Sie auf OK.

  2. Klicken Sie nach dem Definieren eines Problems im Dialogfeld Solver-Parameter auf Optionen.

  3. Aktivieren Sie im Dialogfeld Solver-Optionen das Kontrollkästchen Iterationsergebnisse anzeigen, um die Werte der einzelnen Zwischenergebnisse anzuzeigen, und klicken Sie dann auf OK.

  4. Klicken Sie im Dialogfeld Solver-Parameter auf Lösen.

  5. Im Dialogfeld Zwischenergebnis anzeigen können Sie zwischen folgenden Verhaltensweisen wählen:

Zweck

Verfahren

Beenden des Lösungsprozesses und Anzeigen des Dialogfelds Solver-Ergebnisse

Klicken Sie auf Beenden.

Fortsetzen des Lösungsvorgangs und Anzeigen des nächsten Zwischenergebnisses

Klicken Sie auf Weiter.

Ändern der Weise, in der Solver Lösungen finden

  1. Klicken Sie auf der Registerkarte Daten unter Analyse auf Solver.

    Registerkarte "Daten", Gruppe "Analyse", Solver-Add-In

    Vorgehen, falls Solver auf der Registerkarte "Daten" nicht unter "Analyse" angezeigt wird

    1. Klicken Sie im Menü Extras auf Add-Ins.

    2. Aktivieren Sie in der Liste Verfügbare Add-Ins das Kontrollkästchen Solver.xlam, und klicken Sie auf OK.

  2. Klicken Sie auf Optionen, und wählen Sie dann im Dialogfeld Solver-Optionen eine oder mehrere der folgenden Optionen aus:

Zweck

Verfahren

Festlegen von Lösungszeit und Iterationen

Geben Sie auf der Registerkarte Alle Methoden unter Lösungsgrenzwerte im Feld Höchstzeit (Sekunden) die Anzahl der Sekunden ein, die Sie für die Lösungszeit zulassen möchten. Geben Sie anschließend im Feld Iterationen die maximale Anzahl Iterationen ein, die Sie zulassen möchten.

Hinweis : Wenn der Lösungsprozess die Höchstzeit oder die maximale Anzahl Iterationen erreicht, bevor Solver eine Lösung findet, zeigt Solver das Dialogfeld Zwischenergebnis anzeigen an.

Festlegen der Genauigkeit

Geben Sie auf der Registerkarte Alle Methoden im Feld Nebenbedingungsgenauigkeit das gewünschte Maß an Genauigkeit an. Je kleiner die Zahl, desto größer die Genauigkeit.

Festlegen der Konvergenz

Geben Sie auf der Registerkarte GRG-Nichtlinear oder EA (Evolutionärer Algorithmus) im Feld Konvergenz das Ausmaß der relativen Änderung, die Sie in den letzten fünf Iterationen, bevor Solver mit einer Lösung beendet wird, zulassen möchten. Je kleiner die Zahl, desto weniger relative Änderung wird zugelassen.

  1. Klicken Sie auf OK.

  2. Klicken Sie im Dialogfeld Solver-Parameter auf Lösen oder auf Schließen.

Speichern oder Laden eines Problemmodells

  1. Klicken Sie auf der Registerkarte Daten unter Analyse auf Solver.

    Registerkarte "Daten", Gruppe "Analyse", Solver-Add-In

    Vorgehen, falls Solver auf der Registerkarte "Daten" nicht unter "Analyse" angezeigt wird

    1. Klicken Sie im Menü Extras auf Add-Ins.

    2. Aktivieren Sie in der Liste Verfügbare Add-Ins das Kontrollkästchen Solver.xlam, und klicken Sie auf OK.

  2. Klicken Sie auf Laden/Speichern, geben Sie für den Modellbereich einen Zellbereich ein, und klicken Sie dann entweder auf Speichern oder auf Laden.

    Geben Sie beim Speichern eines Modells den Bezug für die erste Zelle eines vertikalen Bereichs leerer Zellen, in dem Sie das Problemmodell platzieren möchten, ein. Geben Sie beim Laden eines Modells den Bezug für den gesamten Zellbereich ein, der das Problemmodell enthält.

    Tipp : Die letzten Auswahlen im Dialogfeld Solver-Parameter können zusammen mit einem Blatt durch Speichern der Arbeitsmappe gespeichert werden. Jedes Blatt in einer Arbeitsmappe kann eigene Solver-Auswahlen aufweisen, und alle werden gespeichert. Darüber hinaus kann für ein Blatt mehrere Probleme definiert werden, indem Sie auf Laden/Speichern klicken, um Probleme einzeln zu speichern.

Festlegen der von Solver verwendeten Lösungsmethode

  1. Klicken Sie auf der Registerkarte Daten unter Analyse auf Solver.

    Registerkarte "Daten", Gruppe "Analyse", Solver-Add-In

    Vorgehen, falls Solver auf der Registerkarte "Daten" nicht unter "Analyse" angezeigt wird

    1. Klicken Sie im Menü Extras auf Add-Ins.

    2. Aktivieren Sie in der Liste Verfügbare Add-Ins das Kontrollkästchen Solver.xlam, und klicken Sie auf OK.

  2. Wählen Sie im Popupmenü Lösungsmethode auswählen eine der folgenden Optionen aus:

Lösungsmethode

Beschreibung

GRG-Nichtlinear (Generalisierter reduzierter Gradient)

Die Standardauswahl für Modelle, die die meisten Excel-Funktionen mit Ausnahme von WENN, WAHL, VERWEIS und anderen "schrittweisen" Funktionen verwenden.

Simplex-LP

Verwenden Sie diese Methode für lineare Programmierprobleme. Ihr Modell sollte SUMME, SUMMENPRODUKT, + - und * in Formeln verwenden, die von den Variablenzellen abhängen.

EA (Evolutionärer Algorithmus)

Diese Methode, die auf genetischen Algorithmen basiert, ist optimal geeignet, wenn Ihr Modell WENN, WAHL oder VERWEIS mit Argumenten verwendet, die von den Variablenzellen abhängen.

Teile des Solver-Programmcodes unterliegen dem Copyright 1990-2010 von Frontline Systems, Inc. Teile unterliegen dem Copyright 1989 von Optimal Methods, Inc.

Wenden Sie sich für weitere Informationen zu Solver

an:

Frontline Systems, Inc.

P.O. Box 4288

Incline Village, NV 89450-4288

Telefon: (775) 831-0300

E-Mail: info@solver.com

oder navigieren Sie zu Frontline Systems-Website .

Ausführlichere Hilfe zu Solver von Frontline Systems finden Sie in der Solver-Hilfe auf der Frontline Systems-Website.

Siehe auch

Erstellen einer PivotTable

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×