Bearbeiten oder Veröffentlichen einer Webdatenbank in SharePoint 2010

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Wichtig    Das Erstellen und Verwenden von Access Web Apps in SharePoint wird nicht mehr von Microsoft empfohlen. Als Alternative können Sie Microsoft PowerApps zum Erstellen codefreier Geschäftslösungen für das Web und mobile Geräte verwenden.

Mithilfe von Access Services, einer Komponente von SharePoint Server, können Sie Webdatenbanken erstellen. Dies bietet Ihnen folgende Möglichkeiten:

  • Sichern und Verwalten des Zugriffs auf Ihre Daten

  • Freigeben von Daten in einer gesamten Organisation oder über das Internet

    Hinweis : In diesem Artikel wird erläutert, Webdatenbanken – eine Art der Datenbank in Access 2010 eingeführt werden. Es wird nicht erläutert, Access Web apps die SQL Server verwenden, um Daten zu speichern und zahlreiche weitere Optimierungen über Webdatenbanken bieten. Weitere Informationen finden Sie im Artikel Erstellen einer Access-appaus.

    Hinweis :  Zum Verwenden einer Webdatenbank ist ein Benutzerkonto erforderlich. Der anonyme Zugriff wird nicht unterstützt.

  • Erstellen von Datenbankanwendungen, für deren Verwendung Access nicht erforderlich ist

Dieser Artikel bietet eine Übersicht über den Entwurf von Webdatenbanken mit Access. Eine Einführung in den Entwurf von Desktopdatenbanken finden Sie in den Artikeln Erstellen einer neuen Desktopdatenbank und Grundlagen des Datenbankentwurfs.

Wichtig :  Zwar können Sie mit dieser Version von Access eine Webdatenbank öffnen, veröffentlichen, bearbeiten und Änderungen synchronisieren, doch können Sie keine neuen Webdatenbanken erstellen.

Inhalt dieses Artikels / Was möchten Sie tun? / Ich möchte Folgendes tun

(Übersicht)

So funktioniert es

Ausführen von Formularen und Berichten im browser

Daten werden gespeichert in SharePoint-Listen

Ausführen von Abfragen und Datenmakros auf dem server

Intranet oder Internet

Bearbeiten einer Webdatenbank

Übersicht

Access Services (eine optionale Komponente von SharePoint) bietet eine Plattform zum Erstellen von Datenbanken, die Sie im Web verwenden können. Mithilfe von Access und SharePoint entwerfen und veröffentlichen Sie eine Webdatenbank, die von anderen Benutzern, die über SharePoint-Konten verfügen, in einem Webbrowser verwendet werden kann.

Funktionsweise

Wenn Sie eine Webdatenbank veröffentlichen, wird von Access Services eine SharePoint-Website erstellt, die die Datenbank enthält. Alle Datenbankobjekte und -daten werden in SharePoint-Listen dieser Website verschoben. Nach dem Veröffentlichen können SharePoint-Besucher die Datenbank entsprechend den jeweiligen Berechtigungen für die SharePoint-Website verwenden.

  • Vollzugriff    Diese Berechtigung ermöglicht Daten- und Entwurfsänderungen.

  • Mitwirken    Diese Berechtigung ermöglicht Daten-, aber keine Entwurfsänderungen.

  • Lesen    Diese Berechtigung erlaubt das Lesen von Daten, ohne diese jedoch ändern zu können.

Sie können die Webdatenbank in Access öffnen, den Entwurf überprüfen und dann Ihre Änderungen synchronisieren, was bedeutet, dass die Änderungen auf der SharePoint-Website gespeichert werden. Sie können die Webdatenbank auch offline verwenden, die Offlineversion bearbeiten und die Daten- und Entwurfsänderungen dann synchronisieren, wenn Sie wieder online sind.

Hinweis : Zum Erstellen einer Webdatenbank benötigen Sie Vollzugriff auf die SharePoint-Website, in diese veröffentlicht werden soll.

Formulare und Berichte werden im Browser ausgeführt

Formulare, Berichte und die meisten Makros werden innerhalb des Browsers ausgeführt. Dadurch kann Access Daten auf dem Bildschirm aktualisieren, ohne die gesamte Seite neu aufbauen zu müssen.

Sie können ein Formular erstellen, mit dessen Hilfe die Benutzer besser zur Ihrer Anwendung navigieren können. Das neue Navigationssteuerelement erleichtert zu diesem Zweck das Hinzufügen von standardmäßigen an das Web angepassten Navigationsschaltflächen zu einem Formular.

Hinweis : Der Navigationsbereich (der Bereich, den Sie in Access zum Durchsuchen der Objekte in einer Datenbank verwenden) steht in einem Webbrowser nicht zur Verfügung.

Daten werden in SharePoint-Listen gespeichert

Alle Ihre Tabellen werden zu SharePoint-Listen, und Datensätze werden zu Listeneinträgen. Dadurch können Sie mithilfe von SharePoint-Berechtigungen den Zugriff auf Ihre Webdatenbank steuern sowie andere SharePoint-Funktionen nutzen.

Sicherheitshinweis :  Die Verbindungszeichenfolge für verknüpfte Tabellen ist nicht verschlüsselt, dies schließt auch den Benutzernamen und das Kennwort ein, wenn diese Informationen gespeichert wurden (und das Linkziel Benutzerkonten unterstützt). In einer Datenbank, die einen Link zu einer SharePoint-Liste enthält, der den Benutzernamen und das Kennwort umfasst, könnte ein böswilliger Benutzer unter Verwendung der gespeicherten Anmeldeinformationen die als Ziel des Links angegebene Liste ändern. Selbst wenn die Anmeldeinformationen nicht mit der Verbindungszeichenfolge gespeichert wurden, könnte ein böswilliger Benutzer die Berechtigungen auf der SharePoint-Website mit Unterstützung eines anderen Benutzers ändern, der bereits über ausreichende Berechtigungen verfügt. Gehen Sie beim Freigeben von Kopien einer Datenbank, die Links zu Listen in einer veröffentlichten Webdatenbank enthält, umsichtig vor.

Abfragen und Datenmakros werden auf dem Server ausgeführt

Die gesamte SQL-Verarbeitung für Webobjekte erfolgt auf dem Server. Dadurch wird die Netzwerkleistung verbessert, da der Datenverkehr durch Zugriffe auf Resultsets begrenzt wird.

Hinweis :  Wenn die Webdatenbank "Client"-Objekte umfasst (Abfragen, Formulare, Berichte usw., die nicht in einem Browser verwendet werden können) wird die von diesen Objekten verwendete SQL von Access auf dem Desktop verarbeitet.

Intranet oder Internet

Die Veröffentlichung kann auf Ihrem eigenen Intranetserver mit SharePoint oder im Internet erfolgen. Microsoft bietet eine internetorientierte, gehostete SharePoint-Lösung und auch Drittanbieter stellen Hostingdienste bereit.

Seitenanfang

Bearbeiten einer Webdatenbank

Dieser Abschnitt enthält Schritte für die grundlegenden Entwurfsaufgaben, die Sie bei einer Webdatenbank ausführen können.

Inhalt dieses Abschnitts

Vorbemerkung

Entwerfen Sie Unterschiede zwischen Desktop- und Webdatenbanken

Reine Desktop-Features ohne Entsprechung in Datenbank

Öffnen einer Webdatenbank in Access

Erstellen einer Webtabelle

Hinzufügen eines Felds

Ändern von Feldeigenschaften

Hinzufügen eines berechneten Felds

Einrichten von Gültigkeitsregeln für Daten

Einrichten einer Feld-Gültigkeitsprüfungsregel und einer Nachricht

Einrichten einer Gültigkeitsregel und-Meldung für Datensätze

Erstellen einer Beziehung zwischen zwei Webtabellen

Erstellen eines Nachschlagefelds in der Datenblattansicht

Ändern eines Nachschlagefelds in der Datenblattansicht

Erhalten der Datenintegrität mithilfe von Datenmakros

Erstellen einer Webabfrage

Erstellen eines Webformulars

Erstellen eines Webberichts

Erstellen eines navigationsformulars, und legen Sie es als anzeigen beim Start anzuzeigendes

Festlegen des navigationsformulars als Standardanzeigeformular web

Veröffentlichen einer Webdatenbank

Synchronisieren einer Webdatenbank

Vorbemerkung

Bevor Sie mit dem Entwerfen Ihrer Webdatenbank beginnen, müssen Sie verschiedene Aufgaben ausführen. Außerdem gibt es Unterschiede beim Entwurf von Web- und Desktopdatenbanken, die Sie kennen sollten, insbesondere wenn sie ein erfahrener Access-Entwickler sind.

  • Festlegen des Verwendungszwecks der Datenbank    Legen Sie sich einen klaren Plan zurecht, damit Sie beim Ausarbeiten von Entwurfsdetails die richtigen Entscheidungen treffen.

  • Suchen und Organisieren der erforderlichen Informationen    In einer Webdatenbank können Sie keine verknüpften Tabellen verwenden. Daten, die Sie nutzen möchten und nicht ursprünglich in der Datenbank vorhanden sind, müssen vor der Veröffentlichung importiert werden. Wenn Sie Ihre Daten vor Beginn des Entwurfs richtig anordnen, können Sie Anpassungen am Entwurf aufgrund unerwarteter Datenanforderungen vermeiden.

  • Bestimmen der SharePoint-Website, auf der die Veröffentlichung erfolgen soll    Ohne SharePoint ist keine Veröffentlichung möglich. Wenn Sie Ihren Entwurf während der Ausarbeitung in einem Browser testen möchten (was keine schlechte Idee ist), müssen Sie ihn zuerst veröffentlichen.

  • Planen der Sicherheit    Zum Steuern des Zugriffs auf Ihre Webdatenbank können Sie die Sicherheitsfunktionen von SharePoint nutzen. Planen Sie Sicherheitsmaßnahmen frühzeitig, damit Sie sie in Ihren Entwurf integrieren können.

Unterschiede beim Entwerfen von Desktop- und Webdatenbanken

Verschiedene Datenbankfeatures, die Sie in einer Desktopdatenbank nutzen können, stehen in einer Webdatenbank nicht zur Verfügung. Es gibt jedoch neue Features, die viele derselben Aufgaben wie diese Desktop-Features unterstützen.

Die folgende Tabelle enthält die reinen Desktop-Features sowie das neue Feature, das zur Unterstützung derselben Aufgabe dient.

Aufgabe

Reines Desktop-Feature

-Webdatenbank Feature

Entwerfen von Datenbankobjekten

Entwurfsansicht

Verbesserte Datenblattansicht, Layout-Ansicht

Überprüfen zusammengefasster Daten, z. B. Summen, Mittelwerte und Gruppen

Gruppenfunktionen

Datenmakros, Gruppenfunktionen in Berichten

Programmieren von Ereignissen

VBA

Makros und Datenmakros, neue Makroentwurfsumgebung mit IntelliSense

Navigieren zu einem Datenbankobjekt

Navigationsbereich, Übersichten

Navigationssteuerelement oder anderes Formularelement

Hinweis : In einer Webdatenbank können Sie Clientobjekte erstellen, die aber nicht in einem Browser verwendet werden können. Diese sind jedoch Teil der Webdatenbank und können in Access auf dem Desktop verwendet werden. Benutzer können die Webdatenbank in Access öffnen und anschließend die Clientobjekte nutzen. Dies ist eine effektive Möglichkeit der Freigabe einer Datenbank und eröffnet darüber hinaus neue Möglichkeiten für die Zusammenarbeit über das Internet. SharePoint behebt auftretende Parallelitätsprobleme.

Reine Desktop-Features ohne Entsprechung in der Webdatenbank

Die folgende Liste ist nicht ausschließlich.

  • Union-Abfragen

  • Kreuztabellenabfragen

  • Sich überlappende Steuerelemente in Formularen

  • Tabellenbeziehungen

  • Bedingte Formatierung

  • Verschiedene Makroaktionen und Ausdrücke

Öffnen einer Webdatenbank in Access

Es gibt zwei Möglichkeiten zum Öffnen einer Webdatenbank: über einen Browser oder über Access.

Um über einen Browser zu öffnen.    Durchsuchen der Website für die Datenbank, und klicken Sie in der oberen linken Ecke des navigationsformulars Hauptfenster (direkt unter dem Bereich des Browser-Symbolleiste) klicken Sie auf Optionen, und klicken Sie dann auf in Access geöffnet ist.
Menü 'Optionen' auf der Website einer Webdatenbank in SharePoint

Öffnen über Access    Öffnen Sie die Datei aus, wie Sie jede Datenbankdatei öffnen – drücken Sie STRG + O und mithilfe des Dialogfelds Öffnen möchten.

Erstellen einer Webtabelle

Während die Webdatenbank in Access geöffnet ist, klicken Sie im Menüband auf Erstellen und dann in der Gruppe Tabellen auf Tabelle.

Wenn Sie erstmals eine Tabelle erstellen, enthält sie mit dem ID-Feld "AutoWert" ein Feld. Sie können neue Felder zum Speichern der Informationen hinzufügen, die für die Aufgabe der Tabelle benötigt werden. Sie können beispielsweise ein Feld hinzufügen, in dem das Datum gespeichert wird, an dem Sie mit einer Nachverfolgung beginnen.

Hinzufügen eines Felds

Sie können eine Auswahl aus einer Vielzahl vorgefertigter Felder treffen, die zur Tabelle hinzugefügt werden sollen. Dazu stehen zwei einfache Möglichkeiten zur Verfügung:

  • Klicken Sie im Menüband auf Felder, und klicken Sie dann in der Gruppe Hinzufügen und löschen auf den gewünschten Feldtyp.

  • Klicken Sie auf dem Tabellendatenblatt auf Zum Hinzufügen klicken, und wählen Sie dann einen Feldtyp aus.

Ändern von Feldeigenschaften

Das Verhalten eines Felds, z. B. die Art von Daten, die in ihm gespeichert werden können, wird durch die Formatierung und Eigenschaften bestimmt. Sie können diese Einstellungen ändern, damit sich das Feld Ihren Anforderungen entsprechend verhält.

  1. Wählen Sie das Feld mit der Formatierung und den Eigenschaften aus, die Sie ändern möchten.

  2. Klicken Sie im Menüband auf die Registerkarte Felder.

  3. Über die Befehle in den Gruppen Formatierung und Eigenschaften können Sie die Einstellungen ändern.

Hinzufügen eines berechneten Felds

Sie können ein Feld hinzufügen, das einen Wert enthält, der anhand anderer Daten in derselben Tabelle berechnet wird. Daten aus anderen Tabellen können nicht als Quelle der berechneten Daten dienen. Einige Ausdrücke werden von berechneten Feldern nicht unterstützt.

  1. Klicken Sie bei geöffneter Tabelle auf Zum Hinzufügen klicken.

  2. Zeigen Sie auf Berechnetes Feld, und klicken Sie dann auf den für das Feld gewünschten Datentyp.

    Der Ausdrucks-Generator wird geöffnet.

  3. Verwenden Sie den Ausdrucks-Generator, um die Berechnung für das Feld zu erstellen. Denken Sie daran, dass Sie andere Felder aus der gleichen Tabelle nur als Datenquellen für die Berechnung verwenden können. Hilfe zur Verwendung des Ausdrucks-Generators finden Sie im Artikel Erstellen eines Ausdrucks.

Einrichten von Gültigkeitsregeln für Daten

Bei den meisten Feldern können Sie einen Ausdruck zum Prüfen der Gültigkeit der Eingabe verwenden. Mithilfe eines Ausdrucks können Sie auch die Gültigkeit der Eingabe in eine Tabelle prüfen, was nützlich sein kann, wenn Sie die Gültigkeit der Eingabe in ein Feld prüfen möchten, das keine Gültigkeitsprüfung unterstützt, oder wenn Sie die Eingabe in ein Feld basierend auf dem Wert anderer Felder der Tabelle prüfen möchten. Eine ausführlichere Erläuterung der Gültigkeitsprüfung finden Sie im Artikel Einschränken der Dateneingabe mithilfe einer Gültigkeitsregel.

Sie können auch die Meldung angeben, die angezeigt wird, wenn eine Gültigkeitsregel eine Eingabe verhindert (die als Gültigkeitsmeldung bezeichnet wird).

Einrichten einer Gültigkeitsregel und -meldung für Felder

  1. Wählen Sie die Felder aus, denen Sie eine Gültigkeitsregel hinzufügen möchten.

  2. Klicken Sie im Menüband auf die Registerkarte Felder.

  3. Klicken Sie in der Gruppe Feldüberprüfung auf Überprüfung und dann auf Feldüberprüfungsregel.

    Der Ausdrucks-Generator wird geöffnet.

  4. Verwenden Sie den Ausdrucks-Generator, um die Gültigkeitsprüfungsregel zu erstellen. Hilfe zur Verwendung des Ausdrucks-Generators finden Sie im Artikel Erstellen eines Ausdrucks.

  5. Klicken Sie in der Gruppe Feldüberprüfung auf Überprüfung und dann auf Feldüberprüfungsmeldung.

  6. Geben Sie die Meldung ein, die angezeigt werden soll, wenn die Eingabedaten ungültig sind, und klicken Sie dann auf OK.

Einrichten einer Gültigkeitsregel und -meldung für Datensätze

Mithilfe einer Gültigkeitsregel für Datensätze können Sie duplizierte Datensätze vermeiden oder anfordern, dass eine bestimmte Kombination von Fakten zu einem Datensatz wahr ist, z. B. [Startdatum] ist größer als 01.01.2013 und kleiner als [Enddatum].

  1. Öffnen Sie die Tabelle, der Sie eine Gültigkeitsregel hinzufügen möchten.

  2. Klicken Sie im Menüband auf die Registerkarte Felder.

  3. Klicken Sie in der Gruppe Feldüberprüfung auf Überprüfung und dann auf Datensatz-Gültigkeitsprüfungsregel.

    Der Ausdrucks-Generator wird geöffnet.

  4. Verwenden Sie den Ausdrucks-Generator, um die Gültigkeitsprüfungsregel zu erstellen. Hilfe zur Verwendung des Ausdrucks-Generators finden Sie im Artikel Erstellen eines Ausdrucks.

  5. Klicken Sie in der Gruppe Feldüberprüfung auf Überprüfung und dann auf Datensatz-Gültigkeitsprüfungsmeldung.

  6. Geben Sie die Meldung ein, die angezeigt werden soll, wenn die Eingabedaten ungültig sind, und klicken Sie dann auf OK.

Erstellen einer Beziehung zwischen zwei Webtabellen

Mit Tabellenbeziehungen geben Sie an, dass zwei Tabellen über gemeinsame Daten verfügen, d. h., dass eine der Tabellen Daten aus der anderen Tabelle (und möglicherweise auch umgekehrt) verwendet. Hier ein Beispiel: Für jede Aufgabe ist ein verantwortlicher Mitarbeiter vorhanden, und dies ist in der Tabelle "Aufgaben" durch das Feld "Personal-Nr" angegeben (der Primärschlüssel der Tabelle "Mitarbeiter"). Wenn Sie sich die Daten zu einer Aufgabe ansehen, können Sie auch Daten zum verantwortlichen Mitarbeiter einbeziehen, indem Sie diese in der Tabelle "Mitarbeiter" anhand der "Personal-Nr" nachschlagen (dieser Vorgang wird von Access für Sie ausgeführt).

Beim Erstellen einer Beziehung in einer Webdatenbank erstellen Sie zuerst mit dem Nachschlage-Assistenten ein Nachschlagefeld. Dieses Feld wird der Tabelle hinzugefügt, die sich auf der ":n"-Seite der Beziehung befindet, und zeigt auf die Tabelle auf der "1:"-Seite der Beziehung.

Erstellen eines Nachschlagefelds in der Datenblattansicht

  1. Öffnen Sie die Tabelle, die sich auf der ":n"-Seite der Beziehung befinden soll (diejenige mit mehreren Datensätzen pro Schlüsselwert).

  2. Klicken Sie auf den Pfeil neben Zum Hinzufügen klicken, und klicken Sie dann auf Nachschlagen und Beziehung.

  3. Befolgen Sie die Anweisungen im Nachschlage-Assistenten zum Erstellen des Nachschlagefelds.

Ändern eines Nachschlagefelds in der Datenblattansicht

  1. Öffnen Sie die Tabelle mit dem Nachschlagefeld, das Sie ändern möchten.

  2. Führen Sie eine der folgenden Aktionen aus:

    • Klicken Sie auf der Registerkarte Felder in der Gruppe Eigenschaften auf Suchen ändern.

    • Klicken Sie mit der rechten Maustaste auf das Nachschlagefeld und dann auf Suchen ändern.

  3. Befolgen Sie die Anweisungen des Nachschlage-Assistenten.

Erhalten der Datenintegrität mithilfe von Datenmakros

Sie können mithilfe von Datenmakros Cascade aktualisieren und löschen implementieren. Können Befehle auf der Registerkarte Tabelle eingebetteten Makros zu erstellen, die Daten zu ändern.

Erstellen einer Webabfrage

Sie können eine Abfrage als Datenquelle für Formulare und Berichte verwenden. Abfragen werden auf dem Server ausgeführt, wodurch der Netzwerkdatenverkehr minimiert wird.

Angenommen, Sie verfolgen mithilfe einer Webdatenbank Spenden für wohltätige Zwecke nach. Sie möchten prüfen, wer im Verlauf einer Veranstaltung Geld gespendet hat. Mithilfe einer Abfrage können Sie Daten auswählen und diese für eine Nutzung in Formularen und Berichten vorbereiten.

Bei diesem Verfahren wird die Spendenvorlage als Beispiel verwendet. Sie können eine Nachverfolgung einleiten, indem Sie mithilfe der Datenbankvorlage für Spenden eine neue Datenbank anlegen.

  1. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Abfragen auf Abfrage.

  2. Doppelklicken Sie im Dialogfeld Tabelle anzeigen auf die Tabelle, die Sie in der Abfrage verwenden möchten, und klicken Sie dann auf Schließen.

    Doppelklicken Sie in diesem Beispiel auf Constituents, Donations, Events und EventAttendees.

  3. Erstellen Sie erforderliche Verknüpfungen, indem Sie im Abfrageentwurfsfenster Felder von einem Objekt auf ein anderes ziehen.

    Ziehen Sie in diesem Beispiel das Feld ID aus Constituents zum Feld DonorConstituentID in Donations, und ziehen Sie dann das Feld DonorConstituentID aus Donations zum Feld ConstituentID in EventAttendees.

  4. Fügen Sie die Felder hinzu, die Sie verwenden möchten. Sie können die Felder auf das Raster ziehen, oder auf ein Feld doppelklicken, um es hinzuzufügen.

    Fügen Sie in diesem Beispiel Event aus der Tabelle Events, DonationDate aus der Tabelle Donations und Greeting, FirstName und LastName aus der Tabelle Constituents hinzu.

  5. Fügen Sie alle Kriterien hinzu, die Sie verwenden möchten.

    In diesem Beispiel möchten Sie DonationDate so eingrenzen, dass das Spendendatum zwischen StartDate und EndDate der Veranstaltung liegt. Geben Sie in der Zeile Kriterien unter DonationDate Folgendes ein: >=[StartDate] Und <=[EndDate].

Erstellen eines Webformulars

Formulare stellen die wichtigste Möglichkeit zum Eingeben und Bearbeiten von Daten in einer Webdatenbank dar und eignen sich auch zum Überprüfen von Daten. Formulare werden im Browser ausgeführt, wodurch die Systemleistung optimiert wird. Beim Öffnen eines Formulars ruft der Browser die benötigten Daten vom Server mit SharePoint ab. Sie können die Daten im Formular filtern und sortieren, ohne sie nochmals vom Server abrufen zu müssen.

Tipp : Begrenzen Sie zur Optimierung der Systemleistung die Anzahl der von Ihren Hauptformularen und -berichten abgerufenen Datensätze.

  1. Wählen Sie eine Tabelle oder Abfrage als Datenquelle aus.

    Hinweis : Wenn Sie ein nicht gebundenes Formular erstellen möchten, überspringen Sie diesen Schritt.

  2. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Formulare auf eine der folgenden Schaltflächen:

    • Formular    Dient zum Erstellen eines einfachen Formulars, das immer nur einen Datensatz anzeigt, mithilfe des Objekts, das Sie als Datenquelle ausgewählt haben.

      Hinweis : Wenn Sie ein nicht gebundenes Formular erstellen, steht diese Schaltfläche nicht zur Verfügung.

    • Mehrere Elemente    Dient zum Erstellen eines Formulars, das mehrere Datensätze gleichzeitig anzeigt, mithilfe des Objekts, das Sie als Datenquelle ausgewählt haben.

      Hinweis : Wenn Sie ein nicht gebundenes Formular erstellen, steht diese Schaltfläche nicht zur Verfügung.

    • Leeres Formular    Dient zum Erstellen eines Formulars, das nichts enthält.

    • Datenblatt    Dient zum Erstellen eines Formulars, das wie ein Datenblatt aussieht und sich so verhält, mithilfe des Objekts, das Sie als Datenquelle ausgewählt haben.

      Hinweis : Wenn Sie ein nicht gebundenes Formular erstellen, steht diese Schaltfläche nicht zur Verfügung.

Erstellen eines Webberichts

Formulare stellen die wichtigste Möglichkeit zum Überprüfen und Drucken von Daten in einer Webdatenbank dar. Berichte werden im Browser ausgeführt, wodurch die Systemleistung optimiert wird. Beim Öffnen eines Berichts ruft der Browser die benötigten Daten vom Server mit SharePoint ab. Sie können die Daten im Bericht filtern und sortieren, ohne sie nochmals vom Server abrufen zu müssen.

Tipp : Begrenzen Sie zur Optimierung der Systemleistung die Anzahl der von Ihren Hauptformularen und -berichten abgerufenen Datensätze.

  1. Wählen Sie eine Tabelle oder Abfrage als Datenquelle aus.

  2. Klicken Sie auf der Registerkarte Erstellen in der Gruppe Berichte auf eine der folgenden Schaltflächen:

    • Bericht    Dient zum Erstellen eines einfachen Berichts mithilfe des Objekts, das Sie als Datenquelle ausgewählt haben.

    • Leerer Bericht    Dient zum Erstellen eines Berichts, der nichts enthält.

Erstellen eines Navigationsformulars, das als beim Start anzuzeigendes Standardformular festgelegt wird

Benutzer benötigen eine Möglichkeit zur Navigation durch Ihre Anwendung. Bedenken Sie, dass der Navigationsbereich in einem Webbrowser nicht zur Verfügung steht. Damit Benutzer Ihre Datenbankobjekte verwenden können, müssen Sie ihnen die Möglichkeit dazu bieten. Sie können ein Navigationsformular erstellen und festlegen, dass es angezeigt wird, sobald jemand Ihre Anwendung in einem Webbrowser öffnet. Wenn Sie allerdings kein Formular angeben, das beim Start der Anwendung angezeigt wird, dann wird auch kein Formular geöffnet, wodurch es anderen Benutzern erschwert wird, die Anwendung zu verwenden.

Am besten ist es, das Navigationsformular zum Schluss zu erstellen, damit Sie dem Formular bei seiner Erstellung alle gewünschten Objekte hinzufügen können.

  1. Klicken Sie im Menüband auf die Registerkarte Erstellen.

  2. Klicken Sie in der Gruppe Formular auf Navigation, und wählen Sie anschließend in der Liste ein Navigationslayout aus.

  3. Wenn Sie ein Element hinzufügen möchten, ziehen Sie es aus dem Navigationsbereich auf das Navigationssteuerelement.

    Hinweis : Einem Navigationssteuerelement können nur Formulare und Berichte hinzugefügt werden.

  4. Fügen Sie sonstige gewünschte Steuerelemente dem Hauptteil des Navigationsformulars hinzu. Sie können beispielsweise eine formularübergreifende Suchfunktion bereitstellen, indem Sie dem Navigationsformular entsprechende Steuerelemente hinzufügen.

Festlegen des Navigationsformulars als standardmäßiges Webanzeigeformular

  1. Klicken Sie auf der Registerkarte Datei unter Hilfe auf Optionen.

  2. Klicken Sie im Dialogfeld Access-Optionen auf Aktuelle Datenbank.

  3. Klicken Sie unter Anwendungsoptionenauf Webanzeigeformular, und wählen Sie in der Liste das gewünschte Formular aus.

    Sie müssen nicht Ihr Navigationsformular als Webanzeigeformular auswählen, sondern können ein beliebiges Webformular angeben.

Seitenanfang

Veröffentlichen und Synchronisieren von Änderungen an Ihrer Anwendung

Veröffentlichen einer Webdatenbank

  1. Klicken Sie auf der Registerkarte Datei auf Speichern und veröffentlichen, und doppelklicken Sie dann auf In Access Services veröffentlichen.

  2. Klicken Sie auf Kompatibilitätsprüfung ausführen
    Schaltfläche 'Kompatibilitätsprüfung ausführen' in der Backstage-Ansicht von Access  
    Mithilfe der Kompatibilitätsprüfung können Sie sicherstellen, dass die Datenbank ordnungsgemäß veröffentlicht wird. Wenn dabei Probleme erkannt werden, müssen Sie diese vor der Veröffentlichung beheben.

     Alle erkannten Probleme werden in Access in einer Tabelle namens Webkompatibilitätsprobleme gespeichert. Jede Zeile in der Tabelle enthält einen Link zu Informationen zur Problembehandlung.

  3. Füllen Sie unter In Access Services veröffentlichendie folgenden Felder aus:

    • Geben Sie im Feld Server-URL die Webadresse des SharePoint-Servers ein, auf dem die Datenbank veröffentlicht werden soll, z. B. http://Contoso/.

    • Geben Sie im Feld Websitename einen Namen für die Webdatenbank ein. Dieser Name wird an die Server-URL angefügt und bildet so die URL für die Anwendung. Wenn die Server-URL beispielsweise http://Contoso/ lautet und der Websitename "Kundendienst" ist, ergibt sich daraus die URL http://Contoso/Kundendienst.

  4. Klicken Sie noch einmal auf In Access Services veröffentlichen.

Synchronisieren einer Webdatenbank

Nachdem Sie Entwurfsänderungen vorgenommen oder eine Datenbank offline geschaltet haben, müssen Sie eine Synchronisierung durchführen. Bei einer Synchronisierung werden Unterschiede zwischen der Datenbankbank auf Ihrem Computer und der SharePoint-Website beseitigt.

  1. Öffnen Sie die Webdatenbank in Access, und nehmen Sie die gewünschten Entwurfsänderungen vor.

  2. Klicken Sie abschließend auf die Registerkarte Datei, und klicken Sie dann auf Alles synchronisieren.
    Schaltfläche 'Alles synchronisieren' in der Backstage-Ansicht von Access

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×