Aufzeichnen eines Makros

Hinweis: Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Wenn Sie einen Vorgang in Microsoft Office Project wiederholt ausführen, können Sie diesen Vorgang mit einem Makro automatisieren. Ein Makro ist eine Serie von Befehlen und Funktionen, die in einem Modul gespeichert werden und immer ausgeführt werden können, wenn Sie den Vorgang ausführen müssen.

  1. Klicken Sie auf der Registerkarte Ansicht klicken Sie auf Makros, und klicken Sie dann auf Makro aufzeichnen.

    (In Project 2007 im Menü Extras auf Makro zeigen Sie und klicken Sie dann auf Neues Makro aufzeichnen.)

  2. Geben Sie in das Feld Makroname einen Namen für das Makro ein.

    Das erste Zeichen des Makronamens muss ein Buchstabe sein. Weitere Zeichen können Buchstaben, Zahlen oder Unterstreichungszeichen sein. Leerzeichen sind in einem Makronamen nicht zulässig, jedoch kann der Unterstrich als Worttrennzeichen verwendet werden.

  3. Geben Sie einen Buchstaben oder eine Tastenkombination in das Feld Tastenkombination ein, damit das Makro durch Drücken einer Tastenkombination ausgeführt werden kann.

    Sie können STRG+Buchstabe (für Kleinbuchstaben) oder STRG+UMSCHALT+Buchstabe (für Großbuchstaben) verwenden, wobei Buchstabe eine beliebige Buchstabentaste auf der Tastatur, jedoch keine Zahl und kein Sonderzeichen ist. Sie können keine Tastenkombination verwenden, die bereits in Microsoft Office Project verwendet wird.

  4. Klicken Sie in der Liste Speichern in auf den Speicherort, an dem das Makro gespeichert werden soll:

    • Klicken Sie auf Globaldatei, um das Makro bei jeder Verwendung von Project verfügbar zu machen.

    • Klicken Sie auf Diesem Projekt, um das Makro nur für das aktuelle Projekt verfügbar zu machen.

  5. Geben Sie eine Beschreibung für das Makro in das Feld Beschreibung ein. Auf diese Weise, wird die Beschreibung mit dem Makro gespeichert.

  6. Wenn Sie beim Aufzeichnen eines Makros Zellen markieren, wird vom Makro bei jeder Ausführung dieselbe Spalte (bzw. dasselbe Feld) markiert, unabhängig davon, welche Zelle anfangs markiert wird, da das Makro absolute Bezüge für Spalten aufzeichnet. Wenn beim Ausführen des Makros Spalten unabhängig von der Position der aktiven Zelle markiert werden sollen, klicken Sie unter Spaltenbezüge auf Relativ.

    Im Gegensatz dazu werden Zeilen beim Ausführen des Makros unabhängig von der Position der aktiven Zelle markiert, weil das Makro relative Bezüge für Zeilen aufzeichnet. Wenn ein Makro immer dieselbe Zeile markieren soll, unabhängig davon, welche Zelle anfangs markiert wird, klicken Sie unter Zeilenbezüge auf Absolut (Nr.).

    Hinweis: Diese Einstellungen werden von Project weiter beim Aufzeichnen von Makros verwendet, bis Sie die Einstellungen ändern oder Project schließen.

  7. Klicken Sie auf OK, und führen Sie dann die Aktionen aus, die Sie aufzeichnen möchten.

  8. Klicken Sie auf Makros, wenn Sie alle Aktionen abgeschlossen haben, die Sie auf der Registerkarte Ansicht aufzeichnen möchten, und klicken Sie dann auf Aufzeichnung beenden.

    (In Project 2007 im Menü Extras auf Makro zeigen Sie und klicken Sie dann auf Aufzeichnung beenden.)

Sicherheitshinweis: Da Makros Viren enthalten können, sollten Sie bei ihrer Ausführung Vorsicht walten lassen. Ergreifen Sie die folgenden Vorsichtsmaßnahmen: Führen Sie Antivirensoftware auf Ihrem Computer aus, die auf dem neuesten Stand ist, legen Sie die Makrosicherheitsstufe auf "Hoch" fest, deaktivieren Sie das Kontrollkästchen Allen installierten Add-Ins und Vorlagen vertrauen, verwenden Sie digitale Signaturen, und verwalten Sie eine Liste der vertrauenswürdigen Herausgeber.

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×