Aktualisieren von Power Pivot-Datenmodellen auf Excel 2013 oder Excel 2016

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

"Diese Arbeitsmappe hat ein Power Pivot-Datenmodell, das mit einer früheren Version des Power Pivot-Add-Ins erstellt wurde. Sie müssen mit Power Pivot in Microsoft Excel 2013 für Excel 2013 ein Upgrade dieses Datenmodells durchführen."

Sehen Sie sich vertraut? Dies bedeutet Sie eine Excel 2010-Arbeitsmappe in Excel 2013 oder höher geöffnet, und die Arbeitsmappe enthält eine eingebettete Power Pivot Datenmodell mithilfe einer früheren Version des Power Pivot-add-Ins erstellt. Sie möglicherweise diese Meldung angezeigt, wenn Sie, die in einer Excel 2010-Arbeitsmappe ein Power View-Blatt einfügen versuchen .

In Excel 2013 oder Excel 2016 ist das Datenmodell Bestandteil der Arbeitsmappe. Mit dieser Nachricht können Sie wissen, dass das Datenmodell eingebettete Power Pivot aktualisieren, bevor Sie unterteilen können, Ausführen von Drilldowns oder und Filtern der Daten in Excel 2013 oder Excel 2016.

  1. Vor dem Durchführen eines Upgrades sollten Sie prüfen, welche bekannten Fehler Probleme beim Upgrade verursachen können.

  2. Speichern Sie eine Kopie der Datei jetzt für den Fall, dass Sie die vorherige Version später benötigen. Nach der Aktualisierung funktioniert die Arbeitsmappe in Excel 2013 oder höher nur. Weitere Informationen: Was ist in einem per Upgrade aktualisierten Modell anders.

  3. Starten Sie Power Pivot in Microsoft Excel-add-ins.

  4. Klicken Sie auf Power Pivot > Verwalten, um mit dem Upgrade zu beginnen.

    Schaltfläche 'Verwalten' im Menüband 'Power Pivot'

  5. Bestätigen Sie die Upgradebenachrichtigung.

    Die Meldung lautet "Diese Arbeitsmappe hat ein Power Pivot-Datenmodell, das mit einer früheren Version des Power Pivot-Add-Ins erstellt wurde. Sie müssen mit Power Pivot in Microsoft Excel 2013 ein Upgrade dieses Datenmodells durchführen."

    Klicken Sie auf OK , um die Meldung zu schließen.

  6. Führen Sie das Upgrade des Datenmodells durch. Nach dem Upgrade können Sie die Arbeitsmappe nicht mehr in der früheren Version von Power Pivot bearbeiten.

    Die Meldung beginnt mit: "Sie versuchen, eine Arbeitsmappe zu öffnen, die in einer früheren Power Pivot-Version erstellt wurde." Sie endet mit: "Möchten Sie die Arbeitsmappe aktualisieren?"

    Klicken Sie auf OK, damit die Arbeitsmappe aktualisiert wird.

  7. Speichern Sie die Arbeitsmappe, und laden Sie sie erneut. Durch diesen Schritt werden die Änderungen übernommen, die während des Upgrades vorgenommen wurden. Sobald Sie die Arbeitsmappe gespeichert haben, ist ein Rückgängigmachen nicht mehr möglich. Das erneute Laden sollte, je nach Größe und Speicherort der Arbeitsmappe, nur einige Sekunden dauern.

    Die Meldung beginnt mit: „Das Arbeitsmappenupgrade wurde erfolgreich abgeschlossen, Excel ist aber weiterhin im Kompatibilitätsmodus.“

    Klicken Sie auf Ja, um die Arbeitsmappe neu zu laden.

Jetzt ist Aktualisierung abgeschlossen. Wenn Sie andere Nachrichten während des Upgrades eingerichtet, Upgrade möglicherweise fehlgeschlagen ist, oder teilweise Erfolg erfüllt. In einigen Fällen müssen Manuelle Änderungen an der Arbeitsmappe oder das Datenmodell vornehmen Sie ein upgrade vollständig auf Excel 2013 oder Excel 2016. In den folgenden Abschnitten in diesem Artikel, um weitere Informationen zu lesen.

Inhalt dieses Artikels

Bekannte Probleme

Verknüpfte Tabellen, die keiner Quelltabelle in Excel mehr zugeordnet sind, müssen entfernt oder neu erstellt werden

Drillthroughabfragetabellen müssen entfernt werden

Kennwortschutz muss entfernt werden

Eingeschränkter Zugriff muss entfernt werden

Bestimmte Spalten eines Modells sind in einer Upgrademeldung angegeben

Eine Datenquellenverbindung in einer aktualisierten Arbeitsmappe kann nicht aktualisiert werden

Problem

Lösung

Abschließen eines teilweisen Upgrades

KPI-Bilder fehlen

Upgradefehler für DAX-Berechnung: Ein Upgrade dieser Arbeitsmappe konnte nicht ordnungsgemäß …

PivotTable-Funktionen, in denen auf "Power Pivot-Daten" verwiesen wird, sind nicht mehr zulässig

Datenlöschung: Wann beim Durchführen eines Upgrades Daten aus einem Modell gelöscht werden

Upgrade war erfolgreich, die verknüpfte Tabelle ist aber verschwunden

Das ist in einem per Upgrade aktualisierten Modell anders

Datenschnitte und Spaltenbeschreibungen werden in der Feldliste nicht mehr angezeigt

Auf Excel 2013 aktualisierte Arbeitsmappen funktionieren nicht in einer früheren Version von Excel und Power Pivot

Bekannte Probleme

Verknüpfte Tabellen, die keiner Quelltabelle in Excel mehr zugeordnet sind, müssen entfernt oder neu erstellt werden

Veraltete oder verwaiste Tabellen werden nicht mit den anderen Teilen des Modells aktualisiert, wodurch eine Datenlöschung erfolgt oder nicht verwendbare Daten entstehen. Sie können dieses Problem vermeiden, indem Sie sich vergewissern, dass vorhandene verknüpfte Tabellen einer in Excel vorhandenen Quelltabelle zugeordnet sind.

  1. Klicken Sie in Power Pivot für Excel 2010 auf eine verknüpfte Tabelle im Power Pivot-Fenster.

    Symbol für eine verknüpfte Tabelle

  2. Klicken Sie im Menüband auf Verknüpfte Tabelle.

    Registerkarte 'Verknüpfte Tabelle' auf der eine Excel-Tabelle angegeben ist

  3. Vergewissern Sie sich, dass in Excel-Tabelle eine vorhandene Tabelle angegeben ist. Wenn die Tabelle in Excel umbenannt wurde, klicken Sie auf den nach unten zeigenden Pfeil in Excel-Tabelle, und wählen Sie die umbenannte Tabelle aus.

  4. Klicken Sie auf Gehe zu Excel-Tabelle, um sich zu vergewissern, dass die verknüpfte Tabelle eine Quelldatentabelle in Excel ist.

  5. Wenn Excel-Tabelle leer ist, führen Sie einen der folgenden Schritte aus:

Sofern nicht das folgende Problem ebenfalls zutrifft, können Sie das Upgrade der Arbeitsmappe jetzt durchführen.

Drillthroughabfragetabellen müssen entfernt werden

Ein weiteres Upgradeproblem trifft nur für Power Pivot-Datenmodelle zu, die auf Analysis Services-Cubes basieren, die Drillthroughaktionen unterstützen. Wenn eine Arbeitsmappe Drillthroughabfragetabellen enthält, scheint es zunächst, als sei das Upgrade erfolgreich durchgeführt worden, aber danach wird jedes Mal, wenn Sie auf ein Feld in einer PivotTable klicken, ein Upgradefehler zurückgegeben.

  1. Suchen Sie in Power Pivot für Excel 2010 nach allen Drillthroughabfragetabellen in der Arbeitsmappe.

    Eine Drillthroughabfragetabelle wird in einer Arbeitsmappe erstellt, wenn Sie mit der rechten Maustaste auf ein Measure klicken und Details anzeigen auswählen. Die sich daraus ergebende Tabelle wird in der Arbeitsmappe als gesondertes Arbeitsblatt angezeigt. Die erste Zeile beginnt mit „Zurückgegebene Daten für …“

    Drillthroughabfragetabelle

  2. Löschen Sie jedes Blatt, das Drillthroughabfragetabellen enthält. Nach der Durchführung des Upgrades können Sie diese neu erstellen.

  3. Speichern Sie die Arbeitsmappe.

  4. Führen Sie das Upgrade der Arbeitsmappe durch.

  5. Erstellen Sie die Drillthroughabfragetabellen neu, wenn Sie diese benötigen. Klicken Sie mit der rechten Maustaste auf ein berechnetes Feld in einer PivotTable, und klicken Sie auf Details anzeigen. Es wird eine Drillthroughabfragetabelle auf einem gesonderten Arbeitsblatt erstellt.

Kennwortschutz muss entfernt werden

Bei einer kennwortgeschützten Arbeitsmappe, die auch ein Datenmodell enthält, tritt bei einem Upgrade folgender Fehler auf:

„Für das Datenmodell in dieser Arbeitsmappe kann kein Upgrade durchgeführt werden.“

Sie können dieses Problem vermeiden, indem Sie das Kennwort vor dem Durchführen des Upgrades entfernen.

  1. Öffnen Sie die Arbeitsmappe in Excel 2013 oder Excel 2016.

  2. Klicken Sie auf Datei > Informationen > Arbeitsmappe schützen >Mit Kennwort verschlüsseln.

  3. Löschen Sie die Sternchen, und klicken Sie dann auf OK.

  4. Speichern Sie die Arbeitsmappe.

  5. Klicken Sie auf Power Pivot > Verwalten, um erneut mit dem Upgrade zu beginnen.

  6. Fügen Sie der Arbeitsmappe den Kennwortschutz wieder hinzu.

Eingeschränkter Zugriff muss entfernt werden

Bei einem Arbeitsmappendatenmodell, das hinsichtlich Drucken, Bearbeiten oder Kopieren eingeschränkt ist, tritt bei einem Upgrade folgender Fehler auf:

„Für das Datenmodell in dieser Arbeitsmappe kann kein Upgrade durchgeführt werden.“

Sie können dieses Problem vermeiden, indem Sie die Einschränkungen vor dem Durchführen des Upgrades entfernen.

  1. Öffnen Sie die Arbeitsmappe in Excel 2013 oder Excel 2016.

  2. Klicken Sie auf Datei > Informationen > Arbeitsmappe schützen >Zugriff einschränken.

  3. Aktivieren Sie Unbeschränkter Zugriff, damit die Einschränkungen entfernt werden.

  4. Speichern Sie die Arbeitsmappe in Excel ein.

  5. Klicken Sie auf Power Pivot > Verwalten, um erneut mit dem Upgrade zu beginnen.

  6. Fügen Sie der Arbeitsmappe die Zugriffseinschränkungen wieder hinzu.

Bestimmte Spalten eines Modells sind in einer Upgrademeldung angegeben

Wenn bei einem Upgrade Fehler auftreten und in der Fehlermeldung die Felder aufgeführt sind, die das Problem verursachen, gehen Sie wie folgt vor:

  1. In Excel 2013 oder Excel 2016, navigieren Sie zu der PivotTable oder den Bericht, die die Felder enthält, die aktualisiert werden beim Probleme verursachen.

  2. Entfernen Sie die Felder aus der PivotTable oder dem Bericht. Die Felder werden weiterhin in der Feldliste aufgeführt, sie erscheinen nur nicht mehr im Bericht.

  3. Speichern und schließen Sie die Arbeitsmappe.

  4. Öffnen Sie die Arbeitsmappe erneut.

  5. Klicken Sie auf Power Pivot > Verwalten, um erneut mit dem Upgrade zu beginnen.

  6. Wurde das Upgrade erfolgreich durchgeführt, fügen Sie die Felder wieder in die PivotTable oder den Bericht ein.

Eine Datenquellenverbindung in einer aktualisierten Arbeitsmappe kann nicht aktualisiert werden

Sie haben eine Arbeitsmappe in Excel 2010 mit eine Verbindung mit einer externen Datenquelle erstellt. Öffnen Sie die Arbeitsmappe in Excel 2013 oder Excel 2016. Wenn Sie versuchen, eine PivotTable in der Arbeitsmappe ändern, wird eine Meldung, dass Sie die PivotTable aktualisieren müssen. Sie versuchen, die aktualisiert, aber diese Meldung wird angezeigt:

"Excel war nicht in der Lage die notwendigen Informationen für diesen Cube zu erhalten. Dieser Cube wurde evtl. im Server umorganisiert oder verändert. Kontaktieren Sie Ihren OLAP-Cubeadministrator. Falls erforderlich, erstellen Sie eine neue Datenquelle um eine Verbindung zum Cube herzustellen."

Wenn Sie versuchen, die vorhandene Verbindung zu bearbeiten, können Sie den Namen des Datenmodells sehen, können die Datenquelle aber nicht ändern.

Problem

Die Verbindung zur Datenquelle ist nicht mehr gültig und müssen Sie aktualisiert, aber nicht in Excel 2013 oder Excel 2016 aktualisieren.

Lösung

  1. Öffnen Sie die Arbeitsmappe in Excel 2010 mit dem Power Pivot-Add-In.

  2. Klicken Sie auf der Registerkarte Power Pivot in der Gruppe "Datenmodell" auf Verwalten, um das Power Pivot-Fenster zu öffnen.

  3. Klicken Sie im Power Pivot-Fenster auf Home > Externe Daten abrufen > Vorhandene Verbindungen.

  4. Wählen Sie die aktuelle Datenbankverbindung aus, und klicken Sie auf Bearbeiten.

  5. Klicken Sie im Dialogfeld Verbindung bearbeiten auf Durchsuchen, um nach einer anderen Datenbank zu suchen, die denselben Typ, aber einen anderen Namen oder Speicherort hat.

  6. Speichern und schließen Sie die Arbeitsmappe.

  7. Öffnen Sie die Arbeitsmappe in Excel 2013 oder Excel 2016.

Seitenanfang

Abschließen eines teilweisen Upgrades

In den meisten Fällen wird ein Arbeitsmappenupgrade problemlos durchgeführt, gelegentlich sind aber weitere Änderungen erforderlich, um diese Aufgabe abzuschließen. In diesem Abschnitt erfahren Sie, wie Sie auf bestimmte Fehler reagieren können, die ein teilweises oder unvollständiges Upgrade kennzeichnen. Die Arbeitsmappe ist dann zwar aktualisiert, ihr fehlt aber bestimmte Funktionalität.

KPI-Bilder fehlen

Wenn KPI-Bilder (farbige oder Grafiksymbole) fehlen, entfernen Sie den Key Performance Indicator (KPI) aus dem Werte-Bereich der Feldliste, und fügen Sie ihn dann wieder hinzu.

Upgradefehler für DAX-Berechnung: Ein Upgrade dieser Arbeitsmappe konnte nicht ordnungsgemäß …

Einige DAX-Berechnungen erfordern manuelle Änderungen, damit die Arbeitsmappe nutzbar ist. Wenn DAX-Ausdrücke oder -Abfragen nicht mit Excel 2013 kompatibel sind, wird die Arbeitsmappe nur teilweise aktualisiert. Es wird dann folgende Meldung angezeigt:

„Ein Upgrade dieser Arbeitsmappe konnte nicht ordnungsgemäß ausgeführt werden. Das Speichern könnte dazu führen, dass einige Ihrer Excel-Datenfeatures nicht mehr funktionieren. Weitere Details finden Sie hier: http://go.microsoft.com/fwlink/?LinkId=259419.

Wir haben folgenden Fehler erhalten: Es können keine internen Unterstützungsstrukturen für die Spalte '%{table/}'[%{column/}] abgefragt werden, weil sie von einer Spalte, Beziehung oder einem Measure abhängig sind, die bzw. das nicht verarbeitet wurde. Aktualisieren oder berechnen Sie das Modell neu.“

Wenn dieser Fehler angezeigt wird (und dies kann mehrmals passieren), sollten Sie sich die aufgeführten Tabellen und Spalten notieren, damit Sie direkt zu den betroffenen Tabellen navigieren können. Sie müssen jeden DAX-Ausdruck bearbeiten:

Hinweis : Wenn Sie aufgefordert werden, Power Pivot das Speichern, Schließen und erneute Öffnen der Arbeitsmappe zu gestatten, klicken Sie auf Ja.

  1. Öffnen Sie im Power Pivot-Fenster die Tabelle, die in der Meldung angegeben ist.

  2. Klicken Sie auf die Spalte, die ein Fehlersymbol und #FEHLER-Werte enthält. In der Bearbeitungsleiste sollte ein DAX-Ausdruck angezeigt werden.

  3. Suchen Sie nach den folgenden bekannten DAX-Kompatibilitätsproblemen:

    NULL-Werte, die als doppelte Anführungszeichen ohne Werte ("") angegeben sind, sind nicht mehr zulässig. Ersetzen Sie jedes Anführungszeichenpaar durch eine Null (0).

    In LOOKUPVALUE, CONTAINS oder SWITCH wurde versucht, nicht kompatible Werttypen zu vergleichen. Möglicherweise müssen Sie im Argument einen [Typ] angeben, oder Sie müssen sicherstellen, dass beide Werte denselben Typ haben: numerischer, Zeichenfolge- oder Boolean-Datentyp. Wenn Sie einen der Werte konvertieren müssen, können Sie die Funktion VALUE oder FORMAT verwenden.

Möglicherweise treten in Excel weitere Fehler auf, während Sie DAX-Ausdrücke korrigieren. Wenn Sie eine Formel nicht bearbeiten können, wechseln Sie zu Excel, um zu ermitteln, ob ein Fehler weitere Aktionen blockiert. Klicken Sie auf OK, um den Fehler zu schließen, und kehren Sie zu Power Pivot zurück, um Ihre Arbeit dort fortzusetzen.

Nachdem Sie die DAX-Berechnungen korrigiert haben und keine weiteren Fehlermeldungen mehr angezeigt werden, ist die Arbeitsmappe als vollständig aktualisiert anzusehen.

PivotTable-Funktionen, in denen auf "Power Pivot-Daten" verwiesen wird, sind nicht mehr zulässig

Excel-Cubefunktionen, in denen eine Verbindung mit dem Power Pivot-Modell aus der vorherigen Version angegeben ist, müssen manuell auf den neuen Modellnamen "ThisWorkbookDataModel" aktualisiert werden.

Vorherige Version

Excel 2013

=CUBEWERT("Power Pivot-Daten";[Measures].[TotalSales])

=CUBEWERT("ThisWorkbookDataModel";[Measures].[TotalSales])

  1. Klicken Sie in Excel auf jedem Arbeitsblatt auf Formeln > Formeln anzeigen, damit die Berechnungen angezeigt werden, die auf jedem Blatt verwendet werden.

  2. Suchen Sie in Excel-Cubefunktionen, in denen eine Verbindung angegeben ist, nach "Power Pivot-Daten".

  3. Ersetzen Sie "Power Pivot-Daten" durch "ThisWorkbookDataModel".

  4. Speichern Sie die Arbeitsmappe.

Seitenanfang

Datenlöschung: Wann beim Durchführen eines Upgrades Daten aus einem Modell gelöscht werden

„Upgrade konnte die folgenden verknüpften Tabellen <Tabellennamen> nicht aktualisieren. Diese Tabellen wurden aus dem Modell entfernt.”

In Sonderfällen werden bei einem Upgrade Daten aus einem Modell gelöscht. Ein solches Löschen von Daten tritt auf, wenn ein Modell eine verwaiste verknüpfte Tabelle umfasst, die nicht zu einer zugeordneten Tabelle verfolgt werden kann, weil die Quelltabelle gelöscht oder umbenannt wurde.

Upgrade war erfolgreich, die verknüpfte Tabelle ist aber verschwunden

Eine verknüpfte Tabelle ist eine Tabelle, die Sie in einer Arbeitsmappe erstellen und dann einem Datenmodell hinzufügen, sodass Sie sie mit anderen Tabellen in Beziehung bringen und DAX-Berechnungen hinzufügen können. Bei einem Upgrade wird eine verknüpfte Tabelle gelöscht, wenn die Quelltabelle nicht mehr in der Arbeitsmappe vorhanden ist.

Dies ist das Szenario: Sie haben eine Tabelle in Excel erstellt oder importiert, diese als verknüpfte Tabelle in Power Pivot hinzugefügt, wo die Tabelle Bestandteil des Datenmodells geworden ist, und dann die Originaltabelle gelöscht, auf der sie basierte. Das Modell beinhaltet weiterhin die verknüpfte Tabelle, obwohl es die Tabelle in Excel nicht mehr gibt.

Wenn Sie später versuchen, die Arbeitsmappe nach Excel 2013 zu aktualisieren, tritt der folgende Fehler auf.

„Upgrade konnte die folgenden verknüpften Tabellen <Tabellennamen> nicht aktualisieren. Diese Tabellen wurden aus dem Modell entfernt.”

Wenn dies möglich ist, brechen Sie das Upgrade ab, sodass Sie das Modell ändern oder für den Fall, dass Sie später auf die Tabelle verweisen möchten, eine Sicherung erstellen können:

  1. Klicken Sie auf OK, damit die Meldung "Beim Upgrade konnten die folgenden verknüpften Tabellen nicht aktualisiert werden" geschlossen wird.

  2. Wenn Sie gefragt werden, ob die Arbeitsmappe gespeichert, geschlossen und erneut geöffnet werden soll, klicken Sie auf Nein.

  3. Schließen Sie die Datei in Excel 2013, ohne sie zu speichern.

  4. Öffnen Sie die Arbeitsmappe in Excel 2010, und beheben Sie die Probleme mit verknüpften Tabellen:

    1. Eine verknüpfte Tabelle wird nicht mehr benötigt? Löschen Sie die Tabelle aus dem Modell, oder starten Sie erneut eine Upgradedurchführung in Excel 2013, und lassen Sie zu, dass die Tabelle dabei entfernt wird.

    2. Eine Excel-Tabelle wurde umbenannt, die verknüpfte Tabelle aber nicht? Aktualisieren Sie die Verbindungsinformationen in Power Pivot so, wie es in Schritt 1 oben auf dieser Seite beschrieben ist.

    3. Eine verknüpfte Tabelle muss vorhanden sein, weil sie in Berechnungen oder in einer PivotTable verwendet wird, aber die ursprüngliche Excel-Tabelle fehlt? Erstellen Sie die Quelltabelle in Excel neu, und aktualisieren Sie die Verknüpfung:

      • Kopieren Sie die Zeilen aus der verknüpften Tabelle im Power Pivot-Fenster.

      • Fügen Sie die Zeilen in ein Arbeitsblatt in Excel ein.

      • Formatieren Sie die Zeilen als Tabelle.

      • Benennen Sie die Tabelle.

      • Kehren Sie zum Power Pivot-Fenster zurück.

      • Klicken Sie auf Verknüpfte Tabelle > Excel-Tabelle, und markieren Sie dann die Tabelle, die Sie soeben erstellt haben.

      • Speichern Sie die Datei.

  5. Nachdem Sie die Korrekturen vorgenommen haben, öffnen Sie die Datei in Excel 2013.

  6. Starten Sie das Upgrade erneut, indem Sie auf Power Pivot > Verwalten klicken.

Wenn Sie die Arbeitsmappe bereits gespeichert haben, können Sie sie nicht in der vorherigen Version wiederherstellen. Sie müssen die verknüpfte Tabelle vollständig neu erstellen. Weitere Informationen hierzu finden Sie unter: Hinzufügen von Arbeitsblattdaten zu einem Datenmodell mithilfe einer verknüpften Tabelle.

Seitenanfang

Das ist in einem per Upgrade aktualisierten Modell anders

In den meisten Fällen ist eine aktualisierte Arbeitsmappe mit ihrer Vorgängerversion identisch. Es gibt aber einige Änderungen in der neueren Version, die angesprochen werden sollten.

Datenschnitte und Spaltenbeschreibungen werden in der Feldliste nicht mehr angezeigt

In früheren Versionen angezeigt einer PivotTable-Feldliste eine Spalte oder ein Feld Beschreibung als QuickInfo an. In Excel 2013 oder höher, wird die Feldliste QuickInfos nicht unterstützt. Alle spaltenbeschreibungen, die in dem Modell vorhanden sind, werden in datenvisualisierungen in Excel ignoriert.

Datenschnitte werden unterstützt, aber Sie jetzt erstellen sie eine andere Möglichkeit probiert. Die Feldliste bietet keine Optionen zum Erstellen eines Datenschnitts.

Auf Excel 2013 aktualisierte Arbeitsmappen funktionieren nicht in einer früheren Version von Excel und Power Pivot

Vor Excel 2013 gab es zwei frühere Versionen des Power Pivot-Add-Ins. Beide Versionen funktionieren ausschließlich mit Excel 2010. Diese Versionen sind:

  • SQL Server 2008 R2 Power Pivot für Excel

  • SQL Server 2012 Power Pivot für Excel 2010

Nachdem Sie ein Datenmodell in Excel 2013 oder Excel 2016 aktualisiert haben, können Sie öffnen Sie die Arbeitsmappe, aber nicht interagieren oder bearbeiten, die Modell basierenden Pivot-Berichten in Excel 2010. Beim Öffnen einer Excel 2013 oder Excel 2016 Arbeitsmappen-Datenmodell in Excel 2010, wird der folgende Fehler angezeigt werden, wenn klicken Sie auf einen Slicer, ziehen Sie ein neues Feld in der PivotTable oder ändern ein Filters:

„Fehler bei der Initialisierung der Datenquelle.“

Dieser Fehler ergibt sich, weil eine Dateninteraktion wie Klicken auf einen Datenschnitt eine Abfrage generiert, die an das Datenmodell gesendet wird (das Modell ist die Datenquelle der PivotTable). Weil das Datenmodell in Excel 2010 nicht gültig ist, wird anstelle der Dateninteraktion ein Initialisierungsfehler der Datenquelle ausgelöst.

Nehmen Sie an, Sie versuchen nun, das Datenmodell in einem Power Pivot-Fenster zu öffnen. Das Modell wird nicht geöffnet, und es wird folgende Fehlermeldung angezeigt:

"Diese Arbeitsmappe enthält ein Excel-Datenmodell, das mit einer neueren Excel-Version erstellt wurde. Sie können diese Arbeitsmappe in einer älteren Excel-Version öffnen, sind jedoch nicht in der Lage, einen Power Pivot-Lade- oder -Bearbeitungsvorgang vorzunehmen, wenn das Power Pivot-Modell parallel zu einem Excel-Datenmodell existiert."

Es ist keine problemumgehung; Upgrade ist nur für weiterleiten. Aktivieren Sie vor dem Upgrade mit Kollegen, um sicherzustellen, dass Sie alle auf Excel 2013 gleichzeitig aktualisieren. Darüber hinaus sollten Sie auch vorübergehend separate Versionen für Ihre Arbeitsmappen beibehalten, wenn die Organisation mit Excel 2010 und Excel 2013 oder Excel 2016 nebeneinander.

Weitere Informationen: Power Pivot Version Compatibility (nur in englischer Sprache auf dem TechNet-WIKI)

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×