Aktualisieren von Daten in einer PivotTable

Sie können jederzeit auf Aktualisieren klicken, um die Daten für die PivotTables in Ihrer Arbeitsmappe zu aktualisieren. Sie können die Daten für PivotTables aktualisieren, die mit externen Daten verbunden sind, die beispielsweise in einer Datenbank (SQL Server, Oracle, Access usw.), in einem Analysis Services-Cube, in einem Datenfeed oder in vielen andere Quellen enthalten sind. Sie können auch Daten aus einer Quelltabelle aktualisieren, die sich in derselben oder in einer anderen Arbeitsmappe befindet. Und Sie können eine Arbeitsmappe so einstellen, dass in ihr enthaltene PivotTable-Daten automatisch aktualisiert werden, wenn Sie die Mappe öffnen.

Weitere Informationen zum Aktualisieren von verschiedenen Arten externer Daten finden Sie in den folgenden Artikeln:

Manuelles Aktualisieren

Gehen Sie wie folgt vor, um Ihre PivotTable oder PivotTables manuell zu aktualisieren:

  1. Klicken Sie auf eine beliebige Stelle in der PivotTable, damit die PivotTable-Tools im Menüband angezeigt werden.

PivotTable-Tools

  1. Klicken Sie auf Analysieren > Aktualisieren, oder drücken Sie ALT+F5.

Schaltfläche 'Aktualisieren' auf der Registerkarte 'Analysieren'

Tipp :  Wenn Sie alle PivotTables in einer Arbeitsmappe gleichzeitig aktualisieren möchten, klicken Sie auf Analysieren > Pfeil unter Aktualisieren > Alle aktualisieren.

  1. Dauert das Aktualisieren länger als Sie erwartet haben, klicken Sie auf Analysieren > Pfeil unter Aktualisieren > Status aktualisieren, um den Aktualisierungsstatus zu überprüfen.

Wenn Sie das Aktualisieren beenden möchten, Klicken Sie auf Aktualisierung abbrechen.

Verhindern, dass Spaltenbreiten und Zellenformatierung angepasst werden

Werden die Spaltenbreiten und die Zellenformatierung angepasst, wenn Sie die PivotTable-Daten aktualisieren, diese Anpassung von Ihnen aber nicht gewünscht ist, müssen Sie die folgenden Optionen deaktivieren:

  1. Klicken Sie auf Analysieren > Optionen.

Schaltfläche 'Optionen' auf der Registerkarte 'Analysieren'

  1. Deaktivieren Sie auf der Registerkarte Layout & Format die Kontrollkästchen Spaltenbreiten bei Aktualisierung automatisch anpassen und Zellformatierung bei Aktualisierung beibehalten.

Automatisches Aktualisieren von Daten, wenn die Arbeitsmappe geöffnet wird

Gehen Sie wie folgt vor, wenn Sie festlegen möchten, dass PivotTable-Daten beim Öffnen der Arbeitsmappe automatisch aktualisiert werden:

  1. Klicken Sie auf eine beliebige Stelle in der PivotTable, damit die PivotTable-Tools im Menüband angezeigt werden.

PivotTable-Tools

  1. Klicken Sie auf Analysieren > Optionen.

Schaltfläche 'Optionen' auf der Registerkarte 'Analysieren'

  1. Aktivieren Sie im Dialogfeld PivotTable-Optionen auf der Registerkarte Daten das Kontrollkästchen Aktualisieren beim Öffnen der Datei.

Weitere Informationen zu PivotTables

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×