Aktualisieren verbundener (importierter) Daten

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Ein Zellbereich, eine Excel-Tabelle, ein PivotTable-Bericht, ein PivotChart-Bericht, eine Textdatei und eine Webabfrage können mit einer externen Datenquelle verbunden werden. Sie können die Daten aktualisieren, um die Daten dieser externen Datenquellen zu aktualisieren. Bei jeder Aktualisierung der Daten wird die aktuelle Version der Informationen in der Datenquelle angezeigt, einschließlich der an den Daten vorgenommenen Änderungen.

Sicherheitshinweis : Verbindungen zu externen Daten sind auf Ihrem Computer zurzeit möglicherweise deaktiviert. Wenn beim Öffnen einer Arbeitsmappe die Daten aktualisiert werden sollen, müssen Sie die Datenverbindungen mithilfe der Vertrauensstellungscenter-Leiste aktivieren oder die Arbeitsmappe an einem vertrauenswürdigen Speicherort speichern.

Weitere Informationen finden Sie unter Hinzufügen, entfernen oder Ändern eines vertrauenswürdigen Speicherorts für Ihre Dateien, Hinzufügen, entfernen oder Anzeigen eines vertrauenswürdigen Herausgebersund Anzeigen meiner Optionen und Einstellungen im Trust Center.

Was möchten Sie tun?

Aktualisieren von Daten aus einer Microsoft Query, dem Datenverbindungs-Assistenten oder Web-Abfrage

Aktualisieren von Daten aus einer importierten Textdatei

Aktualisieren von Offlinecubedateien

Aktualisieren von Daten in einer importierten XML-Datei

Automatisches Aktualisieren von Daten beim Öffnen einer Arbeitsmappe

Automatisches Aktualisieren von Daten in regelmäßigen Abständen

Festlegen eines Kennworts für die Aktualisierung eines externen Datenbereichs

Führen Sie eine Abfrage im Hintergrund oder im aktiven Programm

Überprüfen des Status eines Aktualisierungsvorgangs oder Abbrechen einer Aktualisierung

Aktualisieren von Daten aus Microsoft Query, dem Datenverbindungs-Assistenten oder einer Webabfrage

Führen Sie eine der folgenden Aktionen aus:

  • Zum Aktualisieren einer bestimmten Datenverbindung in der Arbeitsmappe klicken Sie auf eine Zelle im externen Datenbereich. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf den Pfeil neben Alle aktualisieren, und klicken Sie dann auf Aktualisieren.

  • Um alle Datenverbindungen in der Arbeitsmappe zu aktualisieren, klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Alle aktualisieren.

Hinweis : Falls mehrere Arbeitsmappen geöffnet sind, müssen Sie diesen Vorgang in jeder Arbeitsmappe wiederholen.

Seitenanfang

Aktualisieren von Daten aus einer importierten Textdatei

  1. Markieren Sie das Arbeitsblatt, das die importierte Textdatei enthält.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf den Pfeil neben Aktualisieren, und klicken Sie dann auf Aktualisieren.

  3. Wählen Sie im Dialogfeld Textdatei importieren die Textdatei aus, und klicken Sie dann auf Importieren.

Seitenanfang

Aktualisieren von Offlinecubedateien

Das Aktualisieren einer Offlinecubedatei kann sehr lange dauern und außerdem eine große Menge an temporärem Speicherplatz erfordern, da die Datei mit den aktuellsten Daten vom Servercube neu erstellt wird. Starten Sie daher den Vorgang zu einem Zeitpunkt, an dem Sie nicht auf andere Dateien zugreifen müssen, und stellen Sie zuvor sicher, dass ausreichend Speicherplatz zum erneuten Speichern der Datei zur Verfügung steht.

  1. Klicken Sie auf den PivotTable-Bericht, der auf der Offlinecubedatei basiert.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf den Pfeil neben Aktualisieren, und klicken Sie dann auf Aktualisieren.

    Abbildung des Excel-Menübands

Seitenanfang

Aktualisieren von Daten in einer importierten XML-Datei

  1. Klicken Sie auf dem Arbeitsblatt auf eine zugeordnete Zelle, um die XML-Zuordnung auszwählen, die aktualisiert werden soll.

  2. Wenn die Registerkarte Entwicklertools nicht angezeigt wird, gehen Sie folgendermaßen vor:

    1. Klicken Sie auf die Registerkarte Datei, und klicken Sie dann auf Optionen.

    2. Klicken Sie auf Menüband anpassen; , und wählen Sie unter Hauptregisterkarten das Kontrollkästchen Entwicklertools.

    3. Klicken Sie auf OK.

  3. Klicken Sie auf der Registerkarte Entwicklertools in der Gruppe XML auf Daten aktualisieren.

    Gruppe 'XML' im Menüband

Seitenanfang

Automatisches Aktualisieren von Daten beim Öffnen der Arbeitsmappe

Sie können einen externen Datenbereich beim Öffnen der Arbeitsmappe automatisch aktualisieren lassen. Auf Wunsch können Sie die Arbeitsmappe ohne die externen Daten speichern, um die Dateigröße der Arbeitsmappe zu reduzieren.

  1. Klicken Sie auf eine Zelle im externen Datenbereich.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf den Pfeil neben Aktualisieren, und klicken Sie dann auf Verbindungseigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie auf die Registerkarte Verwendung.

  4. Aktivieren Sie unter Aktualisierungssteuerung das Kontrollkästchen Aktualisieren beim Öffnen der Datei.

  5. Falls die Arbeitsmappe mit der Abfragedefinition, jedoch ohne die externen Daten gespeichert werden soll, aktivieren Sie das Kontrollkästchen Daten vor dem Speichern des Arbeitsblatts aus dem externen Datenbereich entfernen.

Hinweis : Sie können auch das Kontrollkästchen Aktualisieren beim Öffnen der Datei aktivieren, um die Daten zu aktualisieren, wenn die Arbeitsmappe für einen PivotTable-Bericht geöffnet wird. Dieses Kontrollkästchen befindet sich unter dem Abschnitt PivotTable-Daten auf der Registerkarte Daten des Dialogfelds PivotTable-Optionen.

Weitere Informationen finden Sie unter Übersicht der PivotTable- und PivotChart-Berichten.

Seitenanfang

Automatisches Aktualisieren von Daten in regelmäßigen Abständen

  1. Klicken Sie auf eine Zelle im externen Datenbereich.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf den Pfeil neben Aktualisieren, und klicken Sie dann auf Verbindungseigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie auf die Registerkarte Verwendung.

  4. Aktivieren Sie das Kontrollkästchen Aktualisierung alle, und geben Sie dann die Anzahl der Minuten ein, die zwischen den Aktualisierungen liegen soll.

Seitenanfang

Festlegen eines Kennworts für die Aktualisierung eines externen Datenbereichs

Gespeicherte Kennwörter sind nicht verschlüsselt und werden daher nicht empfohlen. Falls zum Herstellen der Verbindung zur Datenquelle ein Kennwort erforderlich ist, können Sie festlegen, dass die Benutzer das Kennwort eingeben müssen, bevor der externe Datenbereich aktualisiert werden kann. Das folgende Verfahren kann nicht für Daten angewendet werden, die aus einer Textdatei (TXT) oder einer Webabfrage (IQY) abgerufen werden.

Verwenden Sie sichere Kennwörter, bei denen Groß- und Kleinbuchstaben, Zahlen und Symbole kombiniert sind. Unsichere Kennwörter weisen nicht diese Mischung auf. Sicheres Kennwort: Y6dh!et5. Unsicheres Kennwort: Haus27. Kennwörter sollten mindestens acht Zeichen umfassen. Ein Pass-Ausdruck mit mindestens 14 Zeichen ist besser geeignet. Weitere Informationen finden Sie unter Schützen persönlicher Informationen mit sicheren Kennwörtern.

Es ist wichtig, dass Sie sich das jeweilige Kennwort merken. Wenn Sie das Kennwort vergessen, kann es nicht von Microsoft abgerufen werden. Bewahren Sie die notierten Kennwörter an einem sicheren Ort auf, damit sie nicht mit den zu schützenden Informationen in Verbindung gebracht werden können.

  1. Klicken Sie auf eine Zelle im externen Datenbereich.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf den Pfeil neben Aktualisieren, und klicken Sie dann auf Verbindungseigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie auf die Registerkarte Definition.

  4. Deaktivieren Sie das Kontrollkästchen Kennwort speichern.

Hinweis : Excel fordert Sie in jeder Excel-Arbeitssitzung nur bei der ersten Aktualisierung des externen Datenbereichs zur Eingabe des Kennworts auf. Beim nächsten Starten von Excel werden Sie erneut aufgefordert, das Kennwort einzugeben, wenn Sie die Arbeitsmappe öffnen, welche die Abfrage enthält, und dann eine Aktualisierung ausführen.

Seitenanfang

Ausführen einer Abfrage im Hintergrund oder im aktiven Programm

Wenn Sie eine Abfrage im Hintergrund ausführen, können Sie Excel während der Ausführung der Abfrage weiter verwenden.

Hinweis : Sie können eine OLAP-Abfrage nicht im Hintergrund ausführen.

  1. Klicken Sie auf eine Zelle im externen Datenbereich.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf den Pfeil neben Aktualisieren, und klicken Sie dann auf Verbindungseigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie auf die Registerkarte Verwendung.

  4. Aktivieren Sie das Kontrollkästchen Aktualisierung im Hintergrund zulassen, wenn die Abfrage im Hintergrund ausgeführt werden soll. Deaktivieren Sie das Kontrollkästchen, wenn die Abfrage durchgeführt werden soll, während Sie warten.

Hinweis : Wenn Sie ein Makro aufzeichnen, das eine Abfrage enthält, führt Excel die Abfrage nicht im Hintergrund aus. Um das aufgezeichnete Makro dahingehend zu ändern, dass die Abfrage im Hintergrund ausgeführt wird, bearbeiten Sie es im Visual Basic-Editor. Ändern Sie die Aktualisierungsmethode für das QueryTable-Objekt von BackgroundQuery := False in BackgroundQuery := True. Weitere Informationen zur Bearbeitung von Makros finden Sie in der Hilfe zu Visual Basic für Applikationen.

Seitenanfang

Überprüfen des Status oder Abbrechen eines Aktualisierungsvorgangs

Führen Sie eine oder mehrere der folgenden Aktionen aus:

  • Überprüfen des Status einer Abfrage    Eine dreht-Symbol wird auf der Statusleiste, um anzugeben, dass die Abfrage ausgeführt wird. Doppelklicken Sie auf das Symbol, um den Status der Abfrage überprüfen Aktualisierung im Hintergrund Aktualisierungsanzeige .

  • Stoppen einer Aktualisierung im Hintergrund    Um eine Abfrage zu stoppen, die im Hintergrund ausgeführt wird, doppelklicken Sie auf die Aktualisierung im Hintergrund Aktualisierungsanzeige -Symbol auf der Statusleiste, um das Dialogfeld Aktualisierungsstatus der externen Daten angezeigt wird, und klicken Sie dann auf Aktualisierung abbrechen.

  • Stoppen einer Abfrage       Um die Ausführung einer Abfrage zu stoppen, wenn Aktualisierung im Hintergrund zulassen deaktiviert ist, drücken Sie ESC.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×