Absenden von Formulardaten in einer E-Mail-Nachricht

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können Ihrer Formularvorlage eine sekundäre Verbindung zum Absenden von Daten hinzufügen, die es Benutzern ermöglicht, ihre Formulardaten in einer E-Mail-Nachricht abzusenden. Verwenden Sie statische Werte, die auf den Daten im Formular basieren, oder eine Formel, die die E-Mail-Adressen angibt, an die das Formular gesendet wird, die Betreffzeile der E-Mail-Nachricht und den Namen des Formulars. Ferner können Sie angeben, ob das Formular im Textkörper der E-Mail-Nachricht oder als Anlage der Nachricht angezeigt werden soll.

Wenn Sie Ihre Formularvorlage so konfigurieren, dass das Formular der E-Mail-Nachricht als Anlage angefügt wird, können Sie der E-Mail-Nachricht auch die Anlage anfügen. Durch Hinzufügen des Formulars und der Formularvorlage als Anlagen der E-Mail-Nachricht, können Sie sicherstellen, dass die E-Mail-Empfänger das Formular in Microsoft Office InfoPath öffnen können. Das gilt auch dann, wenn sie die Formularvorlage nicht auf ihren Computern zwischengespeichert haben. Damit Empfänger Anlagen öffnen können, müssen Sie zuvor InfoPath auf ihren Computern installiert haben.

Wenn Benutzer ihre Formulardaten in einer E-Mail-Nachricht absenden, wird in InfoPath eine E-Mail-Nachricht mit den Formulardaten erstellt und die Nachricht an die E-Mail-Empfänger gesendet, die Sie beim Erstellen der Datenverbindung angegeben haben. Wenn die Personen, die die ausgefüllten Formulare empfangen, Microsoft Office Outlook 2007 verwenden, können Sie ihrem Posteingang einen Ordner hinzufügen, der alle empfangenen InfoPath-Formulare enthält, und Sie können diesen Ordner konfigurieren, um die Daten in den Formularen in Spalten in Outlook anzuzeigen.

Nach Hinzufügen der Verbindung zum Absenden von Daten konfigurieren Sie Ihre Formularvorlage, um Benutzern das Absenden ihrer Formulardaten zu ermöglichen. Wenn Benutzer anschließend das Formular öffnen, wird in InfoPath automatisch die Schaltfläche Absenden der Symbolleiste Standard und dem Menü Datei der Befehl Absenden hinzugefügt. Sie können die Absendeoptionen für Ihre Formularvorlagen folgendermaßen anpassen:

  • Ändern Sie den Text, der auf der Schaltfläche Absenden auf der Symbolleiste Standard und auf dem Befehl Absenden im Menü Datei angezeigt wird.

  • Ändern Sie die Tastenkombination für die Schaltfläche Absenden auf der Symbolleiste Standard und den Befehl Absenden im Menü Datei.

  • Erstellen Sie benutzerdefinierte Meldungen, die Ihren Benutzern angezeigt werden, wenn diese ihre Formulare absenden.

  • Geben Sie an, ob das Formular geschlossen oder geöffnet werden soll, oder ob ein neues leeres Formular geöffnet werden soll, nachdem Benutzer das Formular abgesendet haben.

Seitenanfang

Hinzufügen einer Verbindung zum Absenden von Daten

  1. Klicken Sie im Menü Extras auf Absendeoptionen.

  2. Aktivieren Sie im Dialogfeld Absendeoptionen das Kontrollkästchen Übermitteln dieses Formulars durch Benutzer zulassen.

  3. Klicken Sie auf Formulardaten an ein einziges Ziel senden, und klicken Sie anschließend in der Liste auf E-Mail.

  4. Klicken Sie auf Hinzufügen.

  5. Geben Sie in den entsprechenden Feldern des Datenverbindungs-Assistenten die E-Mail-Adressen der Empfänger ein, den gewünschten Betreff für die E-Mail-Nachricht und den gewünschten Einführungstext, und klicken Sie dann auf Weiter.

    Tipp : Sie können auch ein Feld angeben oder eine Formel verwenden, um mit Ausnahme des Felds Einführung einen Wert für jedes Feld zu erstellen.

    Wie?

    1. Klicken Sie auf Formel einfügen  Formelschaltfläche .

    2. Führen Sie im Dialogfeld Formel einfügen eine der folgenden Aktionen aus:

      • Klicken Sie zum Verwenden eines Felds in der Formel auf Feld oder Gruppe einfügen, klicken Sie auf das Feld, das Sie im Dialogfeld Feld oder Gruppe auswählen verwenden möchten, und klicken Sie dann auf OK.

      • Klicken Sie zum Verwenden einer Funktion in der Formel auf Funktion einfügen. Aktivieren Sie die Funktion, die Sie im Dialogfeld Funktion einfügen verwenden möchten, und klicken Sie dann auf OK.

        Tipp : Wenn die Funktion Parameter erfordert, aktivieren Sie die Funktion im Dialogfeld Funktion einfügen, und klicken Sie auf OK. Doppelklicken Sie anschließend im Feld Formel im Dialogfeld Formel einfügen auf die hinzugefügte Funktion, und klicken Sie dann auf ein Feld oder auf eine Gruppe. Verknüpfungen zu weiteren Informationen über Funktionen finden Sie im Abschnitt Siehe auch.

      • Zum Einfügen eines Werts oder mathematischen Operators in die Formel geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein.

    Berechnung

    Symbol

    Addieren

    +

    Subtrahieren

    -

    Multiplizieren

    *

    Dividieren

    /

    • Hinweis : Falls Ihre Formel das Divisionssymbol (/) verwendet, sollten Sie genügend Abstand vor und hinter dem Divisionssymbol sicherstellen. Falls dieser Abstand nicht vorhanden ist, wird "/" in InfoPath möglicherweise als Trennzeichen für XPath-Pfadbestandteile und nicht als Divisionssymbol interpretieren.

    • Um zu überprüfen, ob die Formel die richtige Syntax aufweist, klicken Sie im Dialogfeld Formel einfügen auf Formel überprüfen.

      Verknüpfungen zu weiteren Informationen über Formeln finden Sie im Abschnitt Siehe auch.

  6. Führen Sie auf der nächsten Seite des Assistenten eine der folgenden Aktionen aus:

    1. Klicken Sie auf Nur die aktive Formularansicht und keine Anlage senden, um das Formular im Textkörper einer E-Mail-Nachricht anzuzeigen.

    2. Um die Formulardaten als Anlage der E-Mail-Nachricht zu senden, klicken Sie auf Formulardaten als Anlage senden, aktivieren Sie das Kontrollkästchen Formularvorlage anfügen, um sicherzustellen, dass Benutzer das Formular öffnen können, und geben Sie dann den Namen für das Formular im Feld Name der Anlage ein. Sie können auch ein Feld angeben oder eine Formel verwenden, um sicherzustellen, dass jeder Formularname eindeutig ist.

      Wie?

      1. Klicken Sie auf Formel einfügen  Formelschaltfläche .

      2. Führen Sie im Dialogfeld Formel einfügen eine der folgenden Aktionen aus:

        • Klicken Sie zum Verwenden eines Felds in der Formel auf Feld oder Gruppe einfügen, klicken Sie auf das Feld, das Sie im Dialogfeld Feld oder Gruppe auswählen verwenden möchten, und klicken Sie dann auf OK.

        • Klicken Sie zum Verwenden einer Funktion in der Formel auf Funktion einfügen. Aktivieren Sie die Funktion, die Sie im Dialogfeld Funktion einfügen verwenden möchten, und klicken Sie dann auf OK.

          Tipp : Wenn die Funktion Parameter erfordert, aktivieren Sie die Funktion im Dialogfeld Funktion einfügen, und klicken Sie auf OK. Doppelklicken Sie anschließend im Feld Formel im Dialogfeld Formel einfügen auf die hinzugefügte Funktion, und klicken Sie dann auf ein Feld oder auf eine Gruppe. Verknüpfungen zu weiteren Informationen über Funktionen finden Sie im Abschnitt Siehe auch.

        • Zum Einfügen eines Werts oder mathematischen Operators in die Formel geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein.

      Berechnung

      Symbol

      Addieren

      +

      Subtrahieren

      -

      Multiplizieren

      *

      Dividieren

      /

      • Hinweis : Falls Ihre Formel das Divisionssymbol (/) verwendet, sollten Sie genügend Abstand vor und hinter dem Divisionssymbol sicherstellen. Falls dieser Abstand nicht vorhanden ist, wird "/" in InfoPath möglicherweise als Trennzeichen für XPath-Pfadbestandteile und nicht als Divisionssymbol interpretieren.

      • Um zu überprüfen, ob die Formel die richtige Syntax aufweist, klicken Sie im Dialogfeld Formel einfügen auf Formel überprüfen.

        Verknüpfungen zu weiteren Informationen über Formeln finden Sie im Abschnitt Siehe auch.

      Hinweis : Die Personen, die Formulardaten als Anlage in einer E-Mail-Nachricht empfangen, müssen zum Öffnen der Anlage InfoPath auf ihrem Computer installieren.

  7. Klicken Sie auf Weiter.

  8. Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung an einen aussagekräftigen Namen für diese Datenverbindung (Absenden) ein.

  9. Überprüfen Sie, ob die Informationen im Abschnitt Zusammenfassung korrekt sind, und klicken Sie dann auf Fertig stellen.

    1. Zum Ändern des Namens der Schaltfläche Absenden, die auf der Standard-Symbolleiste angezeigt wird, und des Befehls Absenden, der im Menü Datei angezeigt wird, wenn der Benutzer das Formular ausfüllt, geben Sie den neuen Namen in das Feld Beschriftung im Dialogfeld Absendeoptionen ein.

      Tipp : Wenn Sie dieser Schaltfläche und diesem Befehl eine Tastenkombination zuweisen möchten, geben Sie vor dem Zeichen, das als Tastenkombination dienen soll, das kaufmännische Und-Zeichen (&) ein. Wenn beispielsweise ALT+B als Tastenkombination für die Schaltfläche Absenden und den Befehl dienen soll, geben Sie A&bsenden ein.

  10. Wenn beim Ausfüllen des Formulars der Befehl Absenden oder die Schaltfläche Absenden in der Symbolleiste Standard nicht verwendet werden soll, deaktivieren Sie das Kontrollkästchen Menüelement "Absenden" und in der Symbolleiste Schaltfläche "Absenden" anzeigen.

    1. In der Standardeinstellung bleibt das Formular in InfoPath weiterhin geöffnet, nachdem das Formular abgesendet wurde, und es wird eine Meldung angezeigt, dass der Sendevorgang erfolgreich abgeschlossen wurde. Um dieses Standardverhalten zu ändern, klicken Sie auf Erweitert, und führen Sie eine der folgenden Aktionen aus:

      • Um das Formular zu schließen oder ein neues, leeres Formular zu erstellen, nachdem ein ausgefülltes Formular gesendet wurde, klicken Sie in der Liste Nach dem Absenden auf die gewünschte Option.

      • Um eine benutzerdefinierte Meldung zu erstellen, die angibt, ob das Formular erfolgreich übertragen wurde, aktivieren Sie das Kontrollkästchen Benutzerdefinierte Meldung verwenden, und geben Sie anschließend die Meldungen in die Felder Absenden erfolgreich und Absenden fehlgeschlagen ein.

        Tipp : Geben Sie im Feld Absenden fehlgeschlagen eine Meldung mit Lösungsmöglichkeiten ein, wenn beim Absenden eines Formulars Probleme auftreten. Sie können beispielsweise empfehlen, das Formular zu speichern und sich an jemanden zu wenden, der weiterhelfen kann.

      • Wenn nach dem Absenden eines Formulars keine Meldung angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Meldung nach dem Absenden anzeigen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×