Absenden von Formulardaten an eine Dokumentbibliothek

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können die Formulare aller Benutzer in einer Dokumentbibliothek auf einem Server speichern und strukturieren, auf dem Microsoft Windows SharePoint Services ausgeführt wird. In der Dokumentbibliothek können Benutzer Formulare ausfüllen, die auf Ihrer Formularvorlage basieren, Daten aus ausgefüllten Formularen an Microsoft Office Excel 2003 oder Microsoft Office Excel 2007 exportieren, oder die Daten aus mehreren Formularen in ein einzelnes Formular zusammenführen.

Um Benutzern zu ermöglichen, auf Ihrer Formularvorlage basierende Formulare an eine Dokumentbibliothek zu senden, können Sie der Formularvorlage, die diese Daten absendet, eine sekundäre Datenverbindung hinzufügen. Nach Hinzufügen der Verbindung zum Absenden von Daten können Sie die Formularvorlage konfigurieren, damit Ihre Benutzer ihre Formulardaten an die Dokumentbibliothek absenden können. Hierbei wird in Microsoft Office InfoPath die Schaltfläche Absenden der Symbolleiste Standard und dem Menü Datei der Befehl Absenden hinzugefügt. Sie können die Absendeoptionen für Ihre Formularvorlagen folgendermaßen anpassen:

  • Ändern Sie den Text, der auf der Schaltfläche Absenden auf der Symbolleiste Standard und auf dem Befehl Absenden im Menü Datei angezeigt wird.

  • Ändern Sie die Tastenkombination für die Schaltfläche Absenden auf der Symbolleiste Standard und den Befehl Absenden im Menü Datei.

  • Erstellen Sie benutzerdefinierte Meldungen, die Ihren Benutzern angezeigt werden, wenn diese ihre Formulare absenden.

  • Geben Sie an, ob das Formular geschlossen oder geöffnet werden soll, oder ob ein neues leeres Formular geöffnet werden soll, nachdem das Formular abgesendet wurde.

Hinzufügen einer Verbindung zum Absenden von Daten

  1. Klicken Sie im Menü Extras auf Absendeoptionen.

  2. Aktivieren Sie im Dialogfeld Absendeoptionen das Kontrollkästchen Übermitteln dieses Formulars durch Benutzer zulassen.

  3. Klicken Sie auf Formulardaten an einziges Ziel senden, und klicken Sie dann in der Liste auf SharePoint-Dokumentbibliothek.

  4. Klicken Sie auf Hinzufügen.

  5. Geben Sie im Datenverbindungs-Assistenten im Feld Dokumentbibliothek den Speicherort der SharePoint-Dokumentbibliothek ein.

  6. Geben Sie im Feld Dateiname einen Namen, der zum Identifizieren des Dokuments in der Dokumentbibliothek verwendet wird.

    Tipp : Sie können auch eine Formel verwenden, um sicherzustellen, dass jeder Formularname eindeutig ist.

    Wie?

    1. Klicken Sie auf Formel einfügen  Formelschaltfläche .

    2. Führen Sie im Dialogfeld Formel einfügen eine der folgenden Aktionen aus:

      • Klicken Sie zum Verwenden eines Felds in der Formel auf Feld oder Gruppe einfügen, klicken Sie auf das Feld, das Sie im Dialogfeld Feld oder Gruppe auswählen verwenden möchten, und klicken Sie dann auf OK.

      • Klicken Sie zum Verwenden einer Funktion in der Formel auf Funktion einfügen. Aktivieren Sie die Funktion, die Sie im Dialogfeld Funktion einfügen verwenden möchten, und klicken Sie dann auf OK.

        Tipp : Wenn die Funktion Parameter erfordert, aktivieren Sie die Funktion im Dialogfeld Funktion einfügen, und klicken Sie auf OK. Doppelklicken Sie anschließend im Feld Formel im Dialogfeld Formel einfügen auf die hinzugefügte Funktion, und klicken Sie dann auf ein Feld oder auf eine Gruppe. Verknüpfungen zu weiteren Informationen über Funktionen finden Sie im Abschnitt Siehe auch.

      • Zum Einfügen eines Werts oder mathematischen Operators in die Formel geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein.

    Berechnung

    Symbol

    Addieren

    +

    Subtrahieren

    -

    Multiplizieren

    *

    Dividieren

    /

    • Hinweis : Falls Ihre Formel das Divisionssymbol (/) verwendet, sollten Sie genügend Abstand vor und hinter dem Divisionssymbol sicherstellen. Falls dieser Abstand nicht vorhanden ist, wird "/" in InfoPath möglicherweise als Trennzeichen für XPath-Pfadbestandteile und nicht als Divisionssymbol interpretieren.

    • Um zu überprüfen, ob die Formel die richtige Syntax aufweist, klicken Sie im Dialogfeld Formel einfügen auf Formel überprüfen.

      Verknüpfungen zu weiteren Informationen über Formeln finden Sie im Abschnitt Siehe auch.

  7. Aktivieren Sie das Kontrollkästchen Vorhandene Dateien überschreiben, um das Überschreiben vorhandener Formulare mit demselben Namen in der Dokumentbibliothek zu ermöglichen.

  8. Klicken Sie auf Weiter.

  9. Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung an einen aussagekräftigen Namen für diese Datenverbindung (Absenden) ein.

  10. Überprüfen Sie, ob die Informationen im Abschnitt Zusammenfassung korrekt sind, und klicken Sie dann auf Fertig stellen.

    1. Zum Ändern des Namens der Schaltfläche Absenden, die auf der Standard-Symbolleiste angezeigt wird, und des Befehls Absenden, der im Menü Datei angezeigt wird, wenn der Benutzer das Formular ausfüllt, geben Sie den neuen Namen in das Feld Beschriftung im Dialogfeld Absendeoptionen ein.

      Tipp : Wenn Sie dieser Schaltfläche und diesem Befehl eine Tastenkombination zuweisen möchten, geben Sie vor dem Zeichen, das als Tastenkombination dienen soll, das kaufmännische Und-Zeichen (&) ein. Wenn beispielsweise ALT+B als Tastenkombination für die Schaltfläche Absenden und den Befehl dienen soll, geben Sie A&bsenden ein.

  11. Wenn beim Ausfüllen des Formulars der Befehl Absenden oder die Schaltfläche Absenden in der Symbolleiste Standard nicht verwendet werden soll, deaktivieren Sie das Kontrollkästchen Menüelement "Absenden" und in der Symbolleiste Schaltfläche "Absenden" anzeigen.

    1. In der Standardeinstellung bleibt das Formular in InfoPath weiterhin geöffnet, nachdem das Formular abgesendet wurde, und es wird eine Meldung angezeigt, dass der Sendevorgang erfolgreich abgeschlossen wurde. Um dieses Standardverhalten zu ändern, klicken Sie auf Erweitert, und führen Sie eine der folgenden Aktionen aus:

      1. Um das Formular zu schließen oder ein neues, leeres Formular zu erstellen, nachdem ein ausgefülltes Formular gesendet wurde, klicken Sie in der Liste Nach dem Absenden auf die gewünschte Option.

      2. Um eine benutzerdefinierte Meldung zu erstellen, die angibt, ob das Formular erfolgreich übertragen wurde, aktivieren Sie das Kontrollkästchen Benutzerdefinierte Meldung verwenden, und geben Sie anschließend die Meldungen in die Felder Absenden erfolgreich und Absenden fehlgeschlagen ein.

        Tipp : Geben Sie im Feld Absenden fehlgeschlagen eine Meldung mit Lösungsmöglichkeiten ein, wenn beim Absenden eines Formulars Probleme auftreten. Sie können beispielsweise empfehlen, das Formular zu speichern und sich an jemanden zu wenden, der weiterhelfen kann.

      3. Wenn nach dem Absenden eines Formulars keine Meldung angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Meldung nach dem Absenden anzeigen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×