Absenden der Formulardaten an mehrere Speicherpositionen

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können Ihre Formularvorlage so entwerfen, dass Benutzer beim Klicken auf die Schaltfläche Absenden ihre Formulardaten an mehrere Speicherpositionen senden können.

Inhalt dieses Artikels

Übersicht

Schritt 1: Hinzufügen der Verbindungen zum Absenden von Daten

Schritt 2: Konfigurieren der Formularvorlage zum Ermöglichen der Absendung

Übersicht

Um Benutzern das Absenden ihrer Formulardaten an mehrere Speicherpositionen zu ermöglichen, müssen Sie Ihrer Formularvorlage eine sekundäre Datenverbindung hinzufügen, die Daten an jede Speicherposition absendet, an die die Benutzer das Formular absenden sollen. Nachdem Sie alle Verbindungen zum Absenden von Daten hinzugefügt haben, konfigurieren Sie die Formularvorlage, um Benutzern das Absenden ihrer Formulardaten an mehrere Speicherpositionen mithilfe einer Regel zu ermöglichen. Infolgedessen wird in Microsoft Office InfoPath in der Symbolleiste Standard die Schaltfläche Absenden und im Menü Datei der Befehl Datei hinzugefügt, wenn Benutzer das Formular ausfüllen. InfoPath sendet die Formulardaten in der Reihenfolge an sekundäre Datenverbindungen, in der sie in der Regel aufgeführt werden. Sie können die Regel nicht so konfigurieren, dass alle Verbindungen zum Absenden von Daten gleichzeitig verwendet werden können.

Wenn Sie die Formularvorlage konfigurieren, damit Benutzer ihre Formulardaten absenden können, können Sie die Absendeoptionen folgendermaßen konfigurieren:

  • Ändern Sie den Text, der auf der Schaltfläche Absenden auf der Symbolleiste Standard und auf dem Befehl Absenden im Menü Datei angezeigt wird.

  • Ändern Sie die Tastenkombination für die Schaltfläche Absenden auf der Symbolleiste Standard und den Befehl Absenden im Menü Datei.

  • Erstellen Sie benutzerdefinierte Meldungen, die Ihren Benutzern angezeigt werden, wenn diese ihre Formulare absenden.

  • Geben Sie an, ob das Formular geschlossen oder geöffnet werden soll, oder ob ein neues leeres Formular geöffnet werden soll, nachdem das Formular abgesendet wurde.

Seitenanfang

Schritt 1: Hinzufügen der Verbindungen zum Absenden von Daten

Um die Formularvorlage so zu konfigurieren, dass Benutzer ihre ausgefüllten Formulare an mehrere Speicherpositionen absenden können, müssen Sie der Formularvorlage die erforderlichen Verbindungen zum Absenden von Daten hinzufügen. Sie können die Datenverbindungen den folgenden Speicherpositionen hinzufügen:

  • Ein Webdienst

  • Eine Dokumentbibliothek auf einem Server, auf dem Microsoft Windows SharePoint Services ausgeführt wird

  • In einer E-Mail-Nachricht

    Hinweis : Benutzer müssen Microsoft Office Outlook auf ihrem Computer installieren, um die Formulardaten in einer E-Mail-Nachricht abzusenden.

In den folgenden Prozeduren wird erläutert, wie diesen Speicherpositionen Verbindungen zum Absenden von Daten hinzugefügt werden.

Hinzufügen einer Datenverbindung, die Daten an einen Webdienst absendet

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten senden, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf An einen Webdienst und dann auf Weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten die Speicherposition des Webdienstes ein, in dem Ihre Benutzer ihre Formulare absenden werden, und klicken Sie dann auf Weiter.

    Hinweis : Wenn Sie einen UDDI-Server (Universal Description, Discovery, and Integration) für den Webdienst suchen möchten, klicken Sie auf UDDI durchsuchen. Geben Sie den UDDI-Server ein, nach dem Sie suchen möchten, geben Sie an, ob Sie nach Anbieter oder nach den angebotenen Diensten suchen möchten, geben Sie ein Schlüsselwort für die Suche ein, und klicken Sie dann auf Suchen. Webdienste, die Ihrem Schlüsselwort für die Suche entsprechen, werden in der Liste Suchergebnis angezeigt.

  6. Klicken Sie auf der nächsten Seite des Assistenten auf der Liste Vorgang auswählen auf den Webdienstvorgang, der die Formulardaten empfängt. Anschließend klicken Sie auf Weiter.

  7. Führen Sie auf der nächsten Seite des Assistenten eine der folgenden Aktionen aus:

    Absenden der Daten in einem Feld oder einer Gruppe

    1. Klicken Sie in der Liste Parameter auf einen Webdienstparameter, der die Daten aus dem Formular empfängt.

    2. Klicken Sie in Parameteroptionen auf Feld oder Gruppe.

    3. Klicken Sie auf Ändern Schaltfläche (Symbol) .

    4. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf das Feld oder die Gruppe, deren Daten Sie absenden möchten, und klicken Sie dann auf OK.

    5. Klicken Sie im Feld Einschließen auf Nur Text und untergeordnete Elemente, um nur die Inhalte und eventuelle untergeordnete Elemente des Felds oder der Gruppe zu senden; klicken Sie auf Untergeordneter XML-Baum, einschließlich ausgewähltem Element, um sowohl den Inhalt als auch die ausgewählte Gruppe oder das Feld zu senden.

    Absenden aller Daten im Formular

    1. Klicken Sie auf Gesamtes Formular (XML-Dokument einschließlich Verarbeitungsanweisungen).

    Absenden der Daten als Zeichenfolge

    1. Aktivieren Sie das Kontrollkästchen Daten als Zeichenfolge absenden.

      Tipp : Normalerweise aktivieren Sie dieses Kontrollkästchen, um digital signierte Daten abzusenden. Deaktivieren Sie in den meisten Fällen dieses Kontrollkästchen.

  8. Klicken Sie auf Weiter.

  9. Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung an einen aussagekräftigen Namen für diese Datenverbindung (Absenden) ein.

  10. Überprüfen Sie, ob die Informationen im Abschnitt Zusammenfassung korrekt sind, und klicken Sie dann auf Fertig stellen.

Hinzufügen einer Datenverbindung, die Daten an eine Dokumentbibliothek absendet

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten senden, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf An eine Dokumentbibliothek auf einer SharePoint-Website, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten im Feld Dokumentbibliothek den Speicherort der SharePoint-Dokumentbibliothek ein.

  6. Geben Sie im Feld Dateiname einen Namen ein, der zum Identifizieren des Dokuments in der Dokumentbibliothek verwendet wird. Sie können auch eine Formel verwenden, um sicherzustellen, dass jeder Formularname eindeutig ist.

    Wie?

    1. Klicken Sie auf Formel einfügen  Formelschaltfläche .

    2. Führen Sie im Dialogfeld Formel einfügen eine der folgenden Aktionen aus:

      • Klicken Sie zum Verwenden eines Felds in der Formel auf Feld oder Gruppe einfügen, klicken Sie auf das Feld, das Sie im Dialogfeld Feld oder Gruppe auswählen verwenden möchten, und klicken Sie dann auf OK.

      • Klicken Sie zum Verwenden einer Funktion in der Formel auf Funktion einfügen. Aktivieren Sie die Funktion, die Sie im Dialogfeld Funktion einfügen verwenden möchten, und klicken Sie dann auf OK.

        Tipp : Wenn die Funktion Parameter erfordert, aktivieren Sie die Funktion im Dialogfeld Funktion einfügen, und klicken Sie auf OK. Doppelklicken Sie anschließend im Feld Formel im Dialogfeld Formel einfügen auf die hinzugefügte Funktion, und klicken Sie dann auf ein Feld oder auf eine Gruppe. Verknüpfungen zu weiteren Informationen über Funktionen finden Sie im Abschnitt Siehe auch.

      • Zum Einfügen eines Werts oder mathematischen Operators in die Formel geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein.

    Berechnung

    Symbol

    Addieren

    +

    Subtrahieren

    -

    Multiplizieren

    *

    Dividieren

    /

    • Hinweis : Falls Ihre Formel das Divisionssymbol (/) verwendet, sollten Sie genügend Abstand vor und hinter dem Divisionssymbol sicherstellen. Falls dieser Abstand nicht vorhanden ist, wird "/" in InfoPath möglicherweise als Trennzeichen für XPath-Pfadbestandteile und nicht als Divisionssymbol interpretieren.

    • Um zu überprüfen, ob die Formel die richtige Syntax aufweist, klicken Sie im Dialogfeld Formel einfügen auf Formel überprüfen.

      Verknüpfungen zu weiteren Informationen über Formeln finden Sie im Abschnitt Siehe auch.

  7. Aktivieren Sie das Kontrollkästchen Vorhandene Dateien überschreiben, um das Überschreiben vorhandener Formulare mit demselben Namen in der Dokumentbibliothek zu ermöglichen.

  8. Klicken Sie auf Weiter.

  9. Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung an einen aussagekräftigen Namen für diese Datenverbindung (Absenden) ein.

  10. Überprüfen Sie, ob die Informationen im Abschnitt Zusammenfassung korrekt sind, und klicken Sie dann auf Fertig stellen.

Hinzufügen einer Datenverbindung, die Daten in einer E-Mail-Nachricht absendet

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie im Dialogfeld Sekundäre Datenquelle auf Hinzufügen.

  3. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten senden, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten auf Als E-Mail-Nachricht, und klicken Sie dann auf Weiter.

  5. Geben Sie auf der nächsten Seite des Assistenten die E-Mail-Adressen der Nachrichtenempfänger ein, den Betreff, der in der Nachricht angezeigt werden soll sowie sonstigen gewünschten Einführungstext in den entsprechenden Feldern, und klicken Sie dann auf Weiter. Außer im Feld Einführung können Sie in jedem Feld auch eine Formel verwenden.

    Wie?

    1. Klicken Sie auf Formel einfügen  Formelschaltfläche .

    2. Führen Sie im Dialogfeld Formel einfügen eine der folgenden Aktionen aus:

      • Klicken Sie zum Verwenden eines Felds in der Formel auf Feld oder Gruppe einfügen, klicken Sie auf das Feld, das Sie im Dialogfeld Feld oder Gruppe auswählen verwenden möchten, und klicken Sie dann auf OK.

      • Klicken Sie zum Verwenden einer Funktion in der Formel auf Funktion einfügen. Aktivieren Sie die Funktion, die Sie im Dialogfeld Funktion einfügen verwenden möchten, und klicken Sie dann auf OK.

        Tipp : Wenn die Funktion Parameter erfordert, aktivieren Sie die Funktion im Dialogfeld Funktion einfügen, und klicken Sie auf OK. Doppelklicken Sie anschließend im Feld Formel im Dialogfeld Formel einfügen auf die hinzugefügte Funktion, und klicken Sie dann auf ein Feld oder auf eine Gruppe. Verknüpfungen zu weiteren Informationen über Funktionen finden Sie im Abschnitt Siehe auch.

      • Zum Einfügen eines Werts oder mathematischen Operators in die Formel geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein.

    Berechnung

    Symbol

    Addieren

    +

    Subtrahieren

    -

    Multiplizieren

    *

    Dividieren

    /

    • Hinweis : Falls Ihre Formel das Divisionssymbol (/) verwendet, sollten Sie genügend Abstand vor und hinter dem Divisionssymbol sicherstellen. Falls dieser Abstand nicht vorhanden ist, wird "/" in InfoPath möglicherweise als Trennzeichen für XPath-Pfadbestandteile und nicht als Divisionssymbol interpretieren.

    • Um zu überprüfen, ob die Formel die richtige Syntax aufweist, klicken Sie im Dialogfeld Formel einfügen auf Formel überprüfen.

      Verknüpfungen zu weiteren Informationen über Formeln finden Sie im Abschnitt Siehe auch.

  6. Führen Sie auf der nächsten Seite des Assistenten eine der folgenden Aktionen aus:

    1. Klicken Sie auf Nur die aktive Formularansicht und keine Anlage senden, um das Formular im Textkörper einer E-Mail-Nachricht anzuzeigen.

    2. Um die Formulardaten als Anlage an die e-Mail-Nachricht zu senden, klicken Sie auf das Formular als Anlage senden, wählen Sie das Kontrollkästchen Anfügen, um sicherzustellen, dass Benutzer das Formular öffnen, können die Formularvorlage aus, und geben Sie einen Namen für das Formular im Feld Name der Anlage. Sie können auch angeben ein Felds oder eine Formel verwenden, um sicherzustellen, dass jeder Formularname eindeutig ist. Diese Option ist nur verfügbar, wenn die Formularvorlage die Sicherheitsstufe automatisch ermitteln konfiguriert ist, oder so konfiguriert, die Sicherheitsstufe eingeschränkt oder voll vertrauenswürdig dass ist.

      Wie?

      1. Klicken Sie auf Formel einfügen  Formelschaltfläche .

      2. Führen Sie im Dialogfeld Formel einfügen eine der folgenden Aktionen aus:

        • Klicken Sie zum Verwenden eines Felds in der Formel auf Feld oder Gruppe einfügen, klicken Sie auf das Feld, das Sie im Dialogfeld Feld oder Gruppe auswählen verwenden möchten, und klicken Sie dann auf OK.

        • Klicken Sie zum Verwenden einer Funktion in der Formel auf Funktion einfügen. Aktivieren Sie die Funktion, die Sie im Dialogfeld Funktion einfügen verwenden möchten, und klicken Sie dann auf OK.

          Tipp : Wenn die Funktion Parameter erfordert, aktivieren Sie die Funktion im Dialogfeld Funktion einfügen, und klicken Sie auf OK. Doppelklicken Sie anschließend im Feld Formel im Dialogfeld Formel einfügen auf die hinzugefügte Funktion, und klicken Sie dann auf ein Feld oder auf eine Gruppe. Verknüpfungen zu weiteren Informationen über Funktionen finden Sie im Abschnitt Siehe auch.

        • Zum Einfügen eines Werts oder mathematischen Operators in die Formel geben Sie den Wert oder das Symbol für die mathematische Operation in das Feld Formel ein.

      Berechnung

      Symbol

      Addieren

      +

      Subtrahieren

      -

      Multiplizieren

      *

      Dividieren

      /

      • Hinweis : Falls Ihre Formel das Divisionssymbol (/) verwendet, sollten Sie genügend Abstand vor und hinter dem Divisionssymbol sicherstellen. Falls dieser Abstand nicht vorhanden ist, wird "/" in InfoPath möglicherweise als Trennzeichen für XPath-Pfadbestandteile und nicht als Divisionssymbol interpretieren.

      • Um zu überprüfen, ob die Formel die richtige Syntax aufweist, klicken Sie im Dialogfeld Formel einfügen auf Formel überprüfen.

        Verknüpfungen zu weiteren Informationen über Formeln finden Sie im Abschnitt Siehe auch.

      Hinweis : Zum Öffnen der Anlage müssen E-Mail-Empfänger der Formulardaten, die als Anlage gesendet werden, InfoPath auf ihrem Computer installieren.

  7. Klicken Sie auf Weiter.

  8. Geben Sie auf der nächsten Seite des Assistenten im Feld Geben Sie einen Namen für die Datenverbindung an einen aussagekräftigen Namen für diese Datenverbindung (Absenden) ein.

  9. Überprüfen Sie, ob die Informationen im Abschnitt Zusammenfassung korrekt sind, und klicken Sie dann auf Fertig stellen.

Seitenanfang

Schritt 2: Konfigurieren der Formularvorlage zum Ermöglichen des Absendens

Nachdem Sie Ihrer Formularvorlage die erforderlichen sekundären Datenverbindungen hinzugefügt haben, konfigurieren Sie die Formularvorlage, um Benutzern das Absenden ihrer Daten zu ermöglichen. Bei diesem Vorgang wird in InfoPath der Befehl Absenden zum Menü Datei und die Schaltfläche Absenden zur Symbolleiste Standard hinzugefügt, wenn Benutzer das Formular ausfüllen. Anschließend können Sie die Aktion konfigurieren, die auftritt, wenn ein Benutzer auf die Schaltfläche Absenden klickt. Fügen Sie in diesem Fall eine Regel hinzu, die die Formulardaten an jede Absendedatenverbindung, wenn der Benutzer im Menü Datei auf Absenden oder auf der Symbolleiste auf Standard klickt.

Hinweis : Im selben Dialogfeld können Sie die Absendeoptionen konfigurieren.

  1. Klicken Sie im Menü Extras auf Absendeoptionen.

  2. Aktivieren Sie im Dialogfeld Absendeoptionen das Kontrollkästchen Übermitteln dieses Formulars durch Benutzer zulassen.

    Hinweis : Beim Aktivieren dieses Kontrollkästchens wird in Microsoft Office InfoPath in der Symbolleiste Standard die Schaltfläche Absenden und im Menü Datei der Befehl Datei hinzugefügt, wenn Benutzer das Formular ausfüllen.

  3. Klicken Sie auf Benutzerdefinierte Aktion mithilfe von Regeln ausführen, und klicken Sie dann auf Regeln.

  4. Klicken Sie im Dialogfeld Regeln für das Absenden von Formularen auf Hinzufügen.

  5. Klicken Sie auf Aktion hinzufügen.

  6. Klicken Sie im Feld Aktion auf Mithilfe einer Datenverbindung absenden. Klicken Sie auf die Datenverbindung, die Sie für diese Absendaktion in der Liste Datenverbindung verwenden möchten, und klicken Sie dann auf OK.

  7. Wiederholen Sie die Schritte 5 und 6 für jede Verbindung zum Absenden von Daten, die Sie Ihrer Formularvorlage hinzugefügt haben.

  8. Klicken Sie zweimal auf OK, nachdem Sie Bedingungen für alle Verbindungen zum Absenden von Daten in Ihrer Formularvorlage hinzugefügt haben.

    1. Zum Ändern des Namens der Schaltfläche Absenden, die auf der Standard-Symbolleiste angezeigt wird, und des Befehls Absenden, der im Menü Datei angezeigt wird, wenn der Benutzer das Formular ausfüllt, geben Sie den neuen Namen in das Feld Beschriftung im Dialogfeld Absendeoptionen ein.

      Tipp : Wenn Sie dieser Schaltfläche und diesem Befehl eine Tastenkombination zuweisen möchten, geben Sie vor dem Zeichen, das als Tastenkombination dienen soll, das kaufmännische Und-Zeichen (&) ein. Wenn beispielsweise ALT+B als Tastenkombination für die Schaltfläche Absenden und den Befehl dienen soll, geben Sie A&bsenden ein.

  9. Wenn Sie Benutzer an der Verwendung des Befehls Absenden oder der Schaltfläche Absenden in der Symbolleiste Standard hindern möchten, wenn diese Ihr Formular ausfüllen, deaktivieren Sie das Kontrollkästchen Menüelement 'Absenden' und Symbolleistenschaltfläche 'Absenden' anzeigen.

    1. In der Standardeinstellung bleibt das Formular in InfoPath weiterhin geöffnet, nachdem das Formular abgesendet wurde, und es wird eine Meldung angezeigt, dass der Sendevorgang erfolgreich abgeschlossen wurde. Um dieses Standardverhalten zu ändern, klicken Sie auf Erweitert, und führen Sie eine der folgenden Aktionen aus:

      • Um das Formular zu schließen oder ein neues, leeres Formular zu erstellen, nachdem ein ausgefülltes Formular gesendet wurde, klicken Sie in der Liste Nach dem Absenden auf die gewünschte Option.

      • Um eine benutzerdefinierte Meldung zu erstellen, die angibt, ob das Formular erfolgreich übertragen wurde, aktivieren Sie das Kontrollkästchen Benutzerdefinierte Meldung verwenden, und geben Sie anschließend die Meldungen in die Felder Absenden erfolgreich und Absenden fehlgeschlagen ein.

        Tipp : Geben Sie im Feld Absenden fehlgeschlagen eine Meldung mit Lösungsmöglichkeiten ein, wenn beim Absenden eines Formulars Probleme auftreten. Sie können beispielsweise empfehlen, das Formular zu speichern und sich an jemanden zu wenden, der weiterhelfen kann.

      • Wenn nach dem Absenden eines Formulars keine Meldung angezeigt werden soll, deaktivieren Sie das Kontrollkästchen Meldung nach dem Absenden anzeigen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×