Abrufen von Daten von Analysis Services

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Analysis Services stellt dimensionale Daten bereit, die sich gut für das Durchsuchen in PivotTables und Power View-Berichten eignen. Analysis Services-Daten können Sie aus folgenden Quellen erhalten:

  • OLAP-Cubes auf einem mehrdimensionalen Analysis Services-Server.

  • Tabellarische Modelle auf einem tabellarischen Analysis Services-Server.

  • Excel-Arbeitsmappen in SharePoint 2010 oder höher, wenn die Arbeitsmappe ein Datenmodell enthält.

Sie können Daten aus einer externen Analysis Services-Datenquelle mithilfe einer Onlineverbindung analysieren. Während Sie einen Bericht pivotieren, Datenschnitte anlegen oder filtern, fragt Excel Analysis Services auf die von Ihnen gewünschten Daten ab. Das Analysieren von Daten in dieser Weise setzt eine Onlineverbindung zur Datenquelle voraus.

Bei einem anderen Ansatz wird offline gearbeitet. Sie können offline arbeiten, indem Sie Daten in Ihre Arbeitsmappe importieren, sodass sowohl die Daten als auch die Berichtsvisualisierungen unabhängig und vollständig portabel in einer einzelnen Datei vorliegen. Wenn Sie Daten importieren, sollte Ihnen jedoch bewusst sein, dass dadurch neue Anforderungen entstehen, einschließlich des Power Pivot-Add-Ins, grundlegender Kenntnisse in MDX und ausreichend Speicherplatz auf Datenträgern zum Speichern größerer Arbeitsmappen. In diesem Artikel wird erläutert, wie Daten aus verschiedenen Analysis Services-Datenquellen importiert werden.

Excel-Arbeitsmappen, die SharePoint- oder Office 365 gespeichert werden eine maximale Dateigröße. Tabelle Import-Assistenten in das Power Pivot-add-in verwenden, können Sie Tabellen, Spalten und Zeilen in einer Gesamtdateigröße verringern Selektives importieren. Wenn die Arbeitsmappe in Excel Online anzeigen zu groß ist, können Sie es stattdessen in Excel öffnen.

Office 365 verhindert die Aktualisierung von Daten aus externen Datenquellen, einschließlich Analysis Services-Lösungen, die auf Servern in einem Netzwerk ausgeführt werden. Wenn aktualisierbare Daten zu Ihren Anforderungen gehören, wählen Sie SharePoint oder verwenden Sie eine Netzwerk-Dateifreigabe.

Inhalt dieses Artikels

Voraussetzungen

Herstellen einer Verbindung mit einem Cube, einem tabellarischen Modell oder einem Power Pivot-Datenmodell

Importieren von Daten aus einem Cube

Importieren von Daten aus einem tabellarischen Modell

Importieren von Daten aus einem Arbeitsmappen-Datenmodell auf SharePoint

Aktualisieren von Daten aus einer externen Analysis Services-Datenbank

Voraussetzungen

Analysis Services-Cubes müssen die Version SQLServer 2005 oder höher.

Analysis Services-Datenbanken für tabellarische sind nur in SQL Server 2012 oder höher.

Sie müssen wissen, wie Sie eine Verbindung zu einer Analysis Services-Datenbank herstellen. Erkundigen Sie sich bei Ihrem Analysis Services-Datenbankadministrator nach den Server- und Datenbanknamen und den zu verwendenden Anmeldeinformationen.

Damit Sie Daten in ein Datenmodell importieren können, müssen Sie über das Power Pivot-Add-In verfügen, das zum Lieferumfang von Office Professional Plus gehört. Möglicherweise müssen Sie auch das Erstellen einer MDX-Abfrage zum Abrufen der gewünschten Daten beherrschen. Alternativen zum Erstellen einer MDX-Abfrage umfassen die Verwendung eines Abfrage-Generators, der die Auswahl der zu analysierenden Measures, Dimensionsattribute und Hierarchien erlaubt.

Zum interaktiven Verbinden mit einer PivotTable oder PivotChart mithilfe von Excel sind keine MDX-Kenntnisse erforderlich. Excel stellt eine Verbindung mit einem gesamten OLAP-Cube oder einem gesamten tabellarischen Modell her.

Die Dateigrößen können das von Ihnen gewohnte Maß übersteigen. Einfach zum Vergleich: Eine Arbeitsmappe, die eine Datenverbindung verwendet, kann deutlich unter 100 KB liegen, während die gleiche Arbeitsmappe mit importierten Daten leicht die zehnfache Größe aufweisen kann. Wenn Speicherplatz auf Datenträgern ein Problem darstellt, müssen Sie für größere Dateien Platz schaffen.

Power Pivot Arbeitsmappen, die Sie als Datenquellen verwenden, können in SharePoint 2010 oder höher veröffentlicht werden. Die SharePoint-Website muss auf einem anderen Computer als die ausgeführt werden, die Sie verwenden, um einen Bericht zu erstellen. Sie müssen Anzeigeberechtigungen für die SharePoint-Website zu Bericht zu Arbeitsmappen auf SharePoint.

Herstellen einer Verbindung mit einem Cube, einem tabellarischen Modell oder einem Power Pivot-Datenmodell

Die einfachste Möglichkeit, Daten in einem Analysis Services-Cube oder -Modell zu analysieren, besteht im Einrichten einer Verbindung mit einer externen Datenquelle. Die PivotTable oder der Bericht verfügt dann über eine ständige Verbindung mit der Datenquelle. Jedes Mal, wenn Sie ein Feld auf einen Werte-, Zeilen-, Spalten- oder Filterbereich einer Feldliste ziehen, erstellt Excel eine Abfrage und sendet sie an Analysis Services.

Eine ständige Verbindung mit den Daten, die Sie analysieren, hat Vorteile. Sie können Freiformanalysen durchführen. Fügen Sie einer PivotTable oder einem Bericht ein beliebiges Feld hinzu, und Analysis Services gibt die angeforderten Daten zurück. Eine Feldliste, die mit Analysis Services verbunden ist, enthält alle Objekte in einem Cube oder Modell, sodass Sie keine MDX-Abfragen erstellen müssen, um die gewünschten Daten abzurufen.

Zu den Nachteilen gehört die Abhängigkeit von einer Serververbindung. Wenn der Server nicht betriebsbereit ist oder Sie offline arbeiten möchten, besteht keinerlei Interaktion mit den Daten.

Seitenanfang

Importieren von Daten aus einem Cube

Alle Daten, die in einer SQL Server Analysis Services-Datenbank enthalten sind, können in ein Datenmodell in Excel kopiert werden. Sie können die gesamte oder einen Teil einer Dimension extrahieren oder Datenschnitte und Aggregate aus dem Cube abrufen, z. B. die Summe der monatlichen Verkäufe für das aktuelle Jahr.

Im folgenden Verfahren wird veranschaulicht, wie Sie das Add-In und MDX verwenden, um eine Teilmenge von Daten aus einem herkömmlichen Cube auf einer Analysis Services-Instanz abzurufen. MDX wird immer verwendet, wenn eine Abfrage mithilfe des Power Pivot-Add-Ins erstellt wird.

In diesem Verfahren wird die Beispieldatenbank Adventure Works DW Multidimensional 2012 verwendet, um das Importieren einer Teilmenge eines Cubes zu erläutern. Wenn Sie Zugriff auf einen Analysis Services-Server mit der Beispieldatenbank Adventure Works DW Multidimensional 2012 haben, können Sie diese Schritte ausführen, um zu erfahren, wie Daten aus Analysis Services importiert werden.

  1. Klicken Sie im Power Pivot-Fenster auf Externe Daten abrufen > Aus Datenbank > Aus Analysis Services oder Power Pivot.

  2. Geben Sie in Verbindung mit Microsoft SQL Server Analysis Services herstellen in Server- oder Dateiname den Namen des Computers ein, auf dem Analysis Services ausgeführt wird.

  3. Klicken Sie auf den Pfeil nach unten, der sich rechts von der Liste Datenbankname befindet, und wählen Sie eine Analysis Services-Datenbank aus der Liste aus. Wenn Sie z. B. Zugriff auf die Beispieldatenbank "Adventure Works DW Multidimensional 2012" haben, wählen Sie Adventure Works DW Multidimensional 2012 aus.

  4. Klicken Sie auf Verbindung testen, um zu überprüfen, ob der Analysis Services-Server verfügbar ist.

  5. Klicken Sie auf Weiter.

  6. Klicken Sie auf der Seite MDX-Abfrage angeben auf Entwurf, um einen MDX-Abfrage-Generator zu öffnen.

    In diesem Schritt ziehen Sie alle Measures, Dimensionsattribute, Hierarchien und berechneten Elemente, die Sie importieren möchten, in den großen Abfrageentwurfsbereich.

    Wählen Sie mindestens ein Measure und eine oder mehrere Dimensionen aus.

    Wenn Sie eine vorhandene MDX-Anweisung verwenden möchten, fügen Sie die Anweisung in das Textfeld ein, und klicken Sie auf Überprüfen, um sicherzustellen, dass die Anweisung funktioniert. Weitere Informationen zur Verwendung des Designers finden Sie unter MDX-Abfrage-Designer für Analysis Services (Power Pivot).

    Führen Sie in diesem Verfahren unter Verwendung des Adventure Works-Beispielcubes folgende Schritte aus:

    1. Erweitern Sie im Bereich Metadaten zuerst Measures und dann Sales Summary.

    2. Ziehen Sie Average Sales Amount in den großen Entwurfsbereich.

    3. Erweitern Sie im Bereich Metadaten die Dimension Product.

    4. Ziehen Sie Product Categories links neben Average Sales Amount in den großen Entwurfsbereich.

    5. Erweitern Sie im Bereich Metadaten die Dimension Date, und erweitern Sie dann Calendar.

    6. Ziehen Sie Date.Calendar Year links neben Category in den großen Entwurfsbereich.

    7. Fügen Sie optional einen Filter hinzu, um eine Teilmenge der Daten zu importieren. Ziehen Sie im Bereich rechts oben vom Designer für Dimension das Element "Date" in das Dimensionsfeld. Wählen Sie in Hierarchie das Element Date.Calendar Year aus, wählen Sie für Operator das Element Nicht gleich aus, klicken Sie für Filterausdruck auf den Pfeil nach unten, und wählen Sie CY 2009 und CY 2010 aus.

      Hiermit wird ein Filter für den Cube erstellt, damit Sie die Werte für 2009 ausschließen können.

  7. Klicken Sie auf OK, und überprüfen Sie die MDX-Abfrage, die vom Abfrage-Designer erstellt wurde.

  8. Geben Sie einen Anzeigenamen für das Dataset ein. Dieser Name wird im Datenmodell als Tabellenname verwendet. Wenn Sie keinen neuen Namen zuweisen, werden die Abfrageergebnisse standardmäßig in einer neuen Tabelle mit dem Namen "Abfrage" gespeichert.

  9. Klicken Sie auf Fertig stellen.

  10. Klicken Sie nach dem Laden der Daten auf Schließen.

Alle Daten, die Sie aus einem Cube oder einer Datenbank importieren, werden vereinfacht. In Ihrem Modell erscheinen die Daten als einzelne Tabelle, die alle Spalten enthält, die Sie in der Abfrage angegeben hatten. Wenn Sie eine Abfrage definiert haben, die Measures aus mehreren Dimensionen abruft, werden die Daten für jede Dimension in eine separate Spalte importiert.

Nachdem Sie die Daten in das Datenmodell importiert haben, kann es sinnvoll sein, den Datentyp der Spalten zu überprüfen, die numerische oder Finanzdaten enthalten. Wenn Power Pivot in einer Spalte leere Werte findet, wird der Datentyp in Text geändert. Sie können den Datentyp überprüfen und ändern, indem Sie die einzelnen Spalten auswählen und Datentyp in der Gruppe Formatierung auf dem Menüband ansehen. Sie können die Option "Datentyp" verwenden, um den Datentyp zu korrigieren, wenn Ihre numerischen oder Finanzdaten dem falschen Typ zugeordnet sind.

Um die Daten in einer PivotTable zu verwenden, wechseln Sie zurück zu Excel:

  1. Klicken Sie auf Einfügen > Tabelle > PivotTable.

  2. Klicken Sie auf Externe Datenquelle verwenden, und klicken Sie dann auf Verbindungen auswählen.

  3. Klicken Sie auf Tabellen.

  4. Wählen Sie in Datenmodell dieser Arbeitsmappe die soeben importierte Tabelle aus.

Seitenanfang

Importieren von Daten aus einem tabellarischen Modell

Das folgende Verfahren beschreibt beispielhaft den Datenimport unter Verwendung einer tabellarischen Beispieldatenbank. Sie können zum Nachvollziehen der weiteren Schritte das Beispiel "Adventure Works Tabular Model SQL 2012", das auf einem tabellarischen Analysis Services-Server ausgeführt wird, verwenden.

  1. Überprüfen Sie, ob die tabellarische Datenbank mindestens ein Measure enthält. Der Importvorgang funktioniert nicht, wenn in der Datenbank keine Measures vorhanden sind. Die Beispiellösung enthält Measures.

  2. Klicken Sie im Power Pivot-Fenster auf Externe Daten abrufen > Aus Datenbank > Aus Analysis Services oder Power Pivot.

  3. Geben Sie in Verbindung mit Microsoft SQL Server Analysis Services herstellen in Server- oder Dateiname den Namen des Computers ein, auf dem Analysis Services ausgeführt wird.

  4. Klicken Sie auf den nach unten zeigenden Pfeil rechts neben der Liste Datenbankname, und wählen Sie in der Liste eine Analysis Services-Datenbank aus. Wenn Sie z. B. Zugriff auf die Beispieldatenbank "AW Internet Sales Tabular Model" haben, wählen Sie Adventure Works Tabular Model SQL 2012 aus.

  5. Klicken Sie auf Verbindung testen, um zu überprüfen, ob der Analysis Services-Server verfügbar ist.

  6. Klicken Sie auf Weiter.

  7. Klicken Sie auf der Seite MDX-Abfrage angeben auf Entwurf, um einen MDX-Abfrage-Generator zu öffnen.

    In diesem Schritt ziehen Sie alle Measures, Spalten und Hierarchien, die Sie importieren möchten, in den großen Abfrageentwurfsbereich.

    Wenn Sie eine vorhandene MDX-Anweisung verwenden möchten, fügen Sie die Anweisung in das Textfeld ein, und klicken Sie auf Überprüfen, um sicherzustellen, dass die Anweisung funktioniert. Weitere Informationen zum Designer finden Sie unter Analysis Services MDX-Abfrage-Designer (Power Pivot).

    Führen Sie in diesem Verfahren unter Verwendung des Beispielmodells die folgenden Schritte aus:

    1. Erweitern Sie im Bereich Metadaten erst Measures und dann Internet Sales.

    2. Ziehen Sie Internet Total Sales auf den großen Entwurfsbereich.

    3. Erweitern Sie die Tabelle Product.

    4. Scrollen Sie bis zum Ende der Liste, und ziehen Sie Category links neben Internet Total Sales in den großen Entwurfsbereich. Dies ist eine Hierarchie, daher werden alle Felder in der Hierarchie zurückgegeben.

    5. Erweitern Sie die Tabelle Date.

    6. Ziehen Sie Calendar Year links neben Category in den großen Entwurfsbereich.

    7. Erweitern Sie "Sales Territory".

    8. Ziehen Sie "Sales Territory Region" in den Filterbereich oben im Designer. Wählen Sie unter "Filterausdruck" den Eintrag "Australia" aus.

      MDX-Abfrage zur tabellarischen Beispieldatenbank

  8. Klicken Sie auf OK, und überprüfen Sie die MDX-Abfrage, die vom Abfrage-Designer erstellt wurde.

  9. Geben Sie einen Anzeigenamen für das Dataset ein. Dieser Name wird im Datenmodell als Tabellenname verwendet. Wenn Sie keinen neuen Namen zuweisen, werden die Abfrageergebnisse standardmäßig in einer neuen Tabelle mit dem Namen "Abfrage" gespeichert.

  10. Klicken Sie auf Fertig stellen.

  11. Klicken Sie nach dem Laden der Daten auf Schließen.

Nachdem Sie die Daten in das Datenmodell importiert haben, kann es sinnvoll sein, den Datentyp der Spalten zu überprüfen, die numerische oder Finanzdaten enthalten. Wenn Power Pivot in einer Spalte leere Werte findet, wird der Datentyp in Text geändert. Sie können den Datentyp überprüfen und ändern, indem Sie die einzelnen Spalten auswählen und Datentyp in der Gruppe Formatierung auf dem Menüband ansehen. Sie können die Option "Datentyp" verwenden, um den Datentyp zu korrigieren, wenn Ihre numerischen oder Finanzdaten dem falschen Typ zugeordnet sind.

Um die Daten in einer PivotTable zu verwenden, wechseln Sie zurück zu Excel:

  1. Klicken Sie auf Einfügen > Tabelle > PivotTable.

  2. Klicken Sie auf Externe Datenquelle verwenden, und klicken Sie dann auf Verbindungen auswählen.

  3. Klicken Sie auf Tabellen.

  4. Wählen Sie in Datenmodell dieser Arbeitsmappe die soeben importierte Tabelle aus.

Seitenanfang

Importieren von Daten aus einem Arbeitsmappen-Datenmodell auf SharePoint

SharePoint möglicherweise zusätzlichen Software, um die Daten zu laden. Wenn Sie SharePoint 2010 verwenden, müssen Sie Power Pivot für SharePoint 2010. SharePoint 2013 oder höher wird hingegen integrierte Funktion für das Laden und Abfragen ein Datenmodell enthält. Wenn Sie SharePoint verwenden, bitten Sie Ihren SharePoint-Administrator, ob Excel Services aktiviert und für BI Auslastung konfiguriert.

  1. Klicken Sie im Power Pivot-Fenster auf Externe Daten abrufen > Aus Datenbank > Aus Analysis Services oder Power Pivot.

  2. Geben Sie auf der Seite Stellen Sie eine Verbindung mit Microsoft SQL Server Analysis Services her für Anzeigename der Verbindung einen aussagekräftigen Namen für die Datenverbindung ein. Durch die Verwendung von aussagekräftigen Namen für die Verbindung können Sie sich leichter merken, auf welche Weise die Verbindung verwendet wird.

  3. Geben Sie in Server- oder Dateiname die URL-Adresse der veröffentlichten XLSX-Datei ein. Beispiel: http://Contoso-srv/Shared Documents/ContosoSales.xlsx.

    Hinweis : Sie können keine lokale Excel-Arbeitsmappe als Datenquelle verwenden. Die Arbeitsmappe muss auf einer SharePoint-Website veröffentlicht werden.

  4. Klicken Sie auf Verbindung testen, um zu überprüfen, ob die Arbeitsmappe in SharePoint verfügbar ist.

  5. Klicken Sie auf Weiter.

  6. Klicken Sie auf Entwerfen.

  7. Erstellen Sie die Abfrage, indem Sie Measures, Dimensionsattribute oder Hierarchien in den großen Entwurfsbereich ziehen. Verwenden Sie optional den Filterbereich in der oberen rechten Ecke, um eine Teilmenge der Daten für den Import auszuwählen.

  8. Klicken Sie auf OK.

  9. Klicken Sie auf Überprüfen.

  10. Klicken Sie auf Fertig stellen.

Power Pivot-Daten werden in das Datenmodell kopiert und in einem komprimierten Format gespeichert. Nachdem die Daten importiert wurden, wird die Verbindung mit der Arbeitsmappe geschlossen. Um die ursprünglichen Daten erneut abzufragen, können Sie die Arbeitsmappe in Excel aktualisieren.

Seitenanfang

Aktualisieren von Daten aus einer externen Analysis Services-Datenbank

Klicken Sie in Excel auf Daten > Verbindungen > Alle aktualisieren, um die Verbindung zu einer Analysis Services-Datenbank wiederherzustellen und die Daten in Ihrer Arbeitsmappe zu aktualisieren.

Durch die Aktualisierung werden einzelne Zellen aktualisiert und Zeilen hinzugefügt, die seit dem letzten Importvorgang in die externe Datenbank eingefügt wurden. Es werden nur Zeilen und vorhandene Spalten aktualisiert. Wenn Sie dem Modell eine neue Spalte hinzufügen möchten, müssen Sie diese mit den Schritten importieren, die in diesem Artikel weiter oben beschrieben sind.

Durch die Aktualisierung wird erneut die Abfrage ausgeführt, mit der die Daten importiert wurden. Befindet sich die Datenquelle nicht mehr am selben Speicherort, oder wurden Tabellen oder Spalten entfernt oder umbenannt, schlägt die Aktualisierung fehl, aber es sind weiterhin die Daten vorhanden, die Sie zuvor importiert haben. Soll die Abfrage angezeigt werden, die bei der Datenaktualisierung verwendet wird, klicken Sie auf Power Pivot > Verwalten, um das Power Pivot-Fenster zu öffnen. Klicken Sie auf Entwurf > Tabelleneigenschaften, damit die Abfrage angezeigt wird.

Analysis Services verwendet für das Lesen von Daten aus seinen Datenbanken Ihr Windows-Benutzerkonto. Damit Sie Daten importieren können, muss ein Datenbankadministrator Ihrem Windows-Benutzerkonto Leseberechtigungen für die Datenbank erteilt haben. Diese Berechtigungen werden auch zum Aktualisieren von verwendet. Wenn andere Personen die Daten aktualisieren möchten, benötigen sie ebenfalls Leseberechtigungen für die Datenbank.

Denken Sie daran, dass wie Sie Ihre Arbeitsmappe freigeben bestimmt, ob die Daten aktualisieren auftreten kann. In Office 365 können Sie Daten in einer Arbeitsmappe aktualisieren, die in Office 365 gespeichert ist. Klicken Sie auf SharePoint Server 2013 oder höher, können Sie auf dem Server unbeaufsichtigten datenaktualisierung planen, auf diese Weise erfordert jedoch die Power Pivot für SharePoint installiert und ist in Ihrer SharePoint-Umgebung konfiguriert. Wenden Sie sich an Ihren SharePoint-Administrator, um herauszufinden, ob die geplante Aktualisierung verfügbar ist.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×