Ändern von Hyperlinks und Korrigieren von fehlerhaften Hyperlinks

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Sie können das Erscheinungsbild sowie das Ziel eines Hyperlinks ändern. Wenn ein Hyperlink nicht funktioniert, müssen Sie das Problem ermitteln und anschließend die Zieladresse des Hyperlinks ändern.

Hinweis : Zum Ändern des Texts oder der Reihenfolge von Hyperlinks auf einer Navigationsleiste klicken Sie auf die entsprechende Navigationsleiste und anschließend im Menü Format auf Eigenschaften der Navigationsleise.

Was möchten Sie tun?

Ändern des Erscheinungsbilds eines Hyperlinks

Ändern des Ziels eines Hyperlinks

Ändern eines Hyperlinks in normalen Text

Testen von Hyperlinks vor dem Veröffentlichen der Website

Korrigieren von fehlerhaften Hyperlinks

Ändern des Erscheinungsbilds eines Hyperlinks

Ändern des Anzeigetexts eines Hyperlinks

  1. Klicken Sie auf den zu ändernden Hyperlinktext.

  2. Geben Sie den neuen Text ein und löschen anschließend die ursprünglichen Zeichen einzeln, indem Sie ENTF oder die RÜCKTASTE drücken.

Entfernen der Unterstreichung von Hyperlinktext

  1. Markieren Sie den Hyperlinktext.

    Um nur die unterstrichenen Zeichen zu markieren, klicken Sie hinter das letzte unterstrichene Zeichen und ziehen den Cursor bis zum ersten unterstrichenen Zeichen.

  2. Klicken Sie auf der Symbolleiste Standard auf Unterstrichen. Schaltfläche .

Ändern des für einen Hyperlink verwendeten Bilds

  1. Markieren Sie das verknüpfte Bild.

  2. Klicken Sie mit der rechten Maustaste auf das Bild, zeigen Sie auf Grafik ändern, und klicken Sie dann auf den Speicherort des neuen Bilds, das verwendet werden soll. Klicken Sie beispielsweise auf Aus Datei, wenn Sie ein auf dem Computer gespeichertes Bild verwenden möchten.

  3. Wählen Sie das neue Bild aus.

Seitenanfang

Ändern des Ziels eines Hyperlinks

  1. Klicken Sie mit der rechten Maustaste auf den zu ändernden Hyperlink, und klicken Sie dann auf Hyperlink bearbeiten.

    Hinweis : Wenn im Kontextmenü nur Befehle für die Rechtschreibprüfung enthalten sind, klicken Sie auf Alle ignorieren, und klicken Sie dann mit der rechten Maustaste erneut auf den Hyperlink.

  2. Geben Sie im Dialogfeld Hyperlink bearbeiten im Feld Adresse das neue Ziel des Hyperlinks ein.

Seitenanfang

Ändern eines Hyperlinks in normalen Text

  • Klicken Sie mit der rechten Maustaste auf den Hyperlink, und klicken Sie dann auf Hyperlink entfernen.

Seitenanfang

Testen von Hyperlinks vor dem Veröffentlichen der Website

Sie können einen Hyperlink testen, um vor dem Veröffentlichen der Website sicherzustellen, dass der Hyperlink funktioniert. Führen Sie eine der folgenden Aktionen aus:

  • Um einen Hyperlink vor seiner Publikation im Internet von der Website aufzurufen, halten Sie STRG gedrückt und klicken auf den verknüpften Text oder das verknüpfte Bild.

  • Klicken Sie im Menü Datei auf Webseitenvorschau und dann in der Vorschau der Website auf einen beliebigen Hyperlink, um dessen Ziel aufzurufen.

    Hinweis : Hyperlinks auf externe Dateien können in der Vorschau der Website nicht getestet werden.

  • Veröffentlichen Sie die Website auf einem lokalen Server, um die Hyperlinks zu testen.

    1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

    2. Wenn Sie ein Informationsfeld zu einem Hostingdienst Web angezeigt wird, klicken Sie auf OK.

    3. Suchen Sie im Dialogfeld Im Web veröffentlichen den lokalen Server, auf dem Sie die Website testen möchten, und klicken Sie anschließend auf Speichern.

Seitenanfang

Korrigieren fehlerhafter Hyperlinks

Im Folgenden erhalten Sie allgemeine Korrekturvorschläge für fehlerhafte Links.

Korrigieren von Hyperlinks, die auf andere Seiten auf der Publisher-Website zeigen

  • Ein Link ist fehlerhaft    Wenn eine Seite verschoben wurde, verweist Microsoft Office Publisher die Hyperlinks automatisch auf die korrekte Seite. Funktioniert ein Hyperlink dennoch nicht, stellen Sie sicher, dass er nicht auf eine verschobene oder gelöschte Textmarke verweist. Gehen Sie zum Korrigieren des Links wie folgt vor:

    1. Klicken Sie mit der rechten Maustaste auf den Hyperlink, und klicken Sie dann auf Hyperlink bearbeiten.

    2. Klicken Sie im Dialogfeld Hyperlink bearbeiten auf Aktuelles Dokument und anschließend auf die Seite und die Textmarke, auf die der Link verweisen soll.

      Wurde die Textmarke gelöscht, klicken Sie auf Abbrechen. Wechseln Sie auf die Seite, auf die verwiesen werden soll, fügen Sie eine Textmarke ein, und wechseln Sie dann erneut zu dem zu korrigierenden Hyperlink und bearbeiten diesen Hyperlink.

  • Mehrere Links sind fehlerhaft    Bei mehreren fehlerhaften Hyperlinks sind bestimmte Dateien unter Umständen nicht veröffentlicht worden. Standardmäßig lädt Publisher beim Veröffentlichen einer Website den Unterordner "index_files" an den festgelegten Dateispeicherort hoch. Dieser Ordner enthält alle der Website zugeordneten Dateien mit Ausnahme der ersten Seite der Publikation (die Homepage der Website), die auf den Ordner mit zugeordneten Seiten zeigt. Steht der Ordner nicht zur Verfügung, funktionieren Hyperlinks zu anderen Seiten in der Publikation nicht. Wenn Sie zum Hochladen der Website ein Drittanbieterprogramm verwenden, wird der Unterordner unter Umständen nicht automatisch auf den Webserver hochgeladen. Laden Sie den Unterordner in diesem Fall manuell hoch.

    Hinweis : Sie können die Einstellungen ändern, damit Publisher bei der nächsten Publikation der Website den Ordner "index_files" nicht erstellt und alle Dateien für die Website in einem Ordner veröffentlicht. Klicken Sie in der Webpublikation im Menü Extras auf Optionen, dann auf die Registerkarte Web und deaktivieren das Kontrollkästchen Hilfsdateien in einem Ordner verwalten.

Korrigieren von Hyperlinks, die auf andere Websites verweisen

Funktioniert ein Hyperlink auf eine andere Website nicht, navigieren Sie zu dem Ziel, auf das verwiesen werden soll. Befindet sich die Zieldatei im Internet, suchen Sie danach im Webbrowser. Ist die Datei auf der Festplatte oder in einem Netzwerk gespeichert, verwenden Sie für die Suche Microsoft Windows Explorer. Überprüfen Sie anschließend in der Publisher-Webpublikation Folgendes:

  • Das Ziel wurde unter Umständen verschoben oder ist nicht mehr vorhanden    Klicken Sie mit der rechten Maustaste auf den Hyperlink, und klicken Sie auf Hyperlink bearbeiten. Stellen Sie im Dialogfeld Hyperlink bearbeiten sicher, dass der Pfad zur Zielseite korrekt ist.

  • Der Text, den Sie für einen Hyperlink halten, hat nur das Erscheinungsbild eines Hyperlinks    Markieren Sie den Text, und klicken Sie auf der Symbolleiste Standard Schaltflächensymbol auf Hyperlink einfügen, um sicherzustellen, dass es sich bei dem Text um einen Hyperlink handelt.

    Tipp : Es darf nur ein Hyperlink markiert sein, wenn Sie auf Hyperlink einfügen klicken. Bei Auswahl mehrerer Hyperlinks oder eines Hyperlinks auf einer Navigationsleiste steht die Option Hyperlink einfügen gegebenenfalls nicht zur Verfügung.

  • Sie haben keinen Zugriff auf das Ziel    Befindet sich das Ziel im Internet, gewährleisten Sie, dass eine Internetverbindung besteht. Ist das Ziel in einem Netzwerk gespeichert, wenden Sie sich an den Netzwerkadministrator, um sicherzustellen, dass Sie über Zugriff auf die Zieldatei verfügen.

Korrigieren von Hyperlinks, mit denen externe Dateien geöffnet werden

Wenn Sie einen Hyperlink auf einer Webseite erstellen, der eine externe Datei öffnet, wie beispielsweise ein Microsoft Office Word-Dokument, ein Microsoft Office Excel-Arbeitsblatt oder eine PDF-Datei, beachten Sie Folgendes:

Dateinamen

Idealerweise sollten Dateinamen für externe Dateien, auf die verwiesen wird, ausschließlich Kleinbuchstaben ohne Leerzeichen enthalten.

Wenn Sie eine Verknüpfung auf eine Datei mit einem Leerzeichen im Dateinamen erstellen und der Name nicht geändert werden kann, überprüfen Sie, ob Publisher das Leerzeichen in der Hyperlinkadresse durch %20 ersetzt hat. Lautet der Dateiname beispielsweise "Meine Datei.docx", sollte die Hyperlinkadresse folgendermaßen aussehen: Meine%20Datei.docx.

Tests

Ein Link auf eine externe Datei kann in der Webvorschau nicht getestet werden. Sie können einen Hyperlink jedoch in der Publikation testen, indem Sie STRG gedrückt halten, während Sie auf den verknüpften Text bzw. das verknüpfte Bild klicken. Die Website kann auch auf einem lokalen Server veröffentlicht werden, um die Hyperlinks auf externe Dateien zu testen.

Wichtig : Stellen Sie beim Testen von Links auf externe Dateien auf einem lokalen Server sicher, dass Sie die externen Dateien auf diesen lokalen Server kopieren.

Upload

Beim Veröffentlichen der Website müssen Sie die externe Datei manuell hochladen. Der Speicherort der Datei auf dem Webserver wird durch den Pfad festgelegt. Beispiel:

  • Wenn Sie eine Verknüpfung von der Homepage auf eine Datei erstellen, die sich im selben Verzeichnis auf dem Webserver befindet, kann der Pfad mit dem Dateinamen übereinstimmen (beispielsweise MeineDatei.docx).

  • Befindet sich die Datei in einem anderen Ordner als die Homepage, muss der Pfad den Ordnernamen enthalten (beispielsweise index_dateien/MeineDatei.docx).

Sie müssen diesen Pfad festlegen und im Dialogfeld Hyperlink einfügen eingeben, bevor Sie im Internet veröffentlichen. Markieren Sie den Text oder das Bild, auf das Besucher der Seite klicken sollen, um die externe Datei zu öffnen. Klicken Sie im Menü Einfügen auf Hyperlink. Geben Sie im Dialogfeld Hyperlink einfügen im Feld Adresse den Pfad für die externe Datei ein.

Hinweis : Wenn Sie den Pfad eines Hyperlinks im Feld Adresse mit Hilfe der Durchsuchen-Schaltfläche eingeben, ändern Sie den Pfad, indem Sie wie oben angegeben nur den Dateinamen oder den Ordner und den Dateinamen eingeben.

Korrigieren des Pfads eines Hyperlinks auf eine auf einem Datenträger gespeicherte Datei

Sie möchten die Dateien für Ihre Website unter Umständen auf einem Datenträger speichern, beispielsweise einer CD oder DVD, damit die Website vor der Publikation im Internet auf einem anderen Computer angezeigt werden kann. Wenn Sie die Dateien der Webpublikation auf einem Datenträger speichern, funktionieren die Hyperlinks nicht. Veröffentlichen Sie die Website stattdessen direkt auf dem Datenträger. Gehen Sie hierzu wie folgt vor:

In Windows Vista

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie in der Adressleiste auf das Laufwerk des Datenträgers auf dem die Website veröffentlicht werden soll, wie z. B. D:\mywebsite.

    Wenn Sie Ihre Website in einem neuen Ordner hinzufügen möchten, klicken Sie auf Neuer Ordner, klicken Sie auf der Symbolleiste, um einen neuen Ordner erstellen, geben Sie einen Namen für den neuen Ordner ein, und drücken dann die EINGABETASTE.

  3. Wählen Sie Index als den Standardnamen für die Homepage in das Feld Dateiname ein und klicken Sie dann auf Speichern.

    Index.htm ist die Standardauswahl. Index auswählen, wie der Name der Startseite Access vereinfacht und verhindert, dass Benutzer das Anzeigen einer Liste der Dateien, die Ihre Website zusammensetzt.

In Windows XP

  1. Klicken Sie im Menü Datei auf Im Web veröffentlichen.

  2. Klicken Sie in der Liste Speichern in auf das Laufwerk des Datenträgers, auf dem die Website veröffentlicht werden soll, wie z. B. D:\mywebsite.

    Wenn Sie Ihre Website in einem neuen Ordner hinzufügen möchten, mit der rechten Maustaste, in dem Sie einen neuen Ordner hinzufügen, wählen neu, und klicken Sie auf Ordner, um einen neuen Ordner erstellen, geben Sie im Feld Name einen Namen für den neuen Ordner, und klicken Sie dann auf Öffnen.

  3. Wählen Sie Index als den Standardnamen für die Homepage in das Feld Dateiname ein und klicken Sie dann auf Speichern.

    Index.htm ist die Standardauswahl. Index auswählen, wie der Name der Startseite Zugriff vereinfacht und verhindert, dass Benutzer das Anzeigen einer Liste der Dateien, aus denen Ihre Website besteht.

Korrigieren eines Hyperlinks, der nicht angezeigt wird

Hierfür gibt es folgende Ursachen:

  • Der Hyperlink befindet sich in einem gedrehten Textfeld oder einer AutoForm    Hyperlinks werden nicht ordnungsgemäß ausgeführt, wenn sie sich in gedrehten Textfeldern oder AutoFormen befinden. Sie funktionieren in der Webpublikation, wenn Sie STRG drücken und auf den Hyperlink klicken. Ihr Erscheinungsbild ist korrekt, aber sie funktionieren weder in der Webvorschau noch beim Veröffentlichen im Internet. Sie können die Hyperlinks in der Webpublikation wiederherstellen, indem Sie den gedrehten Textfeldern und AutoFormen, die Hyperlinks enthalten, erneut ihre ursprüngliche Position zuweisen.

  • Der Hyperlink befindet sich in einem Textfeld oder einer AutoForm mit BorderArt    Hyperlinks in einer Webpublikation werden nicht ordnungsgemäß ausgeführt, wenn sie sich in einem Textfeld oder einer AutoForm mit BorderArt befinden. Sie können die Hyperlinks in Ihrer Webpublikation wiederherstellen, indem Sie die gesamte BorderArt aus den Textfeldern oder Autoformen entfernen, die Hyperlinks enthalten.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Teilen Facebook Facebook Twitter Twitter E-Mail E-Mail

War diese Information hilfreich?

Sehr gut. Noch anderes Feedback?

Was können wir verbessern?

Vielen Dank für Ihr Feedback!

×