Ändern des Webdiensts in der Formularvorlage Hauptfenster Datenverbindung verwendet werden

Hinweis:  Wir möchten Ihnen die aktuellsten Hilfeinhalte so schnell wie möglich in Ihrer eigenen Sprache bereitstellen. Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Teilen Sie uns bitte über den Link am unteren Rand dieser Seite mit, ob die Informationen für Sie hilfreich sind. Hier finden Sie den englischen Artikel als Referenz.

Inhalt dieses Artikels

(Übersicht)

Vorbemerkung

Ändern Sie die Verbindung zum Abfragen von Daten

Ändern Sie die Verbindung zum Absenden von Daten

Übersicht

Wenn Sie zuerst eine Formularvorlage mit einer Verbindung Hauptfenster Daten zu einem Webdienst entwerfen, verwenden Sie möglicherweise eine testumgebung Stelle, an der der Webdienst entwickelt wird. Wenn Sie der Webdienst bereitgestellt werden kann, müssen Sie die Datenverbindung Hauptfenster in der Formularvorlage aus der testumgebung an die Position des bereitgestellten Webdiensts ändern.

Wenn Sie den Webdienst in den Hauptfenster Verbindung ändern, erstellt Microsoft Office InfoPath eine primäre Datenquelle mit Feldern und Gruppen, die die XML-Schema in den neuen Webdienst entsprechen. Wenn die Schemas im alten und neuen Webdienste identisch sind, wird InfoPath automatisch die vorhandenen Steuerelemente in der Formularvorlage für die Felder in der neuen Datenquelle gebunden. Wenn Sie die Felder und Gruppen in der neuen Datenquelle nicht die Felder und Gruppen in der alten Datenquelle übereinstimmen, entfernt InfoPath die Datenquelle Bindung von den Steuerelementen an. Wenn InfoPath die Bindung von den Steuerelementen entfernt, müssen Sie die Steuerelemente aus der Formularvorlage entfernen oder auf andere Felder in der neuen Datenquelle zu binden.

Je nach dem Entwurf Ihrer Formularvorlage möglicherweise die Verbindung zum Hauptfenster Daten eine Verbindung zum Abfragen von Daten, eine Verbindung zum Absenden von Daten oder beides. Wenn die Hauptfenster Datenverbindung sowohl eine Verbindung zum Abfragen von Daten und eine Verbindung zum Übermitteln von Daten hat, und der Webdienst Speicherorte geändert wurde, müssen Sie beide Verbindungen zu ändern.

Hinweis: Suchen nach Links zu Informationen über das Ändern der externen Datenquelle mit anderen externen Datenquellen im Abschnitt Siehe auch.

Nachdem Sie die Verbindung zum Hauptfenster Daten ändern, sollten Sie veröffentlichen und testen die Formularvorlage, um sicherzustellen, dass die Verbindung mit dem Webdienst funktioniert wie erwartet, wenn Benutzer Formulare ausfüllen, die auf Ihrer Formularvorlage basieren. Sie sollten auch testen, um sicherzustellen, dass vorhandene Formulare, die auf Ihrer Formularvorlage basieren weiterhin wie erwartet funktionieren. Wenn Sie die Tests abgeschlossen haben, können Sie Benutzern die starten Ausfüllen von Formularen, die auf dieser Formularvorlage basieren. Suchen nach Links zu weiteren Informationen über das Veröffentlichen einer Formularvorlage im Abschnitt Siehe auch.

Seitenanfang

Vorbemerkung

Bevor Sie die Verbindung zum Hauptfenster Daten ändern möchten, benötigen Sie die folgende Informationen aus dem Webdienstadministrator:

  • Die Position des den neuen Webdienst.

  • Überprüfung, dass der neue Webdienst Dokument/Literal-Codierung verwendet. InfoPath kann nur Dokument/Literal-Webdiensten nutzen.

  • Die Namen der Vorgänge im Webdienst, den Sie verwenden möchten.

  • Überprüfung, dass die Schemas im alten und neuen Webdienste identisch sind.

Seitenanfang

Ändern Sie die Verbindung zum Abfragen von Daten

  1. Klicken Sie im Menü Extras auf Primäre Datenquelle umwandeln.

  2. Klicken Sie in den Datenverbindungs-Assistenten auf eine neue Verbindung zu erstellen, klicken Sie auf Daten empfangen, und klicken Sie dann auf Weiter.

  3. Klicken Sie unter Wählen Sie den Typ der Datenverbindung, die Sie für Ihre Formularvorlage verwenden möchten klicken Sie auf Webdienst, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der nächsten Seite des Assistenten geben Sie den Speicherort des Webdiensts ein, und klicken Sie dann auf Weiter.

    Hinweis: Wenn Sie einem Webdienst mithilfe eines Servers Universal Description Discovery and Integration (UDDI) suchen möchten, klicken Sie auf UDDI durchsuchen, geben Sie die URL des UDDI-Servers ein, die Sie suchen möchten, geben an, ob Sie nach Anbieter oder nach einem Dienst, der suchen möchten zur Verfügung gestellt wird, geben Sie ein Suchschlüsselwort, und klicken Sie dann auf Suchen. Webdienste, die das Stichwort entsprechen, werden in der Liste Suchergebnis angezeigt. Wählen Sie den Webdienst, den Sie verwenden möchten, und klicken Sie dann auf OK.

  5. Klicken Sie in der Liste Wählen Sie einen Vorgang aus auf den Vorgang im Webdienst, der Daten in das Formular zurückgibt, und klicken Sie dann auf Weiter.

  6. Wenn Datenverbindungs-Assistenten ein unbekanntes Element im Schema des Webdiensts vorgefunden wird, kann die nächste Seite des Assistenten in Beispielwerte für jeden Parameter bestimmen, welche Felder oder Gruppen zum Hinzufügen zur der primären Datenquelle angeben aufgefordert werden.

    So wird's gemacht

    1. Wählen Sie einen Parameter in der Tabelle Parameter aus, und klicken Sie dann auf Stichprobe Wert festlegen.

    2. Geben Sie im Sample-Wert einen Wert Ihrer Benutzer für dieses Feld verwenden, und klicken Sie dann auf OK.

    3. Wiederholen Sie diese Schritte für jeden Parameter in der Tabelle Parameter aus, und klicken Sie dann auf Weiter.

    Technische details

    Wenn Sie eine Datenverbindung zu einem Webdienst im Datenverbindungs-Assistenten konfigurieren, wird von Microsoft Office InfoPath eine Verbindung mit der Web-Dienst und fordert die Datei Web Service Description Language (WSDL). WSDL-Datei enthält das Schema vom Webdienst verwendet. Webdienst reagiert auf die Anfrage und senden diese Datei in InfoPath. InfoPath verwendet die Informationen in dieser Datei, um die entsprechenden Felder und Gruppen in der Formularvorlage der sekundäre Datenquelle hinzufügen. Findet InfoPath einen unbekannten Elementtyp in der WSDL-Datei, InfoPath Beispieldaten verwendet, um die Definition des Typs unbekanntes Element zu bestimmen, und addiert dann an die sekundäre Datenquelle die entsprechenden Felder und Gruppen.

  7. Wenn der Webdienst Benutzerinformationen geändert akzeptiert, fragt die nächste Seite des Assistenten, ob Änderungsinformationen in den Abfragedaten enthalten sein sollen. Lassen Sie in den meisten Fällen das Kontrollkästchen beim einschließen Daten übermitteln aktiviert, und klicken Sie dann auf Weiter. Wenn Sie nicht Änderungsinformationen einschließen möchten, deaktivieren Sie das Kontrollkästchen einschließen, die beim Senden von Daten zu ändern, und klicken Sie dann auf Weiter.

    Technische details

    Diese Seite des Assistenten wird nur dann, wenn die Datei Web Services Description Language (WSDL) für den Webdienst gibt an, dass der Webdienst ein Microsoft ADO.NET DataSet zurückgibt.

  8. Klicken Sie auf der nächsten Seite des Assistenten geben Sie einen Namen für die Datenverbindung ein, und klicken Sie dann auf Fertig stellen.

  9. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

  10. Klicken Sie zum Veröffentlichen der Formularvorlage im Menü Datei auf Veröffentlichen.

  11. Testen der Formularvorlage sorgfältig durch Öffnen eines Formulars, das auf dieser Formularvorlage basieren und dieses ausfüllen. Stellen Sie sicher, dass das Formular wie erwartet funktioniert.

Seitenanfang

Ändern Sie die Verbindung zum Absenden von Daten

  1. Klicken Sie im Menü Extras auf Datenverbindungen.

  2. Klicken Sie auf die Verbindung zum Absenden von Daten in den Hauptfenster Verbindung in der Liste, datenverbindungen für die Formularvorlage, und klicken Sie dann auf Ändern.

  3. Geben Sie im Datenverbindungs-Assistenten den Speicherort für den neuen Webdienst, wo Ihre Benutzer ihre Formulare absenden, und klicken Sie dann auf Weiter.

    Hinweis: Wenn Sie einem Webdienst mithilfe eines Servers Universal Description Discovery and Integration (UDDI) suchen möchten, klicken Sie auf UDDI durchsuchen, geben Sie die URL des UDDI-Servers ein, die Sie suchen möchten, geben an, ob Sie nach Anbieter oder nach einem Dienst, der suchen möchten zur Verfügung gestellt wird, geben Sie ein Suchschlüsselwort, und klicken Sie dann auf Suchen. Webdienste, die das Stichwort entsprechen, werden in der Liste Suchergebnis angezeigt. Wählen Sie den Webdienst, den Sie verwenden möchten, und klicken Sie dann auf OK.

  4. Klicken Sie auf der nächsten Seite des Assistenten in der Liste Wählen Sie einen Vorgang aus klicken Sie auf den Vorgang im Webdienst, der die abgesendeten Daten empfängt, und klicken Sie dann auf Weiter.

  5. Führen Sie auf der nächsten Seite des Assistenten um auswählen, welche Daten im Formular für jeden Parameter im Webdienst abgesendet, eine der folgenden Aktionen aus:

    Übermitteln Sie die Daten in einem Feld oder Gruppe

    1. Klicken Sie in der Liste Parameter auf, der die Daten aus dem Formular empfängt Parameter für den Webdienst.

    2. Klicken Sie unter Optionen für Parameter auf Feld oder Gruppe.

    3. Klicken Sie auf Ändern Schaltfläche (Symbol) .

    4. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen klicken Sie auf das Feld oder die Gruppe, deren Daten, die Sie senden möchten, und klicken Sie dann auf OK.

    5. Klicken Sie im Feld einschließen auf nur Text und untergeordnete Elemente aus, um nur die Daten in diesem Feld und die untergeordneten Elemente des Felds oder der Gruppe übermitteln, oder klicken Sie auf untergeordneter XML-Baum, einschließlich ausgewähltem Element, um den Feldnamen, die Daten im Feld übermitteln und die untergeordneten Elemente in der ausgewählten Gruppe oder ein Feld.

    Senden Sie alle Daten im Formular

    1. Klicken Sie in der Liste Parameter auf, der die Daten aus dem Formular empfängt Parameter für den Webdienst.

    2. Klicken Sie auf Gesamtes Formular (XML-Dokument, einschließlich verarbeitungsanweisung), klicken Sie unter Optionen für Parameter.

    Senden Sie die Daten als Zeichenfolge

    1. Klicken Sie in der Liste Parameter auf, der die Daten aus dem Formular empfängt Parameter für den Webdienst.

    2. Klicken Sie auf Gesamtes Formular (XML-Dokument, einschließlich verarbeitungsanweisung), klicken Sie unter Optionen für Parameter.

    3. Aktivieren Sie das Kontrollkästchen Daten als Zeichenfolge senden.

      Hinweis: Wählen Sie in der Regel das Kontrollkästchen Digital signierte Daten übermitteln aus. In den meisten Fällen können deaktivieren Sie dieses Kontrollkästchen.

    Technische Details zu ADO.NET DataSet-Objekte

    Wenn der Webdienst ein ADO.NET DataSet-Objekt erforderlich sind, wählen Sie einen Dataset-Knoten, wenn Sie diese Datenverbindung konfigurieren. Wenn Sie eine andere Art von Knoten für eine Datenverbindung mit einem Webdienst, die ein ADO.NET DataSet erfordert verwenden, tritt die Aktion abzusenden.

  6. Klicken Sie auf Weiter.

  7. Klicken Sie auf der nächsten Seite des Assistenten geben Sie einen Namen für die Verbindung zum Absenden von Daten, und klicken Sie dann auf Fertig stellen.

Seitenanfang

Ihre Office-Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×